Welcome to Scribd, the world's digital library. Read, publish, and share books and documents. See more
Download
Standard view
Full view
of .
Save to My Library
Look up keyword
Like this
1Activity
0 of .
Results for:
No results containing your search query
P. 1
MikroTik Ruter

MikroTik Ruter

Ratings: (0)|Views: 144 |Likes:
Published by Imi Michał Smulski

More info:

Published by: Imi Michał Smulski on Oct 28, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

12/04/2012

pdf

text

original

 
arowane rucu
W sieciach komputerowych bardzo wa
Ŝ
nym elementem zapewniaj
ą 
cym komfort pracy jestbandwidth-manager. Urz
ą 
dzenie to ogranicza ruch jednego typu, najcz
ę 
sciej by zrobi
ć
 miejsce dla ruchu innego typu. Je
Ŝ
eli nie zastosujemy kontroli pasma w najlepszymprzypadku dojdzie do sytuacji, kiedy to jeden rodzaj ruchu b
ę 
dzie musiał na siłe wymusi
ć
 swój przydział pasma z głównego ł
ą 
cza.W systemie MikroTik jest mo
Ŝ
liwo
ść
łatwego ograniczania przepustowo
ś
ci z u
Ŝ
yciemkolejek prostych (simple queues).Niekiedy jednak istnieje konieczno
ść
zrobienia bardziej zaawansowanegopodziału przepustowo
ś
ci - kształotwania ruchu z wyko
Ŝ
ystaniem drzewa kolejek (queue tree).Potrzeba ta, wystepuje przedewszystkim wtedy, kiedy chcemy mie
ć
wi
ę 
ksz
ą 
kontrole nadruchem, chcemy ró
Ŝ
nie podchodzi
ć
do ró
Ŝ
nego rodzaju ruchu lub te
Ŝ
dawa
ć
priorytety igwarantowac pasmo w/g naszych własnych zało
Ŝ
e
ń
.Pierwsz
ą 
czynno
ś
ci
ą 
jak 
ą 
musimy wykona
ć
jest markowanie ruchu.Markowanie jest to proces polegaj
ą 
cy na wirtualnym "oznaczeniu" (z ang. mark) danychktóre maj
ą 
jakie
ś
cechy charakterystyczny (np. adres ip
ź
ródła lub port docelowy)Chc
ą 
c kształotwa
ć
ruch dynamicznie dla grupy userów mo
Ŝ
emy to zrobi
ć
:• Po adresie IP - skuteczne w wypadku routingu i NAT'a• Po adresie MAC - skuteczne w wypadku przezroczystego bridge'aDzisiaj zajmiemy si
ę 
tym pierwszym - a mianowicie markowaniem po adresie IPu
Ŝ
ytkownika.Dla wygody w generowaniu du
Ŝ
ej ilo
ś
ci wpisów polecam stosowanie do tego skryptów.Aby korzysta
ć
ze skryptów nale
Ŝ
y (winbox) wybra
ć
z lewego menu: System -> ScrtiptsW dalszej cz
ęś
ci raportu skrypty wykonwane przez wew. interpretator skryptów w systemieb
ę 
dziemy oznacza
ć
"(skrypt)"
 
ź
niej w nowym oknie klikn
ąć
na symbol „
+
I zawarto
ść
skryptu wpisa
ć
do pola „Source”Po zatwierdzeniu, zaznaczamy wybrany skrypt i klikamy na przycisk „Run Script”
 
 Pierwszym skryptem który musimy wykona
ć
jest :(skrypt)
:for x from 2 to 254 do={ /ip firewall mangle add chain=prerouting
 
src-address=(192.168.0. . $x ) action=mark-packet 
 
new-packet-mark=( $x . upload ) passthrough=no }
 to jest ruch, który wychodzi od usera (jego upload).Jak nie trudno si
ę 
domy
ś
le
ć
 
Ŝ
eby zmieni
ć
klase adresow
ą 
ze 192.168.0 nale
Ŝ
y edytowa
ć
wpis"src-address=(192.168.0. "wa
Ŝ
ne jest zachowanie umiejscowienia kropek jak w przykładziepowy
Ŝ
ej.Podobnie rzecz si
ę 
ma z zakresem od 2 do 254 - mo
Ŝ
emy to łatwo edytowa
ć
wpisuj
ą 
csatysfakcjonuj
ą 
ce nas warto
ś
ci
 
(skrypt)
:for x from 2 to 254 do={ /ip firewall mangle add chain=postroutingdst-address=(192.168.0. . $x ) action=mark-packetnew-packet-mark=( $x . download ) passthrough=no }
 a to z kolei mark w kierunku internet -> user czyli jego downloadPrzygotowania do ograniczania pasma2. Utworzenie nowego typu kolejki (do stochastycznego podziału):wpisy poprzedzone (terminal) z kolei wykonujemy wprowadzaj
ą 
c je z terminala:

You're Reading a Free Preview

Download
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->