Welcome to Scribd, the world's digital library. Read, publish, and share books and documents. See more
Download
Standard view
Full view
of .
Look up keyword
Like this
1Activity
0 of .
Results for:
No results containing your search query
P. 1
Quick Guide to Ccs and Simulator

Quick Guide to Ccs and Simulator

Ratings: (0)|Views: 8 |Likes:
Published by aminkhan83

More info:

Published by: aminkhan83 on Nov 04, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

09/26/2013

pdf

text

original

 
1
Quick guide to Code Composer Studio andhow to use the simulator-template
Henri Penttinen 2004-03-24Abstract
This text will give some guidelines for using the Texas Instruments Code Composer Studio (CCS)environment for DSP coding. The short example uses the simulator-template used on the course S-89.510 Digital Signal Processors and Audio Signal Processing at Helsinki University of Technology, Espoo, Finland. S-89.510. An associated manual is the DSK-GUIDE: GUIDE TOTHE S-89.510 PROJECT TEMPLATE CODE FOR TEXAS INSTRUMENTS TMS320C5416DSK by
Aki Härmä, available on the course web pages. You should also get familiar with the DSK-GUIDE. Other helpful guides are the CCS Help manuals, see e.g., Code Composer Studio Help’s“Tutorial - Learn how to begin developing DSP applications with Code Composer Studio IDE.”
READ THIS FIRST
: In this manual you will find supportive information and guidelines. ReadTexas C-54 family manuals for descriptive information. Recommended manuals:
TMS320C54x DSP Reference Set, Volume 1: CPU and Peripherals
[CD-ROM\C54xx\pdf\spru131g.pdf]
 
o
The CPU architecture, internal register structure, data and program addressing, instructionpipeline, and on-chip peripherals for the TMS320C54x digital signal processors. Alsoincludes development support information, parts lists, and design considerations for usingthe XDS510 emulator.
TMS320C54x DSP Reference Set, Volume 2: Mnemonic Instruction Set
[
 \CD-ROM\C54xx\pdf\spru172c.pdf]
 
o
You will be coding in Mnemonic, therefore vol. 3 is not included.
o
The mnemonic instructions. Also includes a summary of instruction set classes and cycles.
TMS320C54x DSP Reference Set, Volume 4: Applications Guide
[
 \CD-ROM\C54xx\pdf\spru173.pdf]
 
o
Software and hardware applications for the TMS320C54x digital signal processors. Alsoincludes development support information, parts lists, and design considerations for usingthe XDS510 emulator.
o
Example codes.
 
TMS320C54x Assembly Language Tools User's Guide
[
 \CD-ROM\C54xx\pdf\spru102e.pdf 
]
o
Important info on directives, labels, symbolic constants
o
Assembly language tools designed for the TMS320C54x devices.- Assembler- Archiver- Linker- Absolute lister- Cross-reference utility- Hex-conversion utility- Mnemonic-to-algebraic translator utility
 
2Before starting to code assembly you should clarify to yourself from
manuals,
at least, what thefollowing things and concepts actually mean:
o
 
directive
o
 
label
o
 
symbolic constants
1 Quick guide on How to use the simulator-template 
Here very basic features for de-bugging DSP code with CCS will be introduced in a compact form.1)
 
Start CCS 2.2.2)
 
Check if the settings are as described in section 1.2.3)
 
From parallel debug manager choose: Open -> C5416 Device Simulator/CPU.4)
 
Open project:
Project->Open [ ti\myprojects\...\Simulator-Template\template ].5)
 
Rebuild All
(icon or Project-> Rebuild All).6)
 
Load program:
File -> Load program [Simulator-Template\Debug\template].7)
 
Open simulator-template.c to the file view by double clicking it [template.pjt
– source -simulator-template.c].8)
 
Add a break-point
on line
‘ output[i]= right_output; ’ either
by doubleclicking the grey area on the side or clicking the hand-icon (Toggle Break Points). A readcircle appears on the left.9)
 
Run the program.
Now it automatically stops at the break point on line 112.10)
 
View memory:
Open from View-> Memory. A MemoryWindowOptions dialog appears.Write to Address: input, Page:Data.a.
 
Deselect Float in Main Window:
Click right mouse button and deselect Float inMain Window. This way you can look at the code and memory at the same time.11)
 
Add a Watch Window:
Choose from View -> Watch Window.Now the screen should look something like in Figure 1.12)
 
Run Program:
Now run the program a few times. It stops at the break point until the loopexpires. You can see how the values from the input vector appear to the output section inmemory, BUT with a delay.a.
 
Re-load the after gone through the loop. Now watch the _buffer1 section from thememory and how it runs circularly. [View-> Memory -> Address: _buffer1]13)
 
To see the values in registers open
CPU registers
from View->Registers->CPU Registers.
 
3
1. 1 Setting CCS 2.2 for simulation
For proper usage of the simulator do the following, if not done yet. Thank you to Tuomas Kantonenfor pointing this out.In the File View window of CCS choose:1)
 
DSP/BIOS Config
(folder)
 
-> template.cdb (file) [double click]2)
 
System ->
MEM
– Memory Section Manager
 3)
 
Right click SARAM03 -> properties4)
 
If base is 0x028000 change to 0x0080005)
 
Click OK.a)
 
DSP/BIOS Config
-> template.cdbb)
 
System ->
Input/Output
 c)
 
Right click RTDX - Real-Time Data Exchange Settings -> propertiesd)
 
If RTDX Mode is JTAG, change to
Simulator.
 e)
 
Click OK.Figure 1: Screen shot of CCS 2.2. running simulator-template with memory and watch windowsopen.WatchWindowMemoryWindowBreakPointCodeWindow

You're Reading a Free Preview

Download
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->