Welcome to Scribd, the world's digital library. Read, publish, and share books and documents. See more
Download
Standard view
Full view
of .
Save to My Library
Look up keyword
Like this
1Activity
0 of .
Results for:
No results containing your search query
P. 1
test

test

Ratings: (0)|Views: 15 |Likes:
Published by smart__petea9423
clasa Xi
clasa Xi

More info:

Published by: smart__petea9423 on Dec 21, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

03/04/2014

pdf

text

original

 
 Nume şi prenume
TEST CLASA a IX-a
Nr.IIncercuiţi răspunsurile adevărate pentru subiectele de la 1 la 6.
1.
Cunoaştem patru structuri algoritmice: structuraliniară, structura secvenţială, structura selectivă şistructura repetitivă.a)da; b)nu, sunt 5, există si structura alternativă.;c)nu sunt 3, structura secvenţiaeste numisiliniară iar cea selectivă si alternativă;
2.
Transpunerea grafică a unui algoritm folosindfiguri geometrice numite blocuri este:a)schemă logică; b)pseudocod;c)program;d)algoritm;
3.
Următoarea structură:
Dacă
condiţie indeplinită
atunciinstr1sfârşit dacă;
este pseudocod pentru:a)structura liniară; b)structura repetitivă cu număr cunoscut de paşi;c)structura alternativă cu ramură vidă;d)structura alternativă.4. Algoritmul este :a)succesiune de operaţii infinite; b)succesiune de operaţii pentru rezolvarea unei probleme oarecare;c)o noţiune ce nu poate fi descrisă;d)folosit numai la informatică şi matematică;5. Blocul pentru introducerea datelor este de formaunui:a)pătrat b)rombc)dreptunghid)paralelogram6. Se dă următorul algoritm scris în pseudocod. Să se precizeze ce execută acest algoritm pentru valorile lui x-3 şi 5a) -3 5 b) -3 0 c) 1 01 5 1 5 -3 5
Începutx,p,s: integer;citeşte x;p:=1; s:=0;dacă x<0 atunci p:=p*xaltfel s:=s +xsfârşit dacă;scrie p, s;stop
7. Să se scrie schema logică şi pseudocodul pentru calculul valorii expresiei ştiind că
a
este o constantă:
x
2
+ 5x+3 dacă x<-10;E(x)= x
a dacă -10<=x<10;2x+3dacă x>=10 
8. Se citeşte un număr întreg. Dacă acesta este par să se determine maximul dintre două numere reale, iar dacă nu este par să se afişeze suma a două numere naturale, doar dacă este divizibilă cu 5. (schema logică sau pseudocod ).9. Pentru următorul algoritm:
-
care este rezultatul în urma execuţiei
-
transcrie-l sub formă de schemă logicăx,z,m,n,a,b: întregi;n
3; b
n; m
 b; x
 b+4;daca b=5 atunci inceput a
 b; b
 b-1; sfarsitaltfel inceput b
 b-1; a
 b; sfarsit;y
a;daca (y=a) and (m=n) atunci scrie 1altfel scrie 0;n
a+b; b
b-1;daca n= -(m-x) atunci scrie 1altfel daca (a=0) or (b<>0) atunci scrie 0altfel scrie 1stop

You're Reading a Free Preview

Download
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->