Welcome to Scribd, the world's digital library. Read, publish, and share books and documents. See more
Download
Standard view
Full view
of .
Look up keyword
Like this
5Activity
0 of .
Results for:
No results containing your search query
P. 1
Απαντήσεις ΑΕΠΠ ( Πανελλαδικές 2013 )

Απαντήσεις ΑΕΠΠ ( Πανελλαδικές 2013 )

Ratings: (0)|Views: 22,038 |Likes:
Οι απαντήσεις στα θέματα Πανελλαδικών 2013 του μαθήματος Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον.
Οι απαντήσεις στα θέματα Πανελλαδικών 2013 του μαθήματος Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον.

More info:

Categories:Types, School Work
Published by: Σαρημπαλίδης Ιωάννης on May 29, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

06/05/2014

pdf

text

original

 
Σαρημπαλίδης Ιωάννηςhttp://pliroforikiatschool.blogspot.com/ 
Πανελλαδικές Εξετάσεις Γ‘ Τάξης Γενικού ΛυκείουΑνάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον 2013Προτεινόμενες απαντήσεις
ΘΕΜΑ Α
Α1
1Λ2Σ3Σ4Λ5Σ6Λ 
Α2
κ
<-
 1
ΓΙΑ
i
ΑΠΟ
 1 
ΜΕΧΡΙ
 4
ΓΙΑ
j
ΑΠΟ
 1 
ΜΕΧΡΙ
 5
ΑΝ
ΠΙΝ
[
i
,
j
]
 
<>
 0 
ΤΟΤΕ
Α
[
κ
]
 
<-
iΑ
[
κ
+
 1
]
 
<-
jΑ
[
κ
+
 2
]
 
<-
ΠΙΝ
[
i
,
j
]
κ
<-
κ
+
 3
ΤΕΛΟΣ_ΑΝΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
Α3
α.
(σελ 19 του σχολικού βιβλίου)Οι λόγοι για τους οποίους αναθέτουμε την επίλυση ενός προβλήματος στον υπολογιστήείναι:1.
 
Η πολυπλοκότητα των υπολογισμών2.
 
Η επαναληπτικότητα των διαδικασιών3.
 
Η ταχύτητα εκτέλεσης των πράξεων4.
 
Το μεγάλο πλήθος των δεδομένων
β.
(σελ 65 του σχολικού βιβλίου)Η χρήση της σειριακής μεθόδου αναζήτησης σε έναν πίνακα δικαιολογείται σε περιπτώσειςπου:1.
 
Ο πίνακας είναι μη ταξινομημένος
 
Σαρημπαλίδης Ιωάννηςhttp://pliroforikiatschool.blogspot.com/ 2.
 
Ο πίνακας είναι μικρού μεγέθους (για παράδειγμα, n <= 20)3.
 
Η αναζήτηση σε ένα συγκεκριμένο πίνακα γίνεται σπάνια
γ.
(σελ 127 του σχολικού βιβλίου).Τα πλεονεκτήματα των γλωσσών υψηλού επιπέδου είναι:1.
 
Ο φυσικότερος και πιο «ανθρώπινος» τρόπος έκφρασης των προβλημάτων.2.
 
Η ανεξαρτησία από τον τύπο του υπολογιστή.3.
 
Η ευκολία της εκμάθησης και εκπαίδευσης .4.
 
Η διόρθωση λαθών και ση συντήρηση προγραμμάτων είναι ευκολότερο έργο.
Α4
α.
ΓΙΑ
j
ΑΠΟ
 2 
ΜΕΧΡΙ
 100
ΓΙΑ
i
ΑΠΟ
 1 
ΜΕΧΡΙ
j
-
1
ΔΙΑΒΑΣΕ
Π
[
i
,
j
]
 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
β.
Διάβασε
Α
,
Β
Αν
Α
<
Β
τότε
Α
Β
Τέλος_ανΕμφάνισε
Α
Α5
1ε2ζ3στ4α5β6γ7δ 
 
Σαρημπαλίδης Ιωάννηςhttp://pliroforikiatschool.blogspot.com/ 
ΘΕΜΑ Β
Β1Β2
πλ
<-
 0
ΓΙΑ
i
ΑΠΟ
 1 
ΜΕΧΡΙ
 100
ΑΝ
Π
[
i
]
 
=
 
ΑΛΗΘΗΣ
 
ΤΟΤΕ
πλ
<-
πλ
+
 1
ΤΕΛΟΣ_ΑΝΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΓΙΑ
i
ΑΠΟ
 1 
ΜΕΧΡΙ
 100
ΑΝ
i
<=
πλ
ΤΟΤΕ
Π
[
i
]
 
<-
 
ΑΛΗΘΗΣΑΛΛΙΩΣ
Π
[
i
]
 
<-
 
ΨΕΥΔΗΣΤΕΛΟΣ_ΑΝΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
∆ΙΑΒΑΣΕ
 
α
 
 ΑΡΧΗ
 
κ
 
2
α
> 1
 ΑΛΗΘΗΣ
 
ΨΕΥ∆ΗΣ
 
ΤΕΛΟΣ
 
α
 
 
α
div
κ
 
κ
 
 
κ
+ 1
α
mod
κ
= 0
Εµφάνισε
 
κ
 
 ΑΛΗΘΗΣ
 
ΨΕΥ∆ΗΣ
 

You're Reading a Free Preview

Download
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->