Welcome to Scribd, the world's digital library. Read, publish, and share books and documents. See more
Download
Standard view
Full view
of .
Look up keyword
Like this
3Activity
0 of .
Results for:
No results containing your search query
P. 1
Computer applications for everyone, part 3

Computer applications for everyone, part 3

Ratings: (0)|Views: 181 |Likes:
Published by Hany Kheir
Desktop publishing, presentation & the specialized software packages, the internet and computer networks.
Desktop publishing, presentation & the specialized software packages, the internet and computer networks.

More info:

Published by: Hany Kheir on May 07, 2009
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as ODT, PDF, TXT or read online from Scribd
See more
See less

01/30/2013

pdf

text

original

 
VePi NewslettersThe micro-computers (PC) Div. The applications section Number:3
Desktop publishing software:
Desktop publishing software is a software that is used to mix text, figures, drawings, diagrams easilyfor the purpose of producing a master for a commercial document, like a brochure, a panphlet, anewsletter,..etc. There are certain word processing packages that offer this desktop publishing featuresas part of the word processing software. The elements that may befound in a word processing software with additional menu or icons (push buttons) elements for thedesktop publishing capabilities are: DRAW, DRAW A LINE, AUTOSHAPES, RECTANGLE, ELIPSE,WORDART, FILLCOLOUR, LINE COLOUR, FONT COLOUR, LINE STYLE, DASH STYLE,TEXT BOX and SHADOW. The main menu elements of a desktop publishing software are: FILE,EDIT, PAGE, TEXT, LINE, STYLE, OPTIONS. The FILE menu element will have the following sub-elements:New, Open, Exit, Save, SaveAs, AutoSave, Art & Borders, Import Picture, Import Text,Printer Setup, Print. The Edit menu will have the following subelements: Undo,Cut, Copy, Paste, PasteFormat, Clear, Insert Object, Character Map. The Page menu element may have the following sub-elements: Views, Layout tools, Display Snapping, Frame, Setup, Page Setup, Size, Orientation. TheText menu elementhave the following underneath it: Character (Font style, Size, Width, Colour, Shading), Spacing, Align,Leading, Tracking, Insert. The Line menu subelements are: Type, Weight, Colour, Shading, Corners,Fill (Colour, Shading), Picture (Colour, Shading). The Style menu may have: Apply, Update, Edit,Merge, Edit Colours, Text/Graphics/Frame defaults, Save Style.The menu items on a desktop publishing software package may have in addition to what is given inLevel I, the following: Preferences, Wrap settings, Text outflow, Reflow and Font & Pictures. Thesubmenu File/New starts a new publication file, /Open opens an existing publication file or template (atemplate can be created or opened to establish a starting setup for a new publication, for one or several aspects of the publication, including layout content, styles & colour palette), /Exit is the sameas clicking twice on the Window close icon, the user will be given the option to save his work beforeclosing the file and exiting the application program), /Save will allow the user to save the file under thename shown in the title bar, /Saveas saves the current file (publication), as a file or as a template, under the name the user gives in the dialog box, /Autosave saves a hidden, backup, file of the current publication at time intervals specified by the user, /Art & borders the user to access the available artfiles included with the application program, /Import picture imports an image into the publication,/Import text imports a word processor text file into the publication, /Printer setup allows the user toselect the printer, paper size & orientation,/Print allows the user to select the portion of the publicationto be printed & how to be printed. The submenu Edit/Undo undoes the most recent changes made toobjects, /Cut deletes (cuts) the selected object & copies it to the clipboard, /Copy copies the selectedobject from the current working page to the clipboard, /Paste pastes a copy of whatever object is in theclipboard into the current file (working area), /Paste format changes the properties of the currentlyselected object to match as best possible those of the last object cut or copied to the clipboard from theapplication program, /Clear deletes (clears) the selected object or group of objects from the workpage,/Insert object allows the user to select the type of object he requires from the displayed list of OLEobjects, /Character map which allows the user to visually select the special characters that are notmarked on the keyboard. The submenu Page/ Views sets the current zoom level to that specified on themenu, /Layout displays a dialog to control the use of the application program page layout aids whichare frames, rulers, guides that assist accurate layout of the document, /Display lists the applicationlayout aids & shows the ones that are curently displayed, /Snapping turns this feature on or off, /Framesetup displays a dialog bax that enables the control of the selected frame settings, /Page setup displays a
 
dialog box combining the application page properties(page size,margins,number of columns &orientation,wide i.e. landscape vs. tall ie portrait), /Size displays the most common page sizes,/Orientation allows the user to select between wide & tall page orientation. The submenu Text/Character allows the user to select the font name, font style (bold, italic,.), case (upper, lower..etc.),size in points (1 inch=72 points), text colour, tintfill, pattern & effects (strikeout, underline, outline..etc).Under the GRAPHICS menu item the user may find the following: Line which displays a dialog boxcombining all the line (previously selected) properties the properties that can be set through this dialogare type, weight, corners, tint, colour & pattern, certain properties can be set through the availablesubmenu items directly; Fill displays a dialog box combining all the fill properties (these propertiescan also be set via submenu items): pattern, tint colour & shading (pattern, colour & tint), colour & tintadjust fill colour; Picture displays a dialog box combining all the picture & object linking andembedding (automation) properties, these properties can also be set via submenus colour & shading.Under the STYLES menu, the following may be found (which allows the creation, editing &application of styles, changing the colour palette & setting object default values, application programsusually allows the user to create two libraries of named styles: one for Text and one for other Graphicsitems): Apply which allows the user to apply the named style to the current object or all objects withthe current style; Edit graphic style allows the user to remove, update, add styles to the available styleschoices; Merge allows the user to merge styles; Edit colours allows the user to remove, change & addcolours to the available choices of colours for the text and graphics objects; Text/Graphics/Framedefault resets these propertiesof the highlighted objects back to the default levels; Save styles saves the styles of text, graphics &colours created during this session permanently with other settings. Under the OPTIONS, the user may find the following: Preferences displays the preferences dialog box to set the screen & ruler options i.e. horizontal & vertical units, change bar, scroll bar, tool bar & statusbar, rotated & unrotated pictures, metafiles on clipboard & use exact colours; Wrap settings displays a dialog box to control textwrap values for the selected objects; Text outflow switches the outflow of a text in a stream on or off;Reflow story if the user is working with text outflow was turned off, the user selects this command toflow the content of the document; Fonts & pictures displays a dialog box that lists the fonts & picturesused in the application; Save settings, usually when the application starts up it reads the configurationinformation (which controls certain options) from the disk. The user can change any of these detailsonce the application has started. If the user would like to permanently save the settings then he has tomake the changes and then select Save settings. The following are saved: autosave value (fromFile/Autosave), current page setup (from Page/ Page setup), layout tools (from Page/Layout tools),cleanup options (by double clicking on cleanup button on the status bar), position of floating toolbox &change bar (by pointing to the title bar using the mouse and then dragging them to the user's preferred positions) and finally other prefernces (from Options/Preferences).
Presentation software:
A presentation software is a slide show presentation on the personal computer. The presentation is puton electronic slides (screens) on the PC. All the diagrams, graphs and animation are included in each of the screens (slides). At the time of presentation, each screen is displayed on the monitor one by onewith full control of the speed of the screen changing and sequence in the hands of the presenter. Other  presentation related items that can be produced using this type of packages are: speakers notes andhandouts. There are a few commercially available packages on the market. The main menu elementsthat mayappear in the menu portion of the screen are: FILE, EDIT, VIEW, OPTIONS, DESIGN, OBJECTS,GRAPH, SHOWTIME, INSERT, FORMAT, TOOLS, SLIDE. The File menu may have the followingsub-elements: New, Open, Save, SaveAs, Merge (Presentation, Template, Styles, Colours), ImportPicture, Print, Print Setup.
 
The Edit menu item may have: Undo, Restore, Cut, Copy, Paste, Delete, Paste link, Insert New Object.The View mwenu item may have: Slide, Outline, Speaker Notes, Slide Sorter, Sheet, New Slide, Go ToSlide, Actual Size, Fit in Window, Zoom in, Zoom out, Scale, Refresh Screen, View Black & White.The Design menu item may have: Choose Design, Choose Template, Slide SetUp, Notes/Handouts Setup, Choose Colour Palette, New/Modify Colour Palette, Record Style, Notes/HandoutsLayout, Slides per Handout. The Options may have: Control Bar, Message Bar, Tool Bar, Calour Bar,Outline Bar, Rulers, Guides, Snap to Guide/ruler. To Be Continued in the next level (level II)The submenu items of Options menu element given in Level I can have the additional ones:Presentation preferences & Ruler settings. The Design menu item may have the folowing subitems:Choose design, Choose template, Slide+ setup, Notes/Handouts, Setups, Choose olour palette, New/Modify, Record style, Notes layout, Handouts layout & Slides/handouts. The Objects menu itemmay have the following underneath it: Graphic effect, Character, Paragraph, Blend, Duplicate, Layer,Lines, Align/attach, Transform, Tool palette & Convert to curves. The graph menu item may have assubitems the following: New, Modify, Gallery, Format, Update & Replot graph. The Show time mayhave Slide show, Show current slide, New/Modify, Slide jump, Remove slide jumo & Slide showtransitions. The File/New submenu clears out the current presentation & starts a new one (the user iswarned if there are any unsaved changes in the current presentation), /Open opens a new presentationfile (the user is warned if there are any unsaved changes in the current presentation), /Save saves thecurrent presentation file with the same name (in the title bar), Save as saves the current presentationwith a new name or different options, /Merge presentation allows the user to merge another  presentation into the current presentation (appending the current one), /Merge template replaces thecurrent templates with templates from another presentation or design file or adds the templates fromanother presentation to the list of templates in the current presentation. To be continued in the next Level (Level III).As a continuation to level II, under the FILE menu item, the user may find (in addition to what is givenin level II) the following: Merge styles which adds the styles from another presentation or design file tothe list of styles in the current presentation; Merge colours which adds the colour palettes from another  presentation or design file to the list of colour palettes in the current presentation; Import this command performs different actions depending on the current view (there are many possible views in a presentation program: the normal view is Slide View, Template View is similar to Slide View butallows the user to edit the Slide Template, Outline View shows the files & bullet items (text) in theentire presentation, Speakers Note View shows the notes associated with a slide along with a smallversion of the slide, Sorter View shows small pictures of all or many of the slides & allows the user tosort them, Sheet View is a row & column presentation of the used to produce the graphs in the presentation); Print prints the current presentation according to the settings in the Design Slide setupand File Print setup; Exit exits the application program, if there are any unsaved changes, the user iswarned (prompted) to allow the user to save the modified file before exiting. Under the EDIT menuitem, there may be: Undo undoes the last command; Restore reverses the effect of the last Undocommand; Copy it copies the selected items to the clipboard (without deleting them); Cut it deletes theselected items as it copies them to the clipboard; Paste pastes the contents of the clipboard into thecurrent slide; Delete deletes the currently selected objects, text or sheet entries; Copy slide as picturecopies the current slide to the clipboard as an image; Paste link (usually there are 4 types of links theuser can create with a presentation application program: hot links - dynamic link to another runningapplication with real time updates, warm links - to spread sheet in a file on the hard drive, OLEautomation/embedded objects and linked objects it can create an OLE linked object from theinformation in the clipboard setting up a DDE hot link to a running application); Insert new object presents a dialog listing of the available OLE servers, the creation of the object will be embedded in the presentation; Edit links changes the file to which the object is linked (on a linked OLE); Object it isused to edit an embedded or linked OLE object; Select all selects all objects on the current slide; Select

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->