Welcome to Scribd, the world's digital library. Read, publish, and share books and documents. See more
Download
Standard view
Full view
of .
Save to My Library
Look up keyword
Like this
84Activity
0 of .
Results for:
No results containing your search query
P. 1
Mini Curso de MPLAB Passo-A-Passo em Português

Mini Curso de MPLAB Passo-A-Passo em Português

Ratings: (0)|Views: 6,888 |Likes:
Published by Nando
Introdução e ajustes
O MpLab é um ambiente integrado
para o estudo e desenvolvimento
com a família PIC de microcontroladores.
Sua principal característica é a
total integração de seus módulos
com o ambiente Windows, permitindo
a fácil cópia de arquivos e trechos
de arquivos de um aplicativo para
outro.
Para se escrever um programa no
MpLab, precisamos antes assimilar
o conceito de “projeto”.
Introdução e ajustes
O MpLab é um ambiente integrado
para o estudo e desenvolvimento
com a família PIC de microcontroladores.
Sua principal característica é a
total integração de seus módulos
com o ambiente Windows, permitindo
a fácil cópia de arquivos e trechos
de arquivos de um aplicativo para
outro.
Para se escrever um programa no
MpLab, precisamos antes assimilar
o conceito de “projeto”.

More info:

Published by: Nando on Sep 28, 2009
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

07/29/2013

pdf

text

original

 
USANDO O MpLab 5.00 ESUPERIOR
Introdução e ajustes
O MpLab é um ambiente integra-do para o estudo e desenvolvimentocom a família PIC de microcontrola-dores.Sua principal característica é atotal integração de seus móduloscom o ambiente Windows, permitin-do a fácil cópia de arquivos e trechosde arquivos de um aplicativo paraoutro.Para se escrever um programa noMpLab, precisamos antes assimilaro conceito de “projeto”.
O “Projeto” no MpLab
Entende-se por projeto um con- junto de arquivos e informações quediz ao MpLab qual a situação de umcerto trabalho em particular.Por exemplo, num certo projetodesignado EXEMPLO.PJT temosduas janelas abertas: exemplo.asme exemplo.lst.Em outro projeto designadoTESTE.PJT temos três janelas aber-tas: teste.asm, teste.lst. e FileRegister Window.Com o gerenciamento de proje-tos presente no MpLab não precisa-mos “lembrar” quais as janelas quecada projeto estava usando no mo-mento em que encerramos o traba-lho, pois ao carregarmos o projetodesejado todas as informações re-lativas ao mesmo serão recupera-das.IMPORTANTE: Ao encerrar seustrabalhos não vá fechando as jane-las abertas. Feche apenas o MpLabe na janela “Save Project” selecione
Yes
, ou caso pretenda apenas en-cerrar o trabalho atual, selecione nomenu “Project > Close Project”, eresponda
Yes
se necessário, parasalvar as alterações.
Usando o MpLabpela primeira vez.
Crie uma pasta (diretório) em seuHD com o nome
c:\0pic
(com o nú-mero 0 antes, a pasta sempre esta-rá no topo dos menus).Vamos criar um novo projeto, denome EXEMPLO.PJT, nestediretório. Inicie o MpLab. Suatela deverá ser parecida com a dafigura 1.
Selecionando o processador
Se o processador indicado norodapé não for o 16F84A, siga a se-guinte seqüência nos
menus 
:
Options 
->
Development Mode 
, eselecione a ficha
“Tools” 
 
e teremosa tela da figura 2.Marque a opção
MPLAB-SIMSimulator
e selecione
PIC16F84A
no
menu 
à direita, deixando sua se-leção conforme acima e depois dêum
click 
no botão
Apply
e em se-guida em
OK
.
GUIA PRÁTICO PARA SIMULAÇÃO E ESTUDOS.
Mini-curso MpLabpasso-a-passo
MpLab 5.00
(e superiores)
VIDAL - Projetos Personalizadoswww.vidal.com.br
Figura 1 - Tela inicial do MpLab
 
Sua tela agora deve estar confor-me a tela inicial (figura 1).
Ajustando o
clock 
para simulação
Para podermos obter do simula-dor informações precisas sobre nos-so programa quando simulado, de-vemos informar ao mesmo qual a fre-qüência de
clock 
com que o
chip 
fun-cionará. Selecione na linha do
menu 
do MpLab
Options 
>
Development Mode 
> e selecione a ficha
“Clock” 
e obteremos a janela da figura 3:- Inicialmente selecione se a fre-qüência estará em MHz, kHz ou Hz;- No campo “Desired Frequency”entre com a freqüência desejada, porexemplo, 4 para 4 MHz ( o campo“Actual Frequency” mostra a fre-qüência atual com que o simuladorestá calculando os eventos);- No box “Oscilator Type” selecio-ne modo XT;- Dê um
clique 
em “OK” e na nova janela apenas responda “OK” nova-mente.- Veja no rodapé do MpLab a fre-qüência sendo reconhecida pelo pro-grama.
TRABALHANDO COM“PROJETOS”
Criando um novo fonte para tra-balharmos com um projeto
Iniciaremos um
novo
projetosempre pela criação de um novo fon-te.
 
Execute a seguinte seqüência:File > NewUm novo fonte de nome
Untitled1
será criado, e o MpLab lheperguntará se deseja criar um novoprojeto.Responda “NO” para prosse-guir na criação do fonte.Voce obterá a tela da figura 4:Ajuste o tamanho da janela
Untitled1
conforme sua conveniên-cia.Nesta janela digite o texto con-forme a figura 5:
Figura 2 - Seleção do processador.Figura 3 - Ajustando o
clock 
para a simulação.Figura 4 - Janela com o novo fonte ainda sem nome.
 
Após a digitação (confirme se oseu texto está igual ao acima, semerros), salve com o nomeEXEMPLO.ASM.
Como? 
 
Após escrever o progra-ma, selecione nos
menus 
:
File 
>
Save as...
e na janela aberta digite o nome
exemplo.asm
para o fonte E e sele-cione no drive C a pasta
C:\0pic.
Agora dê um
click 
no botão
OK
esua tela deverá estar conforme a fi-gura 5, mas com a barra de título dofonte trocada, ao invés de Untiled1,com o nome e caminho completos,c:\0Pic\exemplo.asm.
Criando o projeto
Agora que já criamos o fonte va-mos criar o projeto para trabalhar-mos com o mesmo.Selecione Project > New Projecte a janela da figura 6 se abrirá(veja na janela do fonte o nome ecaminho do arquivo, como dito ante-riormente):Escreva no campo "File Name".
exemplo.pjt
e de um
click 
em
OK
(isto é , como salvar na pasta
c:\0Pic
o projeto
exemplo.pjt
)
IMPORTANTE:
O fonte e o pro- jeto devem estar na mesma pasta
O nome do fonte não precisa ser o mesmo do projeto.
Sempre que um novo projeto écriado, a janela
“Edit Project”
seráexibida automaticamente.
Editando o projeto(novo ou já existente)
Entende-se por editar o projetoescolher qual fonte fará parte domesmo, sendo usado no processode compilação, além de ajustar osparâmetros do compilador.Quando o projeto é novo, estaopção aparecerá automaticamente.Podemos ainda usar a edição doprojeto para trocar o fonte ou o com-pilador usado no desenvolvimento.
Figura 7 - Editando o projeto exemplo.pjt.Figura 5 - Fonte de teste já digitado.Figura 6 - Janela New Project do nosso exemplo.

Activity (84)

You've already reviewed this. Edit your review.
1 hundred reads
1 thousand reads
Alan Mazzer liked this
josecame3511 liked this
Danilo Matias liked this
lucapeta liked this
Joel Galdino liked this
Tarcio Hortegal liked this
Diogo Cunha liked this

You're Reading a Free Preview

Download
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->