You are on page 1of 59

Ch.

8 – Route Optimization
Part 2 - Redistribution

CCNP 1 version 3.0


Rick Graziani
Cabrillo College

Homer Simpson – Today’s Teaching Assistant


Note to instructors

• If you have downloaded this presentation from the Cisco Networking


Academy Community FTP Center, this may not be my latest version of
this PowerPoint.
• For the latest PowerPoints for all my CCNA, CCNP, and Wireless
classes, please go to my web site:
http://www.cabrillo.edu/~rgraziani/
• The username is cisco and the password is perlman for all of
my materials.
• If you have any questions on any of my materials or the curriculum,
please feel free to email me at graziani@cabrillo.edu (I really don’t
mind helping.) Also, if you run across any typos or errors in my
presentations, please let me know.
• I will add “(Updated – date)” next to each presentation on my web site
that has been updated since these have been uploaded to the FTP
center.
Thanks! Rick
Rick Graziani graziani@cabrillo.edu 2
Route Optimization

• Passive Interfaces
• Route Filters
– Distribute Lists
• Policy Routing
– Route Maps
• Route Redistribution
– Multiple Routing Protocols
– Changing Administrative Distances
– Configuring Redistribution
– Default Metrics

Rick Graziani graziani@cabrillo.edu 3


Route
Redistribution

• Cisco routers support up to 30 dynamic routing processes.


– A router can run RIP, OSPF, IGRP, IS-IS, EIGRP, IPX RIP, RTMP
(AppleTalk), and other protocols simultaneously.
– Most of these routing protocols allow an administrator to configure
multiple processes of the same routing algorithm; RIP is a notable
exception.
• I.e. Multiple OSPF processes
• router ospf 10
• router ospf 15

Rick Graziani graziani@cabrillo.edu 4


Multiple Routing Protocols
Multiple Routing Processes
RTA#show running-config

router ospf 24
network 10.2.0.0 0.0.255.255 area 0
! Not recommended!
router ospf 46
network 192.168.2.0 0.0.0.255 area 2
!
router igrp 53
network 172.16.0.0
network 172.17.0.0
! Not recommended!
router igrp 141
network 10.0.0.0
network 192.168.3.0

Rick Graziani graziani@cabrillo.edu 5


Route
Redistribution

• To support multiple routing protocols within the same internetwork


efficiently, routing information must be shared among the different
routing protocols.
– For example, routes learned from a RIP process may need to be
imported into an EIGRP process.
• The process of exchanging routing information between routing
protocols is called route redistribution.

Rick Graziani graziani@cabrillo.edu 6


Route
Redistribution

• Route redistribution can be one-way (that is, one protocol receives the
routes from another) or two-way (that is, both protocols receive routes
from each other).
• Routers that perform redistribution are called boundary routers
because they border two or more ASs or routing domains.
• The term boundary router is also sometimes used to describe a
router running a classful routing protocol (like RIP) that has interfaces
in more than one classful network.

Rick Graziani graziani@cabrillo.edu 7


Route
Redistribution

Why configure redistribution?


• You want to run IGRP/EIGRP in one or more areas in a mixed vendor
environment
• You want to support legacy UNIX systems that support RIP only, but
use a more scalable protocol elsewhere.
• You need a temporary fix during a prolonged upgrade from older
protocols and hardware to newer, more scalable solutions.

Rick Graziani graziani@cabrillo.edu 8


Administrative Distance

• Because each routing process places substantial demands on the router’s


memory and CPU resources, only boundary routers should run more than
one routing process for the same routed protocol, and only when absolutely
necessary.
• If a boundary router is running multiple IP routing protocols, then it may be
possible that the router will learn about the same network from more than
one routing protocol.
• Specifying administrative distance values enables the Cisco IOS software to
discriminate between sources of routing information.
• If two routes have the same network number, and possibly subnet
information, the IOS software always picks the route whose routing protocol
has the lowest administrative distance.
Rick Graziani graziani@cabrillo.edu 9
Note

• Curriculum states, “A router looks at the metric value to


determine the best route. However, in this case, the router
would have to compare the simple metric of RIP, its hop
count, with the composite metric of IGRP, this being
derived from bandwidth, delay, reliability, load, and MTU.”
• MTU is not and has never been used as a routing metric.

Rick Graziani graziani@cabrillo.edu 10


Route Optimization

• Passive Interfaces
• Route Filters
– Distribute Lists
• Policy Routing
– Route Maps
• Route Redistribution
– Multiple Routing Protocols
– Changing Administrative Distances
– Configuring Redistribution
– Default Metrics

Rick Graziani graziani@cabrillo.edu 11


Administrative Distance

• A routing protocol’s administrative distance rates its trustworthiness


as a source of routing information.
– Administrative distance is an integer from 0 to 255.
– The lowest administrative distance has the highest trust rating.
– An administrative distance of 255 means the routing information
source cannot be trusted at all and should be ignored.
ignored
– An administrative distance of zero is reserved for connected
interfaces, and will always be preferred.
preferred

Rick Graziani graziani@cabrillo.edu 12


Administrative Distance

• Specifying administrative distance values enables the Cisco IOS


software to discriminate between sources of routing information.
• The software always picks the route whose routing protocol has the
lowest administrative distance.
• Although we can’t easily compare apples with oranges, we can, for
example, instruct the router to always choose oranges over apples.
Rick Graziani graziani@cabrillo.edu 13
Administrative Distance

Good CCNP
Routing
Exam
Knowledge!

Rick Graziani graziani@cabrillo.edu 14


Administrative Distance

IGRP at 100
favored

OSPF now
favored

• When using multiple IP routing protocols on a router, the default distances


almost always suffice.
• However, some circumstances call for changing the administrative distance
values on a router.
• If, for example, a router is running both IGRP and OSPF, it may receive
routes to the same network from both protocols.
• The default administrative distances favor IGRP routes over OSPF routes:

Rick Graziani graziani@cabrillo.edu 15


Administrative Distance

IGRP at 100
favored

OSPF now
favored

• But since IGRP doesn’t support CIDR, you may want the router to use
the OSPF route instead.
• In this case, you can configure the local router to apply a custom
administrative distance to all OSPF routes.
• With the distance 95 command, RTZ compares the IGRP and OSPF
routes and comes up with a different result.

Rick Graziani graziani@cabrillo.edu 16


Administrative Distance

Router(config-router)#distance weight [source-ip-address


source-mask (access-list-number | name)]

RTZ(config)#router rip
RTZ(config-router)#distance 105 10.4.0.2 255.255.255.0

• You can also apply the distance command with optional arguments to
make changes to selected routes based on where they originate.
• Remember that the administrative distance defaults exist for a reason
and will serve a network well in most circumstances.
• Use the distance command only when certain that it is necessary to
guarantee optimal routing.
• Using the optional arguments, we can configure a router to apply an
administrative distance of 105 to all RIP routes received from
10.4.0.2.
• These values are local to the router, all other routers will apply the
administrative distance of 120.
Rick Graziani graziani@cabrillo.edu 17
Administrative Distance

RTZ(config)#router rip
RTZ(config-router)#distance 97 10.3.0.1 255.255.255.0 2
RTZ(config-router)#exit Source of the route

RTZ(config)#access-list 2 permit 192.168.3.0 0.0.0.255

The route that will get the


administrative distance of 97

• Or, we can configure a router to apply an administrative


distance of 97 to specific RIP routes: 192.168.3.0, received from
10.3.0.1.

Rick Graziani graziani@cabrillo.edu 18


Administrative Distance

RTZ(config)#router rip Applies to all routes from 10.4.0.2


RTZ(config-router)#distance 105 10.4.0.2 255.255.255.0
RTZ(config-router)#distance 97 10.3.0.1 255.255.255.0 2
RTZ(config)#access-list 2 permit 192.168.3.0 0.0.0.255
Applies to just the 192.168.3.0/24 route from 10.3.0.1
RTZ#show ip route
R 192.168.5.0/24 [105/1] via 10.4.0.2, 00:00:02, Serial1
10.0.0.0/16 is subnetted, 5 subnets
R 10.2.0.0 [120/1] via 10.3.0.1, 00:00:02, Serial0
C 10.3.0.0 is directly connected, Serial0
R 10.1.0.0 [120/2] via 10.3.0.1, 00:00:02, Serial0
C 10.4.0.0 is directly connected, Serial1
R 192.168.1.0/24 [120/3] via 10.3.0.1, 00:00:02, Serial0
R 192.168.2.0/24 [120/2] via 10.3.0.1, 00:00:02, Serial0
R 192.168.3.0/24 [97/1] via 10.3.0.1, 00:00:02, Serial0

Rick Graziani graziani@cabrillo.edu 19


Route Optimization

• Passive Interfaces
• Route Filters
– Distribute Lists
• Policy Routing
– Route Maps
• Route Redistribution
– Multiple Routing Protocols
– Changing Administrative Distances
– Configuring Redistribution
– Default Metrics

Rick Graziani graziani@cabrillo.edu 20


Configuring
Redistribution

• “The redistribution command is available for all IP routing protocols,


so the command is considered to be independent of any one
protocol.”
– Note: However, the redistribution command can be used
differently depending on the IP routing protocols involved.
• Redistribution can take on various complexities depending upon the
from and to routing protocols and the options that can be
implemented.
– This can be a matrix of “what if’s,” but we will keep the complexity
to a minimum, concentrating on the basics.
– We will examine the redistribute command and some of the other
options and tools available.
Rick Graziani graziani@cabrillo.edu 21
Configuring
Redistribution

• Route redistribution can be complicated and have several


disadvantages as shown in the following:
– Routing loops – Depending on how redistribution is used, routers can
send routing information received from one AS back into the AS.
– Incompatible routing information – Each routing protocol uses different
metrics. Because these metrics cannot be translated exactly into a different
protocol, path selection using the redistributed route information may not
be optimal.
– Inconsistent convergence time – Different routing protocols converge at
different rates. For example, RIP converges slower than EIGRP, so if a link
goes down, the EIGRP network will learn about it before the RIP network.

Rick Graziani graziani@cabrillo.edu 22


Configuring Redistribution

• These potential trouble spots can be avoided with careful planning and
implementation. Use the following important guidelines when
configuring route redistribution:
– Be familiar with the network
– Do not overlap routing protocols – Do not run two different protocols in
the same internetwork. Instead, have distinct boundaries between networks
that use different routing protocols.
– Use one-way redistribution with multiple boundary routers – If more
than one router serves as a redistribution point, use one-way redistribution
to avoid routing loops and convergence problems. Consider using default
routes in the domains that do not import external routes.
– Use two-way redistribution with a single boundary router – Two-way
redistribution works smoothly when redistribution is configured on a single
boundary router in the internetwork. If there are multiple redistribution
points, do not use two-way redistribution unless a mechanism to reduce the
chances of routing loops is enabled. A combination of default routes, route
filters, and distance modifications can be used to combat routing loops.

Rick Graziani graziani@cabrillo.edu 23


Redistribute command
Router(config-router)# redistribute protocol [process-id] {level-1 |
level-1-2 | level-2} [metric metric-value] [metric-type type-
value] [match {internal | external 1 | external 2}] [tag tag-
value] [route-map map-tag] [weight weight] [subnets]

• The static [ip] keyword is used to redistribute IP static routes. The optional ip
keyword is used when redistributing into the Intermediate System-to-
Intermediate System (IS-IS) protocol.
• The connected keyword refers to routes that are established automatically by
virtue of having enabled IP on an interface. For routing protocols such as Open
Shortest Path First (OSPF) and IS-IS, these routes will be redistributed as
external to the autonomous system.
• (Optional) metric used for the redistributed route. If a value is not specified for
this option, and no value is specified using the default-metric command, the
default metric value is 0, except for OSPF where the default cost is 20.
Use a value consistent with the destination protocol. (more later)
• (Optional) metric-type, for OSPF, the external link type associated with the
default route advertised into the OSPF routing domain. It can be one of two
values: 1—Type 1 external route, 2—Type 2 external route
• Lets look at the other options, defaults, and command usage guidelines:
Redistribute Command
Rick Graziani graziani@cabrillo.edu 24
One Way
Distribution

• Metric option changes the RIP metric into bandwidth, delay,


reliability and load, to be used with the EIGRP composite
metric calculation.
• MTU must be included but is not used in the calculation.
• One way distribution is more common with IGP protocols
that redistribute partial or full Internet routes from BGP.
Rick Graziani graziani@cabrillo.edu 25
Two way
distribution

EIGRP Routes

• Notice that the syntax of the metric keyword varies depending on the
routing protocol that it uses.
• For RIP, OSPF, and BGP, the metric option is followed by a single
number that represents the metric value (hop count, cost, and so on).
• For IGRP and EIGRP, the metric option is followed by five values that
represent bandwidth, delay, reliability, load, and MTU.

Rick Graziani graziani@cabrillo.edu 26


Two way
distribution

EIGRP Routes

• After configuring two-way redistribution, RTC and RTA have only 11


routes, while the boundary router (RTB) has 12. What is happening?
• The answer lies in the directly connected routes of router RTB as
follows:
– 172.16.0.0/16 (missing from RTA table)
– 172.24.0.0/16 (missing from RTC table)
– Need redistribute connected with default metric (coming)
Rick Graziani graziani@cabrillo.edu 27
Two way
distribution

EIGRP Routes

• Directly connected routes can be redistributed into a routing protocol by using


the redistribute connected command
RTB(config-router)#router eigrp 24
RTB(config-router)#redistribute connected metric 10000 100
255 1 1500
– By using the connected keyword, redistribution will inject all connected
routes into the updates from the routing protocol. This is done without
configuring a network statement.
• The following example illustrates how RTB could be configured to redistribute
static routes:
RTB(config-router)#router eigrp 24
RTB(config-router)#redistribute static metric 10000 100 255
1 1500

Rick Graziani graziani@cabrillo.edu 28


Redistributing from Classless to Classful
Protocols
OSPF IGRP
172.2 172.20.0.0/16
0.113
.192/
26
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28
0 .114. Marge Homer Lisa
172.2
172.20.112.0
172.20.115.0
Only the OSPF-learned routes with the 24-bit
mask are successfully redistributed into the
IGRP domain, which is also using a 24-bit mask.

• Careful consideration must be given when redistributing routes from a


classless routing process domain into a classful domain.
• Remember, a classful routing protocol does not advertise an
address mask along with the advertised destination address.
• For every route a classful router receives, one of two situations will
apply:
– The router will have one or more interfaces attached to the same
major (classful) network.
– The router will have no interfaces attached to the major (classful)
network.
Rick Graziani graziani@cabrillo.edu 29
Redistributing from Classless to Classful
Protocols
OSPF IGRP
172.2 172.20.0.0/16
0.113
.192/
26
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28
0 .114. Marge Homer Lisa
172.2
172.20.112.0
172.20.115.0
Only the OSPF-learned routes with the 24-bit
mask are successfully redistributed into the
IGRP domain, which is also using a 24-bit mask.

The router will have one or more interfaces attached to the same major
(classful) network.
• The router must use its own configured mask for that major network to
correctly determine the subnet of a packet’s destination address.

The router will have no interfaces attached to the major (classful) network.
• Only the major network address itself can be included in the
advertisement because the router has no way of know which subnet
mask to use.
Rick Graziani graziani@cabrillo.edu 30
Redistributing from Classless to Classful
Protocols
OSPF IGRP
172.2 172.20.0.0/16
0.113
.192/
26
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28
0 .114. Marge Homer Lisa
172.2
172.20.112.0
172.20.115.0
Only the OSPF-learned routes with the 24-bit
mask are successfully redistributed into the
IGRP domain, which is also using a 24-bit mask.

• This behavior of only advertising routes between interfaces with matching masks
also applies when redistributing from a classless routing protocol into a classful
routing protocol.

Routing Tables
• Homer: Has routes to all networks
• Marge: Has routes to all networks
• Lisa: Only knows about the IGRP subnets and the matching 24-bit redistributed
subnets, 172.20.112.0 and 172.20.115.0.
We will see how to successfully redistribute from classless to classful in the next
section.
Rick Graziani graziani@cabrillo.edu 31
Configuring
Redistribution

Redistribution is configured in two steps:


1. In the routing protocol configuration that is to receive the redistributed
routes, use the redistribute command.
2. Specify the metric to be assigned to the redistributed routes. Two
methods:
– Use the metric keyword
– Use the default-metric command
• Note: If both the metric and default-metric commands are
used the metric command takes precedence.
The values (parameters) used with these commands are dependent upon
the routing protocol being redistributed.
Rick Graziani graziani@cabrillo.edu 32
Redistribute connected
command and the default-
metric command

Note: The redistribute connected command is not affected by the default-


metric command.
• When using the redistribute connected command, those connected networks
are not affected by the default-metric command.
• Use the redistribute connected metric value option.
• Lab Manual p. 132: So once the OSPF, 'redistribute connected subnets'
command is entered on SJ1, those directly connected networks, being
redistributed into RIP, are no longer affected by the default-metric value.
For more info see: http://www.cisco.com/univercd
/cc/td/doc/product/software/ios122/122cgcr/fiprrp_r/ind_r/1rfindp2.htm
"You cannot use the 'default-metric' command to affect the metric used
to advertise 'connected' routes."

Rick Graziani graziani@cabrillo.edu 33


Configuring Redistribution
OSPF IGRP
172.2 172.20.0.0/16
0 .113.
192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28 E1 E0
0 .114. Marge Homer Lisa
172.2

Example (Homer): By the way this will not necessarily fix the previous issue of
Lisa not seeing all networks.

router igrp 1
redistribute ospf 1 metric 10000 100 255 1 1500
passive-interface ethernet 1
network 172.20.0.0

router ospf 1
redistribute igrp 1 metric 30 metric-type 1 subnets
network 172.20.112.2 0.0.0.0 area 0

Rick Graziani graziani@cabrillo.edu 34


Configuring Redistribution
OSPF IGRP
172.2 172.20.0.0/16
0 .113.
192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28 E1 E0
0 .114. Marge Homer Lisa
172.2
MTU

Example (Homer):
router igrp 1
redistribute ospf 1 metric 10000 100 255 1 1500
passive-interface ethernet 1
network 172.20.0.0
Bandwidth Delay Reliability Load
kbps mircoseconds n/255 n/255
• This configuration redistributes routes discovered by OSPF process 1 into
IGRP process 1.
• The metric portion assigns IGRP metrics to these routes.
• These values constitute the seed metric in our example.
• The seed metric is the initial metric value of an imported route.
Rick Graziani graziani@cabrillo.edu 35
Configuring Redistribution
OSPF IGRP
172.2 172.20.0.0/16
0 .113.
192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28 E1 E0
0 .114. Marge Homer Lisa
172.2

Example (Homer):
router ospf 1
redistribute igrp 1 metric 30 metric-type 1 subnets
network 172.20.112.2 0.0.0.0 area 0
• This configuration redistributes routes discovered by IGRP process 1 into OSPF
process 1.
• The metric portion assigns an OSPF cost of 30 to each of these routes.
– If a value is not specified for this option, and no value is specified using the
default-metric command, the default metric value is 0, except for OSPF
where the default cost is 20. The redistribution makes Homer an ASBR and
the redistributed routes are advertised as external routes, E2.
• The metric-type 1 portion specifies that the these routes will be advertised as E1
routes, and the internal costs will be added.
• The subnets keyword redistributes subnet details. Without it, only the classful
address would be redistributed. (more later)
Rick Graziani graziani@cabrillo.edu 36
Configuring Redistribution
OSPF IGRP
172.2 172.20.0.0/16
0 .113.
192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28 E1 E0
0 .114. Marge Homer Lisa
172.2

Alternative Method (Homer): Assuming RIP and EIGRP networks also attached
router ospf 1
redistribute igrp 1 metric-type 1 subnets
redistribute eigrp 1 metric-type 1 subnets
redistribute rip metric-type 1 subnets
default-metric 30
network 172.20.112.2 0.0.0.0 area 0
router igrp 1
redistribute ospf 1
redistribute eigrp 2
redistribute rip metric 50000 500 255 1 1500
passive-interface ethernet 1
default-metric 10000 100 255 1
network 172.20.0.0

Rick Graziani graziani@cabrillo.edu 37


Configuring Redistribution
OSPF IGRP
172.2 172.20.0.0/16
0 .113.
192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28 E1 E0
0 .114. Marge Homer Lisa
172.2

Alternative Method (Homer): Assuming RIP and EIGRP networks also attached
router ospf 1
redistribute igrp 1 metric-type 1 subnets
redistribute eigrp 1 metric-type 1 subnets
redistribute rip metric-type 1 subnets
default-metric 30
network 172.20.112.2 0.0.0.0 area 0

• default-metric command is useful when routes are being redistributed from


more than one source.
• default-metric command is used to assign an OSPF cost of 30 to all IGRP,
EIGRP, and RIP learned routes. (metric keyword is not used in the
redistribute command.)
Rick Graziani graziani@cabrillo.edu 38
Configuring Redistribution
OSPF IGRP
172.2 172.20.0.0/16
0 .113.
192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

48/28 E1 E0
0 .114. Marge Homer Lisa
172.2

Alternative Method (Homer): Assuming RIP and EIGRP networks also attached
router igrp 1
redistribute ospf 1
redistribute eigrp 2
redistribute rip metric 50000 500 255 1
passive-interface ethernet 1
default-metric 10000 100 255 1
network 172.20.0.0

• default-metric command is used where the metric command is not being


applied in the redistribute command.
• metric keyword takes precedence over the default-metric command

Rick Graziani graziani@cabrillo.edu 39


Configuring Redistribution
Router(config-router)# redistribute protocol [process-id]
{level-1 | level-1-2 | level-2} [metric metric-value]
[metric-type type-value] [match {internal | external 1 |
external 2}] [tag tag-value] [route-map map-tag] [weight
weight] [subnets]

(Optional) metric used for the redistributed route.


• If a value is not specified for the metric option, and no value is
specified using the default-metric command, the default metric
value is 0, except for OSPF where the default cost is 20.
• 0 is only understood by IS-IS and not by RIP, IGRP and EIGRP.
• RIP, IGRP and EIGRP must have the appropriate metrics assigned to
any redistributed routes, or redistribution will not work.
• Use a value consistent with the destination protocol.

Rick Graziani graziani@cabrillo.edu 40


Redistributing EIGRP and OSPF
EIGRP 2 EIGRP 2
172.16.1.0/24 192.168.4.72/29

Smithers 172.16.2.20/30 Burns


192.1 7
68.3.
64/27 192.168.4.4/30 1 60/2
OSPF 1 S1 S0 EIGRP 1 8.3.
192.16
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
4 E1 E0 192.
0/2 168.
68.1. Marge Homer Lisa 2.0/2
192.1 4
router eigrp 1
redistribute ospf 1 metric 1000 100 1 255
redistribute eigrp 2
passive-interface ethernet 1
network 192.168.3.0
router eigrp 2
redistribute ospf 1 metric 1000 100 1 255
redistribute eigrp 1
network 192.168.4.0
network 172.16.0.0
router ospf 1
redistribute eigrp 1 metric 50
redistribute eigrp 2 metric 100
network 192.168.3.33 0.0.0.0 area 0
Rick Graziani graziani@cabrillo.edu 41
Redistributing EIGRP and OSPF
EIGRP 2 EIGRP 2
172.16.1.0/24 192.168.4.72/29

Smithers 172.16.2.20/30 Burns


192.1 7
68.3.
64/27 192.168.4.4/30 .1 60/2
OSPF 1 S1 S0 EIGRP 1 9 2.1 68.3
1
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
4 E1 E0 192.
0/2 168.
9 2.1 68.1. Marge Homer Lisa 2.0/2
4
1

router eigrp 1
redistribute ospf 1 metric 1000 100 1 255
redistribute eigrp 2
passive-interface ethernet 1
network 192.168.3.0
router eigrp 2
redistribute ospf 1 metric 1000 100 1 255
redistribute eigrp 1
network 192.168.4.0
network 172.16.0.0
• Notice there are no metrics configured for redistribution between EIGRP
processes.
• The processes use the same metrics, so the metrics are tracked accurately
across the redistribution boundary.
• Redistributed routes are tagged as EIGRP external routes (D EX).
Rick Graziani graziani@cabrillo.edu 42
Redistributing EIGRP and OSPF
EIGRP 2 EIGRP 2
172.16.1.0/24 192.168.4.72/29

Smithers 172.16.2.20/30 Burns


192.1 7
68.3.
64/27 192.168.4.4/30 .1 60/2
OSPF 1 S1 S0 EIGRP 1 9 2.1 68.3
1
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
4 E1 E0 192.
0/2 168.
9 2.1 68.1. Marge Homer Lisa 2.0/2
4
1

Without subnets,
router ospf 1 Homer only
redistribute eigrp 1 metric 50 subnets redistributes
redistribute eigrp 2 metric 100 subnets 192.168.2.0/24 to
network 192.168.3.33 0.0.0.0 area 0 Marge.

• There is a problem with redistributing EIGRP routes into OSPF.


• The only non-OSPF routes in Marge’s routing table is the E2 route,
192.168.2.0/24
• Why? Only classful network addresses that are not directly
connected to the redistributing router, Homer, will be redistributed
into OSPF.
• Solution? Include the keyword subnets.
Remember, redistribute connected only redistributes directly connected
networks.
Rick Graziani graziani@cabrillo.edu 43
Redistributing OSPF: E1 vs E2

10.2.3.0/24
OSPF Cost = 50 EIGRP

Bart 1
u te 100
Ro
10.2.3.0/24

Ro
ute 10
2

10.2.3.0/24
Cost = 100

• By default, external routes are redistributed into OSPF as type 2 routes


(E2).
• E2 routes include only the external cost of the route.
• As a result, Bart will choose the preferred route of route 1 with a
cost of 50, over route 2 with a cost of 100.
• In this scenario, this is not the ideal route.
Rick Graziani graziani@cabrillo.edu 44
Redistributing OSPF: E1 vs E2

10.2.3.0/24
OSPF Cost = 50 EIGRP

Bart e1
ut 100
Ro
10.2.3.0/24

Ro
ut e2 10

10.2.3.0/24
Cost = 100

• To redistribute routes into OSPF as E1, the keyword metric-type 1


is added to the redistribution commands in the boundary routers.
• Bart will now choose route 2, with a cost of 110 (100+10) over
route 1, with a cost of 150 (50 + 100).

Rick Graziani graziani@cabrillo.edu 45


OSPF and Redistribution (note)

• “Before Cisco IOS Software Release 12.1.3, when redistributing connected


routes into OSPF, connected networks included in the network statements
under router OSPF advertised in Type-1, Type-2, or Type-3 link-state
advertisements (LSAs) were also announced in Type-5 LSAs.”
• In other words, if you are using the redistributed connected command, any
connected networks included using the OSPF network command, were not
only advertised as normal using LSA Type 1, 2, or 3, but also as an external
LSA Type-5.

• “Memory is required to store those Type-5 LSAs. The storage also requires a
CPU to process the LSAs during full or partial Shortest Path First (SPF) runs
and to flood them when some instability occurs.”
• “In Cisco IOS Software Release 12.1(3) and later, the Type-5 LSAs are no
longer created for connected networks included in the network statements
under router OSPF.”

Redistributing Connected Networks into OSPF


• http://www.cisco.com/warp/public/104/redist-conn.html

Rick Graziani graziani@cabrillo.edu 46


OSPF and RIP Example

Rick Graziani graziani@cabrillo.edu 47


OSPF and RIP Example

Router A
router rip
passive-interface serial0/0 0
passive-interface serial0/1 1
redistribute ospf 109 match internal
external 1 external 2
default-metric 10

router ospf 109


redistribute rip subnets
network 130.10.62.0 0.0.0.255 area 0
network 130.10.63.0 0.0.0.255 area 0
distribute-list 11 out rip

access-list 11 permit 130.10.8.0


0.0.7.255
access-list 11 deny 0.0.0.0
255.255.255.255

Rick Graziani graziani@cabrillo.edu 48


• keywords, match internal external 1 and
external 2, instruct RIP to redistribute internal OSPF
routes, as well as external Type 1 and Type 2 routes. This
is the default for OSPF redistribution. These keywords are
required only if its behavior is to be modified.
• These commands prevent RTA from advertising networks
in other RIP domains onto the OSPF backbone. This
prevents other boundary routers from using false
information and forming a loop. When an OSPF backbone
area is in place, the RIP domains can easily be converted
into OSPF areas.

Rick Graziani graziani@cabrillo.edu 49


Redistribution between EIGRP and IGRP

Same AS numbers Different AS numbers


Router Two Router Two
router eigrp 2000 router eigrp 2000
network 172.16.1.0 redistribute igrp 1000
! network 172.16.1.0
router igrp 2000 !
network 10.0.0.0 router igrp 1000
redistribute eigrp 2000
(automatic redistribution) network 10.0.0.0

Rick Graziani graziani@cabrillo.edu 50


Redistribution between EIGRP and IGRP
Router TWO
router eigrp 2000
redistribute igrp 1000
network 172.16.1.0
!
router igrp 1000
redistribute eigrp 2000
network 10.0.0.0

• IGRP metrics are preserved when routes are redistributed into EIGRP with a
different autonomous system, but they are scaled by multiplying the IGRP
metric by the constant 256.
– “The redistribution of IGRP/EIGRP into another IGRP/EIGRP process
doesn't require any metric conversion, so there is no need to define
metrics or use the default-metric command during redistribution.” Cisco
• There is one caveat to redistribution between IGRP and EIGRP that should be
noted.
– If the network is directly connected to the router doing the redistribution, it
advertises the route with a metric of 1.

Rick Graziani graziani@cabrillo.edu 51


Redistribution between EIGRP and IGRP

• There are several other caveats which are not important here,
but if you are interested or have a need, they can be examined
at:
• http://www.cisco.com/warp/public/103/eigrp4.html

Rick Graziani graziani@cabrillo.edu 52


Redistribution and Summarization - FYI

• This is going beyond the scope of the material or the exam, but
here is a quick example of redistribution and summarization.
• This example does not do this topic justice, as there are several
issues, including the routing table outputs, that are not
discussed.
• Let’s take a quick look anyways…

Rick Graziani graziani@cabrillo.edu 53


Redistribution and Route Summarization
EIGRP 2 EIGRP 2
172.16.1.0/24 192.168.4.72/29

Smithers 172.16.2.20/30 Burns


192.1 /27
68.3. 192.168.4.4/30 160
64/27 8.3.
OSPF 1 S1 S0 EIGRP 1 2.16
19
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
E1 E0 192.
68.1 .0/24 168.
2.0/2
192.1 Marge Homer Lisa 4
192.168.3.0/25
192.168.3.128/25

• EIGRP, OSPF and IS-IS have the capability to summarize redistributed routes.
• Summarization is most useful if the IP subnet addresses have been planned for
summarization.
• For example, the 192.168.3.0 subnets within the OSPF domain all fall under the
summary address 192.168.3.0/25.
192.168.3.0/25
• The subnets of the same major address within the EIGRP 1 domain,
192.168.3.0 all fall under the summary address 192.168.3.128/25.
192.168.3.128/25
• If subnet 192.168.3.0/27 were to be connected to Lisa, that single destination
would have to be advertised separately from the summary address, because it
falls under the OSPF summarization.
Rick Graziani graziani@cabrillo.edu 54
Redistribution and Route Summarization
EIGRP 2 EIGRP 2
172.16.1.0/24 192.168.4.72/29

Smithers 172.16.2.20/30 Burns


192.1 /27
68.3. 192.168.4.4/30 160
64/27 8.3.
OSPF 1 S1 S0 EIGRP 1 2.16
19
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
E1 E0 192.
68.1 .0/24 168.
2.0/2
192.1 Marge Homer Lisa 4
192.168.3.128/25 172.16.0.0/16

• The command summary-address specifies a summary address and mask to


an OSPF process.
• This command is used only on ASBRs – summarization at ABRs is
accomplished with the area range command.
router ospf 1
summary-address 192.168.3.128 255.255.255.128
summary-address 172.16.0.0 255.255.0.0
redistribute eigrp 1 metric 50 subnets
redistribute eigrp 2 metric 100 subnets
network 192.168.3.33 0.0.0.0 area 0

Rick Graziani graziani@cabrillo.edu 55


Redistribution and Route Summarization
EIGRP 2 EIGRP 2
172.16.1.0/24 192.168.4.72/29

Smithers 172.16.2.20/30 Burns


192.1 /27
68.3. 192.168.4.4/30 160
64/27 8.3.
OSPF 1 S1 S0 EIGRP 1 2.16
19
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
E1 E0 192.
68.1 .0/24 168.
2.0/2
192.1 Marge Homer Lisa 4
192.168.3.128/25 172.16.0.0/16

• Marge’s routing table will include both of these E2 summary routes with a cost of
50 for the EIGRP 1 route of 192.168.3.128/25 and a cost of 100 for the EIGRP
100 route of 172.16.0.0/16.

router ospf 1
summary-address 192.168.3.128 255.255.255.128
summary-address 172.16.0.0 255.255.0.0
redistribute eigrp 1 metric 50 subnets
redistribute eigrp 2 metric 100 subnets
network 192.168.3.33 0.0.0.0 area 0

Rick Graziani graziani@cabrillo.edu 56


Redistribution and Route Summarization
EIGRP 2 192.168.3.0/24 EIGRP 2
172.16.1.0/24 192.168.4.72/29
192.168.0.0/16
Smithers 172.16.2.20/30 Burns
192.1 /27
68.3. 192.168.4.4/30 160
64/27 8.3.
OSPF 1 S1 S0 EIGRP 1 2.16
19
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
E1 E0 192.
68.1 .0/24 168.
2.0/2
192.1 Marge Homer Lisa 4
192.168.3.0/25
172.16.0.0/24
192.168.4.0/24

• Summarization for EIGRP is interface specific.


interface ethernet 0
ip add 192.168.3.129 255.255.255.224
ip summary-address eigrp 1 192.168.3.0 255.255.255.128
ip summary-address eigrp 1 172.16.0.0 255.255.0.0
ip summary-address eigrp 1 192.168.4.0 255.255.255.0
interface serial 0
ip add 192.168.4.5 255.255.255.252
ip summary-address eigrp 2 192.168.3.0 255.255.255.0
interface serial 1
ip add 172.16.2.21 255.255.255.252
ip summary-address eigrp 2 192.168.0.0 255.255.0.0

Rick Graziani graziani@cabrillo.edu 57


Redistribution and Route Summarization
EIGRP 2 192.168.3.0/24 EIGRP 2
172.16.1.0/24 192.168.4.72/29
192.168.0.0/16
Smithers 172.16.2.20/30 Burns
192.1 /27
68.3. 192.168.4.4/30 160
64/27 8.3.
OSPF 1 S1 S0 EIGRP 1 2.16
19
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
E1 E0 192.
68.1 .0/24 168.
2.0/2
192.1 Marge Homer Lisa 4
192.168.3.0/25
172.16.0.0/24
192.168.4.0/24

• Take a look at which routes are being summarized and why.


• Notice that the 192.160.0.0/16 network can be summarized to Smithers as Smithers has
only 172.16.0.0 connected networks.
• Smithers still gets the 192.168.4.0/24 automatically summarized route from within its
EIGRP 2 routing domain.
• Burns has 192.168.3.0/24 summarized, as it has 192.168.4.0 subnets and learns about
172.16.0.0 routes via EIGRP.
• Routes learned from a different EIGRP process gets tagged as “external” (EX), but
summarized routes from another EIGRP process are not.
• For complete routing tables and a detailed discussion, including some very interesting
surprises, refer to Routing TCP/IP Vol. I by Jeff Doyle.
Rick Graziani graziani@cabrillo.edu 58
That’s it!

• Special thanks to Homer Simpson, Teaching Assistant and


CCDP (Crispy Cream Donut Professional)

Rick Graziani graziani@cabrillo.edu 59

You might also like