Welcome to Scribd, the world's digital library. Read, publish, and share books and documents. See more
Download
Standard view
Full view
of .
Look up keyword or section
Like this
19Activity
0 of .
Results for:
No results containing your search query
P. 1
Mikrotik VPN

Mikrotik VPN

Ratings: (0)|Views: 1,809|Likes:

More info:

Published by: Edy Setiadji Susanto on Feb 12, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

08/11/2013

pdf

text

original

 
PDF generated using the open source mwlib toolkit. See http://code.pediapress.com/ for more information.PDF generated at: Sat, 12 Feb 2011 02:03:40 UTC
Mikrotik
VPN
 
Manual:BCP bridging (PPP tunnel bridging)1
Manual:BCP bridging (PPP tunnel bridging)
Applies to RouterOS:
 
v3, v4
Summary
RouterOS supports BCP (Bridge Control Protocol) for PPP, PPTP, L2TP and PPPoE interfaces. BCP allows tobridge Ethernet packets through the PPP link. Established BCP is independent part of the PPP tunnel, it is not relatedto any IP address of PPP interface, bridging and routing can happen at the same time independently. BCP can beused instead of EoIP + used VPN Tunnel or WDS link over the wireless network.
Requirements
BCP (Bridge Control Protocol) should be enabled on both sides (PPP server and PPP client) to make it work.MikroTik RouterOS can be used with other PPP device, that supports BCP accordingly to the standards, but BCPenabled is necessary.
Configuration Example
We need to interconnect two remote offices and make them in one Ethernet network. We have requirement to useencryption to protect data exchange between two offices. Let's see, how it is possible with PPTP tunnel and BCPprotocol usage
 
Manual:BCP bridging (PPP tunnel bridging)2
Configuration Diagramm
Simple configuration is like this. We have two offices, which are remotely located. Office I is going to be used asPPTP server, Office 2 is going to be used PPTP client. Below you will see how to set configuration using Winboxand CLI.
BCP Configuration (CLI)Office 1 configuration
First we need to create bridge interface and make sure that bridge will always have MAC address of existinginterface. Reason for that is simple - when BCP is used PPP bridge port do not have any MAC address.
/interface bridge add name=bridge_local protocol-mode=rstp/interface bridge port add bridge=bridge_local interface=ether1_local/interface bridge set bridge_local admin-mac=xx:xx:xx:xx:xx:xx//// where xx:xx:xx:xx:xx:xx is MAC address of the ether1_local interface
Now we can assign local and public addresses to proper interfaces.
/ip address add address=192.168.88.1/24 interface=bridge_local/ip address add address=1.1.1.1/24 interface=ether2_public
In case you use PPP only for bridging, configuration of the ppp profile and secret is very easy - just assign user nameand password in secret) and specify bridge option in the profile. PPP bridging does NOT require any IP addresses,but when normal PPP is necessary, specify local and remote addresses on server side as normally.
/ppp profile add name=ppp_bridging bridge=bridge_local use-encryption=yes/ppp secret add profile=ppp_bridging name=ppp1 password=ppp1
When bridging packets PPP tunnel need to pass packets with Layer-2 (MAC) header included , so default interfaceMTU (in case of pptp it is 1460) is not sufficient for this task. To ensure proper operation itis suggested to overridethe value by specifying MRRU option in server settings to a higher value.

Activity (19)

You've already reviewed this. Edit your review.
1 thousand reads
1 hundred reads
nekicova liked this
phaysetha liked this
a_costea liked this
anthonycacciola liked this

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->