Welcome to Scribd, the world's digital library. Read, publish, and share books and documents. See more
Download
Standard view
Full view
of .
Save to My Library
Look up keyword or section
Like this
6Activity

Table Of Contents

Preface
• Document Layout
DOCUMENT LAYOUT
CONVENTIONS USED IN THIS GUIDE
RECOMMENDED READING
THE MICROCHIP WEB SITE
DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE
CUSTOMER SUPPORT
Part 1 – MPLAB IDE
Chapter 1. What is MPLAB®
1.1 AN OVERVIEW OF EMBEDDED SYSTEMS
1.2 THE DEVELOPMENT CYCLE
1.3 PROJECT MANAGER
1.4 LANGUAGE TOOLS
1.5 TARGET DEBUGGING
1.6 DEVICE PROGRAMMING
1.7 COMPONENTS OF MPLAB IDE
1.8 MPLAB IDE DOCUMENTATION
1.9 MPLAB IDE ON-LINE HELP
1.10 MPLAB IDE UPDATES AND VERSION NUMBERING
Chapter 2. Getting Started with MPLAB IDE: A Basic Tutorial
2.1 INTRODUCTION
2.2 MPLAB IDE FEATURES AND INSTALLATION
2.3 TUTORIAL OVERVIEW
2.4 SELECTING THE DEVICE
2.5 CREATING THE PROJECT
2.6 SETTING UP LANGUAGE TOOLS
2.7 NAMING THE PROJECT
2.8 ADDING FILES TO THE PROJECT
2.9 BUILDING THE PROJECT
2.10 CREATING CODE
2.11 BUILDING THE PROJECT AGAIN
2.12 TESTING CODE WITH THE SIMULATOR
2.13 TUTORIAL SUMMARY
Chapter 3. Walk-Through and Tutorial
3.1 INTRODUCTION
3.2 SELECTING A DEVICE
3.3 SETTING UP CONFIGURATION BITS
3.4 CREATING SOURCE CODE WITH THE EDITOR
3.5 CREATING A NEW PROJECT
3.6 USING THE PROJECT WIZARD
3.7 SETTING UP THE LANGUAGE TOOLSUITE
3.8 NAMING AND LOCATING THE PROJECT
3.9 ADDING FILES
3.10 COMPLETING THE PROJECT
3.11 VIEWING THE PROJECT WINDOW
3.12 SETTING BUILD OPTIONS
3.13 BUILDING THE PROJECT
3.14 CHOOSING A DEBUGGER
3.15 RUNNING YOUR CODE
3.16 VIEWING DEBUG WINDOWS
3.17 USING WATCH WINDOWS
3.18 USING BREAKPOINTS
3.19 CHOOSING A PROGRAMMER
3.20 PROGRAMMING YOUR PART
3.21 USING MICROCHIP HELP
• Navigating in the Help Viewer
3.21.1 Navigating in the Help Viewer
3.21.2 Types of Help Available
Chapter 4. Projects and Workspaces
4.1 INTRODUCTION
4.2 USING THE PROJECT WIZARD
• Project Wizard – Welcome
• Project Wizard – Select Device
• Project Wizard – Select a Language Toolsuite
4.2.1 Project Wizard – Welcome
4.2.2 Project Wizard – Select Device
4.2.3 Project Wizard – Select a Language Toolsuite
4.2.4 Project Wizard – Name Your Project
4.2.5 Project Wizard – Add Files
4.2.6 Project Wizard – Summary
4.3 CREATING/UPDATING ANY PROJECT
4.4 SETTING UP A PROJECT STRUCTURE – RELATIVE PATHS
4.5 PROJECT FOLDERS AND FILES
4.6 USING A VERSION-CONTROL SYSTEM (VCS)
4.7 SETTING UP/CHANGING A PROJECT
• Create a New Project
• New Project Window
4.7.1 Create a New Project
4.7.2 New Project Window
4.7.3 Setting Up a Project – Set Up Language Tools
4.7.4 Setting Up a Project – Choose Toolsuite
4.7.5 Setting Up a Project – Add Files
4.7.6 Setting Up a Project – Set Build Options
4.7.7 Setting Up a Project – Save and Build
4.8 USING A SINGLE PROJECT AND WORKSPACE
4.9 USING MULTIPLE PROJECTS IN A SINGLE WORKSPACE
4.10 BUILDING AN APPLICATION WITHOUT A PROJECT
Chapter 5. Integrated Tools
5.1 INTRODUCTION
• Language Toolsuites
5.2 LANGUAGE TOOLSUITES
5.3 MICROCHIP LANGUAGE TOOLS
5.3.1 Microchip PICmicro Language Tools
5.3.2 Microchip dsPIC Language Tools
5.4 THIRD PARTY LANGUAGE TOOLS
• B Knudsen Data Language Tools
• Byte Craft Language Tools
• CCS Language Tools
5.4.1 B Knudsen Data Language Tools
5.4.2 Byte Craft Language Tools
5.4.3 CCS Language Tools
5.4.4 HI-TECH Language Tools
5.4.5 IAR Language Tools
5.4.6 microEngineering Labs Language Tools
5.5 EDITORS
5.6 SIMULATORS
5.7 IN-CIRCUIT EMULATORS
5.8 IN-CIRCUIT DEBUGGERS
5.9 PROGRAMMERS
5.10 THIRD PARTY TOOLS
Chapter 6. MPLAB IDE Troubleshooting
6.1 INTRODUCTION
6.2 COMMON PROBLEMS/FAQ
• I cannot get my language tools to work with MPLAB IDE
• I can't see all of the characters in the displays
I cannot get my language tools to work with MPLAB IDE
I can't see all of the characters in the displays
I have recently ported my projects from one PC to another. They don't
work or worked for a while but now do not
Some of the items on the Project menu and toolbar are grayed out
When stepping through high-level code, if I step into a function with no
source code, a bunch of Program Memory windows start popping up
I cannot find all of my object files
My program keeps resetting. What's going on?
I can't Halt Animate
I tried to Step Over / Step Out of a function/subroutine, and now my
6.3 ERROR MESSAGES
6.4 LIMITATIONS
Part 2 – MPLAB IDE Reference
Chapter 7. MPLAB IDE Desktop
7.1 INTRODUCTION
• MPLAB IDE Menu Bar
7.2 MPLAB IDE MENU BAR
• Basic Debug Options
Basic Debug Options
• Basic Programmer Options
Basic Programmer Options
7.3 MPLAB IDE TOOLBARS
7.3.1 Standard Toolbar
7.3.2 Project Manager Toolbar
7.3.4 Programmer Toolbar
7.3.5 Checksum Toolbar
7.4 MPLAB IDE STATUS BAR
Chapter 8. MPLAB IDE Windows
8.1 INTRODUCTION
8.2 CHANGING WINDOW DATA AND PROPERTIES
8.3 CODE DISPLAY WINDOW SYMBOLS
8.4 PROJECT WINDOW
• Project Window Display
• Project Window Menus
8.4.1 Project Window Display
8.4.2 Project Window Menus
8.4.3 Project Window FAQ
8.5 OUTPUT WINDOW
8.6 DISASSEMBLY LISTING WINDOW
8.7 HARDWARE STACK WINDOW
8.7.1 Hardware Stack Window Display
Stack Return Address
8.7.2 Hardware Stack Window Menu
8.7.3 Hardware Stack Window FAQ
• Understand the Return Address information?
See Section 8.7.1 “Hardware Stack Window Display”
8.8 PROGRAM MEMORY WINDOW
• Program Memory Window Display
• Program Memory Window Menu
• Program Memory Window FAQ
8.8.1 Program Memory Window Display
• Machine or Symbolic
8.8.1.3 PSV MIXED (dsPIC DEVICES ONLY)
8.8.1.4 PSV DATA (dsPIC DEVICES ONLY)
8.8.2 Program Memory Window Menu
8.8.3 Program Memory Window FAQ
8.9 FILE REGISTERS WINDOW
• File Registers Window Display
• File Registers Window Menu
• File Registers Window FAQ
8.9.1 File Registers Window Display
• XY Data (dsPIC devices only)
8.9.1.3 XY DATA (dsPIC DEVICES ONLY)
8.9.2 File Registers Window Menu
8.9.3 File Registers Window FAQ
8.10 EEPROM WINDOW
• EEPROM Window Display
• EEPROM Window Menu
8.10.1 EEPROM Window Display
8.10.2 EEPROM Window Menu
8.11 LCD PIXEL WINDOW
• LCD Pixel Window Display
8.11.1 LCD Pixel Window Display
8.11.2 LCD Pixel Window Menu
8.11.3 LCD Pixel Window FAQ
8.12 WATCH WINDOW
• Watch Window Display
8.12.1 Watch Window Display
Watch Window – C Language Usage
8.13 SPECIAL FUNCTION REGISTERS WINDOW
8.13.1 SFRs Window Display
8.14 TRACE MEMORY WINDOW
• Trace Window Display
• Trace Window Menu
8.14.1 Trace Window Display
8.15 CONFIGURATION BITS WINDOW
• Configuration Bits Window Display
• Configuration Bits Window Menu
• Configuration Bits Window FAQ
8.15.1 Configuration Bits Window Display
8.15.2 Configuration Bits Window Menu
8.15.3 Configuration Bits Window FAQ
8.16 FILE (EDITOR) WINDOW
• File Window Display
8.16.1 File Window Display
Chapter 9. MPLAB IDE Dialogs
9.1 INTRODUCTION
9.2 ABOUT MPLAB IDE DIALOG
9.3 ADD WATCH DIALOG
9.4 BREAKPOINTS DIALOG
9.5 BUILD OPTIONS DIALOG
9.6 EXPORT HEX FILE DIALOG
9.7 EXTERNAL MEMORY SETTING DIALOG
9.8 FILE MANAGEMENT DIALOG
9.9 FILL MEMORY/REGISTERS DIALOG
9.10 FIND IN PROJECT FILES DIALOG
9.11 FIND AND REPLACE DIALOGS
9.12 HELP TOPICS DIALOG
9.13 IMPORT DIALOG
9.14 NEW PROJECT DIALOG
9.15 PROJECT-DISPLAY PREFERENCES DIALOG
9.16 PROJECT WIZARD DIALOGS
9.17 PROPERTIES DIALOG
9.18 SAVE PROJECT AS DIALOG
9.19 SELECT DEVICE DIALOG
Select Device dialog
9.20 SELECT LANGUAGE TOOLSUITE DIALOG
9.21 SET LANGUAGE TOOL LOCATION DIALOG
9.24 USER ID MEMORY DIALOG
9.25 VERSION-CONTROL DIALOG
10.4 SAVED INFORMATION
Part 3 – MPLAB Editor
Chapter 11. Using the Editor
11.1 INTRODUCTION
11.2 CONFIGURING THE EDITOR
• Editor Options Dialog
11.2.1 Editor Options Dialog
11.2.2 Editor Color Customization Dialog
11.3 WORKING WITH FILES
• Creating a New File
• Opening Files
• Printing Files
11.3.1 Creating a New File
11.4 WORKING WITH TEXT
• Selecting Text
11.4.2 Moving to a Specific Line
11.4.9 Undoing Editor Actions
11.4.10 Redoing Editor Actions
11.5 WORKING WITH DEBUG FEATURES
• Filter Trace
11.6 KEYBOARD FEATURES
11.6.2 Movement and Selection
11.6.3 Special Characters
Timers
Comparators (Limited)
A/D Converter (Limited)
USART
EEPROM Data Memory
12.3.3 16-Bit Core Device Model – PIC17
12.3.3.1 16-BIT CORE (PIC17) I/O PINS
12.3.3.2 16-BIT CORE (PIC17) INTERRUPTS
12.3.3.3 16-BIT CORE (PIC17) CPU
12.3.3.4 16-BIT CORE (PIC17) PROCESSOR MODES
12.3.3.5 16-BIT CORE (PIC17) PERIPHERALS
• Timer1 and Timer2
Timer0
Timer1 and Timer2
Timer3 and Capture
12.3.4 16-Bit Core Device Model – PIC18
• 16-Bit Core (PIC18) I/O Pins
• 16-Bit Core (PIC18) Interrupts
12.3.4.1 16-BIT CORE (PIC18) I/O PINS
12.3.4.2 16-BIT CORE (PIC18) INTERRUPTS
12.3.4.4 16-BIT CORE (PIC18) PERIPHERALS
12.4 SIMULATOR MODEL – dsPIC DSCs
• Exceptions (Traps/Interrupts)
• System Integration Block
12.4.2 Exceptions (Traps/Interrupts)
12.4.3 System Integration Block
12.5 SIMULATOR EXECUTION
• Execution Speed
12.5.2 Execution on Instruction Cycle Boundaries
Chapter 13. Getting Started with MPLAB SIM
13.1 INTRODUCTION
• Using the Stopwatch
• Using Stimulus
13.2 USING THE STOPWATCH
13.3 USING STIMULUS
13.4 USING SIMULATOR TRACE
• Tracing Execution
• Trace Window
• Export Trace Buffer
13.4.3 Export Trace Buffer
13.5 USING EXTERNAL MEMORY
13.5.1 External Memory Access
13.5.2 Simulating External Memory Access
1. Setting Configuration Bits
2. Setting External Memory
13.5.2.1 SETTING CONFIGURATION BITS
Chapter 14. Using Stimulus
14.1 INTRODUCTION
• SCL Generator Dialog
14.2 SCL GENERATOR DIALOG
SFR Values As Triggers
14.2.1 Pin/Register Actions
14.2.2 Advanced Pin/Register
14.2.3 Add/Remove Signals Dialog
14.2.5 Register Injection
14.3 STIMULUS CONTROLLER DIALOG
14.4 STIMULUS INPUT INTERACTION
Chapter 15. Using Stimulus – PIC17 Devices
15.1 INTRODUCTION
15.2 USING PIN STIMULUS
• Creating/Editing Pin Stimulus
15.2.1 Creating/Editing Pin Stimulus
15.2.2 Applying Pin Stimulus
15.2.3 Pin Stimulus Display
15.3 USING FILE STIMULUS
• Creating/Editing File Stimulus
15.3.1 Creating/Editing File Stimulus
15.3.1.1 CREATING/EDITING A FILE STIMULUS FILE (.FSTI)
15.3.1.2 CREATING/EDITING A SYNCHRONOUS STIMULUS FILE (.SSTI)
15.3.1.3 CREATING/EDITING A REGISTER STIMULUS FILE (.RSTI)
15.3.2 Applying File Stimulus
15.3.3 File Stimulus Display
Chapter 16. Simulator Troubleshooting
16.1 INTRODUCTION
• Common Problems/FAQ
16.2 COMMON PROBLEMS/FAQ
16.3 LIMITATIONS
Chapter 17. Simulator Reference
17.1 INTRODUCTION
• Debugging Functions
17.2 DEBUGGING FUNCTIONS
17.3 SETTINGS DIALOG
• Osc/Trace tab
• Break Options tab
17.4 SETTINGS DIALOG – PIC17 DEVICES
• Limitations tab
Glossary
Index
WORLDWIDE SALES AND SERVICE
0 of .
Results for:
No results containing your search query
P. 1
mplab

mplab

Ratings: (0)|Views: 733 |Likes:
Published by amierlearing

More info:

Published by: amierlearing on Mar 13, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

03/04/2013

pdf

text

original

You're Reading a Free Preview
Pages 5 to 147 are not shown in this preview.
You're Reading a Free Preview
Page 152 is not shown in this preview.
You're Reading a Free Preview
Pages 157 to 171 are not shown in this preview.
You're Reading a Free Preview
Pages 179 to 240 are not shown in this preview.

Activity (6)

You've already reviewed this. Edit your review.
1 hundred reads
1 thousand reads
alger64 liked this
sivaganesh1903 liked this
Hwanki Zester liked this
hle5457 liked this

You're Reading a Free Preview

Download
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->