You are on page 1of 198

Graphisoft ® ArchiCAD ® Creating GDL Objects

Interactive Training Guide

Graphisoft ® ArchiCAD ® Creating GDL Objects Interactive Training Guide
Graphisoft ® ArchiCAD ® Creating GDL Objects Interactive Training Guide

Graphisoft

Visit the Graphisoft website at http://www.graphisoft.com for local distributor and product availability information.

Graphisoft ® ArchiCAD ® 11 Creating GDL Objects – Interactive Training Guide

Copyright © 2008 by Graphisoft, all rights reserved. Reproduction, paraphrasing or translation without express prior written permission is strictly prohibited.

Trademarks

ArchiCAD ® , Virtual Building™, Virtual Trace™ and Virtual Building Solutions™ are trademarks of Graphisoft. All other trademarks are the property of their respective holders.

CONTENTS

Preface

5

. How to learn GDL?

What is

.

. Getting started with the ArchiCAD Interactive Training

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.5

.5

.5

Step 1: Download and install ArchiCAD

 

.6

Step 2: Create the interactive training environment

.7

Step 3: How to use Movie Player in ArchiCAD?

.9

1.

Saving 2D Symbols from the Floor Plan

 

11

1.1 Creating the Symbol

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

11

1.2 Saving the Object

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

12

1.3 Checking the Result

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

13

1.4 Final Touches

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

15

1.5 Using the 2D Symbol View

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

17

2.

Saving 3D models from the floorplan as GDL objects

 

21

2.1

Overview

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

21

2.2

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.22

2.3

Creating the GDL

.25

2.4

Editing the GDL Object

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.28

3. Rotating Auto-saved Objects. Adding Material Parameters to Library

 

35

3.1

Overview

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.35

3.2

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.36

3.3

Creating the GDL

 

.38

3.4

Editing the GDL Object

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

41

3.5

Adding Material Parameters

 

.44

4.

Auto saving rectangular doors. Creating Custom Door

 

48

4.1

Overview

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.48

4.2

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.49

4.3

Creating the GDL

 

.53

4.4 Editing the GDL Object

55

4.5 Creating Custom Door Panels

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

57

5.

Auto Saving Non-rectangular Windows.

 

63

5.1 .

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

63

5.2 Modeling

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

64

5.3 Creating the GDL Object

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

68

5.4 Enhancing the 2D Symbol

 

71

5.5 Adding Material Parameters

 

73

5.6 Make a Preview Picture with Lightworks

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

75

6.

Basics of GDL Scripting

 

79

6.1 .

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

79

6.2 Creating Parameters

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

82

6.3 Creating the 3D

 

84

6.4 Assigning materials

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

92

6.5 Creating value lists for parameters

 

94

6.6 Checking the 3D

 

96

6.7 Creating the 2D of the

 

97

6.8 Placing and working with the

 

98

7.

Basics of GDL Scripting – Part 2

 

103

7.1 .

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

103

7.2 Creating the parameters

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

104

7.3 Creating the master Script

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.111

7.4 Creating the 3D

 

114

8.

Basics of GDL Scripting – Part 3

 

126

8.1 .

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

126

8.2 Creating the Legs

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

132

8.3 Creating the 2D

 

141

8.4 Testing the completed object

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

149

Contents

9. Advanced GDL Scripting

 

151

9.1

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

151

9.2

Creating the Parameters

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

152

9.3

Creating the Parameter

 

156

9.4

Creating the 3D

162

9.5

Creating the macro call

 

168

9.6

Creating the 2D Script

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

172

10.

Advanced GDL Scripting – continued

 

175

Part 1 – Opening Door

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

175

10.1 Overview

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.175

10.2 Creating the parameters

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.176

10.3 Creating the 3D

 

.179

10.4 Creating the animation

 

.180

Part 2 – Construction

 

.185

10.5 Bringing in data from Google Earth

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.185

10.6 Creating the Object from the Mass

 

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.190

10.7 Creating the parameters

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.193

10.8 Creating the 3D

 

.194

10.9 Creating the animation

 

.196

Preface

PREFACE

The following ten Interactive Training Guide (ITG) chapters will cover the most important aspects of GDL object making in ArchiCAD. The first five lessons will illustrate how you can create Library Parts without any GDL scripting, by using only existing ArchiCAD tools. In the second part we will show you some basic GDL programming examples. This Training Guide was developed to introduce the world of GDL to a wide audience so that users can increase their productivity in ArchiCAD.

WHAT IS GDL?

There is a powerful technology at the heart of ArchiCAD – GDL. This three letter abbreviation stands for Geometric Description Language. GDL has been developed specially for ArchiCAD to describe 2D and 3D elements in a user-friendly parametric programming environment. GDL objects are stored in external libraries; the objects are called Library Parts in ArchiCAD. Each Library Part contains several text-based scripts dedicated to different purposes, including 2D symbols, 3D models and descriptions for quantity take-offs. Whenever a GDL object is inserted into an ArchiCAD project, only a reference to the external Library Part is saved with the file. However, users have the option of saving the project as an archive, which stores the Library Parts in the file as well.

HOW TO LEARN GDL?

In addition to this Training Guide there are several other learning tools available for those who want to know more about GDL:

• The GDL Reference Manual, available from ArchiCAD Help, contains the complete list of commands and detailed descriptions of GDL syntax. This is necessarily the prime source of information for anyone who wants to learn GDL.

• Beginners who are not interested in advanced GDL scripting can find useful information in the Introduction to Object Making PDF document.

• Those who want to learn how to create more advanced parametric objects with scripting can buy the GDL Cookbook from David Nicholson Cole.

• Finally, it is recommended that professional library developers read the GDL Technical Standards document to understand Graphisoft object standards.

GETTING STARTED WITH THE ARCHICAD INTERACTIVE TRAINING GUIDE

This interactive training guide was written to ease and speed up your learning process, saving you time. Please read the three steps of this short introduction to familiarize yourself with the interactive training environment in ArchiCAD. Every chapter of the interactive training guide contains the following elements:

• a section of the PDF Guide with detailed explanations and screenshots;

• a section of the PDF Guide with detailed explanations and screenshots;

• narrated movie clips providing step-by-step instructions,

• narrated movie clips providing step-by-step instructions,

• an ArchiCAD training project file to complete the exercises.

• an ArchiCAD training project file to complete the exercises.

The PDF guide can be printed and all the narrated movie clips can be launched from the PDF. However, we recommend that you play the movie clips within ArchiCAD, while completing the steps using the training project files.

Preface

Step 1: Download and install ArchiCAD

To best enjoy the unique benefits and simplicity of learning in an interactive environment, we recommend that you install the interactive training guide as well as the latest version of Graphisoft ArchiCAD on your computer.

1 Install ArchiCAD on your computer to complete the steps of this interactive training guide.

2 If you do not have ArchiCAD yet, please visit the following websites to obtain a free ArchiCAD installer:

• If you are a student or a teacher, visit

download a fully functional Education Version of ArchiCAD® for Students and Teachers.

Education Version of ArchiCAD® for Students and Teachers. • If you are a professional architect, visit

If you are a professional architect, visit

download a fully functional 30-day trial version of ArchiCAD. Projects saved with this TRIAL version can be automatically

upgraded to FULL versions upon purchase of a commercial license.

to FULL versions upon purchase of a commercial license. Please note that ArchiCAD is available in

Please note that ArchiCAD is available in several localized languages for both Macintosh and for Windows operating systems – make sure to choose the language and installer version that best suits you.

3 Start the Graphisoft ArchiCAD installer and follow the installation wizard to complete the process.

Preface

Preface In case you have not done so already, please install the interactive training guide on

In case you have not done so already, please install the interactive training guide on your computer.

4 Start the installer of the interactive training guide and follow the instructions on the screen. We recommend you install the guide to the “default” location suggested in the installation wizard. Once you have successfully installed both Graphisoft ArchiCAD and any of the Interactive Training Guide packages, please proceed with the following steps to initiate the interactive learning environment.

Step 2: Create the interactive training environment

Step 2: Create the interactive training environment Introduction.mp4 Watch Movie 1 Start ArchiCAD on your

Introduction.mp4

Watch Movie

1 Start ArchiCAD on your computer by double-clicking its desktop shortcut.

on your computer by double-clicking its desktop shortcut. The ArchiCAD splash screen will appear shortly after
on your computer by double-clicking its desktop shortcut. The ArchiCAD splash screen will appear shortly after

The ArchiCAD splash screen will appear shortly after you start the program, and the “Start ArchiCAD” dialog will be displayed.

2 Select the “Standard Profile” for the active Work Environment in the “Start ArchiCAD” dialog. Select the “Open Project” option, then click the “Browse” button to locate the ArchiCAD training project file on your local computer.

Preface

Preface If you installed the interactive training guide to its default location, then you will find

If you installed the interactive training guide to its default location, then you will find its folder in the “Graphisoft” folder of your machine. The Graphisoft folder is located in the “Applications” folder on Macintosh, or in the “Program Files” folder on Windows operating systems.

3 Browse the chapters of this training guide and open any of the ArchiCAD Project archive (.PLA) files.

and open any of the ArchiCAD Project archive (.PLA) files. 4 Select the “Read elements directly

4 Select the “Read elements directly from archive” option for Active Library Usage in the “Open Archive Project” dialog.

Library Usage in the “Open Archive Project” dialog. ArchiCAD will open the selected archive project and

ArchiCAD will open the selected archive project and read all the library elements directly from the archive file. The ArchiCAD training project files are all saved as archive files. This is important because the library elements have different names in localized versions of ArchiCAD (“localized” meaning translated to foreign languages and customized to meet different local standards).

5 Activate the “File > Save As…” command, and save an ArchiCAD Solo Project of the currently open design file to the folder in which the previously opened archive file was located. The Solo Project format and the correct library are

Preface

selected automatically, so practically all you have to do is to click the “Save” button to proceed.

you have to do is to click the “Save” button to proceed. This is an important

This is an important step, since certain exercises will require a Solo Project file to be saved on your local computer. The Movie Player plug-in also requires this step for it to be able to open the necessary training clips automatically. Now that the “training environment” has been set up, and you are ready to proceed with any of the exercises! Please note that for certain exercises the training environment described above will not be available, since some of the steps of the exercises will be completed using other applications, such as an Internet browser or a PDF viewer. In such cases please play the corresponding training movie clip using Apple’s free QuickTime Player application. All the training movie clips are available from the chapter-folders of this guide.

Step 3: How to use Movie Player in ArchiCAD?

Let’s briefly look over the main features and functions of the ArchiCAD Movie Player.

1 Open the Movie Player by activating “Help > ArchiCAD Movie Player”.

by activating “Help > ArchiCAD Movie Player”. 2 The Movie Player will open and the first

2 The Movie Player will open and the first training clip will be automatically loaded. Feel free to reposition or re-size the movie player on your screen.

to reposition or re-size the movie player on your screen. 3 Click the Play button on

3 Click the Play button on the player to start the first clip. You can pause the movie at any time, or use the slider to repeat or skip any parts of the clip.

Preface

Preface 4 Once the movie is over and you have completed the current step of the

4 Once the movie is over and you have completed the current step of the exercise, click the “Next” button to proceed to the next step of the exercise and open the corresponding training clip. You can also click the “Previous” button if you wish to open the previous clip. The title bar of the movie player always indicates the number of the current step and the total number of steps available in the current chapter.

the total number of steps available in the current chapter. We hope that you will find

We hope that you will find this guide useful and will agree with what experienced architects worldwide say: ArchiCAD is easy to learn and fun to use. You are always free to contact Graphisoft and its worldwide partners if you have further questions: www.graphisoft.com.

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

1. SAVING 2D SYMBOLS FROM THE FLOORPLAN

In this first chapter we will save a custom 2D object – a north symbol – from the floor plan and then make some final refinements in the Library Part Editor. The final – optional - step demonstrates an alternative way to create custom 2D objects by copying 2D elements from the floor plan into the 2D symbol view window of a Library Part. Although these are all really simple operations, they will highlight some basic concepts of making objects with ArchiCAD. All elements of the ArchiCAD floor plan can be saved automatically as 2D symbol objects. You don’t have to be afraid to open the GDL Object Master Window. This logical setup dialog allows you to modify your existing objects according to your needs. You can add more value to your auto saved objects with some easy-to-learn techniques. The 2D symbol view of GDL elements allows you to create a 2D symbol for your object with standard 2D ArchiCAD tools.

1.1 CREATING THE SYMBOL

with standard 2D ArchiCAD tools. 1.1 C REATING THE S YMBOL AC Guide GDL Ch 01_01.mp4

AC Guide GDL Ch

01_01.mp4

Watch Movie

Let’s start this lesson by completing our custom north symbol on the floor plan.

1 Open the “AC Guide GDL Ch 01.pla” ArchiCAD project file to start the first lesson of this interactive, hands-on ArchiCAD training guide. Select the “Read elements directly from archive” option.

Select the “Read elements directly from archive” option. Please review the “Getting started with the ArchiCAD

Please review the “Getting started with the ArchiCAD Interactive Training Guide” chapter if you need further information on how to set up ArchiCAD, adjust the necessary ArchiCAD Working Environment, or open the training guide project files. Hint: If you want to check the complete GDL object that we are going to make, open the Object Tool and locate the “ITG_North_Symbol_Final” Library Part in the object browser. The object is located in the “Finished Objects” folder.

Open the “AC Guide GDL Ch 1” folder in the Navigator and activate (by double-clicking) the “1.1 Complete the Symbol” pre-set view in the “Chapter 1” folder. As you can see we have prepared a nearly complete north symbol for you on the floor plan. We used the standard ArchiCAD tools (Line, Circle, Text) and commands (e.g., Multiply) to create this custom symbol. These techniques were discussed in greater detail in previous ITG lessons; therefore, these steps are not described here. In the next step we’ll add some solid fills to the drawing to make it complete.

2

add some solid fills to the drawing to make it complete. 2 Graphisoft® ArchiCAD® Creating GDL

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN Hint : Whenever you want to create GDL

Hint: Whenever you want to create GDL objects on the floor plan to be saved as GDL objects – regardless of whether they are 2D symbols or real 3D elements - we highly recommend that you draw them close to the project origin. Elements placed too far from the origin may result in minor inaccuracies in the GDL code.

3 Activate the “Fill Tool” in the “Tool Box” and click on the “Fill Tool Settings” button in the “Info Box” to display the “Fill Default Settings” dialog box.

4 Click on the “Fill Pattern” button and select the “Solid Fill” type from the pop-up dialog. Set “Pen 1” for all three adjustable pen types (Outline, Cover Fill, Cover Fill Background Pen).

pen types (Outline, Cover Fill, Cover Fill Background Pen). 5 Click OK to leave the “Fill

5 Click OK to leave the “Fill Default Settings” dialog box. Zoom in on the north sign. Press the Space button to activate

the “Magic Wand”

Press the Space button to activate the “Magic Wand” . The cursor’s shape changes to a

. The cursor’s shape changes to a

magic wand indicating that ArchiCAD will automatically trace the boundaries of the area where you click with the cursor

6 Use the left mouse button to click in the middle of those empty areas that you would like to cover with solid fills. You can check the completed symbol on the right side of the screen for reference.

symbol on the right side of the screen for reference. Hint: To avoid segmentation of curv

Hint: To avoid segmentation of curved polygon edges, make sure that the “Tracing Method” is set to “Best Match” in the “Magic Wand Settings” dialog (Options > Magic Wand Settings…) before you click.

1.2 SAVING THE OBJECT

Settings… ) before you click. 1.2 S AVING THE O BJECT AC Guide GDL Ch 01_02.mp4

AC Guide GDL Ch

01_02.mp4

Watch Movie

Let’s save the previously created drawing elements as a GDL object.

1 Open up the “ArchiCAD Guide” folder in the Navigator and activate (by double-clicking) the “1.2 Create the GDL Object” pre-set view in the “Chapter 1” folder.

GDL Object” pre-set view in the “Chapter 1” folder. 12 Graphisoft® ArchiCAD® Creating GDL Objects –

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN 2 Click on the Arrow Tool. Select all

2 Click on the Arrow Tool. Select all the drawing elements with a selection polygon.

Select all the drawing elements with a selection polygon. Hint: Alternatively, you can hold down the

Hint: Alternatively, you can hold down the shift button and click the elements for selection one by one. You can also launch the “Select All” command (Edit > Select All) for the same result.

3 Activate the “Save Selection as

command (File > Libraries

and Objects > Save Selection as…)

and in the opening dialog specify the name and location of the new Library Part to be created. Save the object as

“ITG_North_Symbol” the “ArchiGuide\ITG Library” folder.

the “ArchiGuide\ITG Library” folder. into Hint : For easier library management we suggest you

into

the “ArchiGuide\ITG Library” folder. into Hint : For easier library management we suggest you always

Hint: For easier library management we suggest you always save your custom Library Parts into a dedicated folder other than the standard ArchiCAD Library folder. For each new project we recommend you create a new library folder where the project-specific elements can be stored. Furthermore, it’s very important to give a descriptive name (e.g., with a project-specific suffix or prefix) to your custom objects in order to avoid any Library Part naming conflicts among the loaded libraries.

4 Click OK to create the GDL object at the specified location. Hint: Whenever a new GDL object is made in ArchiCAD it is automatically loaded into the actual project. You can double check this if you open the Library Manager (File > Libraries and Objects > Library Manager) and review the list of Library Parts under the “Other Objects” category. Naturally, if you want to use this object in your other projects you have to load it (or the folder that contains it) with the Library Manager.

1.3 CHECKING THE RESULT

it) with the Library Manager. 1.3 C HECKING THE R ESULT AC Guide GDL Ch 01_03.mp4

AC Guide GDL Ch

01_03.mp4

Watch Movie

Let’s look at the capabilities of the newly created Library Part.

1 Open up the “ArchiCAD Guide” folder in the Navigator and activate (by double-clicking) the “1.3 Check the Result” pre-set view in the “Chapter 1” folder.

2 Open the “Object Default Settings” dialog by double-clicking on the Object Tool in the Toolbox. Note that “ITG North Symbol” is the currently active object in the browser on the left side. Click OK to go back to the floor plan and click anywhere with the left mouse button to place an example of the new object. You may also place additional copies of this element with additional mouse clicks.

copies of this element with additional mouse clicks. Graphisoft® ArchiCAD® Creating GDL Objects – Interactive

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN 3 Activate the Arrow Tool from the Toolbox
1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN 3 Activate the Arrow Tool from the Toolbox

3 Activate the Arrow Tool from the Toolbox and select the object by making a selection rectangle around it. The active points (hotspots) of the element become visible.

Hint: GDL objects can be selected with their hotspots or over the areas of their 2D fills. ArchiCAD places hotspots on the bounding box corners and in the center of auto-saved objects. Additional hotspots can be found at the corners of fill polygons.

4 Move your cursor over one of the bounding box hotspots until the cursor’s shape changes to a checkmark. Click to open the “Pet Palette”.

5 Click on the rightmost button (Stretch mode), move the hotspot and click again to finish the operation.

move the hotspot and click again to finish the operation. The object is automatically stretche d

The object is automatically stretched to fit into the resized bounding box. Hint: In order to avoid distortions of the symbol you have to stretch it along the diagonal of the bounding box. Alternatively, you can select the object, then open “Object Selection Settings” and enter the required values in the Length and Width fields under “Parameters”. ArchiCAD also allows you to adjust the pen and the line-type of auto-saved objects.

6 Select the North Symbol again with the Arrow Tool and then open the “Object Selection Settings” dialog by double clicking on the Object tool or by clicking once on the Object Settings icon in the Info box.

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

7 Under “Floor Plan and Section” uncheck the “Enable Object’s Pens” checkbox and change the “Symbol Line Pens” value to six.

checkbox and change the “Symbol Line Pens” value to six. 8 Click OK to return to

8 Click OK to return to the floor plan and check the result.

8 Click OK to return to the floor plan and check the result. 1.4 F INAL

1.4 FINAL TOUCHES

to the floor plan and check the result. 1.4 F INAL T OUCHES AC Guide GDL

AC Guide GDL Ch

01_04.mp4

Watch Movie

Our current object doesn’t have a preview picture associated with it. That makes it difficult to identify it in the object browser should there be many elements loaded. In this section we are going to learn how we can add a preview image and a short description to your object.

1 Select the object and open the “Object Selection” dialog as described above. Click on the “Preview options” buttons one by one. Note that both the Preview picture and the Comment windows are empty.

both the Preview picture and the Comment windows are empty. 2 Click Cancel to return to
both the Preview picture and the Comment windows are empty. 2 Click Cancel to return to

2 Click Cancel to return to the floor plan.

3 Leaving the element selected, activate the “Open Object” command (File > Libraries and Objects > Open Object…). This opens the selected element’s GDL Master Window.

This opens the selected element’s GDL Master Window. Hint : Each GDL Object has its own

Hint: Each GDL Object has its own Master Window. All controls needed to edit a GDL Object are present in the Master Window. Any number of GDL Object Master Windows can be open at the same time. The elements of the GDL Master Window will be introduced in more detail in the next lessons.

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

4 Click on the Preview Picture button.

The Preview picture window opens, even though it is empty at this stage. Now we’ll copy an existing image into it. Hint: The picture that we are going to use was made with a screen capture tool and an image editing application. The size of the image is exactly 128x128 pixels so that it fits perfectly in the “Preview Picture” area.

Click on the floor plan area outside the GDL Master Window to return to the floor plan.

5 Activate the “File > Open…” command and select the

Activate the “File > Open…” command and select the “ITG_01_preview.png” “ArchiCAD Training Guide”

“ITG_01_preview.png”

“ArchiCAD Training Guide” folder. Make sure that the “All Files” types option is selected.

Make sure that the “All Files” types option is selected. file in the 6 Select the

file in the

the “All Files” types option is selected. file in the 6 Select the picture with the

6 Select the picture with the “Edit > Select all…” (Ctrl+A) command.

7 Copy the content of the selection with the Copy command (Edit > Copy).

of the selection with the Copy command (Edit > Copy). 8 Return to the GDL Master

8 Return to the GDL Master Window (Window > ITG North Symbol).

9 Click on the “Preview Picture” button and paste the content of the clipboard with the Paste command (Edit > Paste).

of the clipboard with the Paste command (Edit > Paste). 10 Close the “Preview Picture” window

10 Close the “Preview Picture” window by clicking on the top right corner and open the “Comments” window by clicking on the Comments button.

11 Enter the following text in the comment window: My Custom North Symbol Object

text in the comment window: My Custom North Symbol Object 12 Close the Comments window. 13

12 Close the Comments window.

13 Save your changes to the object with the Save command (File > Save) and close the GDL Master Window.

14 Back on the floor plan open the Object Selection Settings dialog then check the preview picture and comments added to the ITG North Symbol Object.

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN 15 Return to the floor plan with OK.

15 Return to the floor plan with OK. Save the project file with Save (File > Save) and close it (File > Close).

1.5 USING THE 2D SYMBOL VIEW

it (File > Close). 1.5 U SING THE 2D S YMBOL V IEW A C G

AC Guide GDL Ch

01_05.mp4

Watch Movie

The object is now finished, and you can use it in your projects when you need exactly the same symbol. Furthermore, you have the option of changing its pen color and size as described in Chapter 1.3. However, making any modifications in the content of the symbol requires some basic GDL scripting knowledge, since the 2D symbol is stored as a series of GDL commands in the object’s 2D Script window. You can check this yourself if you open the object’s GDL Master Window and click on the 2D Script button.

GDL Master Window and click on the 2D Script button. In this last chapter we’ll explain

In this last chapter we’ll explain how you can create a symbol object that you can easily modify with just the standard ArchiCAD 2D editing tools.

1 Open up the “ArchiCAD Guide” folder in the Navigator and activate (by double-clicking) the “1.4 Use the 2D Symbol View” pre-set view in the “Chapter 1” folder.

Symbol View” pre-set view in the “Chapter 1” folder. Graphisoft® ArchiCAD® Creating GDL Objects – Interactive

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN 2 Select the symbol with the area selection

2 Select the symbol with the area selection and copy it to the clipboard.

symbol with the area selection and copy it to the clipboard. 3 Create a new GDL

3 Create a new GDL object with “File > Libraries and objects

> New Object

The object’s GDL Master Window opens.

”.

4 Click on the “2D Symbol” button. The 2D symbol window opens.

on the “2D Symbol” button. The 2D symbol window opens. If the actual scale of this

If the actual scale of this window is other than 1:50 then please set it to 1:50 in the bottom-left corner of the dialog.

5 Paste the content of the clipboard with “Edit > Paste”.

6 If the “Pasting…” dialog opens, select the “Paste to Original Location” and “Zoom to Pasted Elements” options.

Location” and “Zoom to Pasted Elements” options. 18 Graphisoft® ArchiCAD® Creating GDL Objects –

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

7 Click outside the selection marquee or hit Enter to place the copied elements.

marquee or hit Enter to place the copied elements. Please note that the 2D symbol window

Please note that the 2D symbol window provides an environment similar to the ArchiCAD floor plan view. All the standards 2D tools (e.g., Line, Fill, Text) and editing commands (Trim, Rotate, Copy, etc.) can be used here to create the desired 2D symbol. Consequently, you don’t have to know GDL if you want to edit these elements. To demonstrate how easy it is to modify this object let’s add a few more hotspots to it.

8 Activate the Hotspot tool and place a hotspot in the middle of symbol and on the quarter points of the outer circle. Please note that when you place a 2D object that was defined in the 2D symbol window on the floor plan, ArchiCAD will automatically resize it according to the actual setting of the A/B parameters (width, height). Currently the A/B parameters are set to 1m (see the parameter list). Consequently, this will be the default size of our north symbol object. If you want to preserve the original size of your symbol you have to modify the A and B parameters accordingly. You can do it manually or you can use the Fit size to 2D symbol option from the Details window. We’ll do the latter.

9 Click on the “Details” button in the currently open GDL Master window and in the opening dialog check the “Fit size to 2D symbol” checkbox. Close the dialog with OK.

size to 2D symbol” checkbox. Close the dialog with OK. The A and B parameters were

The A and B parameters were automatically set according to the original size of the symbol.

set according to the original size of the symbol. Hint : You can also add a

Hint: You can also add a preview picture and comments to your object as described in Chapter 1.4.

10 Save the object as “ITG_North_Symbol_02” into the “ArchiGuide\ITG Library” folder with “File > Save”. Close the GDL Master window with OK.

11 Back on the floor plan place the newly created object with the Object Tool and check the result.

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN

1. SAVING 2D SYMBOLS FROM THE FLOOR PLAN Hint : If you want to further edit

Hint: If you want to further edit this object select it on the floor plan and open its GDL Master window with “File > Libraries and objects > Open Object…”. In the opening dialog click on the 2D symbol button and make the necessary adjustments with the standard 2D tools and editing commands, then save the changes. 12 Close the project with “File > Close”.

2. Saving 3D models from the floorplan as GDL objects

2. SAVING 3D MODELS FROM THE FLOORPLAN AS GDL OBJECTS

The previous chapter explained how you can save 2D symbol objects from the floor plan. In this lesson we’ll go one step further and make a 3D GDL object using only the standard ArchiCAD tools. This interactive training session demonstrates the following basic object-making techniques:

• Three-dimensional ArchiCAD models can be saved automatically as GDL objects. This process doesn’t require any GDL knowledge.

• Any kind of ArchiCAD Tool can be used to develop 3D models that can be saved as a GDL object

Before we start working let’s have a quick look at the object that we are going to model.

2 Open up the “AC Guide GDL Chapter 02” folder in the Navigator and activate (by double-clicking) the “2.1 Overview” pre-set view in the “Chapter 2” folder.

Overview” pre-set view in the “Chapter 2” folder. The Double Coffee Table known as “907B” was

The Double Coffee Table known as “907B” was designed by Alvar Aalto in 1933. The table's two-tier design is unique given Aalto's output and is unusual in its construction. The lower tier is suspended from the tabletop so that it appears to float. For more info please visit the manufacturer’s website: www.artek.fi

2.1 OVERVIEW

the manufacturer’s website: www.artek.fi 2.1 O VERVIEW AC Guide GDL Ch 02_01.mp4 Watch Movie 1 Open

AC Guide GDL Ch

02_01.mp4

Watch Movie

1 Open the “AC Guide GDL Ch 02.pla” ArchiCAD project file to start the second lesson of this interactive, hands-on ArchiCAD GDL training guide. Select the “Read elements directly from archive” option.

Select the “Read elements directly from archive” option. Hint : If you want to check the
Select the “Read elements directly from archive” option. Hint : If you want to check the

Hint: If you want to check the complete GDL object that we are going to make, open the Object Tool and find the “Coffee_Table_907B_Final” Library Part in the object browser. The object is located in the “Finished Objects” folder.

2. Saving 3D models from the floorplan as GDL objects

2.2 MODELING

3D models from the floorplan as GDL objects 2.2 M ODELING AC Guide GDL Ch 02_02.mp4

AC Guide GDL Ch

02_02.mp4

Watch Movie

1 Open up the “AC Guide GDL Chapter 02” folder in the Navigator and activate (by double-clicking) the “2.2 Modeling Steps” pre-set view in the “Chapter 2” folder.

Steps” pre-set view in the “Chapter 2” folder. We are going to take three steps to
Steps” pre-set view in the “Chapter 2” folder. We are going to take three steps to

We are going to take three steps to model the chair on the floor plan; first we’ll create the two tabletops using the Slab Tool, then the four suspensions with the Column Tool and finally the four legs with the Wall Tool. We’ll use the top elevation drawing of the table as a construction aid.

Activate (by double-clicking) the “2.3 Model the Tabletops” pre-set view in the Navigator. We start the modeling process by creating the double tabletops. The active view set shows only the contours of the elements to allow the use of the Magic Wand function.

2

the elements to allow the use of the Magic Wand function. 2 3 Open the Slab
the elements to allow the use of the Magic Wand function. 2 3 Open the Slab

3 Open the Slab Tool

button.

of the Magic Wand function. 2 3 Open the Slab Tool button. and click on the

and click on the “Favorites”

4 Select “Upper Tabletop” from the list and click “Apply”.

“Upper Tabletop” from the list and click “Apply”. The required Slab parameters are set for modeling

The required Slab parameters are set for modeling the first main frame element.

2. Saving 3D models from the floorplan as GDL objects

5 Click OK

3D models from the floorplan as GDL objects 5 Click OK on the “Slab Default Setting”

on the “Slab Default Setting” dialog box

to return to the floor plan.

6 Zoom in the bigger circle (the upper tabletop) and hold down the Space button on the keyboard to activate the Magic Wand function. The cursor’s shape changes to a magic wand indicating that ArchiCAD will automatically trace the contours of the clicked polygon.

7 Move the cursor over the bigger circle until the cursor’s shape shows that it has found a polygon, then click.

shape shows that it has found a polygon, then click. 8 Open the Slab Tool “Favorites”
shape shows that it has found a polygon, then click. 8 Open the Slab Tool “Favorites”
shape shows that it has found a polygon, then click. 8 Open the Slab Tool “Favorites”

8 Open the Slab Tool

“Favorites” button.

then click. 8 Open the Slab Tool “Favorites” button. again and click on the 9 Select

again and click on the

9 Select “Lower Tabletop” from the list and click “Apply”.

“Lower Tabletop” from the list and click “Apply”. 10 Click “OK” on the Slab Default Setting

10 Click “OK”

from the list and click “Apply”. 10 Click “OK” on the Slab Default Setting dialog box

on the Slab Default Setting dialog box to

return to the floor plan.

11 Zoom in the smaller circle (the lower tabletop) and hold down the Space button on the keyboard to activate the Magic Wand function. The cursor’s shape changes to a magic wand indicating that ArchiCAD will automatically trace the contours of the clicked polygon.

12 Move the cursor over the smaller circle until the cursor’s icon indicates that it has found a polygon and click.

icon indicates that it has found a polygon and click. Now the two tabletops are ready
icon indicates that it has found a polygon and click. Now the two tabletops are ready
icon indicates that it has found a polygon and click. Now the two tabletops are ready

Now the two tabletops are ready (you can check them in the 3D window), so we can start creating the suspensions that connect them.

13 Activate (by double-clicking) the “2.4 Model the Suspensions” pre-set view in the Navigator.

Model the Suspensions” pre-set view in the Navigator. The floor plan shows four hotspots that indicate

The floor plan shows four hotspots that indicate the center points of the four rectangular suspensions.

2. Saving 3D models from the floorplan as GDL objects

2. Saving 3D models from the floorplan as GDL objects 14 Open the Column Tool “Favorites”

14 Open the Column Tool

“Favorites” button.

GDL objects 14 Open the Column Tool “Favorites” button. and click on the 15 Select “Tabletop

and click on the

15 Select “Tabletop Suspension” from the list and click “Apply”.

Suspension” from the list and click “Apply”. The required Column setting values are set so that

The required Column setting values are set so that you can create the suspensions.

16 Click “OK”

so that you can create the suspensions. 16 Click “OK” on the Column Default Setting dialog

on the Column Default Setting dialog

box to return to the floor plan.

17 Click once over every hotspot to place the four suspensions.

18 Activate (by double-clicking) the “2.5 Model the Legs”

pre-set view in the Navigator. The floor plan shows the four lines where the legs need to be placed.

plan shows the four lines where the legs need to be placed. 19 Open the Wall
plan shows the four lines where the legs need to be placed. 19 Open the Wall

19 Open the Wall Tool and click on the “Favorites” button.

Open the Wall Tool and click on the “Favorites” button. 20 Select “Table Leg” from the

20 Select “Table Leg” from the list and click “Apply”.

Select “Table Leg” from the list and click “Apply”. 24 Graphisoft® ArchiCAD® Creating GDL Objects –

2. Saving 3D models from the floorplan as GDL objects

The required Wall setting values are set for modeling the four legs. Please note that this special Wall type uses a Custom Profile that we previously defined in the “Profile Manager” dialog.

we previously defined in the “Profile Manager” dialog. To revise the Wall’s profile click on Design

To revise the Wall’s profile click on Design > Complex Profiles > Profile Manager… and choose the “Table Leg” profile.

Profile Manager… and choose the “Table Leg” profile. 21 Click “OK” on the Wall Default Setting
Profile Manager… and choose the “Table Leg” profile. 21 Click “OK” on the Wall Default Setting

21 Click “OK” on the Wall Default Setting dialog box to return to the floor plan.

22 Draw straight wall segments along the four lines. Please note that the Walls’ starting points are indicated by the label arrows. The required Wall Geometry settings are shown below.

arrows. The required Wall Geometry settings are shown below. Now we are finished with the modeling.
arrows. The required Wall Geometry settings are shown below. Now we are finished with the modeling.
arrows. The required Wall Geometry settings are shown below. Now we are finished with the modeling.

Now we are finished with the modeling.

2.3 CREATING THE GDL OBJECT

finished with the modeling. 2.3 C REATING THE GDL O BJECT AC Guide GDL Ch 02_03.mp4

AC Guide GDL Ch

02_03.mp4

Watch Movie

Open up the “AC Guide GDL Chapter 02” folder in the Navigator and activate (by double-clicking) the “2.6 Check 2D” pre-set view in the “Chapter 2” folder. The floor plan shows the complete model. If you’ve followed the previous steps precisely you should see this figure:

1

the previous steps precisely you should see this figure: 1 Graphisoft® ArchiCAD® Creating GDL Objects –
the previous steps precisely you should see this figure: 1 Graphisoft® ArchiCAD® Creating GDL Objects –

2. Saving 3D models from the floorplan as GDL objects

Activate (by double-clicking) the “3.7 Check 3D” pre-set view in the Navigator. The 3D window opens and you can check the consistency of your 3D model.

2

opens and you can check the consistency of your 3D model. 2 Before we continue we
opens and you can check the consistency of your 3D model. 2 Before we continue we

Before we continue we have to understand the concept of auto-saving GDL. The rule is very simple: the viewpoint of the 3D window will define the top view of the automatically saved Library Part. Thus we have to look at the 3D model from a perpendicular top view.

Activate (by double-clicking) the “2.8 Open the Top View” pre-set view in the Navigator. This previously defined view automatically sets the required 3D top view.

3

view automa tically sets the required 3D top view. 3 Hint : You can check the