Manual STEP 5 V6.

6

1

Manual STEP 5 V6.6
Eng. Roberto Bairros dos Santos. www.bairrospd.kit.net

Manual STEP 5 V6.6

2

1

Índice: Exemplo prático de programação com STEP 5:............................................................. 4 1.1 Introdução ao exemplo: .......................................................................................... 4 1.1.1 Breve descrição da estação de lavagem:......................................................... 5 1.1.2 Diagrama elétrico do controle: ....................................................................... 6 1.2 Criando um programa em STEP 5 para controle estação de lavagem: .................. 7 1.2.1 Parametrizando o projeto:............................................................................... 7 1.2.2 Selecionando o modo trabalho” MODE”: ...................................................... 8 1.2.3 Selecionando a forma de representação dos operandos: ............................... 8 1.2.4 Nomeando o arquivo de impressão “Printer file”:.......................................... 8 1.2.5 Selecionando o modo representação: ............................................................ 9 1.2.6 Selecione o número de caracteres do comentário e símbolos: ....................... 9 1.2.7 Salvando as seleções:...................................................................................... 9 1.3 Criando o programa:............................................................................................. 10 1.3.1 Criando uma lista de endereços simbólicos: ................................................ 10 1.3.1.1 Editando a lista de símbolos: .................................................................... 11 1.3.1.2 Imprimindo ou mostrando os erros: ......................................................... 13 1.3.2 Editando o banco de dados: .......................................................................... 13 1.3.3 Editando o bloco de função FB: ................................................................... 17 1.3.3.1 Editando o nome do bloco de função: ..................................................... 17 1.3.3.2 Editando o comentário:............................................................................. 18 1.3.3.3 Editando o título do segmento 1 ............................................................... 18 1.3.3.4 Terminando o segmento 1: ....................................................................... 18 1.3.3.5 Corrigindo e editando símbolos:............................................................... 19 1.3.3.6 Corrigindo a linha de instrução: ............................................................... 19 1.3.3.7 Escrevendo o comentário do segmento: ................................................... 20 1.3.3.8 Deslocando entre os segmentos:............................................................... 20 1.3.3.9 Inserindo um novo segmento: .................................................................. 20 1.3.4 Documentando o programa: ......................................................................... 21 1.4 Transferindo os segmentos, blocos e arquivos: .................................................... 22 1.4.1.1 Verificando arquivos contidos em um diretório:...................................... 23 1.4.1.2 Como transferir os segmentos: ................................................................. 24 1.4.1.3 Verificando se O bloco transferido está no programa: ............................. 25 1.4.1.4 Transferindo segmentos:........................................................................... 25 1.4.1.5 Transferindo e renomeando blocos: ......................................................... 27 1.4.1.6 Renomeando um bloco: ............................................................................ 28 1.4.1.7 Transferindo um bloco de organização (OB): .......................................... 29 1.5 Gerenciando, Verificando e modificando um programa: ..................................... 30 1.5.1 Cross Reference (Referência cruzada): ........................................................ 30 1.5.2 Imprimindo a Lista cruzada:......................................................................... 31 1.5.3 Usando a função Search (Procura): .............................................................. 33 1.5.4 Corrigindo e reescrevendo o seu programa: ................................................. 34 1.5.5 Comparando blocos: ..................................................................................... 35 1.6 Carregando e testando o seu programa:................................................................ 36 1.6.1 Carregando um programa: ............................................................................ 36

Manual STEP 5 V6.6

3

1.6.2 Testando o programa: ................................................................................... 39 1.6.3 Ativando a função Block Status: .................................................................. 40 1.6.3.1 Corrigindo o programa: ............................................................................ 42 1.6.3.2 Verificando o valor de uma variável (Status variable):........................... 43 1.6.3.3 Forçamento das variáveis: ........................................................................ 45 1.7 Apêndice A:.......................................................................................................... 46

Manual STEP 5 V6.6

4

1

Exemplo prático de programação com STEP 5:

1.1

Introdução ao exemplo:

Este exemplo será usado para ajudá-lo a entender o modo de programação usando o STEP 5. O exemplo consiste em criar um programa para a automatização de uma lavagem de carro. Este exemplo irá mostrar como você deverá proceder para editar, documentar, testar e salvar o programa desenvolvido para em STEP 5. Este exemplo tem como principais objetivos: • Dar uma idéia da maneira de editar o programa. • Dar uma idéia da forma de planejar e implementar um projeto usando as ferramentas do STEP 5. O desenvolvimento do programa propriamente dita não fará parte deste exemplo, mas será descrito mais tarde em parágrafo específico. O programa completo consiste das seguintes partes: • Uma lista de símbolos para descrever os endereços absolutos. • Um bloco de função com 15 instruções montadas no formato de lista de instruções STL. • Um bloco de dados (Data Block) • Um bloco de organização OB1 para iniciar e controlar o ciclo de operação.

Manual STEP 5 V6.6

5

1.1.1 Breve descrição da estação de lavagem:
A figura abaixo ilustra uma estação de lavagem de carro:

O passo para a lavagem de um veículo segue os seguintes passos: 1. O carro se move para o local inicial da lavagem. 2. O carro é movimentado até a posição de lavagem. 3. A porta é fechada e a lavagem é iniciada. 4. Um banho de xampu é aplicado, o carro é molhado e esfregado com rolos de escova e então secado com jatos de ar quente. 5. Finalmente a porta é aberta e o carro é movido para fora. Algumas variáveis do processo poderão ser alteradas pelo operador da estação de lavagem. O controle deverá contar e armazenar o número de carros lavados.

.2 Diagrama elétrico do controle: Baseado na descrição acima você poderá descrever o circuito elétrico para implementação deste projeto.6 6 1. Você pode testar o seu programa montando chaves par simular os dispositivos de entrada como botões e sensores.1. e lâmpadas para simular os dispositivos de saída como motores e atuadores.Manual STEP 5 V6. este circuito é apresentado abaixo onde o controle é feito com um CLP do tipo 95U.

conforme a nomenclatura da Siemens.2.1 Parametrizando o projeto: Você deverá começar parametrizando os arquivos necessários para o armazenamento do seu projeto. . neste exemplo os nomes poderão ser: Working directory: C:\S5_DATEN\EXAMPLE Program file: C: CARWASST. 1. Você completa a edição com a tecla RETURN. Especifique o diretório onde o seu programa deverá ser armazenado e nomeie os arquivos da forma que melhor lhe convier. Gerenciar e testar o programa. Você poderá alterar os parâmetros posicionando o cursor na linha a ser alterada e pressionando a tecla F3=Select.6 7 1. Para criar um programa você deverá seguir os seguintes passos: • • • Criar e Parametrizar o projeto. 3. Page 1 Um projeto novo aparece nomeado a primeira vez como: NONAMED. 1.S5D Symbols file: C: CARWASZ0. 2. Editar o programa. Para parametrizar um novo projeto você deverá usar a opção: “Project setting> Page 1”.2 Criando um programa em STEP 5 para controle estação de lavagem: Você deverá chamar o programa para controle da estação de projeto. isto é feito no menu Objeto>Project.INI Os caracteres em negrito não podem ser modificados. pois são fixados pelo programa STEP5. Para selecionar um projeto já existente você deverá selecionar: Load.Manual STEP 5 V6.

4 Nomeando o arquivo de impressão “Printer file”: Escreva o nome do seu projeto “CARWAS” sobre o arquivo . as alterações feitas neste modo só atualizam o CLP.INI” é atualizado automaticamente. alterar o programa “on line”. Selecione o subdiretório EXEMPLE. Para confirmar a seleção pressione a tecla RETURN (atenção: é a tecla RETURN e não a tecla Enter no teclado numérico!) . ..INI.6 8 4. 1.Pressione a tecla F4 para mudar para mudar para a página 2: Page 2.Manual STEP 5 V6. o modo “on line” você deverá selecionar quando as funções necessitem do CLP conectado.LS. tais como: Transferência e carga do programa.2 Selecionando o modo trabalho” MODE”: O modo “off line” é usado para editar o programa sem o CLP. mas não deve.2.2. Para selecionar o diretório de trabalho: Woking dir:. somente no computador.. monitorização. Obs: Para selecionar use o mouse se você estiver trabalhando no windows ou use a tecla TAB para trocar de janela e as teclas “seta para cima” ou “seta para baixo” para trocar a opção dentro da janela. O nome do arquivo de documentação “ .DR. Complete o nome dos outros arquivos. Confirme com a tecla OK e será selecionado o diretório de trabalho C:\S5_DATEN\EXAMPLE Pressione a tecla OK novamente para voltar para a página 1... Primeiro pressione a tecla F3 duas vezes na caixa de diálogo.3 Selecionando a forma de representação dos operandos: Selecione sim para a oopção símbolos “symbol=yes” e comentário “comment=yes” O parâmetro “display” passará automaticamente “Sym”. 5. 1. Você pode. se você esquecer de salvar no seu programa você poderá ficar com um arquivo desatualizado no computador! Para alterar a opção você deverá pressionar a tecla F3=Select.2. 1.

” no menu “Object”.7 Salvando as seleções: Para salvar a parametrização feita anteriormente você deverá pressionar a tecla F8 “RETURN” a fim de retornar ao menu principal. Se alguma mensagem referente a inexistência de arquivos em discos que não estão sendo usados aparecer. Save as.5 Selecionando o modo representação: Selecione a lista de instruções “STL” (lista de instruções) pressionando a tecla F3.. Para retornar ao menu principal digite F8=RETURN. 1. se o nome não existir a mensagem não será apresentada. simplesmente desconsidere clicando OK ou RETURN.6 9 1.INI. Outro modo de representação bastante usado é a lógica de relê “LADDER”.2.6 Selecione o número de caracteres do comentário e símbolos: O padrão para o número de caracteres para a descrição simbólica dos endereços absolutos é 8.Manual STEP 5 V6.2. caso este já existir selecione e pressione a tecla OK você poderá ver a mensagem “Destinatin file already FD. mas você poderá altera-los se quiser.2. Uma caixa de seleção será aberta onde você poderá escrever o nome “CARWAS” no campo file name:. 1. e para o comentário é reservado 40 caracteres. Estas alterações deverão ser finalizadas com a tecla RETURN. overwrite” O STEP 5 irá salvar o seu projeto no arquivo CARWASPJ. .. Uma outra forma de salvar o programa diretamente da página 2 usando a tecla F5 para salvar como “save as” ou F6 para salvar “Save”. já que este será o modo de representação a ser usado neste exemplo. no entanto recomendamos o modo STL uma vez que o programa foi escrito em DOS com recursos gráficos limitados. No menu principal selecione a opção “Project.

2. Acompanhando o trabalho para a elaboração destas três etapas dará a você a experiência necessária para iniciar a trabalhar com o editor do STEP 5.3. temporizadores. Exemplo: “OPEN DOOR” (Abrir a porta) é o endereço simbólico usado para descrever o endereço absoluto da saída Q32. blocos de funções. assim quando uma outra pessoa for ler o seu programa ele terá melhores condições de entende-lo.3 Criando o programa: Uma vez nomeado e parametrizado o projeto. saídas. e até mesmo lhe ajudará a continuar a edição de um programa antigo.6 10 1. contadores. • Criação de uma lista de endereços simbólicos. 1.1 Criando uma lista de endereços simbólicos: Endereços simbólicos são nomes que você atribui aos endereços absolutos presentes no seu programa. • Criação de blocos de funções com uma lista de instruções para o controle do processo. Iisto tornará o seu programa mais legível. Você deverá desenvolver os seguintes passos para a implementação do programa. você poderá editar o programa de controle programando a lógica. A intenção deste exemplo é mostrar os passos para organizar um programa sem entrar nos detalhes da lógica. flags. Para tornar o programa mais inteligível você deverá gerar uma lista de endereços simbólicos para as entradas e saídas conforme a sua função dentro da lógica do programa. Isto é fundamental para um trabalho de manutenção.SEQ. contadores e temporizadores necessários para a automatização da estação de lavagem. Os endereços simbólicos ficarão armazenados no arquivo: C:CARWASZ0. • Criação de um banco de dados para armazenar os parâmetros de tempo e contagem.Manual STEP 5 V6. tais com: entradas. banco de dados etc. .

Digite “Keyswitch carwash on” e pressione a tecla de RETURN para finalizar a edição e passar para o campo seguinte ou a tecla TAB para voltar ao início do campo.6 11 1.. 5.0 MAINSWIT Keyswitch “carwash on” Que é a chave usada para ligar a estação de lavagem! 3 . e as colunas “Operand”.0 baseado no diagrama elétrico. No campo “Symbol” digite “MAINSWIT”. “Symbol” e “Comment”. Na página 1 você já parametrizou o número de caracteres para estes campos.SEQ. Isto irá encerrar o processo. Você vai digitar os símbolos em cada linha conforme o exemplo abaixo para a entrada I32. 2..INI.Manual STEP 5 V6.0 no modo “Insert” e pressionar o botão “SHIFT+curso para direita” ou TAB a fim de deslocar o cursor para o próximo campo.1. Você poderá ver uma tela com o cabeçalho com o título do seu projeto CARWASZO.Para alterar o campo “Operand” você deverá digitar o endereço I32. . 6.1 Editando a lista de símbolos: A lista de símbolos será editada na forma de uma tabela chamada: Tabela de símbolos.Z*. Para editar a lista de símbolos você deverá entrar no editor de símbolos usando o caminho: Editor > assignment list ou pressione a tecla F7. Para editar a tabela de símbolos siga os passos abaixo: 1. Pressione a tecla F7=Enter.3. 4. para isto siga os passos a seguir: Operand Symbol Comment I 32. Complete a lista com o restante dos endereços conforme a lista dada a seguir. quando o número de caracteres chegar a 8 o cursor saltará automaticamente saltará para o próximo campo.. Os endereços simbólicos serão armazenados no PC (PG) no arquivo tipo .

Após o processamento o programa mostrará a seguinte mensagem: ”n lines processed.Manual STEP 5 V6.6 12 Lista de símbolos do exemplo: Note que não é possível colocar acento. “key not found” ou ”n lines processed. no errors found” ou Se algum erro ocorrer a mensagem: ”error in line n” . também não é possível usar os caracteres típicos do português como “ç”. Se a sua edição terminou sem erros você já poderá ver a tabela de símbolos e poderá usar estes símbolos na edição do seu programa. x errors found”. Ao pressionar a tecla F7=enter a linha do erro aparecerá na tela para correção. . se houver algum erro a linha incorreta será mostrada no topo da página. por exemplo .

no caso deste exemplo digite: DB5. Conferindo os dados do cabeçalho: Você deverá observar ao final do processo de nomeação do bloco de dados se o cabeçalho mostra o nome e o caminho correto do seu bloco de dados. Você poderá ler os erros diretamente na tela ou imprimi-lo. 4. neste caso nome deverá ser:DB5 e o caminho: C:CARWASST.2 Imprimindo ou mostrando os erros: Se algum erro ocorrer você poderá mostrá-lo imprimi-lo seguindo as instruções abaixo: 1. O banco de dados completo é apresentado no Apêndice A.6 13 1. para isto você deverá digitar o tipo e nome do seu banco de dados na caixa de diálogo. 2.2) 1.2 Editando o banco de dados: 1.3. . Selecione o caminho: Management> assigment lists > Output error list.Entrando no editor do banco de dados: Para editar o banco de dados você deverá selecionar o seguinte caminho: Editor > Data block > in the program file.3. O editor deverá indicar o número zero para o primeiro na janela de edição aberta mais abaixo. ou tecle F2.1. Faça as correções necessárias no editor de símbolos e volte a editar os símbolos novamente (1. 3. O primeiro passo consiste em nomear o banco de dados.S5D.Manual STEP 5 V6.3. Pressione a tecla “OK” e “Continue” o programa retornará para a menu principal. Confirme pressionando a tecla “OK”. 2.

Manual STEP 5 V6. a menos que você pressione a tecla “Insert”. Entrando com o valor do dado: No segundo campo você deverá entrar com o valor do dado especificado no primeiro campo guardando a respectiva faixa de valores. 4. Corrigindo entrada de dados: • Apagando um caractere: Posicione o cursor sobre o caractere e pressione a tecla DEL. 6. Se o valor não for aceitável o cursor não se moverá. neste caso (KH). Se você entrou com um dado inválido será mostrada a mensagem: “Input illegal”. • Inserindo um caractere: Posicione o cursor no caractere sobre o qual você quer inserir o novo caractere (o novo caractere será inserido sobre o caractere atualmente selecionado) digite o novo caractere.Entrando com o restante dos dados: Digite da mesma forma o restante dos dados conforme descrito no Apêndice A. se o formato for válido o cursor saltará pára o próximo campo. Se tudo correr sem falhas o cursor será posicionado na próxima linha indicando o mesmo tipo de dado. se você desejar altera o tipo de dado.6 14 3. você deverá recuar para a esquerda o cursor e alterar o tipo de dado. • Inserindo uma linha inteira: Posicione o cursor sobre a marca de formatação da linha e selecione a opção “Expand DF”. Entrando com o formato: Para entrar com um dado novo você deverá primeiramente especificar o tipo de dado a ser usado. • Apagando uma linha inteira: Posicione o cursor na marca de formatação da linha e pressione a tecla “DEL”. .

. Editando correções no comentário do banco de dados: Para você experimentar como o "insert/delete" funciona no editor. 9. Agora posicione o cursor no "S" de Simatic e pressione F2 = Delete. O editor estrará no o modo de inserção. Digitando os comentários do dado (DW): Você poderá editar ou corrigir o texto de comentário de um dado do tipo Word usando letras maiúsculas ou minúsculas até 32 caracteres. Toda a palavra que você inseriu é apagada de uma só vez!. Você pode usar as teclas “Insert/delete” para inserir e apagar caracteres no campo de dados. Pressione a tecla “Insert” para retornar a área DW do editor do banco de dados. Você retorna ao modo de correção usando a tecla F1 = Overwrite. o cursor salta para o campo de LIB=.Manual STEP 5 V6. Posicione o cursor no campo de comentário com “SHIFT + tecla seta direita”. O texto é inserido neste ponto. 10. o modo de inserção é exibido e nova inserção pode ser feita. Posicione o cursor no "c" de controlador na segunda linha e pressione F1 = Insert. digite o número de LIB. mova o cursor ao "c" de controller e pressione F2 = Delete novamente.” para identificar o bloco (ex. Entre com o comentário descrito no Apêndice A completando cada linha com a tecla “Insert”. Você poderá inserir ou apagar linhas de comentários usando as teclas de função F1= Expand DC e F2=delete DC. 11. Você poderá movimentar o cursor para a próxima linha usando a tecla seta para baixo ou para cima. 10.6 15 7. Entrando o título no banco de dados: Você pode entrar o título “Carwash: counters/timers” Pressione a tecle SHIFT F6. A descrição das teclas de software muda a tecla F1. você deve especificar um número de livraria “LIB No. Digite "Simatic". neste exemplo "2". Pressione “F2 = Lib no”. . passa para “Overwrite. Entrando com o número da livraria LIB No: Como posso final para a edição do banco de dados. Saía do campo com a tecla Insert ou a tecla de RETURN. 8. por exemplo. Entrando com o comentário do banco de dados: Você pode chamar editor do comentário pressionando a tecla SHIFT F7= Comment. Encerrando o comentário: Complete a inserção com tecla F8= Return e “Insert” ou “Insert” duas vezes. versão do banco de dados).

Completando a seção de edição do banco de dados: Complete a edição pressionando a tecla “Insert”. overwrite?” aparecer.6 16 12. . confirme “yes”. Se a mensagem “DBn Already in file.Manual STEP 5 V6. Suas edições ou modificações ficarão salvas (em alguns casos você tem que confirmar duas vezes).

3. Aqui você deverá entrar com o tipo e o número do bloco que você quer criar no campo disponível na caixa de tarefa. 2. Source file” com yes e clique OK novamente.Você pode chamar a função para edição de um bloco de função a partir do menu “Editor> STEP5 block>in the program file 1”. . 6. não é este o caso. neste modo será mostrado os blocos possíveis.3. 4. O cursor sai posicionado no campo “Name” com 8 caracteres disponíveis para edição. Se o bloco já foi criado você deerá entrar no modo de edição digitando F6=Edit.3. Editando as instruções no bloco de função: Após preencher o cabeçalho o cursor será posicionada na primeira linha para edição da seqüência de instruções do seu programa.Manual STEP 5 V6.S5D) e o comprimento do bloco (LEN=0).6 17 1. 7. estes parâmetros deverão ser preenchidos pela instrução de chamada do bloco. 1. 5.3 Editando o bloco de função FB: 1. Digite CARWAS e pressione a tecla Return novamente.. O cursor irá saltar para o campo “Decl:. Marque as opções “Confirm before overwriting” e “Update seq.. ao selecionar esta opção uma caixa de diálogo será aberta. A tela de edição do bloco de função será aberta.” que somente tem função para aqueles blocos com parâmetros d entrada. 3.1 Editando o nome do bloco de função: O cabeçalho do programa contém o nome FB5 e o caminho (C:CARWASST. Pressione a tecla F3 “select” para entrar no modo de seleção. Entre o tipo de bloco e dê um número que ainda não esteja sendo usado no programa. estas instruções são detalhadas em capítulo separado. no caso do nosso exemplo entre como tipo FB 5 e complete a sua entrada com a tecla “OK”. Digite um bloco possível (depende do CLP) .

3 Editando o título do segmento 1 10. após isto o cursor deverá ser posicionado no segmento seguinte. . 12. No nosso exemplo você deverá digitar como primeira instrução 1: C DB 5.2 Editando o comentário: 8. Terminando o segmento Uma vez preenchido o primeiro segmento para ir ao segundo segmento você deverá pressionar a tecla “F6=Compl seg”. Você também poderá passar para o campo de comentário usando a tecla “Shift+F7=Extras” novas opções irão surgir você poderá mudar o campo usando as teclas F3=Fld left e F4=Fld right.Manual STEP 5 V6. ou digite *** no último campo.3. Uma vez na última posição de edição para passar para o campo seguinte pressione a tecla SETA À DIREITA ou SETA ESQUERDA. 9. no entanto os símbolos já declarados em letras maiúsculas podem ser digitados com letras maiúsculas.3. para editar o título pressione “F6=Seg com” e “SHIFT F6= Title” digite: “Prepare program execution”.3. 1.”.3. Digite a chamada do DB5 (contadores e temporizadores) “Call DB5(timer/counter values)” e então pressione a tecla RETURN para ir para a próxima linha de instrução. Pressione a tecla TAB para deslocar para a direita ou SHIFT+TAB deslocar para esquerda.3. Editando o título do segmento: O segmento editado no parágrafo anterior não tinha título algum. Você deverá editar as instruções sem necessidade de pressionar a tecla de espaço. Para apagar o campo de edição use a tecla F3=Delete na tela de edição. Editando a segunda linha do programa: No segundo segmento digite a instrução e os comentários pertinentes (conforme descrito no Apêndice A). 1. você poderá inserir uma linha de edição extra usando a tecla F7=Vert exp.4 Terminando o segmento 1: 11. Após digitar a instrução você poderá ir para o campo de comentário deslocando o cursor para o último campo.6 18 1.3. Para sair deste campo você deverá pressionar a tecla RETURN ou “Insert.

3.6 19 1.6 Corrigindo a linha de instrução: Você pode corrigir a linha de instrução da mesma forma que você fez com o bloco de dados.1.5 Corrigindo e editando símbolos: 13. Complete a correção pressionando F8=Return.0 (only 1 cycle)”. .3. uma diferença: As funções apagar “delete” e inserir “insert” afeta a linha toda. a primeira vez que você digitar este símbolo o programa exibirá a mensagem: “No assignment. Corrigindo e editando símbolos: No nosso exemplo na quarta linha e na sexta linha do segmento 2 o símbolo – POSPUL.3. Quando você retornar ao segmento 2 complete.3. Pressione F2=Edit symb e depois de editar o símbolo e o comentário pressione F2= insert.conforme a descrição abaixo: 1. Para apagar a linha posicione o cursor bem no início da linha.INI e o cursor aparecerá sobre a linha descrita com F10. Na opção “Output” posicione o cursor na linha quatro e (onde você quer inserir o comentário) e pressione a tecla F1-Disp symb para chamar o editor de símbolo.Manual STEP 5 V6. (sybol not defined)” você deverá então completar a edição deste símbolo. 15. existe.1 no lugar do símbolo –POSPUL com isto o programa irá liberar a edição para você. Ao final da edição você deverá digitar a tecla “Insert”. Para editar um novo símbolo. 14. complete a linha com o símbolo “POSPUL” e o comentário “pulse flag for 10. A lista de símbolos será aberta e seqüência apresentada é aquela gravada no arquivo *ZO. O programa irá abrir uma caixa de mensagem “Enter changed segment? “ selecione a opção “Yes” você deverá trocar a opção da edição para “Output” isto habilitará a edição do comentário. no entanto. primeiro você deverá escrever F10.

Editando os segmentos 4 e 5: Uma vez que você tenha pressionado a tecla segment end.3. Pressione a teclas Page Up duas vezes e digite o rótulo do salto. 1. 18.7 Escrevendo o comentário do segmento: 16. Para escrever o comantário do segmento proceda como descrito a seguir: Pressione a tecla Shift F6=Seg com e shift F7=Comment ou pressione COM duas vezes. Você retorna ao bloco de edição com a tecla F8=Return. você irá inserir mais tarde este segmento. o cursor é posicionado na primeira instrução do segmento 3. antes dos dois pontos.Manual STEP 5 V6. completando cada linha com a tecla Return. 20.3. Digite os textos para os segmentos 1 e 2. 17. digite neste ponto de instrução as instruções descritas no segmento 4 e 5.8 Deslocando entre os segmentos: Para deslocar entre os segmentos ou pressione F5=Seg fct e pressione a tecla F1=-1 ou F2=+1 para ir para o seguinte anterior ou seguinte respectivamente ou use as teclas “Page Up” e “Pag Down”.3. Uma característica especial do segmento 4 é a instrução de salto para a segunda instrução. pressione a tecla F1=New.9 Inserindo um novo segmento: Para inserir um novo segmento use a tecla “F5=Seg fct” e depois “F5=Insert” novamente. 1. o cursor será posicionado na primeira linha do novo segmento vazio. Depois.3.6 20 1. . Sob o caractere $ com o número do segmento você poderá escrever o comentário do seu segmento conforme descrito no Apêndice A. Você pulou as instruções do segmento 3 de propósito.3. O rótulo do destino do salto (label) descrito como CONT deve ser posicionado no início da linha do destino do salto. Edite o novo segmento e pressione a tecla Insert e confirme.3.

Sua cópia impressa do programa CARWASST.INI.S5D deverá corresponder ao programa mostrado no Apêndice A.4 Documentando o programa: Você poderá imprimir a seção do seu programa FB5. Inicie a impressão selecionando a tecla “OK” A cópia impressa contém os seguintes elementos para cada segmento: -o título do segmento e o número de segmento -as instruções com comentários de linha -os nomes dos operando contidos na lista de símbolos.Manual STEP 5 V6. . Primeiro entre com “FB5” especificando o bloco.6 21 1. sobre as opções que aparecem selecione “Word-oriented” e o tipo de impressão “standard”. Mude para o menu Documentation >standard output>STEP 5 blocks: Você poderá ver uma caixa de diálogo e você deverá entrar com os blocos e os segmentos.INI definido na página 2 (Pag 2). o banco de dados e a lista de símbolos.3. escreva no seu lugar CARWASDR. 2. 1. O arquivo de impressão tem o nome padrão (default) NONAMEDR.

Manual STEP 5 V6. no diretório \ S5_DATEN\DEFAULT. Isto irá ajudá-lo a familiarizar-se com a transferência. (Arquivo destino) Você deverá copiar o arquivo PROEXA*.. blocos e arquivos: Nós interrompemos a edição do programa da lavagem de carros carwash no quinto segmento e iremos adicionar agora as seções deixadas para trás no programa . Para transferir o arquivo. Uma tela de diálogo será aberta e você deverá selecionar o destino dos arquivos do programa. O programa completo está localizado com o nome PROEXA. . 2.. você poderá transferir os arquivos um por um usando a opção “single”. cópia apagamento de diretórios usando as funções do DOS no STEP 5. use as funções do DOS como segue: 1. Selecione o menu “Copy” da opção “DOS file”. Para transferir o programa você deverá selecionar o menu Object>DOS file> Copy como descrito abaixo. Acione a transferência clicando em “transfer” ou pressione a tecla “RETURN”. 4. O programa STEP 5 mostra a opção que indica que o arquivo já existe e que você deve confirmar que ele pode ser sobre escrito. Se você tiver selecionado “Confirm before overwriting”. Por exemplo: Source drice: C:\S5_DATEN\DEFAULT (Arquivo fonte) Destination drive: C:\S5_DATEN\EXAMPLE.* seguindo os seguintes passos: 3.6 22 1.4 Transferindo os segmentos. overwrite?”. Confirme a seleção selecionando “yes” e saia da opção usando a tecla ESC=Exit. 5. Primeiro observe se o diretório está selecionado corretamente. Marque “all” na janela de modo de cópia “copy mode” e selecione “Yes” na opção de confirmação de sobre escrever “Confirm before overwriting”.”file already exist.

4. Alteando arquivos:: 1.1 Verificando arquivos contidos em um diretório: Você pode verificar os arquivos contidos em um diretório seguindo o procedimento abaixo: Selecione o menu DOS>Directory observe todos os arquivos contidos no diretório PROEXA que devem ser copiados como se segue: Selecione o diretório: C:\S5_DATEN\EXAMPLE\ sobre “Drive\dir”. uma vez que os blocos de dados são semelhantes. A partir destas opções o arquivo do projeto CARWAS será arquivado como “PROEXA”. Agora que os dois programas já estão salvos em um mesmo diretório você pode alterar ou inserir as partes que estão faltando em seu programa.Manual STEP 5 V6. Você pode substituir o FB5 incompleto pelo FB10 completo e alterar o nome do bloco de função para FB5. 3. Transferir os blocos de organização.6 23 1. . 2.1. Você pode transferir segmentos que estão faltando.

Como origem especifique “as sourrce: C:\PROEXST. A mensagem “block(s) transferred” será apresentada. Confirme a mensagem com “yes”. overwrite?” e “FBDO... Responda “yes”. 5. Para transferir o bloco você deverá selecionar Objext>Blocks>Trasfer>File.1. Em seguida será mostrada a mensagem “Transfer comments as well?”.6 24 1.File. 4. Na lista que aparece sob “selection” e “block liste” selecione o bloco que você quer transferir FB10 neste exemplo.Manual STEP 5 V6.S5D\ ->\S5_DATEN\EXAMPLE” Quando você pressiona F3. confirme pressionando a tecla “OK” e saia da tarefa pressionando a tecla “ESC” . e Como destino “as destination C:\CARWASST. 3.. o STEP 5 irá abrir uma janela de diálogo complete como descrito abaixo: 1..S5D ->\S5_DATEN\EXEMPLE\ “. overwrite?” não aparece a primeira vez que você transfere o programa. isto significa que o FB10 deve primeiro ser transferido do programa PROEXST. Depois pressione a tecla transfer ou clique na tecla RETUR o STEP 5 irá mostrar a mensagem “write preheader to FD?”.2 Como transferir os segmentos: Segmentos somente podem ser transferidos entre blocos do mesmo programa. Nota: A mensagem “FC10 Already in file.4. o STEP 5 mostra a localização no diretório de trabalho: 2.S5D para o nosso programa CARWAS.010 Already in file.

Mova o cursor para segmentar 6 usando a tecla “Page Up” do teclado ou a tecla “+ “.. 1.1.. 2. Selecione o caminho abaixo “Object>Blocks>Directrory>in the program file.” no menu “Object” ou pressione a tecla F3=DIR na caixa de seleção (Directory file: settings).. 4.4 Transferindo segmentos: 1.3 Verificando se O bloco transferido está no programa: 1. 2. Para transferir este buffer para FB5 5. Selecione FB5 no editor de bloco e mova o cursor para segmento 5 no final do programa.. Pressione as teclas “F5 = Seg fct” e depois “F4 = File”. é exibido na tela. Marcando a seleção correspondente.1.4. você também pode imprimir esta lista ou transferi-los para outro arquivo. Uma cópia de segmento 6 está carregada no buffer de sistema.4. Complete a operação com a tecla F8 = Return e ESC = Exit você pode encerrar FB10 agora. Clique “All blocks” se já não estiver selecionado.Manual STEP 5 V6.6 25 1. Depois pressione “output” ou pressione a tecla RETURN ou tecla “Insert” Uma lista dos blocos contidos no arquivo de programa CARWAS. Entre no editor de bloco e pressione a tecla FB10 na caixa de trabalho. 3. .

proceda como descrito abaixo: Vá para Página 1 da parametrização de projeto e entre PROEXAZ0. Então pressione F2 = Buffer para juntar o segmento 6 ao programa CARWAS. Isto é devido ao novo programa estar com a lista de símbolos incompleta.Manual STEP 5 V6. Para corrigir esta situação. Complete a operação pressionando a tecla F8 = Return e F7 =OK. 7. e então. você pode inserir ou retirar segmentos de outros blocos no arquivo de programa.. Você poderá encerrar então a edição.6 26 6. Com este procedimento. os operandos nos segmentos 6 e 7 são também exibido em forma simbólica. é muito demorado. Pressione F5 = Seg Fct e F6 = Append (juncar unir).. salve tudo pressionando a tecla F6. é este método serve. Como você pode ver. porém.INI na opção “Symbol file”.. Você poderá verificar isto chamando o bloco FB5 novamente no editor de blocos. Para transferir seções extensas do programa. nem todos o operando nos segmentos novos estão escritos com os seus símbolos. . Repita o procedimento de transferência para segmente 7. Responda “Yes”. Desde o editor de bloco você pode acessar a lista de símbolos do programa atual.

assim como. Se você deve conferir o diretório do bloco para ter certeza que o bloco FB5 foi apagados. selecione "Object>Blocks>Delete" no menu Objet. • E então.Manual STEP 5 V6. a mensagem de sistema "Delete comments as well? Será mostrada”. 2. você deverá proceder como descrito abaixo: • Primeiro FB5 deve ser apagado inclusive os comentários. renomeie FB10 como FB 5.5 Transferindo e renomeando blocos: Para substituir o bloco FB5 no programa CARWAS. • 1. Confirme esta mensagem com “Yes” e a mensagem "block(s) deleted!" com OK.6 27 1..4. Para apagar FB5.1. Depois que você apertar Delete.005.. pelo bloco FB10 completamente. Entre com "FB5" na caixa de trabalho. . FC5 e FBDO.

Complete os campos com: .arquivo de destino “Dest”: C:CARWASST.6 Renomeando um bloco: 2 1.1. "Obkect>Blocks>Transfer>File to File.Manual STEP 5 V6.4. Quando você conferir o bloco diretório.. ." no menu Objeto e então ENTER. Pressione a opção “Transfer” e confirme os mensagens de sistemas com “Yes”.S5D e . No editor.[ FB10 ] as [FB5 ]". cheque se o FB5 novo está completo com 15 segmentos.marque a opção "Copy block.6 28 1. você verá que há um FB5/FC5 novo junto com FB10/FC10. com os operandos simbólico e todos os comentários.. Para renomear FB10. 2.

Para transferir os OBs selecione "Object>Blocks> Transfer "no menu “Objet” e entre no arquivo de fonte com PROEXA. supondo que o programa “CARWAS. e no destino com o arquivo CARWAS.1.6 29 1. para isto siga o procedimento abaixo: 1..” contém todos os blocos requeridos para o controlador.Marque todos os "OBs".4. na caixa de trabalho..7 Transferindo um bloco de organização (OB): Para completar o seu programa contendo FB5 e DB5 os blocos de organização que está faltando também devem ser transferidos.. Quando você pressionar a tecla de transferência.Manual STEP 5 V6. exibirá os comentários "Transfer comments as well" (transferir os comentários também) o qual você deverá confirmar com OK e então "Blocks transferred" o qual você novamente confirme com “Yes”. 2. o sistema. A operação de salto incondicional em OB 1 deve ser mudada agora para JU FB5 e as chamadas do banco de dados CDB 10 deve ser mudada para C DB 5 em FB 5.... .

Você pode gerar este arquivo através do caminho "Management> Generate XRF" no menu principal. Verificando e modificando um programa: Além das funções do editor o STEP 5 possui umas séries de funções com as quais você pode conferir.1 Cross Reference (Referência cruzada): O STEP 5 armazena referências cruzadas para declarações que contêm o mesmo operando (até mesmo em outros blocos) no arquivo de XRF (* XR. . Aperte F2 = Jump. Pressione F2 = Reference seguido de F5 = Orig blkde Orig.Manual STEP 5 V6. O bloco de organização OB 20 é exibido. No arquivo de XRF você deverá selecionar Página 1 das "settings". 1. Você pode experimentar agora algumas destas funções no programa CARWASH. 5. que é o operando que a referências cruzada irá processar. O cursor é posicionado no primeiro bloco referência “OB20 :1/AN.5 Gerenciando. Esta tabela contém todos os pontos no programa ao qual o operando pertinente estão endereçados. Você pode exibir as referências cruzadas agora para cada operando contido no editor de bloco seguindo a descrição a seguir: 1. Chame o FB 5 no bloco o editor e posicione o cursor em segmento 2 na instrução “STARTUP”.6 30 1. Pressione F2 = Reference e mais uma vez F2 = Disp XRF. Para retornar a tabela: Posicione o cursor no endereço que deseja pesquisar e pressione F2 duas vezes e a tecla de RETURN. 6. 3. Se necessário você pode mudar ao modo de edição e fazer modificações. 2.Para Voltar a FB5 pressione a tecla F2 para voltar novamente para o OB 20. e ainda renomear operandos no seu programa. Uma tabela de referências cruzada para o operando selecionado será exibida como na figura abaixo.INI).” 4. O cursor ficará piscando agora debaixo de F 10. documentar.7.5. Confirme com a tecla “Insert” RETURN.

Q. F. contadores).Manual STEP 5 V6.2 Imprimindo a Lista cruzada: O menu de "documentation" lhe proporciona umas séries de listas dentro do qual as referências cruzadas ou são compiladas para um único operando (neste caso F 10.7) ou para um grupo de operando (por exemplo eu. O segmento 2 no FB10 é então mostrado: 1. Os asteriscos ao lado de números de segmento indicam que o operando ocorre em uma instrução. Figure abaixo mostra a cópia impressa das referências cruzadas para o "outputs" em FB5 e os "conters" e a variável inicial (F 10.5.6 31 Você pode repetir o salto a outro bloco de referência posicionando o cursor em FB10:2/AN na Figura abaixo e pressione F2 = Jump. As referências cruzadas podem ser restringidas a um bloco particular ou estendido a fim de cobrir todos os blocos no programa. Você pode selecionar a lista você quiser marcando as opções na caixa trabalho “Output XRF list”.7) em todos os blocos. SEG 2. .

6 32 .Manual STEP 5 V6.

saída ou variável usada no seu programa. Aperte F2 (no seg1).3 Usando a função Search (Procura): Durante a sessão de edição.6 33 1. 4. Chame FB5 no editor de bloco e pressione a tecla F3 = Search. Esta função é muito útil quando você estiver depurando um programa feito por outra pessoa ou ainda quando você pensar em usar uma variável e quiser saber se esta variável já está sendo usada no seu programa. Pressione F3 = Search novamente e F3 = Continue O segmente 4 é exibido com o cursor na linha 6. Como a tecla de procura (KEY:) especifique um operando. etc. A primeira ocorrência deste operando é exibida no segmento 3 instrução 1. para isto proceda como descrito abaixo: O resultado da busca lhe dará informações sobre a localização no seu programa do endereço de entrada.5. Pressione F3 = Search novamente e F3 = Continue. 2.Manual STEP 5 V6.C-BACK. . etc. 1. O segmente 3 é exibido com o cursor na linha 9. neste caso I 32. você pode executar uma busca através da referência cruzada. 3.5 ou .

5 o endereço do operando novo: Q 1.. Cheque se a modificação foi feita como segue: 5.Chame o bloco FB10 no editor e pressione F3 = Search. operando Q 1. . Entre em FB5 no caixa de trabalho e confirme com OK.7 foi alterado três vezes no lugar de -DRY.6 34 1. Digite no operando velho: Q 33.4 Corrigindo e reescrevendo o seu programa: 2ree Às vezes é necessário nomear um endereço novo para um operando já existente dentro do programa.7.7. . Usando a função "rewiring" você pode renomear estes operandos. renomear endereços de I/O diferentes. o sinal para abrir e fechar as válvulas de ar para secar o carro agora é produzido por Q 1. Segmente 12. 3. 4. . Chame a função “Management>Rewire>Manual” Confira o nome dos arquivos: (Program file C:CARWASST:S5D to Program file C:CARWASST:S5D) 2. por exemplo. Uma tabela é apresentada na qual você entra com o operando velho em representação absoluta no lado esquerdo (old operand) e o operando novo no lado à direita (new operand).Manual STEP 5 V6. por exemplo. Complete sua entrada com a tecla “Insert” e confirme as mensagens de sistema com “Yes”. 1. vamos mostrar como você deve proceder para renomear um dos operando de saída em FB10.5.7 e pressione F2 (No seg 1).Digite no campo “Search” (procura) Q 1. Para ilustrar como esta função trabalha.

S5D abaixo de " Compare with program file" e FB5 abaixo da lista de blocos.Manual STEP 5 V6. pressione a tecla “OK” ao final da pesquisa será apresentado uma tela onde você poderá visualizar o resultado da pesquisa. você poderá conferir o segmento 12. Experimente esta função comparando o conteúdo do bloco de função FB5 em CARWAS.6 35 1. A caixa de trabalho STEP 5 exibirá todas as comparações como mostrado em Figura abaixo.. que você já modificou com a função “rewiring”. 3. chame os " Blocks>Compare> File .. entre com C:PROEXAST.5. Para isto proceda como indicado abaixo: 1. Se não tiver nenhum PLC conectado você poderá comparar blocos entre arquivos de programas diferentes." 2. quando. repita o bloco comparação marcando "todos os blocos". Na caixa de trabalho. Você também pode reconhecer que diferentes blocos de funções FBs são chamados em OB1.. No menu de Project (Object). ..5 Comparando blocos: STEP 5 provê um função comparação que você pode usar para comparar blocos do mesmo tipo e mesmo número no PLC e no PC (PG). então. com o bloco de função FB original em PROEXA. Após fazer isto.. 2 . As operações de STEP 5 discrepantes são listadas com os endereços em código de MC5.file. Blocos não existentes são indicados pela mensagem 020D.

1. entre em C:CARWASST. Confira a carga gerando uma lista dos blocos no PLC. uma vez mais marque a opção “all blocks” na caixa de trabalho. 1.S5D como a fonte na caixa de trabalho e debaixo selecine “FB5” na lista de bloco “DB5” e finalmente “all OBs.1 Carregando um programa: Complete a carga do programa usando a função “Blocks> Transfer” no menu de objeto. . 3. Transfer” no menu de objeto. Estabeleça a conexão permanente entre o PC (PG) e o PLC como segue: Na Página 2 do menu de parametrização "Object>Project>Settings>Page2". Se já não esta selecionado.] " usando F3 = select e F6 = Save. Mude o modo a "online[cycl. A lista só contém as seções do programa requeridas pelo controlador programável.6. Uma lista de todos os blocos carregados no PLC é gerada.Manual STEP 5 V6. 2. Nota: Também são mostrados os blocos de sistemas do PLC.6 36 1. Confirme isto com OK.” (todos os blocos operacionais).6 Carregando e testando o seu programa: Para testar o programa carwash você tem que conectar um S5-95 ao seu programador. 5. Para fazer isto. Selecione “Blocks. os blocos pertinentes serão copiados para o PLC. Depois de pressionar “Transfer” (transferência). Comentários e blocos que não tiveram transferido os seus cabeçalhos não são mostrados também. 4.

Significado dos LED’s: LED VERMELHO LED VERDE X X X X SIGNIFICADO CPU iniciando no modo COULD restart. Modo STOP Modo RUN Programa rodando .como por exemplo um loop infinito. RE reset da memória retentiva. O painel da CPU é mostrado abaixo: 1: Chave de seleção STOP/ RUN 2: LED de indicação modo RUN. 3: LED indicação CPU em STOP. A CPU S5-115U ou CPU’s desta família apresenta uma maneira peculiar para esta operação de reset. OR reset geral 5: Ledo de indicação de erro 6: BASP desabilitação dos módulos de saída. esta seqüência é mostrada abaixo. uma seqüência de acionamento das chaves do painel da CPU deve ser executada para que esta saia do stop e reset a memória.7 Reset da CPU S5-115U: Eventualmente a CPU entra em stop. com isto toda a memória é apagada e você pode então carregar o programa corrigido.6 37 1. Uma forma de sair da situação de STOP consiste em ressetar a CPU.Manual STEP 5 V6. 4: Chave para seleção dos modos de restart: NR reset da memória não retentiva. normalmente isto acontece quando uma parte do programa apresenta problemas.

O LED STOP irá apagar momentaneamente. Solte a chave de restart (4) para a posição RE. Ligue a chave (4) de restart para a posição mais baixa OR e mantenha nesta posição ( A chave não fica sozinha nesta posição. .7.2 Procedimento para o RESET usando as chaves da CPU: Ligue a alimentação da CPU.7. neste caso serão ressetados as seguintes áreas de memória: • Memória de programa do CLP. temporizadores e contadores). Toda a área de identificação de erro: Existem duas maneiras de ressetar a emória: • OFFLINE através das chaves na CPU.Manual STEP 5 V6. Ligue a chave de seleção do modo de operação (1) para ST (stop). a chave normalmente volta para a posição RE). ST->RN RN->ST ST->RN OR->RE SOLTE. RN->ST RE->OR SEGURE..1 Procedimento para o RESET geral: Você deverá proceder a um reset geral antes de carregar um programa novo. Enquanto você segura a chave em baixo na posição OR troque a chave (1) para a posição ST para RN duas vezes.6 38 1. 1. • Toda a memória de dados (flags. • ONLINE através da função “DELETE” do programa S5.

LAD etc. você pode usar oito chaves on/off conectadas as entras (I32. I32.6 39 1... selecionando a função " block status" ou " status variable".) você poderá acionar o teste d programa no PC (PG).. Dependendo do método escolhido para a representação do programa (STL.7. Na tela do PC (PG) irá ser apresentado um diagrama dinâmico mostrando as reações do PLC com respeito as entradas e saídas. Você pode usar um simulador para modificar as entradas e observar as saídas..0 e I 33.0.3 Testando o programa: 2 Você pode testar o seu programa agora.Manual STEP 5 V6. pode ser visto on-line segmento por segmento e instrução por instrução com isto você poderá verificar se o seu programa está rodando corretamente. uma forma de obter esta configuração é usando o simulador da Siemens (número de pedido 6ES5788-8MK11). por exemplo. .7) e dois botões (I33.1). o bloco de função FB5.

1 (= ON). Debaixo da informação de cabeçalho. o resultado de operação de lógica (RLO ) serão exibidos e os estados de ACCU 1 e ACCU 2 (acumuladro 1 e acumulador 2). marque as opções com “yes” e pressione a tecla OK. Mova os interruptores I32. As entradas na coluna “status” (estado atual) e "SAC" (endereço dos contadores) esta informação é irrelevante neste exemplo. Selecione o bloco de função FB5 na caixa de trabalho. a instrução. O segmente 1 aparecerá descrito no método "STL" de representação. No segmento 4. troque todos os interruptores para a posição desligada (= off) e selecione o seletor de modo no PLC para STOP. e a mensagem DIRIJA CARRO DENTRO é exibido. 3. O contador de passo e ACCU 1 têm o valor 1. Mova o ponto de parada para segmentar 6 e mova a chave da entrada I 32. desaparece e você pode ver que a instrução do ramo seguinte não é processado e a mensagem “Statement not processed” é apresentada.0 (start) o processo de .4 Ativando a função Block Status: 1. No PLC.STEP). Estada etc. 1. Agora troque o PLC para o modo RUN. o led da saída Q32. Na coluna 5 da tabela A-2 você pode ver quais entradas devem ser ligadas. Depois de pressionar o botão I 33.7. 5. o processo também pára no ramo. as entradas ligadas têm o estado 1. 2. 6. Agora mova o ponto de parada para segmentar 5 no qual de acordo com Figura KEIN MERKER no Apêndice A que é onde o processamento do programa da lavagem de carro realmente começa.5 e I32. Mova o cursor de interrupção para o segmento 3 pressionando = a barra de rolagem para cima duas vezes.4 acende.Manual STEP 5 V6.. A exibição do RLO. No simulador. O RLO=1 na linha 1 indica que todos o pré-requisitos foram satisfeitos para o início do processamento tais como posicionamento inicial da lavagem e o contador de passo (. 2. Comece o processamento da lavagem de carros (carwash) movendo para cima os interruptores descritos como I32.3 para cima para “car in position”. Mova o cursor para a linha seguinte a operação de salto pressionando o cursor para abaixo três vezes. Selecione a opção "Block status" no menu de teste (test). 4. O RLO (estado atual dos endereços) correspondente é exibido e ao lado direito do botão com a mensagem " Status processing active ".6 40 1. a situação é semelhante. 3.6 para cima.0 e I32.

Manual STEP 5 V6.Mova o ponto de parada para o segmento 7 e para simular a porta fechada desligue a chave da entrada I 32. você pode ver como o tempo de distribuição de cera WT é decrementado até 0 a um intervalo de tempo de 1 segundo disparado pela condição iniciais tendo a secagem sendo gerada automaticamente pelo contador de passo (= 7). Simule as partes restantes do processo no passo 8 e passo 9 como descrito acima.7 = on. você deve usar as informações provenientes do RLO (Resultado da operação lógica) e dos conteúdos dos acumuladores ACCUs para corrigir estes erros . Se erros de lógica acontecerem. 8.6 = off e ligue a chave da entradaI 32. A mensagem para o motorista é desligada (Q 32. mova o ponto de parada para segmentar 12..5 = 1. . giro das escovas (rotate brushes) e avanço do carro (carriage forwards) são iniciados (variável = 1). "As partes do processo que aplicam xampu (apply shampoo )".4 = 0) e a porta é fechado (Q 32. 7. Simule as partes restantes do processo de lavagem mudando as entradas de acordo com Tabela A-2 dependendo da posição do ponto de parada. o contador de passo retorna ao vlor 1. No segmento 14. indicando a posição inicial do programa carwash. Você pode seguir o tempo secagem (DT = 45 s). O contador de passo troca para 3.STEP) mudanças para 2. Isto significa que o programa exemplo rodou todas as etapas e cumprir todas as tarefas. 9. seguindo o estado da entrada I 32. O contador de passo (. No segmento 11.6 41 lavagem é iniciado.3 é iluminado).

Manual STEP 5 V6. apagar instruções já existentes ou inserir novas instruções.4. 2. Com os passos esboçados acima. Você deve posicionar o cursor na instrução que você quer modificar.1 Corrigindo o programa: Para corrigir de Pará o programa proceda como nenhum abaixo de exemplo: 1.7. para um arquivo 3.6 42 1. . você aprendeu a modificar o programa no PLC. PLC . Transfer. Selecione a opção "Blocks. Para transferir o bloco modificado ao PC (PG). Para isto pressione a tecla “Insert”e responde a mensagem "Enter modified segment?" (Entre em segmento modificado? ) e a próxima mensagem com “Yes”. e então.file" (Tranferir blocos do PLC para o arquivo) no menu objeto (Object) e entre com FB5 na caixa de trabalho. Mude o modo de edição com F6. por exemplo.

7. Mova todas as chaves liga-desliga no simulador para a posição desligado (OFF) e o botão seletor de modo de trabalho no PLC para STOP. Entre todos os operando de saída inclusive os temporizadores e contadores no formato absoluto ou simbólico e finalize cada linha com a tecla de RETURN.6 para "ligado." (ON). complete estas preparações por pressionar a tecla de Insert ou F6 = Activate (Ativar). Usando a tabela verdade. Uma tabela vazia com as colunas " Operands: "(Operandos) e " Formats: " (Formatos) será mostrada na tela.5 e I32. 5.Manual STEP 5 V6.4. O programa do carwash vai para o estado pronto com Q 32.1 para "ligado" (ON). 2.2 Verificando o valor de uma variável (Status variable): 1.4 = 1 e C 2 = 1. 4. Desta forma a sua lista de operando ficará com os mesmos conteúdos mostrado no Figura abaixo. Teste o bloco de função usando a função de verificação do valor das variáveis (Status variable) como segue: 6. Selecione a opção “Status variables” no menu de teste (Tert).0 e I 32. pressione F2 = Store (Armazenar) e especifique o número do bloco de variáveis (neste caso VB 5). 7. O STEP 5 acrescenta automaticamente o formato às suas entradas. Mova as chaves das entradas I32. Os valores atuais dos operando (inicialmente todos os 0) e as mensagens são acrescentados “PLC in CYCLE” e “Status processing active” serão adicionados a coluna “Signal states”.6 43 1. Troque a chave de modo do PLC para RUN e a chave liga desliga da entrada I32. . você pode conferir novamente a reação do controlador a certas combinações de valores das entradas. 3.

No passo 9 (I32.Manual STEP 5 V6. Simule o movimento do carro para trás. Simule o estado "porta fechada" desligando a chave da entrada I32. . depois é só apertar a tecla Insert para continuar o processamento. O PC (PG) exibe os estados das variáveis conforme mostrados no Figura abaixo. e para frente ligando e desligando as chaves I32.7 = ON. O STEP 5 exibe o valor das variáveis e o ponto de parada selecionado.6 = desligado) o display DIRIJA CARRO PARAFORA é exibido e no último passo (I32. O sistema de movimentação das escovas será movimentado para frente com as escovas girando e o jato de xampu aberto. 10.4 e I32.3 = 1).0=ON. P Terminar a função de verificação do valor das variáveis. Continue simulando as entradas até que os dois temporizadores WT e Dtconcluam suas contagense o programa chegue no passo = 8.7 = desligado. A porta será fechada (Q 32. pressione ESC = Saída e você voltará ao menu com F8.6 = OFF e ligando a chave da entrada I32. Simule o carro sendo dirigido dentro ligando as chaves das entradas I 32. I32. 11. o contador passo muda para o valor 2 e o contador C 20 assume o valor C20 = 1.9.3 = desligado) o estado inicial é restabelecido com o display mostrando a mensagem CARRO NA ENTRADA e o contador de passo=1.6 44 8. Pressionando a tecla ESC você pode interromper o estado que processamento e inserir operandos adicionais na a lista.5.3 = ON e iniciando o carwash I33.

6 45 1. então. Você pode alterar agora diretamente as saídas de QB 32/QB 33 com o teclado e pode conferir a resposta do programa. Sua tela se assemelhará à tela ilustrada no a figura abaixo.4/32. a saída Q32.1 para "Ligado "(ON) e o PLC de STOP para RUN. .Manual STEP 5 V6. Uma vez mais. uma lista de operandos deve estar montada para a execução desta tarefa.Formats”. Experimente isto como segue: Entre com o padrão de bit KM = 00110011 no QB 32 e pressione Insert.”(Termino do "forçamento) irá aparecer na tela. Pressione ESC = Saída e troque a chave I32.4. No PLC.3 Forçamento das variáveis: Com esta função você pode modificar o valor das variáveis (por exemplo I/Q/F) diretamente no o byte do processo imagem.5 devem ser ligados e a mensagem “End of force fct. ativando os interruptores no simulador um depois o outro. Você também pode exibir os estados atuais com o PLC no o modo de RUN.0/32.7.0/I 32. Selecine a opção “Force variables” (forçamento das variáveis) no o menu de teste e digita as entradas e saídas como operando do tipo Byte (IB e QB) na a tabela vazia “Operands . (Operando – Formatos). Complete a edição de cada linha com a tecla de Return e escreva sobre o formato padrão com "KM". Acrescente C 2/C 20 e T 20/T 22 à lista e então pressione F6 = Activate. você pode exibir os valores correspondentes às saídas e contadores (exatamente como na função Status).1 e Q32. O PC (PG) exibirá a coluna " Force process image “ (Força processo imagem).

6 46 1.8 Apêndice A: Conteúdo do banco de dados usado no programa “CARWAS”: .Manual STEP 5 V6.

Para isto as entradas e saídas ( I/Os) deverão ser copiados em uma tabela como mostrado abaixo.Manual STEP 5 V6. é mais fácil de usar símbolos para as variáveis de input/output. .6 47 Listando as variáveis de entrada/ saída (input/output) Para descrever o processo e escrever o programa.

.São listadas as condições que devem ser avaliadas em função do passo de controle lógico sobre a linha dupla e as ações que são executadas se as condições forem cumpridas estas ações são listadas é listado abaixo da linha dobro. A tabela verdade (Tabela KEIN MERKER) deverá ser lido como segue: . Uma descrição verbal da seqüência de processo foi selecionada e as tarefa de controle são determinadas a partir de uma tabela verdade. representação das funções de controle na tabela verdade. Um passo importante no desenvolvimento do programa é estabelecer a seqüência de controle baseado nas representações esquemáticas e na lista de todas as variáveis de processo. Isto pode ser alcançado. por exemplo. na forma de fluxogramas.Manual STEP 5 V6.Uma coluna corresponde a um número de controle que é descrito verbalmente na seqüência e então programada como um segmento em STL no passo seguinte do desenvolvimento de programa. .6 48 Descrição da seqüência de processo.

Manual STEP 5 V6.6 49 Descrição dos segmentos do programa: .

6 50 .Manual STEP 5 V6.

6 51 .Manual STEP 5 V6.

Sign up to vote on this title
UsefulNot useful