Module 11: Creating Solids Using Quilts

Lab Exercises If you are ready to start on the exercises for this module, please click the links below. • Exercise 1: Completing the Bottle Design • Exercise 2: Completing the Upper Body of the Shaver • Exercise 3: Creating the Shaver Head Cover (Challenge) • Exercise 4: Completing the Lower Body of the Shaver (Challenge) Introduction Surfaces are used to define the complex shapes that you cannot define using solid modeling tools. You can merge the surfaces to create quilts. You can then create solids using the quilts as references by using editing tools such as Solidify and Thicken. The process of converting the quilts to solids requires you to add material thickness. Adding thickness can lead you to limitations when you try to apply the feature. You may not be able to add thickness beyond a particular dimension, due to the geometry of the surface. You can also use quilts to modify existing solid surfaces or use them to cut solids in design models. Also, in complex situations where standard solid rounds and chamfers do not provide satisfactory results, you can create fillets using surfaces. Objectives After completing this module, you will be able to: • Replace a solid surface with a quilt. • Patch a solid surface with a quilt. • Create cuts using quilts. • Create rounds and chamfers as surfaces instead of solids.

1

Creating Solids Using Quilts Surface geometry can be converted to solid geometry in the following ways: • Thickening surfaces – Material is added to either or both sides of the surface using the Thicken tool from the Edit menu. • Solidify closed quilts – If the quilt is closed, with no gaps at the edges, you can add material to the inside of the quilt using the Solidify tool from the Edit menu. • Solidify quilts intersecting the model – When a quilt intersects with the solid geometry such that there are no gaps or openings, the engulfed volume can be filled with material using the Solidify tool from the Edit menu.

2

Creating Solid Geometry from Surfaces Thickening surfaces • The first set of figures show the open surface being thickened using the Thicken tool. Solidify closed quilts • The second set of figures shows the closed quilt being solidified using the Solidify tool. Solidify quilts intersecting the model • In the third set of figures, the desired shape has been visualized over built surfaces. These are merged to form the desired quilt. The quilt is then merged with the solid using the Solidify tool.

Replacing Solid Surfaces • You can replace an entire solid surface using the Replace option in the Offset tool. • Surface replacement differs from protrusions and cuts because it can add material in some places and remove it in others. • Surface replacement is a surface deformation feature and creates a separate feature. Guidelines to use the Replace option: • If the replacing quilt does not extend beyond the boundaries of the existing solid, the system interpolates the existing surface, sometimes leading to undesirable or unexpected results. • If surface replacement adds material in some places and removes it in others, then the replacement quilt must consist of one surface only.

3

Surface replacement cannot be done in the Assembly mode as an assembly feature. • It is not recommended to create two replacement features on top of each other. It is good design practice to delete one replacement quilt before creating a new one. Or, you can redefine the existing tweak/replace feature such that it replaces a different surface or uses a different replacement quilt. • A quilt that has replaced a feature's surface cannot, in turn, be replaced by another quilt. The replacement surface must be deleted first. About the figures • In the first set of figures, the selected surface of the solid block is replaced with the selected quilt positioned above it, resulting in the figure on the right. • In the second set of figures, the Replace tool is used to add and remove material at the same time. • The third set of figures shows the replacement, using a quilt that partially covers the solid surface.

Replacing Solid Surfaces (cont.) • This slide displays an example of how to use the Replace option in the Offset tool to create a smooth shaped button. • You start by creating the approximate shape of the button using a solid feature such as an Extruded protrusion. • You also create a quilt using surfacing techniques that will be used to create the final shape of the button. • You select the solid surface to be replaced, as shown in the first figure. 4

you use the Replace option and the quilt as a reference to replace the solid surface. Patching Solid Surfaces • You can use the Patch option in the Solidify tool to replace a specified portion of a surface or surfaces with a quilt. • This feature differs from the replace feature as it can affect more than just one solid surface. All the boundaries of the replacement quilt must lie on the surfaces that you are patching. 5 . as shown in the second figure.• • Next. as shown in the third figure. You can use it to add or remove material from portions of solid surfaces or the entire solid surface. The patch feature can add or remove material using a single surface definition. The resultant solid will have the smooth shape of the quilt in place of the original solid surface.

in this case.Cutting Solids Using Quilts You can use open or closed quilts to cut solids. you select an open quilt as the cutting entity. • Using open quilts to cut away a solid – You select a quilt as the cutting entity and you remove all material on one side of the quilt. you can remove material a specific distance from either side of the cutting quilt. You use the Solidify tool to access this functionality. 6 . However. For example. or symmetrically about the cutting quilt. • Using open quilts to create a thin cut – Similar to the first method. you make a cut using the Thicken tool.

PRT. In this case. replace. 1. manipulate the resulting surfaces. Datum Axes . Task 1. cut. click Datum Planes . The figure above is intended for illustration purposes only. and Datum Coordinate Systems from the main toolbar to disable their display. 3. Exercise 1: Completing the Bottle Design Objectives After successfully completing this exercise. If necessary. • During design. Open the BOTTLE_THICKEN.Using Surfaces to Create Rounds and Chamfers • You can create rounds and chamfers as solid features or surface features.PRT. you will know how to: • Use the Thicken Tool. you can create the round/chamfer as a surface. • This is especially useful in situations where a round/chamfer would normally fail. create a solid feature using the surface for a protrusion. or patch. right-click the module_11 folder and select Set Working Directory. The default is to create them as solid features. Scenario You are tasked with completing the design of the Bottle part. The primary benefit of this technique is to enable you to edit the surface before the creation of the round or chamfer. In the Folder Browser . 2. Datum Points . 7 . adding a great amount of flexibility to this type of geometry creation. a round will automatically produce the result shown on the right. • Create a Full Round. and finally. Open the BOTTLE_THICKEN. In this case. it is sometimes convenient to create these features as surface type features instead of solid features.

PRT Task 2. Use the Thicken tool to create a material thickness. Click Edit > Thicken from the main toolbar. 2. flip the yellow arrow outward.BOTTLE_THICKEN. 1. Edit the thickness value to 2. If necessary. o Select the bottle quilt. o o o Adding Thickness to the Bottle 8 . Click Complete Feature from the dashboard. Select Quilts as the active selection filter.

Right-click and select Set Working Directory. o Click Complete Feature from the dashboard. In the Folder Browser 2. Task 1. 1. 9 . This completes the exercise. you will know how to: • Add thickness to a surface.Task 3. o Press CTRL. . Exercise 2: Completing the Upper Body of the Shaver Objectives After successfully completing this exercise. • Mirror the completed model. Click Save from the main toolbar and click OK. Scenario You are tasked with completing the BODY_UPPER model. Create a Full Round at the Bottle opening. 1. Click File > Erase > Current > Yes. 3. Open the BODY_UPPER model. and select the edges shown in the following figure. Creating a Full Round 2. browse to the module_11\shaver folder. Start the Round Tool from the feature toolbar. o Right-click and select Full Round.

ASM.PRT.5. 1. and then click Edit > Thicken. o Review the surfaces available in the part. BODY_UPPER Part Task 2. Open the SHAVER. Adding Thickness to BODY_UPPER 10 . Edit the thickness value to 1. Shaver Assembly 4. Remember. we copied geometry from the master part and trimmed the surface using the available curves. Select the BODY_UPPER.3. right-click and select Open. Add material thickness to the model. o o o Flip the direction downward if necessary. Click Complete Feature . Select the quilt.

o Zoom in and examine the material thickness in the assembly.2.PRT node at the top of the model tree.ASM to return to the assembly. Mirroring the Model 3. Click Window > BODY_UPPER>PRT to return to the model. 1. Select the BODY_UPPER. Select datum plane FRONT from the model tree. Thickened Model in the Assembly Task 3.ASM to return to the assembly. Click Window > SHAVER. Click Window > SHAVER. . Notice that the material thickness needs to be increased to match the step thickness in the head assembly. o o Examine the UPPER_BODY model in the assembly. 2. Mirror the BODY_UPPER model. 11 . o o o Start the Mirror Tool Click Complete Feature from the feature toolbar.

PRT and compare thickening options. Increase the thickness of the BODY_UPPER. o o o Type 2. 12 .0 for the thickness value. Read the dialog box and notice the green highlighted areas. o Right-click and select Delete. The thickness value is too large for the sharply curved rib areas. Click Preview Feature . 1. o Right-click and select Edit Definition. Select the Mirror 1 feature from the model tree. Click Window > BODY_UPPER.Thickened Model in the Assembly Task 4. Select the Thicken 1 feature from the model tree.PRT to return to the model. 3. BODY_UPPER Part 2. then click OK.

along the mirror line of the model. o Select the Options tab from the dashboard. and patched into the model. Select the Options tab. o o o Click Preview Feature .Problem Areas in Green 4. merged with the adjacent surfaces. o Notice the system has automatically excluded the problematic surfaces from the thicken operation. o Notice the surfaces of the ribs have been excluded from the thicken operation. Right-click and select Exit Verify. o Orient the model as shown. we could complete the thicken operation. Excluded Surfaces 6. We will explore other options first. 7. leaving these surfaces excluded. Notice that the ribs were successfully thickened. Click Yes and then click Resume Feature . 13 . Orient the model as shown. If desired. but an archshaped surface has been created near each rib. o Change the Normal to Surface option to Automatic Fit. Additional curves and surfaces could then be created manually. o Click Preview Feature .

Notice that the ribs were successfully thickened. Select the Options tab. Notice the material thickness was not normal to the surface in all areas due to the shape of the surface. Click Complete Feature .Automatic Fit 8. Right-click and select Exit Verify. Click Coordinate Systems their display. from the main toolbar to enable Orient the model as shown. This is not an acceptable solution because the BODY_LOWER will not mate properly. leaving a smooth surface for the mirror. Click Coordinate Systems their display. o o o o o Clear the Z check box. disabling translation of the model surfaces in that direction. from the main toolbar to disable Controlled Fit (CSYS shown for reference) 10. 14 . 9. o Change the Automatic Fit option to Controlled Fit. o o Examine the model in more detail.

o o o Click Resume Feature . Press CTRL and select the additional rib surfaces shown in the following figure.Indicating a Problem area Task 5. o Read the dialog box and click Yes. Click Complete Feature . 1. o o Select the Options tab. Surfaces Removed from Thicken 15 . Click Preview Feature . Thicken using Normal to Surface and construct curves and surfaces manually. Additional Surfaces Selected 3. Change the Controlled Fit option to Normal to Surface. Select the Thicken 1 feature from the model tree. Right-click and select Exclude Surfaces. 2. o Right-click and select Edit Definition.

Merge surfaces. Selecting Quilts 3.Task 6. . Click Datum Curve from the feature toolbar. Click Quilt/Surf > Done. 1. o Click Thru Points > Done. o o Start the Merge Tool Click Complete Feature from the feature toolbar. o o Select the eight vertices. (Be sure to select the lowest vertex available for each location. Selecting Vertices 2. 16 . Press CTRL and select the two quilts shown in the following figure. Repeat the merge procedure for the remaining three rib surfaces. 1. as shown in the following figure. 4.) Click Done. Double-click Attributes. Specify Quilts as the selection filter option. Specify Smart as the selection filter option when finished. Task 7. Create curves to be used as boundaries in the first direction. 2.

o Select datum plane FRONT from the model tree as the sketching plane. Click Close. o o o Click Specify References . Click Sketch. 4.o o Select the surface shown in the following figure. o Click Flip to reverse the sketch view direction. Click Entity from Edge from the Sketcher toolbar. o Click Close. o Select the three edges shown in the following figure. Click OK to complete the feature. o Select Top as the orientation direction. Start the Sketch Tool from the feature toolbar. 17 . o Select datum plane TOP from the model tree as the reference plane. Selecting a Surface for Curve to Lie On 3. Selecting References 5. Select the two vertices shown in the following figure as references.

Completed Sketch 18 . o Click Complete Sketch . as shown in the following figure. one in each of the remaining gaps (the completed sketch is shown in red in the following figure). Sketching a Conic 7. Sketch three additional conics. o Click Conic Arc from the Sketcher toolbar. Zoom in on the gap on the left.Selecting Edges 6. o Use the same dimensioning scheme as the previous conic. o Sketch and dimension the conic.

1. Repeat the procedure to copy another one-by-one chain on the right side. 19 . .Task 8. Click Copy o and then Paste from the main toolbar. Selecting and Edge 2. Select the edge shown in the following figure. Click Complete Feature 4. as shown in the following figure. Press SHIFT and select the edge again to begin the one-by-one selection. o Continue pressing SHIFT and select the adjacent edge. as shown in the following figure. Selecting One by One Chain 3. Create curves for you to use as boundaries in the second direction.

as shown in the following figure. as shown in the following figure. Press CTRL and select the upper and lower curves. 2. De-select all items by selecting the background. Right-click and select Second Direction Curves. 1. Create a boundary blend surface using the previous curves. Right-click the lower boundary handle and select Tangent. Selecting Curves in the First Direction 3.Second Copied Curve Task 9. Start the Boundary Blend Tool o . Selecting Curves in the Second Direction 4. o Press CTRL and select the left and right curves. 20 .

o Creating and Completed Sketch 2. Click Complete Sketch . click Edit > Fill. With the sketch still selected. Click Complete Feature Task 10. Start the Sketch Tool o o o Click Use Previous. o Press CTRL and select the two quilts shown in the following figure.Changing Lower Boundary to Tangent 5. 1. from the feature toolbar. . De-select all items by selecting the background. Task 11. Create a series of merge features to form a single quilt. 21 . Create a sketch that you will use with a fill feature. Specify Quilts as the selection filter option. from the Sketcher toolbar. 1. Click Entity from Edge Select the edges (16) to form the outline of the sketch shown in the following figure (also shown completed). 2.

Press CTRL and select the two quilts shown in the following figure. 4. .o o Start the Merge Tool Click Complete Feature from the feature toolbar. o o Start the Merge Tool Click Complete Feature from the feature toolbar. . merging them into the main quilt. De-select all items by selecting the background. Selecting Quilts 3. Repeat the previous merge procedure for the remaining three rib quilts. Selecting Quilts 5. 22 .

. View the completed solid.Task 12. Flip the arrow downward if necessary. o We have accomplished our goals of having a material thickness of 2 and having the desired rib geometry. Select the following four features that come before the boundary blend in the model tree. Mirror the model. Hide curves and patch the surface quilt into the solid. Completed Solid Task 13. Selecting Features 2. 23 . o o o o Click Edit > Solidify. 3. Accept the default of Patch Click Complete Feature . 1. o Right-click and select Hide. Select the merged quilt.

o Notice that the mirrored halves do not blend together smoothly in the area near the ribs. o o o o o Select the Constraints tab. Mirrored Surfaces not Smooth 5. Select datum plane FRONT from the model tree. 24 . Press CTRL + D to orient to the standard orientation. Select Direction 1.First Chain. Click Complete Feature .1. Examine the underside of the model. Enable the Add Side Curve Influence option. right-click and select Hide to hide the curves within the mirror.PRT node from the top of the model tree. Notice that the halves now blend smoothly. 4. Select Boundary Blend 1 from the model tree. o o o Start the Mirror Tool Click Complete Feature from the feature toolbar. Select the BODY_UPPER. 3. . With the Mirror 1 feature still selected. 2. right-click and select Edit Definition.

3. This completes the exercise. 1. Using the references. Click File > Erase > Current > OK. you will know how to: • Modify the shape of a solid by replacing a solid surface with a quilt. You are designing the cover for the head of the razor. Scenario You continue to design the shaver. Completed BODY_UPPER 2. Click Save from the main toolbar and click OK. Task 14. • Modify the shape of a solid by patching a solid surface with a quilt. Click Window > Close to return to the assembly. Exercise 3: Creating the Shaver Head Cover (Challenge) Objectives After successfully completing this exercise. you have developed the base solid and you 25 .Side Curve Influence Enabled The Side Curve Influence and Inner Edge Tangency options can be toggled separately for each boundary curve. View the completed model in the assembly. o Examine the UPPER_BODY model in the assembly.

3. In the Folder Browser o . Transparency Disabled 4. Retrieve the model and review the available geometry. Notice that there are four suppressed features and one suppressed group in the model tree.PRT. Ensure that all previous models are erased from the session. Also. 2. select the module_11 folder. you want to provide an indentation in the cover that can be used to remove the cover easily. Model Tree 26 . Select the Shade tab and clear the Transparency check box. Right-click the module_11 folder and select Set Working Directory. 1. o Click View > Display Settings > Model Display. Open the COVER. Task 1.want to refine the shape by making it aesthetically pleasing.

and select Surface Merge 5209. Start the View Manager tab. o o Right-click and select Resume. as shown in the following figure. press SHIFT. o o o from the main toolbar. and select the X-Sec Double-click the saved section Middle to activate it. Click Display > Flip if necessary to view the model.5. Click Display > Visibility. Select the THUMB_IMP_PROFILE. Zoom in and notice that the thumb indentation is only surface geometry. Notice that the thumb indentation surface appears on the model. Surface Resumed 6. o Reviewing the Base Model Geometry 27 .

Drag the Insert Indicator THUMB_IMP_PROFILE. Replace the inside surface of the cover.7. Replacement Quilt for the Inside Surface 2. Task 2. 1. o Right-click to query and select the solid surface. 28 . Click Close from the View Manager dialog box. o o o Right-click Middle and select Visibility to disable it. Change the selection filter from Smart to Geometry. Select the INSIDE_SURF feature from the model tree. in the model tree just above the 3. Press CTRL + D to view the default orientation. o Right-click and select Unhide. as shown in the following figure. Double-click No Cross Section.

Solid Surface Selected 4. Click Complete Feature . Replace the outside surface of the cover. 4. o o o o In the dashboard. Select the solid surface. Click Edit > Offset. Edit the selection filter to Smart. Solid Surface Replaced Task 3. 3. as shown in the following figure. Select the OUTSIDE_SURF feature from the model tree. click Replace Surface Select the overhanging surface quilt. 29 . 1. 2. . as shown in the following figure. The model appears. Press CTRL + D to view the default orientation. o Right-click and select Unhide.

Replacing a Solid Surface 6. as shown in the following figure.Solid Surface Selected 5. Click Edit > Offset. 30 . Click Complete Feature . and select the X-Sec tab. o Click Display > Visibility. o Notice the solid geometry is now dome-shaped on the inside and out. Select the overhanging surface quilt. Start the View Manager from the main toolbar. The model appears. o o o o Click Replace Surface in the dashboard. o Double-click the saved section Middle to activate it.

Start the Round Tool o o o again. Task 4. Drag the radius handle to 6. Select the intent chain shown in the following figure. Double-click on No Cross Section. Start the Round Tool o o o Select the edge shown in the following figure. 31 . o Click Close from the View Manager dialog box.5. from the feature toolbar.Reviewing the Base Model Geometry 7. Creating a Round on the Inside Edge 2. o Right-click Middle and select Visibility to disable it. Click Complete Feature . Click Complete Feature . Drag the radius handle to 7. Add round to the inside and outside top edges. 1.

2. 32 . as shown in the following figure. 1. o Click YES from the message window. Add a thumb indentation to the cover.Creating a Round on the Outside Edge Task 5. o Click Complete Feature . flip the patch direction. and select Cancel. o If necessary. Select the thumb indentation quilt. Selecting the Quilt 3. as shown in the following figure. o Notice that the dashboard automatically defaults to the Patch Tool . Click Edit > Solidify. Right-click the Insert Indicator from the model tree. o Notice that the surface that defines the thumb indentation was modified to match the new shape.

1. Notice that the patch feature has added material in some places and removed material in other places. o Click Close from the View Manager dialog box. o Double-click the saved section Middle to activate it. Click View > Display Settings > Model Display. 33 . and select the X-Sec tab. o Right-click Middle and select Visibility to disable it. o Click OK. o Select the Shade tab and enable Transparency. Double-click No Cross Section.Patching the Thumb Indentation Geometry Task 6. Review the final geometry using the cross-section. 3. Start the View Manager from the main toolbar. o o Click Display > Visibility. Reviewing the Modified Solid Geometry 2.

ASM. Cover in Head Assembly 3. This Completes the exercise. 2. In the Folder Browser .The Completed Cover 4. Click File > Erase > Current > OK. to view the 1. 34 . 5. Click File > Close Window. To view the final cover. Click Save from the main toolbar and click OK. Task 7. 4. Open the SHAVER_HEAD. Click Save from the main toolbar and click OK. click Working Directory contents of the folder in the browser. retrieve the Shaver Head assembly.

2. Geometry has been copied from the BODY_MASTER. Datum Axes . Lower Body Part 3. Use offset surface to add thickness to a part. you will know how to: • • Offset individual surface patches of a quilt. and Datum Coordinate Systems from the main toolbar to disable their display.Exercise 4: Completing the Lower Body of the Shaver (Challenge) Objectives After successfully completing this exercise. Scenario You continue to create the lower body of the shaver. click Datum Planes . Review the surfaces available in the part. Datum Points . and a surface for the switch base has been added.PRT. click Working Directory . The first step in detailing it is to add thickness to the part. If necessary. In the Folder Browser o Open the BODY_LOWER. 35 . Unlike the upper body. 1. . in this case a series of steps have been performed for you. Task 1. Locate and open the lower body part.

Select the two Note check boxes in the Troubleshooter dialog box. Click OK from the Troubleshooter. Flip the direction downward. Click OK from the Environment dialog box. Add thickness to the part. Click Tools > Environment and enable 3D Notes. o o o Click Edit > Thicken. Select anywhere on the quilt. Adding Material Thickness to the Inside of the Part 2. Troubleshooter Message 36 . 1. Edit the thickness value to 2. The feature fails to regenerate. Read the notes on the screen and identify the trouble spot.Task 2. Click Preview Feature o o o o o o .

1. Task 3. Offset the body surfaces. Flip the direction toward the inside of the model. Select Quilts as the active selection filter.The geometry fails to create due to intersecting surfaces. Click Resume Feature . We cannot use the Thicken tool to add thickness to the part. We use alternate surfacing techniques to resolve this problem. 2. Edit the offset value to 1. Right-click and select Exclude Surface. and click Yes. 3. The offset geometry becomes selfintersecting at the defined offset value. 37 . o Select anywhere on the quilt. as shown in the following figure. o o Offsetting the Inside of the Part 3. as shown in the following figure. Click Edit > Offset. o o Orient the model to view it from the underside. Press CTRL and select the 17 surfaces from the switch base to exclude them from the offset. o Click Cancel Feature . Cancel the Thicken feature creation.

Orient the model. 38 . Orienting the Model 2. 5. 1. o o Enable Create Side Surface. o Flip the direction to add material on the inside of the model. o Click Edit > Offset. Select the Options tab in the dashboard. Click Complete Feature from the dashboard. Select the original quilt surface. Drag the offset handle to 2.Excluded Switch Base Surfaces 4. Offset the switch base surfaces. o Edit the offset value to 2. as shown in the following figure. Offset Surfaces of Body Task 4.

1. Merge the quilts and convert to solid part. Flip each arrow once as shown. o o Start the Merge Tool from the feature toolbar. Right-click and select Join. o Orient the model as shown. Press CTRL and select the small quilt and then the large quilt. o Press CTRL and select the 6 surfaces. as shown in the following figure. o o o Start the Merge Tool Click Complete Feature from the feature toolbar. Excluded Surfaces 4.3. Click Complete Feature Task 5. as shown (highlighted in red) in the following figure. from the dashboard. from the dashboard. 39 . Press CTRL and select the two quilts shown in the following figure. Right-click and select Exclude Surface. Merging Quilts 2.

and click Edit > Solidify. Right-click and select Join. 40 . Press CTRL and select the two quilts shown in the following figure. o o o Start the Merge Tool Click Complete Feature from the feature toolbar. o Click Complete Feature from the dashboard. Select the quilt.o Click Complete Feature from the dashboard. Merging Quilts 3. from the dashboard. Merging Quilts 4.

o This basic solid modeling task is outside the scope of this course. Click Save from the main toolbar and click OK. you should know how to: • • • • Replace a solid surface with a quilt. Patch a solid surface with a quilt. Detailed Lower Body Part 6. 41 . Summary After successfully completing this module. The model can now be detailed by adding additional solid features. Click File > Erase > Current > Yes. Create rounds and chamfers as surfaces instead of solids. Create cuts using quilts. This completes the exercise. as shown in the following figure.Solidified Quilt 5. 7.

Master your semester with Scribd & The New York Times

Special offer for students: Only $4.99/month.

Master your semester with Scribd & The New York Times

Cancel anytime.