Índice

3 ...............................................Entendendo a Time-Line 7...................................................... Caixa de ferramenta 8............................................................................. Layers

13.......................................................... Animando layers

18....................... Interpolação de pontos em animação

21.......................................................... Time-remapping

23................................... Usando os modos dos layers

26....................................... Máscaras e transparências

29................................ Formatos de imagem (Codecs)

31..................................................... Tratamento de cor

ATALHOS

* os anexos: exercícios e composição 3D serão entregues no dia 21

1

2

1

Entendendo a Timeline

A janela timeline é o espaço no qual ficam organizados os layers (camadas) pertencentes à composição. Pode-se configurar mudanças no decorrer do tempo, animar numericamente as propriedades dos layers e definir pontos de entrada (in) e saída (out) dos mesmos. Os controles da timeline são organizados em painéis, cada qual com suas funções; estes painéis podem ser organizados individualmente. A – Pasta da Composição Esta pasta tem como função básica organizar e dispor de maneira prática as diferentes composições do projeto. Cada pasta contém seus layers que podem ser acessados a qualquer momento. Clicando em qualquer pasta deste tipo imediatamente será exibido na janela de preview os elementos da composição. B – Time display Indica o tempo atual da composição, de acordo com o marcador deslizante. Pode ser acessado pelo comando Ctrl+G (go to) levando o marcador ao tempo desejado. C – Painéis Áudio/Vídeo Contém chaves para habilitar e desabilitar funções de áudio e vídeo, travar um único layer (lock) e mostrar apenas um (solo) na composição. As funções A/V do painel são: Vídeo ( ), Áudio ( ), Solo ( ) e Lock ( ). D – Pasta dos layers

3

Contém uma cor, um número e um nome para cada layer diferente. O triângulo à esquerda dá acesso às funções de transformação e efeito dos layers.

E – Switch Habilita e desabilita painéis previamente definidos. F - Switches painel

Apresenta uma variedade de controles para o layer: Shy (

), Collapse

Transformations (

), Qualidade (

), Efeitos (

), Frame Blending (

), Motion Blur (

), Layer de Ajuste

(

) e 3D Layer (

).

G – Gráfico Temporal (Time graph)

4

Representa visualmente os valores de in e out para a composição, seus respectivos keyframes e atributos da timeline. Contém uma régua, marcadores para indicar tempo específico ou área de trabalho além de barras de duração para os layers. Através do gráfico temporal pode-se determinar uma porção mostrada na timeline, aproximar ou afastar o zoom, definir área de render ou preview. O gráfico temporal apresenta funções para manuseio de layers em animação:

A. Time graph/ Gráfico de tempo Toda a estrutura. B. Marcadores de área visível Indicam a área mostrada em detalhe na timeline, podem ser movimentados individualmente ou conjuntamente, representando uma aproximação detalhada da mesma. C. Navegadores São versões em miniatura dos marcadores citados acima. Ao se movimentar os marcadores de área visível os navegadores se ajustam de maneira a mostrar a relação entre o trecho colocado em detalhe e a composição inteira, mantendo a proporção. D – Marcadores de área de trabalho

5

Estes marcadores servem para determinar área de preview e render na composição. Para renderizar ou criar um preview de apenas uma parte da composição basta posicionar estes marcadores no trecho desejado. Podem-se definir os pontos de entrada (in) e saída (out) dos marcadores com os atalhos b (begin) para ponto iniciante e n (end) para ponto final. E – Régua do tempo (time-ruler) Indica gradação de tempo para aquele trecho da composição. F – Window Menu Contém o menu da timeline, com funções que afetam layers e keyframes, assim como acesso ao Composition Settings, que é uma caixa de opções gerais a respeito da composição. G – Marcadores de tempo livres

São marcadores de tempo que podem ajudar na organização da composição, evitando confusão. Quando se tem uma composição com muitos layers executando funções semelhantes, pode-se usar dos marcadores para identificar especificamente um layer.]3. Para habilitá-los basta arrastar à partir do

símbolo (

) e para desabilitá-los basta arrastar de volta.

H – Janela da composição Habilita e desabilita a janela active de cada composição. I – Zoom Ao se movimentar a seta pode-se detalhar a composição, aumentando a gradação do tempo em até 1 frame. Acompanha os movimentos dos Marcadores de área

6

visível. Pode ser controlado também através dos ícones: zoom-in (

)e

zoom-out (

).

2

Caixa de ferramenta

Como no Photoshop as ferramentas são representadas por símbolos. São elas: ferramentas de edição, seleção e visualização de layers. Pode-se editar as propriedades dos layers, máscaras e animação graficamente; além de mudar a qualidade e o tipo de visualização de uma imagem, layer e composição. Um pequeno triângulo indica que ferramentas alternativas estão à disposição.

7

A. Seleção B. Caneta C. Adicionar ponto D. Deletar ponto E. Converter ponto F. Orbitar Câmera G. Track XY Câmera H. Track Z Câmera I. Pan J. Rotação K. Máscara retangular L. Máscara oval M. Pan atrás N. Zoom O. Modo de eixo local P. Modo de eixo world Q. Modo de eixo de visão

3

Layers

Layers são todos os componentes de uma composição. Qualquer item que for adicionado a uma composição, tal como: uma imagem parada (still image), imagem em movimento (vídeo), arquivo de áudio, luzes e câmeras, ou até mesmo outra composição será relacionada como um layer. Trabalhar com layers permite que se possa modificar um único elemento da composição sem interferir nos outros, pode-se aplicar qualquer função de transformação (rotação, posição, opacidade, escala) individualmente; o que permite que se use a mesma imagem várias vezes de maneiras completamente diferentes. Todos os layers podem ser conectados (links) entre si, respeitando um esquema de hierarquia; pode-se animar um personagem conectando os layers referentes aos membros seqüencialmente até o tronco (mão braço antibrbaço tronco) dessa maneira, ao se movimentar o tronco, os membros se movimentarão junto.

8

Para que a hierarquia esteja completa, deve se posicionar os elementos no lugar desejado, posicionar o anchor point (ponto âncora ou centro do eixo de movimento) dos layers nos mesmos locais, para que o movimento aconteça suavemente.

Três layers à esquerda e a composição à direita. Os layers podem interagir entre si, através de modos de mistura (Blending Modes), que se utilizam das informações de cor e contraste, luminânicia, canal alpha, etc; de cada layer para chegar ao resultado final. Os layers podem se movimentar em três dimensões (X, Y e Z) tomando assim características especiais, que podem ser habilitadas se necessário: receber influência de luzes posicionadas na cena causando projeção de sombra e ser percebido pela câmera como informação Z, permitindo a distância focal controlada. Toda informação habilitada ou adicionada aos layers causa aumento da complexidade da informação, conseqüentemente exigindo mais do computador. Para evitar travamento e perda das informações, os efeitos colocados, aqueles habilitados; podem ser temporariamente desligados no preview, facilitando o trabalho

A e B Ativam ou Desativam efeitos específicos; C comanda todos os efeitos da 9

composição

Adicionando layers às composições Um layer pode ser dos seguintes tipos: Qualquer item na lista de elementos do projeto Outra composição Um sólido, câmera ou luz Um layer de ajuste Uma duplicata de outro layer existente Um layer partido ou quebrado Um objeto nulo
             

Para adicionar vá a: layer >new ou ctrl+Y Duplicando um layer Um layer duplicado é uma cópia perfeita da sua matriz, com os efeitos, keyframes, etc; e é colocado automaticamente diretamente abaixo da matriz. Para duplicar um layer sem seus modificadores arraste novamente o elemento da lista do projeto. Para duplicar vá a Edit > Duplicate ou ctrl+D Selecionando o layer Como os layers são numerados automaticamente, basta usar o teclado numérico para acessá-los de maneira rápida; para números acima de 9 basta teclar rápido. Para movimentar o layer no tempo basta arrastá-lo usando o bastão gráfico. Uma outra maneira de se movimentar o layer é posicionar o marcador de tempo e apertar [ para que o layer se posicione a partir daquele tempo e ] até aquele tempo.

Cortando o layer Para cortar o layer basta arrastar o marcador de in e out, ou posicionar a linha marcadora de tempo e apertar Alt+[ ou Alt+].

10

Seqüenciando layers Para colocar layers em seqüência basta utilizar o assistente de sequenciamento de layers (Sequence Layers - keyframe assistant).

Quando é aplicado o assistente de sequenciamento o primeiro layer selecionado mantém sua posição inicial e os demais se reorganizam de acordo com a ordem de seleção. Pode-se definir se os layers se organizarão end to end, ou seja: eles não se sobrepõem; pode-se definir também que os layers façam um crossfade, podendo definir quantos quadros de sobreposição, sendo que nesse caso o After cria keyframes de opacidade.

Usando marcadores de tempo no layer Estes marcadores são triangulares e aparecem no corpo da barra de tempo que representa o layer. São muito úteis no momento de organizar funções ou preparar algo que será terminado depois. Podem ser colocados em qualquer quantidade, movidos, deletados e complementados.

11

Para colocar um marcador basta selecionar o layer desejado, posicionar o marcador de tempo e ir até Layer > Add Marker. Os marcadores de layers permitem que se façam anotações, comentários.

Alterando a direção do playback Ao se alterar a direção do playback todos os keyframes se invertem em posição relativamente ao layer, o qual mantém seus pontos in e out da mesma maneira. Para atingir melhores resultados ao se inverter um layer o melhor é coloca-lo dentro de uma composição com a mesma duração, frame rate, etc; e então inverte-lo. Depois de invertido feche e composição e use-a no lugar do layer.

Para se inverter a direção do playback de um layer clique Ctrl+Alt+R (reverse) ou utilize o time-stretch com valores negativos. Para reverter a ordem dos keyframes sem alterar o playback basta ir à Animation > Keyframe Assistant > Time-Reverse Keyframes.

12

4

Animando layers

O After Effects usa animação através de keyframes, que são pontos que criam e controlam a animação da seguinte maneira: um keyframe criado tem informação sobre velocidade, tipo de movimento (rotação, escala, etc) e informação sobre os pontos imediatamente posteriores e anteriores à ele. Exemplo: ao se criar um keyframe no After Effects, você dá ao software todas as informações sobre aquele momento na animação; a exata localização do elemento na tela, sua escala, se está em movimento ou não, etc. Movimentando o marcador deslizante para outra posição na Time-line e alterando os valores numéricos ou movimentando visualmente o elemento na tela cria-se outro keyframe, contendo informação sobre esse momento de animação. Dessa maneira o software consegue calcular os valores intermediários entre os keyframes e então comandar a animação.

13

O uso de keyframes para animação cria a facilidade de se poder copiar e colar os pontos e assim, facilmente, montar uma animação. Pode-se copiar keyframes de um layer para outro, reproduzindo assim a animação exatamente como no layer original. Navegação entre keyframes Quando se cria um ponto de animação, o After Effects imediatamente habilita o Keyframe navigator que pode ser muito útil em composições complexas. Essa função permite que se movimente o marcador de tempo de keyframe em keyframe, permitindo que o operador tenha um preview na janela correspondente dos pontos principais da animação. A função de navegação entre keyframes é acessada logo à esquerda das funções do layer, abaixo dos painéis Áudio/Vídeo.

A. Keyframe atual B. Nenhum keyframe no tempo atual keyframe na propriedade do layer Alterando valores de vários keyframes de layers diferentes

C. Nenhum

Pode-se modificar numericamente os valores de diferentes keyframes em diferentes layers ao mesmo tempo, o que pode representar um ganho de tempo em extensas animações com movimentos similares. Isto pode ser feito de duas maneiras: numericamente e graficamente.

Para modificar numericamente basta selecionar os layers desejados e então determinar um valor para alguma função naquele momento, por exemplo opacidade. Tem-se os pontos iniciais previamente criados, movimenta-se a linha 14

do tempo para o momento desejado e então numericamente modifica-se os valores. Todos os layers selecionados terão criados pontos de mesmo valor e no mesmo momento da linha de tempo. Essa mudança numérica é uma mudança absoluta. Para modificar os valores graficamente, seleciona-se os layers desejados com o marcador de tempo sobre algum keyframe; então movimenta-se a figura na janela para sua posição desejada. A diferença é que quando a mudança é absoluta (numérica) os valores dos keyframes nos layers se tornam aqueles definidos e na mudança relativa (gráfica) o que ocorre é que toda a animação é modificada. Por exemplo: tem-se um movimento simples de 2 keyframes, apenas um layer; seleciona-se o layer, posiciona-se o marcador de tempo no keyframe e usando a janela de preview move-se o elemento 15 pixels para a esquerda. Toda a animação será movida para a esquerda, pois o valor original dos keyframes serão acrescidos ou diminuídos do valor realizado graficamente.

Modificando o motion path O motion path é o caminho que o elemento animado percorre. Para se ter um motion path basta ter dois keyframes diferentes na timeline, o que é necessário para se criar animação. Quanto menos keyframes mais fácil será

15

controlá-los. Para acrescentar um keyframe certifique-se de que o marcador de tempo esteja onde o keyframe deve ser colocado, o mesmo acontece para modificar um keyframe existente.

A. Haste do layer B. Ponto de animação (keyframe) C. Controle de direção do keyframe D. Menu da composição E. Caminho percorrido pelo layer (motion path) Adicionando um ponto Para adicionar um ponto basta mover o marcador de tempo para o ponto desejado e então modificar o motion path movendo o elemento para a nova posição, dessa maneira um novo keyframe será criado naquele momento.

Modificando um ponto existente Para tal o processo é o mesmo de se adicionar um ponto: posiciona-se o marcador de tempo no momento desejado (nesse caso sobre um keyframe 16

existente) e então modifica-se os valores da ação, ou numericamente ou graficamente. Como somente esse layer está selecionado a mudança ocorrerá somente em seu motion path.

Time-stretch O comando time-stretch permite que facilmente se modifique o tempo de duração do layer e quaisquer operações que tenham sido aplicadas no mesmo. Quando o time-stretch é acionado todos os keyframes são redistribuídos na nova duração. Para o caso de layers derivados de vídeos, áudios, etc; deve-se atentar-se para o fato de o time-stretch alterar o áudio. Portanto recomenda-se apenas utilizar o time-stretch em casos que realmente queira uma completa redistribuição dos keyfra mes.

Quando aplicado o time-stretch redistribui os keyframes na nova duração de tempo

No caso de usar o time-stretch em um layer com animação, pode-se ocorrer perda na qualidade se o slow-motion ou fast-motion forem muito altos, recomenda-se então acionar o frame-blending para melhorar a aparência do efeito.

Controlando velocidade entre keyframes Qualquer propriedade do layer que funcione a partir de keyframes pode ser controlada através da movimentação dos mesmos. Ao se afastar ou aproximar keyframes, alteramos o espaço de tempo forçando assim, a acelerações e desacelerações.

17

A. Pontos mais aproximados, indicando velocidade baixa. B. Pontos afastados, mostrando alta velocidade. C. Espaços desiguais representam mudanças nos valores

5

Interpolação de pontos em animação

Interpolação de pontos é a mudança que ocorre nos valores de um e outro keyframe. Essa mudança nos valores pode acontecer de várias maneiras, por exemplo, o movimento de um determinado elemento pode ser coordenado para que ele pare abruptamente, gradativamente desacelerando, gradativamente acelerando etc.

A. Linear B. Auto Bezier C. Continuous Bezier D. Bezier E. Hold As mudanças na interpolação podem acontecer ao passar do tempo, em qualquer propriedade de layers (temporal interpolation). Para as propriedades dos layers que envolvem movimento tais como posição, ponto âncora, ponto de efeito, orientação em 3D pode-se coordenar a interpolação espacial (spatial interpolation). Ao se modificar a interpolação nos pontos de uma animação os próprios pontos fornecem informação visual sobre o tipo de interpolação que ocorre naquele momento. Par alternar entre os modos de interpolação clique com o Ctrl pressionado sobre o keyframe.

18

A. Linear B. Linear in, Hold out C. Auto Bezier D. Continuous Bezier ou Bezier

Interpolação Linear A interpolação linear cria uma mudança nos valores de maneira uniforme, dando um aspecto mecânico ao movimento. As mudanças acontecem instantaneamente e abruptamente nos keyframes, pois não há uma criação de valores intermediários. O gráfico do movimento aparece como uma linha reta. Por exemplo, o movimento de um carro dobrando a esquina ficaria errado com este tipo de interpolação pois a mudança de direção ocorreria tão abruptamente que formaria uma quina no movimento.

Interpolação Auto-Bezier Já a auto-bezier cria valores intermediários, para que a mudança ocorra de maneira suave, gradativa. Ao se adicionar um keyframe no movimento, os valores de todos os outros já existentes keyframes, sofrem leve mudança para se adequarem aos novos valores. Essa interpolação cria curvas no movimento. Notase que as hastes de controle de direção do keyframe mudam de posição automaticamente sempre que um novo keyframe é adicionado ou um já existente sofre alguma modificação.

19

Interpolação Continuous Bezier Funciona exatamente como o auto-bezier, porém oferecendo as hastes de controle de direção do keyframe para comando manual, o que permite que mudanças não somente na direção do movimento mas também na velocidade do mesmo podem ser feitas. Interpolação Hold Essa interpolação é funcional apenas como temporal interpolation, ou seja não oferecendo mudanças nos casos de movimentos 3D (espaciais). Na prática, acontece que o Hold, fixa os valores de um keyframe até o próximo ponto quando estes valores mudam repentinamente. No caso de aplicar o hold em um movimento, o motion path (percurso) não aparecerá, porém os pontos que marcam a posição dos keyframes aparecerão. Interpolação Temporal Bezier É a forma mais precisa de interpolação, pois permite que se controle as hastes de controle de direção do keyframe individualmente, dos dois lados do keyframe. Desse modo torna-se possível comandar os ins e outs de animação, acelerando gradativamente, mudando o percurso sem ter que acrescentar keyframes. Mudando o tipo de Interpolação:

Para mudar o tipo de interpolação, basta exibir o motion path que foi criado e clicar nos pontos diretamente na tela de preview. Usando o Ctrl e clicando sobre os pontos existentes no path, são mostradas as hastes de controle de movimento. De acordo com a posição das hastes o movimento será mais suave ou mais brusco. As hastes de controle da animação, permitem ao animador ter maior controle sobre a movimentação dos elementos animados. Existem efeitos que podem somar valor à animação, tal qual a aceleração. Um elemento pode ir normalmente de um ponto ao outro da tela sem nenhuma alteração no seu movimento, ou seja: movimento uniforme. Se forem habilitadas as hastes de controle, o movimento desse mesmo elemento pode ser feito com mais qualidade, por exemplo, comandando a aceleração do elemento até determinado ponto, uma leve parada e uma posterior rápida

20

aceleração. Esse tipo de controle na animação agrega valor e realismo aos movimentos.

6

Time-remapping

Processo usado para comandar o playback de um arquivo de vídeo e/ou áudio. Ao se aplicar o Time-remapping em um layer é importante que se saiba que o áudio se manterá sincronizado ao vídeo, podendo resultar em sons distorcidos. O After Effects cria dois keyframes ao se habilitar o time-remapping: um no início do layer e outro no seu ponto final (in e out). Esse processo serve para que, ao se adicionar novos keyframes ao layer o programa possa interpolar os pontos criando os modificações no tempo do vídeo/áudio. Por exemplo: pode-se fazer com que o vídeo comece em velocidade normal e depois de um certo tempo começar a aumentar bruscamente de velocidade, até finalmente congelar a ação: basta habilitar o Time-remapping, aproximar o ponto final do primeiro, o que fará com que o vídeo rode muito mais rápido que o normal e então modificar as opções de interpolação do último keyframe de movimento para hold.

A. Primeiro frame B. Ultimo frame C. Frame atual D. Velocidade máxima E. Velocidade atual F. Menor velocidade 21

Time Remap Representa qual frame está sendo mostrado no momento. Value: Time Remap O valor de cima representa o último frame do layer e o valor de baixo representa o primeiro frame. Velocity: Time Remap O valor de cima indica a velocidade mais rápida, o valor de baixo é sempre o negativo do primeiro valor e o valor do meio indica a velocidade do vídeeo naquele determinado momento. Velocidade normal é 100%, câmara lenta é menos que 100% e mais que 100% é velocidade acelerada. Para habilitar o time-remapping vá a Layer > Enable Time Remapping, ou clicar Alt + Ctrtl + T

Mudança de interpolação em time-remapping O time-remapping, é uma ferramenta poderosa, que causa efeitos modernos mas obviamente depende de alguns pontos importantes como por exemplo a qualidade do vídeo em que se está trabalhando. Ao se habilitar o time-remapping, o after passa a modificar a relação frames/segundo, nos trechos desejados, o que força demais. Em paradas bruscas ou em desacelerações muitos suaves até que se mantenha o mínimo de velocidade, pode ser que o time-remapping cause o efeito errado, trocando de frame bruscamente com o passar do tempo; para diminuir esse efeito, existe uma ferramenta: o frame-blending. O frame-blending cria keyframes de opacidade entre a mudança de frames, o que pode suavizar o movimento.

22

7

Usando os modos dos layers

Os modos dos layers são opções que controlam como os mesmos reagem ou interferem naqueles diretamente abaixo deles. Existem modos de interação que interferem nos canais de transparência (alpha, luminância, etc), assim como modos que controlam interação entre cores. Existem modos que funcionam exatamente como no photoshop. Atenção: Não se pode animar mudanças entre modos com keyframes. Para se conseguir isso, deve-se duplicar os layers e usar a opacidade para alterar de um para o outro. Normal Não ocorre interação, o layer aparece sobre os outros abaixo. Dissolve Baseado na transparência dos layers abaixo, troca aleatoriamente as cores do primeiro com os outros. Dancing Dissolve Funciona da mesma maneira do Dissolve, porém as mudanças aleatórias de cor mudam com o passar do tempo. Add Combina os valores das cores do layer com os layers inferiores, resultando em cores mais vivas e mais claras. A cor preta no layer de cima não surti efeito nenhum no layer de baixo e a cor branca no layer de baixo nunca é alterada. Multiply Multiplica os valores das cores nos layers e divide pelo valor máximo de pixel encontrado. A cor resultante nunca é mais clara que o original. Screen Multiplica os valores inversos de brilho de todas as camadas, resultando em cores nunca mas escuras que o original. Usando o modo Screen é similar à tradicional técnica de sobrepor dois filmes negativos diferentes e projetar o resultado. Overlay

23

Mistura as cores dos layers preservando os maiores brilhos e as sombras para extenuar as diferenças entre as cores. Soft Light O resultado seria similar à apontar um spot difuso ao layer. Se as cores dos layers inferiores forem mas claras que 50% de cinza, o resultado vai ser mais brilho, se as cores forem mas escuras que 50% de cinza o resultado será menos brilho. Hard Light Esse modo é uma mistura de Multiply com Screen, pois se as cores dos layers inferiores forem mais claras que 50% de cinza estas cores serão mais brilhantes como se fosse o screen; mas se as cores forem mais escuras que 50% de cinza então elas vão se comportar como se estivesse em multiply. Essa opção é útil para criar a impressão de sombra no layer. Color Dodge Esse modo estoura o brilho das cores resultantes, de acordo com a cor do layer de cima; quanto mais claras as cores mais brilho terá no resultado. A cor preta no layer de cima nunca muda as cores de baixo, e a cor branca no mesmo layer na maioria das vezes muda a cor de baixo para branco. Color Burn Escurece as cores resultantes baseado na cor do layer de cima, sendo que quanto mais escuro o layer de cima mais escuro será o resultado. A cor branca no layer de cima não muda a cor de baixo, e a cor preta no mesmo layer na maioria das vezes muda a cor resultante para preto. Darken Compara os canais de cor dos layers e mostra o mais escuro deles. Essa opção pode causar mudanças e/ou troca de cores no resultado, em caso de layers de cores. Lighten Funciona exatamente o oposto do Darken, comparando os canais de cor dos layers e mostrando o mais claro deles. Essa opção pode causar mudanças e/ou troca de cores no resultado, em caso de layers de cores. Difference Subtrai os valores dos canais dos layers e as cores dos mesmos mostrando os valores absolutos. Exclusion Cria um resultado similar ao Difference mas com menos nível de contraste. A cor branca inverte as cores abaixo, e a cor preta não surti mudança. 24

Hue Cria cores resultantes com os valores da luminância e da saturação das cores das camadas inferiores e a gradação (tonalidade) das cores. Saturation O resultado é conseguido através dos valores da luminância e gradação de tonalidade de cores das camadas inferiores e a saturação das cores do layer. Se for usado em um layer sem saturação (cinza) não surtirá efeito. Color Funciona similar ao Saturation e ao Hue, porém mantém os diferentes tons de cinza na imagem; resultando em uma multiplicação das tonalidades das cores. Luminosity Essa opção é o inverso do modo Color, resultando em cores sem contraste e tonalidade de cores frias. Alpha Add Compõe normalmente a imagem, porém adiciona aos canais alpha os elementos dos layers abaixo. Útil para se mesclar ambientes, recortes, etc. Luminescent Premul Impede que ocorra uma perda das cores e tonalidades quando estes valores excederam os valores dos canais alpha, adicionando as mesmas (similar ao Add). Excelente para usar com imagens produzidas em outros softwares de composição e com composições de luzes, flairs, brilhos, reflexos justamente porque nesses casos os valores são muito tênues entre as cores e o canal alpha.

8

Máscaras e transparências

Quando uma parte do layer é transparente, essa informação é armazenada como dados no canal alpha e pode ser usada mais tarde com as mesmas funções de sólidos, imagens importadas etc. O canal alpha é o canal de informação sobre a transparência da imagem, que áreas são mais ou menos transparentes, onde houve um recorte ou para esconder ou substituir parte da imagem. No After

25

Effects, as informações a respeito da transparência dos layers são divididas em quatro categorias: Alpha Channel, Mask, Matte e Keying. Alpha Channel: Um canal invisível que define que áreas da imagem são transparentes e o grau dessa transparência. Mask: Uma seleção que modifica o canal alpha. As mascaras são elementos criados no After Effects que determinam áreas da imagem que irão se somar ao canal alpha já existente ou iniciar um. Podem ser animadas ou paradas, modificando a forma ou não. Muito úteis para se retocar ou modificar áreas específicas da imagem. As máscaras são informações restritas de cada layer mas cada layer pode ter múltiplas máscaras.

Matte: É um layer que guarda informações de transparência sobre outro layer. Nesse caso pode-se usar o matte para se definir melhor o canal alpha, especialmente em formatos de arquivo com split alpha channel, o canal alpha é renderizado em seqüência de arquivos separados da seqüência do vídeo. Keying: Definir o canal alpha da imagem através de um canal específico de cor ou luminância. O recorte em fundo azul ou verde, por exemplo, são tipos de key que se utilizam dos canais de cor para separar a parte desejada da imagem.

26

O recorte de chroma é um tipo de keying, muito usado na computação gráfica. Grava-se o elemento sob um fundo azuk que posteriormente é substituído por outra imagem. Dessa maneira pode-se mesclar computação gráfica 3D com imagens de vídeo, fotografias e elementos gráficos do After Effects. Dessa maneira, tendo a Imagem separada em elementos pode-se reparar, tratar ou modificar cada parte com mais controle. Depois do tratamento ser aplicado aos elementos recortados, monta-se a composição final todos os eles. A rotoscopia pode ser usada também para recortar e separar elementos indesejados da tela. Consiste na pintura do elemento indesejado nos quadros em que se pretende fazer a substituição. Funciona exatamente como uma máscara, podendo ser depois animada, estática, etc. A rotoscopia pode ser habilitada no painel de efeitos na opção Paint Vector Paint e pode ser usada para criar efeitos de: desenho animado;

recorte;

Texto;

27

9

Formatos de imagem (Codecs)

São basicamente formatos de compressão de imagem. A imagem capturada para o computador deve passar por alguma forma de compressão que possibilite sua manipulação com segurança, isto porque a captura sem compressão nenhuma resulta am arquivos imensos além de só ser possível através de equipamentos especiais. De qualquer maneira ao se passar o vídeo para o computador, alguma terminação ele deve receber, para assim ser lido e interpretado corretamente como vídeo. Informações como: frame rate (velocidade do vídeo medida em frames por segundo); canais de cor (RGB, YUV); canais de transparência (alpha); pixel espect (square; 0,9) ajudam ao software no momento de importar o vídeo, fazê-lo com o máximo de fidelidade possível com a imagem original. 28

Portanto codecs são codificadores. As diferenças entre os codecs dizem respeito à capacidade e qualidade da compressão. Cada codec prioriza uma das duas opções; o Divx, por exemplo, consegue comprimir arquivos de vídeo de grande duração em arquivos pequenos que guardam excelente qualidade para exibição, o que facilita o armazenamento dos vídeos. Em contra-partida os arquivos com a compressão Divx, se importados para o After Effects ou outro software de finalização; ao serem manipulados perdem rapidamente a aparente qualidade. Percebe-se assim, que os codecs com grande capacidade de compressão apresentam na sua boa qualidade de exibição, um problema. Os codecs conseguem comprimir a imagem calculando a posição dos pixels na tela substituindo aqueles mais próximos e dee cor semelhante por outros de cor igual. Dessa maneira as nuances de cor são perdidas; pois pixels próximos uns dos outros ficam iguais. Portanto quanto maior a qualidade da compressão do codec, maior a gama de cor permitida na substituição dos pixels. Os codecs mais comuns são: AVI, MOV, MPEG, TGA, WMV, JPEG, TIFF, RLA, PNG; cada qual com uma especificação característica. Os arquivos em TGA (TARGA FILE) podem conter canal alpha em um mesmo arquivo juntamente com o vídeo (pre-multiplyied alpha). Os arquivos JPEG por sua vez não armazenam informação acerca de transparência do vídeo e têm baixa qualidade de manipulação, ou seja, não podem ser importados e modificados com segurança, pois perdem qualidade rapidamente. Os arquivos MOV são característicos dos sistemas Apple Macintosh, e possuem completa integração com os softwares de edição e finalização para esse sistema, não necessitando, por exemplo, de renderizar os vídeos em Quick Time, quando são importados para a time-line. Os formatos originais, são aqueles que contém a assinatura das empresas qua os criaram, com características desenvolvidas especialmente para responder às necessidades específicas de cada empresa, como é o caso do codec usado pela Pixar (Renderman) para renderizar seus vídeos contendo exatamente as informações que os animadores precisam para compor os elementos no projeto final. Existem formatos de compressão que visam acumular o máximo dee informação possível, não se importando muito com o tamanho final do arquivo. HDTV (High Definition Television) é um formato de imagem de altíssima qualidade que armazena mais informações de pixel que os outros: 720p - 1280x720 pixels progressive; não existem fields, a cada quadro (24/s) é mostrada a imagem completa na tela. 1080i - 1920x1080 pixels interlaced; existem fields que interlaçãm os quadros (30/s). 29

1080p - 1920x1080 pixels progressive; não existem fields, a cada quadro (24/s) é mostrada a imagem completa na tela. Existem formatos como o HDRI (High Dinamic Range Image) que foram criados com o propósito de armazenar mais um canal de informação além dos de praxe: referentes à cor (R, G, B), referente à transparência (alpha) e acrescentaram o canal referente à iluminação; que armazena informação que diz respeito à luminosidade da imagem: valores de luminância e posição das fontes de luz. Esse tipo de arquivo pode ser usado para reproduzir a iluminação e temperatura da luz de uma determinada cena em outra, facilitando assim a composição final. Existem ainda arquivos que armazenam informação sobre a distância entre a “câmera” e os elementos em cena (RLA) o que permite que na finalização possa ser reproduzida qualquer distância focal que se deseje.

10

Tratamento de cor

O tratamento de cor consiste na correção e no refinamento da qualidade visual da imagem, visando causar mais impacto. A beleza visual da imagem é muito importante e pode-se reforçar a fotografia e a situação do próprio roteiro com um tratamento de cor adequado. Acrescentar tensão, sensação de velocidade, medo, etc; ou simplesmente corrigir pequenos defeitos causados por erro de câmera, maquiagem, iluminação, etc.

30

Muitas vezes a finalização deve ressaltar partes da imagem, cores logomarcas, objetos, etc; bem como esconder ou substituir outros. Esse é o caso da correção de imagem. Na qual é importante conhecer as características do formato do vídeo em que se está trabalhando. Sabendo assim evitar que a imagem perca qualidade na finalização, por exemplo, ao se corrigir a iluminação de uma cena gravada com puçá luz. Uma cena escura é aquela onde existe pouca fonte de luz, criando grandes regiões de escuridão no enquadramento o que dá ao finalizador pouca referência de cor. Sendo assim qualquer mudança no contraste ou cor deve ser feita com valores muitos altos para que se consiga o resultado desejado; o que acaba sobrecarregando a imagem provocando a granulação ou pixelização do vídeo. Todo formato de imagem tem seu limite para manipulação e formatos mais simples não suportam grandes distorções na imagem, pois estes armazenam pequenas quantidades de informação. São vários os pontos que devem ser levados em concideração ao começar o processo de finalização de imagem; são eles: o contraste, as cores e as luzes. Existem várias gradações e escalas para cores: RGB, YUV, Grayscale, etc, existindo pequenas variações entre elas. Cada canal de cor pode ter seu contraste ajustado independentemente dos outros canais.

31

O contraste é a relação entre os pontos claros e os pontos escuros da imagem. Cada canal de cor pode ter o contraste ajustado individualmente, permitindo que determinadas áreas fiquem propositalmente opacas ou contrastadas. O que acontece de fato é: ao se aumentar o contraste diminui-se a relação e nuance entre o branco e o preto, fazendo com que os degrades e as mudanças mais suaves de cor e iluminação se tornem mais secas e definidas. Saturação da imagem é quando são atribuídos valores altos de contraste e ganho de cor na imagem, provocando cores estouradas, regiões distorcidas, etc. O processo contrário, a desaturação, produz imagens em escala de cinza, pois os valores de contraste estão baixos e as cores não têm ganho. A finalização também é responsável pela integração da computação gráfica com o vídeo, adequando a temperatura e contraste para que o elemento em computação gráfica se mescle perfeitamente com a imagem. Efeitos como projeção de luz e sombra podem ser acrescentados para conferir maior realismo à composição final.

ATALHOS
Working with footage items (Project window)

32

RESULT When opening a project, suppress opening of all windows (except the project window)

ACTION

Hold down Open last project

+ Alt +

+P Open selected footage item or composition Double-click or Enter on numeric keypad Open movie in an After Effects footage window Activate most recent composition Add selected item to most recently activated composition Alt-double-click \

+/ Replace a selected layer's source footage in Composition window with selected footage + Alt + / Replace a selected layer's source footage item or composition Alt-drag footage item from Project window into composition

33

Replace footage file

+H Set Interpret Footage options

+F Scan for changed footage

+ Alt +

+Q New folder

+ Alt +

+N Remember footage interpretation

+ Alt + C

34

Apply footage interpretation

+ Alt + V Set proxy file

+ Alt + P Project Settings

+ Alt +

+K

Control

Shift

Key

35

Viewing windows (Composition, Layer, and Footage windows)

RESULT Cycle through open windows

ACTION

+ Tab Display/hide title-safe and action-safe zones Display/hide grid ' (apostrophe)

+ ' (apostrophe) Display/hide proportional grid Center active window Alt + ' (apostrophe)

+ Alt + \ Suspend window updates Cycle through tabs in the frontmost window Caps Lock

+ , (comma) and + . (period) Add Alt to zoom the window to fit

36

Take multiple (up to four) snapshots

+ F5, F6, F7, and F8 Display snapshot in active window Purge snapshot F5, F6, F7, and F8

+ and F8 Purge all

+ F5, F6, F7,

+ Alt + / on numeric keypad Display channel (RGBA) Display channel (RGBA) in color Alt + 1, 2, 3, or 4

Alt + Display channel in color

+ 1, 2, 3, or 4

+ click channel icon Display unmatted color channels

+ click alpha channel icon

37

Display Project window

+0 Display Project Flowchart view

+ F11 Display/hide palettes Close active tab/window Tab

+W Close active window (all tabs)

+ Close all windows (except Project window)

+W

+ Alt + W

Control

Shift

Key

38

Moving around (Timeline window)

RESULT Go to beginning of work area

ACTION

+ Home Go to end of work area

+ End Go to previous visible keyframe or layer marker J Go to next visible keyframe or layer marker Go to a composition-time marker K 0-9 on main keyboard

Scroll selected layer to top of Timeline window X Scroll current time to center of window Go to time D

+G

Control

Shift

Key

39

Moving around (Composition, Timeline, Footage, and Layer windows)

RESULT Go to beginning

ACTION Home or

+ Alt

+ Go to end End or

+ Alt

+ Step forward 1 frame Page Down or

+

40

Step forward 10 frames

+ Page Down or

+

+

Step backward 1 frame

Page Up or

+

41

Step backward 10 frames

+ Page Up or

+

+

Go to layer In point Go to layer Out point Snap items such as keyframes, time markers, and In and Out points to each other on a time ruler

i o

-drag item

Control

Shift

Key

42

Previewing (Timeline window)

RESULT Start/pause playback Preview audio from the current time RAM preview RAM preview every other frame

ACTION Spacebar . (period) on numeric keypad 0 on numeric keypad

+ 0 on numeric keypad Save RAM preview

+ 0 on numeric keypad Scrub video Drag or Alt-drag current-time marker, depending on Preview Preferences setting

Scrub audio

-drag current-time marker Wireframe preview Display rectangle instead of alpha outline during wireframe preview Alt + 0 on numeric keypad

+ Alt + 0 on numeric

43

keypad Leave window contents during wireframe preview

+ Alt + 0 on numeric keypad Leave window contents during rectangle preview

+ numeric keypad

+ Alt + 0 on

Note: If no layers are selected, commands are applied to all layers. Note: Visual previews honor loop and audio toggles in Time Controls palette.

Control

Shift

Key

Working with layers (Composition and Timeline windows)

RESULT

ACTION

Rename layer, composition, folder, or Enter key on main keyboard effect

44

Select next layer back

+ Select next layer forward

+ Select a layer by its layer-outline number Select noncontiguous layers 1-9 on numeric keypad

-click layers Deselect all layers

+ F2 Lock selected layers

+ A, or

+L Unlock all layers

+

+L

45

Split selected layer

+ Activate Composition window with layer Display selected layer in Layer window Show/hide video \ Enter on numeric keypad

+D

+ Alt + Hide other video

+V

+ Display or close Effect Controls window for selected layer

+V

+ F3 Switch between Composition and Timeline windows Open source of a layer \

+ T, or

Alt-double-click a layer, or press AltEnter on numeric keypad

Scale layer without dragging a handle Alt-drag layer in Composition window

46

Snap layer to edges or center of frame in Composition window

+ -drag layer (begin dragging before pressing keys) Constrain layer movement along xaxis or y-axis

-drag layer (begin dragging before pressing keys) Stretch layer to fit Composition window

+ Alt + F Stretch layer to fit horizontally, preserving frame aspect ratio

+ Alt + Stretch layer to fit vertically, preserving frame aspect ratio

+H

+ Alt + Reverse a layer's playback

+G

+ Alt + R Set In point Set Out point Trim In point of a layer [ (left bracket) ] (right bracket) Alt + [ (left bracket)

47

Trim Out point of a layer Display solid settings

Alt + ] (right bracket)

+ Create new null object

+Y

+ Alt + Add/remove expression Set In point by time-stretching Alt-click property stopwatch

+Y

+ (comma) Set Out point by time-stretching

+,

+ Alt + , (comma) Move In point to beginning of composition Alt + Home

Move Out point to end of composition Alt + End Constrain rotation to 45-degree increments

-drag rotation tool

48

Constrain scaling to footage frame aspect ratio

-drag layer handle Constrain movement along x or y axis

-drag layer Reset rotation angle to 0 degrees Reset scale to 100% Change property value Change property value x 10 Double-click rotation tool Double-click selection tool Drag underlined values in Switches/Modes panel

-drag underlined values Change property value / 10

-drag underlined values

Control

Shift

Key

49

Zooming

RESULT Zoom in

ACTION

. (period) or Zoom out

+ Alt + =

, (comma) or on main keyboard Zoom in and resize window

+ Alt + - (hyphen)

Alt + . (period) or keyboard Zoom out and resize window

+ = on main

Alt + , (comma) or on main keyboard Zoom to 100% Zoom to 100% and resize

+ - (hyphen)

/ (on main keyboard) or double-click zoom tool Alt + / on main keyboard

50

window Zoom window

+\ Zoom window to fill monitor

+

+\

Control

Shift

Key

Working with compositions (Composition window)

RESULT Set composition resolution to custom

ACTION

+ Alt + J

51

Composition Flowchart view

+

+ F11 Toggle window display options in palette menu

+

+H

Control

Shift

Key

Using the Tools palette (Tools palette)

RESULT Selection tool: Selects, moves, and resizes layers,

ACTION V

52

masks, and controls Rotation tool: Rotates layers in the Composition window Camera tools (3D): Orbit, Track XY, and Track Z W

C, or + C to cycle through tools Rectangle tool or Oval tool: Draws a rectangular or elliptical mask in the Layer window; double-click to reset the mask Q, or + Q to toggle between tools Pen tool: Edits Bezier masks, motion paths, and Value G graphs Pan Behind tool: Moves a layer behind a mask, or moves the anchor point without moving the layer Y

Hand tool: Scrolls window to reveal areas beyond H, or hold down window edge; hold down spacebar to use Hand tool in spacebar any window Zoom tool: Magnifies (or reduces using Alt) an area of a Z page

Control

Shift

Key

53

Modifying keyframes (Timeline window)

RESULT Add or remove keyframe (if stopwatch is on) or turn on time-vary stopwatch (if off)

ACTION

Alt + property display shortcut Select all keyframes for a property Deselect all keyframes Snap keyframe to significant times

+

Click property name Shift + F2

-drag keyframe Nudge keyframe 1 frame forward

Alt + Nudge keyframe 1 frame backward

Alt +

54

Select all visible keyframes

+ Alt + A Go to previous visible keyframe Go to next visible keyframe Switch interpolation between Linear and Auto Bezier J K

-click keyframe Change Auto Bezier interpolation to Continuous Bezier Toggle between Continuous Bezier and Bezier interpolation Drag keyframe handle

+ drag keyframe handle Easy ease Easy ease in Easy ease out F9 Shift + F9

+ Shift + F9

Control

Shift

Key

55

Setting the work area (Timeline window)

RESULT Set beginning of work area to current time Set end of work area to current time Set work area to selected layers

ACTION B N

+ Alt + B Set work area to composition duration when no layers are selected

+ Alt + B

Control

Shift

Key

Working with masks (Composition and Layer windows)

RESULT Reset oval or rectangle mask to fill window

ACTION Double-click tool

56

Scale around center point in Free Transform mode

+ drag Select all points in a mask Free transform mask Alt-click mask

+ T, or double-click mask Exit free transform mask Enter

Control

Shift

Key

Using markers (Composition and Timeline windows)

RESULT Set layer-time marker Remove layer-time marker

ACTION * on numeric keypad

-click marker Go to previous visible layer-time marker or keyframe J

57

Go to next visible layer-time marker or keyframe Go to a composition-time marker Set and number a composition-time marker at the current time

K 0-9 on main keyboard

+ 0-9 on main keyboard

Control

Shift

Key

Apostila de apoio
Oficina after effects 6.0
58

Junho 2004 Fabiano Waewell

59

Sign up to vote on this title
UsefulNot useful