P. 1
curso básico indesign

curso básico indesign

|Views: 574|Likes:
Published by Mateo Sánchez
Uploaded from Google Docs
Uploaded from Google Docs

More info:

Published by: Mateo Sánchez on Jan 12, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

11/25/2014

pdf

text

original

- Introducción a InDesign - Introducción al espacio de trabajo de InDesign - Preferencias - Crear un documento en InDesign - Añadir texto a un documento Anulaciones: una

definición - Estilos de carácter y de párrafo Estilos de párrafos Estilos de carácter - Estilos de celdas y tablas: Estilos de celdas: Estilos de tablas: - Libros electrónicos (formato epub) - Introducción a XML - Bibliografía y enlaces

- Introducción a InDesign
Indesign se trata de un programa de maquetación o de composición de páginas, con él es posible combinar textos con elementos gráficos y así crear documentos que podemos imprimir o bien exportar a formatos electrónicos. A diferencia de un procesador de textos o un programa de edición de páginas web, los textos no fluyen por las páginas, si no que están en cajas o marcos. Con esos marcos o contenedores y con los elementos gráficos, que también estarán en sus contenedores correspondientes, crearemos nuestros documentos. Los elementos básicos del programa y que explicaremos en este manual son: ● Las páginas maestras ● Los estilos de párrafo ● Los estilos de carácter ● Los estilos de celda ● Los estilos de tabla Si trabajamos con estos elementos básicos conseguiremos documentos que serán fáciles de modificar y que nos permitirán posteriormente exportar a formatos electrónicos y xml.

- Introducción al espacio de trabajo de InDesign

En el espacio de trabajo, comenzando en la parte superior y yendo en la dirección de las agujas del reloj, tenemos: ● Barra de menús: donde tendremos acceso a todo lo que podemos hacer con el programa, importantísimo el menú “ventana”. ● A continuación de la barra de menús aparece: ○ acceso a Bridge, ○ zoom, ○ opciones de visualización, ○ modo de pantalla y ○ organización de documentos. ● En la parte de la superior derecha tenemos: ○ el selector de espacios de trabajo, ○ un cuadro de búsqueda rápida de ayuda y ○ el botón CS Live desde el que podemos acceder a una serie de recursos que pone Adobe a nuestra disposición, hay que tener una cuenta en Adobe (es gratis) ● Panel de control: se encuentra debajo de la barra de menús y en función de qué tengamos seleccionado cambiará. Hay tres: texto, objeto y tablas. En función de la resolución de la pantalla aparecerán más o menos elementos. ● En la parte de la derecha tenemos los paneles, los cuales cambian en función del espacio de trabajo que seleccionemos y que siempre podremos modificar a nuestro gusto. Hay 61 paneles y la forma más rápida de acceder a ellos es a través del menú ventana, donde aparecen ordenados alfabéticamente. Cada panel, en su parte superior derecha, tiene un menú que nos permite gran cantidad de opciones. ● En la parte inferior del espacio de trabajo, de derecha a izquierda, tenemos: ○ Área de estado, nos dice si el documento ha sido o no guardado y nos permite acceder a él en el disco duro ○ Área de comprobación preliminar: nos informa si hay algún error, es completamente personalizable avisándonos de lo que queramos controlar. ○ Controles de avance y retroceso de páginas ● En la parte de la izquierda está el cuadro de herramientas.

Podemos saber qué hace cada herramientas mediante el menú Ventanas/Utilidades/Sugerencias sobre herramientas.

● ● ●

Reglas, de donde arrastrando saldrán las guías. En la unión de las dos, esquina superior izquierda, con el botón derecho podemos cambiar las unidades. Ventana del documento, diremos que es lo que se va a imprimir Mesa de trabajo, todo lo que hay alrededor de la ventana del documento.

- Preferencias
Las preferencias determinan el comportamiento inicial de los documentos y objetos en Indesign. Todos los cambios que realicemos en las preferencias sin ningún documento abierto se aplicarán a todos los documentos que creemos a continuación. Si las modificamos con un documento abierto, solo afectarán a dicho documento. Respecto de este tema decir que si se cambia la configuración de cualquier elemento de un menú, panel o cuadro de diálogo cuando no hay ningún elemento seleccionado, los cambios serán ahora la configuración

predeterminada para los nuevos objetos creados a partir de este momento. Por ejemplo: si sin que tengamos nada seleccionado modificamos el grosor de las líneas y ponemos 0,5 pt, o 1 pt, todas las nuevas líneas tendrán entonces un grosor de 0,5 pt o 1pt. ¡Cuidado con los cambios que hagamos sin tener nada seleccionado! Resaltar en la preferencias: ● “Numeración de páginas” en General, si ponemos numeración absoluta, el panel de páginas pondrá el número “real” de la página, si ponemos por secciones, cada sección llevará su numeración ● “Reflujo de texto inteligente” en Texto. Controlamos si se crearán nuevas páginas cuando sea necesario por haber más texto. Hay que tener cuidado con esta opción. ● “Resaltar “ en Composición marcaremos los cuadros de verificación si queremos “controlar” lo abierto y cerrados que están los textos (tonos de amarillo), si aplicamos kerning a un texto (tono verde), excepciones de separación (tono naranja) nos avisa de viudas y huérfanas. ● “Incrementos de teclado” en Unidades e incrementos, aquí cambiaría a 0,1 el tamaña/interlineado y Desplazamiento vertical, y a 1 el valor del kerning/tracking. ● En el panel de preferencias de cuadrícula definiremos la cuadrícula base, recordar que en cada caja de texto podemos definir su propia cuadrícula. ● El panel de diccionario nos permitirá añadir nuestros propios diccionarios. Cuidado con lo de adjuntar el diccionario (es conveniente) pero puede remaquetar documentos. ● En Administración del portapapeles determinaremos si se mantiene toda la información al cortar / pegar. Podemos volver a los valores de fábrica del programa pulsando CTRL+ALT+MAYÚSCULAS al arrancar el programa.

- Crear un documento en InDesign
Cuando vamos a crear un documento, lo primero que debemos saber es su tamaño final. Lo normal para los libros es un tamaño de A4 (170x240 mm), o 150x210 mm (A5), aunque podemos usar cualquier otro tamaño que se nos ocurra. También actualmente en inDesign podemos crear páginas web y crear documentos que se vean en dispositivos electrónicos (ebooks o tabletas), y en la versión cs6 nos encontramos preconfigurados los tamaños estándar de dispositivos como el iPad, Kindle, Motorola Touche, etc. Para los libros tiene sentido hablar de páginas enfrentadas, para los dispositivos electrónicos siempre hablaremos de pantallas, o sea, de documentos de una “página”. Una vez que sabemos el tamaño del documento final pasamos a lo que se denomina la caja de texto, que se trata de la parte del documento por donde “correrá” el texto, y se determina con los márgenes de la página. Los valores clásicos nos dicen que los márgenes deben cumplir la norma de que el inferior sea el doble que el superior, y el exterior el doble del interior. Lo normal, por razones de economía de papel y si el libro es muy grueso, es que el interior sea mayor que el exterior, y que el superior sea mayor que el inferior. http://hurqualya.com/telomaq/sin-categorias/la-reticula-base/. En esa página hay más información sobre las “retículas base”.

Una vez determinado el tamaño y la caja tendremos que indicar si hay o no columnas, esto también lo podremos decidir más adelante, y también indicaremos si el documento lleva sangre, pues con ella permitiremos que cuando se imprima un documento y queramos que lleve elementos en el borde de la página no quede un filo blanco al recortar el documento al tamaño final.

Creación de un documento. pulsamos ctrl+n, o en archivo / nuevo., nos sale la pantalla anterior y en ella vemos que nos pregunta por páginas opuestas (para libros), marco de texto maestro (más adelante hablaremos); tamaño, vienen por defecto varios tamaños y podemos crear los que queramos con anchura y altura, si es más ancho que alto el documento se pondrá en forma apaisada (orientación). Aparecen las columnas y el medianil (espacio entre columnas). Por último están los márgenes, el sangrado y las anotaciones (éste es un espacio para hacer indicaciones a la imprenta o a otras personas que trabajan con nosotros) Caja de texto maestro. Cuando creamos documentos de texto es conveniente que la página maestra lleve “caja de texto maestro”. Con ésta, inDesign se aproxima a un procesador de texto, y nos permitirá que al modificarla en la página maestra estos cambios se trasladen a todo el libro. Páginas maestras. Al haber creado el documento automáticamente se crea la primera página maestra, la página A. Una página maestra diremos que es como si fuera una plantilla donde nosotros colocaremos todos aquellos elementos que deben aparecer en

todas las páginas. Así, añadiremos el número de páginas (folios), elementos decorativos como líneas (filetes), logotipos, color de fondo, datos de la empresa o de la publicación que queremos que se reproduzcan en todo el libro. Podemos crear tantas páginas maestras como necesitemos; una por cada tipo de página que vayamos a necesitar. Normalmente en los libros hay cuatro: página normal (A), página de comienzo y fin de capítulo (B), páginas en blanco y para portadillas (C), y páginas de la tabla de contenido (D), esto es una idea. Además podemos crear páginas maestras basadas en otras páginas maestras, y en ella añadiremos nuevos elementos y/o quitaremos de la primera, este tipo de página se denominan hijas o heredadas. Numeración automática de páginas. Para que aparezca el número de página en una nos iremos a la página maestra, creamos una caja de texto con la herramienta texto (T), la ponemos donde queramos que aparezca el número y dentro de ella pulsamos: ctrl+mayúscula+alt+n, o bien, en el menú texto, insertar carácter especial, marcadores, número de página

- Añadir texto a un documento
Si bien en InDesign podremos escribir directamente lo normal es importar texto de un procesador de texto. InDesign importa diremos “perfecto” de word, pero también de otros procesadores de texto para ello guardaremos en el procesador correspondiente en formato word (.doc o .docx) o bien en formato .rtf (este formato es mejor para importar). InDesign también importar desde hojas de cálculo excel, y texto en formato txt. Para importar podemos estar dentro de una caja de texto (no lo recomiendo a no ser que estemos seguros que el texto que importamos debe aparecer donde estamos) o bien en cualquier sitio (tendremos seleccionado la herramienta selección). Pulsaremos a continuación CTRL+D o bien nos vamos al menú Archivo, colocar; donde nos saldrá la siguiente pantalla:

Debemos seleccionar “Mostrar opciones de importación”. La casilla de “Reemplazar elemento seleccionado” nos informa de lo que ocurre cuando estamos en una caja de texto e importamos texto, así se sustituirá el contenido de un marco seleccionado, o el texto seleccionado o se añade al marco de texto en el punto de inserción. La casilla de “Crear pies de ilustración estáticos” es porque este menú es el mismo para la importación de imágenes, y en ese caso podemos crear pies de imagen a partir de los metadatos que contiene las imágenes. Indicar que todo lo que seleccionemos en este cuadro de diálogo se conserva hasta que volvamos a cambiar las opciones de colocar texto. El cuadro de diálogo que sale al señalar “Mostrar opciones de importación” es:

En ella es conveniente tener siempre señalado las primeras casillas de “Incluir” y que nos permitirá importar lo que se indica en ellas. Indicar que las notas finales las importa, pero indesign no tiene control sobre ellas, en el sentido que si borramos una llamada en el interior las siguientes llamadas no se renumeran, ni la nota que se corresponde con la llamada tampoco desaparece. Si nos interesa esas notas finales como notas a pie, lo mejor es convertirlas en Word y a continuación importamos. Respecto del formato diremos que hay dos formas muy diferentes, es un caso se importa pero se mantiene las modificaciones locales, o sea, se importan las cursivas, las negritas, los diferentes tamaño de fuentes, los colores de éstas, etc. Se trata la opción de “Quitar estilos y formato de texto y tablas”. Si no tenemos control sobre el texto que importamos, o sea, no sabemos de dónde proviene, la mejor opción es ésta. Si por el contrario el texto que importamos es nuestro, o vemos que está bien estructurado con estilos de párrafos y caracteres entonces usamos la segunda opción. Esta opción nos permite decidir qué estilos de párrafos “mandan”, los que llegan o los que tiene el documento, todo ello lo podemos controlar

en este menú. Todas las especificaciones que hagamos lo podemos guardar en “guardar valor...” y así tenerlas preparadas para otra ocasión en que importemos un texto similar. Una vez demos a “Aceptar” veremos que el cursor se carga, si estamos encima de una caja de texto veremos que aparecen unos “parentesis”, si no estamos en una caja de texto saldrá con una “escuadra”. En el primer caso si pulsamos la tecla mayúscula el texto creará tantas páginas como necesite. En el segundo caso “crearemos una caja de texto”, arrastrando el curso y al “soltar” el texto quedará en la caja. Si en una caja de texto aparece una cruz roja en la parte inferior derecha nos está indicando que hay texto desbordado. Para solucionarlo pinchamos con el ratón sobre la cruz roja y de nuevo se nos “llenará” el ratón de texto y lo llevaremos a la caja siguiente. El siguiente artículo da todo tipo de información sobre la importación de textos desde word http://www.nousmedis.com/2009/04/importar-estilos-de-word-en-indesign/ En ese artículo aparece un tema muy importante que son los textos que vienen con “anulaciones”, copio/pego Anulaciones: una definición Si aplicas un estilo de párrafo a un texto y más adelante introduces modificaciones locales (como cambiar el kerning o convertir un texto en cursiva), InDesign mostrará, en el panel Estilos de párrafo –o en el apartado correspondiente del panel Control–, el nombre del estilo aplicado seguido del signo +. Con este signo, InDesign indica que el párrafo contiene anulaciones, es decir, todo o parte del texto contiene uno o más atributos de párrafo con valores diferentes a los definidos por el estilo.

Figura 4. Panel Estilos de párrafo mostrando anulaciones en el estilo Cuerpo de texto. La forma más sencilla de acabar con las anulaciones y, por tanto, aplicar el estilo tal cual marca su definición, es hacer clic en el botón Borrar anulaciones en la selección de la parte inferior del panel Estilos de párrafo, o bien mantener pulsada la tecla Opción (Alt) al mismo tiempo que haces clic en el nombre del estilo. Sin embargo, cuando utilizas estilos de carácter en lugar de modificaciones locales, InDesign deja de considerar que el texto contenga anulaciones. Es más, cuando modifiques la definición del estilo de párrafo o bien pulses el botón Borrar anulaciones

en la selección , las porciones de estilo a las que hayas aplicado estilos de carácter se mantendrán inmutables. Por eso DEBES utilizar, en la medida de lo posible, estilos de carácter en lugar de aplicar manualmente cursivas, negritas, subrayados u otras alternativas. Existe un script gratuito que al aplicarlo a un texto crea los estilos de caracteres correspondientes a las “anulaciones” que haya. En este artículo en inglés vemos como “solucionar” el problema y los scripts correspondientes. De nuevo Peter Kahrel nos regala un script http://indesignsecrets.com/perfectpreptext-a-smart-way-to-style-local-formatting.php traducido al español http://translate.google.com/translate?hl=es&sl=en&tl=es&u=http%3A%2F%2Findesignsecrets.c om%2Fperfectpreptext-a-smart-way-to-style-local-formatting.php

- Estilos de carácter y de párrafo
Una vez que tenemos nuestro texto pasamos a trabajar con él. La forma más efectiva es que todo nuestro texto esté estilado con estilos de párrafos y de carácter, pues de esta forma podremos cambiar la apariencia del texto de una forma rápida y además nos permitirá tenerlo preparado para la exportación a libro electrónico y trabajos con xml. Para crear estos estilos lo podemos hacer de dos formas: si conocemos las características de cada uno de ellos crearemos los estilos de párrafo oportunos, y si no lo tenemos claro, conforme vamos aplicando características a los textos vamos creando los estilos, que posteriormente podremos modificar buscando los resultados que buscamos. Diremos que los estilos de párrafo controlan los atributos del párrafo y los de caracteres solo modifican los caracteres seleccionados. Los dos estilos se alían en los llamados estilos anidados, y los estilos GREP. Si bien en un documento que sea una plantilla irán todos los estilos, también podremos importar estilos de un documento a otro.

Estilos de párrafos
Deberemos crear un estilo para cada tipo de párrafo diferente, todo el texto que aparece en un documento debe estar estilado. Primero haremos una estudio de los estilos de párrafos que necesitemos e incluso podremos agruparlos. Es conveniente que tengamos un estilo base sobre el que crearemos los demás, en este estilo base pondremos las características de nuestro documento: tipo de fuente, tamaño e interlineado, idioma, separación de sílabas, control de viudas y huérfanas, sangría de la primera línea, espacios anterior o posterior y alineación del texto. El resto de los párrafos lo basaremos en éste de forma que si queremos cambiar una característica general del texto al cambiarlo en el base se cambiará en el resto. Normalmente en los documentos extensos diremos que existen: ● Párrafo normal que es el base, ● Párrafo normal con espacio anterior, que nos servirá para aquellos párrafos que van a continuación de listas y citas,

Párrafo para Título del capítulo y para los autores de los capítulos y para la procedencia del autor o autores, ● Párrafo de citas, ● Párrafos de listas, donde distinguiremos listas numeradas, listas de letras y listas con viñetas, ● Párrafos para notas a pie de página, ● Párrafos de bibliografía, ● Grupos de párrafo de la tabla de contenido, ● Grupo de párrafos de índices de materia, ● Grupo de párrafos de texto en tablas. Después habrá que crear párrafos para los elementos que aparecen en las páginas maestras: párrafos para cabeceras, párrafos para el número de página, etc. El cuadro de diálogo de las opciones de párrafo es el siguiente, como vemos en la parte de la izquierda hay 18 categorías... hay algunas que difícilmente tocaremos, pero es bueno saber que están ahí pues nunca sabremos qué nos hará falta.

Del primer apartado “General” tendremos en cuenta: ● El nombre: es conveniente que párrafos similares tenga el mismo nombre, indicar que como podemos poner atajos de teclado y éstos se crean con una teclas (ctrl y/o

mayúsculas y/o alt) y un número del teclado numérico, una costumbre mía es poner el número delante, así para el texto base pongo el 00, para el con un espacio superior el 01, para los párrafos tipo títulos pongo 10, 11, etc. Como en xml no pueden comenzar las etiquetas por número, pondremos _00, _01, _10, etc Basado en: aquí lo que hablábamos, si bien cada párrafo de un tipo de párrafos se basará en el base, en el 00, el reto de estilos de ese tipo se basará en este primero. Ejemplo, yo suelo nombrar a los estilos de enunciados con el 40, entonces el primer enunciado, el de nivel 1, _40_enunciado01 estará basado en el _00_texto_normal, el enunciado de nivel 2, el _41_enunciado02, ya estará basado en el _40_enunciado01 y así respectivamente. Estilo siguiente: esta característica es interesante si somos nosotros quien introducimos texto y lo que nos permite es que al pulsar “enter” el siguiente texto estará asociado a un tipo de párrafo establecido, por ejemplo, después del nombre de la persona vendrá la procedencia, pues lo normal es que el estilo siguiente al estilo de “nombre de la persona” sea “procedencia” Atajo: será una combinación de teclas: CTRL, ALT, MAYÚSCULAS y los números del teclado numérico. Este atajo nos permitirá asociar un estilo a un texto sin sacar las manos del teclado. Ventana “configuración de estilo”: vemos las características propias del párrafo y sus diferencias con respecto al que se basan. Al lado vemos “restaurar base”, para que volvamos al original. Casilla “Aplicar estilo a selección”, es muy conveniente que lo tengamos activado para que así el texto sobre el que estamos creando el estilo lo tenga

En este apartado de “Formato de caracteres básicos” es donde decidimos los valores de ● Familia de fuente: TimesNewRoman, Arial, etc. ● Estilo de fuente: regular, cursiva, negrita, etc. ● Tamaño ● Interlineado, por defecto este suele ser el 120 % del tamaño, así en la imagen vemos que para 12 es 14,4, observamos que está entre paréntesis, eso indica que es un valor automático y así si aumentamos el cuerpo en una palabra o en un carácter, la línea “se abrirá” para que quepa, si quitamos los paréntesis o damos un valor estamos con un interlineado fijo. Yo recomiendo esta forma. ● Mayús./minús.: Ahí decidimos si un texto va en normal, todo en mayúsculas, todo en versalitas. ● Posición: para subíndice o superíndice. ● Las demás casillas es conveniente no tocarlas, la usaremos en casos en que queramos párrafos “diferente”, diremos para casos de publicidad, títulares, etc.

De este diálogo sólo tocaremos el idioma.

Este cuadro de diálogo será de los más usados:

● ●

Alienación: además de las de bandera izquierda (izquierda), bandera derecha (derecha), centrada, justificada (con las opciones de última línea centrada o a la derecha), justificación total (se llenará toda la línea, no se recomienda), están la de “hacia el lomo” y “hacia el lado opuesto del lomo”, esta es una alineación interesante para aquellos párrafos que queremos que se orienten de forma diferente según estemos en una página derecha o izquierda. Equilibrar líneas irregulares: característica interesante para los títulos, para los enunciados, para los pies de figuras..., la idea es que las líneas queden equilibradas y no nos deje una línea que ocupe toda la caja de texto y la siguiente solo tenga una palabra, de este forma las dos líneas tendrán el mismo número de palabras, serán iguales de longitud. Ignorar margen óptico: detalle tipográfico que hacer que las comillas y los marcas de puntuación “sobresalgan” de la caja de texto. Sangrias: la sangría es el espacio que tiene un párrafo que lo “aleja” de la caja. Normalmente las citas irán sangradas, en algunos casos por la izquierda y por la derecha. Respecto de la sangría de la primera línea decir que en la composición de párrafos la primera línea suele ir sangrada entre 5 y 10 mm. Para conseguir una sangría francesa lo que haremos será sangrar el párrafo una cantidad, por ejemplo 10 mm, y la primera línea la sangraremos con -10 mm, de esa forma se consigue esa forma de párrafo tan usado en las biblografías. Con la sangría de última línea conseguiremos el mismo efecto pero con la última línea, o sea, sangramos por la derecha todo el párrafo, por ejemplo 10 mm (se alejará de la caja) y la última línea le damos -10 mm y conseguimos que esta línea llegue a caja. Se usa en las tablas de contenido. Espacio anterior y posterior: espacio extra que introducimos entre los párrafos, para que la composición de los textos sea “elegante” se introducirán valores múltiplos de la interlínea, así si la interlínea es 12 pt, pondremos 24 pt antes y 12 puntos después en el caso de enunciados, o bien 18 pt y 6 pt, si no queremos tantos blancos. Alinear con la cuadrícula. Cuando definimos una cuadrícula haremos al aplicar esta opción el texto, independiente de la interlínea se situará sobre estas líneas (que podremos ver mediante ver cuadrícula base), ejemplo: si tenemos interlínea de 10 pt, pero la cuadrícula va a 12, la primera se pondrá sobre 12, y la segunda sobre 24, no en 10 y 20. Cuando trabajamos con columnas es conveniente tener activado esta opción para que las líneas de las dos columnas vayan a la misma altura.

Las tabulaciones: observamos que pueden ser de cuatro tipos, izquierda, central, derecha y decimal (respecto de un carácter). Las tabulaciones sirven para determinar dónde se van a parar los textos al darle a la tecla tabulador del teclado. Decir que si queremos tabular un texto es mucho mejor hacerlo con las tablas, nos dan muchas más opciones. ● tabulación izquierda: el texto sale desde esta posición hacia la derecha ● tabulación central: el texto queda centrado respecto de la posición del tabulador, y “crecerá” a izquierda y derecha según vayamos añadiendo texto ● tabulación derecha: el texto “llega” hasta el tabulador y no lo sobrepasará, todo el texto “vuelve” hacia la izquierda. ● tabulación decimal: se usa junto el cuadro “alinear en:” y nos permite alinear los textos respecto del carácter que introduzcamos en el cuadro “alinear en:”, muy usado para alienar por ejemplo respecto de la coma de cifras con decimales, de esa forma todas las comas estarán alineadas verticalmente. Respecto de los cuadros “X”, decir que es donde introduciremos el valor en que queremos que aparezca el tabulador; y el cuadro “Carácter”, introduciremos el carácter que queremos que aparezca en el “espacio en blanco” que crea el tabulador, sería por ejemplo como conseguimos los puntos que aparecen en las tablas de contenido.

Los filetes son esas líneas que ponemos en los párrafos. Para cada párrafo podemos añadir dos filetes, uno superior y otro inferior. Para ello marcaremos la casilla “filete activado”. No es posible recuadrar un párrafo.

Otro de los cuadros importantes. En este cuadro controlaremos que no existan huérfanas y viudas, para ello activaremos “conservar líneas juntas”, y pondremos 2 en inicio y fin. ● El cuadro “mantener con anterior”, nos permitirá que un párrafo no se quede solo al comienzo de una página. Es útil, por ejemplo, para poesías, si queremos que el último verso no se quede solo en una página ● La opción “No separar de las siguientes”, pondremos 2 y conseguiremos que un título o un enunciado se quede solo al final de una página, comenzando el texto que le sigue en la página siguiente. ● La opción “Empezar párrafo”: nos permitirá que un párrafo comience al principio de una página, por ejemplo el estilo de título de un capítulo es conveniente que comience siempre al principio de una página, incluso le podemos decir que sea una página impar, ese detalle lo controlaremos con este cuadro

Otro cuadro a tener muy en cuenta. Aquí señalaremos si queremos que las palabras se corten al final de una línea y cómo se deberán cortar. Podemos decir número mínimo de caracteres, cuantos quedan en la parte final de la línea y cuantos al comienzo de la siguiente, y número de guiones que pueden aparecer “seguidos”. Los otros elementos nos indica qué preferimos, si “más o menos guiones”, si se cortaran palabras, si se corta la última palabra de un párrafo o se si corta la última palabra de una página y/o columna.

Este es un cuadro que mejor no tocar, en él variaremos el espacio entre palabras, caracteres, el interlineado automático (por defecto es 120%). Si queremos las líneas más “abiertas” aumentaremos este valor, que es el responsable de los valores que salen entre paréntesis en el interlineado del cuadro “Formatos de caracteres básicos”. En “Justificado de una sola palabra”, ésta se “abrirá” para ocupar toda la línea. Respecto al modo de composición es conveniente dejarlo tal cual. El cuadro expandir columnas, nuevo en cs5.5, nos permitirá que un párrafo se extienda por las diversas columnas o bien que un párrafo se divida en varias columnas sin tener que crear cajas de texto, como en las versiones anteriores ocurría.

En este cuadro de diálogo podremos definir las capitulares y aparecen los estilos anidados: ● Estilos anidados: se trata de la unión de los estilos de párrafo y los estilos de carácter, la idea es que si tenemos una serie de elementos en un párrafo y aparecen de una forma determinada, primero uno, luego el otro, etc, y queremos que estos elementos aparezcan en todos los casos con unas características determinadas, podremos conseguirlo con los estilos anidados, por ejemplo, tenemos una serie de párrafos en que lo primero que aparece es una o varias palabras y a continuación dos puntos, luego aparecen una o varias palabras y a continuación una coma, etc. Entonces podemos crear un estilo anidado que diga que, por ejemplo, hasta los primeros dos puntos que vaya en negrita, hasta la primera “,” que vaya en cursiva, y de esa forma tendremos que así ocurrirá independientemente de que haya una o varias palabras antes de los dos puntos, la primera coma, etc. ● Estilos de línea anidado: la misma filosofía pero en este caso será la primera línea, la segunda, etc. En el caso del cuadro de diálogo estilo GREP, tendremos que hacer igual: aplicar un estilo de carácter a un texto, pero en vez de estar este texto colocado de cierta forma en el párrafo, lo que buscaremos será patrones de texto que queramos resaltar de alguna forma. Así mediante estos estilos podremos conseguir que los números de teléfono (conjuntos de nueve números) sean negrita, o que las direcciones de correo (palabras que contienen @) aparezcan en azul.

Cuando queramos exportar a libros electrónicos o bien para el xml donde todos las anulaciones deben estar en estilo de carácter, decir que los estilos anidados y estilos grep no se tendrían en cuenta, por tanto habrá que usar el siguiente script gratuito para convertir los estilos anidadado y grep en estilos de carácter que sí se exportarán. Paso la traducción de una parte del documento http://indesignsecrets.com/free-scripts-help-fix-word-formatting.php Si hemos aplicado estilos de caracteres, ya sea a través del panel Estilos anidados (CS3 y CS4) o en el panel Estilos GREP (CS4). Todo funciona perfectamente ... hasta que necesite exportar texto con formato con los estilos de carácter automático aplicados, tales como la exportación a RTF para compartir con un usuario de Word, o libros electrónicos o xml. El formato de estilo de carácter se pierde, y el texto vuelve a su formato base definida por el estilo de párrafo. Para conservar el formato, es necesario aplicar manualmente el estilo de carácter a cada instancia de texto con estilo. Pero, ¿por qué perder el tiempo haciendo ese trabajo tedioso cuando dos personas maravillosas han llegado con secuencias de comandos que hacer eso para usted? ApplyNestedStyles.zip (CS3 y CS4) es un script multiplataforma escrito por nuestro amigo Harbs (propietario de In-Tools) que se ocupa del problema de estilos anidados. No cambia la definición de estilo de párrafo en absoluto, el estilo de párrafo se sigue aplicando sus estilos anidados definidos. Es sólo que, cuando se ejecuta el script, el texto afectado también obtiene el estilo mismo carácter que se le aplica de forma manual, lo que significa que va a tener el formato correcto al exportarlo. TurnGrepStyles2CharStyles.zip (CS4) es un script multiplataforma escrito por un gurú de Adobe llamado Adi Israel Ravid. Al igual que ApplyNestedStyle, el script manualmente aplica el estilo mismo carácter al texto con el estilo de esa manera porque de un estilo GREP definido en el estilo de párrafo padres, y no toca la definición de estilo de párrafo. Conversión de estilos anidados y GREP'd a estilos de carácter manualmente aplicados también es útil cuando se exporta un diseño para INX (CS3 CS4 perdería el formato de estilo GREP, por ejemplo), y cuando el texto a exportar a ePub, XHTML y XML.

Mediante el cuadro de diálogo viñetas y numeración podremos crear párrafos que lleven delante viñetas (símbolos) o numeraciones de tipo 1., 1.1., 1.1.1,..., a), b); o bien Figura 1, Figura 2...; cuadro 1, cuadro 2,.... etc Los cuadros de color de caracteres, características open type, opciones de subrayado y opciones de tachado, son cuadros donde podremos cambiar algunas características específicas de los textos.

Cuadro de diálogo nuevo en la versión cs5.5, en él podremos etiquetar nuestros párrafos con vistas a la exportación a epub y hmtl y sobre todo con vistas a las css que se usan en estos lenguajes. A priori no es conveniente cambiar nada, pero es necesario saber que podremos etiquetar de forma diferente a como lo hace el programa y que eso nos permitará trabajar mejor con las css.

Estilos de carácter
Los usaremos para características “especiales”: colores, tamaños, tipos de fuente, idiomas y como hemos comentado, junto con los estilos de párrafo hacemos los estilos anidados, GREP, y también los podremos usar para los estilos de capitulares, para crear estilos en las viñetas, etc. El estilo de carácter manda sobre los estilos de párrafos, y si a un texto le tenemos aplicado un estilo de carácter, aunque le digamos al estilo de párrafo que quite todas las anulaciones, las diferencias que tenga el estilo de carácter permanecerán. El cuadro de diálogo de estilos de carácter tiene 8 categorías, e igual que en los estilos de párrafos, puede que no usemos algunas, pero es bueno saber que están ahí.

En la categoría general le daremos el nombre. A igual que ocurría con los estilos de párrafos, sería conveniente utilizar nombres que nos indiquen qué son y que podamos después relacionar con etiquetas xml. El “basado en” es la misma filosofía que en aquéllos y el “atajo” se creará de igual forma. Es conveniente tener señalado “aplicar estilo a selección”. Si observamos las diferentes categorías veremos que éstas ya se han comentado en los estilos de párrafos. Lo único que debemos recordar es que aquéllas eran para el párrafo entero y éstas solo son para los caracteres que tengamos con el estilo aplicado.

- Estilos de celdas y tablas:
Mediante estos estilos conseguiremos cambiar la forma de las tablas de forma rápida, de igual forma que ocurría con los estilos de carácter y párrafo. Aquí el estilo de celda manda sobre el de tabla. Como veremos, cada estilo de celda puede llevar asociado un estilo de párrafo, cosa que es conveniente. Pero como ya hemos dicho, si el texto de una celda tiene asignado un estilo de carácter, al aplicar el estilo de celda, con estilo de párrafo incluido, dominará las características del estilo de carácter.

Estilos de celdas:
Dentro de una celda hay que distinguir dos temas, uno el aspecto de la celda: filetes (líneas) de las celdas, fondo, márgenes, alineación vertical, etc, y por otro lado el formato del texto. Ésto lo conseguiremos con el estilo de párrafo asociado a un estilo de párrafo. El cuadro de diálogo del estilo de celda tiene 4 categorías:

En la general, de forma similar a otros cuadros de diálogos de estilos, tenemos el nombre, si está basado en otro estilo y el atajo. Y además, el “estilo de párrafo”. Es conveniente crear un estilo de párrafo base para las tablas y los demás basarlos en este, por ejemplo creamos el estilo tabla_izq, pues normalmente los textos irán en bandera izquierda y a partir de él crearemos los tabla_der, y tabla_central, que se diferenciarán en la alineación. Para las celdas de cabecera, que tendrán su propio estilo, crearemos un estilo tabla_cabecera.

En la categoría texto observamos que una celda es similar a un cuadro de texto y que por tanto podremos definir márgenes como alineación vertical, superior, media, inferior o justificada. A igual que hacemos con las cuadrículas bases, podremos determinar dónde se coloca la Primera línea base. Cuando trabajamos con imágenes usaremos la casilla de recorte. En la rotación del texto decidiremos si va a 0, 90, 180 y 270º

En esta categoría definiremos cómo queremos el aspecto de la celda, si lleva “bordes”, de qué estilos serán estos, y de qué color. Lo mismo con el color de las celdas. Por último queda la categoría “líneas diagonales” que nos permite definir cómo serán las línea diagonales que puede llevar una celda.

Estilos de tablas:
Con ellos conseguiremos que la tabla se comporte según unas características, así podremos definir espacio anterior y posterior a la tabla, si lleva un contorno, cuál es el formato de las celdas por defecto, así como las celdas de cabecera, de pie, de la 1ª columna de la izquierda y de la última columna de la derecha. Podremos indicar también si queremos que lleven rellenos alternos las filas y/o columnas. Resumiendo, con el estilo de tabla definiremos el aspecto de la tabla. El cuadro de diálogo de los estilos de tablas tiene 5 categorías. Veamos:

En la categoría general daremos el nombre, si está basado en otra, si hay algún atajo y podremos definir los estilos de celda que llevarán cada una de las filas y columnas que aparecen en el cuadro.

En la categoría “configuración de tabla” le diremos si queremos que tenga un borde, si las celdas tienen bordes mandarán estos sobre el de la tabla. Y también le decimos aquí el espacio que hay antes y después de la tabla. En el cuadro “orden de dibujo de trazo” nos permitirá saber, en el caso de que los bordes de columna y filas sean diferentes, quién está encima.

Las categorías “trazo de fila”, “trazos de columnas” y “rellenos” son semejantes y están pensadas para cuando queremos tablas en que se alternen los trazos y/o rellenos” de las filas o de las columnas, en estos cuadros podremos determinar el color de los fondos y de los trazos y cómo se alternan. Cuando aplicamos estilos de celdas y de tablas es conveniente tener pulsada la tecla Alt de forma que desaparezcan todas las “anulaciones” de los textos de las tablas.

- Libros electrónicos (formato epub)
Para InDesign los libros electrónicos se entienden como una forma de exportar un documento creado en el mismo programa. Por tanto si trabajamos teniendo en cuenta que todos los textos están estilados, ya sea con estilos de carácter o estilos de párrafo, no debemos tener ningún problema a la hora de crear un libro electrónico. Algunos detalles a tener en cuenta cuando trabajamos con vista a los libros electrónicos: ● No debe haber lo que se llaman anulaciones: texto en cursiva, en negrita, en color, etc, aplicado directamente sobre el texto, si no que conseguiremos esas características mediante estilos de carácter.

En el caso de que haya imágenes éstas deberán ir ancladas en el lugar que deben aparecer, recordar que las imágenes que no se anclen irán al final del documento. ● En el caso de tablas que las necesitemos introducir en un cuadro de texto independiente de la caja de texto “normal”, también la anclaremos con idea de que salga luego en el lugar que corresponde. ● Recordar que todos los elementos de la página maestra desaparecen, que no habrá número de páginas y que si bien se puede hacer una tabla de contenidos no es necesario numerarla ya que los números no servirán, aunque al tocar sobre los distintas entradas nos llevará. ● Otro detalle en el libro electrónico pierde sentido los conceptos de viuda y huérfanas, los cortes de palabra, etc. Por lo menos en la revisión actual de epub 2.1. ● Tampoco existen páginas en blanco, ni dobles, triples, etc, retornos ● Las imágenes valdrían en principio a 144 ppp, pero si es para el iPad y otras tabletas similares, entonces la resolución debe ser 300 ppp, recordar que esto origina ficheros muy grandes, por tanto podemos dejar a 144/150 ppp Para crear un libro electrónico nos vamos al menú Archivo / exportar y elegimos epub:

Nos saldrá este cuadro de diálogo que como vemos tiene tres categorías. En esta primera tenemos: ● Incluir metadatos de documento: estos metadatos se toman de la información que se haya introducido en el cuadro que sale en Archivo / Información del archivo, son muy importante las palabras clave ● Añadir entrada del Publisher: aquí deberá ir el nombre de la editorial o del editor. ● Identificador único: aquí debería ir el ISBN, si no se introduce nada, indesign genera un número único y propio, que no es ISBN. ● Portada EPUB, hay tres posibilidades: ○ Sin imagen de portada, en las estanterías de los lectores saldrá el nombre del fichero y una portada sin nada ○ Rasterizar la primera página: en la estanterías de los lectores saldrá la primera página del documento ○ Usar un archivo de imagen existente: recordar que este archivo es el que se usará para verse en las “estanterías” de los readers, no es la portada del libro. ● Orden: aquí se refiere a cómo exportará indesign los elementos que componen el libro, este punto tiene sentido en publicaciones con muchos elementos, incluso en una misma página. Para publicaciones de texto con algunas imágenes/gráficos (que deberán estar anclados) usaremos la primera opción. Las otras dos opciones dependerá de haber usado estructuras XML y artículos. ● Opciones de formato: ○ Margen del libro: en teoría sirve para darle un margen a la página, en la realidad todos los lectores lo ignoran, menos el de Adobe (Adobe digital editions). ○ Las opciones de si exportamos como texto o listas es saber que en un caso las listas en las css se comportan de una forma pero que podemos crear un estilo de párrafo que haga lo mismo. ● Ver tras la exportación: visualizar el resultado.

En la categoría imagen decidimos cómo queremos que salgan las imágenes que hay en el documento, ● Conservar la apariencia de la maquetación: esto se refiere a que si nosotros tenemos una imagen que la hemos recortado y/o girado, InDesign exportará una nueva imagen que tenga en cuenta esos detalles, si no está marcado saldrá la imagen como era originalmente, sin recorte ni giro. ● Resolución: con 150ppp se ve bien en los lectores que no sea los de calidad “Retina” (iPad 3 e iPhone 5). También el Samsumg Galaxy SIII y dispositivos Android similares tienen pantallas de Alta Definición, y para estos pasos nos iríamos a 300ppp. ● Tamaño de la imagen: aquí es conveniente poner relativo a la página de forma que si una imagen ocupa la mitad, ocupará la mitad de una pantalla, sea como sea esa pantalla. ● Los elementos que vienen a continuación sirven para controlar cómo queremos que se coloquen las imágenes e incluso si las ponemos en páginas a parte ● A continuación nos pregunta por cómo queremos exportar las imágenes, formato, y con qué especificaciones, es conveniente dejar los valores por defecto de indesign

Casilla de Ignorar configuración de exportación de objetos: a cada objeto le podemos dar unos valores específicos de exportación, si la marcamos no se tendrán en cuenta esos valores.

Categoría contenido: ● Formato para contenido EPUB: elegimos XHTML ● Contenido: ○ es conveniente marcar “usar estilo de TDC de InDesign y elegir la que hayamos creado nosotros. ○ Dividir documento por estilo: aquí recordamos que no es conveniente ficheros muy grandes, por tanto podremos indicar un estilo que divida el documento en varios. ○ Para lo de las notas es lo que se quiera, por defecto las coloca al final del documento y al pulsar sobre la llamada nos lleva y al pulsar allí sobre el número nos “devuelve” a la llamada. ○ Hay que tener cuidado con eliminar los saltos de líneas forzadas, pues podría dar lugar a que se unieran palabras en una misma línea.

Opciones de CSS: recordamos que las css es un estilo de libro, o sea, libros idénticos, de la misma colección, deberán tener css iguales, por tanto si es el caso deberemos crear primero una y luego usar siempre la misma, en este caso para los siguiente libros usaríamos la opción de “Usar archivos CSS existentes”, pero la primera vez hay que generarla. Una de las opciones de este primera forma “Generar CSS” es “conservar modificaciones locales”, esto es por si no hemos usado estilos de carácter para las anulaciones (cursivas, negritas, etc), InDesign crea los suyos propios.

Ahora podremos exportar y se generará un epub. Decir que un EPUB lo podremos modificar mediante la edición de las CSS. Aquí dos páginas del mismo sitio, el de don Francisco Javier Gómez Laínez, donde se puede ampliar lo dicho sobre libros electrónicos (es para InDesing cs4 pero sirven las ideas para la cs5.5): http://www.nousmedis.com/2010/01/creacion-de-libros-electronicos-en-formato-epub-conindesign-cs4/ Y esa es para editar el epub tocando su css: http://www.nousmedis.com/2012/03/editar-un-epub-creado-con-indesign/ Una página para crear epub de don gustavo sánchez http://www.gusgsm.com/como_crear_un_libro_electronico_en_formato_epub_con_adobe_indes ign_55

- Introducción a XML
XML son las inciales de eXtensible Markup Language (lenguaje de marcas extensibles). Se trata de un lenguaje de marcas para datos, lo que significa que no se ocupa de aspecto, sino del significado del contenido. Diremos que xml es una base de datos en texto plano. XML es una forma de trabajar: nosotros tenemos un contenido, una información y ese contenido los podemos representar de una forma u otra, pero esa forma de representarlo depende de algo independiente del contenido. Por tanto al trabajar en XML lo que hacemos es estructurar los contenidos mediante etiquetas. InDesign permite pasar de textos con una estructura de estilos de párrafos y carácter a una estructura de etiquetas de XML, y también en sentido inverso, a partir de textos etiquetados, podemos pasar a textos con estilos lo que nos permite “presentar” esos textos de forma diferente en función de cómo tengamos definidos esos estilos. A partir de textos estilados es posible crear estructuras xml, para ello lo que hacemos es que a cada estilo de párrafo y carácter asignamos una etiqueta. Ahora, si bien esas etiquetas se pueden crear diremos que tendríamos texto etiquetado, pero no estaría estructurado, o sea, no sabemos qué relación hay entre las etiquetas. Para controlar ese aspecto usamos las DTD (Document Type Definition=definición del tipo de documentos), o sea, en una DTD se declaran

elementos, entidades y atributos que pueden aparecer y en qué forma (estructura) en un archivo xml determinado. Como lenguaje semántico que es, DocBook nos permite crear documentos en un formato neutro, independiente de la presentación. En este formato neutro, se recogen tanto el contenido como la estructura lógica del mismo. Permitiendo así que pueda ser publicado (presentado) automáticamente en multitud de formatos: HTML, XHTML, EPUB, PDF, man pages , HTML Help, etc. Simplemente aplicando "plantillas" de presentación, sin que sea necesario ningún cambio sobre el documento original. Por tanto la idea para trabajar es crear una dtd donde definimos los elementos de nuestra publicación, y a cada elemento le corresponde una etiqueta. Pueden ocurrir dos cosas: ● Que nos den un texto que ya viene etiquetado (un documento xml que InDesign puede importar), entonces mediante el panel de etiquetas (Menú Ventana / Utilidades/ Etiquetas) y teniendo unos estilos (ya los habremos creado en su momento o bien los importaremos) que trataremos que tengan el mismo nombre que las etiquetas, podemos asignar a cada etiqueta un estilo (de párrafo y carácter), y de esa forma el texto etiquetado pasará a estar estilado y por tanto ya tendremos nuestro documento creado. ● Que nos den un texto sin etiquetas, entonces nosotros mediante los estilos de párrafo y carácter estilaremos los textos, y luego mediante el panel de etiquetas asignaremos una etiqueta (que habremos importado mediante un dtd o fichero xml) a cada uno de los estilos, de esta forma tendremos los textos etiquetados, y luego siguiendo las instrucciones de la dtd agruparemos los elementos en elementos mayores (que también tendrán sus etiquetas) y de esa forma crearemos una estructura que podremos exportar a xml y así tener un documento en ese formato que se podrá usar para otros fines. Ponemos a continuación la DTD de del diario de sesiones y la explicamos, en negro la dtd, en rojo las explicaciones
<?xml version="1.0" encoding="UTF-8"?> (Nos indica que es xml y que está en formato utf-8, uno de los estándares) <!ELEMENT diario_sesion_pa (legislatura, numero_diario, tipo_sesion?, organo, presidente, numero_sesion?, fecha, desarrollo)> (Aquí definimos el primer elemento, que como tal es el elemento raíz, del que parte todo, se llama diario_sesion_pa, darse cuenta que no puede haber espacios, tampoco tildes, no puede comenzar por una cifra, y sí por ejempl por _. Este elemento está compuesto por los elementos que van entre paréntesis, los cuales al estar separados por “,”, significa que deben aparecer en ese orden, los elementos son: legislatura, numero_diario, tipo_sesion, organo, presidente, numero_sesion, fecha, desarrollo. Los elementos que llevan ?, o sea, tipo_sesion? y numero_sesion?, nos dice la dtd que pueden aparecer una vez o no aperecer, en el caso de en vez de una vez o no aparecer, fuera varias veces o no aparecer (ejemplo las notas a pie de páginas en un párrafo que puede no haber o puede haber más de una) sería un * en vez de la ?) Ahora comenzamos a definir cada uno de los elementos que componen el elemento diario_sesion_pa <!ELEMENT legislatura (#PCDATA)> <!-- I, II, III, IV, V, VI, VII, VIII,... → (#PCDATA) nos indica que el tipo de contenido es una cadena de caracteres, o sea, texto o entidades analizables. Otros tipos de contenido son ANY, sería cualquier tipo de dato, es conveniente no utlizarlo; EMPTY, el elemento no contiene datos, pero se refiere a que no contiene texto o datos

analizables, por ejemplo las imágenes; (Element?) sería el caso del elemento diario_sesion_pa, pues nos indica que un elemento puede contener más elementos) <!ELEMENT numero_diario (#PCDATA)> <!-- como una misma sesion puede durar varios dias, y cada dia genera un diario... --> <!ELEMENT tipo_sesion (#PCDATA)> <!-- ordinaria, extraordinaria, constitutiva, institucional --> <!ELEMENT organo (#PCDATA)> <!-- pleno, comision de XXXX, diputacion permanente --> <!ELEMENT presidente (#PCDATA)> <!ELEMENT numero_sesion (#PCDATA)> <!ELEMENT fecha (dia, mes, anio)> (Aquí nos indica que el elemento fecha está compuesto de otros tres elementos: dia, mes, anio) <!ELEMENT desarrollo ((epigrafe | iniciativa)+)> <!-- epigrafe es un artificio para agrupar todas las iniciativas del mismo tipo → (En este caso el elemento desarrollo está compuesto por epígrafe o por iniciativa (se indica por la barra vertical |, se tratan de elementos excluyentes o uno u otro) y como hay un + detrás del paréntesis nos está indicando que puede haber uno o varios pero de unos o de otros, o sea, que habrá desarrollos que estén compuesto por uno o varios epígrafes, a su vez cada epígrafe estará compuesto, como vemos a continuación por iniciativas; o bien un desarrollo puede estar compuesto por una o más iniciativas, sin tener un epígrafe)) <!ELEMENT dia (#PCDATA)> <!ELEMENT mes (#PCDATA)> <!ELEMENT anio (#PCDATA)> <!ELEMENT epigrafe (tipo_epigrafe, iniciativa+)> <!-- tipo_epigrafe es lo mismo que tipo_iniciativa → (El elemento epigrafe está compuesto de tipo_epigrafe y de iniciativa, y al llevar un + iniciativa significa que puede ser una o más) <!ELEMENT tipo_epigrafe (#PCDATA)> <!ELEMENT iniciativa (tipo_iniciativa, numero_expediente?, extracto?, proponentes?, debate_agrupado?, tramite?, votacion*, intervienen?, materias?, intervencion+)> (El elemento iniciativa está compuesto por tipo_iniciativa, numero_expediente, extracto, proponente, debate_agrupado, tramite, votación, intervienen, materias, intervencion, ahora bien los elementos numero_expediente, extracto, proponentes, debate_agrupado, tramite, intervienen y materias, al llevar un ? pueden o no aparecer y si lo hace solo será una vez. El elemento votación, al llevar un * significa que puede no aparecer o aparecer una o varias veces) <!ELEMENT tipo_iniciativa (#PCDATA)> <!-- pregunta oral, proposicion no de ley... --> <!ELEMENT numero_expediente (#PCDATA)> <!-- si se trata de un debate agrupado, aparecera el numero de expediente de todas las iniciativas que han sido agrupadas --> <!ELEMENT extracto (#PCDATA)> <!-- si se trata de un debate agrupado, aparecera el extracto de todas las iniciativas que han sido agrupadas. Aparecen en el orden del dia --> <!ELEMENT proponentes (#PCDATA)> <!-- Este dato aparece en el orden del dia; ojo con a peticion propia en las comparecencias; presentada por, formulada por, solicitada por, a propuesta de --> <!ELEMENT debate_agrupado ((componente)+)> <!-- Si es un debate agrupado, el numero de expediente contiene la lista de los numeros de expedientes componentes, el extracto contiene el extracto resumen que aparece en el desarrollo, y proponentes esta vacio. Cada componente

tiene su propio numero de expediente, su extracto y sus proponentes →(El elemento debate_agrupado está compuesto de uno o más componentes, lleva un+) <!ELEMENT componente (numero_expediente, extracto?, proponentes?)> (El elemento componete está compuesto de numero_expediente, extracto y proponentes, ahora bien, extraco y proponentes no tiene por qué aparecer) <!ELEMENT tramite (#PCDATA)> <!-- motivo por el que esta incluida, etapa por la que va de su tramitacion --> <!ELEMENT votacion (#PCDATA)> <!-- este dato aparece en el sumario, solo a veces, otras dice consultar texto --> <!ELEMENT intervienen (#PCDATA)> <!-- este dato aparece en el sumario --> <!ELEMENT materias (#PCDATA)> <!ELEMENT intervencion (interviniente,discurso)> (el elemento intervencion está formado por interviniente y dicurso, los dos elementos son obligatorios) <!ELEMENT interviniente (#PCDATA)> <!-- tratar de relacionar con la lista de intervinientes del sumario, donde aparecen nombres completos y cargos --> <!ELEMENT discurso (parrafo+)> (el elemento discurso está compuesto por uno o más párrafos, lleva un +, observar que el + va al lado de la palabra, y no como en el caso de de debate_agrupado que el +iba detrás del paréntesis de componente, la diferencia es que párrafo es un elemento #PCDATA y componentes es un elemento compuesto por otros) <!ELEMENT parrafo (#PCDATA)> Para importar esta dtd a InDesing tendremos que ir al panel etiquetas, o bien al panel estructura (para verlo menú Ver/Estructura/Mostrar estructura), que nos daría una etiqueta por cada uno de los elementos que aparecen. Según la definición que hemos hecho, serían 31 elementos=31 etiquetas: diario_sesion_pa tipo_sesion numero_sesion dia epigrafe tipo_iniciativa proponentes tramite materias nombre_inter parrafo legislatura organo fecha mes tipo_epigrafe numero_expediente debate_agrupado votacion intervencion cargo_inter numero_diario presidente desarrollo anio iniciativa extracto componente intervienen interviniente discurso

Ahora cada una de las etiquetas tendrá una correspondencia con los estilos de párrafo y de caracteres, aunque puede haber etiquetas que afecten a marcos de texto. Vamos ahora a importar un fichero xml sobre un documento de indesign al que lo primero que hacemos es cargar la dtd. Como la dtd es la diario de sesiones de parlamento, el elemento raíz es el diario de sesiones y cuando importamos decimos “combinar”, sobre el elemento raíz que le hemos dicho que es un diario de sesiones. Si dijéramos “anexar”, nos saldría un diario de sesiones hijo del diario de sesiones “padre”

- Bibliografía y enlaces
La ayuda de InDesign es muy extensa y además casi todos los apartados tiene vídeos, la mayoría en inglés. En Adobe España, sus trabajadores, tienen un sitio muy completo con clases de una hora de duración y que están muy bien, el sitio en general http://www.trucosyconsejos.com/ La parte dedicada a InDesign: http://disenytrucosyconsejos.blogspot.com.es/p/design-photoshop-indesign-illustrator.html Adobe España hace regularmente cursos online de una hora de duración al que se se puede asistir gratuitamente, estos cursos, pasados unos días, se publican en la página indicada arriba. Un libro económico y escrito por un señor que sabe mucho es “Guía Práctica de Indesign CS5” de Francisco Javier Gómez Laínez, de Anaya Multimedia, a un precio de 14 euros. Es adecuado tanto para principiantes como para usuarios más avanzados, y está muy bien. Para los script tenemos esta página donde aparecen muchas otras: http://www.indiscripts.com/post/2010/08/50-indesign-scripts-and-tools-for-end-users Para mi la mejor página con script gratuitos es: http://www.kahrel.plus.com/indesignscripts.html 20 scrpit gratuitos http://www.creativepro.com/article/20-free-must-have-scripts-indesign-users Una página con un glosario gráfico: http://glosariografico.com/ Que ha sido realizado por uno de los grandes profesionales de las artes gráficas que escribe un blog muy bueno: http://gusgsm.com/ Se trata de don Gustavo Sánchez Muñoz (gusgsm), en ese blog hay mucho para aprender. Otro que está muy bien y sobre todo relacionado con los libros electrónicos es el blog de mi amigo Ignacio Lirio: http://www.publicarendigital.com/ Donde tiene un glosario de términos sobre publicaciones electrónicas muy interesantes.

Otro blog parecido sobre publicaciones electrónicas, de otro que sabe mucho es, es el autor del libro que he recomendado: http://www.nousmedis.com/ Por último la páginas de los foros de adobe en español, donde se contesta de todo: http://forums.adobe.com/community/international_forums/espanol Para el mundo de las búsquedas GREP está muy bien la ayuda de InDesign: http://help.adobe.com/es_ES/indesign/cs/using/WSFB3603CC-8D84-48d8-9F77F3E0644CB0B6a.html#WSa285fff53dea4f8617383751001ea8cb3f-6f59a GREP también se llaman expresiones regulares y en la Wikipedia encontramos: http://es.wikipedia.org/wiki/Expresi%C3%B3n_regular Aquí un manual en español de lo que se llaman expresiones regulares. Es un enlace que viene en la Wikipedia: http://www.desarrolloweb.com/manuales/expresiones-regulares.html

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->