Acknowledgements
Special thanks to: Dean, School of Mechanical and Aerospace Engineering, USM Assoc. Prof. Dr. Zaidi Mohd Ripin. USAINS Holding Sdn. Bhd. Unit Latihan, USM Secretariat committee; Mr. Mohamad Ikhwan Zaini Ridzwan, Dr. Mohd Salman Abu Mansor, Mr. Wan Amri Wan Mamat Ali, Mr. Norijas Abd Aziz, Mr. Hishammudin Endan Ms. Rosmawati Mohamath Ms. Siti Farah Aida Zolhani Staffs, School of Mechanical and Aerospace Engineering, USM Prof. Ahmad Yusoff Hassan Mr. Ahmad Khaizi Mahidin Ms. Sharmila Azlin Ramly Ms. Nor Zainah Bahari Ms. Juhana Ahmad Ariff Mr. Jamari Sadli Mr. Hasrie Mohd Hashim

Coordinator, Mr. Mohamad Ikhwan Zaini Ridzwan
i

Contents
Day One – 29 April 2008
Module 1: Introduction to SolidWorks and Basic Sketching..................................... 1 Introduction to SolidWorks........................................................................................1 SolidWorks user interface & Toolbar menus .......................................................2 FeatureManager Design Tree ...............................................................................4 Keyboard shortcuts and mouse buttons..............................................................5 Tools-Options .........................................................................................................6 Basic 2D sketching....................................................................................................9 Sketch Entities/Geometry.................................................................................. 10 Status of a sketch............................................................................................... 11 Sketch Relations................................................................................................. 12 Tutorial 1.1: Sketch a Simple Nut with Circle and Polygon ............................. 20 Tutorial 1.2: Using 3D sketch ............................................................................ 21 Tutorial 1.3: Apply Add Relations between Sketch Entities ………………………. 22 Exercise 1.1: Sketching Horizontal and Vertical Lines..................................... 23 Exercise 1.2: Sketching Lines............................................................................ 23 Exercise 1.3: Sketching using Rectangle and Circle........................................ 24 Exercise 1.4: Sketching a Chair Frame using 3D sketch................................. 24 Module 2: Additional Sketching ............................................................................... 25 Tutorial 2.1: Creating a Flat Bar ............................................................................ 26 Tutorial 2.2.............................................................................................................. 31 Tutorial 2.3.............................................................................................................. 33 Exercise 2.1 ........................................................................................................ 35 Exercise 2.2 ........................................................................................................ 36 Module 3: Basic Part Modeling ................................................................................ 37 Sketching and Creating Bosses............................................................................. 38 Creating a Counterbore Hole ............................................................................. 41 Cut Feature ......................................................................................................... 43 Filleting................................................................................................................ 46 Chamfering.......................................................................................................... 47 Define Material and Mass Properties ............................................................... 48 Editing features .................................................................................................. 49 Exercise 3.1: Glass Plate ....................................................................................... 51 Exercise 3.2: Bracket ............................................................................................. 51 Exercise 3.3 ............................................................................................................ 52 Exercise 3.4: Gland ................................................................................................ 52 Exercise 3.5: PVC Tee Pipe .................................................................................... 54

Day Two – 30 April 2008
Module 4: Additional Part Modeling......................................................................... 55 Revolved features................................................................................................... 56 Tutorial 4.1.......................................................................................................... 57 Patterning................................................................................................................ 62
ii

...............................................1: Curve Driven Pattern...................................................................................... 97 Insert Component into Drawing............................................ 96 Drawing toolbars...............................................................................................................120 iii ..................... 105 Edit Sheet Format.............................................................................................................................................................1:...................................3: Creating a Worm Gear .... 119 References ........................................................................................................... 64 Swept. 118 Exercises 6................................................ 114 Creating Bill of Materials (BOMs) ............... 94 Module 6: Drawing.................................................................................... 116 Producing an e-drawing file ..............................5: Creating a Bottle (with a guide curve).... 67 Tutorial 4..... 72 Rib and Shell............4: Creating a Spring................................................................... 112 Example of Assembly Drawing.............................................................................................................. 65 Tutorial 4.. 101 Insert a Note ..................................................... 98 Adding dimensions to drawing and modifying dimensions ...... 106 Assembly Drawing ....................................... 70 Exercises 4...........................................................................................................................................2: Chisel ................. 77 Module 5: Assembly Modeling ........... 97 Insert standard drawing views ...................................................... 100 Create Section View.................................................................................................................................................................................................................................................................................................................................................. 66 Tutorial 4............................................................................................................................................................................Tutorial 4...................................................................................................................................................... 112 Opening drawing template and edit Sheet Format ................................. 78 Assembly toolbars ........................................................................................................................................ 115 Customizing BOMs ................................................................................................................................... 93 Creating an explode line sketch .............................................. 113 Adding the Exploded View................................. 68 Lofted ........................................................................................ 81 Sliding Brace Assembly ............................................................ 76 Tutorial 4.....................................6: Create lofted part with Centerline Parameters .............................................................................................. 82 Exploding and collapsing the assembly ...................... 69 Tutorial 4.......................... 81 Basic assembly mates ........................ 112 Elements of an Assembly Drawing .........................................................2: Vary Sketch option ....... 116 AutoBalloons............... 63 Exercises 4.................Angle of projections..................................7: Using Shell to create wall thickness inside the Bottle..............................................................

In SolidWorks. an assembly. when you make change to the drawing and assembly. and a drawing are all fully associated. and drawings. assemblies. a part. those changes will be reflected back to the model. Likewise. Starting a SolidWorks 1 . which take advantage of the Microsoft Windows graphical user interface.SolidWorks Training (Basic) Module 1: Introduction to SolidWorks and Basic Sketching (1 hour 50 minutes) Introduction to SolidWorks (20 minutes) SolidWorks is a mechanical design software package to build parts. Changes to the model are automatically reflected in the associated drawings and assemblies.

• When a menu item is followed by a series of dots. 2 . it means there is a sub-menu associated with the choice.SolidWorks Training (Basic) SolidWorks user interface & Toolbar menus The interface is native Windows interface. Main Menu Standard Toolbar View Toolbar Standard Views Toolbar CommandManager FeatureManager Design Tree Status Toolbar Menus • • It provides access to all commands that the SolidWorks offers. When a menu item has a right pointing arrow. it means that option opens a dialog box with additional choices or information. and such behaves in the same manner as other Windows applications.

3 . They are organized according to function and can be customized. 3. saving documents. Clicking View – Toolbars displays the same list of toolbars. click the check boxes to select each toolbar you want to display. You can turn toolbars on and off using one of three methods.SolidWorks Training (Basic) Toolbars menus • • Provide shortcuts enabling to quickly access the most frequently used commands. On the Toolbars page. Click Tools – Customize. 2. printing. copying and pasting objects. Right click on toolbar area of the SolidWorks window. and help. 1. Clear the check marks of the toolbar you want to hide. redo. removed and rearranged according to your preferences. Clear the check boxes of the toolbars you want to hide. Check marks indicate which toolbars are currently visible. Example of a Toolbar Standard toolbar as shown below contains commonly used function as opening new or existing documents. undo.

The ConfigurationManager on the left side of the SolidWorks window is a means to create. You can drag items in the FeatureManager design tree list to reorder them. execute the command. and has explode state 4 . The icons in the ConfigurationManager denote how the configuration was created: Manually With a design table Manually. Identify and change the order in which features are created. The PropertyManager appears on the PropertyManager tab in the panel to the left of the graphics area. It allows access to do editing of the models. and view multiple configurations of parts and assemblies in a document. Suppress and Unsuppress part features and assembly components. Display the dimensions of a feature by double-clicking the feature’s name. It consists of three default tabs: o FeatureManager design tree o PropertyManager o ConfigurationManager The FeatureManager design tree makes it easy to: • • • • • Select items in the model by name. Display a preview of the feature. Open the corresponding help topic. It displays the details chronological sequence on how all the parts. Rename items by slowly clicking two times on a name to select it and then entering a new name. This changes the order in which features are regenerated when the model is rebuilt.SolidWorks Training (Basic) FeatureManager Design Tree • • • • It is located on the left side of the SolidWorks Graphic window. assembly and drawing are created. It opens when you select entities or commands defined in the PropertyManager. select. Ignore any selections and close the PropertyManager. Title bar Help. and close the PropertyManager. and has an explode state With a design table. OK. Preview. Cancel. Accept the selections.

To deselect object. Click Tools – Customize. To select multiple items. zooming a part or assembly. The contents of the menu is differ depending on what object the cursor is over. (Simply rotates the wheel of the middle mouse button for zooming in or out if your middle mouse button is a wheel. • • 5 .SolidWorks Training (Basic) Keyboard shortcuts and mouse buttons Keyboard shortcuts Some menu items indicate a keyboard shortcut such as: Ctrl+O for File. Find Keyboard tab as in figure shown. Open Ctrl+S for File.) o Pan all document types – Hold down the Ctrl key while depressing the middle button and drag the mouse. menus buttons. simply click anywhere in a blank (empty) portion of the work area. Save Ctrl+Z for Undo And many more You can customize SolidWorks by creating your own shortcuts. o Rotate part or assembly – Holding down the middle button and drag the mouse o Zoom all document types – Hold down the Shift key while depressing the middle button and moving the mouse. Middle – use for dynamically rotating. Three mouse buttons • Left – to select objects as geometry. you must hold down the Control (Ctrl) key. Right – activates a context sensitive shortcut menu. panning. and objects in the FeatureManager design tree.

if you set the color to Black. Level of customization: • System Options Every option under System Options will affect every document you open in SolidWorks session. the viewport background. Example: Set Viewport Background to White 6 .SolidWorks Training (Basic) Tools-Options The Options dialog box able you to customize the SolidWorks software based on your preferences. it will remain as black every time you open the SolidWorks window until you change to another color. For example.

image quality etc. For example. Example: Setting Units Tools Options second) Document Properties Units MMGS (millimeter. material properties.SolidWorks Training (Basic) • Document Properties This setting only applied to individual documents. units. They are saved with the document and do not change. gram. drafting standard. Example: To increase the quality of image 7 .

SolidWorks Training (Basic) Example: Set Dimensioning Standard 8 .

or over defined) Sketch tools (Tools can be used to modify the sketch geometry that has been created/ this often involves the trimming or extension of the entities) Extruding the sketch (Extruding uses the 2D sketch to create a 3D solid feature) 9 . millimeter or other units) Sketches (Collections of 2D geometry that are used to create solid features) Sketch Entities/Geometry (Types of 2D geometry such as lines. circles and rectangles that make up the sketch) Sketch Relations (Geometric relationships such as horizontal and vertical are applied to the sketch entities. under.SolidWorks Training (Basic) Basic 2D sketching (1 hour 30 minutes) Sketching is the act of creating 2-dimensional profile comprised of wireframe geometry. The relations restrict the movement of the entities) State of the sketch (Each sketch has a status that determines whether it is ready to be used or not. Sketches are used for all sketched feature in SolidWorks including: • Extrusions • Revolves • Sweeps • Lofts Process of completing the sketches Starting a New part (It can be created in inch. The state can fully-.

SolidWorks Training (Basic) Sketch Entities/Geometry SolidWorks offers a rich variety of sketch tools for creating profile geometry. Sketch entity Line Toolbar button Geometry example Circle Centerpoint Arc 3 Point Arc Tangent Arc Ellipse Partial Ellipse Parabola Spline Polygon Rectangle Parallelogram Point Centerline 10 .

Color Diagnostic Under constrained 1. 11 . Red Only case 1 and 2 are allowable. For case 3. Black Over constrained (adding any dimension to fully defined would serve to overdefine the sketch) 3. you must fix the error as soon as possible before quitting the sketch mode otherwise a warning message will popout and it will create more problems for yourself.SolidWorks Training (Basic) Status of a sketch The most common color codes are: No. Blue (this is usually appears when first drawn) Case Fully constrained (when more constraints and dimensions are added to the sketch – the sketch become completely defined) 2.

ellipse. Collinear Coradial Two or more lines. The items share the same centerpoint and radius. Two or more lines or two or more arcs. Two lines and one point. Points are aligned horizontally or vertically. Parallel Two or more lines. Two lines or a point and a line. or spline. The line lengths or radii remain equal. lines.SolidWorks Training (Basic) Sketch Relations The following table describes the entities that you can select for a relation and the characteristics of the resulting relation. The entity’s size and location are fixed. An arc. The two points are merged into a single point. or ellipse. The items are parallel to each other. The items lie on the same infinite line. or a point and an arc. The point remains at the midpoint of the line. Fix Merge Points Two sketch points or endpoints. arc. Relation Horizontal or Vertical Entities to select One or more lines or two or more points. Resulting relations The lines become horizontal or vertical (as defined by the current sketch space). Any entity. or ellipses. or ellipse. on a line perpendicular to the centerline. and a line or arc. arcs. The point lies on the line. A line and a plane (or a planar face) in a 3D sketch. Two or more arcs. the endpoints of an arc or elliptical segment are free to move along the underlying full circle or ellipse. The two items remain tangent. However. Two or more arcs. arc. Also. 12 . Tangent Concentric Midpoint Intersection Coincident Equal Symmetric The arcs share the same centerpoint. The items remain equidistant from the centerline. A centerline and two points. A point and a line. The point remains at the intersection of the lines. Perpendicular Two lines. the end points of a fixed line are free to move along the infinite line that underlies it. The line is parallel to the selected plane. The two items are perpendicular to each other.

on the Sketch toolbar click Add Relation You can view all relations in your sketches by select View – Sketch Relations 13 . For an instance: The line is in Horizontal The line is in vertical The lines are in horizontal and have equal length Where to find it • Select the sketch entity or entities. it will remain horizontal unless the relation is removed. Once the line is drawn horizontally.SolidWorks Training (Basic) A line may be constrained vertically or horizontally. right click the entity or entities. and select the appropriate relation from the Add Relations section of the PropertyManager • • • Or. and select Add Relation from the short-cut menu Or. The line can be repositioned and resized but must remain horizontal. Relations. Add… Or. click Tools.

4. 3.SolidWorks Training (Basic) What are we going to sketch? How to start? 1. Click OK. Select the type of new file (Part. Open a new Sketch. Sketch active. Select New from the File menu. This will show all three default planes for selection in a trimetric orientation. Open the sketch by either clicking or choosing Sketch from the Insert menu. Assembly. or Drawing) from the New SolidWorks Document window. 6. Plane can be resized by dragging these handles The Origin Point 14 . The plane will highlight and rotate. Open SolidWorks 2007. choose the Front Plane. 2. The selected Front Plane rotates so it is parallel to the screen. 5. From the screen. or click on the New icon on the Standard toolbar.

Select Save from the File menu. Always bear in mind to save regularly and often. or click Save icon on the Standard toolbar. Saving your Work. It is a good habit to save your work right way. Sketch lines Click the Line tool 1 2 3 4 5 6 8.SolidWorks Training (Basic) 7. 15 .

select Dimensions. Add additional linear dimensions to the sketch as shown. 16 .SolidWorks Training (Basic) 9. 10. Smart Or Right click. select Smart Dimension Or Dimensions/Relations toolbar. pick Smart Dimension tool. Angular dimension. Where to find it? • • • Tools menu. create the angular dimension shown and set the value to 125°. Using the dimension tool. Linear dimensions.

SolidWorks Training (Basic) 11. Fillets. Click Sketch Fillet and set the Radius to 10 mm. Select all of the endpoints in the sketch. Click OK.

Sketch Fillets are used to round off sharp corners in a sketch. Where to find it? • Tools menu, select Sketch Tools, Fillet. • Or Sketch toolbar, click Sketch Fillet

12. Extrude menu. Click Insert, Boss/Base, Extrude or the to access the command tool on the Features toolbar

The depth is 10 mm.

17

SolidWorks Training (Basic) 13. Edit the sketch

Right click on Extrude, and select Edit Sketch

a. Change the value of angular dimension

Double click on 125° and modify to 110°. You’ll see that other dimensions remain unchanged.

18

SolidWorks Training (Basic) b. Length of the base

Double click on 100 mm and modify to 90 mm

Click here to Exit Sketch and update your part.

Modified part

19

5. Sketch a circle centered at the origin. Click Sketch from the toolbar. Right click Top Plane from the FeatureManager design tree. 4. Extrude to 8 mm depth. 3. 6. Parameters This box allows you to define the number of sides. Sketch a Polygon centered to the origin larger than the circle.1: Sketch a Simple Nut with Circle and Polygon 1. Circumscribed circle Inscribed circle 20 . Give dimension as illustrated. Click Tools – Sketch Entities – Polygon from the Menu bar. We can create equilateral polygons with any number of sides from 3 to 40. Create a New part in SolidWorks. This will be a Sketch plane. Click Circle from the Sketch toolbar. 2.SolidWorks Training (Basic) Tutorial 1. Other parameters will automatically update when this parameter is modified.

You will learn this through Module 4 21 .SolidWorks Training (Basic) Tutorial 1.2: Using 3D sketch 1 Select 3D sketch and start sketching 2 You can change the plane sketch by pressing the Tab key 3 4 5 6 Apply Fillet with the radius is 10 mm Sweep function.

3: Sketch part using Lines. Tangent Arc and apply Add Relations between Sketch Entities 1 2 3 4 Select these two arcs to make tangent 5 6 7 8 Select Tangent as relations Symbol of tangent as relations between these two arcs Add dimensions as illustrated Extrude to 80 mm depth 22 . 3 Point Arc.SolidWorks Training (Basic) Tutorial 1.

Exercise 1. 23 . Extrude the sketch 30 mm in depth.1: Sketching Horizontal and Vertical Lines (15 minutes) Create this sketch on the Front Plane using lines.2: Sketching Lines (5 minutes) Create this sketch on the Front Plane using lines. automatic relations and dimensions. Save and close the part. Fully define the sketch. automatic relations and dimensions. Extrude the sketch 30 mm in depth. Save and close the part.SolidWorks Training (Basic) Exercise 1.

SolidWorks Training (Basic) Exercise 1. automatic relations and dimensions. Exercise 1.3: Sketching using Rectangle and Circle (5 minutes) Create this sketch on the Front Plane using rectangle and circle.4: Sketching a Chair Frame using 3D sketch (5 minutes) Create this sketch using 3D sketch (free dimension) The completed figure used Swept feature that you will learn in Module 4 24 .

o Mirror – able to mirror existing sketch entities. Dimensions and edit the sketch. and selected model edges by a specified distance. On the completion of this module. you will be able to: • Apply other Sketch Entities: o Rectangle o Centerline o Ellipse Understand and utilize the available tools from the Sketch toolbar to create and modify the sketch: o Trim – able to trim the selected entities. Sketch Relations. Here. you will learn more about Sketch toolbar. o Linear Pattern – able to create a linear pattern along one or both axes.SolidWorks Training (Basic) Module 2: Additional Sketching (2 hours) This module is an extension of the previous module. o Offset – able to offset one or more sketch entities. o Circular Pattern – able to create a circular pattern along one or both axes Apply Sketch Relations between sketch entities o Midpoint o Horizontal o Coincident o Tangent Edit the sketch o Edit Linear Pattern o Change the sketch plane • • • 25 .

4. Click Centerline toolbar. 26 . Select both Centerline and Origin Point (press Ctrl key while selecting) and choose Midpoint as their relations.SolidWorks Training (Basic) Tutorial 2. Open a New sketch and Save As Flat Bar Click Sketch from the toolbar. 2. Click Rectangle from the Sketch toolbar. 3. 5.1: Creating a Flat Bar (20 minutes) 1. from the Sketch 6. Select the Front Plane.

10. from the Sketch toolbar. Click Tangent Arc 11.SolidWorks Training (Basic) 7. 27 . Give dimension to the bar. Select Trim to closest from the Trim Options 9. Click Trim Entities from the Sketch toolbar 8. Select the right and left vertical lines to remove.

SolidWorks Training (Basic)

12. Click Circle

from the Sketch toolbar with the diameter is 20 mm at the

left end of the bar.

13. Click Linear Pattern menus.

from Tools – Sketch Tools drop down

14. Extrude the bar to 10 mm depth.

28

SolidWorks Training (Basic)

15. Save the part.

16. Editing a. Reduce the number of holes to 5 Right click on Extrude and select Edit Sketch ii. Select one of the Circle and right click and choose Edit Linear Pattern i.

iii. Change the number of holes from 9 to 5 and the distance between each holes to 50 mm

iv. Select OK and Exit Sketch.

29

SolidWorks Training (Basic)

b. Change the Sketch Plane i. Expand the Extrude. Right click on Sketch and select Edit Sketch Plane.

ii. You will see shows the Front Plane, which denotes your previous sketch plane.

iii. Expand this button iv. Select Top Plane.

v. Click OK and you will see that the sketch plane is now changed to Top Plane.

30

Connect these circles with 3 Point Arc.2: (20 minutes) 1. Select the Front Plane. Sketch two Circles with different diameters as shown in figure below. Tangent between arc and circle Coincident Horizontal 31 . Sketch horizontal and vertical Centerlines. 6. 4. 3. We can see all relations between the sketch entities. Open a new sketch. 2.SolidWorks Training (Basic) Tutorial 2. 5. Click Sketch from the toolbar.

8. Select Ellipse from the sketch toolbar and complete all dimensions as shown in figure below. Next.SolidWorks Training (Basic) 7. 9. 32 . Select Mirror from the sketch toolbar and mirror the entity with respect to the vertical Centerline. Mirror with the horizontal Centerline. 10. Trim the sketch as shown in figure below.

Select the Front Plane. Create a Circle with 50 mm in diameter. 2. 6. Tutorial 2. 33 .3: (15 minutes) 1. 4. Extrude to 10 mm depth and save the part.SolidWorks Training (Basic) 11. 5. Create another Circle by using Offset Type 7 mm as distance parameter outside the first Circle. Open a new sketch. 3. Click Sketch from the toolbar.

Select the lines and insert 8 as your number of pattern instances. Then Trim the lines carefully until you get as similar as in figure below. 34 . Extrude to 10 mm and save your part. Trimming 8.15 mm from the vertical Centerline and Mirror about the Centerline. you may Undo the step. If you pick a wrong line.SolidWorks Training (Basic) 7. 10. 9. Select Tools – Sketch Tools – Circular Pattern . Trim the lines 11. Sketch one Line which 6.

SolidWorks Training (Basic) Exercise 2.1: (20 minutes) (a) (b) Special cam (Unit is in inch) 35 .

SolidWorks Training (Basic) (c) Shift Lever Exercise 2.2: Create a solid model of this 2 mm thick steel bicycle disk rotor. (25 minutes) 36 .

Simple Hole and Hole Wizard features. Find the mass of your part and Edit or manipulate features geometry to reduce or increase the mass properties of the component. 6. 3. Sketch at any planes. Chamfer.SolidWorks Training (Basic) Module 3: Basic Part Modeling (2 hours) This module provides an understanding of creating Extruded. These are the samples of Features toolbar: Boss/Base and Cut Features Pattern/mirror Some of the icons (which are not circled) will be seen during Module 4 – Additional Part Modeling. 37 . you will be able to: 1. 5. Create fillet and chamfer at the selected edges. Create standard holes by applying the Hole Wizard. 4. On the completion of this module. Utilize extruded boss and extruded cut. 2. Fillet.

2.SolidWorks Training (Basic) Sketching and Creating Bosses (45 minutes) 1. Select the Top Plane. Open a new sketch. Click Sketch from the toolbar. Add dimensions to the sketch. 3. Coincident with the origin 38 . Extrude 10 mm upwards. 4. Sketch as shown in figure below. Equal length 5.

SolidWorks Training (Basic) 6. Create a new sketch using Insert. Sketch as shown in figure below. lnsert new sketch. Sketch or by clicking the Sketch tool. Select this side/plane 7. Coincident with the origin 39 .

SolidWorks Training (Basic) 8. 9. Add dimensions. 40 . Extrude to 10 mm depth and in reverse direction.

SolidWorks Training (Basic) Creating a Counterbore Hole 10. Select the face indicated and Insert – Features – Hole – Wizard… Select this face 41 . Hole position.

Drop the point onto the center point.5 Size: M8 Fit: Normal End Condition: Through All 12. 42 . Set the properties of the hole as follows: Standard: Ansi Metric Screw Type: Hex Bolt – ANSI B18. Turn to Hole Position. 13. Choose Counterbore.SolidWorks Training (Basic) 11.2.3.

Select the left vertical sketch line and the vertical model edge. Start a sketch on this large face and add a rectangle Coincident with the bottom model edge. (Hold down the Ctrl key and then select the objects) Repeat the process on the opposite side. Press the spacebar and double-click *Front. Completed Hole. 16. Cut Feature 15. Click Finish to complete the hole feature. 43 . Add a Colinear relation between them.SolidWorks Training (Basic) 14.

18. Extrude. Through All Cut. Or pick Extruded Cut on the Features toolbar. Click Insert. Cut. Choose Through All and click OK 44 .SolidWorks Training (Basic) 17. Add a dimension.

20. Set Dimensions add relation so that these points are aligned horizontally. 22. Hole. Change the view orientation. Press the spacebar and double-click *Top.SolidWorks Training (Basic) Holes 19. 45 . Click the Hole tab and set the properties of the hole as follows: Standard: Ansi Metric Screw Type: Drill sizes Size: ∅12.5 End Condition: Through All 21. Turn to Hole Position and locate the holes.

lnsert Fillet.SolidWorks Training (Basic) 23. Return to Isometric. Filleting 24. Set a radius = 10 mm 46 .

Add fillets at selected edges and face. Selected edges and face Chamfering 26. 47 . and using Full preview. Add chamfer to the holes.SolidWorks Training (Basic) 25.5 mm. radius 2.

48 .SolidWorks Training (Basic) 27. How to define material and check its mass properties Right click on Material and select Edit Material 29. Define Material and Mass Properties 28. Save the part. Choose Copper and its Alloys and select Brass.

49 . Mass of the part can be reduced by modified the thickness of the features.04 g) Editing features 31. Drop down menus. Tools – Mass Properties… Mass of the part (474. 32.SolidWorks Training (Basic) 30. Right click on Extrude and select Edit Feature.

Click OK. 36.SolidWorks Training (Basic) 33. 34. the mass is 326.09 g which means more than 30 % of mass has been reduced.50 mm from the bottom face. 35. The Cut Feature is still maintaining the dimension to be 2. Change the depth from 10 mm to 5 mm. Now. Check the current mass of the part. 50 .

4 x M20 Drilled Hole 10 R20 fillet Exercise 3. Sketch and extrude profiles to create the part. CBore M14 Hex Head Bolt 51 .1: Glass Plate (15 minutes) Create this part using the information and dimensions provided. Sketch and extrude profiles to create the part.SolidWorks Training (Basic) Exercise 3.2: Bracket (15 minutes) Create this part using the information and dimensions provided.

SolidWorks Training (Basic) Create this part using the information and dimensions provided. 52 .4: Gland (15 minutes) Create this part using the information and dimensions provided.3: Exercise 3. (10 minutes) Exercise 3. Sketch and extrude profiles to create the part. Sketch and extrude profiles to create the part.

SolidWorks Training (Basic) Start sketching Give dimensions Mirror the sketch with vertical axis Trimming Mirror Extrude 10 mm Sketch small circle and mirror for another circle Complete part Sketch circle with 70 mm diameter and extrude 10 mm Sketch another circle with 48 mm diameter and extrude cut 15 mm 53 .

a strong. The type of tee shown here is used to join pipes with solvent welding. permanent joint is created. The sockets are tapered slightly to allow for a tight fit with the pipe. and the pipe is then forced into the socket.50 degrees Set the material to PVC Rigid (density=1300kg/m3) and find the mass of the tee. A chemical is applied to the inside of the socket.SolidWorks Training (Basic) Exercise 3. The solvent softens the plastic. Sockets are to be tapered 0. and when the solvent dries.63 g) 54 . (Answer: Weight =70.5: PVC Tee Pipe (30 minutes) Create a solid model of this plastic pipe tee. A tee is used to connect pipes together.

Below are examples of products that applied these types of features. Patterning. Lofted. Swept. 55 . Rib and Shell features in SolidWorks.SolidWorks Training (Basic) Module 4: Additional Part Modeling This module provides a comprehensive understanding on additional modeling techniques such as: Revolved.

SolidWorks Training (Basic) Revolved features Revolved Boss/Base – material added by rotating the profiles about a centerline Revolved Cut – material removed by rotating the sketch The Revolve parameters box provides the ability to select: Axis of Revolution Revolve Type • One-Direction • Mid-Plane • Two-Direction Angle It controls the revolve thickness Allow a small gap between rectangle and the centerline to create a hollow cylinder Centerline One of the lines is collinear with the centerline to make a solid cylinder 56 .

Exit the sketch and select Revolve from Features toolbar. Select the Centerline as the Axis of Revolution. It rotates clockwise 57 .1: 1. Draw a Centerline across the Origin 2. Using Line.SolidWorks Training (Basic) Tutorial 4. sketch as follows (free dimension) 3.

6.e. 58 . 180°. The direction of rotation and its angle can be changed. Click OK. To edit the feature. Click here to change the rotation to counter clockwise 5.SolidWorks Training (Basic) 4. i. Right click Revolve and select Edit Feature.

Change the angle of revolution to 360°. 8. 9. We will make holes on the selected face. The line will turn to construction line. Sketch a Circle and tick For construction box. 59 .SolidWorks Training (Basic) 7.

12. Extrude Cut. 11. Through All. The axis will be used as axis of rotation.SolidWorks Training (Basic) 10. 60 . Sketch a small Circle and coincident with the construction line. The hole will be copied around the face by using Circular Pattern. Click View – Temporary Axes.

SolidWorks Training (Basic) 13. Select Circular Pattern from Features toolbar. 14. 61 . The completed part. Number of holes are 6.

and the alignment method. then specify the direction. a fill pattern. or Add or retrieve previously created X-Y coordinates to populate a seed feature on the face of the model. Typical uses include: • Weight reduction • Ventilation holes Select where to populate a seed feature by sketching points on model face. You may find them at Insert – Pattern/Mirror. the curve method. or use sketch points or table coordinates to create the pattern. Select the features and an edge or sketch segment on which to pattern the feature. Circular pattern Curve driven pattern Fill pattern Sketch points or Table coordinates to create the pattern But remember. the linear spacing. Select the features and an edge or axis as the center of rotation. There are other pattern tools that are available in SolidWorks. You can create a linear pattern. Fill a defined region with a pattern of features or a predefined cut shape. a curve driven pattern.SolidWorks Training (Basic) Patterning In Module 2. and the total number of instances. a circular pattern. and then specify the total number of instances and the angular spacing between instances. Linear pattern Select the features. 62 . you have learnt the sketch pattern such as linear and circular pattern. the commands are only enable when you have multi body parts. Then you can specify the type of curve. Pattern repeats the selected features in an array based on a seed feature.

2: Vary Sketch option 1 2 3 4 Sketch as illustrated (some of the entities are free dimension) 5 Extrude the sketch 6 Sketch a slot on top of 3D part and give dimensions Hint: 8 mm at both sides will control the distance between the arcs and the plate edges. Extrude cut the slot 7 Apply Linear Pattern and enable Vary Sketch option Apply Circular Pattern Complete component 63 .SolidWorks Training (Basic) Tutorial 4.

1: Curve Driven Pattern 1 2 4 3 Offset 5 mm Sketch as illustrated using Spline (free dimension) Extrude to 10 mm Sketch a Circle with diameter 3 mm on top of spline face 6 7 8 5 Select the Circle and add relations with the Offset line to be coincident Extrude Cut the Circle Select the Extruded Cut feature and go to Insert-Pattern/Mirror-Curve Driven Pattern Select the Offset Spline as the direction Spacing and Instances: 20 64 .SolidWorks Training (Basic) Exercises 4.

Sample of applications: Keep Normal Constant – the section remains parallel to the beginning section at all times. Power cord Spiral coil 65 .SolidWorks Training (Basic) Swept Swept Boss/Base – material added by sweeping a profile along the path Cut Sweep – material removed by sweeping a profile along the path Follow path – the section remains at the same angle with respect to the path at all times.

SolidWorks Training (Basic) Tutorial 4. but you have to modified a bit) Create the path Completed part 66 .3: Creating a Worm Gear Sketch the profile (or the sketch can be taken from Tutorial 2.3.

The Circle will be the Profile and Helix/Spiral is the Path.4: Creating a Spring Click Insert: Curve: Helix/Spiral Sketch a Circle Create a Plane Normal to Curve Completed spring Select Swept. Sketch a Circle with 3.50 mm diameter 67 .SolidWorks Training (Basic) Tutorial 4.

5: Creating a Bottle (with a guide curve) 1 2 3 4 Create a Profile 5 6 7 68 .SolidWorks Training (Basic) Tutorial 4.

or first and last profiles can be points. last. can be contained in a single 3D sketch. A loft can be a base. You create a loft using two or more profiles. including guide curves and profiles. boss. cut. or surface.SolidWorks Training (Basic) Lofted Loft creates a feature by making transitions between profiles. All sketch entities. You can drag to modify/change the location of these blue points (closing point) Sample of application: Chisel 69 . Only the first.

2. View in Isometric.6: Create lofted part with Centerline Parameters 1. One of its end points must coincident with the Origin. 4. 70 . 3. Create Rectangle on Front Plane. Select and sketch 3 Point Arc at other Top Plane.SolidWorks Training (Basic) Tutorial 4. Create a Plane Normal to Curve. You have to select the Arc and Point.

7.SolidWorks Training (Basic) 5. 71 . Sketch another Rectangle on this Plane 6. Select Sketch 1 and Sketch 3 (both Rectangles) as the profiles. Expand the Centerline Parameters and pick the Arc (Sketch 2). Select Loft from Feature toolbar.

2: Chisel 1. Hold Ctrl key and drag Front plane to the left. Set the Distance to 30 mm and Instances: 2 4. 72 . Select Front Plane 2. To create another Plane. 3.SolidWorks Training (Basic) Exercises 4. Create one more plane (Plane3) which 40 mm from Plane2 using the same method.

7. which its radius is coincident with the vertex of the square. Select Plane1 and sketch a Circle. 8. 6. Select and Copy larger Circle and Paste on Plane3. 73 . Select Plane2 and sketch another Circle.SolidWorks Training (Basic) 5. 9. Exit sketch. 10. Exit the sketch. Select Front Plane and sketch a square. Exit sketch.

Select sketches. Create one plane 200 mm at the back of Front Plane. 13. Click Features – Lofted Boss/Base 12.SolidWorks Training (Basic) 11. 74 . You have to make sure that all the selected points are at the same corner.

Complete the model. Pick the point at the right bottom of square and rectangle. Click Features – Lofted Boss/Base. 75 . 16. Select Plane4 that you have just created and sketch a Rectangle as illustrated below.SolidWorks Training (Basic) 14. Save the part. 15. Select the profile.

SolidWorks Training (Basic) Rib and Shell Rib is a special type of extruded feature created from open or closed sketched contours. Sketch a Line to use as the rib feature on a plane. You can create a rib using single or multiple sketches. Click Rib on the Features toolbar. and creates thinwalled features on the remaining faces. or click Insert. Rib Rib 1. If you do not select any face on the model. Sketch L shape and extrude the sketch. Click OK Shell tool hollows out a part. 2. creating a closed. It adds material of a specified thickness in a specified direction between the contour and an existing part. You can also shell a model using multiple thicknesses. Rib. 4. 76 . 3. leaves open the faces you select. hollow model. you can shell a solid part. Features.

7: Using Shell to create wall thickness inside the Bottle 1 2 3 4 5 6 77 .SolidWorks Training (Basic) Tutorial 4.

SolidWorks Training (Basic)

Module 5: Assembly Modeling
Stages in the process; • 1. Creating a new assembly New assemblies are created using the same method as new parts

2. Adding the first component Components can be added in several ways. They can be dragged and dropped from an open part window or opened from standard browser.

3. Position of the first component The initial component added to the assembly is automatically fixed as it is added. Others components can be positioned after they are added.

4. Mating components to each other Mates are used to position and orient components with reference to each other. Mates remove degrees of freedom from the components.

78

SolidWorks Training (Basic)

Concentric mate between two cylindrical faces

5. Sub assemblies Assemblies can be created and inserted into the current assembly. They are considered sub-assembly components.

79

SolidWorks Training (Basic) From assemblies, you can: 1. Perform mass properties calculations on entire assemblies and also interference (clashes) detection between parts in assembly,

2.

Create an exploded view of an assembly,

3.

Bill of Materials (BOM) table can be generated from the assembly. Associated balloons can be added to identify the items.

80

SolidWorks Training (Basic) Assembly toolbars • Insert components • Hide/show components • Change suppression state • Edit component • No external references • Mate • Move component Basic assembly mates • Smart fasteners • Exploded view • Explode line sketch • Interference detection • Simulation • Coincident – place two flat surfaces in the same plane • Parallel – define two flat surfaces as parallel • Perpendicular – define two lines or planes as perpendicular to one another • Tangent – define a cylindrical feature as tangent to a line or plane • Concentric – align the centerlines of two cylindrical features • Distance – make two surfaces parallel. with a specified distance between them • Angle – two lines or planes at a preset angle to one another 81 .

the first component inserted into an assembly is fixed (locked) in position. Fixed 3. Now. Create a new assembly 2. Float and Fix components Right click and select Float. the component is ‘floating’.SolidWorks Training (Basic) Sliding Brace Assembly 1. Insert components (Browse the components from Desktop/SolidWorks Basic Training/Module5/Bracket) By default. and can be moved or rotated 82 .

Mate the faces of these two components (Bracket – C Link) and select Coincident Select top Face of C Link 3 1 Coincident 2 Select bottom Face of Bracket 83 .SolidWorks Training (Basic) 4.

SolidWorks Training (Basic) Select these two faces 1 2 Select these two faces 84 .

Moving and rotating the component – U Bolt Select this component to rotate 1 2 3 Rotate the bolt so that its legs are parallel with the holes 85 .SolidWorks Training (Basic) 5.

SolidWorks Training (Basic) 6. Mating components (select U Bolt’s right leg and Bracket’s hole) – choose Concentric 2 1 Concentric 3 86 .

Mate another side Mate another side 87 .SolidWorks Training (Basic) 7.

1 2 Distance 88 .SolidWorks Training (Basic) 8. Select bottom faces of U-Bolt and C Link and constraint their Distance to maintain at 40 mm.

Continue with the other side. 1 11. You will utilize the Design Library and take a standard nut from the library. You have to insert other U-Bolt and C Link and apply mates on respective parts as before.SolidWorks Training (Basic) 9. Save as the nut to Desktop/SolidWorks Basic Training/Module5/nut. 10. 2 Double click the nut 89 .

5. 14. M – Metric.SolidWorks Training (Basic) 12. Insert/copy four nuts. 20 – nut diameter (in mm) 13. Select M20-2. You will be asked to Select a Configuration of the nut size. Mating the nuts 1 90 .

A complete assembly.SolidWorks Training (Basic) 2 3 15. 91 .

9 components 20 mates 92 .SolidWorks Training (Basic) 16.Generate a report of the components and mates in an assembly. Generate an assembly statistics .

Select the nuts (it will be highlighted in cyan color at the design tree). 18. Select the component to be exploded – a triad will appear – place the cursor over the arrow on the triad that represents the direction in which component should be exploded – then drag to the desired distance. Continue to select other parts and follow the sequence. 93 .SolidWorks Training (Basic) Exploding and collapsing the assembly Exploded View . Then drag the triad downward. Exploded step Drag the triad downward 19.It is a view of an assembly where the components have been separated. 17.

SolidWorks Training (Basic) 20. Expand the entries in the ConfigurationManager so that defined Explode Steps will appear 1 2 Exploding Collapsing Creating an explode line sketch 21. Make sure the assembly in its exploded view (not collapsed). 94 .

Select edges 23. Save the assembly. Select edges or faces on components that the explode line will connect between. Repeat for other components.SolidWorks Training (Basic) 22. 95 .

open SolidWorks 2007. • create a custom drawing sheet format. To open a new drawing file. Do not turn on the Display sheet format yet. 4. Select Drawing icon and then OK. 3.SolidWorks Training (Basic) Module 6: Drawing After completion of this module. 96 . we will set a few options before browsing the part file. Click Standard sheet size and select A-Landscape. you will be able to: • make 2-D drawing from a SolidWorks part file. click New icon on the Standard toolbar. You will be asked about the format and size of your drawing layout. Click on the X to close the box. 2. and • use eDrawings to create a drawing file that allows easy file sharing 1.

97 . In the drawing space.Angle of projections 5.SolidWorks Training (Basic) Drawing toolbars In the drawing mode. right-click and select Properties from the menu. Insert standard drawing views . the CommandManager has THREE groups of command: Drawing Sketch Annotation You will use some of the icons along the way.

SolidWorks Training (Basic) 6. select Standard 3 View 8. Do not worry about the scale. it can be changed later. In Drawings CommandManager. Then Browse… 98 . Select Third angle projection. Select Third angle projection Insert Component into Drawing 7.

99 . Enable the Preview to view the part before you open.SolidWorks Training (Basic) 9. Selected part in third angle projection. All other views are aligned with the Front view. 10. Search the Bracket that you have created during Exercise 3.2.2 or go to Desktop/Module3/Exercise 3. When you move/drag the front view up-down or left-right will move the other views. Top view Front view Right view 11.

and in Dimensions tab. click Marked for Drawing Source: Entire model Marked for Drawing 100 . Enlarge the views by change the scale to 1:2 Make the Hidden Lines Visible Adding dimensions to drawing and modifying dimensions 13.SolidWorks Training (Basic) 12. Select Annotation – Model Items.

click this point. To change the arrow direction. Create Section View 15. Select the Section View Tool from the Drawing group. 1 2 Move the cursor over the edge 3 Move the cursor to the downside of the bracket 101 .SolidWorks Training (Basic) 14.

102 . To reverse the arrow direction – double click on the section line 17. A Section View is created.SolidWorks Training (Basic) 16. To break alignment between section view and top view. 18. Delete the Right view. go to Alignment-Break Alignment. right click the section view.

20. but you need to rotate this view first. choose Zoom/Pan/Rotate – Rotate View. Right click the view. Rotate the view to -90°.SolidWorks Training (Basic) 19. 21. Select the section view. and click Centerline Tool from Annotations group then centerlines will be added to the holes 103 . The location of Right view will be replaced by the Section view.

You can also hide the dimension. Press and hold the Shift key and drag the dimension of 45 mm diameter hole from the top view into the Section View Press Shift key and select the Dimension Bring the Dimension to a new location 23. To show the dimension. then click any hidden dimension 104 . Just select the dimension you want to hide. go to View – Hide/Show Annotations. right click and find Hide.SolidWorks Training (Basic) 22.

105 . Begin typing the text as shown in the box that appears. Select Note Tool from the Annotation group 25.SolidWorks Training (Basic) Insert a Note 24.

Right click in the drawing space and select Properties 27. Turn on/enable the box Display sheet format. 106 .SolidWorks Training (Basic) Edit Sheet Format 26.

After this. you will learn how to do some modification to the sheet.SolidWorks Training (Basic) 28. 29. Right click in the drawing area and select Edit Sheet Format. The drawing Sheet Format. 107 .

Symbol plus/minus is inserted by clicking on the Add Symbol Tool under Text Format tab. Press Delete key and then use Trim Entities to trim the lines.SolidWorks Training (Basic) 30. Drag your mouse from left to the right to select all the lines and information that you may not needed. Select Note Tool and type inside the Comments. Trim until you get the drawing table like this. 32. 108 . 31.

Fill up the form as shown.SolidWorks Training (Basic) 33. 34. To modify the scale. type your department and drawing title. you have to go to Sheet Properties and change the Scale 1:2. 109 . The Scale 1:5 is not corrected.

It includes your drawing part and sheet. Right click and select Edit Sheet.SolidWorks Training (Basic) 35. 110 . 36. You will get back to the other side of drawing.

To bring the view into the drawing layout. Click arrow Next. 111 . click Model View from Drawings.SolidWorks Training (Basic) 37. and arrange the view as figure below. 38. 39. A trimetric view can often be helpful in interpreting a 2D drawing. Select the Trimetric View.

description. quantity. and referenced to the parts list Machining and assembly instructions Example of Assembly Drawing Balloons Parts list (BOM) 112 . etc. catalogue number.SolidWorks Training (Basic) Assembly Drawing Assembly drawings show all the parts and how they go together Dimensioning is not usually required Hidden lines usually omitted 3D CAD packages can generate assembly drawings directly from assembly models Elements of an Assembly Drawing All parts are shown in one drawing • assembled view • sectioned assembly • exploded assembly Parts list or bill of materials (BOMs) • Part ID. Balloons • each part is identified by a numbered balloon.

Click Standard sheet size and select A-Landscape.SolidWorks Training (Basic) Opening drawing template and edit Sheet Format 1. and make sure it is in Third angle projection 113 . Open the assembly file Desktop/SolidWorks Basic Training/Module5/Sliding brace assembly.sldasm”. OK to accept the Drawing Template 3. select the Standard 3 View. In the new drawing window. Uncheck the box 4. Make sure that the assembly is in the ‘collapsed’ configuration 2. Do not turn on the Display sheet format yet.

we will make an exploded view to the drawing. Select the Model View Tool from Drawings group Select Trimetric from the list Trimetric view Adding the Exploded View 6. Next. 1 Right click the Trimetric View and select Properties 2 Enable the box to show in exploded state 114 .SolidWorks Training (Basic) 5.

Creating Bill of Materials (BOMs) 8. Accept the default selections 115 . select Insert: Tables: Bill of Materials 10. From the main menu.SolidWorks Training (Basic) 7. Select any of the drawing views 9. Showing the assembly and exploded drawing.

and select Column Properties 2 Edit the title box to read PART NAME 12. Edit the title box 1 Click on the Part Number cell. 116 . We will add “balloons” with part numbers to the drawing. Select the exploded Trimetric Views. Select the AutoBalloons Tool from the Annotations group of the CommandManager. AutoBalloons 13. 14.SolidWorks Training (Basic) Customizing BOMs 11. Balloons will be added to the view. 15. Click and drag the part numbers to relocate the balloons. but the item numbers in the Bill of Materials are not linked with the components in the drawing. The drawing is almost complete.

Balloon styles Circular – Triangular – Hexagon – Circular split line – Item number Quantity 17. 117 .SolidWorks Training (Basic) 16. Completed assembly drawing.

Click Publish eDrawings 2007 File 3. A pop up window will come out. 2. Click Retry button. Right click at the Main Menu and select eDrawings 2007. 118 . e-drawing file.SolidWorks Training (Basic) Producing an e-drawing file 1. 4.

edrw. To save the file. click Browse.1: In the PropertyManager. 119 . Exercises 6.SolidWorks Training (Basic) 5.sldasm. and then open Desktop\ SolidWorks Basic Training/Module6/motor casing. The type of file is *. go to File-Save As. Do the assembly drawing as shown.

4. (2006). James H. 8. Technical Drawing 12th Edition. ISBN 0-13-142573-0. (2008). David C. Earle (2004).SolidWorks Training (Basic) References 1. McGraw-Hill International Edition. http://www. A Commands Guide for SolidWorks 2008 – The reference edition including more than 200 integrated stand-alone tutorials. Inside SolidWorks 4th Edition. (2002). John Thomas Dygdon and James E. Musto. ISBN-13: 9781-4283-5301-5. ISBN 007-124956-7. Alva Mitchell.solidworks. Howard and Joseph C. ISBN 007-471043-5. (2003). 7. Introduction to Solid Modeling using SolidWorks. McGraw-Hill International Edition. Planchard. 5. Prentice Hall. David Murray. Engineering Design Graphics AutoCAD 2004 11th Edition. ISBN 0-13-178446-3.com/ 9. Henry Cecil Spencer. SolidWorks 2007 Online User’s Guide 120 . 6. Ivan Leroy Hill. SolidWorks 2003 Training Manual. Planchard and Marie P. ISBN 1-4180-2085-0. Pearson Prentice-Hall. Frederick E. William E. Novak. Thompson Delmar Learning. Engineering Drawing 6th Edition. ISBN-10: 1-42835301-1. Giesecke. 2. Albert William Boundy. 3. Thompson Delmar Learning. (2006).

Sign up to vote on this title
UsefulNot useful