%Función 1: Retorna el número del equipo que más goles anotó.

Entero función EquipoConMasGoles(Real: torneo[ ][ ],Entero:filas,columnas) Variables: Enteros: GolesAnotados(1,filas), i,j, MasGoles Inicio Para i←1, filas,1 Para j←1, columnas,1 GolesAnotados(i)←GolesAnotados(i) + torneo(i,j); Fin_para Fin_para MasGoles←0; Para i←1,filas Si GolesAnotados(i)> MasGoles MasGoles←GolesAnotados(i); EMasGoles←i; Fin_si Fin_para Fin_para Devolver (EMasGoles) Fin_funcion % Función 2: Retorna el número del equipo que más goles recibió. Entero función EMasGoleado←EquipoConMasGoleado(Real: torneo[ ][ ],Entero:filas,columnas) Variables: Enteros: GolesRecibidos(1,columnas), i,j, EMasGoleado Inicio Para i←1,columnas,1 Para j←1,filas,1 GolesRecibidos(i)←GolesRecibidos(i) + torneo(j,i); Fin_para Fin_para MASGOLEADO←0; Para i←1,columnas,1 Si GolesRecibidos(i)> MASGOLEADO MASGOLEADO←GolesRecibidos(i); EMasGoleado←i; Fin_si Fin_para Devolver (EMasGoleado) Fin_funcion %función 3: retorna el número del equipo con mejor gol dSierencia Entero función GolDiferencia(Real: torneo[ ][ ],Entero:filas,columnas) Variables: Enteros: GolesDiferencias(1,columnas), i, j, MejorGolDiferencia, diferencia, auxiliar Inicio

MejorGolDiferencia←0; diferencia←0; GolesDiferencias←zeros(1,columnas); Para i←1,filas,1 Para j←i+1,columnas,1 Si i =~ j auxiliar←torneo(i,j)- torneo(j,i); Si auxiliar > 0 Si auxiliar > GolesDSierencias(i) GolesDSierencias(i)←auxiliar; Fin_si si_no Si (auxiliar*-1) > GolesDSierencias(j) GolesDSierencias(j)←auxiliar*-1; Fin_si Fin_si Fin_si Fin_para Fin_para Para i←1:filas Si dSierencia <GolesDSierencias(i) dSierencia←GolesDSierencias(i); MejorGolDSierencia←i; Fin_si Fin_para Devolver(MejorGolDiferencia) Fin_funcion %Función 4←Retorna el promedio de goles anotados por equipo Real función ←PromedioGolesPorEquipo(Real: torneo[ ][ ],Entero:filas,columnas) Variables Entero: GolesAnotados(1,filas),i, j Real: PromedioGoles(1,filas), PromedioGoles Inicio Para i←1,filas, 1 Para j←1,columnas;1 GolesAnotados(i)←GolesAnotados(i) + torneo(i,j); Fin_para Fin_para Para i←1: filas PromedioGoles(i)←GolesAnotados(i)/(filas-1); Fin_para Devolver (PromedioGoles) Fin_funcion

%Procedimiento1: Retorne el equipo que ganó el torneo. Un partido ganado da tres puntos y un empate da un punto.

Procedimiento EquipoConMasPuntos(E:Real: torneo[ ][ ],Entero:filas,columnas; S: Entero: Ganador) Variables Entero:Ganador,PuntosGanador, PuntosEquipos(1,columnas) Inicio Para i←1,filas,1 Para j←i+1,columnas,1 Si i ~← j Si torneo(i,j)> torneo(j,i) PuntosEquipos(i)←PuntosEquipos(i)+3; si_no Si torneo(i,j)←← torneo(j,i) PuntosEquipos(i)←PuntosEquipos(i)+1; PuntosEquipos(j)←PuntosEquipos(j)+1; si_no PuntosEquipos(j)←PuntosEquipos(j)+3; Fin_si Fin_si Fin_si Fin_para Fin_para Para i←1:filas Si PuntosGanador<PuntosEquipos(i) PuntosGanador←PuntosEquipos(i); Ganador←i; Fin_si Fin_para Fin_procedimiento %Algoritmo Principal: Donde se leen los datos entrada y se muestran los resultados de los subprogramas desarrollados Constante Entero:filas←16; columnas←16; Variables Entero: TORNEO(filas,columnas); Escribir('TORNEO DE FUTBOL ') Escribir('Están participando 16 equipos ') Para i←1,filas,1 Escribir('Los goles que anoto el equipo ',i) Para j←1,columnas,1 Si i =~ j Escribir('Al equipo:',j) Leer TORNEO(i,j) si_no TORNEO(i,j)← 0; Fin_si

Fin_para Fin_para EMasGoles←EquipoConMasGoles(TORNEO,filas,columnas); Escribir('El equipo que anoto mas goles fue:',EMasGoles) EMasGoleado←EquipoConMasGoleado(TORNEO,filas,columnas); Escribir('El equipo que recibio mas goles fue:',EMasGoleado) MejorGolDiferencia←GolDiferencia(TORNEO,filas,columnas); Escribir('El mejor gol diferencia es el del equipo :',MejorGolDiferencia) PromedioGoles←PromedioGolesPorEquipo(TORNEO,filas,columnas); Para i←1, filas,1 Escribir('El promedio de goles anotados por el equipo’, ‘i’, es:',,PromedioGoles(i)) Fin_para EquipoConMasPuntos(TORNEO,filas,columnas, Ganador); Escribir('El EQUIPO ganador del torneo es: ',Ganador) Fin