Proceso Algoritmo

Escribir "Ingrese el valor de a:";
Leer a;
Escribir "Ingrese el valor de b:";
Leer b;
Escribir "Ingrese el valor de c:";
Leer c;
x1<-(-b+RC(b*b-4.0*a*c))/2.0/a;
x2<-(-b+RC(b*b-4.0*a*c))/2.0/a;
Escribir "Valor de x1: ", x1;
Escribir "Valor de x2: ", x2;
FinProceso

Formula general en programación C++.
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
16.
17.
18.

#include <iostream.h>
#include <stdlib.h>
#include <math.h>
void main ()
{
int a,b,c;
float x1,x2,raiz;
cout<<"Introduce 'a': "; cin>>a; cout<<"Introduce 'b': "; cin>>b; cout<<"Introduce 'c': ";
cin>>c;
if (a==0) cout<<"Error, divicion entre cero"<<endl;
else
{
raiz=(b*b)-4*(a*c);
if (raiz<0) cout<<"Error, raiz negativa (imaginaria)"<<endl;
else
cout<<"X1: "<<((-1*b)+sqrt(raiz))/(2*a)<<endl<<"X2: "<<((-1*b)-sqrt(raiz))/(2*a)<<endl;
}
system("PAUSE");
}

Sign up to vote on this title
UsefulNot useful