Introduction

Learning Resources

Tips & Tricks

Support Services

DraftSight.com

The Lyons’ Share™
brought to you by

The Lyons’ Share™

brought to you by

WELCOME TO THE

The DraftSight community – more than 1.6 million users and growing.
DraftSight users represent a mix of professionals, educators, and students from a wide range of companies, industries and educational institutions. What DraftSight users share, is the desire to maximize their design skills and the “DraftSight Masters Series” was designed to help them do just that. This Series, brought to you by The Lyons’ Share,™ features a collection of tips, tricks, videos, webinars and more from DraftSight’s training guru, Mark Lyons. It’s a one-of-a-kind instructional resource for designers at every skill level. We hope you’ll find this valuable and encourage you to share it with your colleagues and friends.

Introduction Video

1

DraftSight.com

000 FB fans Learning Resources Tips & Tricks Are you a fan yet? • Available in 12 languages • New features and updates introduced frequently • Offers access to free community support Support Services * Standalone license. (MAC and Linux are currently in Beta) • Affordable Premium services available • Over 1. Windows Vista®.com 2 . Windows® 7 (General Release). DraftSight. view DWG files • Takes less than a few minutes to download • Supports Microsoft® Windows XP®. MAC® and Linux.8 million users • More than 66. DraftSight highlights: • You can create. edit.DraftSight™ Master Series Volume 1 Introduction DraftSight Facts DraftSight is a professional-grade. free* 2D CAD product from Dassault Systèmes. Activation required.

A free resource designed to get you up and running with DraftSight in no time. DraftSight Getting Started Guide ™ Getting Started with DraftSight™ Check out the DraftSight Getting Started Guide.solidworks.com http://www.The Lyons’ Share™ brought to you by Learning Resources The Learning Resources that you’ll discover in this chapter. Outside the U.S.com .: Fax: Email: Web: +1-978-371-5011 +1-978-371-7303 info@solidworks.com/education Download PDF of guide 3 DraftSight. with the exception of the “Getting Started Guide” are video-based and take just a few minutes to view.

Support Services DraftSight.com 4 .DraftSight™ Master Series Volume 1 Introduction User Interface Learning Resources Tips & Tricks Understanding the User Interface is an important element of learning how to use DraftSight. This is an introduction to the design of the product screen. and the communication between the user and DraftSight.

com . This Make Block Tutorial is designed to help you get started creating and inserting blocks in your drawing.The Lyons’ Share™ brought to you by Make Block Tutorial Creating custom blocks is an important feature in DraftSight™. 5 DraftSight.

it’s important to set up your mouse correctly.com 6 .® Support Services DraftSight.DraftSight™ Master Series Volume 1 Introduction Setting up your Mouse on the Mac Learning Resources Tips & Tricks With DraftSight available for the Mac. Watch this Setting up your Mouse for DraftSight on the Mac Tutorial for helpful information when using a Mac.

They can also be useful for users who have difficulties typing commands.The Lyons’ Share™ brought to you by Mouse Gesture The Mouse Gesture is a way of combining pointing device movements and clicks which DraftSight™ recognizes as a specific command. Mouse gestures can provide quick access to common functions of a program.com . 7 DraftSight.

Support Services DraftSight. With DraftSight. you can create your own custom toolbars as a way of increasing your productivity by grouping commonly used commands into one specific tool bar.com 8 .DraftSight™ Master Series Volume 1 Introduction Create Your Own Custom Toolbars Learning Resources Tips & Tricks Customizing your user environment to increase productivity is key for any proficient user.

Learning how to use ETracking and Polar Tracking will save you time.com . 9 DraftSight. and help you be a more productive DraftSight user.The Lyons’ Share™ brought to you by ETracking and Polar Tracking Using the power of DraftSight to assist in geometry creation will enhance your productivity.

Support Services DraftSight. make sure you customize your user environment.DraftSight™ Master Series Volume 1 Introduction The System Setup Tutorial Learning Resources Tips & Tricks Before you start using DraftSight. The System Setup Tutorial will assist you in creating a user friendly work space.com 10 .

The Trapezoid is created as a PolyLine entity.The Lyons’ Share™ brought to you by Trapezoid Command A fresh new command in DraftSight is the Trapezoid Command. A Trapezoid is a four sided figure with one pair of parallel sides. Use the Trapezoid command to draw a 2D conical entity.com . 11 DraftSight.

Support Services DraftSight. Jeremy uses DraftSight to help his productivity. to see how he was able to use 2D legacy data to help create the design of his field of play. DraftSight and Let’s Go Design.DraftSight™ Master Series Volume 1 Introduction DraftSight and Let’s Go Design Learning Resources Tips & Tricks In this episode of Let’s Go Design. Watch this video.com 12 .

DWG file.The Lyons’ Share™ brought to you by 3D ContentCentral Although DraftSight is a 2D product. Most models contained at 3D ContentCentral are available to download as a 2D .com . 13 DraftSight. we invite you to download virtually anything you need for your design layout at 3D ContentCentral.

and rotated linear dimensions. vertical.DraftSight™ Master Series Volume 1 Introduction Linear Dimension Tutorial Learning Resources Tips & Tricks The Linear Dimension Tutorial command creates horizontal. Follow this video and learn more about this function.com 14 . Support Services DraftSight.

Hatching a drawing adds meaning and helps to differentiate the materials and areas. you can apply solid hatches to fill in a bounded area with any color by selecting Fill in the Hatch type dialog. such as construction drawings. 15 DraftSight.The Lyons’ Share™ brought to you by Hatch/Fill Use the Hatch/Fill command to fill enclosed areas or specified entities with a hatch pattern. Some drawing applications. Along with patterns. require hatch patterns which can increase the clarity and legibility of a drawing.com .

The Tool Matrix is a user interface that behaves like other palettes.DraftSight™ Master Series Volume 1 Introduction Tool Matrix Learning Resources Tips & Tricks DraftSight for Windows is now in general release. there are some exciting new features that have been implemented. such as the Properties Palette or the Reference Palette. One such feature is the Tool Matrix.com 16 . Support Services DraftSight. With that.

you need to specify the second point relative to the first one. Once you have located your first point. we often need to locate a point in the Graphics area relative to another point. Use the Relative Command input to do this. The rectangle command is an excellent example.The Lyons’ Share™ brought to you by Relative Command When using DraftSight.com . 17 DraftSight.

com and view your drawings.DraftSight™ Master Series Volume 1 Introduction DraftSight for the Architectural Industry Learning Resources Tips & Tricks With its layering functionality and the ability to specify units as Architectural.com 18 . DraftSight is a great way to provide your customers with professional grade drawings. They can download DraftSight for free at DraftSight. Support Services DraftSight.

Click Format>Layer Tools>Delete or type DeleteLayer at the command prompt. At the command prompt. Then Undo your Move until the object is back in its original position. Find will even locate text within a block and modify the block to include the new text! DELETE LAYER TIP: The DeleteLayer command will delete all entities on a specified layer and remove the layer from the drawing. MATCH LAYER TIP: You can change entities to match a destination Layer. In the graphics area select Entities with layer changes and press Enter. You can choose the layer by specifying an entity or by typing its name.0 as a reference point. Use the Paste command with a reference point of 0. 19 DraftSight. don’t panic. type Find.0 and you’ll have your copy and your original object. To match the Layer of entities to a destination Layer click Format > Layer Tools > Change Entity’s Layer (or type MatchLayer). or select an entity on the destination Layer or specify the Layer Name option and select a Layer in the Choose New Layer dialog box. MOVE INSTEAD OF COPY: What to do if you Move instead of Copy: If you Move an object instead of Copying it. FIND AND REPLACE TIP: Use the Find command to find and replace text in your document. Use the Copy@ command and copy the object using 0.The Lyons’ Share™ brought to you by Tips and Tricks The tips and tricks that you’ll discover in this chapter will take just minutes to review and could have a dramatic impact on your productivity.com . This is a quick way of removing unwanted layers and its associated geometry. you can select the text to be replaced in your document. Using the Find and Replace dialog.

DraftSight™ Master Series Volume 1 Introduction FLIP COMMAND TIP: Use the Flip command to create a mirror copy of entities. Instead they maintain the same relative position to the symmetry axis.or the Y-axis of the coordinate system. Support Services COMMAND WINDOW DISPLAY: Pressing Ctrl + 9 will toggle the command window display on and off. The command contrasts to the Mirror command in that entities do not remain in their original positions when they move across the mirror axis. from the menu. deleting the source entities. DraftSight.com 20 . but not to the clipboard. you can paste the entities into open drawings using the Paste and PasteAsBlock commands. Tips & Tricks Note: The Copy command copies entities in the drawing from a specified base point to target points within the drawing. From the clipboard. select Tools > Options > User Preferences > Drafting Options > Entity Selection > Pre-selected highlighting > uncheck the option of “Between commands”. To Copy the clipboard with a reference point: Click Edit>Copy with Reference Point (or type Copy@) ENTITY PRE-SELECT: To disable “entity” getting highlighted when hovering the cursor over it. To Flip drawing entities type Flip at the command prompt. but flip about the specified mirror axis. You can define the reflection axis freely by specifying two points. Learning Resources COPY@ TIP: Use the Copy@ command to copy selected entities and a reference point from the drawing onto the Windows® clipboard. Use ortho mode to force the mirror line to be parallel to the X. The entities selected with Copy@ remain on the clipboard until you place new entities on the clipboard.

Type SpellCheck at the command prompt. To save all open drawings: • Type SaveAll. The SpellCheck dialog box appears if DraftSight finds a spelling mistake. Change. select the Text entities to check and press <Enter>. SAVE ALL DRAWINGS AT ONCE: Use the SaveAll command to save the drawing in the current window and all other open drawings. When prompted to Specify start point. Ignore All.The Lyons’ Share™ brought to you by MID BETWEEN POINTS OPTION: To draw a center line exactly between two other parallel lines. type L (or line). If necessary. the Save File dialog box opens so you can set the location. • Opened drawings are saved under the location. OPENING AND REPLACING DRAWINGS: The ReplaceOpen and ReplaceNew commands replace the current drawing with a new one. press Shift+Right-mouse click in the graphics area. and file type. In the graphics area. When drawn.com . Repeat method for the other endpoint of line. select the new Line and change its LineStyle to Center or Dashdot. select the Mid between two points option. name. Next. • If a drawing is unnamed. Then. SPELLCHECK TIP: You can check the spelling inside your DraftSight Drawing. select the two endpoints of the original parallel lines. 21 DraftSight. you are prompted to save the drawing being closed. name. Change All and even Look Up a word to find Synonyms. and then display a dialog box for opening another drawing. In effect. You can choose to Ignore. and file type specified when they were opened. these commands close the current drawing.

use GetArea. In the dialog select Block as the source and from the drop down list. For any error detected. Type GETAREA > A >select shapes > press Enter. The Check command is a diagnostic tool for examining the current drawing and correcting errors. select the Block that you want to export.com 22 . it is good practice to perform a Check and Clean. EXPORT DRAWING: Use the ExportDrawing command to create a DWG file from a Block. a description is provided in the command window The Clean command removes unused References from the drawing.dxf file or using a DWG file that you did not create? If you are. Since SVG files are XML-based. click and hold Shift+MMB to start the RollView command. Press and hold the MMB to start the Pan command. use it to zoom in and out and center the zoom at the same time (DraftSight will use your cursor for the center of the zoom). press F2 to launch the text screen. If you can’t see the results in the Command window. many graphics programs support this format. too. And lastly. If you have a wheel mouse. and you need the combined length of the perimeters. You can also export any entities in a drawing to a new DWG file using the ExportDrawing command. too). Tips & Tricks OPTIONAL FORMAT: If you need to bring the contents of a drawing into a graphics program (like Corel® Paint Shop Pro) and you need the image to be scalable. Go to File>Export>Export Drawing. Use the Browse button to select where you want the new DWG file created. Learning Resources MOUSE NAVIGATIONS: Use your mouse to easily navigate around in your drawing. Support Services GET AREA: You can use the GetArea for perimeter information.DraftSight™ Master Series Volume 1 Introduction ERROR CHECK AND CLEAN: Are you opening a . use the Print command to create an SVG (Scalable Vector Graphics). DraftSight. If you have several closed polygonal shapes. Double-click middle-mouse button (MMB) to do a Zoom > Extents (works ViewPoints on Layouts.

deployment. ENTERPRISE EDUCATORS PREMIUM PACK A service for companies that supports software compliance issues. ROI Calculator.The Lyons’ Share™ brought to you by Support Services DraftSight® is more than just a professional-grade. 23 KCAP MOORSSALC See what you can save. Includes: Telephone support Email support Network license Comprehensive curriculum Access to DraftSight APIs and API updates Access to online community support and an abundance of learning resources Options: • • Classroom Pack: 45 Licenses Campus Pack: 200 Licenses See what you can save. KCAP MUIMERP DraftSight.com . it offers added value with affordable fee-based support services for enterprise and education users. ROI Calculator. Includes: Telephone support Email support Network license Access to DraftSight APIs and API updates Access to online community support and an abundance of learning resources CAMPUS/ CLASSROOM PACK DraftSight Premium Pack for education offers significant value. customization and integration. 2D CAD product.

For answers to your specific questions. Learning Resources Free Community Support The online DraftSight™ Community provides easy access to the guidance. Join the free online community. there is an iQuestions forum.DraftSight™ Master Series Volume 1 Introduction How valuable is DraftSight and its support services compared to your current or planned 2D CAD investment? Take just a few minutes to conduct a complimentary ROI analysis that will reveal the significant savings your company can achieve using DraftSight and “Enterprise” services. counsel and support of thousands of CAD users from around the world. Tips & Tricks Support Services DraftSight.com 24 . Their experience and know-how is complemented by a wide array of online training videos. tutorials and instructional materials.

Sign up to vote on this title
UsefulNot useful