Getting started with Abaqus

Problem statement:  Cantilever beam with 10 inches length , 2 inches width and 0.375 inches thickness  Material specification: Young‟s modulus: 30 x 107 pounds/inch2 Poisson‟s ration: 0.3  Loading: Axial compressive load of 1000 pounds at the free end , applied at the centre point. ABAQUS has a GUI version called ABAQUS/CAE. Let us have some basic introduction to ABAQUS/CAE. ABAQUS CAE provides a complete modeling and visualization environment for ABAQUS analysis products. With direct access to CAD models, advanced meshing and visualization, and with an exclusive view towards ABAQUS analysis products, ABAQUS/CAE is the modeling environment of choice for many ABAQUS users. With CAE, you can build complicated models quickly and it gives you a method to import models created by other software packages. Now, we follow a step by step procedure to do an analysis.

1. Launching Abaqus/CAE
a. Log into Hammer using a SSH client b. Create a separate directory with „mkdir‟ command in your home directory for abaqus analysis. c. Change the directory to the new directory d. Type „abaqus cae’ to launch Abaqus/CAE e. When it starts click on Create Model Database. f. If you want to assign a name to your model, then go to main menu: Model > Manager. Click Rename, type 2D Cantilever Beam or something you like and Click Dismiss.

2. Little more on ABAQUS/CAE: Its better we know the general structure of
CAE before we start working with it. So, let us have some Knowledge transfer! a. ABAQUS CAE creates a binary file with a .cae file extension. When viewing your results it uses the .odb and .fil files b. CAE created an input file to run the analysis. c. You can import an input file to CAE to manipulate the model d. In CAE you make parts, and then assemble those parts into a model which is then analyzed.

1

A general look of CAE is as follows: Figure 1. In the Approximate Size text field type 30 or any value that would be appropriate for your FE model size. In the Context bar under Module. b. viii. Click on “Create Part” in the toolbox area. In the Prompt area type (0. Wire for Line. Part – Create individual parts Property – Create and assign material properties. and Base Feature to Shell (Shell for Area. iv. Make sure you set Modeling Space to 2D Planar. v. Creating a model: a. They are as follows: i. Click Create Lines: Rectangle (4 Lines) in the toolbox to draw the cantilever beam. Name the part Beam or something you like. Click Continue to exit the Create Part dialog box. vi. g.View your results 3. iii. Point for Point). select Part if not loaded already. ix. you have different modules here.e. vii.Define and place all loads and boundary conditions Mesh – Define your nodes and elements Job – Submit your job for analysis Visualization. give coordinates for the 2 . To work through these steps you will work with individual modules in CAE. CAE modules: Unless like in ANSYS. 0) and press enter. Type to Deformable. General Look of CAE GUI f. Assembly – Create and place all parts instances Step – Define all analysis steps and the results you want Interaction – Define any contact information Load. Note that the approximate size will not affect your solution. ii.

Click on Independent (mesh on instance) and click OK. Click OK. c. 4. Name the material (say. and Create Instance dialog box appears.3. and forces/reaction.If you made some mistakes in drawing you can click Delete to make changes. BeamLoad) and make sure you define a step of Static. Click the mouse button 2 anywhere in the view port to finish using the rectangle tool. the region takes on the material properties associated with the section. In the context bar under Module. press both mouse buttons simultaneously). Click on Create Section in the toolbox to define a section. For the output we want stresses. Edit Material dialog box appears.375 in the Plane Stress/Strain thickness. select Step. b. Creating a part a. Assembling the Model: Load the Assembly module from the Context bar. strains. Accept the default selection of BeamSection as the section and click OK. Click OK. ABAQUS/CAE changes the color of the entire beam to aqua to indicate the region has a section assignment. Click on the Create Step button in the toolbox. Save your work in regular intervals using the Save button in the main menu bar. you can use the Shift key for multiple selections). Click done in the prompt area after finishing drawing. 3 . Note: Save your model using File > Save/Save As. Steel) and click on Mechanical > Elasticity > Elastic. You will see that a new set of tools appear in the toolbox area. Defining Analysis Steps: In the Context bar under Module. When you assign a section to a region of a part. Click on Assign Section in the toolbox. Set this in Field Output request option of the model tree. Click OK. Leave Type as Isotropic and fill in the value of Young’s Modulus as 30e6 and Poisson’s ratio as 0. e. 2) and press enter. displacements. The Edit Section Assignment Dialog Box appears containing a list of existing sections. Name the new section as you like (say. Name the step (say. Accept the default selection of Steel for the Materials and Type 0. Click Done in the prompt area to accept the selected geometry. Click on Create Material. f. (If you are using a 2button mouse. select Property. Click Continue and accept all the default settings. d. Click anywhere in the beam to select it (Note: If you have to select more than one thing. General. set Category to Solid and Type to Homogenous and click Continue. Click on Instance Part button from the toolbox.other end of the rectangle (10. BeamSection).

Click OK. make sure you set Element Library to Standard. The name for the selected element type is shown in the panel. hourglass control.inp) and will be stored in the working directory. Click on Assign Element Type button in the toolbox. then select your input file. Select another member and repeat this for all members and click Done in the prompt line when finished for all members. Meshing the model and creating an input file a. reduced integration. the Element Type popup window appears. Click off Reduced Integration. Load Mesh from Module in the context bar. Go to File > Import >Model. Then give the values of loads in the X-direction (CF1) as -1000 and click OK.) for this case. Name the load (say. The input file will be created with the given name (say Axial. d.5. axial load). type the number of elements you want in that member and press Enter. set the Step to Initial. Click on Create Boundary Conditions in the toolbox. select Load. b. CPS4 (A 4-node bilinear plane stress quadrilateral. In the Context bar under Module. If you want to have different number of mesh in different members. Click on the appropriate node for applying the load and click Done in the prompt line. Applying Boundary conditions: a. then click Continue. You will see meshed part you created in the last section. Category to Mechanical and Types for Selected Step to Displacement/Rotation. Close the model. press Enter and click Done. Click Yes on the prompt line. c. To define load. Save your work. Geometric Order to Linear (cf. Make sure you set the Category to Mechanical and Types for Selected Load to Concentrated Force before hitting Continue. Save your work! 4 . 6. e. Click on the nodes on the edge where you want (the left end) to apply the boundary condition to select it. b. Click on Mesh Part Instance button from the toolbox. Linear for CPS4 and Quadratic for CPS8) and select Plane Stress in Family. select Seed > Edge by Number. Give a name to the BC set (say Fixed). d. type 1 in the prompt line. press Done. select BeamLoad in Step. From the main menu bar at top. Click on Job and then write input file option to create an input file of the model. Click somewhere inside the beam. click on the Create Load button in the toolbox. the selected part will appear red after selection and click done on the prompt line. all members will be selected. select one member at a time. Then select Encastre in the pop-up window and click OK. c.

Load the Job module. you will see something similar to this: Similarly. b. To display the node numbers. go to the page tabbed Labels. selecting Displacement in X direction gives a plot as shown here: 5 . If you select S11 (from Stress components). Load the Visualization module.7. if any. click on Show Node Labels. Click on Plot Deformed Shape in the toolbox area see the deformed shape. c. You can load different plots by selecting Field output in Results Menu section. click on Superimpose Undeformed plot. go to the main menu click Options > Deformed Shape. Click on the Job Manager Button in the toolbox.odb. go to the page tabbed Basics. go to the main menu click Options > Deformed Shape. Viewing the results of Analysis a. Check for Errors. Click File > Open in the main menu bar and select Axial. then click Dismiss. To plot both the deformed and undeformed shapes. b. Submitting the job a. Click on Submit in the Job Manager and wait until the Status appears Completed. There are other visualization tools in the toolbox. 8. play with them to see different results.

edu 224G Computer Building Research Computing and Cyberinfrastructure Pennsylvania State University. make sure that no output databases are active. name the report (say. set Position to Unique Nodal. Click on the black arrow next to U: Spatial displacement to expand and select U1 and U2 from the list of available variables. Open the Axial.d. notepad. In the Variable tabbed page. Click Apply. University Park PA 16802 Please contact beatnic@aset.rpt file from the location where your ABAQUS Job Files are saved (Check your command line at the bottom of screen to see where your report files are saved) in any text editor like MSWord. In the Setup tabbed page. etc. Click Apply. f. Quitting ABAQUS/CAE When you quit from CAE. click the box next to S: Stress components to remove it from selection.edu if you have any comments/suggestions to this report. Axial . 6 . . The nodal displacements are appended to the report file. In the Variable tabbed page.psu. click on the variables you want in your output file like S11. etc. Click the black arrow next to S: Stress components to see the list of available variables. S12.rpt). Report Field Output. For tabular data reports from the main menu bar select Report > Field Output. e. Then. From the utility menu select File > close ODB. S22. File > Quit Prepared by: Vikas Argod vikasargod@psu.