Preparado por: Prof. Wellington D.

Guimarães - CEFETES

9. Aplicações em redes de sistemas viários
A modelagem do sistema viário de uma cidade permite o desenvolvimento de diversas aplicações úteis ao planejamento urbano. Nesta aula prática, utilizaremos a malha viária do Bairro Jardim da Penha já devidamente estruturada e veremos alguns exemplos de aplicação. A extensão Network Analyst é necessária para executar os procedimentos descritos a seguir. Na próxima aula prática será visto como estruturar o banco de dados. Iniciaremos com o exemplo de otimização no traçado de rotas, ou seja, definição de rotas de custo mínimo. Elas auxiliam o gestor urbano no planejamento de itinerários para:
➢ ➢ ➢ ➢ ➢

coleta de lixo; rega de praças, jardins e canteiros centrais; deslocamento de ambulâncias, viaturas policiais e carros do corpo de bombeiros; aplicação de dedetização (fumacês, por exemplo); e entrega de correspondênicas, entre outras. Enfim, qualquer atividade que envolva o deslocamento de veículos ou pessoas pela malha

viária existente pode se beneficiar da otimização de rotas. A seguir, calcularemos as áreas de influência para os pontos de ônibus desse bairro. Elas são importantes para avaliar a acessibilidade dos usuários do sistema de transporte público aos pontos de ônibus. De uma forma abrangente, ela pode ser entendida como uma medida do esforço para se transpor uma separação espacial caracterizada pelas oportunidades apresentadas ao indivíduo ou grupo de indivíduos, para que possam exercer suas atividades por meio do sistema de transporte. A acessibilidade está associada à facilidade de chegar ao local de embarque no transporte coletivo e de sair do local de desembarque e alcançar o destino final da viagem (FERRAZ & TORRES, 2004). E para finalizar, encontraremos o ponto de ônibus mais próximo para um pedestre. Este recurso pode ser extrapolado para diversas outras situações, como alocar ambulâncias, viaturas do corpo de bombeiros ou viaturas policiais para atender a um chamado.

9.1 Objetivos
➢ ➢ ➢

traçar rotas de menor percurso; calcular a acessibilidade a pontos de ônibus; encontrar os pontos de ônibus mais próximos ao usuário.

147

9.2 Dados Necessários
Os dados necessários para esse exercício encontram-se em ...\Prat9\Dados. Os arquivos (mapas e suas tabelas de atributos) a serem utilizados estão descritos no quadro abaixo. O Datum horizontal é o SAD69. O sistema de projeção é UTM, com meridiano central de 39°W (zona 24). Para os exemplos apresentados nesta prática, os planos de informação foram previamente configurados e organizados no network dataset eixo_logradouro_ND.nd. Plano de Informação Limite-jpenha Quadra Ponto-onibus Eixo-logradouro Conversoes_Proibidas Formato shapefile Limites das quadras shapefile Pontos de ônibus shapefile Eixos de logradouro shapefile Conversões proíbidas Descrição

shapefile Limite do bairro Jardim da Penha

9.3 Procedimentos
Inicie o ArcMap e abra o mapa Prática9_Rotas.mxd, diretório ...\Prat9. O data frame Bairro Jardim da Penha possui apenas os layers limitejpenha e Eixo_logradouro_ND. Este último modela o comportamento do sistema viário do bairro em relação a sentidos proibidas, de tráfego conforme e conversões convenções localizado no

indicadas na Figura 98. Utilize os recursos de visualização para explorar os dados. Observe que a seta azul indica o sentido proibido de conversão. Ou seja, para um veículo que está na rua Carlos Eduardo Monteiro de Lemos e se desloca em direção a Dante Michelini,
Figura 98: Convenções gráficas.

não é permitido virar à esquerda. Ruas 148

Altere seu nome para Rota1. O menu Network Analyst da barra de ferramentas mostra os recursos de processamento desta extensão (Figura 99). Figura 99: Barra de ferramentas do Network Analyst. excluir. modificar a ordem de passagem. Certifique-se de que a opção Stops(0) esteja selecionada na janela Network Analyst window. barreiras.1 Otimização de rotas Clique no menu Network Analyst e selecione a opção New Route. Barriers e Routes. Acople-a junto com a tabela de conteúdo para que não ocupe muito espaço na tela. Figura 100: Layers para os pontos de parada. ) no lugar da bola preta para indicar o sentido de tráfego que Uma vez que as convenções foram entendidas. 149 . No menu View / Bookmarks. etc).3. selecione Cruzamento 1. 9. que empacota (agrupa) os layers Stops. clique no botão Show/Hide Network Analyst window . Esta caixa de diálogo serve para gerenciar os pontos de parada (importar. Na barra de ferramentas Network Analyst.de mão única têm uma seta preta ( é permitido. conforme indica a Figura 100. rotas e marcar as configurações que deverão ser observadas no momento do processamento. barreiras e rotas calculadas. Abra a barra de ferramentas Network Analyst. Será acrescentado ao data frame um layer chamado Route. carregue a extensão Network Analyst (menu Tools / Extensions) para utilizarmos seus recursos. Será aberta uma janela com este nome (Figura 101).

Marque dois pontos conforme indica a Figura 102. valores default. mantendo a mesma ordem. como carteiros. os pontos criados também deverão ser acrescentados no item Stops da janela Network Analyst window. a rota de custo mínimo significa aquela de menor distância. Na janela Network Analyst window. rua e pedestres. Uma situação assim poderia ser aplicada. mantenha os Impedance: Meters (Meters) Allow U-Turns: Nowhere Restrictions: mantenha as caixas de verificação Conv_Proibidas e Oneway desmarcadas Distance Units: Meters Open Directions window automatically: marcado O campo Impedance indica ao software qual é o campo da tabela de atributos que armazena os custos associados a cada arco da rede. Para aqueles que não forem informados. Mude o nome do ponto 1 para Início e do ponto 2 para Fim. O nome padrão é Graphic Pick X. selecione o comando Route1 Properties . varredores de Analyst window. Será aberta a caixa de diálogo Layer Properties (Figura 103). para quem faz o deslocamento a pé. selecione o comando Create Network Location Tool . por exemplo. No caso deste exercício.Na barra de ferramentas Network Analyst. No campo Restrictions. 150 . onde X indica o número do ponto. o software não levará em conta no processamento as conversões proibidas (Conv_Proibidas) e os sentidos de tráfego (Oneway). Figura 102: Indicação dos pontos de partida (1) e de chegada (2). como mantivemos as duas caixas de verificação desmarcadas. Selecione a aba Analysis Settings e Figura 101: Janela Network configure os parâmetros conforme descrito abaixo e clique no botão OK. Além de aparecer sobre os eixos de logradouro.

Figura 103: Configurações para cálculo da rota. 151 . Também deverá ser aberta a caixa de diálogo Directions (Rota1) . aparece uma listagem com o itinerário que deverá ser seguido.Figura 104. Nela. Após as configurações. o passo seguinte é o cálculo da rota. selecione o comando Solve e observe o resultado do cálculo. Figura 104: Itinerário da rota. Na barra de ferramentas Network Analyst. com as parciais de cada trecho e a distância total a ser percorrida. que deve ser semelhante ao da Figura 105.

mxd. 152 e observe o . Clique com o botão direito do mouse sobre Stops(0) e selecione Load Locations no menu popup. mantenha os valores default. Na barra de ferramentas Network Analyst. certifique-se de Rota2 é o layer selecionado no combobox. Na janela Network Analyst window. clique no combo-box Load From. Utilizaremos os mesmos pontos de partida e de chegada. selecione o comando Rota2 Properties descrito abaixo. Impedance: Meters (Meters) Allow U-Turns: Nowhere Restrictions: marque as caixas de verificação Conv_Proibidas e Oneway Distance Units: Meters Open Directions window automatically: marcado Na barra de ferramentas Network Analyst. Observe que o layer Rota2 também foi acrescentado ao Network Analyst window. Na caixa de diálogo Layer Properties. o comando Export Data deverá ser utilizado para gerar um shapefile com a rota que foi criada. mas agora observando as conversões proibidas e os sentidos de tráfego. Na janela Network Analyst window. que deve ser semelhante ao da Figura 106. Altere seu nome para Rota2. Vamos criar outra rota. clique no menu Network Analyst e selecione a opção New Route. Abra a tabela de atributos do layer Routes. Na caixa de diálogo Load Locations. Dependendo da situação. Um layer novo chamado Route será acrescentado ao data frame. selecione a aba Analysis Settings e configure os parâmetros conforme . Figura 105: Resultado do processamento. Observe que ele existe apenas dentro do arquivo . Desligue o plano de informação Rota1 no data frame. Para aqueles que não forem informados. selecione Rota1/Stops e no botão OK.Repare também o que aconteceu no layer Rota1 (layer Routes)do data frame e da janela Network Analyst window. selecione o comando Solve resultado do cálculo.

Compare as distâncias entre as duas rotas. 153 . Acrescente mais de dois pontos. Figura 106: Rota. Crie outras rotas. que considera os sentidos de tráfego e as conversões proibidas. Figura 107: Itinerário da segunda rota. Agora é por sua conta.Também foi gerado o itinerário para a segunda rota. Avalie os parâmetros Reorder Stops To Find Optimal Route e Allow U-Turns.

Na janela Network Analyst window.mxd. No nosso caso serão os pontos de ônibus. Na janela Network Analyst window. Adicione o plano de informação ponto-onibus ao data frame. mantenha os valores default.3. comando Áreas de Influência Properties . Impedance: Meters (Meters) Defalult Breaks: 0 300 500 Allow U-Turns: Nowhere Restrictions: mantenha as caixas de verificação Conv_Proibidas e Oneway desmarcadas Direction: Away From Facilities 154 . certifique-se de que Áreas de Influência é o layer selecionado no combobox. Na caixa de diálogo Load Locations. na qual se consideram faixas de distâncias em relação aos pontos de ônibus. que empacota (agrupa) os layers Facilities. clique no menu Network Analyst e selecione a opção New Service Area. conforme Quadro 5. Vamos avaliar quantitativamente a acessibilidade dos pedestres ao sistema de transporte coletivo do Bairro Jardim da Penha. Barriers.9. clique no combo-box Load From. Clique com o botão direito do mouse sobre Facilities(0) e selecione Load Locations no menu popup. Para os parâmetros que não forem informados. Selecione a aba Analysis Settings e configure os parâmetros conforme descrito abaixo. selecione o Figura 108: Layers utilizados na criação de áreas de serviço. Na barra de ferramentas Network Analyst. selecione Ponto-onibus e no botão OK. A primeira coisa a fazer é carregar os pontos em relação aos quais serão geradas as áreas de influência. Lines e Polygons. A abordagem adotada é aquela proposta por Ferraz e Torres (2004). Coloque um símbolo mais adequado (exemplo: Bus Station na categoria Transportation/Guide Sign). Será acrescentado ao data frame um layer chamado Service Area. Altere seu nome para Áreas de Influência.2 Acessibilidade a pontos de ônibus Abra o mapa Prática9_Acessibilidade. conforme indica a Figura 100. Será aberta a caixa de diálogo Layer Properties (Figura 109).

mantendo os valores default para os demais.Fator Parâmetros de avaliação Bom < 300 Regular 300-500 Ruim > 500 Acessibilidade Distância de caminhada no início e no fim da viagem (m) Quadro 5: Avaliação de acessibilidade. Figura 109: Configurações para o cálculo das áreas de influência. Adaptado de Ferraz e Torres (2004). Trim Polygons: 500 meters Multiple Facilities Options: Merge by break value Overlayp Type: Rings Allow U-Turns: Nowhere Na barra de ferramentas Network Analyst. selecione o comando Solve resultado do cálculo. Selecione a aba Polygon Generation e configure os parâmetros conforme descrito abaixo. que deve ser semelhante ao da Figura 110. e observe o 155 .

Gere outro mapa com as áreas de influência. utilizando os intervalos abaixo: 0m .30m 30m – 60m 60m – 90m Quais seriam as limitações caso utilizássemos o comando de criação de buffer para representar as áreas de influência de cada ponto de ônibus? 156 .Figura 110: Resultado do cálculo das áreas de influência.

barreiras (ruas impedidas.3 Localização de equipamentos ou serviços mais próximos Outro recurso útil da extensão Network Analyst consiste no cálculo dos equipamentos ou serviços mais próximos de um determinado ponto. a localização dos equipamentos (os pontos de ônibus no nosso exemplo). Os layers citados correspondem. No exemplo a seguir. Impedance: Meters (Meters) Facilities To Find: 3 Allow U-Turns: Everywhere Restrictions: mantenha as caixas de verificação Conv_Proibidas e Oneway desmarcadas Distance Units: Meters Open Directions window automatically: marcado 157 . Para aqueles que não forem informados. certifique-se de Ponto de ônibus mais próximo é o layer selecionado no combo-box. Barriers e Routes. mantenha os valores default. Na janela Network Analyst window. Como exemplos podemos citar: alocação de alunos à escola mais próxima. Selecione Cruzamento 2 no menu View / Bookmarks. Marque um ponto no cruzamento das ruas Comissário Octávio Queiroz e Doutor Moacyr Gonçalves. respectivamente. identificação dos pontos de atendimento mais próximos de um cliente para que ele possa efetuar o pagamento de contas. fornecendo inclusive o itinerário para se chegar ao equipamento. clique no combobox Load From. Na barra de ferramentas Network Analyst. etc. selecione Ponto-onibus e no botão OK. selecione o comando Create Network Location Tool . Será acrescentado ao data frame um layer chamado Closest Facility. Incidents. Altere seu nome para Ponto de ônibus mais próximo. Na janela Network Analyst window. pontos de chamada ou demanda (a localização do pedestre no nosso exemplo). por exemplo) e as rotas que serão calculadas dos pontos de chamada até os equipamentos. que empacota (agrupa) os layers Facilities. selecione o comando Ponto de ônibus mais próximo Properties .3. vamos informar um posição e calcular os pontos de ônibus mais próximos. selecione o layer Incidents(0). Clique no menu Network Analyst e selecione a opção New Closest Facility. Na janela Network Analyst window. Será aberta a caixa de diálogo Layer Properties (Figura 111).9. Clique com o botão direito do mouse sobre Facilities(0) e selecione Load Locations no menu popup. Na caixa de diálogo Load Locations. Selecione a aba Analysis Settings e configure os parâmetros conforme descrito abaixo e clique no botão OK.

Na barra de ferramentas Network Analyst.Figura 111: Parâmetros de configuração utilizados no cálculo dos pontos de ônibus mais próximos. Figura 112: Itinerário do ponto de partida até os três pontos de ônibus mais próximos. 158 . Na Figura 112 têm-se os itinerários até os três pontos de ônibus. semelhante Figura 113. selecione o comando Solve que e observe o deve ao ser da resultado do cálculo.

Dos recursos vistos nesta prática. Faça outras simulações. Experimente criar barreiras. Antônio Clóvis Pinto. Transporte público urbano. 9.Figura 113: As três rotas que foram calculadas. 2ª ed. São Carlos: Rima. 2. Trace um paralelo entre o emprego de buffers e de áreas de influência. 428 p. qual deveria ser utilizado para a alocação de alunos a escola mais próxima? 9.5 Bibliografia FERRAZ. 2004. Isaac Guilhermo Espinosa.4 Exercícios 1. TORRES. 159 .

tem de ser quebrados em trechos sempre que houver uma interseção entre eles. Outro aspecto de fundamental importância é que os arcos possuem um sentido. FT indica que é permitido percorrer o arco do início para o fim. É importante salientar que os eixos pertencentes a uma mesma rede – pode-se combinar redes de modais diferentes . estradas. impedâncias relativas ao comprimento do arco ou tempo necessário para percorrê-lo são modelados através de atributos e tem como padrão para seus nomes Oneway. coverages ou geodatabases – para criação de um Network Dataset. Ela oferece recursos que permitem elaborar estudos sobre roteamento. As regras possíveis são a conectividade . respectivamente. os sentidos de deslocamento. as conversões proibidas. deve-se preencher o campo Oneway com os valores FT (From To) e TF (To From). e por fim propriedades relativas ao relatório do itinerário. A escolha entre eles se dará de acordo com o sentido do arco. Para os arcos onde é possível se deslocar em ambos os sentidos basta deixar em branco. Guimarães . Ruas. TF tem o efeito contrário. Wellington D. No network dataset utilizam-se os termos Along (ao longo de) e Against (contrário a) para substituílos. É formado por dois tipos de geometria . serão criadas nos extremos de cada arco no momento de criação. estejam eles conectados ou não – lembre-se de que as redes são 2D e pense no caso de viadutos.polilinhas (edge sources) e pontos (junction sources). O passo inicial consiste em estruturar os dados de origem – shapefiles. indicando que só é permitido percorrer o arco do ponto final para o inicial. Ou seja. o ArcGIS Desktop utiliza uma extensão chamada Network Analyst para realizar análises que envolvem redes de transporte. A conexão entre 160 . os campos de impedância. os tipos mais comuns serão: Shapefile-Based Network Dataset e Geodatabase-Based Network Dataset. No caso do sentido de fluxo. Ambos indicam que o arco possui mão única. caso não existam. e serão armazenadas em um plano de informação. Estruturação de redes no ArcGIS Conforme visto na aula anterior.define como as feições participantes da rede se interligarão.Preparado por: Prof. As junções. respectivamente. um para cada sentido). Este consiste de um conjunto de regras aplicadas aos planos de informação de entrada. Meters e Minutes (FT_Minutes e TF_Minutes. acessibilidade e delimitação de áreas de influência. Todo network dataset possui um nome e um tipo – que é dado em função dos planos de informação de entrada.CEFETES 10. que permitem modelar as restrições que permeiam a rede. linhas de metrô e cursos d'água são modelados através de seus eixos. Nesta aula veremos como estruturar uma rede de transporte. Naqueles onde não é permitido o tráfego coloca-se o valor N. Restrições como sentido de fluxo. que recebem o nome de edge sources na terminologia do software.

Na primeira. c. não haverá conexão. Se dois arcos que se interceptam tiverem o mesmo valor de ZLEV estabelecer-se-á conexão entre eles. Eles armazenam valores lógicos de elevação (ZLEV) – não confunda com altitude. como linhas de metrô e de eixos de logradouro. apenas os extremos do arco poderão ser utilizados para conexão. todo arco de uma seqüência pode conectar-se apenas ao seu sucessor (árvore sem folhas. i. não é permitido conexão do tipo “Y”). Conversões envolvem no mínimo dois arcos. Uma conversão deve obedecer as regras a seguir: ➢ ➢ uma conversão é uma seqüência de pelo menos dois arcos. 161 ➢ ➢ . Um network dataset baseado em shapefile suporta apenas um plano de informação para compor os arcos da rede. os arcos externos não poderão ser internos em outras conversões. As letras F e T correspondem a From e To. inclusive conversões em U. Se forem diferentes. sendo que o Network Analyst suporta uma máximo de 20. Cada arco tem um sentido. Há n2 (n – número de arcos) possibilidades de conversão em uma junção de rede. no caso de conversões que envolvam três ou mais lados (multiedge turns). O primeiro e último arcos recebem o nome de exteriores. qualquer vértice comum será utilizado para estabelecer a conexão.arcos pode se dar de duas formas . ou seja. como no caso de pontes e viadutos. São úteis no caso de integração de redes de modais diferentes. Podem ser construídas em qualquer junção onde os arcos se conectam. A Figura 115 ilustra um exemplo de conversão que envolve múltiplos arcos – f. A conexão do tipo End Point é modelada através dos atributos F_ZLEV e T_ZLEV. arcos internos podem ser compartilhados por outras conversões. O número máximo suportado será definido no momento de criação de uma turn feature class. Figura 114: Conversões possíveis em uma junção de três arcos (ESRI). conforme ilustra a Figura 114. enquanto um network dataset baseado em geodatabase suporta múltiplos planos de informação para formar os arcos e junções da rede. arcos de Os demais arcos são chamados intermediários.End Point e Any vertex. Os arcos f e i são exteriores e os demais interiores. respectivamente. definido em função de seus pontos inicial e final. Na segunda. d. Conversões também podem ser incorporadas à rede.

que é uma classe de feição personalizada de polilinhas do tipo ESRI Turn Feature. Minutes.\Prat10\Dados. 10. A seguir veremos em detalhes como construir uma rede. Para adicionar uma turn feature class à rede. No caso de shapefiles. 162 . O Datum horizontal é o SAD69..2 Dados Necessários Os dados necessários para esse exercício encontram-se em . Uma turn feature class pode ser criada no ArcCatalog através do menu de contexto ou no Arctoolbox. Isto significa que duas conversões não podem ter os arcos exteriores inicial e final iguais.) podem ser utilizados no Field Evaluator. nenhum significado. Um network dataset suporta diversas turn features classes. 10.➢ duas conversões não podem representar o mesmo movimento de conversão. com meridiano central de 39°W. Campos pré-definidos (Meters. Criar e editar os atributos necessários para modelar uma rede.. Para criar uma conversão. elas deverão compor um network dataset. Estruturar um Network Dataset baseado em shapefiles.1 Objetivos ➢ ➢ ➢ ➢ Dividir uma rede de eixos de logradouro em trechos.. a turn feature class deve pertencer a um network dataset. O sistema de projeção é UTM. Criar uma turn features class. ela deve estar no mesmo feature dataset dos demais dados (arcos e junções). Ela não pode participar de grupos de conectividade e não tem informações sobre elevação. para o caso de geodatabases. Fora de uma rede.. Para fazer uso de seus dados. ela deve estar no mesmo diretório (workspace de shapefile) e tem que ter o mesmo sistema de referência dos demais elementos do network dataset. Conversões são modeladas como vetores (geometria do tipo polilinha) em uma turn feature class. uma turn feature class não tem Figura 115: Exemplo de conversão que envolve mais de dois arcos (ESRI). Todos os planos de informação estão no formato shapefile. Os arquivos (mapas e suas tabelas de atributos) a serem utilizados estão descritos no quadro abaixo.

Os campos Name e Type já foram criados anteriormente.. Abra a tabela de atributos do layer Eixo_logradouro e crie os campos descritos no Quadro 6. conforme o vídeo de exemplo Planarize_Lines.3.\Prat10.2 Criação dos campos de impedância e de sentidos de tráfego De posse dos trechos de logradouro.. 10. 10. Mude o nome do data frame Layers para Jardim da Penha. o passo seguinte será a criação dos campos que armazenarão os atributos que controlam o fluxo pela rede e a geração de itinerários. disponível na barra de ferramentas Topology. Esta regra só não é válida para o caso de integração de redes de modais diferentes – rede de metrô com a rede do sistema viário.3. 163 . Quantos logradouros existem no bairro? Eles estão divididos em trechos? Salve o mapa com o nome de Pratica10..1 Divisão dos logradouros em trechos Para modelar o sistema viário é necessário quebrar os logradouros em trechos. O critério de quebra é a interseção com outros logradouros. para dividir os logradouros em trechos.htm.3 Procedimentos Inicie o ArcMap com um mapa vazio.Plano de Informação Limite-jpenha Quadra Eixo_Logradouro Formato shapefile shapefile shapefile Limites das quadras Eixos de logradouro Descrição Limite do bairro Jardim da Penha 10. armazenado no diretório .. Utilize o comando Planarize Lines . por exemplo.\Prat10\Dados.mxd no diretório . Adicione o layer Eixo_logradouro.

164 . etc.Campo METERS MINUTES ONEWAY Tipo de dado Double. Nome do logradouro. Sentido de tráfego. Considere que um pedestre anda 5Km por hora. A título de exercício. 2 Descrição Comprimento em metros de cada trecho de logradouro. Preencha o campo ONEWAY de acordo com as convenções do Quadro 6. NAME TYPE Text. Figura 116: Ruas de mão única do bairro Jardim da Penha.mão única e de sentido contrário ao do arco. conforme vídeo de exemplo Sentido_Arcos. Preencha o campo MINUTES com o tempo necessário para percorrer cada trecho de logradouro. 12.htm. avenida. Preencha o campo METERS com o comprimento de cada trecho de logradouro. conside uma velocidade de tráfego de 60 km/h para todos os trechos. 5 Quadro 6: Campos padronizados utilizados no ArcGIS.). Tipo de logradouro (rua. Utilize a Figura 116 ou os dados da prática de número nove para saber os sentidos do tráfego do bairro. Altere a legenda do layer eixo_logradouro de modo que seja possível saber o sentido de cada arco. 5 Text. Tempo em minutos necessário para percorrer cada trecho de logradouro à pé. FT – mão única e de mesmo sentido do arco. 2 Double. TF . 30 Text. Em branco – mão dupla. N – trânsito impedido. 10.

.\Prat10\Dados. Consulte o vídeo de exemplo Criacao_Conversoes_Proibidas. navegue até a pasta .. O primeiro passo é criar um plano de informação do tipo turn feature class..htm.mxd.htm para ver os procedimentos necessários. Inicie o ArcCatalog e navegue até a pasta .3. Crie um plano de informação do tipo turn feature class com o nome de Conv_proibidas.4 Criação do Network Dataset Conforme discutido anteriormente. 10. 165 . Crie o network dataset com o nome de ND_JPenha.5. o network dataset é o elemento que vai ”empacotar” as regras que controlam o deslocamento pela rede.\Prat10\Dados e adicione o network dataset ND_JPenha.3 Criação do plano de informação para modelar as conversões proibidas Apenas os sentidos de tráfego não são suficientes para modelar o fluxo pela rede. Inicie o ArcMap e abra o arquivo Pratica10. As conversões propriamente ditas serão criadas no tópico 10. 10. conforme vídeo Criacao_turn_feature_class. Clique no comando Add Data . Figura 117: Adição de todos os layers do network dataset. conforme vídeo Criacao_Network_Dataset. falta registrar as conversões proibidas.htm. de acordo com a Tabela 2. Observe que você apenas criou um plano de informação vazio. Inicie o ArcCatalog e navegue até a pasta . Registre todas as conversões proibidas. criado no item anterior.3..5 Criação das conversões proibidas Para concluir..10.\Prat10\Dados.3. para que todos os planos de informação que fazem parte do newtork dataset sejam adicionados ao data frame. Responda sim à pergunta indicada na Figura 117. Observe que a ordem é que indica o sentido proibido.3. Outra variável que pode compor nosso modelo são as conversões proibidas.. caso não esteja aberto.

Dante Michelini Rua Eugenilio Ramos Av. Saturnino Rangel Mauro Av. Carlos Orlando Carvalho Av. francisco generoso da fonseca Av. Luiz Manoel Velloso Av. Dante Michelini Rua adriano fontana Av. Anisio Fernandes Coelho Rua Maria Eleonora Pereira Rua José Neves Cypreste Av. Anisio Fernandes Coelho Rua Oscar Rodrigues de Oliveira Rua Ronaldo Scampini Av. Dante Michelini Rua Doutor Antonio Basilio Av. Dante Michelini Rua Candido Ramos e Av. Luiz Manoel Velloso Rua Maria Eleonora Pereira Rua José Neves Cypreste Av. Dante Michelini Av. 166 . Luiz Manoel Velloso Rua José Neves Cypreste Rua Maria Eleonora Pereira Av. Carlos Orlando Carvalho Av. Anisio Fernandes Coelho Rua Ronaldo Scampini Logradouros Av. Carlos Orlando Carvalho Av. Dante Michelini Tabela 2: Relação de conversões proibidas. Hugo Viola Rua Oscar Rodrigues de Oliveira Av.Conversões Proibidas 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 Av. Dante Michelini Rua Adriano Fontana Av. Doutor Pedro Feu Rosa Rua Sérgio Murilo França de Souza Av. Dante Michelini Rua Archimedes Vivacqua e Av. Dante Michelini Rua Comissario Octavio Queiroz e Av. Hugo Viola Av. Anisio Fernandes Coelho Rua José Neves Cypreste Rua Maria Eleonora Pereira Av. Dante Michelini Av. Dante Michelini Rua Aristobulo Barbosa Leão e Av. Francisco Generoso da Fonseca Av.

6 Configuração da legenda para Network Datasets Após a inclusão das conversões proibidas e atualização do network dataset.htm para ver os procedimentos necessários. 167 .10.3. Figura 118: Mapa resultante da modelagem do sistema viário do bairro Jardim da Penha. Consulte o vídeo de exemplo Legenda_Network_Datasets. você pode alterar a legenda da rede para facilitar sua visualização. Você deverá obter um mapa semelhante ao da Figura 118.

Para obtê-los.htm mostra um exemplo. que são versão ArcInfo do ArcGIS Desktop. que é utilizado na definição dos trechos de mão única.5 Exercícios 1. ele pode ser alterado. O comando FLIP deve ser utilizado para esta finalidade. Conforme vimos. estão disponíveis apenas na O primeiro converte polígonos em polilinhas. que criará as linhas de centro (centerlines). mas dos limites de quadras (polígonos). Por que dividir os logradouros em trechos? 168 . uma alternativa é utilizar os comandos FeatureToLine e CollapseDualLinesToCenterline. 10. Caso seja necessário. O vídeo necessárias para execução do segundo comando. os arcos têm um sentido. Eles Derivacao_de_Eixos_de_Logradouro. Para quem consultar o sistema de ajuda do software. observar que a tradução de sentido é direction.4 Dicas Em algumas situações não se dispõe dos eixos de logradouro.htm ilustra o uso desses comandos. O vídeo FLIP.10.

Sign up to vote on this title
UsefulNot useful