You are on page 1of 2

1- Leia um número inteiro, apos a leitura teste se o número é divisível por 10.

Caso isso seja verdadeiro exibir a mensagem" Numero ternado em zero" caso contrário, exibir a mensagem "Numero NÃO terminado em zero". Resolução: algoritmo "testa Número" var N: Inteiro inicio Leia (N) se (numero mod 10=0) entao escreva ("número terminado em zero") senao escreva ("Número NÃO terminado em zero") fimse fimalgoritmo 2- Efetue o cálculo de um sálario de um professor. Para fazer este algoritmo você deverá ler alguns dados.tais como: valor da hora aula,número de aulas dadas no mês e percentual de descontos de INSS. Deve ser apresentado ao usuário o salário liquido eo salário Bruto obtido. SALARIO_BRUTO = QUANT_AULAS * VALOR_ AULA SALARIO_LIQUIDO = SALARIO_BRUTO - DECONTOS Resolução: algoritmo "Calculo de um salário" var valor_Hora_aula, Numero-aula, descontosINSS, salario_bruto, salario_liquido: Real inicio Leia (valor_hora_aula) Leia (numero_aula) Leia (descontoINSS) salario_bruto<-valor_hora_aula*numero_aula descontoINSS<-salario_bruto*(descontoINSS/100) salario_liquido<-salario_bruto-descontosINSS escreva('salário Bruto é",salario_bruto) escreva("salário Líquido é"salario_liquido) fimalgoritmo 3-Leia dois números reais e mostre qual o maior dos dois. Considera que nunca serão informados valores iguais. Resolução: algoritmo "testando número maior ou menor" var Numero1, Numero2: Real inicio Leia (numero1) Leia (numero2) se (numero1> Numero2) entao escreva(numero1) senao escreva(numero2) fimse

salario_final) fimalgoritmo.salario_fixo) escreva("O salário fixo é". Resolução: algoritmo "Salário de um vendedor" var nome: caractere salario_fixo.fimalgoritmo 4.Leia o nome de um vendedor o seu salário fixo e o valor total de vendas efetuadas por ele no mês (em dinheiro).comissao. O final informar o seu nome. Sabendo que este vendedor ganha 5% de comissão sobre as vendas efetuadas. o salário fixo e salário final do mês.salario_fixo) escreva("O salário no final do mês é". valor_vendas. . salario_final: Real inicio Leia(nome) Leia(salario_fixo) leia(valor_vendas) comissao<-valor_vendas*(5/100) salario_final<-salario_fixo+comissao escreva("O nome do vendedor é'.