You are on page 1of 95

Accompanying

Training Manual
Roboguide V6.40 Rev.B

Name:

Z-KAE-TRN-Roboguide-1/01

Copyright

FANUC Robotics Deutschland GmbH

Do not copy this document or parts of this document and give it to a third party
without the express written permission of FANUC.
Other than the described functions may run on the controller. However, you do not
have any rights to claim these functions at delivery.
We have checked the contents of this document for correspondence with the
described hardware and software.
However, we do not ensure full correspondence. We do, however,
regularly check the contents of this document and make necessary corrections in the
succeeding editions.
Design and specifications that do not affect the functioning are subject to change
without notice.
Author: Werner Schollenberger

Z-KAE-TRN-Roboguide-1/01

Preface

Training your staff is the key to your success


A profound training of your staff is the key to your success. Training your staff means
to give them the necessary information to be able to control the system and
understand the applied technology. General knowledge as well as detailed
knowledge about the system is as important as the practical knowledge of the applied
programming.
This is the aim of our training concept.
Our training is a successful mix of well explained theory and practical applications. To
guarantee a successful training, we use detailed training documents, state-of-the-art
training methods and means in our training center in Neuhausen.
More than two thirds of the course are reserved for training on the machine. Your
staff collects practical knowledge of the robot and the appropriate application
programs.
A qualified training means for you:
Maximum utilization ... of the system and optimum cycle times through
professional programming.
Long service life ... and insignificant wear because of qualified
maintenance.
Minimum downtime ... because of fast fault removal and program corrections
as well as repair measures according to good professional practive.
Less operator errors ... because of extensive knowledge.
Optimum robot integration ... in the work cell because of profound
knowledge of the interfaces.
Motivated staff ... understanding what you do brings fun!
Desired Flexibility ... understanding the robot and system functions
allows fast and flexible adaptions to your special
needs. We offer you a diverse training and course program for your staff from
novice to expert, according to the training level, and treating the diverse
application programs. These courses allow you make full use of your FANUC
robot. In addition to our standard courses, we offer individual training courses
on demand.
In these courses, we can treat special uses, systems, and functions.
Furthermore, we offer on-site courses on agreement.

Z-KAE-TRN-Roboguide-1/01

Contents
Contents ......................................................................................................... 4
System requirements..................................................................................... 8
Installation ...................................................................................................... 8
Registration .................................................................................................... 9
Registration Step 1 .....................................................................................................................9

Registration .................................................................................................. 10
Registration Step 2 ...................................................................................................................10

License transfer ........................................................................................... 11


General ....................................................................................................................................11
Procedure.................................................................................................................................11

License transfer ........................................................................................... 12


Procedure.................................................................................................................................12

Directory structure....................................................................................... 12
Directory structure....................................................................................... 13
Generate a new cell...................................................................................... 14
Generate a new cell..................................................................................................................15
Generate a new cell..................................................................................................................16
Generate a new cell..................................................................................................................17
Generate a new cell..................................................................................................................18

Mouse commands........................................................................................ 19
Functions of the triad .................................................................................. 20
Add a tool...................................................................................................... 21
Add a tool (Option 1).................................................................................................................22
Add a tool (Option 1).................................................................................................................23
Add a tool (Option 1).................................................................................................................24
Add a tool (Option 1).................................................................................................................25
Add a tool (Option 2).................................................................................................................26
Add a tool (Option 2).................................................................................................................27
Create a tool.........................................................................................................................27

Indicate TCP (Tool Center Point) ................................................................ 28


Add a positioner (fixture)............................................................................. 29
General ....................................................................................................................................29

Add a positioner (fixture)............................................................................. 30


Insert ........................................................................................................................................30

Add obstacles............................................................................................... 31
General ....................................................................................................................................31

Add obstacles............................................................................................... 32
Add a fence ..............................................................................................................................32

View of the created work cell ...................................................................... 33


Insert and remove the yellow position lines .............................................. 34
Change the background color .................................................................... 35

Z-KAE-TRN-Roboguide-1/01

Explanation of icons .................................................................................... 36


Explanation of icons .................................................................................... 37
Explanation of icons .................................................................................... 38
The Run Panel .........................................................................................................................38

Explanation of icons .................................................................................... 39


Check the reachability with a mouse click (Option 1)............................... 40
Check the reachability with a mouse click (Option 2)............................... 41
Check the reachability (Option 3) ............................................................... 42
Set a user frame ........................................................................................... 43
The teach pendant ....................................................................................... 44
Create programs on the teach pendant ..................................................... 45
Create programs in the cell browser .......................................................... 46
Create a simulator program ......................................................................................................46

Start programs ............................................................................................. 47


Start programs from the teach pendant .....................................................................................47

Start programs ............................................................................................. 48


Start programs from the Run Panel...........................................................................................48
Record AVI ...............................................................................................................................48

Measuring tool.............................................................................................. 49
Measuring tool.............................................................................................. 50
Record dimensions ...................................................................................................................50
Specifiy measuring points .........................................................................................................50

Measuring tool.............................................................................................. 51
Define and change the distance between two components .......................................................51

Measuring tool.............................................................................................. 52
Define dimensioning lines .........................................................................................................52

Add parts ...................................................................................................... 53


Add a part.................................................................................................................................53

Add parts ..................................................................................................... 54


Shift parts .................................................................................................................................54
Change part properties .............................................................................................................54

Add parts ...................................................................................................... 55


Link a part with a positioner ......................................................................................................55

Add parts ...................................................................................................... 56


1. Prepare a part for a pick-and-place simulation.......................................................................56

Add parts ...................................................................................................... 57


2. Prepare a part for a pick-and-place simulation.......................................................................57

Add parts ...................................................................................................... 58


3. Prepare a part for a pick-and-place simulation.......................................................................58

Add parts ...................................................................................................... 59


4. Prepare a part for a pick-and-place simulation.......................................................................59

Parts .............................................................................................................. 60
1. Prepare a program for a pick-and-place simulation................................................................60
Z-KAE-TRN-Roboguide-1/01

Parts .............................................................................................................. 61
2. Prepare a program for a pick-and-place simulation................................................................61

Parts .............................................................................................................. 62
3.

Prepare a program for a pick-and-drop simulation ............................................................62

Parts .............................................................................................................. 63
4.

Create a pick program (simulator program).......................................................................63

Parts .............................................................................................................. 64
5.

Create a pick program (simulator program).......................................................................64

Parts .............................................................................................................. 65
6.

Create a drop program (simulator program) ......................................................................65

Parts .............................................................................................................. 66
7.

Create a drop program (simulator program) ......................................................................66

Parts .............................................................................................................. 67
8.

Complete a simulator program..........................................................................................67

Parts .............................................................................................................. 68
9.

Other options to create a simulator program .....................................................................68

Machines....................................................................................................... 69
General ....................................................................................................................................69

Machines....................................................................................................... 70
1. Create a machine (actuated via DO) .....................................................................................70

Machines....................................................................................................... 71
2. Create a machine (actuated via DO) .....................................................................................71

Machines....................................................................................................... 72
3. Create a machine (actuated via DO) .....................................................................................72

Machines....................................................................................................... 73
1.

Create a machine (actuated via servo) .............................................................................73

Machines....................................................................................................... 74
2.

Create a machine (actuated via servo) .............................................................................74

Machines....................................................................................................... 75
3.

Create a machine (actuated via servo) .............................................................................75

Machines....................................................................................................... 76
4.

Create a machine (actuated via servo) .............................................................................76

Machines....................................................................................................... 77
5.

Create a machine (actuated via servo) .............................................................................77

Machines....................................................................................................... 78
6.

Create a machine (actuated via servo) .............................................................................78

Machines....................................................................................................... 79
7.

Create a machine (actuated via servo) .............................................................................79

Replace the robot in an existing work cell................................................. 80


Add a second robot ..................................................................................... 81
Generate a path (Automatic program generation) .................................... 82
General ....................................................................................................................................82

Generate a path (Automatic program generation) .................................... 83


Procedure for path generation related to an edge......................................................................83

Z-KAE-TRN-Roboguide-1/01

Generate a path (Automatic program generation) .................................... 84


Procedure for path generation related to an edge......................................................................84
Change the approach and return position .............................................................................84

Generate a path (Automatic program generation) .................................... 85


Procedure for path generation related to an edge......................................................................85
1. Other setting options (feature) ..........................................................................................85

Generate a path (Automatic program generation) .................................... 86


Procedure for path generation related to an edge......................................................................86
2. Other setting options (feature) ..........................................................................................86

Generate a path (Automatic program generation) .................................... 87


Procedure for path generation related to an edge......................................................................87
3.
Other setting options (feature) ......................................................................................87

Generate a path (Automatic program generation) .................................... 88


Segmentation ...........................................................................................................................88

Target points ................................................................................................ 89


Define target points as points in space......................................................................................89

Target points ................................................................................................ 90


1. Define a target group ............................................................................................................90

Target points ................................................................................................ 91


2. Define a target group ............................................................................................................91

Target points ................................................................................................ 92


3. Define a target group ............................................................................................................92

Target points ................................................................................................ 93


Define target points on a surface and assign a positioner..........................................................93
General ................................................................................................................................93
1. Procedure.........................................................................................................................93

Create a dynamic tool.................................................................................. 94


General ....................................................................................................................................94
Procedure.................................................................................................................................94

New functions as from V.6.40 Rev. C ......................................................... 95


Projects ....................................................................................................................................95

Z-KAE-TRN-Roboguide-1/01

System requirements
Windows XP
1024 MB RAM
Pentium 4 > 3.0 GHz
Nvidia Quadro 4 oder Nvidia Quadro FX

Installation
1. Start License Checker Setup.
2. Start SimPro Setup.
During the installation, you can select the language under Custom (1).
You can choose between German and Japanese (2). If you select Typical, the
software will be installed with German menus (please observe note). If you select
Typical, you have to select the virtual controller you want to use.
If you select German, the menus will be in German language.
If you select Japanese, the menus will be in English.
Note:
If you select German or Typical, nearly all (but not all) terms and menus are in
German.
This manual uses the German menus.
After the installation, you can use Roboguide for 30 days.
After 30 days, you have to register the software. (see registration)
Please note: You get the registration key after approx. 3 days.
1

Z-KAE-TRN-Roboguide-1/01

Registration
Registration Step 1
Open the License Manager.

Generate a screen shot.

Beispiel Darstellung

Copy the software codes 1 and 2 from RTL-SIMPRO640.


Send the screen shot and the software codes 1 and 2 to the following e-mail address:
Licenses@fanucrobotics.de

Z-KAE-TRN-Roboguide-1/01

Registration
Registration Step 2
After receiving registration key 1 and 2, follow this procedure:
Open the License Manager and mark the check box (1).
Enter the two keys in the appropriate columns (2).
Click on Register (3).

Beispiel Darstellung

Z-KAE-TRN-Roboguide-1/01

10

License transfer
General
Roboguide has been successfully installed on computer 1.
You want to transfer the license to another computer (computer 2).

Procedure
Install Roboguide on computer 2.
Connect the storage medium (e.g. USB stick) to computer 2.
Open the License Manager on computer 2 and choose the Transfer Licenses
tab.
Select the USB stick using the Browse button.
Click on the Prepare button.
The USB stick is ready for a license transfer.

Z-KAE-TRN-Roboguide-1/01

11

License transfer
Procedure
Open the License Manager on computer 1 and choose the Transfer Licenses
tab.
Connect the storage medium (e.g. USB stick) to computer 1.
Click on the button (1) and follow the instructions (2).

Open the License Manager on computer 2 and choose the Transfer Licenses
tab.
Connect the storage medium (e.g. USB stick) to computer 2.
Click on the button (3) and follow the instructions (4).
3

Z-KAE-TRN-Roboguide-1/01

12

Directory structure
Roboguide may be installed under Programme > Fanuc > Pro > SimPro.
All data generated in one cell are recorded under
C:\Dokumente und Einstellungen\ IHR Profil \ My Workcells.
You can open the folder directly under Tools .

Imported IGES data are converted by Roboguide and then get the extension .CSB

Z-KAE-TRN-Roboguide-1/01

13

Generate a new cell


1. Start the software.

2. Generate a new cell.

3. Enter the project name and then click on NEXT.

Z-KAE-TRN-Roboguide-1/01

14

Generate a new cell


4. Select an option under Robot Selection Method .
a) Create a new robot: Generate a completely new robot.
b) Create a robot from a file backup: You can create a robot from an
existing data recording (All of above).
c) Create an exact copy of an existing robot: A sort of cloning the robot,
not a copy of the complete cell, but only of the robot configuration.

This manual describes the procedure (a).


5. After the selection, click on the Next button.
6. Select the application software FANUC Handling Tool and then click on the
Next button.

Z-KAE-TRN-Roboguide-1/01

15

Generate a new cell


7. Select the robot type and then click on the Next button.

8. Select the robot software (deviations from the display may occur), and then
click on the Next button.

Z-KAE-TRN-Roboguide-1/01

16

Generate a new cell


9. You can create new groups with Additional Motion Groups . If you do not
want to use additional groups, click on the Next button.

10. Here, you can select software options. Click on the Next button to open the
Summary, an overview of your selection. To complete your selection, click on
the Finish button.

Z-KAE-TRN-Roboguide-1/01

17

Generate a new cell


Your cell has been generated after diverse messages.

Z-KAE-TRN-Roboguide-1/01

18

Mouse commands
To display the mouse commands, click on this icon.

The following overview is displayed.

Overview of the functions


Click on the right
mouse button to rotate the
layout.

Turn the mouse wheel


to zoom-in/out on the cursor
position

Press both buttons to zoom.

Press the wheel to shift the


layout

Z-KAE-TRN-Roboguide-1/01

19

Functions of the triad


You can place or shift objects via changing the properties or via the triad.

You can shift (x, y, z) and rotate (w, p, r) objects via the triad.
1. Shifting
Select the desired coordinate axis with the mouse and drag.
Z

2. Rotating
Hold down the shift key and select the desired coordinate axis and rotate.

Z-KAE-TRN-Roboguide-1/01

20

Add a tool
1. Click on this icon to open the cell browser.

2. Open the path as follows.

Z-KAE-TRN-Roboguide-1/01

21

Add a tool (Option 1)


Double-click on UT:1 (EOAT1) to open the Properties.
(EOAT = End of Arm Tool)

1
2

Give a name to your tool (1).


Import (2) a tool from the data base (Image Library), open the EOAT folder,
select Grippers and then Vacuum01.IGS.

Z-KAE-TRN-Roboguide-1/01

22

Add a tool (Option 1)


The path has been read in (1), click on Aktiviere.

The tool was adapted to the robot.

Z-KAE-TRN-Roboguide-1/01

23

Add a tool (Option 1)


Note:
For a faultless adaptation of the tool, you have to set the origin and the coordinates in
a 3D CAD system.
Tools may only be imported in the IGES format.
Actual condition

Desired condition

+Z

Z-KAE-TRN-Roboguide-1/01

+Z

24

Add a tool (Option 1)


You can place the tool at its correct position by entering changes on the
property screen.

Mark the Sperre alle Koordinatenwerte check box (1).

Z-KAE-TRN-Roboguide-1/01

25

Add a tool (Option 2)


Click on UT:1 with the right mouse button to add a link.
You can choose from
o CAD Bibliothek: Import from data base
o CAD File: Import customer data in IGES
o Create customized tools with Box, Cylinder, Sphere

The following tool is created below.

Z-KAE-TRN-Roboguide-1/01

26

Add a tool (Option 2)


Create a tool
1

Z-KAE-TRN-Roboguide-1/01

27

Indicate TCP (Tool Center Point)

Open the Property window


Select the UTOOL tab
Check the Bearbeite UTOOL box
Drag the triad with the mouse
to the desired position or
enter the data directly.
Click on Benutze aktuelle
Triad Position
Click on the Aktiviere button

Z-KAE-TRN-Roboguide-1/01

28

Add a positioner (fixture)


General
Positioners recorded in the data base may be
Conveyor belts (Conveyer)
FANUC machines (Maschine)
Miscellaneous (Misc)
Motors (Motors)
Pallets (Pallets)
Racks (Racks, Shelf)
Tables (Table)
Furthermore, a positioner may be imported as IGES or may be created from scratch.
A positioner is used for placing parts.

Z-KAE-TRN-Roboguide-1/01

29

Add a positioner (fixture)


Insert
Example for inserting a conveyor belt from the
data base
Click with the right mouse button
on Positionierung and select Zufgen
Positionierer and then CAD Bibliothek .
Open the Conveyer path and select
Conveyer11.iges .
Click on the OK button.

For this representation, no


bitmap file has been created.
However, the
model exists.

After the conveyor belt has been placed, you can


position it by means of the triad or a direct entry
at the target position.
It is recommended to give the positioner
a new name.
You can copy and paste the positioner and other
objects with the known Windows commands.
Copying is performed in the cell browser.

Z-KAE-TRN-Roboguide-1/01

30

Add obstacles
General
An obstacle recorded in the data base may be
a controller
a fence
Furthermore, an obstacle may be imported as IGES or may be created from scratch.

Z-KAE-TRN-Roboguide-1/01

31

Add obstacles
Add a fence
Click with the right mouse button
on Hindernis and select Zufgen
Hindernis and then CAD Bibliothek .
Open the FENCE path and select
Sreen-Course-Wire.igs .
Click on the OK button.

After the fence has been placed, you can


position it by means of the triad or a direct entry
at the target position.
Renaming is recommended.
You can copy and paste the fence, as well as other objects, by using the known
Windows commands.
Copying is performed in the cell browser.

Z-KAE-TRN-Roboguide-1/01

32

View of the created work cell

Tool with TCP

Positioner
Conveyor belt

Obstacle
Fence

Z-KAE-TRN-Roboguide-1/01

33

Insert and remove the yellow position lines


You can insert and remove the position lines (1).
Select the cell properties in the cell
browser (double-click on icon (2)).
Select the Chui Welt tab.
Uncheck the Zeige Positionslinien check box (3).

Z-KAE-TRN-Roboguide-1/01

34

Change the background color


Click on Tool and select Optionen .
Select the Farben tab.
You can change the background color
in this window.

Z-KAE-TRN-Roboguide-1/01

35

Explanation of icons
New cell

Help

Open a cell
*Process Navigator
Save a cell
Undo
Open the cell browser
Use the process navigator for a step-by-step work cell creation.

Select to directly
approach a

Display teach tool


(TCP)

- Face
- Edge
- Vertex

To set target points,


e.g. point in space.

Move to retry
To reach positions
that are out of reach
by using another axis
configuration.

Display speed controller

Display motion
coordinates

Z-KAE-TRN-Roboguide-1/01

36

Explanation of icons
Call alarm screen

Graphics mode
(may be applied
only in connection
with parts)

Call web server

Open/close tool
(may be applied only in
simulator programs or
with dynamic tools)

Start AVI recording

Use teach pendant

Display robot
work cell

Cycle start

*Open
Run Panel
See next
page

Error Reset

Pause
Cancel

Z-KAE-TRN-Roboguide-1/01

37

Explanation of icons
The Run Panel
In the Run Panel, you can select settings for the AVI recording as well as for the
automatic mode.

*Open
Run Panel

1
Kollisionserkennung: Enables the collision detection
Sammle TCP: TCP motion path is displayed (1)
Geteachte Bahn sichtbar: The taught path is displayed (2)
Fenster ausblenden: You can display or hide the Run Panel window
Anzeige erneuern: Must be enabled
Komprimiere AVI: Must be enabled
Simulationszeit auf AVI: The AVI time may be displayed in the AVI

Z-KAE-TRN-Roboguide-1/01

38

Explanation of icons

Zoom

Center selected
object

Measuring tool

Mouse commands

Change view

Orthogonal
views

Z-KAE-TRN-Roboguide-1/01

Grid representation

39

Check the reachability with a mouse click (Option 1)


Press and hold down the
SHIFT + CTRL keys on your computer keyboard.
Place the cursor and click at a point
(a small line shows the Z direction)
where the robot is to move.
The TCP (green) jumps to this point and
the robot follows.
If the color of the TCP changes to red
this position is not within reach.

Reachable (green TCP)

Z-KAE-TRN-Roboguide-1/01

Not reachable (red TCP)

40

Check the reachability with a mouse click (Option 2)


2

Open the Quickbar (1) with the according icon (2).


With a mouth click, select a point where the
robot is to move.
Face: Face
Edge: Edge
Vertex: Vertex (corner point)
Arc Ctr.: Center point (can be used only under certain conditions)
Place the cursor and click on a point
(a small line shows the Z direction)
where the robot is to move.

The TCP (green) jumps to this point and


the robot follows.
If the color of the TCP changes to red
this position is not within reach.

Face

Z-KAE-TRN-Roboguide-1/01

Edge

Vertex

41

Check the reachability (Option 3)


The robot may be moved via the triad and the
mouse.
Enable the icon.
Drag the triad with the mouse
to the desired position.
The robot follows the TCP.

Z-KAE-TRN-Roboguide-1/01

42

Set a user frame


Figure 1
1
Move the robot TCP to a vertex
of the conveyor belt (Figure 1).
Open the path, as shown
in Figure 2.
Check the Bearbeite UFrame check box (1).
Click on Use Current TCP Location (2).
The user frame (3) is displayed and may be
positioned via the triad or by means of direct entry.
Click on the Aktiviere button and then on OK .
Figure 2

Z-KAE-TRN-Roboguide-1/01

43

The teach pendant


You can use all functions of the
teach pendant.

Use
teach pendant

Bei der Version V


6.40 (Rev B) kann
das i-Pendant in
Verbindung mit der
Applikations-Software
FANUC Handling
Tool nicht genutzt
werden.
Wenn Sie mit dem iPendant arbeiten
wollen, mssen Sie
die ApplikationsSoftware Handling
Tool (N.A.) benutzen

Display current position or enter


current position. Use MoveTo
to approach current position.

Z-KAE-TRN-Roboguide-1/01

Data backup path

44

Create programs on the teach pendant


On the teach pendant, you can create
virtual reality programs.
In addition, the programs are displayed in the cell browser.

Z-KAE-TRN-Roboguide-1/01

45

Create programs in the cell browser


You can choose between two methods to
create a program in the cell browser.
1. Simulator Program
2. Teach Pendant Program (TP)

(Known procedure)

Create a simulator program

Select Simulationsprogramm
zufgen .
Give a name to your program (1).
Select the Simulation subtype (2).
Click on the Aktiviere button and then on OK .
The window (3) is still visible.
3
In the Record menu, you can
teach positions.
In the Inst menu, you can insert Wait/Call
and Remark
(Pickup and Drop will be explained later.)
Use FWD and BWD to start
the programs.
Convert your simulator program into
a TP program.

Open the properties of the


program (5).
Select the None (TP) subtype.
The program is displayed on the select screen
on the teach pendant.

Z-KAE-TRN-Roboguide-1/01

46

Start programs
You can start programs from the teach pendant
or the Run Panel.

Start programs from the teach pendant

(Known procedure)
In the Ansicht menu, you can select the following
items (2).

You can change the positions by means of the triad


and the mouse.
Click on the triad. If the triad is
displayed as in Figure 3, you can
change the positions.
This change is immediately
updated in the program.

Figure 3

Z-KAE-TRN-Roboguide-1/01

47

Start programs
Start programs from the Run Panel
Select the program in the
cell browser (no double-click).
Open the Run Panel (1) and enable
the desired settings.
Start the program (2).

If Sammle TCP has been enabled, the


movement of the TCP is recorded (3).
If you want to remove the connecting lines (4),
disable the appropriate function in the
Ansicht menu (see Start programs from the
teach pendant).
1

Record AVI
Use the record button to create
an AVI file.
After the AVI file has been created, the storage path
is displayed.
In case of not registered versions (30-day demo)
a message appears to report that this version has not been
registered.
Note: If you have enabled the Starte Programm
in Schleife function,
you have to end the AVI recording
with the Cancel button.

Z-KAE-TRN-Roboguide-1/01

48

Measuring tool
This example explains how to measure the width
of the conveyor belt.
Open the measuring tool (1).
Click on the Von button (2).

1
2

This button has been enabled

Place the cursor on the


vertex (3).
Click on the Nach button (4).
Place the cursor on the
opposite vertex (5).
3

or

Z-KAE-TRN-Roboguide-1/01

49

Measuring tool
Record dimensions
Use the button (1) to record dimensions
in the cell browser.
Thus, you can display these dimensions
at any time.
1

Specifiy measuring points


Use the button (2) to specify the starting
and end point of
the measurement.
Entity: The selected point
Ursprung: From the origin
If a measurement starts from the robot,
you have these additional choices,
see Figure 3.

Z-KAE-TRN-Roboguide-1/01

Figure 3

50

Measuring tool
Define and change the distance between two components
Generate a layout with two boxes.
Measure from origin to origin.
Record the dimensions in the cell browser.
Open the recorded dimensions in the cell
browser.
Enter a number in the X/Y/Z or D box
to position the objects.

Z-KAE-TRN-Roboguide-1/01

51

Measuring tool
Define dimensioning lines

Select the Extrusion tab.


Click on the mm value of the X measurement and drag the dimensioning line
in position.
Click on the OK button.
Open the window again.
An X should now be displayed in the Extrusion window.
Select the X and change the position of the dimensioning line in the Erweitern
(L) and the Winkel boxes.

Z-KAE-TRN-Roboguide-1/01

52

Add parts
The following simulations are possible with a part:
1. You can move parts.
2. You can draw on parts (path generation, see Path generation ).

Add a part
Open the cell browser.
Click on Teile with the right mouse button.
Add a part (BOX).
The part properties will be displayed (1).
The part has been placed (2).
1

Z-KAE-TRN-Roboguide-1/01

53

Add parts
Shift parts
Click on the base plate of the part (1).
Shift the part by means of the triad
to a position in the layout, so that it
2
will not be visible in an AVI recording or
a screen shot.
Regard this position as a pseudo-storage location.

Change part properties


In the Property window, you can change names,
colors, dimensions, and the weight.

Z-KAE-TRN-Roboguide-1/01

54

Add parts
Link a part with a positioner
Double-click on the conveyor belt to open
the Properties window.
Select the Teile tab.
Check the check box of the desired
part (1).
Click on the Aktiviere button.

The origins of the part and the conveyor belt


will be linked (2).
Check the Bearbeite Teile Offset
check box (3).
Position the part by means of the triad or
direct entry (4).
2

In order to complete the procedure, click


on Ativiere and then on OK (5).

5
Z-KAE-TRN-Roboguide-1/01

55

Add parts
1. Prepare a part for a pick-and-place simulation
By means of a simulator program, you can pick
and place parts.
The description below explains the necessary
settings step-by-step.
Create a work cell as displayed in the figure below.
Tool mit TCP

Positioner 1
Conveyor belt
Link part with conveyor
belt and position

Positioner 2
Table

In this simulation, the robot is to pick the part (1) from the conveyor belt and
place it on the table.

Z-KAE-TRN-Roboguide-1/01

56

Add parts
2. Prepare a part for a pick-and-place simulation
Link the part with the table.
Position the part at the target position.

Z-KAE-TRN-Roboguide-1/01

57

Add parts
3. Prepare a part for a pick-and-place simulation
Link the part with the tool.
Position the part at the target position (where is the part to be positioned at the tool).
Be sure to use the correct link.
In case the tool was created by yourself, use the same LINK as shown in Figure 1.

Z-KAE-TRN-Roboguide-1/01

58

Add parts
4. Prepare a part for a pick-and-place simulation
This is how your work cell should look like.

When you click on the icon (1), the part at the tool should be removed
or inserted.

Z-KAE-TRN-Roboguide-1/01

59

Parts
1. Prepare a program for a pick-and-place simulation
Create a teach pendant program using the positions necessary for such a sequence.
The pick-and-place operations will be included later.

Ahead
Table

Start

Ahead
Belt
Pick Belt

Z-KAE-TRN-Roboguide-1/01

Place
Table

60

Parts
2. Prepare a program for a pick-and-place simulation
Insert blank lines (see figure).
These lines will be needed for the
pick-and-place operations.

Z-KAE-TRN-Roboguide-1/01

61

Parts
3. Prepare a program for a pick-and-drop simulation
Before you can complete the programs, you have to make some adjustments to the
properties (tool, conveyor, and table).
Make the following adjustments:
Tool adjustments

Z-KAE-TRN-Roboguide-1/01

Table adjustments

Conveyor adjustments

62

Parts
4. Create a pick program (simulator program)
Open the Programme path.
Click on the item
Simulationsprogramm zufgen
with the right mouse button.
You will see Figure 3.
Name your program (1)
Pick and click on the Aktiviere
button and then on OK .

Figure 3

Figure 4

Z-KAE-TRN-Roboguide-1/01

63

Parts
5. Create a pick program (simulator program)
Select Inst > Pickup.
You will see Figure 2.

Figure 2

Set the following items.

Close the window and store the program with


the following procedure.

Z-KAE-TRN-Roboguide-1/01

64

Parts
6. Create a drop program (simulator program)

Open the Programme path.


Click on the item
Simulationsprogramm zufgen
with the right mouse button.
You will see Figure 3.
Name your program (1)
Drop and click on the Aktiviere
button and then on OK .

Figure 3

Figure 4

Z-KAE-TRN-Roboguide-1/01

65

Parts
7. Create a drop program (simulator program)

Select Inst > Drop.


You will see Figure 2.

Figure 2

Set the following items.

Close the window and store the program with the following procedure.

Z-KAE-TRN-Roboguide-1/01

66

Parts
8. Complete a simulator program
To edit your sequence program, use the following procedure.

Start your sequence program in the Run Panel (program must be stored in cell
browser).

Z-KAE-TRN-Roboguide-1/01

67

Parts
9. Other options to create a simulator program
You can insert and remove parts by means of the pick-and-drop programs at any
time.
In order to do so, you have to create the following simulator programs.
If you create and call this program, the part on the conveyor belt will be positioned.

If you create and call this program, the part on the table will be removed from the
layout.

Z-KAE-TRN-Roboguide-1/01

68

Machines
General
If you create a machine, you can make components
movable.
Examples:
The door of a machine is to be opened and
closed.
A conveyor belt is to move.
A press is to be opened and closed.
Etc.
There are two methods to open and close a door:
Using a digital output (DO)
Using a servo motor

Movements must comply with the following rule:


Rotational and linear movements have to be executed around or in z direction
respectively.

Z-KAE-TRN-Roboguide-1/01

69

Machines
1. Create a machine (actuated via DO)
In this example, you have to create a machine
in the form of a simplified conveyor belt.
The movement is to be actuated via a digital
output.
Remove the existing conveyor belt from your
simulator work cell (properties).
Add a box with the following
dimensions (1) and place the box
in front of the robot.
Rename the box. The new name should be
Grundelement (2).

Z-KAE-TRN-Roboguide-1/01

70

Machines
2. Create a machine (actuated via DO)
Click with the right mouse button
on Grundelement and select Link
zufgen and then Box .
The box has been placed (1).
Rename the box. New name: Schlitten (2).
Click on the button (3) (the motor orientation
will be displayed as a triad).
2

Orient the triad as


described below.
For W set
90 or -90.
The triad is repositioned.
Click on the button (4).
Select the
Link CAD tab.

Z-KAE-TRN-Roboguide-1/01

71

Machines
3. Create a machine (actuated via DO)
Position the slide (Schlitten) by
means of the triad or direct entry (2).
Change the color of the slide.
Select the Motion tab.
2

Make the settings


according to figure 3.
Adjust the time value (3).
The number (4) specifies the
distance.
Set the outputs in the TP program
in order to make the slide move.

1
Fig. 3
3

Z-KAE-TRN-Roboguide-1/01

72

Machines
1. Create a machine (actuated via servo)
The layout is identical with the layout for
the machine actuated via DO.
Except for the type of actuation
and the configuration of the additional axis.
Create a new robot work cell and make the following
selections:

Z-KAE-TRN-Roboguide-1/01

73

Machines
2. Create a machine (actuated via servo)
Configure the additional axes as shown below:
1

Z-KAE-TRN-Roboguide-1/01

74

Machines
3. Create a machine (actuated via servo)
7

10

11

12

Z-KAE-TRN-Roboguide-1/01

75

Machines
4. Create a machine (actuated via servo)
13

14

15

16

17

18

Z-KAE-TRN-Roboguide-1/01

76

Machines
5. Create a machine (actuated via servo)
19

20

The work cell has been created.

Z-KAE-TRN-Roboguide-1/01

77

Machines
6. Create a machine (actuated via servo)
Create the basic element (Grundelement) of the machine

Create the link Schlitten (slide).

Z-KAE-TRN-Roboguide-1/01

78

Machines
7. Create a machine (actuated via servo)
Select (1) and position the slide by means of the triad or by direct entry
as shown below.
1

Select the Motion tab and make the following settings.

To complete the procedure, click on Aktiviere and then on OK .


You can now use the additional axis in your programs.

Z-KAE-TRN-Roboguide-1/01

79

Replace the robot in an existing work cell


1

Open the robot properties and click


on the button (1).
Select the desired robot type in
the wizard.
Click on the Aktiviere button.
The new robot type is read in.
All data, except for the TP programs are
restored.
However, you can copy (2) and paste (3)
the TP programs.
After the copy-and-paste procedure, you can load the
programs on the teach pendant.
The programs do not have to be re-taught.

Z-KAE-TRN-Roboguide-1/01

80

Add a second robot


You can add a second robot to an existing
layout. The number of robots that may be added
is limitless.
Use the wizard to configure the second
robot.

Teaching is possible for both robots.


Make sure on the teach pendant display (2)
that the correct robot is activated.
If the wrong robot is activated, keep the
teach pendant activated and click on the
desired robot.
2

Z-KAE-TRN-Roboguide-1/01

81

Generate a path (Automatic program generation)


1

General
Use the graphics function (1) to generate a path (program)
automatically.
You can use the graphics function only in connection
with parts.
You can choose between the following options:
Edge line (2)
Freehand line (3)
Surface fit line (projection on surface) (4)
Curve (5)
3

2
3
4
5

Z-KAE-TRN-Roboguide-1/01

82

Generate a path (Automatic program generation)


Procedure for path generation related to an edge

Select the part (single mouse click).


Open the graphics icon menu.
Click on the edge line symbol (Kantenlinie).
Move the mouse cursor along the
edge. The distance is displayed
e.g. 78.1 mm).
Use a double-click to complete the
selection of the desired section.
The window (1) is
displayed.
Name the program (2).
Check the settings (3).
Click on the button (4).
You have created a program with an approach and a return position.
A feature and a segment have been created in the cell browser (5).
Segments may be segmented.

5
4

Z-KAE-TRN-Roboguide-1/01

83

Generate a path (Automatic program generation)


Procedure for path generation related to an edge
Change the approach and return position

You can modify the approach and return position


when opening the Nherung/Rckzug tab (1).
When you do not wish to use an approach or return
position, you can disable these functions.

After such modifications, you have to


regenerate the program. The old version will be
overwritten (3).

Z-KAE-TRN-Roboguide-1/01

84

Generate a path (Automatic program generation)


Procedure for path generation related to an edge
1

1. Other setting options (feature)

Program settings (1)


(self-explaining)

Position standards (2)


This setting specifies the
tool orientation for the path generation.

TCP

Z-KAE-TRN-Roboguide-1/01

85

Generate a path (Automatic program generation)


Procedure for path generation related to an edge
2. Other setting options (feature)

On the Raw Normals tab (1), you can define


the start and end angle position.
In this example, the start angle
position is 30 degrees and the angle position at
the end of the path is -30 degrees.

Z-KAE-TRN-Roboguide-1/01

86

Generate a path (Automatic program generation)


Procedure for path generation related to an edge

3. Other setting options (feature)

On the Pos Offsets tab (1), you can specify the


following settings.
2
2. Translation relative to the standard
position

3. Translation relative to the segment

3
2
4
2
5
2
6
2

4. Offset in Z
5. Offset in X
6. Offset in Y
7.
8.
7
9.
10. Rotation around Z
11. Rotation around X
12. Rotation around Y

8
9
10
12

13.
14.

11

13
14

Z-KAE-TRN-Roboguide-1/01

87

Generate a path (Automatic program generation)


Segmentation
Generate a path (1).
Open the graphics window (2)
and click on Bearbeiten (3).
Click on Segment1 in the cell browser.
The Segment teilen button (4) is active.
Click on the button (4).

The segment is divided (Figure 4 and 5).


For segment 1 and 2, you can now specify
different settings.
A further segmentation is possible.
After a segmentation, you can
shift the segmentation points with the mouse
and adjust them.

Figure 4

Z-KAE-TRN-Roboguide-1/01

Figure 5

88

Target points
1

Use the target points (1) to specify positions.


You can choose between the following options:
Define positions in space (2).
Define positions on a surface (3).
Define positions at the TCP (4).
When you select button (2) together with button (5),
the points in space are stored in a target group.
You can also specify a target group separately
at a later point.

3
4
5

Define target points as points in space


Click on the Air button and specify
points in space using the mouse.
The target points are displayed as a
coordinate system.
The targets are also displayed in the
cell browser.
In order to create a program from these
targets, you have to define a target
group.
For explanations, see next page.

Z-KAE-TRN-Roboguide-1/01

89

Target points
1. Define a target group
Select Target Groups and then Add Target
Group .
Click on Abbruch (1).
The target group has been established (2).
Open the target group properties (3).

Z-KAE-TRN-Roboguide-1/01

90

Target points
2. Define a target group

Specify a program name (1).


Click on the Members button (2).
Assign the targets (3) to the group (4).
Click on Aktiviere (5) and then on OK (6).

Z-KAE-TRN-Roboguide-1/01

91

Target points
3. Define a target group

Select a motion line (1).


Select the Target Edit tab (2). You will see the screen in figure 2.
You can now adapt the sequence to your needs, e.g. you can disable
Approach and Retreat (3) or the interpolation (4).

Figure 2

Select the Generation Parameters tab.


Click on the Erstelle Muster TP Programm button.

Z-KAE-TRN-Roboguide-1/01

92

Target points
Define target points on a surface and assign a positioner
General
This method is used to assign target points to
a positioner (e.g. a box).
When shifting the box, the
target points are also shifted.
Of course, you can define targets on surfaces
without defining interactions.

1. Procedure
Use the Surface button to generate 3 points on the surface of a box.
Open the properties of each target
point and select the box under Attached (1).
The target points are displayed in the cell browser
under the box (2).

From here on, the procedure is identical with the procedure for defining points
in space.

Z-KAE-TRN-Roboguide-1/01

93

Create a dynamic tool

General
To create and simulate a dynamic tool,
you need two different models.

Procedure
Create a new work cell.
Import the 36005f-200.CSB model
as the tool (known procedure).
Select the Simulation tab
and add the 36005f-200-4.CSB model
using the icon (1).
Use the ffnen/Schlieen buttons (2) to
check whether the gripper opens and/or
closes.
You can also use the symbol
for this check.
The opening and closing is
realized in a program sequence by means of the
Pick or Drop simulator programs (see Parts).
Note
The parts that are to be moved have to be
defined on the Teile and Simulation
tabs (3).

Z-KAE-TRN-Roboguide-1/01

94

New functions as from V.6.40 Rev. C


Projects

Z-KAE-TRN-Roboguide-1/01

95