You are on page 1of 1

algoritmo "CONSTRUIR UM PROGRAMA QUE LEIA A IDADE DE 10.

"A CADA LEITURA O PROGRAMA DEVE VERIFICAR SE O RESULTADO DA MEDIA É UM NUMERO PRIMO. "AO FINAL O PROGRAMA DEVE APRESENTAR A QUANTIDADE DE VALORES PRIMOS(SE HOUVER) - 23-04-2013" var i,j,idade,totalidade,cont,contprimo,mediaint,mediainteiro:inteiro media:real inicio totalidade <- 0 //contador para somar os valores digitados contprimo <- 0 //contador para somar a quantidade de valores primos encontrados para i<-1 ate 10 faca //repetiçao para os valores digitados cont <- 0 //contador para somar a quantidade de divisoes exatas encontradas, começa dentro do 1º PARA, pois será usado no 2º PARA na verificaçao dos numeros primos escreva("digite uma idade: ") //digite um valor leia (idade) //guarda o valor digitado escreval //pula uma linha // 0 valor digitado ex.: IDADE=15 entao TOTALIDADE = 0 + 15 = 15 totalidade <- totalidade + idade se i>1 entao //começa a operar somente a partit da 1ª repetiçao(segundo valor), o primeiro valor nao gera soma e por isso nao tem media media <- (totalidade / i) //MEDIA recebe a media dos valores a partir da 1ª repetiçao(segundo valor) mediaint <- int(media) //MEDIAINT guada o valor da media convertido para tipo inteiro (se MEDIA = 2,5 entao MEDIAINT = 2) escreval("valor total:",totalidade," quantidade de valores:",i) escreval("media:",media) escreval //apresenta os valores para confirmaçao

se mediaint = media entao //vai comparar se a media encontrada é igual a ela mesma do tipo inteiro(MEDIA = 2,5 <>(difirente de) MEDIAINT = 2) mediainteiro <- mediaint //se igual, a variavel MEDIAINTEIRO guarda o valor da media tipo inteiro(MEDIA = 2 = MEDIAINT = 2) MEDIAINTEIRO <- MEDIAINT = 2 senao mediainteiro <- 0 //caso nao seja verdade a igualdade entre MEDIA e MEDIAINT entao MEDIAINTEIRO recebe 0 para nao ficar sem valor e assim evitar erro no programa fimse para j <-1 ate (mediainteiro) faca //repetiçao para verificaçao dos numeros primos ou nao primos se (mediainteiro mod j) = 0 entao //caso, encontrada alguma media inteira, se houver alguma divisao exata entre essa media cont <- cont + 1 //e algum valor no intervalo de 1 e esse proprio valor, CONT que inicia com 0 soma com fimse //com a quantidade de divisoes exatas encontradas fimpara fimse se cont = 2 entao //se o contador registrar somente 2 divisoes exatas, é um numero primo! pois esse numero foi divisivel apenas por 1 e por ele mesmo contprimo <- contprimo+1 //entao o contador de numeros primos que inicia com 0 soma +1 escreval(mediainteiro," é um numero primo!") escreval fimse fimpara escreval("quantidade de medias com numero primo encontradas: ",contprimo) //apresenta a quantidade de medias com numero primo encontradas fimalgoritmo