Pro/ENGINEER-Mathcad Integration. Units.

Pro/ENGINEER-Mathcad Integration. Units. Dimensions. (Length, Angle, Area, Volume).

1. Introduction

The new integration between Mathcad and Pro/ENGINEER has become available as of Pro/ENGINEER release Wildfire 3.0 (datecode M030) and later.

Users can associate any Mathcad worksheet with a Pro/ENGINEER part or assembly using the Analysis feature in Pro/ENGINEER. Parameters/Dimensions from Pro/ENGINEER can be input into Mathcad for engineering calculations. Values calculated in Mathcad can be mapped to parameters & dimensions in the model to further drive the design.

This example is intended to walk users through a typical Pro/ENGINEER Mathcad Analysis setup procedure and to emphasize some basic understanding of units’ compatibility.

2. The Model. This rectangular block will fit exactly in the cut made in the triangular cross-section block. The rectangularshaped block will be placed in this location using typical Pro/ASSEMBLY constraints (Mate/Align/etc) constraints. Another rectangular shaped block is assembled to this model in a Pro/ENGINEER assembly (*.asm) file. The final assembled geometry can be seen in Figure 3.

A simple model (Figure 1.) is to be examined, a 3D block of triangular shape cross-section. The model has a cut, made on the inclined surface, of dimensions shown in Figure 2.

1.

Pro/ENGINEER-Mathcad Integration. Units.

After you have opened the Pro/ENGINEER part examine the system of units this part was created in. The same units are the ones we are going to work with in this session. Use from Pro/ENGINEER main menu: >Edit >Setup >Units to accomplish this operation. The current system of units is the Pro/ENGINEER default1 [in-lbm-sec].

Obviously, these units can be changed, converted and interpreted. But, for our example we’re going to use inch (length)-lbm (mass)-seconds (time).

From the Pro/ENGINEER Model Tree edit the definition of Sketch 1. This sketch was created such that it 3. Modeling Technique defines the cross-section for the Pro/ENGINEER 3D geometry. The following dimensions (as shown in This example will be divided in 2 main steps. Figure 4.) will be displayed.

In the first step only the triangular-shaped geometry will be examined and integrated with a Mathcad worksheet. Pro/ENGINEER model dimensions will be input to Mathcad & values calculated from Mathcad mathematical operations reported back in Pro/ENGINEER.

In the second step, the assembly will be examined and both Pro/ENGINEER dimensions & analysis feature parameters will be input to Mathcad, then Mathcad will perform the mathematical calculations and report values back in Pro/ENGINEER. These values will be later used in a Behavioral Modeling Relation analysis feature.

4. Evaluation of Distances (Length, Angle). The given dimensions are: the base (Length_1= Start this example by retrieving the model from provided Winzip files in a Pro/ENGINEER session. The name of the Pro/ENGINEER part is triangle_block.prt.
1 You can investigate Pro/ENGINEER Help Center (‘Fundamentals’) for more details on basic & derived units used in Pro/ENGINEER.

15.00 inches) and angle (Angle_1=60 degrees). From Pro/ENGINEER main menu use: >Info

2.

Length_2 and Angle_3) be computed and evaluated. etc. 3. Since the cross section is a 90-degree triangle we’re going to use trigonometry in Mathcad such that the other dimensions (Length_3. That is. >Switch Dimensions in order to see the customized names of these dimensions (see Figure 5. the purpose is to present the Mathcad-Pro/ENGINEER integration and required compatibility of units. meter2 for areas. when Pro/ENGINEER default system of units is [in-lbm-sec]. the source. . if in MKS [meter-kg-sec] system of units: use meter for length. etc. inches2 for area inches3 for volume. quantities matching units to units. Since Mathcad can accommodate both degrees and/or radians.have to match the ones from The first step of this example is to input Length_1 and Angle_1 dimensions in a Mathcad worksheet. We will write mathematical operations in the Mathcad worksheet evaluating other dimensions in the model (see Figure 6.although UI-display are in degrees (as in our case 60°). we need to use in Mathcad: inches for length.1.Pro/ENGINEER-Mathcad Integration. and unitless to unitless (where the case may seem necessary). The units for input & output -provided to or generated by Mathcad worksheet.). meter3 for volume. While the example seems rather simple. For example. in this case Pro/ENGINEER. Preparing the Pro/ENGINEER Model. Identically. Units. How about angles? What are the Pro/ENGINEER units for angles? Pro/ENGINEER angle’ units are interpreted as radians . The main requirement to be satisfied in order to integrate Pro/ENGINEER dimensions or analysis feature parameters with Mathcad worksheet is to ensure compatibility of units. 4. the change needs to be done in Pro/ENGINEER.).

we need to convert the current Angle_1 (60 degrees) value to radians. Notice the new ANGLE_1_RAD value. Add a new real number parameter. since this is value is in inches (remember After setting the units for this new parameter. this time in radians. click OK in the relation editor. 4.xmcd from the provided Winzip folder. The 4. Before verifying the relation. We have to take into account the angular units (radians). Start this operation by creating a new Pro/ENGINEER parameter called –for instance. . set the units to radians (rad) as seen in Figure 7. ensure that the relation is unit sensitive. There is no need to convert the units for the Length_1. Save the Pro/ENGINEER model. This known relation is presented in Figure 8. customize its name to ANGLE_1_RAD. Please investigate it. This can be done by selecting from the relation editor main menu: >Utilities >Unit Sensitive. Write a relation that converts the angular Open the Mathcad worksheet dimensions.2. Units. but we’ll adjust the units in the Mathcad worksheet to ensure compatibility. our system of units is “Pro/E Default” [in-lbm-sec]). This worksheet can be seen in Figure 9. and type in an initial unit value. click OK in the parameter definition window.ANGLE_1_RAD.Pro/ENGINEER-Mathcad Integration. Next. After verifying the relation. Preparing the Mathcad Worksheet. From Pro/ENGINEER main menu select: >Tools >Relations. From Pro/ENGINEER main menu select: >Tools >Parameters. We need to create a Pro/ENGINEER parameter or relation that converts angle units from degrees in the equivalent of radians. Therefore. dimension of Angle_1 from degrees to radians.

This operation can be easily identified in Figure 10. we also have to tag the output variables such In order to accomplish this interaction –from Mathcad point of view. Click on the variable Length_1 from within the Mathcad worksheet. The known angle (Angle_1) and dimension of the base (Length_1) will be input in Mathcad.we’d have to tag these variables2 to be used in reading input from & output to Pro/ENGINEER. Units. steps/formulas used to compute the angles & lengths are self-explanatory. As you probably assumed. and click in the box called Tag. The output is highlighted in green. then right-mouse button and select >Properties.Pro/ENGINEER-Mathcad Integration. and is 90 degrees. that Mathcad provides the computed output back in Pro/ENGINEER. and following computed values input back to Pro/ENGINEER: Angle_3. & 11. select the tab called Display. Now. Once in Mathcad variable’s >Properties definition window. for the other input variable (Angle_1). 5. not a variable. . Use the same procedure to complete the tag operation Note that Angle_2 is known. 2 The input variables are highlighted in blue in the Mathcad worksheet. Type in the name of the tag: proe2mc as seen in Figure 11. this is done using the same operation as depicted in Figure 10. and Length_2 & Length_3.

Mathcad Interaction. This has to be the last saved worksheet. Ensure that this file is loaded as seen in Figure 14. the worksheet that has the input/output variables already tagged with proe2mc and mc2proe. customize the name of this analysis (“DIMENSIONS”). The tag is called mc2proe as seen in Figure 12. Use the same procedure to complete the tag operation for the other 2 output variables (Length_2. Click on the variable (Angle_3) . the dimensions and/or parameters are input from and read back in Pro/ENGINEER through the Analysis feature tool. 6. Units. After you complete these last steps. In the next window we need to load the saved Mathcad worksheet that is stored in the working directory. Similar to Behavioral Modeling’s Excel Analysis feature. 3 Another selection of menu picks yielding similar outcome is: >Analysis >Mathcad Analysis (see Behavioral Modeling Help Center for differences between these 2 operations). and retrieve the Mathcad worksheet called dimensions.Pro/ENGINEER-Mathcad Integration. save the Mathcad worksheet and close the window.xmcd.e. Click the Load File button. i. This selection of menu picks3 will bring up the Analysis main definition window (Figure 13.right-mouse button and select >Properties. Select the radio button called Mathcad Analysis – optionally. Access from Pro/ENGINEER main menu the followings: >Insert >Model Datum >Analysis.3. . Length_3).and click the Next button. Pro/ENGINEER.). 4.from within the Mathcad worksheet .

Pro/ENGINEER interface should provide the Mathcad variable that you’ve tagged in the previous steps (Length_1) as seen in Figure 17.Pro/ENGINEER-Mathcad Integration. After you have accessed Add Dimension. Units. After you’ve selected this dimension. Once the Mathcad file is loaded. click with the pointer of the mouse the 3D geometry. access the dimensions of the triangular shaped model. Select the 15 inches dimension as seen in Figure 16. such that we can 7. click button Add Dimensions (as seen in Figure 15) such that we can access the dimensions of the model (the 1st one is Length_1) and input them to Mathcad. .

Pro/ENGINEER will ask for the selection of tagged variable from Mathcad (see Figure 20. Investigate units’ compatibility in Pro/ENGINEER’s Select this ANGLE_1_RAD parameter. we need to select Pro/ENGINEER parameters for our next input (Angle_1).). Before proceeding with the next input selection (Angle_1). Thus. Click in the Mathcad Analysis definition window for Add Parameters as see in Figure 19. This operation will allow us to select Pro/ENGINEER parameter ANGLE_1_RAD that we have created in our previous steps. and click OK in the Input Selection definition window. . investigate units’ compatibility in Pro/ENGINEER’s Pro/E to Mathcad definition window (see Figure 18. we will maintain compatibility of units between Pro/ENGINEER and Mathcad worksheet. Units.Pro/ENGINEER-Mathcad Integration. Next.). Select this variable.). 8. Pro/E to Mathcad definition window (see Figure 21. Also. and click OK.

Units. The system will provide the tagged parameters from Mathcad that evaluate Length_2.) click Compute button such that Mathcad can provide computed values for these variables (Angle_3. Angle_3. and Length_3). Click on the button called Outputs as seen in Figure 22. Length_2. Next. This last operation completes the input from Pro/ENGINEER to Mathcad. In this example. Check the boxes for the parameters that you need evaluated and input back in Pro/ENGINEER.) and select OK. Length_3 and the angle. . we need to retrieve the output from Mathcad worksheet (all the computations are performed by Mathcad) and provide it back in Pro/ENGINEER. Once all the input & output has been specified in the Mathcad Analysis definition window (see Figure 24. check the boxes for all 3 measures (see Figure 23. we need to use the same Mathcad Analysis definition window. In order to accomplish this operation.Pro/ENGINEER-Mathcad Integration. 9.

We intend to use these parameters for future Pro/ENGINEER use.4. Complete this Pro/ENGINEER feature by clicking . the units for Angle_3 were evaluated by Mathcad in radians and read as such in Pro/ENGINEER.Pro/ENGINEER-Mathcad Integration.converting Angle_3 from radians (as currently evaluated) back in degrees. Mathcad will compute the values and report them in the Mathcad Analysis definition window under Results as seen in Figure 25. 10. . Units. parameter and convert it from radians in degrees for future use in the model. As you’ve already noticed. Pro/ENGINEER Postprocessing of Mathcad Analysis Data. as -for instance. This was necessary because we needed to ensure units compatibility. In this subsection of suggested technique we will use the just created Mathcad Analysis’ MC_Angle_3 Click Close from the Mathcad Analysis definition window. 4. and create Pro/ENGINEER parameters from these measures as seen in Figure 26.

Next. parameters will update accordingly. Once this operation is completed. and notice the updated value for this angle. we’d like to set a certain angle in the model equal to this new angle value and. Click OK in the relation editor definition window. As expected. Create a new Pro/ENGINEER parameter –let’s name it ANGLE_3_DEG. For instance. now in degrees. click OK in the parameter definition window. The advantage of using Mathcad Analysis feature & parameters is that any Pro/ENGINEER changes made in the model will be reflected in the computations and therefore. This can be accomplished by using from Pro/ENGINEER main menu: >Tools >Parameter. and Angle_2 is 90 degrees.of unit value. . the value has to be in degrees for Pro/ENGINEER to interpret it correctly. from Pro/ENGINEER main menu select: >Tools >Relations. 11. Units. Write a relation that converts the Mathcad MC_ANGLE_3 parameter from radians in degrees.). obviously. Do not specify units for this parameter. Verify the relation (see Figure 28. since Angle_1 is 60 degrees.Pro/ENGINEER-Mathcad Integration. this ANGLE_3_DEG value is 30 (degrees).

and erase models from session. Integrating Mathcad Analysis Parameters in Pro/ENGINEER Analysis Features. Align. These 2 parts were assembled using regular Pro/ASSEMBLY constraints (Mate.prt will be evaluated assembly as: 12.) rectangular_block. regenerate and save the model. The purpose of this example is to help end users understand the Pro/ENGINEER-Mathcad This last operation completes the first section of the suggested technique. and then identify the new values for ANGLE_1_RAD. and used to evaluate Pro/ENGINEER Relation analysis feature parameters in the assembly model. We plan to evaluate the total volume & mass of the 5. integration. Restore the original angle value (back to 60 degrees). etc).prt will be evaluated from a Pro/ENGINEER Mass Properties analysis feature. 60 degrees) to 45 degrees (see Figure 29. The volume & mass of the rectangular_block. The assembly has 2 components (parts): triangle_block. These new values updated accordingly (see Figure 30. Retrieve in Pro/ENGINEER assembly 3d_asx. and obviously ANGLE_3_DEG.prt and Regenerate the model. Units. The volume & mass parameters of the triangular_block. change dimension Angle_1 (currently. . The following steps and parameters can be attained/evaluated through different methods in Pro/ENGINEER. Close Pro/ENGINEER window. For instance.asm from the provided Winzip file.prt.Pro/ENGINEER-Mathcad Integration. Another Mathcad-Pro/ENGINEER integration example will be investigated in this section: Pro/ENGINEER Mathcad Analysis parameters will be input back in Pro/ENGINEER.).

4 13.prt in a Pro/ENGINEER window and select from main menu: >Analysis >Model >Mass Properties. It is worth mentioning that the rectangular shaped block & triangle Pro/ENGINEER parts are made of different materials. Verify the units for each part as: retrieve each assembly part in Pro/ENGINEER and use >Edit >Setup >Units. where each Pro/ENGINEER part may or may not use similar system of units.1. select tab Definition. . basic units for: Length is (inches). Mass (lbm). Preparing the Pro/ENGINEER Assembly Model.Pro/ENGINEER-Mathcad Integration. This can be accomplished by accessing from Pro/ENGINEER main menu: >Edit >Setup >Units. Select radio button Feature under the tab entitled Analysis as seen in Figure 32.or underevaluate the total values as a result of mismatching units.) a density equal to 0. That is. customize In the end. 5.asm assembly model. the name of this analysis feature to MASS_PROPS_TRIANGLE. Units. This operation is needed so we can plan accordingly the Mathcad worksheet. but we will evaluate these 2 quantities using Mass Properties Analysis feature. Start by examining the system of units used in the current 3d_asx. using Pro/ENGINEER Mathcad Analysis feature.asm assembly will be evaluated using a Pro/ENGINEER Relation analysis feature. Remember that these are the units at the assembly level. Notice that assembly4’s current system of units is “Pro/E Default”. You may over. and Time (seconds). Open triangle_block. Use default coordinate system for computations. the total mass & volume of the entire 3d_asx. and specify (see Figure 33.prt) Pro/ENGINEER part. This step is very important since we’re about to evaluate the total volume & mass of the assembly. We need to evaluate the mass and volume of the triangular-shaped (triangle_block.29 lbm/in3. The Mass Properties definition window will be displayed. There are several procedures to accomplish this. Optionally. Next.

we can deploy the same method for the rectangular shaped component of the assembly. Check boxes for VOLUME & MASS such that the Mass Properties analysis feature parameters are created. These 14. In the first stage set the list of input for the Mathcad worksheet. Open rectangular_block. evaluate its mass. Click for Pro/ENGINEER to compute the mass mathematical operations will be performed in Mathcad. further computations. These parameters report the volume (in3) and mass (lbm) for the triangle_block. Obviously. . .). & 36. These are the dimensions in the model as presented in Figure 35. we will use a Pro/ENGINEER Mathcad Analysis feature. The plan is to evaluate the volume of the block as surface area times the depth of the block. and through the help of Mathcad Analysis feature input back in the Pro/ENGINEER model for properties’ values Click tab Feature (Figure 34. Units.Pro/ENGINEER-Mathcad Integration.prt component. Then. Complete this Pro/ENGINEER feature by clicking Save the model and close the Pro/ENGINEER window. using the known material density value.prt in a separate Pro/ENGINEER window. Instead.

the input from (or output to) Pro/ENGINEER & Mathcad worksheet variables have to be compatible. volume and mass of the rectangular block component. Specify the value for this parameter as 0. Open the supplied asx_dimensions_try1. and Volume_R_Block (or Volume.) called DENSITY. Width.Pro/ENGINEER-Mathcad Integration. We have specified in the Mathcad worksheet the input for (Length. we need to input the material density in the Mathcad worksheet. we need to examine the Mathcad worksheet. The unit for density in “Pro/E Default” is [lbm/in3]. Preparing the Mathcad Worksheet. From Pro/ENGINEER main menu access: >Tools >Parameters.2. in general) is L (liters).12 lbm/in3. Units. Next. Examine this worksheet. But. As mentioned in our previous example. so good! We have all the input required to compute surface area. 15. in general) is m2.xmcd worksheet in Mathcad. notice in the Mathcad worksheet that the default unit for Surf_Area (or Area. and Depth) in inches. Create a new real number parameter (see Figure 37. This can be identified in Figure 38. Also. . and specify the units as per “Pro/E Default” system of units. mainly concentrating on the units provided for the input from and output to Pro/ENGINEER. the units of So far. 5.

16. get a better understanding of this units’ compatibility. and therefore we had adjusted this unit to the closest found [lb/in3].3. Units.): asx_dimensions_try2.xmcd. With rectangular_block. 3 3 2 2 2 Next. we need to tag -in the Mathcad worksheet -the input (using the tag: proe2mc) and output variables (using: mc2proe). These units (in . access from main menu: >Analysis >Mathcad Analysis. Also. Save the Mathcad worksheet as asx_dimensions_try2. we need to adjust the units for Surf_Area from m to in . This operation can be accomplished using identical steps mentioned in Section 4. You can close Mathcad worksheet window for the time being. Mathcad does not have [lbm/in3] units for density (variable Density_R_Block).2. Thus. But. Pro/ENGINEER-Mathcad Interaction. the interaction between the Pro/ENGINEER and Mathcad is accomplished through the Mathcad Analysis feature. and Volume_R_Block from L (liters) to in . & in ) are Pro/ENGINEER corresponding units when using “Pro/E Default” system of units. From within Mathcad Analysis definition window load (click Load File) the last saved version of the Mathcad worksheet (Figure 40.xmcd.Pro/ENGINEER-Mathcad Integration. This operation will bring up the Mathcad Analysis definition window. we will pursue this example as is and attempt to troubleshoot the issue later on in the example. 5.prt still opened in Pro/ENGINEER. Since all our units have to be compatible. We predict that the density units in Mathcad [lb/in3] are not matching Pro/ENGINEER’s [lbm/in3]. . The updated worksheet can be seen in Figure 39. the unit for mass (Mass_R_Block) in the Mathcad worksheet is going to be [lb] (pounds). of this suggested technique. Therefore. As previously mentioned in the beginning of the suggested technique.

Select the dimensions from the model using the pointer of the mouse and selecting the appropriate Mathcad variables as prompted by the system. and DEPTH) and DENSITY parameter in the Mathcad worksheet.Pro/ENGINEER-Mathcad Integration. All this after you have successfully loaded the Mathcad worksheet in Mathcad Analysis definition window. WIDTH. - For WIDTH as seen in Figure 43: This can be accomplished using Add Dimensions button from Mathcad Analysis definition window (Figure 41). Units. . 17. - For LENGTH as seen in Figure 42: We need to input Pro/ENGINEER dimensions (LENGTH.

we have to specify the DENSITY parameter from Pro/ENGINEER. The input of dimensions is to be specified as in Figure 45. This operation will bring up the Parameter Selection definition window (see Figure 47. - For DEPTH as seen in Figure 44: This was tagged in Mathcad for variable Density_R_Block. Click button Add Parameters from the Mathcad Analysis definition window as seen in Figure 46. Ensure that you click OK after each selection of Mathcad variables from Input Selection definition window. Next. . 18.Pro/ENGINEER-Mathcad Integration. Units.).

Pro/ENGINEER-Mathcad Integration. How to troubleshoot this kind of problem? There are several solutions: we can specify DENSITY parameter without units. Units. Also. 3 We have also specified Mathcad worksheet with units as [lb/in3]. and maintain the identical format in the Mathcad worksheet for Density_R_Block. Pro/ENGINEER cannot provide this unit to Mathcad worksheet as a fraction. Click OK in the error confirmation window. Troubleshooting Pro/ENGINEERMathcad Units Incompatibility.) in units of [IlbmS_dens_unit]. 5. 3 The DENSITY parameter from Pro/ENGINEER although specified in [lbm/in3] was reported in the Mathcad Analysis’ Parameter Selection window (see Figure 47. Pro/ENGINEER will prompt you the following error message: “No properly tagged compatible Mathcad variable found” (Figure 48. But the units for variable Density_R_Block are specified in the Mathcad worksheet as [lbm/in ]. This becomes a unit incompatibility issue. Select DENSITY from Parameter Selection window (Figure 47. These 2 issues caused our Pro/ENGINEER-Mathcad units to become incompatible. Another possibility. report values back in Pro/ENGINEER in a similar format. .xmcd worksheet5 and adjust the units for density from [lb/in3] to [IlbmS_dens_unit] as seen in Figure 49. which was the closest system of units to our Pro/ENGINEER DENSITY parameter. we will troubleshoot this problem. Therefore. and after Mathcad computations. we will present the steps to be followed when troubleshooting such a particular problem. it will use [IlbmS_dens_unit]. Edit asx_dimensions_try2. Next.) and click OK. is to use Mathcad tools to adjust the system of units. First of all notice the units for the Pro/ENGINEER parameter DENSITY.). or we can create a new customized unit in Pro/ENGINEER that has a compatible unit in Mathcad. We have specified in Pro/ENGINEER the units for DENSITY as [lbm/in ]. 5 This worksheet is available already since using Load File button (see Figure 41) from Mathcad Analysis definition window brought up the Mathcad worksheet up as well 19. and the one used in this technique. In our next steps we’ll see how both Mathcad and Pro/ENGINEER deal with this.4.

Save this worksheet. Next. The Parameter Selection window will be prompted as seen in Figure 51. Units. Click button Add Parameters (seen in Figure 46) in the Mathcad Analysis definition window. Mathcad Analysis feature will not be able to get created in the model if are not understood by Pro/ENGINEER. . Select Pro/ENGINEER parameter DENSITY. What about the units for the output variable Mass_R_Block? Are these units specified correctly? These are currently in [lb]. but do not close it! Return to the Pro/ENGINEER window to restore our last operation. Therefore. This is Density_R_Block.Pro/ENGINEER-Mathcad Integration.for the selection of the variable from the Mathcad worksheet. Select Mathcad variable Density_R_Block from Input Selection window. But. the system will prompt –without error. we need to add a new Mathcad variable that does help understanding that this [IlbmS_dens_unit] is in fact 1 [lb/in3] (see Figure 50). and click OK. and click OK. 20. this [IlbmS_dens_unit] unit is not a system of units that Mathcad can understand. Notice the new units for the Mathcad variable Density_R_Block matching the ones of Pro/ENGINEER’s parameter DENSITY (see Figure 52).

. When prompted for the output. In our next steps we will evaluate the volume and the mass of rectangular_block. 5. Pro/ENGINEER-Mathcad Interaction (Revisited) The variables that were tagged from Mathcad are: Mass_R_Block (computes the mass of the rectangular block) and Volume_R_Block (evaluates the volume of the rectangular block). Next. Units. check the boxes of the tagged Mathcad variables as seen in Figure 54. click Compute from Mathcad Analysis definition window. The final input list is seen in Figure 53. Click OK in Output Variables definition window after checking all the required boxes.5.prt from Mathcad and create the Mathcad Analysis feature & parameters. This completes our troubleshooting procedure. Select Outputs button while in the same Mathcad Analysis definition window (Figure 54.). 21. The volume and mass will be reported with the computed values (as seen in Figure 55).Pro/ENGINEER-Mathcad Integration. The computations for these 2 quantities are all done in Mathcad.

Next. This feature will be added in the model. This operation will activate the Relation Analysis feature definition window. Select radio button entitled Relation. For confirmation. and mass in [lbm]. Regenerate the assembly and access from Pro/ENGINEER main menu: >Insert >Model Datum >Analysis. customize the name of this feature to TOTAL_M_V.6. feature. Pro/ENGINEER will prompt the relation editor in the next window. . investigate the Model Tree (ensure that “Features” visibility is turned on in the Model Tree settings). This last completes this subsection of the suggested technique. Units. Click Add Feature button from the Mathcad Analysis definition window as seen in Figure 56. 5. 22. Evaluating the Total Mass & Volume of the Pro/ENGINEER Assembly In the next steps we plan to evaluate the total mass and volume of the entire assembly. and click Next. as seen in Figure 58.asm. This step will be accomplished using Pro/ENGINEER Relation analysis Rename the feature from default Analysis1 to MC_MASS_PROPS.Pro/ENGINEER-Mathcad Integration. Notice that volume is in in3. Save the model and close the Pro/ENGINEER window. we will evaluate the total mass and volume of the Pro/ENGINEER assembly using the Relation analysis feature. Activate the Pro/ENGINEER assembly window in which we had retrieved 3d_asx. Verify the units of the Mathcad Analysis feature parameters (Figure 57).

using Mathcad Analysis & other Pro/ENGINEER features. and complete this Pro/ENGINEER feature by clicking . In our last step –for easily identifying the benefits of Using the just created Pro/ENGINEER parameters (either from Mass Properties model feature in triangle_block. and identify the newly created parameters (TOTAL_VOLUME & TOTAL_MASS) in Figure 60.asm): >Tools >Parameters. This last step completes our example and suggested technique.05 lbm/in3). Access from Pro/ENGINEER main menu (after regenerating the top-level assembly 3d_asx.12 to .prt (from .prt or Mathcad Analysis feature in rectangular_block. Verify the Pro/ENGINEER relations. . Click OK from the relation editor. Units. In the parameter definition window change the Look In selector to Feature and select from the Model Tree feature TOTAL_M_V.modify the geometry of the triangle_block.Pro/ENGINEER-Mathcad Integration. Notice that they have the correct system of units.prt) write 2 relations that compute the total volume and mass of the assembly (as seen in Figure 59). Notice the total mass & volume updated values (Figure 61).prt ( 15-inch dimension to 20 inches) and density of rectangular_block. 23.