Chapter 9

Determining IP 
Routes
© 2000, Cisco Systems, Inc. 

9­1

Objectives
Upon completion of this chapter, you will 
be able to complete the following tasks:
• Distinguish the use and operation of static and 
dynamic routes 
• Configure and verify a static route
• Identify how distance vector IP routing protocols 
such as RIP and IGRP operate on Cisco routers
• Enable Routing Information Protocol (RIP) 
• Enable Interior Gateway Routing Protocol (IGRP) 
• Verify IP routing with show and debug commands
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­2

What is Routing?
10.120.2.0

172.16.1.0

To route, a router needs to know:
• Destination addresses
• Sources it can learn from
• Possible routes
• Best route

• Maintain and verify routing information
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­3

What is Routing? (cont.)
10.120.2.0
E0

172.16.1.0
S0

Network
Protocol
Connected
Learned

Destination
Network
10.120.2.0
172.16.1.0

Exit 
Interface
E0
S0

Routed Protocol: IP

Routers must learn destinations that are not 
directly connected
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­4

Identifying Static and Dynamic 
Routes
Dynamic Route

Static Route
Uses a route that a 
network 
administrator enters 
into the router 
manually

© 2000, Cisco Systems, Inc. 

Uses a route that a 
network routing 
protocol adjusts 
automatically for 
topology or traffic 
changes

www.cisco.com

ICND v1.0a—9­5

Static Routes
Stub Network
172.16.1.0

Network

SO
A

172.16.2.2

172.16.2.1

B
B

Configure unidirectional static routes to and from a stub 
network to allow communications to occur.

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­6

Static Route Configuration

Router(config)#ip route network [mask]
{address | interface}[distance] [permanent] 

Defines a path to an IP destination network or subnet

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­7

Static Route Example
Stub Network

172.16.1.0

Network
10.0.0.0

SO
A

172.16.2.2

172.16.2.1

B
B

ip route 172.16.1.0 255.255.255.0 172.16.2.1

•  This is a unidirectional route. You must have a route 
configured in the opposite direction.
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­8

Default Routes
Stub Network
172.16.1.0

Network

10.0.0.0

SO
A

172.16.2.2

172.16.2.1

BB

ip route 0.0.0.0 0.0.0.0 172.16.2.2

•This route allows the stub network to reach all known 
networks beyond router A.
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­9

What is a Routing Protocol?
10.120.2.0

Routing protocols are 
used between 
routers to determine 
paths and maintain 
routing tables. 
Once the path is 
determined a router can 
route a routed protocol.

E0

Network
Protocol
Connected
RIP
IGRP

172.16.1.0
S0

Destination
Network
10.120.2.0
172.16.2.0
172.17.3.0

Exit 
Interface

172.17.3.0

E0
S0
S1

Routed Protocol: IP
Routing protocol: RIP, IGRP
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­10

Autonomous Systems: Interior or 
Exterior  Routing Protocols
IGPs: RIP, IGRP

EGPs: BGP

Autonomous System 100

Autonomous System 200

• An autonomous system is a collection of networks 
under a common administrative domain
• IGPs operate within an autonomous system
• EGPs connect different autonomous systems
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­11

Administrative Distance: 
Ranking Routes
I need to send a packet to 
Network E. Both router B 

IGRP
Administrative 
Distance=100

and C will get it there.
 Which route is best?
Router A

Router B

RIP
Administrative 
Distance=120

Router D

Router C

© 2000, Cisco Systems, Inc. 

www.cisco.com

E

ICND v1.0a—9­12

Classes of Routing Protocols
B

Distance Vector

A

C
D

Hybrid Routing

B
A

C

Link State

D

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­13

Distance Vector Routing 
Protocols
B
A

C
Distance—How far
Vector—In which direction

D

D

C

B

A

Routing
Table

Routing
Table

Routing
Table

Routing
Table

Pass periodic copies of routing table to neighbor 
routers and accumulate distance vectors
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­14

Distance Vector—Sources of 
Information and Discovering Routes
10.1.0.0

10.2.0.0

E0

A

S0

Routing Table

10.3.0.0
B

S0

S1

Routing Table

10.4.0.0
S0

C

E0

Routing Table

10.1.0.0

E0

0

10.2.0.0

S0

0

10.3.0.0

S0

0

10.2.0.0

S0

0

10.3.0.0

S1

0

10.4.0.0

E0

0

 

 

 

 

 

Routers discover the best path to 
destinations from each neighbor
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­15

Distance Vector—Sources of 
Information and Discovering Routes
10.1.0.0
E0

10.2.0.0
A

S0

Routing Table

10.3.0.0
B

S0

S1

Routing Table

10.1.0.0

E0

0

10.2.0.0

10.2.0.0

S0

0

10.3.0.0

10.3.0.0

S0

1

10.4.0.0
S0

C

E0

Routing Table

0

10.3.0.0

S0

0

S1

0

10.4.0.0

E0

0

10.4.0.0

S1

1

10.2.0.0

S0

1

10.1.0.0

S0

1

 

S0

 

Routers discover the best path to 
destinations from each neighbor
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­16

Distance Vector—Sources of 
Information and Discovering Routes
10.1.0.0
E0

10.2.0.0
A

S0

Routing Table
10.1.0.0

10.3.0.0
B

S0

Routing Table

E0

0

10.2.0.0

S0

0

10.3.0.0

10.3.0.0

S0

1

10.4.0.0

S0

2

10.2.0.0

S1

10.4.0.0
S0

C

E0

Routing Table

0

10.3.0.0

S0

0

S1

0

10.4.0.0

E0

0

10.4.0.0

S1

1

10.2.0.0

S0

1

10.1.0.0

S0

1

10.1.0.0

S0

2

S0

Routers discover the best path to 
destinations from each neighbor
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­17

Distance Vector—Selecting 
Best Route with Metrics
A

IGRP
56

RIP
Hop count

Bandwidth
Delay
   

T1

56

Reliability
MTU

IPX
Ticks, hop count

Load

T1
B

Information used to select the best path for routing
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­18

Do not delete

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­19

Distance Vector—Maintaining 
Routing Information
Process to 
update this 
routing
table

A

Topology
change 
causes
routing
table
update

Updates proceed step­by­step 
from router to router
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­20

Distance Vector—Maintaining 
Routing Information
Process to 
update this 
routing
table
Router A sends 
out this updated
routing table 
after the 
next period
 expires

A

Topology
change 
causes
routing
table
update

Updates proceed step­by­step 
from router to router
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­21

Distance Vector—Maintaining 
Routing Information
Process to 
update this 
routing
table

B

Process to 
update this 
routing
table
Router A sends 
out this updated
routing table 
after the 
next period
 expires

A

Topology
change 
causes
routing
table
update

Updates proceed step­by­step 
from router to router
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­22

Maintaining Routing Information 
Problem—Routing Loops
10.1.0.0

10.2.0.0
A

E0

S0

Routing Table

10.3.0.0

S0

B

S1

Routing Table

10.4.0.0
S0

C

E0

Routing Table

10.1.0.0

E0

0

10.2.0.0

S0

0

10.3.0.0

S0

0

10.2.0.0

S0

0

10.3.0.0

S1

0

10.4.0.0

E0

10.3.0.0

S0

1

0

10.4.0.0

S1

1

10.2.0.0

S0

1

10.4.0.0

S0

2

10.1.0.0

S0

1

10.1.0.0

S0

2

Each node maintains the distance from itself to each 
possible destination network
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­23

Maintaining Routing Information 
Problem—Routing Loops
10.1.0.0

10.2.0.0

E0

A

S0

Routing Table

10.3.0.0

S0

B

S1

Routing Table

10.4.0.0
S0

C

E0

X

Routing Table

1

1

1

2

1

2

Slow convergence produces inconsistent routing

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­24

Maintaining Routing Information 
Problem—Routing Loops
10.1.0.0
E0

10.2.0.0
A

S0

Routing Table

10.3.0.0

S0

B

S1

Routing Table

10.4.0.0
S0

C

E0

X

Routing Table

1

1

1

2

1

2

Router C concludes that the best path to network 
10.4.0.0 is through Router B
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­25

Maintaining Routing Information 
Problem—Routing Loops
10.1.0.0
E0

10.2.0.0
A

S0

Routing Table

10.3.0.0

S0

B

S1

Routing Table

10.4.0.0
S0

C

E0

X

Routing Table

1

3

1

4

1

2

Router A updates its table to reflect the new but 
erroneous hop count
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­26

Symptom: Counting to Infinity
10.1.0.0
E0

10.2.0.0
A

S0

Routing Table

10.3.0.0

S0

B

S1

Routing Table

10.4.0.0
S0

C

E0

X

Routing Table

1

5

1

6

1

2

• Packets for network 10.4.0.0 bounce between routers 
A, B, and C
• Hop count for network 10.4.0.0 counts to infinity
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­27

Solution: Defining a Maximum
10.1.0.0

10.2.0.0
A

E0

S0

Routing Table

10.3.0.0

S0

B

S1

Routing Table

10.4.0.0
S0

C

E0

X

Routing Table

10.1.0.0

E0

0

10.2.0.0

S0

0

10.3.0.0

0

10.2.0.0

S0

0

10.3.0.0

S1

S0

0

10.4.0.0

16

10.3.0.0

S0

1

S0

10.4.0.0

S1

16

10.2.0.0

1

10.4.0.0

S0

16

S0

10.1.0.0

S0

1

10.1.0.0

S0

2

Define a limit on the number of hops to prevent 
infinite loops
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­28

Solution: Split Horizon
10.1.0.0
E0

10.2.0.0
A

S0

Routing Table

X

10.3.0.0

S0

B

S1

Routing Table

X

10.4.0.0
S0

C

E0

X

Routing Table

1

1

1

2

2

2

It is never useful to send information about a route back 
in the direction from which the original packet came 
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­29

Solution: Route Poisoning
10.1.0.0

10.2.0.0
A

E0

S0

Routing Table

10.3.0.0

S0

B

S1

Routing Table

10.4.0.0
S0

C

E0

X

Routing Table

10.1.0.0

E0

0

10.2.0.0

S0

0

10.3.0.0

10.2.0.0

S0

0

10.3.0.0

S1

S0

0

10.4.0.0

10.3.0.0

S0

1

S0 Infinity

10.4.0.0

S1

1

10.2.0.0

1

10.4.0.0

S0

2

S0

10.1.0.0

E1

2

10.1.0.0

S0

2

0

Routers set the distance of routes that have gone down 
to infinity
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­30

Solution: Poison Reverse
10.1.0.0

10.2.0.0
A

E0

S0

Routing Table

10.3.0.0

S0

B

S1

10.4.0.0
S0

C

E0

Poison
Reverse

Routing Table

Routing Table

10.1.0.0

E0

0

10.2.0.0

S0

0

10.3.0.0

10.2.0.0

S0

0

10.3.0.0

S1

S0

0

10.4.0.0

10.3.0.0

S0

1

S0 Infinity

10.4.0.0

S1

10.2.0.0

1

10.4.0.0

S0

2

S0

10.1.0.0

E1

10.1.0.0

S0

2

Possibly
Down

2

X

0

Poison Reverse overrides split horizon
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­31

Solution: Hold­Down Timers
Network 10.4.0.0
is unreachable

Update after
hold­down Time

10.1.0.0

10.2.0.0

E0

A

S0

S0

10.3.0.0
B

S1

Update after
hold­down Time

10.4.0.0
S0

C

E0

X

Network 10.4.0.0 is down
then back up
 then back down

Router keeps an entry for the network possibly down 
state, allowing time for other routers to recompute for this 
topology change
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­32

Solution: Triggered Updates
Network 10.4.0.0
is unreachable

Network 10.4.0.0
is unreachable

10.1.0.0
E0

Network 10.4.0.0
is unreachable

10.2.0.0
A

S0

S0

10.3.0.0
B

S1

10.4.0.0
S0

C

E0

X

Router sends updates when a change in its routing 
table occurs

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­33

Blank Slide for Instructor Notes

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­34

Implementing Solutions in 
Multiple Routes
D

10.4.0.0
E

B

X

C

A

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­35

Implementing Solutions in 
Multiple Routes (cont.)
Holddown

D

10.4.0.0
E

B

X

C

Holddown

A
Holddown
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­36

Implementing Solutions in 
Multiple Routes (cont.)
Holddown
Poison Reverse

D

Poison Reverse

10.4.0.0
E

B

X

C

Holddown
Poison Reverse
Poison Reverse

A
Holddown

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­37

Implementing Solutions in 
Multiple Routes (cont.)
Holddown

D

10.4.0.0
E

B

X

C

Holddown
Packet for 
Network 10.4.0.0

Packet for 
Network 10.4.0.0

A
Holddown

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­38

Implementing Solutions in 
Multiple Routes (cont.)
D

10.4.0.0
E

B

Link up!

C

A

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­39

Implementing Solutions in 
Multiple Routes (cont.)
D

10.4.0.0
E

B

Link up!

C

A

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­40

Link­State Routing Protocols
B
C

A
D

Topological
Database

Link­State Packets
Routing
Table

SPF
Algorithm
Shortest Path First Tree

After initial flood, pass small event­triggered link­state 
updates to all other routers
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­41

Hybrid Routing
Choose a
routing path based 
on distance vectors
Balanced Hybrid Routing
Converge rapidly using  
change­based
 updates

Share attributes of both distance­vector 
and link­state routing
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­42

IP Routing 
Configuration Tasks
Network 172.16.0.0

Router configuration
• Select routing protocols
• Specify networks or 
interfaces

RIP
IGRP,
RIP

IGRP
Network
160.89.0.0

RIP

Network 172.30.0.0

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­43

Dynamic Routing 
Configuration

ter(config)#router protocol [keyword] 
• Defines an IP routing protocol

r(config-router)#network network-number
• Mandatory configuration command for each 
IP routing process
• Identifies the physically connected network 
that routing updates are forwarded to

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­44

RIP Overview

19.2 kbps
T1

T1
T1

• Maximum six paths (default = 4)
• Hop count metric selects the path
© 2000, Cisco Systems, Inc. 

• Routes update every 30 seconds
www.cisco.com

ICND v1.0a—9­45

RIP Configuration

ter(config)#router rip
•Starts the RIP routing process

(config-router)#network network-number
• Selects participating attached networks
• The network number must be a major classful
 network number

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­46

RIP Configuration Example
172.16.1.0

E0

S2

S2

A
172.16.1.1 10.1.1.1

10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

2.3.0.0
router rip
network 172.16.0.0
network 10.0.0.0

192.168.1.0 

2.3.0.0
router rip
network 192.168.1.0
network 10.0.0.0

router rip
network 10.0.0.0

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­47

Verifying the Routing Protocol
—RIP
172.16.1.0

E0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterA#sh ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 0 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Redistributing: rip
Default version control: send version 1, receive any version
Interface
Send Recv
Key-chain
Ethernet0
1
1 2
Serial2
1
1 2
Routing for Networks:
10.0.0.0
172.16.0.0
Routing Information Sources:
Gateway
Distance
Last Update
10.1.1.2
120
00:00:10
Distance: (default is 120)
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­48

Displaying the 
IP Routing Table
172.16.1.0

E0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterA#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
T - traffic engineered route
Gateway of last resort is not set
C
R
C
R
© 2000, Cisco Systems, Inc. 

172.16.0.0/24 is subnetted, 1 subnets
172.16.1.0 is directly connected, Ethernet0
10.0.0.0/24 is subnetted, 2 subnets
10.2.2.0 [120/1] via 10.1.1.2, 00:00:07, Serial2
10.1.1.0 is directly connected, Serial2
192.168.1.0/24 [120/2] via 10.1.1.2, 00:00:07, Serial2
www.cisco.com

ICND v1.0a—9­49

debug ip rip Command
172.16.1.0

E0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterA#debug ip rip
RIP protocol debugging is on
RouterA#
00:06:24: RIP: received v1 update from 10.1.1.2 on Serial2
00:06:24:
10.2.2.0 in 1 hops
00:06:24:
192.168.1.0 in 2 hops
00:06:33: RIP: sending v1 update to 255.255.255.255 via
Ethernet0 (172.16.1.1)
00:06:34:
network 10.0.0.0, metric 1
00:06:34:
network 192.168.1.0, metric 3
00:06:34: RIP: sending v1 update to 255.255.255.255 via
Serial2 (10.1.1.1)
00:06:34:
network 172.16.0.0, metric 1

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­50

Introduction to IGRP
IGRP

• More scalable than RIP
• Sophisticated metric
• Multiple­path support
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­51

IGRP Composite Metric
19.2 kbps

19.2 kbps

Source

Destination

•Bandwidth
•Delay
•Reliability
•Loading
•MTU
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­52

Blank Slide for Instructor 
Notes

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­53

IGRP Unequal Multiple Paths
New Route
Source

Initial 
Route

Destination

•Maximum six paths (default = 4)
•Within metric variance

•Next­hop router closer to destination
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­54

Configuring IGRP

Router(config)#router igrp autonomous-system
• Defines IGRP as the IP routing protocol

config-router)#network network-number
• Selects participating attached networks

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­55

Configuring IGRP (cont.)

Router(config-router)#variance multiplier
• Control IGRP load balancing

ter(config-router)#traffic-share
alanced | min }
• Control how load­balanced traffic is distributed
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­56

IGRP Configuration Example
Autonomous System = 100
172.16.1.0

E0

S2

S2

A
172.16.1.1 10.1.1.1

10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

router igrp 100
network 172.16.0.0
network 10.0.0.0

192.168.1.0 

router igrp 100
network 192.168.1.0
network 10.0.0.0

router igrp 100
network 10.0.0.0

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­57

Verifying the Routing Protocol
—IGRP
172.16.1.0

E0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterA#sh ip protocols
Routing Protocol is "igrp 100"
Sending updates every 90 seconds, next due in 21 seconds
Invalid after 270 seconds, hold down 280, flushed after 630
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
IGRP maximum hopcount 100
IGRP maximum metric variance 1
Redistributing: igrp 100
Routing for Networks:
10.0.0.0
172.16.0.0
Routing Information Sources:
Gateway
Distance
Last Update
10.1.1.2
100
00:01:01
Distance: (default is 100)
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­58

Displaying the 
IP Routing Table
172.16.1.0

E0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterA#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
T - traffic engineered route
Gateway of last resort is not set
C
I
C
I

172.16.0.0/24 is subnetted, 1 subnets
172.16.1.0 is directly connected, Ethernet0
10.0.0.0/24 is subnetted, 2 subnets
10.2.2.0 [100/90956] via 10.1.1.2, 00:00:23, Serial2
10.1.1.0 is directly connected, Serial2
192.168.1.0/24 [100/91056] via 10.1.1.2, 00:00:23, Serial2

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­59

debug ip igrp transaction 
Command
172.16.1.0

E0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterA#debug ip igrp transactions
IGRP protocol debugging is on
RouterA#
00:21:06: IGRP: sending update to 255.255.255.255 via Ethernet0 (172.16.1.1)
00:21:06:
network 10.0.0.0, metric=88956
00:21:06:
network 192.168.1.0, metric=91056
00:21:07: IGRP: sending update to 255.255.255.255 via Serial2 (10.1.1.1)
00:21:07:
network 172.16.0.0, metric=1100
00:21:16: IGRP: received update from 10.1.1.2 on Serial2
00:21:16:
subnet 10.2.2.0, metric 90956 (neighbor 88956)
00:21:16:
network 192.168.1.0, metric 91056 (neighbor 89056)

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­60

debug ip igrp events 
Command
172.16.1.0

E0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterA#debug ip igrp events
IGRP event debugging is on
RouterA#
00:23:44: IGRP: sending update to 255.255.255.255 via Ethernet0 (172.16.1.1)
00:23:44: IGRP: Update contains 0 interior, 2 system, and 0 exterior routes.
00:23:44: IGRP: Total routes in update: 2
00:23:44: IGRP: sending update to 255.255.255.255 via Serial2 (10.1.1.1)
00:23:45: IGRP: Update contains 0 interior, 1 system, and 0 exterior routes.
00:23:45: IGRP: Total routes in update: 1
00:23:48: IGRP: received update from 10.1.1.2 on Serial2
00:23:48: IGRP: Update contains 1 interior, 1 system, and 0 exterior routes.
00:23:48: IGRP: Total routes in update: 2

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­61

Updating Routing Information 
Example
E0

172.16.1.0

X

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterA# debug ip igrp trans
00:31:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to down
00:31:15: IGRP: edition is now 3
00:31:15: IGRP: sending update to 255.255.255.255 via Serial2 (10.1.1.1)
00:31:15:
network 172.16.0.0, metric=4294967295
00:31:16: IGRP: Update contains 0 interior, 1 system, and 0 exterior routes.
00:31:16: IGRP: Total routes in update: 1
00:31:16: IGRP: broadcasting request on Serial2
00:31:16: IGRP: received update from 10.1.1.2 on Serial2
00:31:16:
subnet 10.2.2.0, metric 90956 (neighbor 88956)
00:31:16:
network 172.16.0.0, metric 4294967295 (inaccessible)
00:31:16:
network 192.168.1.0, metric 91056 (neighbor 89056)
00:31:16: IGRP: Update contains 1 interior, 2 system, and 0 exterior routes.
00:31:16: IGRP: Total routes in update: 3

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­62

Updating Routing Information 
Example (cont.)
E0

172.16.1.0

X

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterB#debug ip igrp trans
IGRP protocol debugging is on
RouterB#
1d19h: IGRP: sending update to 255.255.255.255 via Serial2 (10.1.1.2)
1d19h:
subnet 10.2.2.0, metric=88956
1d19h:
network 192.168.1.0, metric=89056
1d19h: IGRP: sending update to 255.255.255.255 via Serial3 (10.2.2.2)
1d19h:
subnet 10.1.1.0, metric=88956
1d19h:
network 172.16.0.0, metric=89056
1d19h: IGRP: received update from 10.1.1.1 on Serial2
1d19h:
network 172.16.0.0, metric 4294967295 (inaccessible)
1d19h: IGRP: edition is now 10
1d19h: IGRP: sending update to 255.255.255.255 via Serial2 (10.1.1.2)
1d19h:
subnet 10.2.2.0, metric=88956
1d19h:
network 172.16.0.0, metric=4294967295
1d19h:
network 192.168.1.0, metric=89056
1d19h: IGRP: sending update to 255.255.255.255 via Serial3 (10.2.2.2)
1d19h:
subnet 10.1.1.0, metric=88956
1d19h:
network 172.16.0.0, metric=4294967295
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­63

Updating Routing Information 
Example (cont.)
E0

X

172.16.1.0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterB#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
T - traffic engineered route
Gateway of last resort is not set
I

172.16.0.0/16 is possibly down, routing via 10.1.1.1, Serial2
10.0.0.0/24 is subnetted, 2 subnets
C
10.1.1.0 is directly connected, Serial2
C
10.2.2.0 is directly connected, Serial3
I
192.168.1.0/24 [100/89056] via 10.2.2.3, 00:00:14, Serial3
RouterB#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
RouterB#
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­64

Updating Routing Information 
Example (cont.)
172.16.1.0

E0

S2

A
172.16.1.1 10.1.1.1

S2
10.1.1.2

S3
B

S3

E0

C
10.2.2.2 10.2.2.3 192.168.1.1

192.168.1.0 

RouterB#debug ip igrp transactions
RouterB#
1d20h: IGRP: received update from 10.1.1.1 on Serial2
1d20h:
network 172.16.0.0, metric 89056 (neighbor 1100)
RouterB#
RouterB#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
T - traffic engineered route
Gateway of last resort is not set
I

172.16.0.0/16 is possibly down, routing via 10.1.1.1, Serial2
10.0.0.0/24 is subnetted, 2 subnets
C
10.1.1.0 is directly connected, Serial2
C
10.2.2.0 is directly connected, Serial3
I
192.168.1.0/24 [100/89056] via 10.2.2.3, 00:00:18, Serial3
RouterB#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/38/48 ms
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­65

ip classless Command
Default route
E0

10.7.1.1

S0

10.1.0.0

Router(config)#ip classless

10.2.0.0

Network
Protocol

To get to 10.7.1.1:
•With ip classless     Default

C
C
RIP

172.16.0.0

Destination
Network

Exit 
Interface

10.1.0.0 
10.2.0.0
172.16.0.0 via
0.0.0.0

E0
S0
S0
E0

•With no ip classless     Drop
© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­66

Visual Objective
wg_pc_a
10.2.2.12
e0/1

RIP

e0/2

e0

wg_ro_a
s0 
10.140.1.2/24

10.2.2.3

wg_sw_a
10.2.2.11 
wg_pc_l
10.13.13.12

RIP

e0/1
e0/2
wg_sw_l
10.13.13.11 

e0
10.13.13.3 

wg_ro_l

pod
A
B
C
D
E
F
G
H
I
J
K
L

core_ server
10.1.1.1
© 2000, Cisco Systems, Inc. 

ro’s e0
10.2.2.3
10.3.3.3
10.4.4.3
10.5.5.3
10.6.6.3
10.7.7.3
10.8.8.3
10.9.9.3
10.10.10.3
10.11.11.3
10.12.12.3
10.13.13.3

sw
10.2.2.11
10.10.10.11
10.4.4.11
10.5.5.11
10.6.6.11
10.7.7.11
10.8.8.11
10.9.9.11
10.3.3.11
10.11.11.11
10.12.12.11
10.13.13.11

LL

      s0
10.140.12.2/24
...

fa0/24

ro’s s0
10.140.1.2
10.140.2.2 
10.140.3.2
10.140.4.2
10.140.5.2
10.140.6.2
10.140.7.2
10.140.8.2
10.140.9.2
10.140.10.2
10.140.11.2
10.140.12.2

fa0/23

fa0/0

  

s1/0 ­ s2/3
10.140.1.1/24 … 10.140.12.1/24

core_ro
10.1.1.3

core_sw_a
10.1.1.2
www.cisco.com

ICND v1.0a—9­67

Visual Objective
wg_pc_a
10.2.2.12
e0/1

e0/2

IGRP

e0

wg_ro_a

10.2.2.3

wg_sw_a
10.2.2.11 

s0 
10.140.1.2/24

wg_pc_l
10.13.13.12

IGRP

e0/1

e0/2

wg_sw_l
10.13.13.11 

e0

wg_ro_l

10.13.13.3 

pod
A
B
C
D
E
F
G
H
I
J
K
L

sw
10.2.2.11
10.10.10.11
10.4.4.11
10.5.5.11
10.6.6.11
10.7.7.11
10.8.8.11
10.9.9.11
10.3.3.11
10.11.11.11
10.12.12.11
10.13.13.11

      s0
10.140.12.2/24

fa0/24

© 2000, Cisco Systems, Inc. 

ro’s e0
10.2.2.3
10.3.3.3
10.4.4.3
10.5.5.3
10.6.6.3
10.7.7.3
10.8.8.3
10.9.9.3
10.10.10.3
10.11.11.3
10.12.12.3
10.13.13.3

LL

...

core_ server
10.1.1.1

ro’s s0
10.140.1.2
10.140.2.2 
10.140.3.2
10.140.4.2
10.140.5.2
10.140.6.2
10.140.7.2
10.140.8.2
10.140.9.2
10.140.10.2
10.140.11.2
10.140.12.2

fa0/23
  

core_sw_a
10.1.1.2

fa0/0

s1/0 ­ s2/3
10.140.1.1/24 … 10.140.12.1/24

core_ro
10.1.1.3
www.cisco.com

ICND v1.0a—9­68

Summary
After completing this chapter, you should be 
able to perform the following tasks:
• Determine when to use a static or dynamic route.
• Configure a static route on a Cisco Router.
• Describe how distance vector routing protocols operate.
• Configure the RIP and  IGRP routing protocols on a Cisco 
router.
• Use show ip route, show ip protocols, and other show and 
debug commands to verify proper routing operation. 

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­69

Review Questions
1. What is an advantage of using a static  
route rather than a dynamic route? 
What is a disadvantage?
2. What is the advantage of using IGRP 
rather then RIP? What is a possible 
disadvantage?
3. To scale up to very large IP networks, 
what routing protocols are recommended?

© 2000, Cisco Systems, Inc. 

www.cisco.com

ICND v1.0a—9­70

Sign up to vote on this title
UsefulNot useful