EE5613 RF/Microwave Design Laboratory

University of Minnesota

Hosaeng Kim (hosaeng@umn.edu)

Advanced Design System (ADS) Tutorial
This tutorial describes how to analyze a stepped impedance filter using Advanced Design System (ADS) step by step.

STEPPED-IMPEDANCE FILETER DESIGN
The figure below shows the design layout of the stepped-impedance low pass filer obtained in Example 8.6 in Microwave Engineering, 3rd, Pozar. This filer has a cutoff frequency at 2.5GHz and more than 20dB insertion loss at 4GHz.

The details of the step-impedance low pass filter are listed in the tables below. Section L1 L2 L3 L4 L5 L6 Characteristic impedance(Zi) 20 120 20 120 20 120 Electrical Length(βi) 11.8˚ 33.8˚ 44.3˚ 46.1˚ 32.4˚ 12.3˚ Microstrip Width (Wi) 11.3mm 0.423mm 11.3mm 0.428mm 11.3mm 0.428mm Microstrip Length (Li) 2.05mm 6.63mm 7.69mm 9.04mm 5.63mm 2.41mm

1/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

# Substrate Substrate Dielectric constant 4.2 Substrate thickness 0.158cm Loss tangential 0.02 1mil Conductor Copper thickness Conductivity 5.8x107

I. Launching Advanced Design System (ADS)
1. To access Agilent Advanced Design System (ADS), click the Microsoft Start Button,
select Programs, and select the Advanced Design System 2003C (or other versions) program group. Click Advanced Design System.

II. Creating a New Project
¾ To created a new project: 1. In an ADS Main Window, click the File > New Project. on the Standard toolbar, or select the menu item

2. When the dialog box appears, give the project a name by c:\users\default\EE5613demo

typing: e.g.

2/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

Notes: Project Technology Files is a setting for items such as microstrip lines and also used for layout. the Browse button allows you to create project directories anywhere you like. 3. Click OK to continue. ¾ Project File Brower and Project Hierarchy The Main window File Browser area shows that you are in the lab1 project directory. Notice that the sub-directories (data, networks, etc.) were created automatically. All the schematic files exist in the networks directory.

III. Creating a Schematic Design.
1. In the Main window, click the New Schematic Window icon, or select the menu item Window > New Schematic Window. Immediately, the Schematic window will appear. If

3/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

your preferences are set to create an initial schematic, you will have two schematics now opened – close one of them.

Component Palette

2. Save the schematic design: notice the top line (window border) shows the project name (EE5613demo_prj) and the name of the schematic (untitled1) with an incremental number (1, 2, 3, …) of the schematic window you have open. To name the schematic, click File > Save As and type in a name such as stepped_impedance_filter and click Save. This will save it in the networks directory of the EE5613demo project.

3. In the Components Palette List, click the TLines-Mcrostrip palette.

4/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

4. In the TLines-Microstip palette, click on the MLIN. Then click to insert the MLIN as shown on the schematic. Next, insert the other five MLINs.

5. In the TLines-Microstip palette, click on the MSUB (Microtrip Substrate). Then click to insert the MSUB on the schematic. 6. Select the Simulation-S_Param palette to insert the terminations (TERM). Then insert two terminations. 7. Insert grounds. The ground icon is placed in the top toolbar as shown below.

8. Combine all the components by using wire as shown below.

5/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

T erm T erm 1 Num =1 Z=50 Ohm

M LIN T L1 Subst="M Sub1" W=25.0 m il L=100.0 m il

M LIN T L2 Subst="M Sub1" W=25.0 m il L=100.0 m il

M LIN T L3 Subst="M Sub1" W=25.0 m il L=100.0 m il

M LIN T L4 Subst="M Sub1" W=25.0 m il L=100.0 m il

M LIN T L5 Subst="M Sub1" W=25.0 m il L=100.0 m il

M LIN T L6 Subst="M Sub1" W=25.0 m il L=100.0 m il

T erm T erm 2 Num =2 Z=50 Ohm

M Sub M SUB M Sub1 H=10.0 m il Er=9.6 M ur=1 Cond=1.0E+50 Hu=3.9e+034 m il T =0 m il T anD=0 Rough=0 m il

9. After the circuit is built, edit the parameters of the microstrip substrate (MSUB). To do this, double-click on the MSUB. Then edit the substrate parameters as shown in the table below.
Substrate Dielectric constant 4.2 Substrate thickness 0.158cm Loss tangential 0.02 Conductor Copper thickness 1mil Conductivity 5.8x107

IV. Use LineCalc to determine the physical parameters of the MLINs
1. From the schematic window start LineCalc: Tools > LineCalc > Start LineCalc. The main window will appear as shown here.

Substrate Paramters

Physical Dimension

Reference Frequency

Electrica Dimension

6/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

NOTE on LineCalc: Notice that the default component type is MLIN and that the default substrate is an ADS MSUB but it may not be set to the values on your schematic. 2. Substrate Parameters: Set the MSUB values to your schematic MSUB values, such as H=0.158cm, etc. 3. Component Parameters: Set Freq to 2.5 GHz (this will be easier to use with the reference line and the numbers will be easier to use). 4. Electrical: Set the Electrical characteristic (characteristic impedance and electrical length) of a microstrip line. Here, set Z0 = 20 ohm and E_Eff =11.8˚. 5. Click the Synthesize button and the width and length of the microstrip line will be calculated. 6. Calculate the width and length for each microstrip line as like the table below. Components MLIN1 MLIN2 MLIN3 MLIN4 MLIN5 MLIN6 Characteristic impedance(Zi) 20 120 20 120 20 120 Electrical Length(βi) 11.8˚ 33.8˚ 44.3˚ 46.1˚ 32.4˚ 12.3˚ Microstrip Width (Wi) 11.3mm 0.423mm 11.3mm 0.428mm 11.3mm 0.428mm Microstrip Length (Li) 2.05mm 6.63mm 7.69mm 9.04mm 5.63mm 2.41mm

V. Setup and Run the Simulation
1. Select the Simulation-S_Param palette to insert the S-parameter simulation controller (gear icon). Then insert the S-parameter simulation controller on the schematic.

S-PARAMETERS
S_Param SP1 Start=0 GHz Stop=5 GHz Step=0.01 GHz

2. To setup the simulation, double-click on the S-parameter simulation controller on the schematic. When the dialog box appears, put the start frequency, the stop frequency, and the step size and click Apply button. Start Frequency: 0GHz

7/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

-

Stop Frequency: 5GHz Step Size: 0.01GHz

3. Click the Display tab and you will see that the Start, Stop and Step values have been checked to be displayed on the simulation controller. You will use the display tab for setting other controllers to display the desired settings during this class. 4. Click the OK button to dismiss the dialog box.
T erm T erm 1 Num =1 Z=50 Ohm M LIN T L1 Subst="M Sub1" W=11.3 m m L=2.05 m m M LIN T L2 Subst="M Sub1" W=0.428 m m L=6.63 m m M LIN T L3 Subst="M Sub1" W=11.3 m m L=7.69 m m M LIN T L4 Subst="M Sub1" W=0.428 m m L=9.04 m m M LIN T L5 Subst="M Sub1" W=11.3 m m L=5.63 m m M LIN T L6 Subst="M Sub1" W=11.3 m m L=2.41 m m T erm T erm 2 Num =2 Z=50 Ohm

M Sub M SUB M Sub1 H=0.158 cm Er=4.2 M ur=1 Cond=5.8E+7 Hu=3.9e+034 m il T =1.4 m il T anD=0.02 Rough=0 m il

S-PA RA METERS
S_Param SP1 Start=0.0 GHz Stop=5.0 GHz Step=0.01 GHz

5. Click the Simulate icon (gear) to start the simulation process. This is the same as clicking Simulate in the setup dialog. When you simulate, the resulting data is always written into the current dataset you have setup. 6. Next, look for the Status window to appear and you should see a message similar to the one

8/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

here, describing the results of the simulation. SP1 refers to the s-parameter simulation controller and its settings. If no errors occurred, the message tells you the simulation is finished and that the dataset has been written into the data directory in the project you are in (here it is EE5613demo_prj).

7. Close the Status window after you see the message. You can always get the status window back using the command: Window > Restore Status. The simulation status information can be restored using the Window command in the status window and then selecting the simulation from the list.

VI. Display the simulation results (Data Display windows)
1. Open a data display window from either the Main window or the schematic window by clicking the Data Display icon. 2. When the Data Display window opens, the name of the dataset will appear in the list.

9/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

3. To create the plot, click on the Rectangular Plot icon and move the cursor (with ghost plot) into the window and click. When the next dialog box appears, select the S21 data and click the Add button.

4. The next dialog will prompt you to specify the type of data to display. Select dB and click OK. The plot should show a reasonable low pass filter response.

10/11 page

EE5613 RF/Microwave Design Laboratory

University of Minnesota

0 -5

dB(S(2,1))

-10 -15 -20 -25 -30 0 1 2 3 4 5

freq, GHz

5. Select the menu item: Marker > New. Select the trace and click to insert the marker. Move the marker using the cursor or the keyboard arrow keys. Also, move the marker text by selecting it and positioning it as desired. Try deleting the marker or putting another marker on the trace.

m1 freq= 4.010GHz m1=-21.893
0 -5

dB(S(2,1))

-10 -15 -20 -25 -30 0 1 2 3 4 5

m1

freq, GHz

11/11 page

Sign up to vote on this title
UsefulNot useful