You are on page 1of 3

Carga Cencosud

1. Coger archivo comprimido de la ruta:
\\10.92.1.44\SIA Archivos\PERU\Cadenas\Recepcion\Data Cadenas\Wong\Informacion Recibida\ 2. Se tiene el archivo ReporteSem<##>.txt abrirlo en Excel, al momento de importar desde el txt se debe colocar al campo EAN como texto y ordenarlo por la columna centro para luego copiar todo el bloque a otro archivo Excel de nombre CSD_MAY_SEMANA<#>.xlsx y comenzar a trabajarlo. Se corta el bloque de registros cuyos centros sea 1 y se pega en una hoja nueva del libro, en esta nueva hoja se deberá a proceder con el cambio de formato de las celdas, para eso se utilizar la formula guardada en archivos anteriores. Se deberá colocar los campos en sus respectivas cabeceras. NO OLVIDAR, la columna EAN siempre debe contener como valores un numero entero, no debe contener “E+” en sus celdas =TEXTO(C21,0), el campo debe ser numérico pero siempre revisando que no se modifique el código. DESPUES DE HABER TRABAJADO EL ARCHIVO, SE DEBE COPIAR EL ARCHIVO A LA SIGUIENTE RUTA: \\10.92.1.44\SIA Archivos\Area Procesos\Envio Cadenas\Consumo\Cencosud 6. DESPUES DE HABER TRABAJADO EL ARCHIVO, SE DEBE COPIAR EL ARCHIVO A LA SIGUIENTE RUTA:
\\192.168.10.250\ccr_cadenas\Metro\

3.

4.

5.

7.

se tiene un script para importar a la BD “CCR_BaseProcesos” la información del mes en proceso:

DECLARE

@ExisteError BIT, @SQL VARCHAR(3000), @Fecha DATETIME, @Registros INT, @TotalInsertados INT , @CadenaAux VARCHAR(100), @Ciudad VARCHAR(100) SET @TotalInsertados = 0 SET @SQL = 'INSERT INTO CCR_BaseProcesos.dbo.CSD_JUNIO SELECT 1,* FROM OPENROWSET(''Microsoft.ACE.OLEDB.12.0'', ''Excel 12.0 Xml;HDR=YES;Database='+'\\192.168.10.250\ccr_cadenas\Metro\CSD_JUN_SEMANA1.xlsx '+' '', ''SELECT * FROM ['+'SEMANA22'+'$]''); ' EXEC (@SQL)

BEGIN TRY END TRY BEGIN CATCH PRINT 'Error en el archivo ' + '\\192.168.10.250\ccr_cadenas\Metro\CSD_JUN_SEMANA1.xlsx' + ' Hoja: ' + 'SEMANA22' DECLARE @ErrorMessage NVARCHAR(4000); DECLARE @ErrorSeverity INT; DECLARE @ErrorState INT; SELECT @ErrorMessage = ERROR_MESSAGE(), @ErrorSeverity = ERROR_SEVERITY(), @ErrorState = ERROR_STATE(); RAISERROR ('Error con el formato del archivo', -- Message text. @ErrorSeverity, -- Severity. @ErrorState -- State. ); END CATCH;

Select Count(1) FROM CCR_BaseProcesos.dbo.CSD_JUNIO Where Semana=1 Select SUM(Venta_UMN),SUM(Venta_UMV),SUM(Venta_Sls) From CCR_BaseProcesos.dbo.CSD_JUNIO Where Semana=1

Para validar que no haya registros duplicados y errores en las descripción de los productos. .

\\192.168.10.250\ccr_cadenas\Metro .