PSAT

(Power System Analysis Toolbox) By : H. Lotfizad

History

PSAT is a Matlab toolbox for static and dynamic analysis and control of electric power systems. PSAT is written by Federico Milano , in September 2001, while he was studying as Ph.D. student at the Universita di Genova, Italy, First public version of PSAT completed in November 2002, when he was a Visiting Scholar at the University of Waterloo, Canada.

Now Federico Milano is working as assistant professor at the Universidad de Castilla-La Mancha, Ciudad Real, Spain but he maintains PSAT in the spare time

continuation power flow.Overview  PSAT is a Matlab toolbox for electric power system analysis and control. PSAT includes Power Flow .   All PSAT operations can be assessed by means of graphical user interfaces (GUIs) and a Simulinkbased library provides an user friendly tool for network design. optimal power flow. small signal stability analysis and time domain simulation. .

which also takes care of state variable initialization.   These routines are:      1. Small signal stability analysis 4. Optimal power flow (OPF) 2.Overview  PSAT core is the power flow routine. Once the power flow has been solved. Time domain simulations 5. further static and/or dynamic analysis can be performed. Phasor measurement unit (PMU) placement. Continuation Power flow (CPF) 3. .

Useful features  Mathematical A Models & Utilities variety of utilities to other programs  Bridges  Data Format Conversion capability .

PSAT supports a variety of static and dynamic component models. as follows: .Mathematical Models  In order to perform accurate power system analysis.

Mathematical Models          Power Flow Data CPF and OPF Data Switching Operations Loads Machines Controls Regulating Transformers FACTS Other Models .

PSAT utilities      Simulink library for drawing networks.  Command logs. GUIs for settings system and routine parameters. User defined model construction and installation. Filters for converting data to and from other formats. . GUI for plotting results.

 This .PSAT bridges to other programs  PSAT includes bridges to GAMS and UWPFLOW programs. bridges highly extend PSAT ability of performing optimization and continuation power flow analysis.

Comparison between PSAT & Other Matlab Power System Toolboxes standard power flow (PF) continuation power flow and/or voltage stability analysis (CPF-VS) optimal power ow (OPF) Small signal stability analysis (SSSA) time domain simulation (TDS) Electro Magnetic Transient analysis (EMT) graphical user interface (GUI) graphical network construction (CAD) .

Mexico. Romania. Italy . Philippines. Indonesia. Peru. Thailand. Colombia. Venezuela. Australia. Nigeria. Hong Kong. Malaysia. Sweden . Sudan. Iran. Macedonia. Egypt. France. Spain . Puerto Rico. PSATusers around the world. Canada . Japan . Chile.  . China . Norway   Under developing countries like : Algery. England . Brasil. Costa Rica.PSAT Users   PSAT is currently used in several countries. These include: Modern Countries like : USA . Argentina. Turkey. India. Guatemala.

2.5 (ver 2) : Matlab 7 3.2) : Matlab 6.uwaterloo.Download the last PSAT version : http://thunderbox.Requirements (ver 1.ca/fmilano 2.PSAT Installation 1.Installation :  Extract PSAT zip files in a good location  Open MATLAB  Add PSAT’s Path to MATLAB default path .

PSAT quick tutorial  PSAT Installation  Launching PSAT  Loading Data  Running the Power flow Program  Displaying Results  Saving Results  Settings .

Launching PSAT Type psat in MATLAB Prompt >> psat This will create all the structures required by the toolbox . then opens psat GUI .

Menu File/Open/Data File .  .Loading Data  Almost all operations require that a data file is loaded. If the source is in a different format supported by the PSAT format conversion utility.m data file. first perform the conversion in order to create the PSAT data file.Short cut <Ctr-y>  To allow portability the .File/Open/Saved System .out files used for saving system results include also the original data which can be saved in a new .Short cut <Ctr-d> Load a saved system: .  The data file can be either a .m file in PSAT format or a Simulink model created with the PSAT library.  To load a file: Load only a data file : .

 .Running the Power flow Program  To run the power flow routine: Menu Run/Power Flow Short cut <Ctr-p> It is not necessary to load again the data file every time it is modied. bacause :   The last version of the data file is read each time the power flow is performed. The data are updated also in case of changes in the Simulink model originally loaded.

… of these procedures can be launched from the tool-bar or the menubar of the main window.  Each . OPF . such as CPF .Other Analysis  After solving the first power flow. the program is ready for further analysis.

These routines only create a text report:     Standard Power flow (in a .eig file) SSSA (Small Signal Stability analysis) (in a .tex file) PMU placement (in a . either by means of a graphical user interface in Matlab or as a ascii text file.pmu file)  These routines create graphical output :   CPF OPF .xls or . .Displaying Results  Results can be generally displayed in more than one way.txt .

 .mat file :   Menu File/Save/Current System Shortcut <Ctrl-a>  All global structures used by PSAT are stored in this file which is placed in the folder of the current data file all static computations allow to create a report in a text file that can be stored and used later.Saving Results  To save actual System status in a .

Settings  The main settings of the system are directly included in the main window      Base frequency Base Power Start & End Simulation Time static and dynamic tolerance Maximum number of iterations  Other general settings  Menu Edit/General Settings or <Ctr-k>  To change the default values for some fields of the Settings structure  Menu Edit/Set Default  To save a customize settings . use it as default values for the next sessions  Menu File/Save/Settings .

Network Design  Using The Simulink environment :     Creating a CAD able to design power networks visualize the topology change the data stored in it without the need of directly dealing with lists of data. the time domain routines that come with Simulink and its ability to build control block diagrams are not used.    Simulink has been thought for control diagrams with outputs and inputs variables This is not the best way for approaching a power system network.  PSAT simply reads the data from the Simulink model and writes down a data file. . Thus.  However.

the menu Edit/Network/Edit Network or the short cut <Ctr-s>.Network Design  To    launch PSAT library click on Simulink icon in the menu-bar. .

Tools  Tools that provided with PSAT   data format conversion functions user defined model routines.  PSAT static data files can be converted in the IEEE Common Data Format User defined model routines provide a simple way for extending the capabilities of PSAT  .

PSAT Interfaces  PSAT provides interfaces :  GAMS and UWPFLOW. These interfaces highly extend PSAT ability to perform OPF and CPF analysis   The General Algebraic Modeling System (GAMS) is a high-level modeling system for mathematical programming problems.  UWPFLOW is an open source program for sophisticated continuation power flow analysis  UWPFLOW consists of a set of C functions and libraries designed for voltage stability analysis of power systems .

Practices and Tools. Rep. IEEE/PES Power System Stability Subcommittee.Using PSAT for analysis of Voltage Collapse  Based on C. Canizares. A.  Direct Methods for determining   Saddle-Node Bifurcations (SNB) Limit-Induced Bifurcations (LIB)  Continuation Power Flow (CPF)   The CPF is more general than DMs CPF can be used for determining:  generator reactive power limits  voltage limits  flow transmission limits. ." Tech. “Voltage Stability Assessment: Concepts.

CPF Settings .

PSAT plot for DM & CPF Results  This Figure depicts CPF nose curves as displayed by means of the PSAT GUI for plotting results system. graphic refers to three load voltages of the IEEE 14-bus test system  The .

IEEE 14-bus test system psat plots .

Special Thanks to Session Audiences .

Sign up to vote on this title
UsefulNot useful