Σηµειώσεις ΑΕΠΠ 2010-2011

εκπαιδευτηρια βασιλειαδη

Κεφ.1

περίληψη θεωρίας

Τι είναι πρόβληµα : Μία κατάσταση η οποία χρήζει αντιµετώπισης, απαιτεί λύση, η δε λύση της δεν είναι
γνωστή, ούτε προφανής.
Σελίδες
3,5,6,8

Κατανόηση προβλήµατος : Προϋποθέσεις: Σωστή διατύπωση (το δυνατόν πιο σαφής) και σωστή ερµηνεία
Σαφήνεια διατύπωσης: ∆υο στοιχεία που µπορεί να προκαλέσουν παρερµηνείες και παραπλανήσεις είναι
άστοχη ορολογία και λανθασµένη σύνταξη. Η παρερµηνεία είναι δυνατή ακόµη και όταν τηρούνται όλοι οι
λεξιλογικοί και συντακτικοί κανόνες. Αποσαφήνιση του χώρου στο οποίο αναφέρεται το πρόβληµα.
∆εδοµένο: οποιοδήποτε στοιχείο µπορεί να γίνει αντιληπτό από έναν τουλάχιστο παρατηρητή µε µία από τις
πέντε αισθήσεις του( ο ορισµός αυτός θα αλλάξει παρακάτω όταν µιλάµε για δεδοµένα που αφορούν στον
υπολογιστή )

Σελίδες
8,16,18

Πληροφορία: οποιοδήποτε γνωσιακό στοιχείο προέρχεται από επεξεργασία δεδοµένων (µέσω ενός
µηχανισµού επεξεργασίας π.χ. µυαλό, Η/Υ)
∆οµή προβλήµατος: Είναι τα συστατικά µέρη του προβλήµατος, τα επιµέρους τµήµατα που το αποτελούν και ο
τρόπος που αυτά τα µέρη συνδέονται µεταξύ τους. Συνήθως για τη γραφική απεικόνιση της δοµής ενός
προβλήµατος χρησιµοποιείται η διαγραµµατική αναπαράσταση (σελ. 10 και παράδειγµα σελ. 11)
Καθορισµός απαιτήσεων επακριβής προσδιορισµός δεδοµένων και λεπτοµερειακή καταγραφή ζητουµένων
(µπορεί να είναι «κρυµµένα» τα δεδοµένα ή τα ζητούµενα )
Στάδια στη διαδικασία επίλυσης ενός προβλήµατος:

Σελίδες
16,17

• Κατανόηση (σωστή και πλήρης αποσαφήνιση δεδοµένων και ζητουµένων) • ανάλυση (διάσπαση του αρχικού προβλήµατος σε άλλα απλούστερα) • επίλυση (µέσω της λύσης των επιµέρους προβληµάτων) (σελ 16 )
Κατηγορίες προβληµάτων: ως προς

δυνατότητα επίλυσης : επιλύσιµα , ανοικτά, άλυτα

βαθµό δόµησης: δοµηµένα, ηµιδοµηµένα, αδόµητα

πολυπλοκότητα υπολογισµών,

επαναληπτικότητα διαδικασιών,

ταχύτητα εκτέλεσης πράξεων,

µεγάλο πλήθος δεδοµένων

Λειτουργίες Η/Υ:

Πρόσθεση ( µε τη βοήθεια αυτής της πράξης γίνονται και οι υπόλοιπες, αφαίρεση κλπ )

Σύγκριση ( βασική λειτουργία για την επιτέλεση των λογικών πράξεων )

Μεταφορά δεδοµένων (προηγείται & έπεται της επεξεργασίας )

Σελ 25,
27,28,29

Κεφ.2

περίληψη θεωρίας

Αλγόριθµος: Είναι µια πεπερασµένη σειρά ενεργειών , αυστηρά καθορισµένων και εκτελέσιµων σε πεπερασµένο
χρόνο που στοχεύουν στην επίλυση ενός προβλήµατος
Κριτήρια αλγορίθµου:
1. είσοδος (καµία µία ή περισσότερες τιµές),
2. έξοδος ( εµφανίζονται-ανακοινώνονται τα αποτελέσµατα, οι λύσεις του αλγορίθµου)
3. καθοριστικότητα (κάθε εντολή να εκτελείται χωρίς αµφιβολία πχ Χ  3/Ψ )
4. περατότητα ( να τελειώνει ο αλγόριθµος µετά από συγκεκριµένη σειρά βηµάτων)
5. αποτελεσµατικότητα ( οι εντολές απλές και εκτελέσιµες)
Τρόποι αναπαράστασης αλγόριθµου:
1. Ελεύθερο κείµενο ( αδόµητος τρόπος , πρόβληµα στην αποτελεσµατικότητα )
2. Φυσική γλώσσα κατά βήµατα ( πρόβληµα στην καθοριστικότητα )
3. διαγραµµατικές τεχνικές (διαγραµµατικός τρόπος , παλιά µέθοδος παρουσίασης αλγ)
4. κωδικοποίηση (εντολές της ψευδογλώσσας ή κάποιας γλώσσας προγραµµατισµού )
1

εκπαιδευτηρια βασιλειαδη

Σελίδες 19,117
παραγραφ 6.1

Σελίδες
18,19

• είδος επίλυσης: απόφασης, βελτιστοποίησης, υπολογιστικά (σελ 16)
Η επίλυση µε Η/Υ προσφέρεται όταν υπάρχει:

Ππροσοχή στα διαγράµµατα ροής των επαναλήψεων (θέση συνθήκης. Ανάλυσης ∆εδοµένων (σελ. έξοδος από την επανάληψη.) Μελετείστε προσεκτικά ( ως επανάληψη ) τα Στοιχεία Ψευδογλώσσας . ΜΕ_ΒΗΜΑ (σελ 44) δες και τα παραδείγµατα στο περιθώριο της σελίδας Ολίσθηση προς τα αριστερά είναι πολλαπλασιασµός επί 2 ενώ ( αριστερά – επί ) προς τα δεξιά είναι ακέραια διαίρεση δια 2 ( δεξιά – δια ) Ο πολλαπλασιασµός αλα-ρωσικά χρησιµοποιεί τη µέθοδο της ολίσθησης γιατί υλοποιείται πολύ πιο απλά απ΄ ότι ο χειρωνακτικός τρόπος και εκτελείται ταχύτερα από τα κυκλώµατα του υπολογιστή. 46-47 Δομή ακολουθίας : ∆ΙΑΒΑΣΕ Δομή Επιλογής ΑΠΛΗ ΕΜΦΑΝΙΣΕ Δομή επανάληψης ΠΟΛΛΑΠΛΗ ΟΣΟ ΣΥΝΘΕΤΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΓΙΑ Σελ 39 ΕΝΤΟΛΗ ΕΚΧΩΡΗΣΗΣ Πίνακας τιµών των λογικών πράξεων ( ΟΧΙ . ΜΕΧΡΙ. Το µέγεθος του το δηλώνουµε από την αρχή στο τµήµα δηλώσεων και δεν µπορούµε µετά να το αλλάξουµε.. ∆ιαχωρισµός Σελ 56 Κατηγορίες δοµών δεδοµένων: Στατικές – ∆υναµικές (3 διαφορές –µέγεθος –µνήµη –φάση εκτέλεσης/µετάφρασης) Στατική δοµή: Είναι αυτή για την οποία το ακριβές µέγεθος της απαιτούµενης κύριας µνήµης καθορίζεται στη φάση της κατασκευής του προγράµµατος και όχι κατά τη στιγµή της εκτέλεσης του. Κάθε µορφή δοµή δεδοµένων αποτελείται από ένα σύνολο κόµβων (nodes). Αναζήτηση. µπορούν να ισχύουν η µία από τις δύο ή να ισχύουν και οι δύο προτάσεις Βρόχος τµήµα αλγορίθµου που επαναλαµβάνεται (δοµή επανάληψης).Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη Σύµβολα λογικού διαγράµµατος και τι δηλώνει το καθένα: δηλώνει την αρχή η το τέλος του αλγορίθµου (πχ Αρχή Τέλος) εκτέλεση πράξεων (πχ Α X+10 ) συνθήκη (πχ Χ>10 ) είσοδος ή έξοδος (πχ ∆ΙΑΒΑΣΕ Χ ΕΜΦΑΝΙΣΕ Χ) Βασικές συνιστώσες/εντολές αλγορίθµου: ∆οµή αλγορίθµου. Εισαγωγή. Συγκριτικά στοιχεία για τις µορφές των επαναλήψεων ( διαφορές – πότε σταµατά – πότε συνεχίζει – θέση συνθήκης – πλήθος επαναλήψεων – κλπ) Προσοχή στις δεσµεύσεις των τιµών ΑΠΟ . 2 . είναι αποκλειστικό και όχι συνδετικό Η = δεν είναι αποκλειστικό. ∆ιαγραφή. ∆οµών ∆εδοµένων. δοµή ακολουθίας–επανάληψης– επιλογής. ΚΑΙ . Συγχώνευση. συνώνυµο του ∆ΕΝ ( αν είναι αληθής γίνεται ψευδής και το αντίστροφο ) ΚΑΙ = πρέπει να ισχύουν ( να είναι αληθείς ) και οι δύο προτάσεις . Αντιγραφή. έτσι και µε τα δεδοµένα η Πληροφορική είναι η επιστήµη που τα µελετά από πλευράς:Υλικού. Ταξινόµηση. Γλωσσών προγραµµατισµού. παράδειγµα στατικής δοµής είναι ο πίνακας. σελ. 53) ∆οµή ∆εδοµένων: Είναι ένα σύνολο αποθηκευµένων δεδοµένων που υφίστανται επεξεργασία από ένα σύνολο λειτουργιών. Τα στοιχεία µιας στατικής δοµής αποθηκεύονται σε συνεχόµενες θέσεις µνήµης. Κεφ.3 Σελίδες 53.54 περίληψη θεωρίας Όπως και µε τους αλγόριθµους. εµφωλευµένες διαδικασίες. Η ) πρόταση Α αληθής αληθής ψευδής ψευδής πρόταση Β αληθής ψευδής αληθής ψευδής ΑήΒ αληθής αληθής αληθής ψευδής Α και Β αληθής ψευδής ψευδής ψευδής οχι Α ψευδής ψευδής αληθής αληθής ΟΧΙ = σηµαίνει άρνηση. Οι βασικές λειτουργίες (ή αλλιώς πράξεις) επί των δοµών δεδοµένων είναι οι: Προσπέλαση.

PL/1: γλώσσες χωρίς µεγάλη απήχηση LISP. Κάθε εγγραφή αποτελείται από ένα ή περισσότερα πεδία (fields) Κεφ. γι' αυτό ο προγραµµατισµός στους πρώτους Η/Υ όταν η µόνη δυνατότητα εντολών ήταν σε δυαδική µορφή.65 Αναζήτηση: Υπάρχουν δύο τεχνικές αναζήτησης: η σειριακή και η δυαδική. αλλά ο αριθµός των κόµβων της µεγαλώνει και µικραίνει.µηχανής και συνεπώς την παραγωγή πολλών και σύνθετων προγραµµάτων. οι οποίες αποτελούνται από ακολουθίες δυαδικών ψηφίων (0 κ 1) και συνεπώς είναι κατανοητές από τον επεξεργαστή του Η/Υ και µπορούν να εκτελεσθούν άµεσα από αυτόν (χωρίς µετάφραση). JAVA (διαδίκτυο ): Αντικειµενοστραφείς γλώσσες Σελ 127 Πλεονεκτήµατα γλωσσών υψηλού επιπέδου: (σε σχέση µε τις συµβολικές γλώσσες) [1]φυσικότερος τρόπος έκφρασης – [2]ανεξαρτησία από τον Η/Υ ( µεταφερσιµότητα ) – [3]ευκολία εκµάθησης & εκπαίδευσης – [4]ευκολία στη διόρθωση λαθών & συντήρηση προγραµµάτων. καθώς στη δοµή εισάγονται νέα δεδοµένα ή διαγράφονται άλλα.Out). PASCAL(γενικής) : πετυχηµένες γλώσσες που ολοένα εξελίσσονται. όπως οι πίνακες). ακολουθώντας αυστηρούς κανόνες σύνταξης και για να εκτελεσθούν από τον επεξεργαστή του Η/Υ πρέπει να προηγηθεί η µετάφραση τους σε γλώσσα µηχανής από ένα ειδικό πρόγραµµα (µεταγλωττιστή ή διερµηνευτή). δοµής είναι το αρχείο . Ο εµπρός (front) που δείχνει τη θέση του στοιχείου που θα εξαχθεί και ο πίσω (rear) που δείχνει τη θέση του στοιχείου που µόλις εισήλθε.60 εκπαιδευτηρια βασιλειαδη ∆υναµική δοµή: δεν έχει σταθερό µέγεθος. Χρήση της σειριακής γίνεται όταν ο πίνακας είναι : µη ταξινοµηµένος – σπάνια – σε µικρό πίνακα ( 20 στοιχεία ) δες και σελ 199 Σελ 66 Ταξινόµηση: Η διαδικασία τακτοποίησης των στοιχείων µιας δοµής δεδοµένων κατά αύξουσα ή φθίνουσα σειρά. αλλά στηρίζονται στη τεχνική της δυναµικής παραχώρησης µνήµης. αρκετά κοινά µε Pascal. το συµβολοµεταφραστή (assembler). Για την υλοποίηση µιας στοίβας απαιτείται ένας µονοδιάστατος πίνακας και µια βοηθητική µεταβλητή (δείκτης) που δείχνει το στοιχείο που τοποθετήθηκε τελευταίο στην κορυφή της στοίβας. αλλά ξεπερασµένη COBOL: ιδανική για εµπορικές εφαρµογές.First. Οι δυναµικές δοµές δεν αποθηκεύονται σε συνεχόµενες θέσεις µνήµης.In. C: πολύ δυνατή γλώσσα. ακόµη σε χρήση. Τα στοιχεία ενός αρχείου ονοµάζονται εγγραφές (records).Οι γλώσσες υψηλού επιπέδου αποτέλεσαν επανάσταση στον προγραµµατισµό. Απαιτούνται δύο δείκτες. ακόµη και του ίδιου κατασκευαστή. διότι διευκόλυναν την επικοινωνία ανθρώπου . Οι κύριες λειτουργίες είναι δύο εισαγωγή και εξαγωγή. 3 . PROLOG: τεχνητή νοηµοσύνη BASIC (εκπαίδευσης ). Οι κύριες λειτουργίες σε µια στοίβα είναι η ώθηση στοιχείου στην κορυφή (top) και η απώθηση στοιχείου από τη στοίβα. Ακόµη είναι [3] δύσκολη η γραφή και η συντήρηση Γλώσσα υψηλού επιπέδου: Σύνολο εντολών που αποτελούνται από απλές λέξεις της αγγλικής γλώσσας (οι οποίες λέξεις συνήθως παραπέµπουν στη λειτουργία της εντολής). Όµως η δυαδική µορφή είναι ακατανόητη από τον άνθρωπο.Out). Υποχείλιση (δεν υπάρχει στοιχείο για απώθηση – κενός πίνακας) Υπερχείλιση (δεν υπάρχει χώρος για να γίνει ώθηση – γεµάτος πίνακας ) Ουρά: ∆οµή δεδοµένων µε δύο άκρα (εµπρός και πίσω). δεν διαθέτει [2] εντολές για πιο σύνθετες λειτουργίες και εποµένως είναι δύσκολη η µεταφορά ενός προγράµµατος από έναν υπολογιστή σε άλλο.6 Σελ 118 Γλώσσα µηχανής: Σύνολο εντολών. Σελίδες 64. εκπαιδευτηρια βασιλειαδη Σελ 119 Παραδείγµατα γλωσσών υψηλού επιπέδου FORTRAN: κατάλληλη για επιστηµονικές εφαρµογές. Όµως η συµβολική γλώσσα παραµένει στενά [1] συνδεδεµένη µε την αρχιτεκτονική του Η/Υ. Συµβολική γλώσσα ή γλώσσα χαµηλού επιπέδου: Εξέλιξη της γλώσσας µηχανής. παράδειγµα δυν. Ελάττωση του χρόνου & κόστους παραγωγής προγραµµάτων. µ'αυτήν παρήχθη το λειτουργικό σύστηµα Unix SQL: γλώσσα ερωταποκρίσεων και C+ +. Είναι ειδικές δοµές για την αποθήκευση δεδοµένων στη δευτερεύουσα µνήµη (κυρίως µαγνητικό δίσκο) και τα δεδοµένα τους δεν χάνονται αν διακοπεί η ηλεκτρική παροχή (σε αντίθεση µε τις δοµές της κύριας µνήµης. Στοίβα: Είναι η δοµή δεδοµένων µε ένα άκρο (κορυφή).In. στην οποία το πρώτο στοιχείο που εισάγεται είναι και το πρώτο που µπορεί να εξαχθεί (µέθοδος επεξεργασίας FIFO First. χωρίς σύγχρονες δυνατότητες ALGOL.First.Σηµειώσεις ΑΕΠΠ 2010-2011 Σελίδες 59. ήταν δύσκολος και απαιτούσε πολύ καλή γνώση της αρχιτεκτονικής του Η/Υ. στην οποία το τελευταίο στοιχείο που εισάγεται είναι και το πρώτο που µπορεί να εξαχθεί (µέθοδος επεξεργασίας LIFO Last. Η µέθοδος που χρησιµοποιούµε είναι της φυσαλίδας (ευθείας ανταλλαγής) Σελ 67 ∆οµές δεδοµένων δευτερεύουσας µνήµης: Ονοµάζονται αρχεία (files). αναπαριστά µε συµβολικό τρόπο το δυαδικό κώδικα της γλώσσας µηχανής (σε µορφή περισσότερο οικεία για τον άνθρωπο) και για να εκτελεσθούν οι εντολές της από τον Η/Υ απαιτείται µετάφραση µε ένα ειδικό πρόγραµµα.

Μεταφραστικά προγράµµατα : α) Μεταγλωττιστές (Compilers) β) ∆ιερµηνευτές (Interpreters) Ο µεταγλωττιστής µεταφράζει όλο το πρόγραµµα σε γλώσσα µηχανής και παράγει ένα ανεξάρτητο πρόγραµµα σε γλώσσα µηχανής. Φυσικά πρέπει να έχει προηγηθεί η ιεραρχική σχεδίαση του προγράµµατος. ∆ιορθώνουµε τα συντακτικά λάθη και το διορθωµένο πρόγραµµα το µεταφράζουµε πάλι και πάλι µέχρι να εξαλειφθούν τα λάθη µετατροπή (µετάφραση) προγρ. τη γραµµατική και τη σηµασιολογία της. Στηρίζεται στη χρήση τριών και µόνο στοιχειωδών λογικών δοµών. παράληψη δήλωσης µεταβλητών και εµφανίζονται στο στάδιο της µετάφρασης ( µεταγλωττιστής ή διερµηνευτής) 2. Το πρόγραµµα που επιτρέπει αυτή τη σύνδεση λέγεται συνδέτης. Τµηµατικός προγραµµατισµός:Ονοµάζεται η τεχνική της ανάπτυξης προγραµµάτων κατά την οποία το τελικό πρόγραµµα ανάγεται στην κατασκευή ανεξάρτητων ενοτήτων (υποπρογραµµάτων) και κατόπιν τη σύνδεση µεταξύ τους. Προσοχή στις διαφορές µεταγλωττιστή και διερµηνευτή: 1. λογικά που είναι πιο δύσκολα στη διόρθωση και οφείλονται σε σφάλµατα κατά την υλοποίηση του αλγορίθµου και εµφανίζονται στο στάδιο της εκτέλεσης. ώστε το αρχικό πρόβληµα να έχει υποδιαιρεθεί σε απλούστερα υποπροβλήµατα ( δες και σελ 208). της ακολουθίας. ∆ώστε προσοχή στη γραµµατική (τυπικό & συντακτικό). Όλα τα προγράµµατα γράφονται µόνο µε τη χρήση αυτών των τριών δοµών και κάθε πρόγραµµα ή υποπρόγραµµα έχει µόνο µια είσοδο και µια έξοδο. το πρόγραµµα που παράγει ο µεταγλωττιστής είναι πιο γρήγορο από το αντίστοιχο του διερµηνευτή 3. της επιλογής και της επανάληψης. Σελ 136 Σελ 138 Πλεονεκτήµατα δοµηµένου προγραµµατισµού: [1] δηµιουργία απλούστερων προγραµµάτων [2] µεταφορά αλγορίθµων σε προγράµµατα [3] διευκόλυνση ανάλυσης σε τµήµατα [4]µείωση των λαθών [5] εύκολη κατανόηση και ανάγνωση του προγράµµατος [6]ευκολία στη διόρθωση και συντήρηση. Οµοιότητες µεταγλωττιστή και διερµηνευτή: 1. 4 . ώστε να επιλυθούν εύκολα.Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη ης Γλώσσες 4 γενιάς: είναι γλώσσες που απευθύνονται στους χρήστες των Η/Υ ( επειδή οι προηγούµενες χρησιµοποιούνταν µόνο από τους προγραµµατιστές ) και µπορούν [1] να υποβάλλουν ερωτήσεις στο σύστηµα [2] να αναπτύσσουν εφαρµογές που ανακτούν πληροφορίες και [3] να καθορίσουν τον τρόπο εµφάνισης των πληροφοριών Σελ 130 Μια γλώσσα προσδιορίζεται από: το αλφάβητο της. συντακτικά που οφείλονται σε αναγραµµατισµούς εντολών. σε δυαδική µορφή ανίχνευση λαθών & εµφάνιση διαγνωστικών µηνυµάτων άµεση εκτέλεση ταχύτητα εκτέλεσης αρχικό και εκτελέσιµο πρόγραµµα Μεταγλωττιστής ΝΑΙ ΝΑΙ ΟΧΙ ΓΡΗΓΟΡΗ 2 διαφορετικά προγράµµατα ∆ιερµηνευτής ΝΑΙ ΝΑΙ ΝΑΙ ΑΡΓΗ ΤΟ Ι∆ΙΟ ΠΡΟΓΡΑΜΜΑ Λάθη : τα λάθη είναι δύο ειδών 1. µέχρι το τελευταίο επίπεδο που οι λειτουργίες είναι πολύ απλές. Στο αντικείµενο πρόγραµµα συνδέονται και τα υποπρογράµµατα (που τα παίρνει από τις βιβλιοθήκες) και παράγεται το εκτελέσιµο πρόγραµµα. Πηγαίο είναι το αρχικό πρόγραµµα ενώ το µεταφρασµένο λέγεται αντικείµενο. ο µεταγλωττιστής παράγει ανεξάρτητο πρόγραµµα ενώ ο διερµηνευτής όχι 2.Ρίξτε µια µατιά στις διαφορές φυσικών & τεχνητών γλωσσών σελ131 Σελ 127 Σελ 132 Ιεραρχική σχεδίαση προγράµµατος: Είναι ο καθορισµός των βασικών λειτουργιών ενός προγράµµατος σε ανώτερο επίπεδο και στη συνέχεια η διάσπαση των λειτουργιών αυτών σε όλο και µικρότερες λειτουργίες (σχεδίαση από πάνω προς τα κάτω). µε το διερµηνευτή διορθώνουµε πιο εύκολα τα λάθη (φάση δηµιουργίας) γιατί το πρόγραµµα που παράγει ο µεταγλωττιστής δεν εκτελείται άµεσα ( πρώτα περνά από τη διαδικασία της µεταγλώττισης και σύνδεσης ) ενώ του διερµηνευτή εκτελείται άµεσα. Εµπεριέχει τόσο την ιεραρχική σχεδίαση όσο και τον τµηµατικό προγραµµατισµό. Ο διερµηνευτής διαβάζει µια προς µία τις εντολές του αρχικού προγράµµατος και εκτελεί αµέσως µια ακολουθία εντολών µηχανής. ανιχνεύουν (προσοχή) τα συντακτικά λάθη και εµφανίζουν κατάλληλα διαγνωστικά µηνύµατα. ∆οµηµένος Προγραµµατισµός: Είναι µία κοινή µεθοδολογία ανάπτυξης προγραµµάτων που µείωσε τη χρήση των εντολών GOTO. µετατρέπουν (µεταφράζουν) ένα πρόγραµµα που γράφτηκε σε γλώσσα προγραµµατισµού σε γλώσσα µηχανής ( σε γλώσσα αναγνωρίσιµη από τον Η/Υ : ψηφία 0 και 1 ) 2. το λεξιλόγιο.

µεταβλητών. Προσοχή! Για τη δήλωση χρησιµοποιείται το σύµβολο = . πραγµατικοί. Σελ 153 Συναρτήσεις: Μάθετε τις συναρτήσεις της παραγράφου 7.Η µεταβλητή και η έκφραση πρέπει να είναι του ιδίου τύπου. Για να δηλώσουµε σχόλιο βάζουµε το σύµβολο ! στην αρχή της γραµµής.. Αριθµητικές εκφράσεις : όταν µια τιµή προκύπτει από υπολογισµό. έκφραση πρέπει προηγουµένως να έχουν πάρει τιµή . Εκτός από τη θεωρία χρειάζονται και στις ασκήσεις. του οποίου η τιµή µπορεί να αλλάζει κατά τη διάρκεια λειτουργίας του προγράµµατος. παρενθέσεις. µεταβλητές.7 Σελ 148 Αλφάβητο ΓΛΩΣΣΑΣ: ∆ιαβάστε την παραγρ.6.χ. ενώ στο δεξιό οποιαδήποτε έκφραση(αριθµητική–χαρακτήρας–λογική). Βοηθούν στην κατανόηση του προγράµµατος από τρίτους (π. [2] Ύψωση σε δύναµη [3] Πολλαπλασιασµός & διαίρεση [4]Πρόσθεση και αφαίρεση. Σχόλια: Επεξηγήσεις γι' αυτόν που διαβάζει το πρόγραµµα. Όταν η ιεραρχία είναι η ίδια οι πράξεις γίνονται από αριστερά προς τα δεξιά Εντολή εκχώρησης. Στις εκφράσεις χρησιµοποιούµε σταθερές. Εντολές εισόδου – εξόδου: Κατά την εκτέλεση το προγράµµατος η εντολή ∆ΙΑΒΑΣΕ διακόπτει την εκτέλεσή του και περιµένει την εισαγωγή δεδοµένων (από το πληκτρολόγιο). Επιπλέον πρέπει υποχρεωτικά να αρχίζουν από γράµµα.14. τελεστές . χωρίς αυτά να αποτελούν εντολές του . Η χρήση τους κάνει το πρόγραµµα πιο κατανοητό και ευκολότερο στη διόρθωση και συντήρηση. συναρτήσεις. Μερικές λέξεις που χρησιµοποιούνται από την ίδια τη ΓΛΩΣΣΑ λέγονται δεσµευµένες και δεν µπορούν να χρησιµοποιηθούν για ονόµατα (π. για να εξηγήσουµε τι παριστάνει µια µεταβλητή ή γιατί κάνουµε µια αλγεβρική πράξη) ΠΡΟΓΡΑΜΜΑ ΧΧΧ ΣΤΑΘΕΡΕΣ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ : … ΑΚΕΡΑΙΕΣ : … ΧΑΡΑΚΤΗΡΕΣ : … ΛΟΓΙΚΕΣ : … ΑΡΧΗ … … ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ • Κάθε εντολή σε ξεχωριστή γραµµή – αν δεν χωρά τότε η επόµενη γραµµή αρχίζει µε το σύµβολο & • Σχόλια: ξεκινά η γραµµή µε το θαυµαστικό ! • Τα υποπρογράµµατα γράφονται µετά το τέλος του προγράµµατος • Οι πίνακες δηλώνονται µε το µέγιστο πλήθος γραµµών & στηλών πχ Α [ 20.Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη Για τη δηµιουργία.) Αριθµητικοί τελεστές: Μελετείστε τον πίνακα της σελίδας 153. Στο αριστερό σκέλος µιας εντολής εκχώρησης βρίσκεται πάντοτε µεταβλητή. Συµβολικές σταθερές: Ονόµατα σταθερών που αντιστοιχίζονται µε τις σταθερές ( πχ π=3. Μην ξεχνάτε ότι οι τελεστές DIV και MOD χρησιµοποιούνται µόνο για ακέραιους αριθµούς και δίνουν πάντοτε ακέραιο αποτέλεσµα. ∆ΙΑΒΑΣΕ.14 είναι η σταθερά) Σελ 151 Σελ 150 Μεταβλητές: Ονόµατα που χρησιµοποιούνται για να παραστήσουν ένα στοιχείο. 7. 40 ] ∆ΙΑ∆ΙΚΑΣΙΑ … ΣΥΝΑΡΤΗΣΗ … 5 εκπαιδευτηρια βασιλειαδη ∆οµή προγράµµατος Σελ 157 .1 Τύποι δεδοµένων ή αποτελεσµάτων: ακέραιοι.χ. προγράµµατος) µπορούν να αποτελούνται από γράµµατα πεζά ή κεφαλαία του ελληνικού ή του λατινικού αλφάβητου. ΑΝ. χαρακτήρας κλπ) Προσοχή! Όλα τα ονόµατα (σταθερών. ΑΠΟ. χαρακτήρες ή αλφαριθµητικοί. µετάφραση και εκτέλεση ενός προγράµµατος απαιτούνται ο συντάκτης ο µεταγλωττιστής και ο συνδέτης Κεφ. λογικοί Σταθερές: Προκαθορισµένες τιµές που δεν µεταβάλλονται κατά τη διάρκεια εκτέλεσης του προγράµµατος. Η ΓΡΑΨΕ εµφανίζει τα αποτελέσµατα. Σελ 154 Ιεραρχία πράξεων : [1] Πράξεις µέσα σε παρένθεση. τα ψηφία 0 έως 9 και την κάτω παύλα ( _ ). . ∆ηλώνονται στην αρχή του προγράµµατος (πριν τις µεταβλητές). το π είναι συµβολική σταθερά ενώ το 3. Όλες οι µεταβλητές που χρησιµοποιούνται σε µια αριθµ. αριθµ. Ενώ η τιµή της αλλάζει κατά την εκτέλεση του προγράµµατος αυτό που δεν αλλάζει είναι ο τύπος (ακέραιος .

κλπ ) σε αγκύλες ή παρενθέσεις. επεξεργασία και εκτύπωση των στοιχείων ενός πίνακα γίνεται πάντοτε από βρόχους ( επαναλήψεις ) Σελ 191 Πλεονεκτήµατα : [1] διαχείριση πολλών µεταβλητών του ιδίου τύπου [2] διατήρηση των στοιχείων του πίνακα στη µνήµη µέχρι το τέλος του προγράµµατος Μειονεκτήµατα : [1] απαιτούν µνήµη [2] περιορίζουν τις δυνατότητες του προγράµµατος (στατική δοµή – σταθερό µέγεθος που δηλώνεται στην αρχή του προγράµµατος και σε συνεχόµενες θέσεις µνήµης ) Σελ 198 Τυπικές επεξεργασίες πινάκων : [1] Εύρεση µέγιστου .χ. τα οποία αναφέρονται µε το ίδιο όνοµα. 165 και πώς γίνονται οι συγκρίσεις µεταξύ των διαφόρων τύπων δεδοµένων . Πλεονεκτήµατα τµηµατικού προγραµµατισµού : [1] ευκολία στην ανάπτυξη αλγορίθµου και προγράµµατος [2] ευκολία στην κατανόηση και διόρθωση από τρίτους [3] εξοικονόµηση χρόνου και κόπου ( κόστος παραγωγής ) στη γραφή του προγράµµατος και [4] επέκταση των δυνατοτήτων (εµπλουτισµός ) των γλωσσών προγραµµατισµού Σελίδες 210. (άρα να αποφεύγονται ) Πρέπει επίσης να αποφεύγονται οι περιττοί έλεγχοι ( παράδειγµα σελ 171 και 172) Σελ 175 Τιµή φρουρός : τιµή που τερµατίζει το πρόγραµµα ή έναν βρόχο επανάληψης Σελ 165 Σελ 180 Εµφωλευµένοι βρόχοι: [1] ο εσωτερικός να βρίσκεται µέσα εξολοκλήρου στον εξωτερικό [2] η είσοδος σε κάθε βρόχο γίνεται από την αρχή του και [3] δεν επιτρέπεται να χρησιµοποιηθεί η ίδια µεταβλητή σε βρόχους που ο ένας είναι µέσα στον άλλο. Υπάρχουν 2 είδη παραµέτρων οι πραγµατικές ( που είναι οι παράµετροι του προγράµµατος που στέλνει τις τιµές στο υποπρόγραµµα ) και οι τυπικές που είναι οι παράµετροι του υποπρογράµµατος που δέχεται τις τιµές. Η αναφορά στα στοιχεία γίνεται µε το όνοµα του πίνακα ακολουθούµενο από ένα δείκτη ( ανάλογα αν είναι µονοδιάστατος. Λογική έκφραση οποιαδήποτε σχέση έχει συγκριτικό τελεστή. Πχ Χ>Ψ είναι λογική έκφραση. Η τεχνική αυτή είναι ένα από τα βασικότερα χαρακτηριστικά του δοµηµένου προγραµµατισµού. δισδιάστατος.10 Τµηµατικός προγραµµατισµός : είναι η τεχνική σχεδίασης και ανάπτυξης προγραµµάτων ως σύνολο από απλούστερα προγράµµατα. Κάποιες από τις επεξεργασίες αναφέρονται και σε δισδιάστατους πίνακες πχ αθροίσµατα στηλών ή µέγιστο κάθε γραµµής κλπ Τετραγωνικός πίνακας: Ο δισδιάστατος πίνακας που το µέγεθος των δύο διαστάσεων είναι ίδιο (π. αριθµητικών – χαρακτήρων (αλφαβητική σειρά) – λογικών (µόνο = και <> ) Ιεραρχία τελεστών : πρώτα οι αριθµητικοί έπειτα οι συγκριτικοί και τέλος οι λογικοί Λογικοί τελεστές και σύνθετες λογικές εκφράσεις. Το αποτέλεσµα µιας λογικής έκφρασης είναι αληθής /ψευδής Χρήση εµφωλευµένων ΑΝ οδηγεί συνήθως σε πολύπλοκες δοµές που αυξάνουν την πιθανότητα λάθους και τη δυσκολία κατανόησης του προγράµµατος. Κάθε ένα από αυτά τα αντικείµενα ονοµάζεται στοιχείο του πίνακα. ∆ύο είναι οι πλέον διαδεδοµένοι τρόποι αναζήτησης η σειριακή και η δυαδική που γίνεται µόνο σε ταξινοµηµένο πίνακα και είναι πιο αποδοτική από τη σειριακή. 5 γραµµές και 5 στήλες) και γενικά συµβολίζεται ως πίνακας nxn. Υπάρχουν 3 κανόνες για τις παραµέτρους : [1] το πλήθος των πραγµατικών πρέπει να είναι ίσο µε 6 . Υποπρόγραµµα : είναι ένα ανεξάρτητο τµήµα προγράµµατος που επιτελεί αυτόνοµο έργο και έχει γραφεί χωριστά από το υπόλοιπο πρόγραµµα Χαρακτηριστικά υποπρογραµµάτων : Σελ 208 [1] µόνο µια είσοδο και µια έξοδο [2] το κάθε ένα να είναι ανεξάρτητο από το άλλο και [3] να µην είναι πολύ µεγάλο.8 Συγκριτικοί τελεστές: Μελετείστε καλά τον πίνακα της σελ. Η ανάγνωση. Κεφ.Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη Κεφ. Κεφ.ελάχιστου [2] υπολογισµός αθροισµάτων [3] ταξινόµηση των στοιχείων [4] συγχώνευση 2 πινάκων [5] αναζήτηση ενός στοιχείου.217 εκπαιδευτηρια βασιλειαδη Σελ 205 Παράµετρος : είναι µια µεταβλητή που επιτρέπει το πέρασµα της τιµής της από ένα τµήµα προγράµµατος σε άλλο.9 Πίνακας : σύνολο από αντικείµενα ίδιου τύπου.

…. n 1. Σελ 211 ∆ιαδικασία : υποπρόγραµµα που µπορεί και εκτελεί όλες τις λειτουργίες ενός προγράµµατος ( εισαγωγή δεδοµένων – µεταβολή τιµών µεταβλητών – εκτύπωση – υπολογισµούς ) Συνάρτηση : υποπρόγραµµα που υπολογίζει και επιστρέφει µόνο ΜΙΑ τιµή ∆ΙΑΦΟΡΕΣ & ΧΑΡΑΚΤΗΡΙΣΤΙΚΑ ΥΠΟΠΡΟΓΡΑΜΜΑΤΩΝ ∆ΙΑ∆ΙΚΑΣΙΑ ΣΥΝΑΡΤΗΣΗ 0.Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη αυτό των τυπικών [2] οι παράµετροι των αντίστοιχων θέσεων είναι του ίδιου τύπου δεδοµένων και [3] οι τιµές περνούν από το ένα τµήµα του προγράµµατος στο άλλο στις αντίστοιχες θέσεις. 3. n Όλες όσες δέχεται Μόνο ΜΙΑ τιµή Εντολές που χρησιµοποιεί Όλες τις εντολές ΟΧΙ ΓΡΑΨΕ & ∆ΙΑΒΑΣΕ Η ΚΛΗΣΗ γίνεται Με την ΚΑΛΕΣΕ Με το όνοµα της Τύπος υποπρογράµµατος ΟΧΙ ΝΑΙ Εντολή εκχώρησης µε το όνοµα ΟΧΙ ΝΑΙ Πόσες παραµέτρους δέχεται Πόσες τιµές επιστρέφει Παρατηρήσεις – Σχόλια Λογικός τύπος δεδοµένων : παίρνει τιµή αληθής . 2. Έκφραση : Μεταβλητή  έκφραση ( άρα έκφραση είναι το δεξί µέρος της εντολής εκχώρησης) 7 . ψευδής ( πχ flag  αληθής ) Λογικοί τελεστές : ΟΧΙ ΚΑΙ Η Λογικές εκφράσεις : σχέσεις που έχουν τελεστή σύγκρισης πχ Χ>Ψ (το αποτέλεσµα είναι ΑΛΗΘΗΣ/ΨΕΥ∆ΗΣ) Αριθµητικές εκφράσεις : σχέσεις που υπολογίζουν µια τιµή (περιέχουν σταθερές. συναρτήσεις. 1. µεταβλητές. Το αποτέλεσµα είναι ένας αριθµός. 2. αριθµητικούς τελεστές και παρενθέσεις). … .

150. κείµενο ή κατάσταση Ανάλογα µε το περιεχόµενο η µεταβλητή είναι αριθµητική. 3] προσθ. 149. ΟΧΙ δεσµευµένες λέξεις (∆ΙΑΒΑΣΕ κλπ) Όνοµα Μεταβλητή Περιεχόµενο Τύπος δεδοµένων Μπορεί να είναι αριθµός. ένα συρτάρι) που γεµίζει µε µια τιµή 1. Μια δοµή µέσα σε άλλη ΤΕΛΟΣ_ΑΝ 3] ΑΝ … ΤΟΤΕ … ΑΛΛΙΩΣ_ΑΝ …ΤΟΤΕ … ΑΛΛΙΩΣ_ΑΝ …ΤΟΤΕ … ΑΛΛΙΩΣ … ΤΕΛΟΣ_ΑΝ… 8 2] ΓΙΑ … 3] ΜΕΧΡΙΣ_ΟΤΟΥ . ψηφίων . 153 Αυτό που αλλάζει σε µια µεταβλητή είναι το περιεχόµενό της ( ΜΟΝΟ αυτό ) ΤΕΛΕΣΤΕΣ ( σύµβολα πράξεων ) • • • + – * / ^ DIV > = < <> >= <= ΟΧΙ ΚΑΙ Η MOD (αριθµητικοί) (συγκριτικοί) (λογικοί) Προτεραιότητα αριθµητικών τελεστών : 1]δυνάµεις.Σελ 31 . ¨ Μανωλης ¨ Σελ 1. 2]πολ/σµός & διαίρεση. 150 ΣΤΑΘΕΡΕΣ : Προκαθορισµένες τιµές πχ 3.39 165. Ξεκινά µε γράµµα 3. αλφαριθµητική ή λογική Σελ 31 .& αφαίρεση Όταν υπάρχουν πράξεις ίδιας προτεραιότητας τότε οι πράξεις γίνονται από αριστερά προς τα δεξιά Προτεραιότητα τελεστών ΑΡΙΘΜΗΤΙΚΟΙ  ΣΥΓΚΡΙΤΙΚΟΙ  ΛΟΓΙΚΟΙ DIV MOD ΑΚΕΡΑΙΑ ∆ΙΑΙΡΕΣΗ ΜΕ ΑΚΕΡΑΙΟΥΣ ΑΡΙΘΜΟΥΣ Χ  7 div 2 (X=3) DIV = Πηλίκο MOD = Υπόλοιπο Ψ  7 mod 2 (Ψ=1) Βασικές συνιστώσες/εντολές αλγορίθµου: ∆οµή ακολουθίας ∆οµή επανάληψης 1] ∆ΙΑΒΑΣΕ 2] ΕΜΦΑΝΙΣΕ 3]  1] ΟΣΟ … ∆οµή επιλογής 1] ΑΝ …ΤΟΤΕ 2] ΑΝ … ΤΟΤΕ … … ΤΕΛΟΣ_ΑΝ ΑΛΛΙΩΣ … Εµφωλευµένες ∆ιαδικασίες Σύνθεση όλων των δοµών.14 . Χρήση γραµµάτων. κάτω παύλας 2. 151 Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη ΜΕΤΑΒΛΗΤΕΣ : ποσότητες που η τιµή τους µπορεί να µεταβάλλεται Είναι µια θέση µνήµης (ένα κουτάκι.

…. Αλφαριθµητικές (γράµµατα και αριθµούς ). Scaner. Χ • Εµφάνισε το περιεχόµενο της µεταβλητής Χ) (εµφανίζει την πρόταση : δώσε κωδικό ) • ΓΡΑΨΕ (τι κάνει ? ) Προσοχή ! ! ! Πάντοτε πρέπει να υπάρχει η εντολή αυτή ( συνήθως στο τέλος του αλγορίθµου ) η οποία θα εµφανίζει τα αποτελέσµατα του αλγορίθµου. 154 Σελ 30. ΤΟΤΕ Εντολες 1 ΑΛΛΙΩΣ_ΑΝ συνθ2 ΤΟΤΕ Εντολες 2 ΑΛΛΙΩΣ_ΑΝ συνθ3 ΤΟΤΕ Εντολες 3 ΑΛΛΙΩΣ_ΑΝ συνθ4 ΤΟΤΕ Εντολες 4 …. µικρόφωνο. τελεστών κλπ. κλπ).Σελ 30. ΑΛΛΙΩΣ Εντολες Ν ΤΕΛΟΣ_ΑΝ ΠΟΛΛΑΠΛΗ 2 Υπάρχει άλλη µία δοµή Απλής επιλογής : ΑΝ συνθήκη ΤΟΤΕ Εντολή . Συνήθως την εντολή αυτή την συναντούµε στην αρχή του αλγορίθµου • ∆ΙΑΒΑΣΕ Χ • ∆ΙΑΒΑΣΕ ΟΝΟΜΑ. µεταβλητών. Modem. • Χ  30 • Όνοµα  ‘’ Ηλίας’’ • ∆ιεύθυνση  ‘’ Παπάφη 43’’ • Done  Αληθής • Sum  Α + Β * ( Ε + ∆ )/2 • ΧΧ+1 ΕΜΦΑΝΙΣΕ ( Εντολή εξόδου ) (εκτυπώνει • Εκτύπωσε Χ ΄΄ δώσε κωδικό ΄΄ ΄΄ το αποτέλεσµα είναι ΄΄. Αυτό που υπάρχει στο δεξί µέρος τοποθετείται στην µεταβλητή που είναι αριστερά ( δηλαδή έτσι όπως δείχνει το βέλος ). 156 Σελ 30. ΑΠΛΗ ΑΝ συνθ ΤΟΤΕ εντολες ΤΕΛΟΣ_ΑΝ ΣΥΝΘΕΤΗ ΑΝ συνθ ΤΟΤΕ Εντολες 1 ΑΛΛΙΩΣ Εντολες 2 ΤΕΛΟΣ_ΑΝ ΠΟΛΛΑΠΛΗ 1 ΑΝ συνθ 1. Λογικές (αληθής – ψευδής ) και αποτελέσµατα αριθµητικών πράξεων πχ. η οποία χρησιµοποιείται όταν θέλουµε να εκτελέσουµε ΜΟΝΟ µία εντολή µετά από κάποια συνθήκη 9 . και το αποτέλεσµα αποδίδεται σε µια µεταβλητή πχ Χ  Α + Β*4 – Σ^3 Η εντολή αυτή είναι εντολή ανάθεσης τιµών σε µεταβλητές. Οι τιµές µιας έκφρασης είναι Αριθµητικές. 155 Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη ∆ΙΑΒΑΣΕ ( Εντολή εισόδου ) Εντολή εισόδου – εισάγει τα δεδοµένα στον αλγόριθµο (στον υπολογιστή από το πληκτρολόγιο – και τις υπόλοιπες συσκευές εισόδου : δισκέτα. Μπορούµε να αναθέσουµε τιµές. CD. DVD. ΜΙΣΘΟΣ Ότι πληκτρολογήσει ο χρήστης θα αποθηκευθεί στις µεταβλητές ∆ΕΝ γνωρίζουµε το περιεχόµενο των µεταβλητών γιατί ο χρήστης είναι ελεύθερος να πληκτρολογήσει ότι θέλει µεταβλητή  έκφραση ( ΕΝΤΟΛΗ ΕΚΧΩΡΗΣΗΣ ) Έκφραση είναι συνδυασµός σταθερών.

δηλαδή να υπάρχει ∆ΙΑΒΑΣΕ ή εντολή ΕΚΧΩΡΗΣΗΣ που να έχει σχέση µε τη συνθήκη επαναληπτικές δοµές διαγραµµατικά ΟΣΟ & ΓΙΑ : πρώτα η συνθήκη και έπειτα πράξεις ΜΕΧΡΙΣ_ΟΤΟΥ : πρώτα πράξεις και έπειτα συνθήκη Όσο η συνθήκη είναι ψευδής (αν απαντούµε ΟΧΙ στη συνθήκη ) Όταν η συνθήκη γίνει αληθής Όταν υπάρχει έλεγχος τιµών (τιµές που πρέπει να ικανοποιούν κάποια όρια πχ βαθµοί 0-100) Οµοίως µε την ΟΣΟ Όταν το πλήθος των επαναλήψεων είναι γνωστό από πριν Ακριβώς το αντίθετο µε τις δυο προηγούµενες ( δηλαδή να µην «αλλάζουµε» το µετρητή ) ΜΕΧΡΙΣ ΟΤΟΥ ΟΣΟ συνθήκη Όσο ο µετρητής είναι µικρότερος ή ίσος από το µέχρι.. Τέλος_επανάληψης συγκεκριµένος και γνωστός από πριν ( µπορεί και µηδέν ) ΑΡΧΗ αριθµός επαναλήψεων ? Αρχή_επανάληψης εντολές …. Μέχρις_οτου <συνθήκη> ΤΟΥΛΑΧΙΣΤΟΝ µια φορά θέση συνθήκης ΑΡΧΗ ΤΕΛΟΣ σύνταξη η επανάληψη λειτουργεί Όσο η συνθήκη είναι αληθής (αν απαντούµε ΝΑΙ στη συνθήκη ) η επανάληψη σταµατά Όταν η συνθήκη γίνει ψευδής Πότε τη χρησιµοποιούµε? Πρέπει απαραίτητα Σε όλες τις περιπτώσεις να υπάρχει µέσα στην επανάληψη εντολή που να «αλλάζει» τη µεταβλητή στη συνθήκη.Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη ΟΣΟ ΜΕΧΡΙΣ_ΟΤΟΥ ΓΙΑ Όσο <συνθήκη> επανάλαβε εντολές …. (ή µεγαλύτερος-ίσος από το µέχρι …) Όταν ο µετρητής ξεπεράσει το µέχρι… πράξεις ΓΙΑ συνθήκη ΟΧΙ ΟΧΙ ΝΑΙ ΟΧΙ πράξεις 10 συνθήκη ΝΑΙ πράξεις ΝΑΙ . Τέλος_επανάληψης Για χ από … µέχρι … µε_βήµα εντολές ….

008 / sec Τι θα πληρώσει κάποιος αν α) µιλήσει 100 sec.20 € το χιλιόµετρο • πληρώνει επίσης την βενζίνη που καταναλώνει το αυτοκίνητο του πωλητή µε τιµή 1. τα πρώτα 10 κιλά χρεώνονται µε 1.8 €.2 € τα επόµενα 20 µε … κλπ 1. Παράδειγµα άσκησης Όταν ταξιδεύουµε µε αεροπλάνο δικαιούµαστε να έχουµε βάρος αποσκευών 22 κιλά ανα επιβάτη. Παράδειγµα άσκησης Μια εταιρεία ενοικίασης ιστιοπλοϊκών σκαφών εφαρµόζει τον παρακάτω τρόπο χρέωσης • για ναύλο από 1 µέχρι και 3 ηµέρες 700 € • για κάθε ηµέρα καθυστέρησης 200 € • αν οι µέρες καθυστέρησης ξεπεράσουν τις 8 τότε πληρώνει 180 € για κάθε µέρα καθυστέρησης πέραν των 8 Να γράψεις αλγόριθµο που να διαβάζει το πλήθος των ηµερών ενοικίασης και να εµφανίζει το ποσό της χρέωσης µε τον εξής τρόπο : «Ηµέρες ενοικίασης 14» «Χρέωση 2030€ σας ευχαριστούµε για την προτίµησή σας» 4. β) µιλήσει 250 sec Πως καταλαβαίνουµε αν υπάρχει κλιµακωτή χρέωση ? Α] αν το λέει ρητά η εκφώνηση Β] αν υπάρχει παράδειγµα το οποίο ξεκαθαρίζει την περίπτωση της κλιµακωτής χρέωσης Γ] από τα συµφραζόµενα της άσκησης (πχ . Κάθε επιπλέον κιλό χρεώνεται µε 1. Αν εργαστεί µηνιαίως περισσότερες ώρες από 140 τότε κάθε επιπλέον ώρα πληρώνεται µε 12 € την ώρα. Να γράψεις αλγόριθµο που να διαβάζει τις ώρες που εργάστηκε ο εργαζόµενος και να εµφανίζει τις καθαρές αποδοχές του αν έχει κρατήσεις 12%.006 / sec 0. 2.15 € το χιλιόµετρο • για κάθε χιλιόµετρο πάνω από τα 500 πληρώνει 0. 3. Να γράψεις αλγόριθµο που να διαβάζει το βάρος των αποσκευών ενός επιβάτη και να εµφανίζει το ποσό πληρωµής που πιθανόν να πληρώσει.005 / sec 0. Παράδειγµα άσκησης Η αµοιβή ενός εργαζοµένου είναι 7€ την ώρα.2 € το χιλιόµετρο Να γράψεις αλγόριθµο που να διαβάζει την αρχική και την τελική ένδειξη του χιλιοµετρητή (κοντέρ) του αυτοκινήτου του πωλητή και να υπολογίζει τα χρήµατα που πρέπει να πάρει ο πωλητής 11 .Σηµειώσεις ΑΕΠΠ 2010-2011 εκπαιδευτηρια βασιλειαδη ΚΛΙΜΑΚΩΤΗ ΧΡΕΩΣΗ Ασκήσεις που στην λύση τους χρησιµοποιούµε την δοµή επιλογής ακολουθώντας την «κλίµακα χρέωσης» δηλαδή σε κάθε σκαλί της κλίµακας έχουµε διαφορετική τιµή χρέωσης.. Πχ έστω ότι υπάρχει η παρακάτω κλίµακα χρέωσης για χρήση κινητού τηλεφώνου 401– 900sec 121 – 400sec Από 0 – 120sec 0. Παράδειγµα άσκησης Μια εταιρεία πληρώνει τους πωλητές της για έξοδα εκτός έδρας όπως παρακάτω • για κάθε χιλιόµετρο µέχρι και τα 500 πληρώνει 0.

οµοίως και να βρίσκει αν τον καλύτερο βαθµό τον έχει αγόρι ή κορίτσι 4. Αν πρόκειται για τον ίδιο αθλητή να εµφανίζει «ο ίδιος είναι ταυτόχρονα ψηλότερος και βαρύτερος» διαφορετικά να εµφανίζει «πρόκειται για 2 διαφορετικούς αθλητές». να δέχεται για 52 αθλητές sumo το βάρος και το ύψος τους. 5. Να εµφανίζει το ύψος του ψηλότερου και το βάρος του βαρύτερου. να διαβάζει το ύψος 400 αθλητών του volley και να εµφανίζει το ύψος του ⌦ ψηλότερου αθλητή και του ⌦ κοντότερου αθλητή 2. να δέχεται για 32 µαθητές τον βαθµό του απολυτηρίου και το φύλο τους (‘Α’= για τα αγόρια και ‘Κ’= για τα κορίτσια) και να υπολογίζει και εµφανίζει ⌦ τον µέσο όρο της τάξης ⌦ τον µέσο όρο των κοριτσιών ⌦ ποιος µαθητής/τρια έχει τον µεγαλύτερο βαθµό ( ποιος α/α ) ⌦ (υποθέστε ότι δεν υπάρχουν µαθητές µε τον ίδιο βαθµό) 3. 12 .Σηµειώσεις ΑΕΠΠ 2010-2011 ΜΑΧ – εκπαιδευτηρια βασιλειαδη ΜΙΝ Πρόβληµα: να διαβάζει τις 50 προσπάθειες ακοντιστών & να βρίσκει την καλύτερη 1η Μέθοδος (ειδική) Θέτουµε αυθαίρετα ⌦ τη µικρότερη τιµή στο max 2η Μέθοδος (γενική) Θέτουµε στο max την πρώτη τιµή ⌦ τη µεγαλύτερη τιµή στο min Προσοχή Αλγόριθµος Ακόντιο Αλγόριθµος Ακόντιο ∆ιάβασε ΠΡ max  ΠΡ max  0 Για x από 1 µέχρι 50 ∆ιάβασε ΠΡ Αν ΠΡ > max τότε max  ΠΡ 2 Για x από µέχρι 50 ∆ιάβασε ΠΡ Αν ΠΡ > max τότε max  ΠΡ Τέλος_αν Τέλος_επανάληψης Εµφάνισε max Τέλος_αν Τέλος_επανάληψης Τέλος Ακόντιο Εµφάνισε max Τέλος Ακόντιο 1. να διαβάζει 500 τυχαίους αριθµούς και να εµφανίζει ποιος είναι ο µεγαλύτερος και ποιος είναι ο µικρότερος.

1. Από ΟΣΟ σε ΜΕΧΡΙΣ_ΟΤΟΥ ⌦ η συνθήκη αλλάζει (η µια είναι το λογικό συµπλήρωµα της άλλης ) πχ Όσο χ<> 0 επανάλαβε Μέχρις_οτου χ=0 ⌦ Τοποθετούµε ολόκληρη την Μέχρις_ότου µέσα σε ένα ΑΝ που έχει την ίδια συνθήκη µε την Όσο ( πιθανόν να µη χρειάζεται ) Χβ Αν Χ <> 0 τότε Χβ Όσο Χ <> 0 επανάλαβε Εµφάνισε ‘‘ΟΚ’’ ΧΧ+1 Τέλος_επανάληψης Αρχή_επανάληψης Εµφάνισε ‘‘ΟΚ’’ ΧΧ+1 Μέχρις_ότου Χ = 0 Τέλος_αν 2. Από ΜΕΧΡΙΣ_ΟΤΟΥ σε ΟΣΟ ⌦ η συνθήκη αλλάζει (η µια είναι το λογικό συµπλήρωµα της άλλης ) ⌦ Πριν από την Όσο γράφουµε όλες τις εντολές του βρόχου ( ώστε να εκτελεστούν τουλάχιστον µια φορά πράγµα που είναι πιθανόν να µη χρειάζεται ) Χβ Χβ Αρχή_επανάληψης Εµφάνισε ‘‘ΟΚ’’ ΧΧ+1 Μέχρις_ότου Χ = 0 Εµφάνισε ‘‘ΟΚ’’ ΧΧ+1 Όσο Χ <> 0 επανάλαβε Εµφάνισε ‘‘ΟΚ’’ ΧΧ+1 Τέλος_επανάληψης 3.εκπαιδευτηρια βασιλειαδη.. ΜΕΤΑΤΡΟΠΗ ∆ΟΜΗΣ ΕΠΑΝΑΛΗΨΗΣ ΟΣΟ ΓΙΑ ΜΕΧΡΙΣ_ΟΤΟΥ Οι µετατροπές από µια µορφή επανάληψης σε άλλη πρέπει να γίνονται µε ιδιαίτερη προσοχή. Από ΓΙΑ σε ΟΣΟ και έπειτα σε ΜΕΧΡΙΣ_ΟΤΟΥ ⌦ Αν το βήµα είναι θετικό τότε γίνεται Όσο Χ <= 10 επανάλαβε ⌦ ενώ αν είναι αρνητικό τότε γίνεται Όσο Χ >= 10 επανάλαβε Χ1 Για χ από 1 µέχρι 10 µε_βήµα 2 Εµφάνισε ‘’ΟΚ’’ Τέλος_επανάληψης Όσο x <= 10 επανάλαβε Εµφάνισε ‘‘ΟΚ’’ ΧΧ+2 Τέλος_επανάληψης Χ1 Για χ από 1 µέχρι 10 µε_βήµα – 2 Εµφάνισε ‘’ΟΚ’’ Τέλος_επανάληψης Όσο x >=10 επανάλαβε Εµφάνισε ‘‘ΟΚ’’ ΧΧ–2 Τέλος_επανάληψης Μετατροπή δοµής επιλογής σε άλλη δοµή επιλογής 13 κλητος .

.. β να εµφανίζει το ίδιο αποτέλεσµα µε το αρχικό....εκπαιδευτηρια βασιλειαδη... Αν ... ΠΟΛΛΑΠΛΗ ΑΝ ΑΠΛΕΣ ΠΟΛΛΑΠΛΗ Προσοχή χρειάζεται στην µετατροπή µιας δοµής επιλογής σε άλλη...... Αν ... ΓΡΑΨΕ "∆ώσε αριθµό από 0 έως και 5" ∆ΙΑΒΑΣΕ Χ ΑΝ Χ = 0 ΤΟΤΕ ΓΡΑΨΕ "µηδέν" ΑΛΛΙΩΣ_ΑΝ (Χ = 1) ή (Χ = 3) ή (Χ = 5) ΤΟΤΕ ΓΡΑΨΕ "περιττός αριθµός" ΑΛΛΙΩΣ_ΑΝ (Χ = 2) ή (Χ = 4) ΤΟΤΕ ΓΡΑΨΕ "άρτιος αριθµός" ΑΛΛΙΩΣ ΓΡΑΨΕ "έδωσες λάθος αριθµό" ΤΕΛΟΣ_ΑΝ Μονάδες 6 14 κλητος ....2 Στο παρακάτω τµήµα προγράµµατος να µετατρέψετε την αλγοριθµική δοµή της πολλαπλής επιλογής σε ισοδύναµη αλγοριθµική δοµή ΕΠΙΛΕΞΕ.... τότε Α←Α-1 αλλιώς Α←Α+1 Τέλος_αν Εµφάνισε Α Να γράψετε στο τετράδιό σας τις συνθήκες που λείπουν... Ιδιαίτερα όταν µετατρέπω πολλαπλή σε απλές.... Μονάδες 10 Θέµα 2008 Γ.. τότε Α←Α+1 Αλλιώς Α← Α-1 Τέλος_αν Εµφάνισε Α β. ∆ίνεται το παρακάτω τµήµα αλγορίθµου: Αν Α ≥ 5 τότε Αν Β < 7 τότε Α←Α+1 Αλλιώς Α←Α-1 Τέλος_αν Αλλιώς Α←Α-1 Τέλος_αν Εµφάνισε Α Επίσης δίνονται παρακάτω δύο τµήµατα αλγορίθµων από τα οποία λείπουν οι συνθήκες: α.... ώστε κάθε ένα από τα τµήµατα α... Για παράδειγµα δείτε το παρακάτω θέµατα πανελληνίων Θέµα του 2009 Γ.

Sign up to vote on this title
UsefulNot useful