Design Modeler Evaluation Guide A Quick Tutorial Ansys, Inc.

March, 2005

© 2005 ANSYS, Inc.

1

Last modification: May, 26th - PTH ANSYS, Inc. Proprietary

Agenda

• • • • • • • • •

Introduction Overview of the GUI Parametric Modeling Defeaturing and parametrizing an imported geometry Handling thin models Mid-Surfacing Slicing Internal volumes Enclosure

© 2005 ANSYS, Inc.

2

ANSYS, Inc. Proprietary

Introduction

© 2005 ANSYS, Inc.

3

ANSYS, Inc. Proprietary

• • Make sure you read the “GUI overview” since it defines a few required notions that will allow you to understand the explanations of each section.0 except the mid-surface one (version 10. Inc. we strongly encourage you to follow the full tutorial. since they are independent. It is not meant to be an in-depth training. All examples can be done with DesignModeler 9. You might skip one part or the other. You will learn how to: – – – – – – Model a parametric geometry Defeature an existing geometry before simulating Slice models to get specific mesh properties Handle thin models Create internal volumes Enclosures • You need about 4 hours to go through the entire tutorial.Purpose of this tutorial • • This tutorial will guide you through the basics of Design Modeler. Proprietary . especially the “Parametric Modeling” part.0) © 2005 ANSYS. 4 ANSYS. if you would like to have a broader understanding of the functionalities. However. Inc.

5 ANSYS. Proprietary . Inc. Inc.Overview of the GUI © 2005 ANSYS.

GUI . Inc. 6 ANSYS.Graphical User Interface GUI Overview • • GUI Layout: Two Basic Modes of Operation – Sketching tab (2D) – Modeling tab (3D) – The menus and toolbars accept user input and commands – Tool bars can be “docked” and re-sized to meet user‟s preference Mode Tabs © 2005 ANSYS. Inc. Proprietary .

Inc.Graphical User Interface GUI Overview Menus.GUI . Inc. 7 ANSYS. Pull-down Lists Tree Pane GRAPHICS (Model View) Mode Tabs Details Pane Display Triad Status/Info Bar © 2005 ANSYS. Proprietary . Toolbars.

– Help: access documentation © 2005 ANSYS.GUI . Inc. 8 ANSYS. program customization – View: modify display settings. parameter management. Proprietary .Graphical User Interface Main Menu • Main menu: – File: basic file operations – Create: 3D creation and modification tools – Concept: Tools to create line and surface bodies – Tools: global modeling operations. Inc.

Proprietary . Inc. Inc.GUI . 9 ANSYS.Graphical User Interface Toolbars File management Sketching Only Selection filters/tools Plane/Sketch Controls Graphics controls 3D geometry tools © 2005 ANSYS.

10 ANSYS. Proprietary .GUI .Graphical User Interface Documentation • On-Line Help • Copyright and Support Info © 2005 ANSYS. Inc. Inc.

Inc. Inc.GUI . 11 ANSYS. Proprietary .Graphical User Interface Accessing Help Topics Search Tab Contents Tab © 2005 ANSYS.

GUI . Inc. Proprietary . Inc.Graphical User Interface Basic Mouse Functionality • Basic mouse control (3 button mouse assumed): – LMB • Geometry selection • <CTRL> + LMB adds/removes selected entities • Hold LMB and sweep cursor = continuous selection – MMB • Free Rotation (shortcut) – RMB • Box Zoom (shortcut) • Open context menus © 2005 ANSYS. 12 ANSYS.

Surface Bodies. 13 ANSYS. Line Edges Vertices Extension Options Solid Bodies. 3D Edges. Adjacent Select. © 2005 ANSYS. Adjacent Select will pick all model surfaces within a tangent tolerance of that surface or edge. Inc. Line Bodies • • Adjacent/Flood Select In select mode the cursor changes to reflect current selection filter (it will match the icon). selects surfaces or edges adjacent to the current selection. Inc. Model Points. Proprietary . PF Faces 2D Edges.Selecting Selection Filters • • Model features are identified by graphically picking them (selecting) using the left mouse button Feature selection is done by activating one of the selection filters (also from RMB) New Selection Single/Box Selection 2D Points.

Proprietary . Inc.Selecting Selection Filters • Selection filters can also be set via RMB on the Model View: – In Sketching Mode: – In Modeling Mode: © 2005 ANSYS. 14 ANSYS. Inc.

hold left mouse button then move (“paint”) mouse over entities to be selected Hold – Depends on current selection filter (lines.) + © 2005 ANSYS. Inc. Proprietary . etc. Inc. surfaces. etc. click once in a blank area of the geometry window 15 ANSYS. • “Paint Select” .) Note: To un-select all. surfaces.Selecting Mouse Selection Ctrl + • Add to or remove from current selection set – Depends on current selection filter (lines.

Inc. etc) that an imaginary line would pass through starting from the initial mouse click location and proceeding into the screen in the normal viewing direction.Selecting Selection Panes • “Selection Panes” allow selecting hidden geometry (lines. etc. Proprietary . © 2005 ANSYS. Inc. surfaces. 16 ANSYS. each plane represents an entity (surface.) after initial pick – Panes are color coded to match part colors (for assemblies) – Multi-select techniques apply to selection panes as well Initial mouse click Note. edge.

Proprietary . 17 ANSYS. Inc.Selecting Box Selection • The Selection Toolbar includes a “Select Mode” button allowing users to select items via Single Select or Box Select – Selection based on currently active filter – Type of selection based on dragging direction: • Drag from left to right: items completely enclosed in the box are selected • Drag from right to left: items completely and partially enclosed in the box are selected Left to Right Right to Left – Note the difference in the hash marks along the edges of the box to help you determine which box selection type will be performed. Inc. © 2005 ANSYS.

– Cursor near top or side edge of graphics screen = rotations about X (top/bottom) or Y (left/right) axes. 18 ANSYS. Inc.Graphics Controls • Rotate Behavior (LMB): – Cursor near center of graphics screen = free rotations. Inc. Proprietary . – Cursor outside center = rotation about Z view. Note: the cursor will change style depending on window location/action © 2005 ANSYS.

centered at pick point. © 2005 ANSYS. Model automatically orients normal to feature. 19 ANSYS. Inc. etc. • Shift + Center mouse button = zoom.) then “Look At”. Proprietary . Inc. • Right mouse button = box zoom. line. • Additional Mouse Controls – While in select mode: • Center mouse button = free rotations.…Graphics Controls – Panning – Zoom in/out – Box Zoom – Fit model to graphics screen – Look At: select model feature (surface.

or Zoom mode: • Left click on model temporarily resets center of view and rotation at cursor location (identified by red dot). Temporary rotational center © 2005 ANSYS.…Graphics Controls – While in Rotate. Proprietary . Inc. • Left click in open area re-centers model and rotation center to centroid. Inc. Pan. 20 ANSYS.

Inc.Graphical User Interface Context Menus • RMB – Context Sensitive Menus appear: Tree Object Model View Print Preview Tree Note: to delete a feature: highlight it on Tree. Inc. or <Delete> using keyboard Sketch Dimensioning © 2005 ANSYS.GUI . Proprietary . RMB >Delete. 21 ANSYS.

Proprietary . 22 ANSYS.GUI . Rotation… • Selecting • Sketch AutoConstraints • System Status “busy. wait” © 2005 ANSYS.Graphical User Interface Cursor Modes • Mouse Cursor is context sensitive – Indicates chosen operation • Viewing. Inc. Inc.

Inc.Parametric Modeling © 2005 ANSYS. 23 ANSYS. Inc. Proprietary .

24 ANSYS.Workshop Overview • In this workshop. the assembly shown on right will be enhanced. Inc. • The final design is shown on the right © 2005 ANSYS. Proprietary . Basic DesignModeler functionality will be covered. Inc.

Then select the [Browse] button. © 2005 ANSYS. Inc. select the “DMQuickIntroModeling. 25 ANSYS.agdb” file and click on [Open]. – You will be prompted to select a DesignModeler database to open • In the Open dialog box. Inc.0 > ANSYS Workbench” • In the Start page. Proprietary .Open DesignModeler File • Launch Workbench via “Start Menu > Programs > ANSYS 9. select the “Geometry” icon.

• Click on the “Generate” icon when done. Inc. then copying the arm sketch onto the planes. as shown on the right. new planes for creating sketches can be defined in a number of ways. as noted above. © 2005 ANSYS. Value 1” as “60°”. • Change “Transform 1 (RMB)” to “Rotate about Y” with the “FD1. – After completing each action. • Select ArmCopyPlane5 from the Tree. the five arms have been created by copying and rotating previous planes by 60°. use the “Generate” icon to have DesignModeler check and execute the new geometric definitions. change the “Plane” name to “ArmCopyPlane6”. 26 ANSYS. In this example. Proprietary . Inc. Select the “New Plane” icon to create a new plane based on the selected plane – In DesignModeler. • In the Details view of the newly-created plane.Create New Plane for 6th Arm – The DesignModeler geometry will be opened and displayed. – The newly-created plane will be renamed to “ArmCopyPlane6” and rotated 60 degrees.

and scaled by changing definitions FD1 through FD6 in the Details view. © 2005 ANSYS. Select “ArmSketch” from the Tree. – As noted earlier. • Click on “Generate” to apply the new definition. they can be translated. and these sketch instances will automatically be updated if changes are made to the original sketch • DesignModeler will prompt for a “Base Sketch” to be used. under “XYPlane”. but they can be used as a way of using exact copies of other sketches for other features. no reorientation or rescaling of the sketch instance is necessary. 27 ANSYS.Copy Sketch Instance for 6th Arm • Right-click on ArmCopyPlane6 and select “Insert > Sketch Instance” – A sketch instance can be thought of as a copy of another sketch. However. sketch instances cannot be modified directly. Click on “Apply” for “Base Sketch” to finish the selection. rename “Sketch Instance” to “ArmSketchCopy6”. Proprietary . Inc. For this exercise. Inc. • In the Details view. Sketch instances may not be modified directly. rotated.

• Click on “Generate” to complete the changes. Proprietary .” then select the axis of rotation of the sketch which is parallel to the Global Y-Axis.” – This will provide the profile (sketch instance) to be revolved • In the Details view. Click on “Apply. Click on “Apply. select “Axis. Angle (>0)” to “30.Revolve Sketch to Generate 6th Arm • Click on the “Revolve” button • In the Details view.” – This provides the axis of revolution. change “FD1. and the amount of rotation is specified to be 30 degrees. select “Base Object. Inc. • In the Details view.” Then. change the “Revolve” name to “ArmRevolve6” © 2005 ANSYS. 28 ANSYS. Inc.” then select ArmSketchCopy6 from the Tree.

assemblies.Freeze the “TopBase” Body • “Freeze” the body by selecting “Tools menu > Freeze” – Freezing and unfreezing bodies are common operations when creating multibody assemblies. and separate files are not used to keep track of parts vs. DesignModeler has a different concept. • In fact. “freezing” operations allow the user to specify whether resulting operations will be merged to the current geometry or created separately. – Because all parts are created in one database. Frozen bodies cannot be manipulated. which is called multi-body parts. the bottom plate will be created from an extrusion of a sketch. there is no distinction between „parts‟ and „assemblies‟ as in CAD software. although this can be toggled on/off under “View menu > Show Frozen Bodies in Transparent Mode” © 2005 ANSYS. Inc. Inc. 29 ANSYS. Proprietary . where bodies in a part will share coincident nodes on adjacent surfaces when meshed in Workbench Simulation (instead of using contact elements to define the interaction between parts). – Frozen bodies will be shown as translucent. – In the next steps. the top plate will be “frozen” to prevent any further manipulation to it. • In DesignModeler. To prevent the bottom and top plates from being merged into one body. and only the bottom plate will be an active body. so any further operations will result in new bodies being created.

© 2005 ANSYS.” if needed. • In Details view. • Click on “Generate” when done. 30 ANSYS. – Make sure that the origin at the center of the model will be used for the plane origin by choosing “Base Face” in the Details view.Create Plane for Second Body • Rotate the model with the middle-mouse button such that the bottom face is in view • Select the bottom face (shown on right) and select the “New Plane” icon – Note that. However. Proprietary . click on “Apply” for “Base Face. depending on the location of the bottom face selected. as was done earlier when ArmCopyPlane6 was rotated 60°. so the center of whichever arc is closest to the selection point will be used for the origin of the new plane. then selecting the inner or outer edges of the selected face (this will cause the selection to be near the inner or outer rings. rename “Plane” to “BaseBottomPlane”. for this plane. – Additional transformations may be applied. Inc. the origin will be positioned differently. no further manipulation of the plane is necessary. so their center will be used for the origin). • In the Details view. This is because “Use Arc Centers for Origin?” is set to “Yes” by default. Inc.

Inc. Click again to set the radius with an autoconstraint equal to the outer radius (“T”=Tangent to outer diameter). – When doing this. • Create another circle with a small radius – Ensure that the center is coincident with the origin of the plane (with the “P” auto-constraint). select “Draw: Circle” and create a circle with the outer radius equal to the plane boundary. the letter “P” will be displayed. In the Details view. • In Sketching mode.Create Sketch for Second Body • Add a new sketch by selecting the “New Sketch” icon in the toolbar. Make sure that the center is constrained to the origin of the plane (“P”=coincident Point constraint). This is an auto-constraint which will allow the user to easily set constraints when creating sketches. note that when the cursor is near the center of the plane. Proprietary . Create the outer radius to be somewhere as shown on right. Inc. Note that the color of the line is teal – underconstrained lines are shown in teal whereas fully-constrained lines (like the outer radius) is shown in blue. 31 ANSYS. rename the “Sketch” to “BaseBottomSketch. © 2005 ANSYS.” Select the “Sketching” tab from the Tree to enter Sketch mode. Note that the “T” letter will be shown when the cursor is near the outer diameter. then move the cursor to the outside diameter of the plane.

or radius dimensions whereas the latter tries to select all underconstrained aspects of the sketch. In the Details view. 32 ANSYS. Proprietary . Inc. rename the “Diameter” to “INNERDIAM”. if the items have descriptive names. • Use the “Dimensions: Edit” and select the newlycreated dimension. – The Dimensions section allows users to specify various types of dimensions. length. Specify the dimension location with another left-mouse click. Inc. – Renaming the sketch dimensions is not required. The “General” and “Semi-Automatic” are the most common options – the former allows generic specification of distance.Create Sketch for Second Body (cont’d) • Select “Dimensions: General” and click on the teal inner circle sketch. © 2005 ANSYS. but it makes parameter or dimension assignment (shown later) much easier.

” then set the “FD1. the sketch can be reassigned by selecting the item next to “Base Object. Note that. a preview outline of the new extrusion will be shown. • Select the “Extrude” icon on the toolbar • In the Details view. Inc. ensure that “Base Object” is set to “BaseBottomSketch. • Click on “Generate” to create the Extrusion.” • The extrude “Direction” should be set to “Normal. Proprietary . rename the “Extrude” name to “BaseBottomExtrude” © 2005 ANSYS.Extrude to Create Second Body • Return to modeling mode by choosing the “Modeling” tab beneath the Tree.” the newly defined sketch. then selecting “Apply. – Since the extrusion “Type” defaults to “Fixed. Depth (>0)” to “1” inch.” this creates an extrusion in the plane‟s normal direction at a fixed distance of 1 inch. 33 ANSYS. • In the Details view. in the Graphics window. If not. Inc.” selecting the “BaseBottomSketch” from the Tree.

• Click on the “Generate” icon. Note that it is a cross-section sketch which was revolved about the Y-Axis. the inner diameter of the bottom body will be set to twice the value of the inner radius of the top body • Select “XYPlane: BaseProfile” sketch. Select the “Check” tab. – Notice that.Provide Dimensional Assignment – In this step. In this case. Hence. INNERRADIUS is from XYPLANE. will be shown. Because a dimensional assignment is made. Proprietary . if the radius of the top body hole changes.INNERDIAM=2*XYPlane. – The dimension assignment is done by specifying the Parent name. type BaseBottomPlane. then the “Close” tab. Inc. the center hole of the bottom body is the same diameter (3 inches) as the center hole of the top body. used to create the top body. now. the above expression is entered in the Parameter window. • • Turn the solid geometry display back on and select the “Parameters” icon from the toolbar. – The BaseProfile sketch. © 2005 ANSYS. and INNERDIAM is from the BaseBottomPlane. 34 ANSYS. so will the hole in the bottom body.INNERRADIUS in the window. Turn off the solid geometry and view normal to the sketch. There is a dimension called “INNERRADIUS” that defines the inner radius of the center hole. to make the diameter of one equal to twice the radius of the other. then the dimension name. Inc. In the “Parameter/Dimensions Assignment” tab.

Inc. Then click on “Extrude.Cut Holes in Second Body • From the Tree. this allows the cut to always be a certain depth. expand HoleCut and select the HoleProfile sketch. Adding a „frozen‟ body is also possible. as well as imprinting faces. change the “Extrude” name to “BaseBottomHoleCut”. 35 ANSYS. by selecting a surface. even if the thickness of the second body is changed. – Extrusions can be performed by specifying a distance or. as shown highlighted on the right. • In the Details view. If a surface is selected. – The direction is selected as “Normal”. select the bottom-most face. For the target face. © 2005 ANSYS. but it can be changed to be a given vector based on the normal of a selected surface or by vectors defined by selected edges or vertices. the type of extrusion can be changed between adding or removing material. Proprietary . • Select “To Surface” for the “Type” of cut. Change “Operation” to “Cut Material” and ensure that the “Direction” is set to “Normal” – Although considered an extrusion. in this example. A sketch is not limited for use for a single part/body. Inc. • Click on “Generate” when done.” – The same sketch used to create the holes in the upper body can also be used to modify the lower body.

indicated with an arrow). change the “Plane” name to “BottomCutPlane1”. © 2005 ANSYS. so temporarily hiding the second body makes this easier. 2 Bodies” branch in the Tree. Right-click on the LowerBase branch and select “Hide Body. Change “Transform 1 (RMB)” to “Offset Z”. 36 ANSYS. Inc.Create Top Cut in LowerBase • Expand the “2 Parts. similar to the one created earlier for the main extrusion of the LowerBase body • Click on “Generate” when done. – A new plane based on a selected surface will be created. Proprietary .” – Renaming bodies makes it easier to differentiate bodies when brought into Workbench Simulation. – An inner surface needs to be selected. This is an outline plane. Select the “New Plane” button from the Toolbar. as shown in the figure on the right (highlighted surface. In the Details view. Inc. • Select the inner cut. Rename the second “Body” to “LowerBase”.

if the surface changes. so. the outline plane will be updated accordingly. Proprietary . • Unhide the LowerBase body by right-clicking the item in the Tree and selecting “Show Body” • With “BottomCutPlane1” selected in the Tree. Change the “Extrude” name to “BaseBottomCut1”. This outline plane is based on a surface. © 2005 ANSYS. Inc.5” inches. 37 ANSYS. add BottomCutPlane1. Depth (>0)” should be changed to “0. – The BottomCutPlane1 Z-offset was left at zero earlier. “FD1. Under the “Parameter/Dimension Assignments” tab. the z-offset was made to always be equal to the bottom of the surface. Change “Operation” to “Cut Material” with a “Direction” of “Normal”. a plane (outline plane) created earlier was used.FD1=XYPlane.Create Top Cut in LowerBase (cont’d) • Select “Parameters” from the Toolbar. – Instead of using a sketch to create a cut. Inc.CUTDEPTH and click on the “Check” then “Close” tab. By adding a dimension assignment. • Click on “Generate” when complete. Click on “Generate” when done. click on the “Extrude” icon from the Toolbar.

then dimension the circle with a 7 inch diameter. 38 ANSYS.” the origin of the new plane will be defined using the closest arc where the plane was selected. – If the “P” coincident-point auto-constraint is hard to differentiate with the “C” coincident-line auto-constraint. with “Use Arc Center for Origin?” set to “Yes. turn off the line select filter from the toolbar (circled on right). Then click on “Generate”. © 2005 ANSYS. and the “P” auto-constraint will be easily generated. Proprietary .e. Rename the “Plane” to “BottomCutPlane2”. as shown on the right. then create a “New Plane”.. Inc. If needed. – Recall that. Create a circle coincident with the origin (“P” autoconstraint symbol should be shown).Create Bottom Cut for LowerBase • Select the bottom face of LowerBase body. only points (i. Then. • Enter sketching mode by selecting the “Sketching” tab in the Tree. – Entering sketch mode will automatically create a new sketch (if not previously defined) on the selected base plane (or surfaces). select “Base Face” and adjust the origin to be at the center of the model.” the user can reselect the face near the centermost circle to use the center as the origin for the new plane. – Creating and dimensioning a circle uses the same steps as done earlier in creating the main extrusion of LowerBase. Using “Base Face. Inc. the origin) will be selectable.

rename the sketch to “BottomCutSketch2”. Inc. Depth (>0)”) of “0.3” inches. © 2005 ANSYS.Create Bottom Cut for LowerBase (cont’d) • Re-enter “Modeling” mode by selecting the appropriate tab from the Tree. In the Details view. Inc. Proprietary .” with a fixed distance (“FD1. • Select the “Extrude” icon from the toolbar. Change “Operation” to “Cut Material.” Respecify the “Direction” to “Reversed. 39 ANSYS. Click on “Generate” when done. rename the “Extrude” to “BaseBottomCut2”. • In the Details view.

40 ANSYS. • Create a circle with a “P” auto-constraint at the origin of the newly created BoltHeadPlane. Dimension this to make the diameter equal to “1. and rename the sketch to “BoltHeadSketch”. • Select the “Sketching” tab to enter sketch mode. • Re-enter “Modeling” mode. Proprietary . Click on “Generate” when completed. • In the Details view. Inc.2” inches. Create a “New Plane”. change the selection filter to points only.Create First Bolt Head • Select the top face of the TopBase body. Inc. rename the “Plane” to “BoltHeadPlane” and change the “Base Face” such that the origin is at the center of one of the holes. © 2005 ANSYS. as illustrated on the right. as only existing points are now selectable. This makes it easier to have the coincident point “P” autoconstraint. – Recall that if the “P” auto-constraint symbol does not readily appear.

In the Details view.” – A new sketch to define the bolt shaft will be created • Enter “Sketching” mode by selecting the tab below the Tree. Proprietary . © 2005 ANSYS. Inc. Inc. • Hide the solid model geometry by toggling off the “Display Model” icon from the toolbar • Select BoltHeadPlane and create a “New Sketch”.2” inches in the normal direction.Create First Bolt Head (cont’d) • Select the “Extrude” icon. rename the “Extrude” to “BoltHead” with a fixed depth of “0. Rename this “Sketch” to “BoltShaftSketch. – Note that a new body is created since TopBase is a frozen body. 41 ANSYS. Click on “Generate” when done to create the bolt head.

Proprietary . © 2005 ANSYS.1 to specify the bolt diameter to have a 0. and enter “BOLTSHAFTDIAM” for the “Diameter” in the Details view. indicating that it is a driven dimension. • Open the “Parameters” window from the toolbar. – After specifying the dimension assignment. Inc. • Dimension the diameter with “Dimensions: General”.CUTDIAM ETER-0. 42 ANSYS. Under “Parameters/Dimension Assignments”. Click on the “Check” tab to verify the result of the dimension assignment. the BOLTSHAFTDIAM parameter will have a “D” next to it in the Details view. Inc.Create First Bolt Head (cont’d) • Create a similar circle as done earlier for the bolt head with “Draw: Circle” and a “P” auto-constraint at the plane origin. enter BoltHeadPlane. Rename the dimension with “Dimensions: Edit”. then click on the “Close” tab.1 inch clearance compared with the hole.BOLTSHAFTDIAM=TopBasePlane.

– In this case. will the bolt shaft. select “ArmCopyPlane1” from the Tree.” select the bottom-most surface of LowerBase. • • To copy the bolt. © 2005 ANSYS. For the “Target Face.” select “ArmCopyPlane2”. Hence. too. instead of creating an extrusion of a fixed distance. Inc. With BoltShaftSketch selected. Inc. select the newly-created bolt body. existing geometry is used as a reference point for the extrusion depth.Create First Bolt Head (cont’d) • • Re-enter “Modeling” mode by selecting the tab below the Tree. For “Source Plane”. In this way. For “Bodies”. – Although ArmCopyPlane1 and ArmCopyPlane2 may not lie on the same plane as the bolt body. Click on “Generate” when done. For “Type”. these two planes can be used as a way of copying the bolt body 60 ° to another hole location. these two planes are rotated 60 ° from each other along the same axis of revolution. change “Extrude” to “BoltShaft”. if the depth of the TopBase or LowerBase bodies change. select “Create menu > Body Operation” In the Details view. For “Target Plane. so. In the Details view. 43 ANSYS. change to “To Surface”. Click on “Generate” to create the new copy of the bolt. Specify the extrusion “Direction” as “Reversed”. Proprietary . click on the “Extrude” icon from the toolbar. change “Type” to “Copy”. as shown on the right.

• In the Tree.” select both bolt bodies. 8 Bodies” menu and rename the bolts as “Bolt1” through “Bolt6” – The resulting assembly should be similar to the one shown on right. Proprietary . a rotation of 120° needs to be specified. ArmCopyPlane1 and ArmCopyPlane2 were used. – This is done in a similar manner as above. although the specified bodies will now be the newly-copied bolts #3 and #4. so ArmCopyPlane3 is used instead for the target plane. with all bodies named accordingly © 2005 ANSYS. In this case. • Repeat the above step to create bolts #5 and #6. and for “Bodies.Copy Bolt Bodies • Rename the “Body Operation” to “Bolt Copy 2” • Copy the two bolts again by selecting “Create menu > Body Operation”. Inc. expand the “8 Parts. Change “Type” to “Copy”. 44 ANSYS. – In the previous step. but specify the “Target Plane” as “ArmCopyPlane3”. Click on “Generate” to create bolts #3 and #4. Inc. because a copy of both bolts are done. Specify “BoltCopy34” as the “Body Operation” name. The “Source Plane” should be “ArmCopyPlane1”.

Inc. 45 ANSYS. Proprietary .Defeaturing and parameterizing © 2005 ANSYS. Inc.

agdb – Click “Open” – Click “Generate” to refresh the model This assembly is a Autodesk Inventor part which was attached in Design Modeler.The model Load the Design Modeler file “DMQuickIntroDefeaturing. Proprietary . © 2005 ANSYS.agdb” – Start ANSYS Workbench – Choose “Empty Project” – Select “Browse” under “Link to Geometry file” – Browse to DMQuickIntroDefeaturing. Inc. Inc. We will perform many operations on this part: •Body Delete •Face Delete •Fill •Bodies merging •Face imprint 46 ANSYS.

0” menu item and select “Workbench” © 2005 ANSYS. Inc. Proprietary . 47 ANSYS. Starting from the CAD system (Autodesk Inventor in this case). the user just goes to “ANSYS 9. Inc.Model Import • We now explain how the model was imported in ANSYS Workbench – This is just an information. not a step you have to perform.

Note: if you start from a non-associative format (parasolid. Catia…). Inc. © 2005 ANSYS. The next steps remain unchanged. Inc. Once Design Modeler has started. select the appropriate length unit and click the “Generate” button to import your model. Select “Empty project” The geometry is shown under the “Link to active CAD geometry” item. Click on the file name Finally create a New geometry based on the CAD part. sat. 48 ANSYS.Model import (cont’d) This dialog appears. the starting point would be a “Link to geometry file” (dashed pink ellipse above) instead of the active CAD file. Proprietary .

Steps to be performed 1. Inc. 49 ANSYS. Proprietary . Move bodies with “Body operation” 5. Create a parametric feature with “sketch” and “extrusion” © 2005 ANSYS. Remove fillets or chamfers with “Face Delete” 4. Remove holes with “Face Delete” 3. Inc. Remove body with “Body operation” 2.

Removing unwanted bodies

Select Create->Body Operation Click on the four bodies marked with a cross on this picture (hold CTRL to select multiple bodies at the same time) Make sure the type option of the tool is set to “Delete”

χ χ χ

χ

Click “Generate”

© 2005 ANSYS, Inc.

50

ANSYS, Inc. Proprietary

Removing holes – Face delete
Freeze the full assembly (Tools -> Freeze). We will now remove the holes of the leftmost plate Unfreeze the left plate (Tools>Unfreeze then select left plate) Click “Generate”

Choose Create->Face Delete Select the inner holes faces as shown right (green highlighted) Click “Apply” in the tools options. Click “Generate” to get this

© 2005 ANSYS, Inc.

51

ANSYS, Inc. Proprietary

Removing fillets and chamfers
Freeze the full assembly (Tools -> Freeze). We will now remove the fillets and chamfers out of the circled part

Unfreeze the circled part (Tools->Unfreeze then select part)
Click “Generate” Pick one face of the part and press RMB. Select “Hide all other bodies” Choose Create->Face Delete Select the two fillets faces and the chamfer at the bottom Click “Apply” in the tools options. Click “Generate” to get this Finally click RMB and select “Show all bodies”

© 2005 ANSYS, Inc.

52

ANSYS, Inc. Proprietary

Inc. Proprietary .Merging objects – Partial unfreeze Another interesting feature of DM concerns the ability to merge parts that have coincident surfaces. Inc. 53 ANSYS. Let’s try on the yellow parts shown on the right Unfreeze the two parts (Tools>Unfreeze then select both parts – Hold CTRL key for multiple parts selection) Make sure the “Freeze others” is set to “yes” Click “Generate” Both parts are now merged into a single one © 2005 ANSYS.

Adding a parametric feature
We will now add a circular imprint to the model, whose diameter will be parameterized. This kind of imprint is useful to apply load on a specific area that does not belong to the original CAD model First select the face as shown on the picture, then choose “Sketching” under the tree view (the face contour now appears as a black dotted line) Click the “look at sketch icon” to get a correct view of the working plane

© 2005 ANSYS, Inc.

54

ANSYS, Inc. Proprietary

Adding a parametric feature (cont’d)

Draw a circle on the surface as shown here. Go to “dimensions”, click on “General” then pick the circle. It automatically adds a diameter dimension to the model.

You can edit the value of the diameter in the option window.
Using horizontal and vertical dimensions let you parameterize the location of the circle based on the sketch main axis. The dimensions can then be changed as we did for the diameter.

© 2005 ANSYS, Inc.

55

ANSYS, Inc. Proprietary

Adding a parametric feature (cont’d)

Click the “Extrude” icon Set the options as shown. Make sure you select only the concerned body. Click generate. The top surface now has the imprint on it If you click on “Sketch 2” under the Extrude object in the tree, the dimensions are shown in the options dialog. You can change the value of the dimensions and then update your model by clicking “Generate”

© 2005 ANSYS, Inc.

56

ANSYS, Inc. Proprietary

Handling thin models © 2005 ANSYS. Inc. Proprietary . 57 ANSYS. Inc.

We will transform this solid model into a thin model.agdb” – Start ANSYS Workbench – Choose “Empty Project” – Select “Browse” under “Link to Geometry file” – Browse to DMQuickIntroThinModels. Inc.agdb – Click “Open” This assembly is a Autodesk Inventor part which was attached in Design Modeler. Inc. 58 ANSYS. Proprietary . © 2005 ANSYS.The model Load the Design Modeler file “DMQuickIntroThinModels.

Inc. Inc. Proprietary .5mm 10mm © 2005 ANSYS. 59 ANSYS.Model thicknesses 13mm 5mm 6.

Inc.Understanding the basics of Thin/Surface feature Let‟s take a single thin body with 6. 60 ANSYS. Proprietary . Inc.5mm thickness and go through various options to get a single surface out of the solid We consider here that the green face is one face we would like to keep (this could be the opposite one as well) One face kept and translated inward by half the thickness One face kept and translated outward by half the thickness © 2005 ANSYS.

61 ANSYS. Proprietary .Thin/Surface feature • This feature can be used : – to thicken a surface in order to create a volume – to hollow a body © 2005 ANSYS. Inc. Inc.

Proprietary . Inc. Inc.Extracting surface bodies Freeze the model (Tools>Freeze) Unfreeze the 3 plates with 6. 62 ANSYS.5mm thickness (shown in solid on the picture) Pick one face of each solid Select the “thin/surface” Feature and set the options as shown Click generate © 2005 ANSYS.

Proprietary . Inc.Extracting surface bodies (cont’d) Freeze the model (Tools>Freeze) Unfreeze the tube with 5mm thickness (shown in solid on the picture) Pick the internal or external faces (you can pick one face and use the “Extend Selection” tools with “Extend to limits”) Select the “thin/surface” Feature and set the options as shown Click generate © 2005 ANSYS. 63 ANSYS. Inc.

64 ANSYS. Inc. Inc. Proprietary .Extracting surface bodies (cont’d) Repeat the previous operations with the last two solid bodies to get the model shown below © 2005 ANSYS.

Inc. Select the Surface Extension tool (Tools->Surface extension) Target face Pick the edge of the surface you want to extend as shown on the picture Select the face to extend to (you could also specify a distance) Click generate Select the edge to extend © 2005 ANSYS.Extending surfaces We will now extend the surfaces to touch. Inc. 65 ANSYS. Proprietary .

66 ANSYS. Select the Surface Extension tool (Tools->Surface extension) Pick the edges as shown here Select the 5 faces of the tube (planes and fillets) Select the faces of the tube Click generate Select the three lines for each blade © 2005 ANSYS. Inc. Proprietary . Inc.Extending surfaces (cont’d) You can also select multiple edges and multiple surfaces in a single operation.

Proprietary . Inc. 67 ANSYS. The final result is shown here © 2005 ANSYS.Extending surfaces (cont’d) You can also extend the tube to the largest surface. Inc.

Proprietary . 68 ANSYS. Inc. There is no connection of any kind between the surfaces so all parts are mesh totally independent from each other. Using the “Joint” feature of Design Modeler will help solve this issue. © 2005 ANSYS. Inc.Joining surfaces If we stop at this stage and mesh the resulting surfaces. we get a mesh similar to the one shown on the right.

Proprietary . Click Generate Clicking on the joint feature just created in the construction tree shows green lines wherever a connection between surfaces exists. Select “Form new part” from the Tools menu.Joining surfaces (cont’d) Select the “Joint” Tool (Tools->Joint) Select the tube. Make sure “Share Topology” is set to “Yes”. Inc. the largest surface and the bottom one then click “Apply” in the tool options. The surfaces have now imprints corresponding to their intersections. so that they share common nodes at the created intersections. We will also form a new part with these 3 surfaces. The bodies are grouped under a “Part” in the tree © 2005 ANSYS. pick the three bodies and generate. Inc. 69 ANSYS.

70 ANSYS. Inc.Joining surfaces (cont’d) The mesh now shows the common boundaries (in green on the picture) © 2005 ANSYS. Proprietary . Inc.

Inc.0) © 2005 ANSYS. Proprietary . Inc. 71 ANSYS.Automated Mid Surfacing (available from DesignModeler 10.

© 2005 ANSYS.The model Load the Design Modeler file “DMQuickIntroMidSurface. 72 ANSYS. Inc.agdb – Click “Open” This assembly is a Autodesk Inventor part which was attached in Design Modeler. Inc. Proprietary .agdb” – Start ANSYS Workbench – Choose “Empty Project” – Select “Browse” under “Link to Geometry file” – Browse to DMQuickIntroMidSurface. We will transform this solid model into a thin model using the mid surfacing tool.

Inc. 73 ANSYS.Extracting surface bodies Select the “Mid Surface tool” (Tools>Mid-Surface) In the tool options.1mm and maximum threshold to 15 mm (doing this. Proprietary . select “Automatic” for the selection method Set minimum threshold to 0. you set the extreme values for detecting face pairs – in other words. Inc. the minimum and maximum sheet thickness to work with) Then select “Yes” for “Find face pairs now” © 2005 ANSYS.

Now click on generate to extract the mid surfaces © 2005 ANSYS.Face pairs identification The 20 face pairs found are shown in blue. 74 ANSYS. Inc. Inc. Proprietary .

75 ANSYS. Proprietary .First result This extraction also returns a few non desired faces corresponding to the holes © 2005 ANSYS. Inc. Inc.

This reactivates the options Click on “Face pairs” In the main window. Proprietary .Removing face pairs In the tree. click RMB then “Remove face pairs” © 2005 ANSYS. 76 ANSYS. click the RMB on “Midsurf” item and select “Edit selections”. Inc. Inc.

Inc. Inc. the two missing are near the green circled one) Click “Apply” in the options then the “Generate” button © 2005 ANSYS. 77 ANSYS.Removing face pairs – cont’d Click each of the fillets near to the holes – You have to remove 7 pairs (5 are shown here. Proprietary .

Inc. you will see that the thickness has automatically been affected to each of the bodies.Final extraction The undesired faces are now removed. 78 ANSYS. Inc. © 2005 ANSYS. Proprietary . If you go over the surface bodies in the tree.

Instructions are not repeated here. Click on this link to get back to the previous tutorial © 2005 ANSYS. Proprietary .Surface extension and joining • You now can extend and join the surfaces as shown in the previous tutorial. Inc. 79 ANSYS. Inc.

Slicing © 2005 ANSYS. Proprietary . Inc. 80 ANSYS. Inc.

The Model Load the Design Modeler file “DMQuickIntroSlicing. Inc. Proprietary . Inc. The default mesh obtained on such a part is a tetra mesh as shown. 81 ANSYS.agdb – Click “Open” The goal of this tutorial is to show you how to use slicing in order to get a swept mesh of this part.agdb” – Start ANSYS Workbench – Choose “Empty Project” – Select “Browse” under “Link to Geometry file” – Browse to DMQuickIntroSlicing. © 2005 ANSYS.

Inc. © 2005 ANSYS. This last type is not addressed in this tutorial. 82 ANSYS. Proprietary .Slicing: what does it mean? • Slicing is an operation that will allow you to split a solid into smaller parts. Inc. • The purpose of slicing can be meshing with hexa (swept) elements but also affecting multiple materials in various areas of the model • Three type of slicing are available: – Slice Off Faces: a set of faces is selected and a slice will be generated to create a solid from these faces – Slice by plane: a plane is chosen and the part is sliced by this plane – Slice by sketch: you can use sketches to draw an arbitrary shape that will be used for slicing (using extrusion or revolve features).

Proprietary . pick all bodies. we have the result shown to the right. if we mesh this new part. So we freeze everything (Tools->Freeze) Select all the faces of the feature as shown Select Create->Slice and “Apply” to use the previously selected faces Click generate: your model has now two parts. we will form a new part: select Tools->Form new part. This is a mix of tetra and hexa elements. 83 ANSYS. Since we want to keep a unique body. Inc.Slicing Off faces We start slicing the part using the faces of the rightmost feature Any slice operation can only be performed on frozen bodies. © 2005 ANSYS. Inc. click “Apply” and “Generate” The construction tree should look as indicated Now.

we need creating a plane corresponding to these faces. We still have one solid in the part that is not swept. To do this.Slicing by plane Now. then choose the plane name in the construction tree then click “Apply”. The planes look like the right top picture. We will also slice it along the third green face perpendicular to the two first. To do this. click on “Base Plane”. You now have 8 bodies that you can group into a new part. Finally. at two altitudes shown by the green faces on the top left picture. then the “Plane” icon. select the Slice tool (Create->Slice). Select one of the plane as cutting plane. To slice the part at this level. Proprietary . pick one of the face. Inc. 84 ANSYS. Repeat the previous step for the 2 other planes. then click “Generate”. © 2005 ANSYS. set the options to “Slice by plane”. the part will be sliced parallel to the XY plane. Inc. “Generate”. Once the three planes have been created.

based upon the two green faces shown on the right.Slicing by plane (cont’d) To finalize the model. You now have 10 bodies that you can group into a new part. Inc. Create the planes corresponding to these two faces and slice the part. we will use two additional slices. Proprietary . And the mesh is totally swept! © 2005 ANSYS. Inc. 85 ANSYS.

Inc. 86 ANSYS.Internal volumes © 2005 ANSYS. Inc. Proprietary .

87 ANSYS. Inc. © 2005 ANSYS.agdb – Click “Open” The goal of this tutorial is to show you how to create the internal volume of an hollow body. Inc. agdb” – Start ANSYS Workbench – Choose “Empty Project” – Select “Browse” under “Link to Geometry file” – Browse to DMQuickIntroInternalVolu me.The Model Load the Design Modeler file “DMQuickIntroInternalVolume. Proprietary .

Inc.Filling a part Select the “Fill” Tool (Tools->Fill). Select all the internal faces of the body as shown here in green and click “Apply”. Proprietary . You can delete the outer body (Create->Body Operation) Note that the outer body needs be frozen before creating the internal one. You must have 10 faces selected Click “Generate” You now have 2 bodies: the original one and the internal volume. © 2005 ANSYS. 88 ANSYS. Inc.

Proprietary .Enclosures © 2005 ANSYS. Inc. 89 ANSYS. Inc.

agdb” – Start ANSYS Workbench – Choose “Empty Project” – Select “Browse” under “Link to Geometry file” – Browse to DMQuickIntroEnclosure.The Model Load the Design Modeler file “DMQuickIntroIEnclosure.agdb – Click “Open” The goal of this tutorial is to show you how to create an enclosure around this model. 90 ANSYS. © 2005 ANSYS. the goal is to create the air surrounding the motor for a electromagnetic simulation. Inc. In this case. Proprietary . Inc.

we can see that it really fills all the gaps between the various solids of the original model. Inc. 91 ANSYS.Creating the enclosure Select the “Enclosure” Tool (Tools->Enclosure) Set the options as shown here (note that you can choose other enclosure shapes) Click “Generate” If we cut the enclosure. Inc. Proprietary . Internal view of the enclosure © 2005 ANSYS.

Sign up to vote on this title
UsefulNot useful