CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA DO PARANÁ UNIDADE DE PATO BRANCO

CURSO SUPERIOR DE TECNOLOGIA EM M ANUTENÇÃO INDUSTRIAL

COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6

PROF. CARLOS MARCELO DE OLIVEIRA STEIN ABRIL, 2003

PSIM mostra ser um ambiente de simulação poderoso para a análise de conversores de potência. e determinar quais as combinações dão os resultados para o pior caso. e outras dores de cabeça de laboratório. que é lido pelo simulador PSIM. INTRODUÇÃO A simulação de circuitos está ficando cada vez mais aceita como uma ferramenta normal no projeto de equipamentos de eletrônica. tornando-se uma ferramenta indispensável na formação de técnicos e engenheiros. o simulador pode perfeitamente ser utilizado em praticamente todos os tipos de circuitos. Este material tem o objetivo de fazer uma breve introdução à utilização do simulador de circuitos elétricos PSIM. Os conceitos elétricos são gerais e úteis para todos os tamanhos de circuitos. simulação rápida. Os comandos são fáceis de aprender e usar. PSIM é muito útil para simular todos os tipos de circuitos.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 2 1. ü Verificar seu projeto depois que ele estiver pronto. operação empregando componentes ideais para isolar efeitos limitantes no seu projeto. o Inconvenientes (equipamento especial de teste não é disponível). No entanto. ü Simular um circuito várias vezes com variações de componentes para verificar que percentual passaria no teste final. Um circuito é descrito por comandos armazenados em arquivo chamado de “arquivo de circuito”. Além disso. ü Teste ideal. ü Fazer medidas dos testes simulados que são: o Difíceis (devido a ruídos elétricos ou carga do circuito). PSIM tem uma variedade de usos. em uma enorme faixa de aplicações. Com interface amigável. sejam eles digitais ou analógicos. Resultados de simulação são livres de instabilidade de tensão e corrente. Você deve olhar os resultados para ver se eles fazem sentido na sua aplicação. O método prático para verificar o projeto de um circuito elétrico é construí-lo e testa-lo. PSIM é um programa de simulação especialmente projetado para eletrônica de potência. o circuito pode ser cuidadosamente simulado usando um programa de computador antes da implementação do circuito real. O simulador não faz considerações sobre como o circuito deveria se comportar. isso pode se tornar caro e consumir muito tempo. o Imprudentes (o circuito de teste pode se destruir). e apresentação de formas de onda semelhante à tela de um osciloscópio. microvolts e megavolts são apenas números para o PSIM. principalmente na parte referente a projetos e interpretação de equipamentos eletroeletrônicos. como: ü Verificar uma idéia de circuito antes de montá-la em laboratório. malhas de controle e estudo de acionamento de motores. VERSÃO 01 – A BRIL 2003 . O simulador não tem conceito de circuito grande ou pequeno. O que o PSIM pode fazer por você? ü Simular seus circuitos projetados antes de construí-los. restrições de aterramento. Para circuitos discretos (circuitos feitos de partes individuais montadas sobre um circuito). O uso da simulação é reconhecido como uma necessidade prática. Como alternativa.

56. Para facilitar a digitação de números muito grande ou muito pequenos. que são: Extensão sch cct txt fra smv Descrição Esquemas do PSIM Lista de nós do esquema Saída da simulação Saída de uma análise AC Lista de forma de ondas Tipo de arquivo binário texto texto texto binário O programa é em inglês. ü PSIM não projetará o circuito para você. Na tabela a seguir estão relacionados os sufixos aceitos. apresenta dois programas executáveis: PSIM.56 e não 34. 3. Como qualquer nova ferramenta. deve-se digitar 34. todos os números devem ser digitados utilizando-se um ponto como separador decimal. e SIMVIEW.Ícones dos programas. CARACTERÍSTICAS DO PROGRAMA O simulador utiliza algumas extensões características para os arquivos gerados por ele. o PSIM aceita algumas letras indicando múltiplos e submúltiplos. que demonstra graficamente as formas de onda obtidos na simulação. experiência é requerida para tirar o maior proveito. você achará que ele pode substituir a maioria de seus trabalhos (mas não todos) de laboratório. que é o editor de esquemas elétricos. Sufixo Nome Valor p pico 10-12 n nano 10-9 u micro 10-6 m mili 10-3 K ou k kilo 10+3 M mega 10+6 G giga 10+9 VERSÃO 01 – A BRIL 2003 . Os ícones dos programas estão representados na figura abaixo: Figura 1 . uma vez instalado. Desta forma. ESTRUTURA DO SIMULADOR O simulador. ou seja. Uma vez familiarizado com o PSIM. 2.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 3 ü PSIM é uma bancada simulada na qual criam-se circuitos de teste e realizam-se medidas. ao invés da vírgula utilizada em português.

Salvar arquivo. Inverter verticalmente a seleção. Abrir arquivo. Copiar seleção para a área de transferência (usado para passar desenhos para outros programas. Imprimir arquivo. Gira a seleção. Na tabela abaixo estão descritas as funções destes botões: Criar arquivo.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 4 4. Figura 2 – Tela principal do PSIM. Na figura a seguir está um exemplo da tela principal do programa. Recortar seleção. e uma barra de ferramentas com alguns botões de atalho. como um editor de texto). Na parte superior o programa apresenta um menu de opções. Colar. VERSÃO 01 – A BRIL 2003 . PROGRAMA PSIM Executando-se o programa PSIM. Copiar seleção. Inverter horizontalmente a seleção. tem-se a tela do editor de esquemas. com um circuito já desenhado. Inserir ligações.

Zoom. Aumentar. e elementos comuns aos circuitos de potência e controle). Na parte inferior do programa está uma barra de ferramentas. como filtros e componentes de eletrônica digital. com botões de atalho para alguns dos componentes disponíveis. resistores. terra resistor indutor capacitor diodo tiristor MOSFET IGBT ponte de diodos monofásica ponte de diodos trifásica comando de chaves interface controle/comando de chaves fonte de tensão CC fonte de tensão senoidal fonte de tensão triangular fonte de tensão quadrada degrau de tensão sensor de tensão sensor de corrente ganho proporcional ganho proporcional-integral subtrator somador multiplicador VERSÃO 01 – A BRIL 2003 . instrumentos de medição. todos os componentes estão dispostos no menu Elements . Adicionar um texto no esquema eletrônico. ü Control .elementos de controle. Somente disponível durante simulações. Iniciar a simulação. Ajusta à página.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 5 Inserir marcadores (para conectar dois ou mais pontos do circuito sem utilizar ligações). Diminuir. ü Other (para controladores de chaves semicondutoras. Ferramenta de seleção. sensores. como chaves semicondutoras. Cancelar a simulação. Zoom. Zoom. No PSIM. elementos de interface entre potência e controle. Os elementos estão divididos em quatro grupos: ü Power – onde estão os componentes de potência. Para adicionar rapidamente um componente do mesmo tipo de algum dos últimos já adicionados. indutores e capacitores. Seleção. Abrir o programa de visualização das formas de onda. ü Sources (para fontes de tensão e corrente). Zoom.

exceções. Entretanto.1 Simulando um Pequeno Circuito divisor comparador limitador Inicialmente será utilizado um circuito rápido para introduzir o PSIM. basta clicar com o botão direito do mouse. 3. é necessário: ü Criar o arquivo de entrada. No caso. basta clicar com o botão esquerdo do mouse. Fazer algumas simulações requer vários fundamentos. Iniciar a inserir os componentes. Para retornar ao cursor normal. A melhor maneira de aprender a trabalhar em um simulador de circuito é fazendo simulações. seleciona-se no menu Elements a opção Sources. Com isso. deve-se pressionar a tecla ESC. Para inserir a fonte de tensão contínua. pode-se selecionar as propriedades de um componente dando-se dois cliques sobre o mesmo. ü Rodar o simulador. Desta forma. permitindo que seja inserido outro componente igual. Para desenhar o circuito no PSIM. Uma vez que o cursor do mouse esteja com sua forma normal.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 6 voltímetro voltímetro diferencial amperímetro porta inversora 1. as informações adicionais ( other info) e a cor do componente (color) não afetam os resultados da simulação. quanto mais simples for este circuito. Isto é feito indo-se no menu File . As propriedades variam. ou simplesmente clicando-se no botão . podese alterar o nome e o valor do componente. Na figura a seguir estão representados os parâmetros da fonte de tensão contínua. e selecionandose New. Outra opção é utilizar o botão . e então DC. presente na barra de ferramentas inferior do programa. e definir se estas propriedades devem ou não aparecer no esquema. e então rapidamente atingir um resultado bem sucedido. ou arquivo do circuito. na barra de ferramentas superior. de forma a se conhecer previamente o funcionamento. VERSÃO 01 – A BRIL 2003 . o cursor do mouse permanece com a forma do componente. Com isso. é selecionar outro componente. o circuito escolhido foi um divisor resistivo de tensão. ou outra ferramenta de edição. Editar os parâmetros dos componentes. uma janela com as propriedades aparecerá na tela. Para colocar o componente em um determinado lugar da área de edição. detalhes. utiliza-se o seguinte procedimento: 1. de acordo com o componente selecionado. ü Inspecionar os resultados obtidos. Isto mostrará os fundamentos de uma simulação de circuito sem tornar-se complicado por regras. Além disso. melhor. Mesmo após a colocação do componente. Para rotacionar o componente em 90º. Outra opção. pode-se alterar outras informações sobre o componente (other info). ou seja. Naturalmente. e a cor (color) do mesmo. Voltage . ou utilizar o botão . o cursor do mouse fica com a forma do componente. 2. Criar um novo arquivo.

Inserir o componente que indica o ponto de terra do circuito. Este componente é importante pois serve de referência para a maioria das medições realizadas. A seleção dos pontos do circuito que o programa irá adicionar ao arquivo de saída é feita através da adição de instrumentos de medida. como Voltage Probe e Voltage Probe (node -to-node). o cursor do mouse fica com o formato de um lápis. Para observar-se tensão. existem duas opções: a utilização de amperímetro ou selecionando nos parâmetros do componente. onde é possível selecionar 0 (sem medição de corrente) ou 1 (com medição de corrente). 4. Para a medição de corrente. Para conectar dois pontos. 7. que mede a tensão entre seus dois terminais. leva-se o cursor até o segundo ponto. e solta-se o botão. Probes. que apresenta o item Current Flag. Pode-se notar que o programa realiza até uma curva de 90º. Outra opção é utilizar os botões e . e mantendo-se pressionado o botão do mouse. primeiramente seleciona-se a ferramenta apropriada. na barra de ferramentas superior. 5. presente na barra de ferramentas inferior do programa. respectivamente. Selecionar as variáveis de saída. e o diferencial. Para os demais componentes. O componente amperímetro está no menu Elements na opção Other. Esses componentes estão no menu Elements na opção Other. Conectar os componentes. 6.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 7 Figura 3 – Parâmetros da fonte de tensão contínua. no botão . VERSÃO 01 – A BRIL 2003 . Este componente está no menu Elements na opção Other. como Current Probe e na barra de ferramentas inferior do programa. Na figura abaixo estão representados os parâmetros de um resistor. clicando-se no botão . Para realizar as conexões. Outra opção é utilizar o botão . Ground. presentes na barra de ferramentas inferior do programa. clica-se com o botão esquerdo do mouse no primeiro ponto. Probes. Com isso. A maioria dos componentes apresenta em seus parâmetros o item Current Flag. deve-se utilizar um dos dois tipos de voltímetro disponíveis: um que mede a tensão de um determinado nó em relação ao componente terra. repetem-se os passos 2 e 3.

podese utilizar os comandos Save ou Save As no menu File . Pode-se notar nesta figura o nome e o valor dos componentes. Figura 5 – Circuito representado no PSIM. Depois de ser adicionado ao esquema.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 8 Figura 4 – Parâmetros de um resistor. na barra de ferramentas superior. Desta forma irá aparecer a janela padrão do windows para salvar arquivos. bem como a posição dos voltímetros. onde pode ser alterado o caminho e o nome do arquivo. é necessário incluir o controle de simulação. Para salvar o arquivo com o circuito desenhado. Na figura abaixo está representado o divisor resistivo de tensão desenhado no PSIM. 8. ou o botão . Salvar o arquivo. como Simulation Control. VERSÃO 01 – A BRIL 2003 . Para isso. localizado no menu Simulate . Para que o circuito possa ser simulado é necessário definir os parâmetros de simulação do mesmo. O arquivo deve ser salvo com a extensão sch.

o simulador irá salvar os valores finais da simulação em um arquivo com a extensão ssf. Na figura abaixo está representada esta tela. Para ler valores iniciais. obtida após a simulação de um circuito. em Tempo total da simulação. apenas 1 em cada 10 pontos é salvo. Se 1. nenhum dado é salvo. tem-se a tela do mostrador de formas de onda. no menu Options . Além disso. PARÂMETRO Time Step Total Time Print Time DESCRIÇÃO Passo utilizado segundos na simulação. o botão apertado irá mudar seu desenho para . o simulador irá ler os valores iniciais de um arquivo com a extensão ssf. pode-se simular o circuito. Se 1. PROGRAMA SIMVIEW Executando-se o programa SIMVIEW . Uma vez terminada a simulação. VERSÃO 01 – A BRIL 2003 . Save Flag Com os parâmetros da simulação definidos. Antes de a simulação atingir este tempo. cujos parâmetros são explicados na tabela a seguir. Na barra inferior do programa irá surgir um indicativo do percentual da simulação já atingido. Isso ajuda a reduzir o tamanho do arquivo de saída. Na figura a seguir está um exemplo da tela principal deste programa. todos os pontos são salvos. em segundos Tempo inicial para salvar os dados. existe na barra de ferramentas superior o botão . Isso é realizado através do botão . Para salvar os valores finais. Pode-se configurar o programa PSIM para que ele automaticamente execute o Simview quando as simulações terminarem. pode-se executar o programa Simview. Passo para salvar os pontos. 5. deve-se selecionar o item Auto-run SIMVIEW. na barra de ferramentas superior. Para isso. Para isso. Este botão poderá ser utilizado agora para parar a simulação. Se 10. Se 1. Print Step Load Flag Figura 6 – Parâmetros do controle de simulação.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 9 uma tela com os seus parâmetros é mostrada.

Abaixo está a janela obtida para o circuito desenhado na seção anterior. Para adicionar uma forma de onda deve-se seleciona-la e clicar no botão Add. basta seleciona-la e clicar no botão Remove . VERSÃO 01 – A BRIL 2003 . Estas grandezas são aquelas definidas no circuito desenhado no PSIM.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 10 Figura 7 – Tela de abertura do SIMVIEW. Para isso deve-se utilizar o campo de edição presente na parte inferior da janela. onde estão relacionadas todas as grandezas disponíveis para serem mostradas. para adicionar a expressão matemática. Na tela inicial há uma janela. Da mesma forma que uma variável. Figura 8 – Janela para seleção das formas de onda. É possível realizar funções matemáticas simples entre as variáveis disponíveis. Para retirar uma forma de onda já selecionada.

Imprimir. onde então representadas as tensões sobre os dois resistores. Para adicionar formas de onda ao gráfico atual. Na parte superior o programa apresenta um menu de opções. Ferramenta de zoom. obtém-se a tela a seguir. e alguns botões de atalho. Copiar para a área de transferência (usado para passar as formas de onda para outros programas. criando um novo gráfico. Para passar para o domínio da freqüência. deve-se clicar no botão OK. Na tabela abaixo estão descritos os comandos dos botões da barra de tarefas superior: Abrir arquivo. No caso do exemplo apresentado aqui. Figura 9 – Resultado obtido na simulação. Redesenhar os dados. Para configurar as escalas do eixo horizontal. Para adicionar formas de onda. como um editor de texto). Reabrir o arquivo atual. Para abrir a caixa de medições. adicionando-se as duas variáveis. Para configurar as escalas do eixo vertical. e habilitar os botões de medição. Uma vez selecionadas as formas de onda.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 11 deve-se clicar no botão Add. VERSÃO 01 – A BRIL 2003 .

De uma maneira simplificada são apresentadas as principais ferramentas do programa. bem como algumas razões para que simulações sejam realizadas.* Mostra o valor médio da variável selecionada. VERSÃO 01 – A BRIL 2003 . pressiona-se o botão . CONCLUSÃO Neste material é apresentada uma breve introdução ao uso do simulador de circuitos PSIM.* Mostra o valor mínimo da variável selecionada. Figura 10 – Valores das tensões sobre os resistores. Desta forma aparece uma janela com o nome Measure . Adicionar texto.* Mostra o próximo valor mínimo da variável selecionada.* Mostra o valor médio do módulo da variável selecionada. e demonstrado como realizar uma simulação. e uma variável está selecionada Para saber o valor da tensão sobre os resistores. 6.* * disponível apenas quando a caixa de medições está na tela.* Mostra o próximo valor máximo da variável selecionada. mas o procedimento utilizado pode ser aplicado a circuitos mais complexos. Mostra o valor máximo da variável selecionada.COMO SIMULAR CIRCUITOS ELETRÔNICOS UTILIZANDO PSIM 6 12 Para passar para o domínio do tempo. Para que os valores apareçam nesta janela basta clicar no gráfico. Ferramenta de seleção.* Mostra o valor eficaz da variável selecionada. O circuito simulado é bem simples. São apresentadas algumas características do programa. Na figura a seguir está representado o resultado obtido no exemplo.

Sign up to vote on this title
UsefulNot useful