Modul v Fox Pro 2008

MODUL VISUAL FOXPRO MERCUSUAR

TABLE Table merupakan kerangka utama dalam database. Karena semua elemen database dari paling kecil ke paling besar bermula dari table. Cara membuat Table : • Masukkan perintah berikut pada Command Window : CREATE <nama table> • Maka akan muncul pengisi struktur table seperti dibawah ini :

Masukkan field-field pada : Nama field pada Field, Tab, pilih type data pada Type, Tab, ketik lebar field pada Width, Tab, ketik desimal (jika tipe Numeric), Tab, pilih index (Ascending, Descending, None), Tab, Tab, masukkan field yang lain. Akhiri dengan tekan OK, muncul pertanyaan “Input record data now”, Jawab Yes (bila langsung mengisi record) atau No (jika tidak akan mengisi record).

Memodifikasi Table • Masukkan perintah ini pada Command Window MODIFY STRUCTURE • Cara pengoperasiannya sama dengan pengoperasian langkah-langkah membuat table. FORM Form adalah tool dalam pemrograman visual untuk merancang tampilan masukan (input). Langkah-Langkah membuat Form : Dengan Wizard • Klik menu File, Pilih New, muncul

Menjalankan Form : DO FORM <nama form> Hasil dari form muncul seperti contoh berikut : • Pengoperasian Form : Add untuk menambah record. Ketik rutinnya. pilih Caption. Memberi Rutin agar tombol dapat difungsikan. OK). Save untuk menyimpan record Print mencetak record Edit untuk meng-edit record Delete untuk menghapus record Find untuk mencari record Top ke record no. Klik Close. Fancy. Tutup window Data Environment. • Klik dua kali (Double Klik) pada tombol yang akan diberi rutin. OK. Shadowed. Pilih Form Control Toolbar). • Pilih field yang dijadikan kunci urutan. pilih New File • Muncul Form kosong. lepaskan. Boxed. Klik Ascending (urut kecil – besar) atau Descending (urut besar – kecil). Klik Close. Membuat Tombol Pengoperasian Form. No Button. ganti teksnya dengan nama tombol yang diinginkan.1 Prev ke record sebelum Next ke record sesudah Bottom ke record terakhir Exit menutup form Membuat Form secara manual • Masukkan perintah berikut pada Command Window CREATE FORM <nama form> Atau Klik Menu File. Klik Save. Atur posisi field. Colorful). . Klik View pilih Properties. Embosed. Picture Button. arahkan pointer mouse ke form yang kosong. pilih jenis tombol (Text Button.MODUL VISUAL FOXPRO MERCUSUAR Klik Form. • Klik tombol >> untuk memilih semua field dari table yang akan dibuat form. pilih Table. Klik Add. Klik Next. Pilih Form. • Pilih Style Form (Standard. Klik Next. • Ketik judul form.. Stone.. pilih Form Wizard. Pilih Table yang ada (kalau tidak ada Klik tombol . Klik Finisih.. Custom). Klik Next. Ketik nama file form. Flex. Pilih Data Environment. Klik tahan fields. • Klik Command Button pada Toolbox Form (bila tidak muncul pilih View. klik Wizard. Chiseled. Pilih New. • Berikut rutin untuk tombol-tombol tertentu. Pilih Table. Klik menu View. OK..

Klik OK Ketik Judul Laporan pada tempat sudah disediakan. Banded. klik menu tombol Close [X] jawab Yes. OK). Klik Wizard. Untuk menyimpan. Pilih New. Atur posisi. pilih Titles/Summary. Untuk menambah Judul. Klik Next • Pilih field yang dijadikan kunci urutan. Klik Next • Pilih Field Layout (Columns. Klik Next.Refresh Menghapus Delete ThisForm. Langkah-langkah membuat report Dengan Wizard • Klik Menu File. pilih Quick Report.. pilih New File Muncul report dalam keadaan kosong. • • • • • Klik Check Box pada Title Band. Untuk melihat hasil report ke printer klik Icon ! atau dari menu Report pilih Run Record. • Pilih nama table (bila belum ada. Ketik nama file Report.Release REPORT Report adalah tool dalam pemrograman visual yang digunakan untuk merancang laporan. Pilih Report. maka field akan masuk kedalam report. • Ketik judul Report. klik tombol . Pilih field-fieldnya dan Klik tombol >>.Refresh Ke record Sebelum (Prev) If BOF() Go Top Else Skip -1 Endif ThisForm. Klik Next • Pilih Style Form (Executive.Refresh Ke Record Akhir (Bottom) Go Bottom ThisForm.Refresh Ke Record Pertama (Top) Go Top ThisForm. OK. Pilih New. .Refresh Ke record Sesudah (Next) If EOF() Go Bottom Else Skip Endif ThisForm. Klik Finisih. Pilih Report. Klik Next • Pilih field yang dijadikan kunci pengelompokan. Ledger. pilih table. Klik Menu Report.Refresh Keluar ThisForm. Klik Save. Presentation. Klik Add.. Klik Ascending (urut kecil – besar) atau Descending (urut besar – kecil). Pilih Report Wizard. Membuka File Report Masukkan perintah berikut pada Command Window REPORT FORM <nama report> Membuat Form secara manual • Masukkan perintah berikut pada Command Window CREATE REPORT <nama form> Atau Klik Menu File. Landscape). Klik icon Preview.MODUL VISUAL FOXPRO MERCUSUAR Tambah data Append Blank ThisForm. Row) dan Pilih Orientation (Portrait. Klik menu Report.. Untuk melihat hasil report. OK. Casual).

OK. . Maka menjadi seperti contoh berikut : • • • • Pilih field pada bagian Available fields dan tekan tombol Add> maka field pindah ke bagian Selected fields. Klik Other. Jalankan hasil query. Akhiri dengan menyimpan file Query. Klik OK. pilih table kedua (dan seterusnya). Untuk menyaring data klik bagian Filter. Langkah membuat Query • Masukkan perintah ini dalam Command Windows CREATE QUERY <nama query> • Pilih table pertama. • Akhiri dengan tekan tombol Close. Pilih Field Name. Klik Icon ! untuk melihat hasil Query. masukkan kriteria penyaringan. Pilih Criteria.MODUL VISUAL FOXPRO MERCUSUAR QUERY QUERY adalah tool dalam pemrograman visual yang digunakan untuk menghubungkan beberapa table menjadi satu relasi atau join. OK.

Sign up to vote on this title
UsefulNot useful