You are on page 1of 5

TALLER PROGRAMACION

ANGEL JAVIER PEREZ PIMIENTA 2021216090

INGENIERO ROBERTO MAL DOCENTE

UNIVERSIDAD DEL MAGDALENA FACULTAD DE INGENIERIA PROGRAMCION INDUSTRIAL

1. sum=0.".j<5. j. sum. para(i=0. se deben hacer a través de recorridos de ciclos. j.1)hacer imprimir(" INGRESE NUMERO EN LA POSICION ".i. sum = (sum + A[i][j]). . fin_para fin_para para(i=0. Diseñe un Algoritmo que llene una matriz de 5X5 y luego calcule la suma de lo elementos de la primera fila." : ").1)hacer j=0.i<5.1)hacer para(j=0.i. 1 3 0 5 6 4 4 5 6 5 5 3 2 8 7 6 6 1 9 1 2 1 5 10 2 funcion_principal entero A[5][5].i<5. leer(A[i][j]). sum=0. ". de la ultima columna. fin_para imprimir("LA SUMA DE LA PRIMERA FILA ES: ". Se Calcularan cuatro sumatorias independientes. Los cálculos no se podrán hacer directamente. de la primera columna. de la ultima fila."\n").

1)hacer si(i==j)entonces P[i][j]=1.j<5. fin_principal 2. sum=0. Diseñe un algoritmo que llene una matriz de 5x5 con 1 en la diagonal principal. los elementos por debajo de la diagonal los llene con 0 y los que están por encima con 2. sum = (sum + A[i][j]).1)hacer i=0.sum. sum=0."\n"). sum = (sum + A[i][j]). fin_para imprimir("LA SUMA DE LA ULTIMA FILA ES: ". imprimir(P[i][j].i. j.1)hacer para(j=0.1)hacer j=4. Las asignaciones se efectuaran a través de recorridos de ciclos y no a través de asignaciones directas. para(i=0. si_no si(j<i)entonces ."\n").i<5.1)hacer i=4. fin_para imprimir("LA SUMA DE LA PRIMERA COLUMNA ES: ".sum. 1 0 0 0 0 2 1 0 0 0 2 2 1 0 0 2 2 2 1 0 2 2 2 2 1 funcion_principal entero P[5][5]. sum = (sum + A[i][j]).j<5.para(i=0. para(j=0."\n"). fin_para imprimir("LA SUMA DE LA ULTIMA COLUMNA ES: "." ").i<5.j<5. para(j=0.sum.

si_no P[i][j]=2.P[i][j]=0. Diseñe un algoritmo que lea por teclado dos matrices A y B de 4x4 y llene una tercera matriz C con la el resultado de sumar las dos matrices. fin_para fin_principal 3. 0 A 0 1 2 3 1 0 10 3 2 3 1 4 1 8 4 7 6 2 0 6 1 9 3 B 0 1 2 3 0 2 4 6 6 1 4 8 1 7 2 4 9 2 1 3 1 3 0 4 C 0 1 2 3 0 3 4 16 9 1 6 11 2 11 2 12 13 9 7 3 0 9 0 13 ." "). imprimir(P[i][j]. imprimir(P[i][j]." "). fin_si fin_si fin_para imprimir("\n").

j<4.i. leer(A[i][j]).".i<4. "." "). ". C[4][4]. imprimir(C[i][j]. B[4][4].j.i.i<4.j<4. imprimir("MATRIZ A\n").": "). para(i=0. fin_para fin_para imprimir("LA MATRIZ RESULTANTE C ES:\n").i.": "). leer(B[i][j]). fin_para fin_para imprimir("MATRIZ B\n").1)hacer imprimir("INGRESE NUMERO EN LA POSICION ".j<4. fin_para imprimir("\n").1)hacer para(j=0.funcion_principal entero A[4][4].j.i<4.1)hacer imprimir("INGRESE NUMERO EN LA POSICION ".1)hacer para(j=0. j.1)hacer C[i][j]=A[i][j]+B[i][j]. fin_para fin_principal . para(i=0.". para(i=0.1)hacer para(j=0.