Probleme TEST INITIAL 1,Se da un numar natural a de maxim 9 cifre.

Sa se determine prima cifra a lui a 2,Ghiceste numarul – Cautare binara

-

intreg x,m1,m2, mij, pasi; citesc x; m1 <- 1; m2<- 100; mij<- 50; pasi<- 0; cat timp (mij!=x) executa {daca (x<mij) atunci m2<- mij; altfel m1<- mij; mij<-(m1+m2)/2; pasi<- pasi +1;}; scrie pasi.

3, Se citeste n, sa se determine toate numerele perfecte mai mici decît n. Un numar este perfect daca este egal cu suma divizorilor sai (de ex. 6=1+2+3).