P. 1
CFX Mesh Tutorials

CFX Mesh Tutorials

|Views: 3,610|Likes:
Published by lvstudio
CFX-Mesh Tutorials
CFX-Mesh Tutorials

More info:

Published by: lvstudio on Sep 08, 2009
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

12/06/2012

pdf

text

original

Contents•Copyright

Geometry Creation

Geometry Creation

Creating the Project

1. Open ANSYS Workbench, and create a new project.
2. Open up DesignModeler, specifying the units as meters.

Back To Top

Creating the Solid

The first step is to create the main solid, which is a simple box.

1. Create a new sketch (

) based on the XYPlane.
2. Use Rectangle from the Draw Toolbox of the Sketching tab to create a rectangle which has one corner at the
origin and another at X = 3.0 m, Y = 3.0 m

3. Select

Extrude from the 3D Features Toolbar.
4. Set Base Object to be the new sketch (Sketch1), and set Operation as Add Material.

5. Set Depth to be 2.5 m, and click on

Generate to generate the solid.

Back To Top

Breaking the Faces to form the Boundary Conditions

The solid that you have just created has six rectangular faces. Some of these faces need breaking up, so that the
features such as windows, door and vents exist as separate faces of the solid. This can be done by using Extrude with
the Imprint Faces option.

Using this option requires sketches of the correct dimensions to be created first. However, when the Extrude
operation takes place, you cannot choose to have the Imprint Faces action only apply at a specified face; it will apply
at all faces between the sketch and the required face. For this reason, the sketches cannot be created on the existing
three planes since then they would always affect the faces of the solids which are co-planar with these planes. This
means that you need to start by creating a new plane.

http://www.ansys.com/dm_how_tos/cm_hvac_geom.html (1 of 4)2005-2-20 21:18:16

Contents•Copyright

Tutorial 12: Room with Air Conditioning> Geometry
Creation

Geometry Creation

1. Create a new plane (

), based on the XYPlane.
2. In the Details View, set Transform 1 to Offset Z, and set the Value of the offset to 1 m.

3. Click on

Generate to create the plane.

4. Create a new sketch (

) based on the new plane (Plane4). Use Rectangle from the Draw Toolbox of the
Sketching tab to create a rectangle which has one corner at X = 0.05 m, Y = 1.3 m and another at X = 0.15 m,
Y = 1.7 m.

5. Select

Extrude from the 3D Features Toolbar.
6. Set Base Object to be the new sketch (Sketch2), and set Operation as Imprint Faces.

7. Set Type to be To Next, and click on

Generate to break the top face.

Notice that in the figure above, the top face has been selected in order to show that it is in two parts.

These operations now need to be repeated to break the faces to form the windows and side vent.

1. Create a new plane (

), based on the ZXPlane. [In ANSYS Workbench 8.0.1, create the new plane based

on the XZPlane.]

2. In the Details View, set Transform 1 to Offset Global Y, and set the Value of the offset to 1 m.

3. Click on

Generate to create the plane.

4. Create a new sketch (

) based on the new plane (Plane5). Use Rectangle from the Draw Toolbox of the
Sketching tab to create a rectangle which has one corner at X = 1.25 m, Z = 0.75 m and another at X = 1.75
m, Z = 1.75 m.
5. Use Rectangle from the Draw Toolbox of the Sketching tab to create another rectangle, which has one
corner at X = 2.05 m, Z = 0.15 m and another at X = 2.55 m, Z = 0.55 m.

6. Select

Extrude from the 3D Features Toolbar.
7. Set Base Object to be the new sketch (Sketch2), and set Operation as Imprint Faces.

http://www.ansys.com/dm_how_tos/cm_hvac_geom.html (2 of 4)2005-2-20 21:18:16

Geometry Creation

8. Set Direction to Reversed, Type to be To Next, and click on

Generate to break a side face. [In ANSYS

Workbench 8.0.1, Direction should be set to Normal.]

1. Create a new plane (

), based on the YZPlane.
2. In the Details View, set Transform 1 to Offset Z, and set the Value of the offset to 1 m.

3. Click on

Generate to create the plane.

4. Create a new sketch (

) based on the new plane (Plane6). Use Rectangle from the Draw Toolbox of the
Sketching tab to create a rectangle which has one corner at Y = 1.25 m, Z = 0.75 m and another at Y = 1.75
m, Z = 1.75 m.

5. Select

Extrude from the 3D Features Toolbar.
6. Set Base Object to be the new sketch (Sketch4), and set Operation as Imprint Faces.

7. Set Direction to Reversed and Type to To Next, then click on

Generate to break another side face.

http://www.ansys.com/dm_how_tos/cm_hvac_geom.html (3 of 4)2005-2-20 21:18:16

Geometry Creation

Finally, you need to break one more face to make a face for the door. However, this time, the plane which contains
the sketch to be extruded must be outside the geometry. Otherwise, because the door reaches the edge of the room,
you will find that the rectangular (unbroken) face which shares an edge with the door will be broken.

1. Create a new plane (

), based on the YZPlane.
2. In the Details View, set Transform 1 to Offset Z, and set the Value of the offset to 4 m.

3. Click on

Generate to create the plane.

4. Create a new sketch (

) based on the new plane (Plane4). Use Rectangle from the Draw Toolbox of the
Sketching tab to create a rectangle which has one corner at Y = 2.3 m, Z = 0.0 m and another at Y = 3.0 m, Z
= 2.0 m.

5. Select

Extrude from the 3D Features Toolbar.
6. Set Base Object to be the new sketch (Sketch5), and set Operation as Imprint Faces.

7. Set Direction to Reversed and Type to To Next, and click on

Generate to break the side face.

The geometry is now complete.

1. Select File>Save to save the geometry file.

Prev

Up

Next

Tutorial 12: Room with Air
Conditioning

Home

Mesh Generation

http://www.ansys.com/dm_how_tos/cm_hvac_geom.html (4 of 4)2005-2-20 21:18:16

Mesh Generation

Mesh Generation

First open CFX-Mesh.

1. Switch from the DesignModeler to the Project Page using the tabs at the top of the window and open CFX-

Mesh.

Setting up the Regions

Create the 2D Regions:

1. Create a Composite 2D Region called Inlet on the vent in the roof (small rectangular face contained in the
plane with the highest Z-coordinate.
2. Create a Composite 2D Region called Roof on the remaining part of the roof (highest Z-coordinate).
3. Create a Composite 2D Region called Window1 on the rectangular face which is cut out from the ZXPlane.
This plane has two cutout rectangular faces, and you need the one which is taller and located at a higher Z-
coordinate.

4. Create a Composite 2D Region called Window2 on the rectangular face which is cut out from the YZPlane.
5. Create a Composite 2D Region called VentOut on the rectangular face which is cut out from the ZXPlane.
This plane has two cutout rectangular faces, and you need the one which is smaller and located at a lower Z-
coordinate.

6. Create a Composite 2D Region called Floor on the rectangular face which is in the XYPlane.
7. Create a Composite 2D Region called Door on the tall, thin rectangular face which is cut out from the face
with the highest X-coordinate.

Back To Top

Setting up the Mesh

Set the Maximum Spacing:

1. Click on Default Body Spacing in the Tree View, which is contained in Mesh>Spacing.
2. In the Details View, change Maximum Spacing to 0.25 m, and press Enter on the keyboard to set this value.

This is a coarse length scale, suitable only for tutorial purposes. In order to better resolve the flow near the inlet and
outlet vents, Face Spacings will be applied to these regions to refine the mesh.

1. Right-click on Spacing and select Insert>Face Spacing.

http://www.ansys.com/dm_how_tos/cm_hvac_mesh.html (1 of 3)2005-2-20 21:18:39

Contents•Copyright

Tutorial 12: Room with Air Conditioning> Mesh
Generation

Mesh Generation

2. In the Details View, set Face Spacing Type to Constant, and set the Constant Edge Length to 0.04 m.
3. Set the Radius of Influence to 0.0 m, and Expansion Factor to 1.3.
4. For Location, select Inlet from the Tree View.
5. Right-click on Spacing and select Insert>Face Spacing, to create another Face Spacing.
6. In the Details View, set Face Spacing Type to Constant, and set the Constant Edge Length to 0.1 m.
7. Set the Radius of Influence to 0.0 m, and Expansion Factor to 1.3.
8. For Location, select VentOut from the Tree View.

Back To Top

Setting up Inflation

It is a good idea to put inflation on the walls.

1. Click on Inflation in the Tree View. In the Details View, set Number of Inflated Layers to 5.
2. Set Expansion Factor to 1.2. Leave the rest of the parameters as their default values.
3. In the Tree View, right-click on Inflation and select Insert>Inflated Boundary.
4. For Location, select all of the Composite 2D Regions in the Tree View (including the Default 2D Region)
except for Inlet and VentOut. The Details View should show 6 Composites after you have made the
selection.
5. Set Maximum Thickness to 0.25 m.

Back To Top

Generating the Volume Mesh

Finally, you can generate the volume mesh.

1. Click on Options in the Tree View, and change GTM Filename to HVACMesh.gtm.
2. Right-click on Mesh in the Tree View and select Generate Volume Mesh.

The mesh is now complete.

1. Select File>Save to save the CFX-Mesh database.
2. Switch to the Project Page using the tabs at the top of the window, and choose File>Save to save the project.
3. Exit from ANSYS Workbench by selecting File>Exit.

You can now work through the CFX-5.7 example “Tutorial 17: Air Conditioning Simulation” using the newly-
generated mesh.

http://www.ansys.com/dm_how_tos/cm_hvac_mesh.html (2 of 3)2005-2-20 21:18:39

Mesh Generation

Prev

Up

Next

Geometry Creation

Home

Tutorial 13: Can Combustor

http://www.ansys.com/dm_how_tos/cm_hvac_mesh.html (3 of 3)2005-2-20 21:18:39

Tutorial 13: Can Combustor

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->