OTEdit for Mac 基本操作

2007 年 7 月 24 日 版
武蔵システム

本書の表記
・ メニュー、コマンド、ダイアログボックス、ダイアログボックス内の項目やボタン名などは、[]で
くくります。
・ 操作説明中、メニューからコマンドを実行する場合は、“[ファイル]→[インポート]→[ビットマッ
プファイル]”という表記をしています。これは“[ファイル]メニューから[インポート]を選び、そ
のサブメニューである[ビットマップファイル]をクリックする”という意味になります。
・ 単に OTEdit と記載した場合、OTEdit for Mac のことを示します。

Adobe、ATM、Acrobat、Illustrator、InDesign、InCopy、PostScript は、アドビ システムズ社の米国
ならびに他の国における商標または登録商標です。
Macintosh と Apple、Mac OS は、それぞれ、Apple Computer,Inc.の米国および他諸国で登録されている
登録商標および商標です。
Microsoft、Windows、Windows NT は、Microsoft Corporation の米国およびその他の国における登録商
標です。
フォントを変形加工して1組みの書体またはフォントとして制作、使用、販売する等の行為は、権利障
害になる場合があります。

2

目次
第1章 基礎知識............................................................................................................................................. 5

1.1 OPENTYPE フォント ........................................................................................................................6
1.2 OTEDIT はどんなソフト? ............................................................................................................9
1.3 メイン画面の名称.....................................................................................................................11
第2章 新規作成からフォントのインストールまで ..................................................................................... 12

2.1
2.2
2.3
2.4
2.5
2.6

OPENTYPE フォントの新規作成 ....................................................................................................13
作成する文字の選択 .................................................................................................................15
グリフの作成............................................................................................................................16
ファイルの保存 ........................................................................................................................20
フォントのインストール ..........................................................................................................20
フォントのアンインストール...................................................................................................22

第3章 ファイルのオープン ......................................................................................................................... 24

3.1 インストール済みフォントのオープン.....................................................................................25
3.2 未インストールフォントのオープン ........................................................................................26
第4章 編集文字の指定 ................................................................................................................................ 27

4.1 [文字指定]ダイアログによる指定 .............................................................................................28
4.2 「文字一覧」からの指定 ..........................................................................................................29
4.3 次の文字・前の文字の表示 ......................................................................................................30
第5章 描画ツールによるグリフ作成........................................................................................................... 32

5.1 [ペン]ボタンによる描画 ......................................................................................................33

5.1.1
5.1.2
5.1.3
5.1.4
5.1.5
5.1.6
5.2
5.3
5.4
5.5
5.6
5.7
5.8

曲線の描画 ........................................................................................................................33
丸い図形(たまご形)の描画.................................................................................................33
直線の描画 ........................................................................................................................34
輪郭を閉じる.....................................................................................................................35
方向点の引き出し ...............................................................................................................35
スムーズポイント、コーナーポイントの相互変換....................................................................36

[直線]・[多角形]ボタンによる描画.....................................................................................37
[長方形]・[楕円]ボタンによる描画.....................................................................................39
[鉛筆]ボタンによる描画 ......................................................................................................41
[制御点の挿入]ボタンによる制御点の追加..........................................................................43
[消しゴム]ボタンによる制御点の削除 .................................................................................45
[選択]ボタンによる制御点の選択 ........................................................................................46
[なげなわ]ボタンによる制御点の選択 .................................................................................48

第6章 グリフの修整.................................................................................................................................... 50

6.1 輪郭の結合 ...............................................................................................................................51

3

6.2
6.3
6.4
6.5

輪郭の切断 ...............................................................................................................................52
制御点の位置揃え.....................................................................................................................54
グリフの反転............................................................................................................................55
グリフの中央移動.....................................................................................................................57

第7章 いろいろな表示方法 ......................................................................................................................... 59

7.1 拡大・縮小 ...............................................................................................................................60
7.2 塗りつぶしで表示.....................................................................................................................62
7.3 制御点の表示/非表示..............................................................................................................63
第8章 編集操作........................................................................................................................................... 65

8.1
8.2
8.3
8.4

コピー&ペースト.....................................................................................................................66
文字取り込み............................................................................................................................68
巻き方向を修正 ........................................................................................................................69
オーバーラップ輪郭を削除 ......................................................................................................71

第9章 ビットマップファイルからのグリフ作成 ......................................................................................... 73

9.1 ビットマップファイルの用意...................................................................................................74
9.2 ビットマップファイルのインポート ........................................................................................74
第10章 ILLUSTRATOR でのグリフ作成 ................................................................................................. 76

10.1 SING 外字ファイルの作成 ...................................................................................................77
10.2 SING 外字ファイルのインポート.........................................................................................79
第11章 文字情報の設定 ............................................................................................................................ 80

11.1 文字幅の設定 ........................................................................................................................81
11.2 縦書き位置の設定 .................................................................................................................82
第12章 一括コピー.................................................................................................................................... 85

12.1 新規ファイルへの全文字コピー............................................................................................86
12.2 既存ファイルへの追加コピー ...............................................................................................88
12.3 CSV ファイルでのコピー文字指定 .......................................................................................89
第13章 オンラインヘルプ ......................................................................................................................... 91

13.1 トラブルシューティング ......................................................................................................92

4

第1章

基礎知識

第1章 基礎知識
ここでは OTEdit がどのような特徴を持つソフトなのか説明します。また、OpenType フォントについて
も簡単ではありますが解説しています。

OpenType フォント
OTEdit はどんなソフト?
メイン画面の名称

5

第1章

基礎知識

1.1 OpenType フォント
OpenType フォントは Adobe 社と Microsoft
社が共同で開発したフォントフォーマット
です。ベジェ曲線と直線で文字の輪郭を記述
します。

アウトラインフォント

OpenType フォントのように文字の輪郭を
定義したフォントをアウトラインフォント
(outline font)といいます。拡大してもギザ
ギザが現れず綺麗に表示されます。これに対
して、点の集まりで定義されたフォントを
ビットマップフォント(bitmap font)または
ドットフォント(dot font)と呼びます。拡大
して表示するとギザギザが現れます。

ビットマップフォント

1 つのベジェ曲線は、4 つの制御点で構成
され、両端の制御点は端点(アンカーポイン
ト)、間の 2 点は方向点と呼ばれます。

2 つ以上のベジェ曲線がつながる場合は、
手前のベジェ曲線の端点が、次のベジェ曲線
の端点となります。

また端点は、スムーズポイント及びコー
ナーポイントのどちらかになります。
スムーズポイントの場合、その前後にある
方向点の直線上に位置し、2 つのベジェ曲線
が滑らかにつながります。OTEdit では赤丸
で表示されます。
コーナーポイントの場合、2 つのベジェ曲
線は鋭角になります。OTEdit では赤い四角
で表示されます。

6

第1章

基礎知識

直線は直線ポイントで構成されます。
OTEdit では赤い四角で表示されます。

文字の字形を専門用語ではグリフ(Glyph)
と呼びます。
グリフには描画方向があり、OpenType フ
ォントでは、外側の輪郭は反時計回りに、内
側の輪郭は時計回りに描かなければなりま
せん。制御点を描いた順番が大きくなる方向
に進んで左側が黒く塗られます。これを間違
えると、思わぬ塗り状態になってしまいます。
なお、この方向は TrueType フォントの場
合とは逆になっています。
複数のグリフが交差してもいけません。
交差しているためよくない

このように作成するこ

7

第1章

基礎知識

文字は仮想ボディと呼ばれるボックス内
に作成します。また下側にベースラインと呼
ばれる基準位置を設け、これより上をアセン
ト、下をディセントと呼びます。

コラム
ベジェ曲線を数式で示すと次のようになります。

t を媒介変数とする、x,y の2次元平面上の曲線として表現されます。

8

第1章

基礎知識

1.2 OTEdit はどんなソフト?
OTEdit は OpenType フォントを作成するソ
フトです。
OTEdit ではドロー系のソフトと同様な操
作でグリフを作成します。

Adobe Creative Suite2 付属の Illustrator
CS2 で SING 外字ファイルを作成し、OTEdit
に取り込むこともできます。Illustrator を
使い慣れた人であれば、この方が作成し易い
と思います。

OTEdit に取り込
んだ状態

9

第1章

基礎知識

ドロー系のソフトが使いづらい人は、ペイ
ント系のソフトで文字をデザインして
OTEdit に取り込むこともできます。

OTEdit に取り込
んだ状態

10

第1章

基礎知識

1.3 メイン画面の名称
スケール
ツールバー
描画ツールバー
編集画面

11

第2章

新規作成からフォントのインストールまで

第2章 新規作成からフォントのインストールまで
ここでは、OpenType フォントを新規に作成するところから、フォントをパソコンにインストールす
るままでの手順を説明します。

OpenType フォントの新規作成
作成する文字の選択
グリフの作成
ファイルの保存
フォントのインストール
フォントのアンインストール

12

第2章

新規作成からフォントのインストールまで

2.1 OpenType フォントの新規作成
①OTEdit のメニュー[ファイル]→[新規作
成]をクリックします。
[フォント種類の選択]ダイアログが表示
されます。

②作成するフォントの種類を選択します。今
回は、[Std フォント]のままとします。


各種類の意味は次の通りです。
Std フォント

Adobe-Japan1-3 の 9,354 字に対応したフォントです。

Pro フォント

Adobe-Japan1-4 の 15,444 字に対応したフォントです。CID の 0~9,353 は
Std フォントと同じです。

Adobe-Japan1-x キャラクタセットについては、 Adobe の Web サイト
http://partners.adobe.com/public/developer/font/index.html で公開されている
「Adobe-Japan1-6 Character Collection for CID-Keyed Fonts #5078 (PDF: 7.38M)」をご参照くだ
さい。
Adobe-Japan1-6 の CID 0 ~ 9353 が Adobe-Japan1-3 キ ャ ラ ク タ セ ッ ト 、 CID 0 ~ 15443 が
Adobe-Japan1-4 キャラクタセットです。
③[次へ]をクリックします。
[フォントメトリクスの設定]ダイアログ
が表示されます。
④[アセント]の値を設定します。今回は、880
のままとします。
⑤[ディセント]の値を設定します。今回は、
120 のままとします。


13

第2章

新規作成からフォントのインストールまで

アセントとディセントの合計が 1000(仮
想ボディの値)になるように設定してくだ
さい。強制ではありませんが、異なると、
作成したフォントをアプリケーションソ
フトで使う時に何らかの問題が発生する
かもしれません。
ア セ ン ト と デ ィ セ ン ト の 単 位 は FUnit
(Font Unit、フォントユニット)と呼ばれ
る抽象的なもので、mm(ミリメートル)の
ような物理的寸法ではありません。
⑥[次へ]をクリックします。
[書体名の設定]ダイアログが表示されま
す。
⑦[書体名(日本語用)]を設定します。
⑧[書体名(英語用)]を設定します。日本語は
使わないで、半角の英語と数字で設定して
ください。
⑨[著作権]を設定します。ここで設定した値
は、フォントファイル内に記入されます。
⑩[完了]をクリックします。



⑪編集画面が表示されます。

14

第2章

新規作成からフォントのインストールまで

2.2 作成する文字の選択
①[表示]→[他の文字]をクリックします。
[文字指定]ダイアログが表示されます。

②[入力方法]として、[Unicoce]を選択しま
す。
③[データ]にこれから作成する文字を入力
します。今回は、丸付き数字①の文字に、
グリフ❶を作成してみます。データに 2460
と入力します。
④[OK]をクリックします。


⑤編集画面が文字①用に変わります。

15

第2章

新規作成からフォントのインストールまで

2.3 グリフの作成
①[編集]→[文字取り込み]をクリックしま
す。
[文字取り込み]ダイアログが表示されま
す。

②[文字]に半角数字 1 を入力します。
③フォントの一覧から Arial を選択します。
④[OK]をクリックします。


⑤編集画面にフォント Arial の”1”のグリ
フが取り込まれます。

16

第2章

新規作成からフォントのインストールまで

⑥キーボードの右矢印キーを数回押下して、
今取り込んだグリフを中央に移動します。
この時、グリフの選択が解除されていると、
右矢印キーを押下しても、グリフが移動し
ません。その場合は、[編集]→[すべて選
択]をクリックしてから再度行ってくださ
い。

選択が解除
された状態

⑦OTEdit のメイン画面左側にある描画ツー
ルバーから、[楕円]をクリックします。

17

第2章

新規作成からフォントのインストールまで

⑧キーボードの Shift キーを押しながら、編
集画面内赤いボックスの左上でクリック
し、そのまま右下までドラッグします。
円が描かれます。

⑨[表示]→[塗りつぶしで表示]をクリック
します。

18

第2章

新規作成からフォントのインストールまで

⑩ グ リ フが塗 り つ ぶされ た 実 際の文 字 イ
メージで表示されます。
円の中の1が黒く塗られており、このまま
では単なる黒丸と同じです。これは、グリ
フの描画方向が間違っているためです。

⑪[編集]→[巻き方向を修正]を選択します。

⑫グリフの描画方向が修正され、正しく表示
されます。

19

第2章

新規作成からフォントのインストールまで

2.4 ファイルの保存
①[ファイル]→[保存]をクリックします。

②ファイルを保存する[場所]を選択します。
③[名前]を適当に設定します。
OpenType フ ォ ン ト の フ ァ イ ル 拡 張 子
は.otf で、[名前]の後ろに自動的に追加さ
れます。
④[保存]をクリックします。


2.5 フォントのインストール
①Font Book を起動します。

20

第2章

新規作成からフォントのインストールまで

②[ファイル]→[新しいコレクション]をク
リックします。

③新しいコレクションが追加されるので名
前を適当に設定(今回は OTEdit を設定)
します。

④[ファイル]→[フォントを追加]をクリッ
クします。

21

第2章

新規作成からフォントのインストールまで

⑤OTEdit で作成したフォントを選択します。
⑥[開く] をクリックします。


⑦フォントが追加されます。

2.6 フォントのアンインストール
①Font Book を起動します。

②アンインストールしたいフォントを選択
します。

22

第2章

新規作成からフォントのインストールまで

③[ファイル]→["xxx(選択したフォント名)
"を取り除く]をクリックします。

④確認ダイアログが表示されるので、[取り
除く]をクリックします。

23

第3章

ファイルのオープン

第3章 ファイルのオープン
ここでは既存ファイルのオープンについて説明します。

インストール済みフォントのオープン
未インストールフォントのオープン

24

第3章

ファイルのオープン

3.1 インストール済みフォントのオープン
ここでは、パソコンにインストールされて
いるフォントを、OTEdit でオープンする方
法について説明します。

①[ファイル]→[インストール済みを開く]
をクリックします。
インストール済みフォントの一覧が表示
されます

②オープンしたいフォントを選択します。
③[OK]をクリックします。

⑤選択したフォントがオープンされます。

25

第3章

ファイルのオープン

3.2 未インストールフォントのオープン
まだパソコンにインストールしていない
フォントのオープンについて説明します。

①[ファイル]→[開く]をクリックします。

②OpenType フォントを選択します。
③[開く]をクリックします。

④選択したフォントがオープンされます。

26

第4章

編集文字の指定

第4章 編集文字の指定
ここでは作成する文字を指定する方法について説明します。

[文字指定]ダイアログによる指定
「文字一覧」からの指定
次の文字・前の文字の表示

27

第4章

編集文字の指定

4.1 [文字指定]ダイアログによる指定
「2.2作成する文字の選択」で述べました
が、ここで改めて説明します。

①[表示]→[他の文字]をクリックします。
[文字指定]ダイアログが表示されます。


②編集する文字の指定を文字コードの指定
で行うか文字入力で行うかを[入力方法]
の中から選択します。

入力方法

説明

文字

文字で指定します。

シフト JIS コード

シフト JIS で指定します。

JIS コード

JIS コードで指定します。

Unicode

Unicode で指定します。

CID

CID(character identifier)で指定します。

③上で選択した入力方法に応じた値を[デー
タ]に入力します。
④縦書き文字を選択する場合は、「縦書き」
のチェックボックスを選択状態にしてく
ださい。これは、縦書き専用文字を持って
いる場合に有効です。縦書き専用文字は、
OTEdit のインストール先にある「縦書き専
用文字.xls」ファイルを参照してください。
このファイルには、横書き文字の CID とそ
の縦書き文字の CID が記入されています。
⑤[OK]をクリックします。
⑥入力した文字の編集画面になります。

28

第4章

編集文字の指定

4.2 「文字一覧」からの指定
①[表示]→[文字一覧を表示]をクリックし
ます。
「文字一覧」ウィンドウが表示されます。
左側に表示されているのは文字コードの
上位側コードで、上に表示されている 0~F
は、文字コードの最下位コードです。

②[サンプルを表示]をクリックします。
白で各文字のサンプルが表示されます。

文字コードの最
下位コード

文字コードの上位側コード

③編集したい文字が見えるまでスクロール
します。
④編集したい文字部分で、ダブルクリックし
ます。

このコードは
0050 + 9 = 0059
となる


29

第4章

編集文字の指定

⑤ダブルクリックしたところの文字の編集
画面になります。

4.3 次の文字・前の文字の表示
現在、編集画面に表示している文字の、次
の CID の文字や前の CID の文字を表示する方
法を説明します。

①[表示]→[次の文字]をクリックします。

②次の CID の文字が表示されます。

30

第4章

編集文字の指定

③同様に、[表示]→[前の文字]をクリックす
れば、前の CID の文字が表示されます。

31

第5章

描画ツールによるグリフ作成

第5章 描画ツールによるグリフ作成
ここでは、描画ツールにより、グリフを作成する方法を説明します。

[ペン]ボタンによる描画
[直線]
・[多角形]ボタンによる描画
[長方形]・[楕円]ボタンによる描画
[鉛筆]ボタンによる描画
[制御点の挿入]ボタンによる制御点の追加
[消しゴム]ボタンによる制御点の削除
[選択]ボタンによる制御点の選択
[なげなわ]ボタンによる制御点の選択

32

第5章

描画ツールによるグリフ作成

5.1 [ペン]ボタンによる描画
5.1.1 曲線の描画
①描画ツールバーの[ペン]ボタンをクリッ
クします。

②編集画面上をクリックします。
③曲線の曲がり方向が変わる所で左ボタン
を押します。
④そのままドラッグし、左ボタンを離します。
⑤曲線の終わりでクリックします。

③ここで左ボタンを押す

②クリック

⑤クリック

④ここまでドラッグし、
左ボタンを離す

5.1.2 丸い図形(たまご形)の描画
③ここまでドラッグし、左ボタンを離す
①描画ツールバーの[ペン]ボタンをクリッ
クします。
②編集画面上で左ボタンをクリックします。
③そのままドラッグし、左ボタンを離します。
④丸い図形の反対側あたりで左ボタンを押
します。
⑤そのままドラッグし、左ボタンを離します。

④ここで左ボタンを押す

②ここで左ボタンを押す
⑤ここまでドラッグし、
左ボタンを離す
33

第5章

描画ツールによるグリフ作成

⑥②の位置で再度左ボタンを押します。

⑥ここで左ボタンを押す

⑦そのままドラッグし、左ボタンを離します。

⑦ここまでドラッグし、左ボタンを離す

5.1.3 直線の描画
①描画ツールバーの[ペン]ボタンをクリッ
クします。
②頂点部分でマウスをクリックします。

②クリック

34

第5章

描画ツールによるグリフ作成

5.1.4 輪郭を閉じる
輪郭を閉じるには、
・command キー( )を押しながら画面をク
リック
・マウスの右ボタンをクリック
・輪郭開始点をクリック
・最後の制御点でダブルクリック
のいずれかを行います。

・command キー( )を押しながらクリック
・マウスの右ボタンをクリック
・輪郭開始点をクリック
・最後の制御点でダブルクリック
のいずれかを行う。

輪郭が閉じられる

5.1.5 方向点の引き出し
直線ポイントからは方向点を引き出して、
線を修正することができます。

①描画ツールバーの[選択]ボタンをクリッ
クします。

35

第5章

描画ツールによるグリフ作成

②option キーを押しながら直線ポイント上
で左ボタンを押します。
②option キーを押しながら
左ボタンを押す

③そのままドラッグし、左
ボタンを離す

③そのままドラッグし、左ボタンを離します。


④離した位置に方向点が移動します。

5.1.6 スムーズポイント、コーナーポイントの相互変換
スムーズポイントをコーナーポイントへ、
逆にコーナーポイントをスムーズポイント
に変換することができます。
①描画ツールバーの[選択]ボタンをクリッ
クします。

②コーナーポイント上で control キーを押
しながらクリック(または単に右クリッ
ク)し、表示されるメニューから「スムー
ズポイントに変換」を選択します。

③コーナーポイントがスムーズポイントに
変換されます。
④スムーズポイントに変換されたので、方向
点を移動すると反対側の方交点も一緒に
移動します。

36

第5章

描画ツールによるグリフ作成

⑤スムーズポイント上で control キーを押
しながらクリック(または単に右クリッ
ク)し、表示されるメニューから「コーナー
ポイントに変換」を選択します。

⑥スムーズポイントがコーナーポイントに
変換されます。

⑦コーナーポイントに変換したので、方向点
を移動すると、ドラッグしている方向点の
みが移動します。

5.2 [直線]
・[多角形]ボタンによる描画
①描画ツールバーの[直線]ボタンをクリッ
クします。

②編集画面上でクリックし、そのままドラッ
グします。

37

第5章

描画ツールによるグリフ作成

③以後、同様にすれば連続した直線を描けま
す。

④描画ツールバーの[多角形]ボタンをク
リックします。

⑤画面上をクリックして行けば、直線が追加
されます。

38

第5章

描画ツールによるグリフ作成

⑥最初に描いた制御点をクリックすれば閉
じた輪郭となります。

5.3 [長方形]・[楕円]ボタンによる描画
①描画ツールバーの[長方形]ボタンをク
リックします。

②編集画面上でクリックし、そのままドラッ
グします。

39

第5章

描画ツールによるグリフ作成

③長方形が描画されます。

④描画ツールバーの[楕円]ボタンをクリッ
クします。

⑤編集画面上でクリックし、そのままドラッ
グします。

40

第5章

描画ツールによるグリフ作成

⑥楕円が描画されます。

長方形や楕円を描く時、キーボードの Shift
キーを押しながら行うと、正方形や円になり
ます。

Shift キー押下で描画

5.4 [鉛筆]ボタンによる描画
①描画ツールバーの[鉛筆]ボタンをクリッ
クします。

41

第5章

描画ツールによるグリフ作成

②編集画面上でクリックし、そのままドラッ
グしてグリフの輪郭を描きます。

③マウスのボタンを放せば、マウスの軌跡が
トレースされ、グリフの輪郭に変換されま
す。

④同様にして描画を繰り返してください。

⑤前回最後の制御点上からドラッグ開始す
れば、輪郭が延長されます。

42

第5章

描画ツールによるグリフ作成

⑥前回最後の制御点から離れた位置よりド
ラッグ開始した場合、そこまで直線で結ば
れます。

⑦輪郭を閉じる時は、輪郭開始点までドラッ
グして、そこでマウスのボタンを離してく
ださい。

⑧ダブルクリックすることでも、輪郭を閉じ
ることができます。ダブルクリックした位
置に、オンカーブ点が追加されます。

5.5 [制御点の挿入]ボタンによる制御点の追加
①描画ツールバーの[制御点の挿入]ボタン
をクリックします。なお、編集画面のグリ
フが閉じていないと、ボタンは使えません。

43

第5章

描画ツールによるグリフ作成

②制御点を追加したい位置で、マウスをク
リックします。なお、この位置はグリフの
輪郭線上でなければなりません。

③クリックした位置に、制御点が追加されま
す。

④キーボードの←→↑↓キーを押下して、今
追加した制御点を、希望の位置へ移動して
ください。

44

第5章

描画ツールによるグリフ作成

⑤[選択]ボタンをクリックし、マウスで制御
点をドラッグすることによっても、制御点
を移動することができます。

5.6 [消しゴム]ボタンによる制御点の削除
①描画ツールバーの[消しゴム]ボタンをク
リックします。なお、編集画面のグリフが
閉じていないと、ボタンは使えません。

②マウスカーソルが右図のように変わりま
す。
45

第5章

描画ツールによるグリフ作成

③マウスをクリックしたまま、マウスカーソ
ル先端にある小さな四角部分を、グリフの
制御点に触れてください。

④制御点が削除されます。

5.7 [選択]ボタンによる制御点の選択
①描画ツールバーの[選択]ボタンをクリッ
クします。なお、編集画面のグリフが閉じ
ていないと、ボタンは使えません。

46

第5章

描画ツールによるグリフ作成

②グリフの輪郭線上をダブルクリックしま
す。

③輪郭全体が選択されます。

④マウスカーソルをグリフ内に移動すると、
右図のように十字矢印の付いた形に変わ
ります。
⑤この状態で、ドラッグすれば選択したグリ
フを移動することができます。

47

第5章

描画ツールによるグリフ作成

⑥部分的に制御点を選択するには、選択した
い制御点を囲むようにマウスをドラッグ
してください。

5.8 [なげなわ]ボタンによる制御点の選択
①描画ツールバーの[なげなわ]ボタンをク
リックします。なお、編集画面のグリフが
閉じていないと、ボタンは使えません。

②選択したい制御点をマウスで囲みます。

48

第5章

描画ツールによるグリフ作成

③囲まれた部分の制御点が選択されます。

49

第6章 グリフの修整

第6章 グリフの修整
輪郭の結合
輪郭の切断
制御点の位置揃え
グリフの反転
グリフの中央移動

50

第6章 グリフの修整

6.1 輪郭の結合
2つの輪郭を結合して、1つにする方法を説明します。
①[接着剤]ボタンをクリックします。

②結合したい所でマウスをドラッグします。

③制御点が追加され、輪郭が結ばれます。

51

第6章 グリフの修整

④結合部分は2つの制御点が重なっている
ので、制御点をマウスで移動してください。

6.2 輪郭の切断
1つの輪郭を切断して、2つにする方法を説明します。
①修整ツールバーの[ナイフ]ボタンをク
リックします。

②切断したい所でマウスをドラッグしてく
ださい。

52

第6章 グリフの修整

③制御点が追加され、輪郭が2つに切断され
ます。

④切断部分は2つの制御点が重なっている
ので、制御点をマウスで移動してください。

[ナイフ]ボタンは 1 つの閉じた輪郭を切断して 2 つの閉じた輪郭にする場合に使用し、[接着剤]
ボタンは 2 つの閉じた輪郭を接合して 1 つの閉じた輪郭にする場合に使用します。
そのため下図のように口形をC形にする場合は、[ナイフ]ボタンではなく、[接着剤]ボタンで行い
ます。

53

第6章 グリフの修整

6.3 制御点の位置揃え
複数の制御点の位置を揃える方法を説明
します。
①位置を揃えたい制御点を選択します。

②[横方向点揃え]ボタンをクリックします。

③位置を揃えたい場所でマウスをクリック
します。

54

第6章 グリフの修整

④クリック位置で制御点が揃えられます。

⑤同様に縦方向に制御点を揃えるには、位置
を揃えたい制御点を選択して、[縦方向点
揃え]ボタンをクリックし、位置を揃えた
い場所でマウスをクリックします。

6.4 グリフの反転
グリフを鏡に映したように反転します。
①反転したいグリフを選択します。

55

第6章 グリフの修整

②[横方向鏡面反転]ボタンをクリックしま
す。

③グリフが横方向に反転します。

なお、反転は変形中心
を中心にして行
われます。変形中心はマウスで移動できま
す。

56

第6章 グリフの修整

④同様に、[縦方向鏡面反転]ボタンをクリッ
クすれば、縦方向に反転します。

6.5 グリフの中央移動
グリフを仮想ボディ内の中央に移動します。
①移動したいグリフを選択します。

②[左右中央]ボタンをクリックします。

57

第6章 グリフの修整

③グリフが仮想ボディ内の左右中央に移動
します

④同様に、[上下中央]ボタンをクリックすれ
ば、仮想ボディ内の上下中央に移動します。

58

第7章 いろいろな表示方法

第7章 いろいろな表示方法
ここでは編集画面での表示方法について説明します。

拡大・縮小
塗りつぶしで表示
制御点の表示/非表示

59

第7章 いろいろな表示方法

7.1 拡大・縮小
①表示ツールバーの[拡大]ボタンをクリッ
クします。

②拡大表示したい部分をドラッグして選択
します。

③ドラッグした部分が拡大表示されます。

60

第7章 いろいろな表示方法

④表示ツールバーの[縮小]ボタンをクリッ
クします。

⑤表示倍率が小さくなります。

⑥表示ツールバーの[ウィンドウに合わせ
る]ボタンをクリックします。

61

第7章 いろいろな表示方法

⑦仮想ボディ全体が編集画面内に収まるよ
うに表示されます。

7.2 塗りつぶしで表示
①表示ツールバーの[塗りつぶしで表示/非
表示]ボタンをクリックします。

②グリフが塗りつぶされた状態で表示され
ます。

62

第7章 いろいろな表示方法

③再度、表示ツールバーの[塗りつぶしで表
示/非表示]ボタンをクリックします。
④グリフが塗りつぶしなしで表示されます。

7.3 制御点の表示/非表示
①表示ツールバーの[制御点の表示/非表示]
ボタンをクリックします。

②制御点が非表示になり、グリフのアウトラ
インのみ表示されます。

63

第7章 いろいろな表示方法

③再度、表示ツールバーの[制御点の表示/
非表示]ボタンをクリックします。
④グリフの制御点が表示されます。

64

第8章 編集操作

第8章 編集操作
ここでは、[編集]メニューを中心に説明します。

コピー&ペースト
文字取り込み
巻き方向を修正
オーバーラップ輪郭を削除

65

第8章 編集操作

8.1 コピー&ペースト
編集画面間でのコピー&ペースト
①コピーしたいグリフを選択します。
②[編集]→[コピー]をクリックします。

③グリフを貼り付けたい画面で、[編集]→
[貼り付け]をクリックします。
編集画面にグリフが貼り付けされます。

66

第8章 編集操作

イメージ形式クリップボードデータのコピー&ペースト
グラフィックス描画プログラムを使って作成したファイルからグリフを作成する方法です。
「第9章ビットマップファイルからのグリフ作成」と同様な処理です。
①グラフィックス描画プログラムでグリフ
を描きファイルに保存します。
② フ ァ イルを ダ ブ ルクリ ッ ク してプ レ ビ
ューを起動します。
③プレビューの[編集] →[コピー]でクリッ
プボードにデータをコピーします。

④グリフを貼り付けたい画面で、[編集]→
[貼り付け]をクリックします。

⑤編集画面にグリフが貼り付けされます。

67

第8章 編集操作

8.2 文字取り込み
①[編集]→[文字取り込み]をクリックしま
す。
[文字取り込み]ダイアログが表示されま
す。

②一覧から取り込むフォントを選びます。
③[文字]に、取り込みたい文字を入力します。
④[OK]をクリックします。


⑤編集画面にグリフが取り込まれます。

68

第8章 編集操作

8.3 巻き方向を修正
「1.1OpenType フォント」で説明したように、グリフには描画方向があり、外側の輪郭は反時計回り
に、内側の輪郭は時計回りに描かなければなりません。ここではこの描画方向を自動で修正する方法
を説明します。
①いくつかの重なったグリフがあるとしま
す。

②[編集]→[巻き方向を修正]をクリックし
ます。

69

第8章 編集操作

③描画方向が修正されます。

④実際にどのような順番になっているかは、
[表示]→[制御点番号を表示]をクリック
すれば、描画順番に番号が表示されます。

⑤見づらい場合は、表示ツールバーの[塗り
つぶしで表示/非表示]ボタンをクリック
して、塗りつぶしなしにしてください。

70

第8章 編集操作

8.4 オーバーラップ輪郭を削除
「1.1OpenType フォント」で説明したように、交差部分のあるグリフは OpenTrueType フォントとし
て、好ましくありません。ここではこの交差を取り除く方法を説明します。
①交差しているグリフがあるとします。

②[編集]→[オーバーラップ輪郭を削除]を
クリックします。

71

第8章 編集操作

③交差部分は修正されます。

72

第9章 ビットマップファイルからのグリフ作成

第9章 ビットマップファイルからのグリフ作成
ここではビットマップファイルの画像データからグリフを作成する方法について説明します。

ビットマップファイルの用意
ビットマップファイルのインポート

73

第9章 ビットマップファイルからのグリフ作成

9.1 ビットマップファイルの用意
手書き風のフォントを作成する場合、OTEdit の描画ツールでグリフを作成するより、紙に描いて
スキャナで取り込んでビットマップファイルとして保存し、OTEdit にインポートした方が簡単です。
取り込むビットマップサイズは縦横 50 ドット~1000 ドット程度がよいと思います。あまり小さい
とグリフが崩れ、大きいと制御点が多くなりすぎます。実際に試して、取り込む解像度を調整してく
ださい。

9.2 ビットマップファイルのインポート
①[ファイル]→[インポート]→[ビットマッ
プファイル]をクリックします。

②「9.1ビットマップファイルの用意」で
用意したファイルを選択します。
③[開く]をクリックします。


④ビットマップのトレース画面が表示され
ます。
⑤[輪郭トレース]をクリックします。

74

第9章 ビットマップファイルからのグリフ作成

⑥ビットマップがトレースされ、制御点が表
示されます。
⑦[OK]をクリックします。

⑧グリフが編集画面に取り込まれます。

75

第10章 Illustrator でのグリフ作成

第10章 Illustrator でのグリフ作成
ここでは、Illustrator を使ってグリフを作成する方法について説明します。

SING 外字ファイルの作成
SING 外字ファイルのインポート

76

第10章 Illustrator でのグリフ作成

10.1 SING 外字ファイルの作成
Adobe Creative Suite2 付属の Illustrator CS2 で SING 外字ファイルを作成します。
①Illustrator のメニュー[表示]→[グリフ
レット]をクリックしグリフレットパレッ
トを表示します

②グリフレットパレットのメニュー(右上の
三角形のボタンをクリックして表示され
るメニュー)から[新規グリフレット]を選
択します。

③デフォルトのまま[OK]をクリックします。

77

第10章 Illustrator でのグリフ作成

④文字を作成するための画面が表示される
ので、枠内に文字をデザインします。

⑤グリフレットパレットの[字送り]、[作成
者コード]、[枝番号]、[ユニコード]、[読
み]を設定しまし。なお、OTEdit に取り込
んだ時、[作成者コード]、[枝番号]、[ユ
ニコード]、[読み]は無視されるので適当
に設定してください。

⑥グリフレットパレットのメニューから[グ
リフレットの保存]を選択します。

⑦保存場所を選択して、[保存]をクリックし
ます。

78

第10章 Illustrator でのグリフ作成

10.2 SING 外字ファイルのインポート
①OTEdit のメニュー[ファイル]→[インポー
ト]→[SING 外字ファイル]をクリックしま

②「10.1 SING

外字ファイルの作

成」で作成したファイルを選択し、[開く]
をクリックします。

③グリフが取り込まれます。

79

第11章 文字情報の設定

第11章 文字情報の設定
ここでは、文字幅などの各文字に関する情報の設定について説明します。

文字幅の設定
縦書き位置の設定

80

第11章 文字情報の設定

11.1 文字幅の設定
アルファベットなどの一部の半角文字は
文字幅を設定できます。

①[設定]→[文字情報]をクリックします。

②[横書き]タブが選択されていることを確
認します。
③[文字幅]を設定します。


④文字幅をサイドベアリングの値で設定す
る場合は、[サイドベアリングで設定する]
をチェックします。
⑤レフトサイドベアリングとライトサイド
ベアリングを設定します。


レフトサイドベアリングは仮想ボディ左
端から文字の左端までの距離、ライトサイ
ドベアリングは仮想ボディ右端から文字
の右端までの距離です。

81

第11章 文字情報の設定

文字幅は、編集画面上でマウスを使って変
更することもできます。Shift キーを押しな
がら仮想ボディの右側にある緑色の線をマ
ウスでドラッグすれば文字幅を変更できま
す。

11.2 縦書き位置の設定
OpenType フォントには VORG テーブルと呼ばれる、縦書き時の Y 方向の文字位置を調整するための
データを持たせることができます。
文字列「う g う g」を縦書きした場合、VORG
テーブルがないと「g」の下と「う」の上が
重なってしまいますが、
VORG テーブルを持っ
ていて、データが適切に設定されていると、
これを避けることができます。
ただし、アプリケーションが VORG テーブ
ル を サ ポート し て いる必 要 が ありま す 。
Adobe Illustrator や InDesign は VORG テー
ブルをサポートしています。

VORG なし

VORG あり

VORG テーブルの値を設定できる文字は、CID で 710~720、758、771~772、780~841、1011~1124、
7575~7584、7601~7607、7610~7612、8020~8037、8053、8055、8092~8101、8182、8186~8190、
8192~8194、8225~8226、8295~8307、9779、9872~9883、11846~11870、12089~12096 の文字だけ
です。

82

第11章 文字情報の設定

①[設定]→[文字情報]をクリックします。

②[縦書き]タブを選択します。
③縦書き上端ラインまたは縦書き下端ライ
ンを設定します。
縦書き上端ラインは、ベースラインから上
端までの距離、縦書き下端ラインは、ベー
スラインから下端までの距離です。上端ラ
インから下端ラインまでの値が文字高さ
になります。なお、文字高さは常に 1000
になります。


④サイドベアリングの値で設定する場合は、
[サイドベアリングで設定する]をチェック
します。
⑤トップサイドベアリングとボトムサイド
ベアリングを設定します。
トップサイドベアリングは文字の上側ス
ペース、ボトムサイドベアリングは文字の
下側スペースです。

83

第11章 文字情報の設定

編集画面上でマウスを使って変更するこ
ともできます。Shift キーを押しながら仮想
ボディの上側または下側にある緑色の線を
マウスでドラッグすれば変更できます。

84

第11章 一括コピー

第12章 一括コピー
フォント間で文字をまとめてコピーする機能です。ただし、元々OTEdit では作成することができない
文字はコピーされません。

新規ファイルへの全文字コピー
既存ファイルへの追加コピー
CSV ファイルでのコピー文字指定

85

第11章 一括コピー

12.1 新規ファイルへの全文字コピー
Adobe-Japan1-3 や Adobe-Japan1-4 キャラクタセットに対応した OpenType フォントを新規ファイル
に全文字コピーする方法について説明します。
OTEdit 以外で作成したフォントは OTEdit では修正保存できませんが、ここで説明する方法で全文字
コピーすれば修正保存できるようになります。ただし、フォントのライセンスにはご注意ください。
また、OTEdit のバージョンアップによってフォントテーブルの修正があった場合、旧バージョンの
OTEdit で作成したフォントを全文字コピーする場合などにもご利用いただけます。
①[ファイル]→[一括コピー]をクリックし
ます。

②コピー元ファイルを選択します。
[コピー元ファイル]にある[…]をクリッ
クします。

86

第11章 一括コピー

③コピー元ファイルを選択します。
④[開く]をクリックします。


⑤コピー先ファイルを選択します。
[コピー先ファイル]にある[…]をクリッ
クします。

⑥まだ存在しない新しいファイル名を設定
します。
⑦[保存]をクリックします。


⑧コピー元フォントに応じて[Std フォント]
か[Pro フォント]のどちらかを選択します。
⑨ [コード種別]として[CID]を選択します。
⑩他の設定はデフォルトのまま、[OK]をク
リックします。


87

第11章 一括コピー

⑩進行状況を示すダイアログが表示されま
す。ダイアログが消えれば、コピー終了で
す。

12.2 既存ファイルへの追加コピー
①~④までは、
「12.1新規ファイルへの全
文字コピー」と同じです。
⑤コピー先ファイルを選択します。
[コピー先ファイル]にある[…]をクリッ
クします。

⑥[名前]の右にあるボタンをクリックしダ
イアログを拡張します。

⑦以前に OTEdit で作成したファイルを選択
します。
⑧[保存]をクリックします。

88

第11章 一括コピー

⑨コピーする文字に応じて、コピー元の文字
コードおよびコード種別を設定します。
⑩[OK]をクリックします。


⑪進行状況を示すダイアログが表示されま
す。ダイアログが消えれば、コピー終了で
す。

12.3 CSV ファイルでのコピー文字指定
コピーする文字コードが記入された CSV
ファイルを作成しておき、そのファイルを指
定して一括コピーを行います。
CSVファイルフォーマットは右図のよ
うになります。ファイルの先頭で文字コード
種別を指定します。
文字コード=SJIS
文字コード=JIS
文字コード=Unicode
文字コード=CID
指定しなかった場合は、ダイアログで設定さ
れているコード種別に従います。
その後、
コピー元コード,コピー先コード
を指定します。
コピー元コードとコピー先コードが同じ場
合は、コード1つを指定します。

89

第11章 一括コピー

①「12.1新規ファイルへの全文字コピー」
や「12.2既存ファイルへの追加コピー」
と同様にして、コピー元ファイルとコピー
先ファイルを選択します。
②[CSV ファイルで指定]をチェックします。
③[ファイル]右端にある[...]を選択します。

④コピーする文字コードが記入されている
CSV ファイルを選択します。
⑤[開く]をクリックします。

⑥[OK]をクリックします。


⑦進行状況を示すダイアログが表示されま
す。ダイアログが消えれば、コピー終了で
す。

90

第12章 オンラインヘルプ

第13章 オンラインヘルプ
ここではオンラインヘルプについて説明します。

トラブルシューティング

91

第12章 オンラインヘルプ

13.1 トラブルシューティング
OTEdit を使っていて何か問題が発生した
時は、ヘルプにあるトラブルシューティング
を参照してみてください。

①[ヘルプ]→[OTEdit ヘルプ]をクリックし
ます。

②下までスクロールします。
③「トラブルシューティング」をクリックし
ます。

④ヘルプが表示されますので該当する記述
がないか調べてください。

なお、
http://musashi.or.tv/oteditmacqa.htm
ではヘルプのトラブルシューティングにない情報も公開していますのでご参照ください。

92

第12章 オンラインヘルプ

索引

選択ボタン ................................................... 32, 46

B スプライン曲線 .................................................6

楕円ボタン ................................................... 32, 39

TrueType フォント...............................................6

多角形ボタン ............................................... 32, 37

長方形ボタン ............................................... 32, 39

アウトラインフォント..........................................6

直線ボタン ................................................... 32, 37

アセント ...............................................................8

ディセント ........................................................... 8

一括コピー..........................................................85

ドットフォント.................................................... 6

オーバーラップ輪郭を削除 ................................71

オンカーブ点の挿入ボタン ..........................32, 43

ナイフボタン ..................................................... 52

オンカーブ点ボタン .....................................32, 33

なげなわボタン............................................ 32, 48

仮想ボディ............................................................8

ビットマップファイルのインポート ................. 74

グリフ ...................................................................7

ビットマップフォント ......................................... 6

グリフの中央移動 ...............................................57

フォントのインストール ................................... 20

グリフの反転 ......................................................55

Pro フォント ...................................................... 13

消しゴムボタン.............................................32, 45

ベースライン ....................................................... 8

コーナーポイント .................................................6

コピー&ペースト ...............................................66

巻き方向を修正.................................................. 69

文字高さの設定.................................................. 82

SING ......................................................76, 77, 79

文字取り込み ..................................................... 68

Std フォント.......................................................13

文字幅の設定 ..................................................... 81

スムーズポイント .................................................6

制御点の位置揃え ...............................................54

輪郭の結合 ......................................................... 51

接着剤ボタン ......................................................51

輪郭の切断 ......................................................... 52

93

Sign up to vote on this title
UsefulNot useful