You are on page 1of 29

Customer Training Material

W k h 3 Workshop 3
Geometry Cleanup y p
Introduction to ANSYS Introduction to ANSYS
DesignModeler
WS3-1
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Introduction to ANSYS DesignModeler
Customer Training Material
Introduction
Introduction:
This Workshop demonstrates the import, clean-up and repair of a CAD
aerospace geometry in DesignModeler (DM).
Prerequisites:
This workshop assumes that you have some experience with DesignModeler, and that
you are familiar with the graphical user interface.
Preparation:
WS3-2
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Preparation:
Copy the file airplane.x_t to your working directory.
Introduction to ANSYS DesignModeler
Customer Training Material
Goals
Goals;
Geometry Import.
Surface Body Connection.
Repair Missing Surface.
Solid Body Creation.
Repair Hard Edges.
Remove Sharp Angles.
Merge Entities.
Create Fluid Domain.
Create Symmetry Model.
WS3-3
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Introduction to ANSYS DesignModeler
Customer Training Material
Geometry Import
Create the Workbench Project;
Start a new Workbench R13 project and save the project to your working
directory as WS3.
Copy the file airplane.x_t to the user_files directory.
The user_files directory is created by workbench to allow you to store general files
and documents associated with your project.
ANSYS Workbench will also protect this directory and ensure that it is managed and
archived appropriately with the rest of the project.
WS3-4
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Introduction to ANSYS DesignModeler
Customer Training Material
Geometry Import
Create the Workbench Project (Continued);
Drag a Geometry System into the Project
Schematic.
RMB on the Geometry Cell and select Import
Geometry.
Select airplane.x_t from the user_files
directory. directory.
This will associate the Parasolid CAD file with
the Geometry Cell.
WS3-5
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Introduction to ANSYS DesignModeler
Customer Training Material
Geometry Import
Open DesignModeler;
Click RMB the Geometry Cell and select Edit Geometry.
This will open the DM session.
Set the units to Meter.
WS3-6
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Introduction to ANSYS DesignModeler
Customer Training Material
Geometry Import
Generate Imported Geometry;
An Import feature associated with a Parasolid file is
already present in the Tree Outline.
LMB the feature (Import1) to view the details.
Beneath the Import name and Source file there are
several options.
Base Plane Base Plane
Specifies the model alignment coordinate system.
Operation
Add Material (Active) or Add Frozen.
Process Solid/Surface/Line Bodies
Option to selectively import by entity type.
Simplify Geometry
Simplify model into analytical geometry where possible Simplify model into analytical geometry where possible.
Simplify Topology
Remove redundant geometry from the model where possible.
Clean Bodies
WS3-7
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Heals geometry.
Leave the default details and click Generate.
Introduction to ANSYS DesignModeler
Customer Training Material
Geometry Import
Check Imported Geometry;
When importing CAD geometry it is
useful to first run Fault Detection to
hi hli ht t t highlight any corrupt geometry.
From the Tools menu select Analysis
Tools> Fault Detection.
RMB on the geometry and Select All. g y
Apply the entity selection.
No Model Faults are reported. Press the Esc key to exit the Fault Detection
Tool
WS3-8
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Tool.
When faults are found it is often necessary to rebuild the corrupt geometry
before proceeding.
Introduction to ANSYS DesignModeler
Customer Training Material
Geometry Import
Check Imported Geometry (Continued);
Set Edge Colouring to Connection.
From the menu View > Graphics options
> Ed C l i > B C ti > Edge Coloring > By Connection.
Edges connected to only one face are
highlighted in red.
Free (blue), single (red), double (black),
triple (pink) and multiple (yellow)
An enclosed connected surface would be
comprised of black edges.
A shortcut menu can also be used.
The red edges highlight a hole to the
rear of the fuselage and an
unconnected surface body on the right unconnected surface body on the right
nacelle.
Note that the geometry has imported as
two separate surface bodies as indicated
by the surface body icon The default
WS3-9
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
by the surface body icon . The default
body names are independent of body
type and can be changed.
Introduction to ANSYS DesignModeler
Customer Training Material
Surface Body Connection
Repairing the Nacelle;
Connect the two surface bodies using a Body operation.
From the Create menu, select Body Operation.
Set Type to Sew, select both surface bodies (RMB > Select All).
Click Generate.
The two bodies are sewn together into one surface body.
N t th i l 1 B d d th d d th ll bl k Note there is now only 1 Body and the red edges on the nacelle are now black.
WS3-10
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Select Body operation Select Both Surface Bodies
Generate
Introduction to ANSYS DesignModeler
Customer Training Material
Repair Missing Surface
Repairing the Fuselage;
Use the Surface Patch Tool to repair the hole.
From the Tools menu, select Surface Patch.
Hide edges connected to 2 faces using the shortcut menu.
This will hide all edges except those surrounding the hole.
Select edges; In the graphics window RMB select all.
Click Generate and set edge display back to Show Double Click Generate and set edge display back to Show Double.
WS3-11
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Select Surface Patch Select Edges
Generate
Introduction to ANSYS DesignModeler
Customer Training Material
Solid Body Creation
Create a solid body from the surface body;
From the Create Menu select Body Operation.
Change Type to Sew.
Select the Surface Body.
Set Create Solids to Yes.
Click Generate.
A single solid body is created.
WS3-12
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Introduction to ANSYS DesignModeler
Customer Training Material
Repair Hard Edges
Identify and remove any hard edges;
From the Tools Menu select Repair>Repair
Hard Edges.
In the Details view set Find Faults Now to Yes.
Hard edges will be listed in the details view.
The view will automatically switch to wireframe.
Click on each to locate in the graphics window.
WS3-13
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Introduction to ANSYS DesignModeler
Customer Training Material
Repair Hard Edges
Identify and remove any hard edges (Continued);
By default the repair method for each hard edge identified is set to Edge Delete.
This can be set to Do Not Repair if the edges are required.
Leave both Repair Methods set to Edge Delete, Click Generate and check the first
repair....
WS3-14
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Before Repair After Repair
Introduction to ANSYS DesignModeler
Customer Training Material
Repair Hard Edges
Identify and remove any hard edges (Continued);
....and second repair.
In both cases the small hard edges are deleted.
WS3-15
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Before Repair After Repair
Introduction to ANSYS DesignModeler
Customer Training Material
Remove Sharp Angles
Identify and remove any sharp angles;
From the Tools Menu select Repair>Repair
Sharp Angles.
In the Details view the min and max angle
determines the range within which an angle is
flagged.
Set Find Faults Now to Yes.
Clicking on each Sharp Angle in the Details view
will highlight the entity in the Graphics Window.
WS3-16
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Introduction to ANSYS DesignModeler
Customer Training Material
Remove Sharp Angles
Identify and remove any sharp angles (Continued);
By default the repair method for each sharp angle
identified is set to Face Merge.
S f Select the first sharp angle.
The actual angle is detailed.
The face containing the sharp angle is highlighted.
The Face Merge repair method automatically g p y
selects the face pair to merge.
Clicking on the Merging Entity selection box will
highlight the entity automatically selected to merge
with the sharp angle face with the sharp angle face.
WS3-17
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
This can be changed if necessary. In this case no
changes need to be made.
Introduction to ANSYS DesignModeler
Customer Training Material
Remove Sharp Angles
Identify and remove any sharp angles (Continued);
Click Generate.
The four sharp angles are repaired by face merging (Sharp Angle 1 shown here)
WS3-18
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Before Repair After Repair
Introduction to ANSYS DesignModeler
Customer Training Material
Merge Entities
Simplify the model using face merge;
From the Tools Menu, select Merge.
In the Details View set the Merge Type to Faces
d th S l ti M th d t M l and the Selection Method to Manual.
The minimum angle is used to determine whether
adjacent faces should be merged. If the angle
between faces is less than this value the faces will
not be merged not be merged.
Click the Y Axis to align the model view.
Activate the face selection filter and select the
faces as shown.
Use the Box Select tool. Dragging from right to left
will select all faces partially or fully contained
within the box 16 faces in this case.
WS3-19
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Apply the Selection.
Introduction to ANSYS DesignModeler
Customer Training Material
Merge Entities
Simplify the model using face merge (Continued);
Click Generate.
The selected faces have been merged into one face.
WS3-20
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Before Merge After Merge
Introduction to ANSYS DesignModeler
Customer Training Material
Merge Entities
Simplify the model using face merge
(Continued);
View merged face edges.
f Zoom in to the merged face.
Change the selection filter to Edge
and highlight any of the edges
surrounding the merged face as shown.
Note that whilst the faces have been
merged the original individual edges are
retained.
In the Details View for the Merge
feature set Merge Boundary Edges to
Yes.
Click Generate.
WS3-21
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
The Merge feature will now be
regenerated this time merging the edges
in addition to the faces.
Introduction to ANSYS DesignModeler
Customer Training Material
Merge Entities
Simplify the model using face merge (Continued);
Use the Merge tool again to merge the following faces.
This time use the Box Select tool from left to right to select only faces fully contained
ithi th b 18 f h ld b l t d within the box. 18 faces should be selected.
Set Merge Boundary Edges to Yes click Generate.
WS3-22
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Select Faces After Merge
Introduction to ANSYS DesignModeler
Customer Training Material
Merge Entities
Simplify the model using face merge (Continued);
Use the merge tool again to merge the following faces.
18 faces should be selected. Again, make sure Merge Boundary Edges is set to Yes
d li k G t and click Generate.
WS3-23
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Select Faces After Merge
Introduction to ANSYS DesignModeler
Customer Training Material
Merge Entities
Simplify the model using face merge (Continued);
Attempting to manually merge large numbers of faces
may fail or cause geometry corruption. Faces can be
d i t bl l t t ti ll grouped into merge able clusters automatically.
Select the Merge tool again but this time set the Selection
Method to Automatic.
Under Automated Search set Targets to Search to Selected
Faces. Select the faces as shown (31) and apply the
selection. Set Find Clusters Now to Yes.
A list of clusters will be produced in the Details View (Cluster
colours in the Graphics Window may vary).
WS3-24
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Check the settings above and Click Generate.
Introduction to ANSYS DesignModeler
Customer Training Material
Merge Entities
Simplify the model using face merge (Continued);
Use the merge tool to merge the following 6 faces.
Use the manual selection method.
Since not all the faces selected are connected the merge tool automatically assigns
them separate clusters. Click Generate.
WS3-25
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Select Faces After Merge
Introduction to ANSYS DesignModeler
Customer Training Material
Merge Entities
Simplify the model using face merge (Continued);
Finally, use the merge tool again to merge the last 4 faces.
WS3-26
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
Select Faces After Merge
Introduction to ANSYS DesignModeler
Customer Training Material
Create Fluid Domain
Create an enclosure around the solid body;
From the Tools Menu select Enclosure.
Change Shape to Sphere.
Set Cushion to 1m.
Click Generate.
The enclosure operation has created a
frozen spherical body around the
geometry geometry.
A Boolean subtraction has also been
automatically performed.
Click RMB on the solid representing the
original geometry and select Suppress original geometry and select Suppress.
WS3-27
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
This leaves the fluid domain surrounding
the aeroplane body.
Introduction to ANSYS DesignModeler
Customer Training Material
Create Symmetry Model
Prepare the model for a symmetric analysis;
From the Tools Menu select Symmetry.
Set Symmetry Plane to ZXPlane by selecting
th ZXPl f th T O tli the ZXPlane from the Tree Outline.
Click Generate.
The model will be divided about the ZX Plane.
The side retained is the + side of the Plane
normal.
Finally, use a Body Operation from the
Create menu to Scale the model.
In this workshop the full model has been
repaired in order to demonstrate a range of
repair techniques. It is often advantageous
to use the symmetry tool initially in the
cleanup process to restrict repair
operations to the side requiring least
WS3-28
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010
This completes the geometry preparation.
operations. The mirror tool can be
subsequently used to recreate a full model
if required.
Introduction to ANSYS DesignModeler
Customer Training Material
Finished Model
Final Model
Save the Project from the Workbench Project Page.
WS3-29
ANSYS, Inc. Proprietary
2010 ANSYS, Inc. All rights reserved.
Release 13.0
December 2010