You are on page 1of 14

Contents

1.Learning Conditions………………………………………………………………………………………………………………2
1.1General Information……………………………………………………….………………2
1.2Students Conditions……………………………………………………………………….………………………………2
1.3College Conditions……………………………………………………………………….…………………………………3
1.4Classroom Conditions…………………………………………………………………………………………………….3
2.Didactical Planning ………………………………………………………………………………………………………………4
2.1Curriculum Analysis………………………………………………………………………..………………………………4
2.2Content Analysis………………………………………………………………………….………………………………….4
2.3Didactic Analysis……………………………………………………………………………………………………………..8
Objectives....................................................................................................................................8
3.1General Objectives………………………………………………………………………...8
3.2Specific Learning Objectives……………………………………………………..………8
Lesson Plan ................................................................................................................... 9
Worksheet……………………………………………………………………………………………………………….………………11

1 page

1. Learning Conditions
1.1

General Information:

College: Technical Trainers College, Riyadh
Class: ICT NE - 8.1
Classroom: 1.261
1.2

Students Conditions

Table of Class Characteristics:

NO Name

ID

Age Former School

Home

Last

Last

City

Certificate

Grading

MCT, Madinah
Sultan Alzahrani
1

College of
405

24

Technology

Madinah

Diploma

84

Diploma

78

Jazan

Diploma

88

Abha

Diploma

97

Abha

Diploma

77

Qassem

Diploma

78

ACT, Abha
College of
2

Saleh Raqa 424

26

Abha

Technology
JCT, Jazan
College of

3

Yahya Ahamed 408

25

Technology
ACT, Abha
College of

4

Abdullah Saad 409

26

Technology
ACT, Abha

5

Abdulrahman
Abdullah

College of
412

25

Technology
MCT, Qassem

6

2 page

Thamer Aziz 458

31

College of Tec

hnology
ACT, Arar
College of
7

Rakkad Alanazi 418

25

Technology

Arar

Diploma

93

Abha

Diploma

75

Dammam

Diploma

80

ACT, Abha
College of
8

Saad Saeed 420

26

Technology
DCT, Dammam

Abdulaziz

9

Aldossari

College of
426

23

Technology

Table 1: Class Characteristics
Performance of the Class
The trainees in TTC have a Diploma certificate. This will be first lesson I give it , I
sure of trainees have a lot of knowledge about networking, so that I’m trying to
have high level of knowledge.
1.3

College Conditions

My college is TTC, is located in The Ryan district Breadh Street. I will teach the
class. Also, my lesson will be in next week on Thursday. It will be theoretic
content and practical. I will make my lesson in the main building, because I want
use the computers when I explain my lesson. The time for my lesson will be in
the morning.
1.4

Classroom Conditions

The classroom will be in the main building in lab 64 , because I will use the
computer during my lesson and let the students use it to finish their task.The
classroom has 24 computers with tables and chairs for students .Also, it has one
disk, computer and chair for the teacher. In this classroom it a very good to

3 page

explain the topic for students, because it is clean, there are two whiteboard and
one projector in the class. The class will start at 7:30 a.m.

2. Didactical Planning
2.1

Curriculum Analysis
The study plan for major Technical Support in Eight semester the course

name is LAN Support. This course has code SUP 247. The content hour for this
course six hours, two hours for lecture and four hours for workshop and does not
have any tutorial. This course talks about basic skills in using and operating
Local Network devices including wireless local network. Also, it has prerequisites
with NET 107 . This course aims for providing trainees with skills in operating
switches and panels of the network and controlling the network access . The
specific objectives are Configures Router, Uses switches with LANs , nstalls
Ethernet LANs , Installs VLANs , Installs WLAN access points , WLAN security.
In the course LAN Support in unit Configures Router my lesson is Routers
Commands.
2.2

Content Analysis

In this lesson I’ll talk about “Router Configuration”:I will start my lesson by define
the router and what is the task of I by drawing a small network and explain the
task router. This picture present to 2 different network which connected together
by using routers. Gives some examples and what are the interfaces in the router
and how can I use it.

What are the components of routers. Then, I will describe the router mode and
there are many modes. It is the first step to deal with router configurations. These
mode enable you as a programmer to set the configuration to your router.

4 page

After that I will start with basic router configuration and list the command which I
should use when I configure my router in all situations.
Global Configuration Mode:Router>

- User mode

Router>en

- This command Turn on the router

Router#config t

-This command enable you to configure your

router.
Configuring a Router Name:Router(config)#hostname R1

-This command enable you to change the

name of your router.
Configuring Password:You should configure a password in your router to provide high level of secure.

Router(config)#enable password cisco -This command put a password to run
the router.
Router(config)#enable secret class -Now we put “class” as a word password
Router(config)#line con 0
Router(config-line)#password console

5 page

Router(config-line)#login
Router(config)#line vty 0 4
In the router, they are two type of interfaces ; a serial Interface and Ethernet
Interface.

First: Configuring a Serial Interface:Router(config)#int s0/0/0

-This command enable you to configure Serial

Interface.
Router(config-if)#ip address 192.168.10.1 255.255.255.0 -This command to put
an IP address and a Subnet Mask.
Router(config-if)#no shut

-This command to turn on the port.

Second: Configuring Ethernet Interface
Router(config)#int fa0/0

-This command enable you to configure Ethernet

Interface:Router(config-if)#ip address 192..168..20..1 255..255..255 -This command to put
an IP address and a Subnet Mask.
Router(config-if)#no shut

-This command to turn on the port.

Show Commands:These command help you to check all the configuration that you are made it.
Each one of these command show you something different.
Router#show ?
Router#show interfaces

6 page

Router#show interface serial 0
Saving Configurations
Router#copy run start

-This command to save all configurations that you did

in your project.
Then, we will have Topology Diagram. I will distribute it on all the students and
let them applied it on their computers.

Device

Interface

IP Address

Subnet Mask

Default

R1

Fa0/0
S0/0/0

192.168.1.1
192.168.2.1

255.255.255.0
255.255.255.0

Gateway
N/A
N/A

Fa0/0
192.168.3.1
255.255.255.0
N/A
R2
S0/0/0
192.168.2.2
255.255.255.0
N/A
S0/0/1
192.168.4.2
255.255.255.0
N/A
Fa0/0
192.168.5.1
255.255.255.0
N/A
R3
S0/0/1
192.168.4.1
255.255.255.0
N/A
PC1
NIC
192.168.1.10
255.255.255.0
192.168.1.1
PC2
NIC
192.168.3.10
255.255.255.0
192.168.3.1
PC3
NIC
192.168.5.10
255.255.255.0
192.168.5.1
In this exercise, we have 3 Routers, 3 switch and 3 PCs. First, we will configure
the routers and the PCs by using all the commands that we had. Second, we will
connect the three routers together by using RIP protocols.
Configure RIP:
R1(config)#router rip
R1(config-router)#
7 page

R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#
We will use this command on all the three routers and an IP Addresses put the
connected Network ID on each router.
2.3

Didactic Analysis

I will use in this lesson didactic reduction, because I have just 50 minutes to
explain this topic, so the time not enough to explain all subjects. Just I’ll focus on
main part of this topic for example : I’ll focus in the basic command for router,
build a network by using Packet Trace and configure all the interfaces. I will use
lecture in some parts like, when I gives the students definition for the routers and
explain the commands to give students new information. I will disruptions
exercise that enable the students to applied the commands that we had.

Objectives
3.1

General Objectives:
The Trainees:

1. Improve their English Language (Cognitive)
2. Finish assignment at time (Affective).
3. Switch their mobiles on silent (Cognitive)
4. Ask questions during the lesson (Affective).
5. Organize the classroom at the end of a lesson (Psychomotor).
6. Clean the whiteboard after finishing of lesson (Psychomotor).
3.2

Specific Learning Objectives:
The Trainees:
1. Define the Router (C / Reproduction).
2. Explain commands and names and benefits of the command (C /
Reorganization).

8 page

3. List the configuration modes (Reproduction/Cognitive).
4. identify the function of commands (transfer/ Cognitive).
5. Build a topology diagram by using Packet Trace (Cognitive /
Transfer).
6. Cable a network according to the Topology Diagram(Cognitive /
Transfer).
7. Perform basic configuration tasks on a router(Cognitive / Transfer).
8. Configure RIP routing on all routers(Cognitive / Transfer).
9. Solve the router configurations error.(Solving problem/Cognitive).

Lesson Plan
Overview of the Intended Process
Opening / Entrance / Motivation

Time

Expected Trainer-action Expected Trainee-action Methodology

Media Minutes

--The teacher start the
lesson by defining the
router and draw a small
network which explain
PPP

the task of routers.
-The teacher list the

internal and the eternal the teacher and try to
parts of the routers.
answer.
-The Teacher list the
router modes and
explain the task of
modes.

9 page

Slide

-The Students listen to
Classroom

(1 - 6)

Conversation whiteboard

7

Body (Information / Elaboration)
Expected Traineraction

Time
Methodology

Media

Expected Trainee-action

Minutes

-Teacher explains the - Students listen and
Basic Router

answer the teacher's

Configuration

questions and give

command and define

examples of.

each task for each
command.

- Students apply and
follow the teacher on

PPP
Slide(7-11)
Classroom Whiteboard
Conversation

- Teacher explains the their PCs and they try to
commands by using

13

Handout
(1)

understand .

the Packet Tracer .

-Teacher gives the

-Students work together

students Partner work to finish this task.
by using Packet

Handout 2
Partner Work

20
Slides (12)

Tracer Program
- The teacher list error -the students try to solve

10 page

network to the

this problem by using

students.

Packet Trace Program.

Individual
work

Slide 13

7

Close (Reflection , Exercises , Homework , Methodology
Feedback)
Expected Trainer-action
-Teacher asks about

Media

Expected Trainee-action

Minutes

-Students give Feedback

what have been learned. and Summary to the
teacher about the lesson.
-If the teacher have
more time he will give

Individual
work

Slide
(13-14)

(3)

Worksheet
Handout (1)
Configuration Example: Basic Router Configuration

Step 2: Enter runing EXEC mode.

PPP

Handout

the students other task.

11 page

Time

3

Router>enable
Step 3: Enter configuration mode.
Router#config t
Router(config)#
Step 4: Configure the router name as R1.
Router(config)#hostname R1
Step 6: Configure the EXEC mode password.
R1(config)#enable secret class
R1(config)#
Step 8: Configure the console password on the router.
Use cisco as the password. When you are finished, exit from line configuration
mode.
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#
Step 9: Configure the password for the virtual terminal lines.
Use cisco as the password. When you are finished, exit from line configuration
mode.
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit

Step 10: Configure the FastEthernet0/0 interface.
Configure the FastEthernet0/0 interface with the IP address 192.168.1.1/24.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
Step 11: Configure the Serial0/0/0 interface.
Configure the Serial0/0/0 interface with the IP address 192.168.2.1/24.
Note: The purpose of the clock rate command is explained in Chapter 2: Static
Routes.
R1(config-if)#interface serial 0/0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#

12 page

Step 13: Save the R1 configuration.
R1#copy running-config startup-config
Building configuration...
[OK]

Handout (2 )
Partner work

Device
R1

R2

R3
PC1
PC2
PC3

Interface

IP Address

Subnet Mask

Fa0/0

192.168.1.1

255.255.255.0

Default
Gateway
N/A

S0/0/0
Fa0/0
S0/0/0
S0/0/1
Fa0/0
S0/0/1
NIC
NIC
NIC

192.168.2.1
192.168.3.1
192.168.2.2
192.168.4.2
192.168.5.1
192.168.4.1
192.168.1.10
192.168.3.10
192.168.5.10

255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0

N/A
N/A
N/A
N/A
N/A
N/A
192.168.1.1
192.168.3.1
192.168.5.1

Task:
1.
2.
3.
4.
5.

13 page

Build a network by using Packet Trace
Configure the router hostname.
Configure an EXEC mode password.
Configure a password for console connections.
Configure a password for VTY connections.

6. Configure the interfaces on the R1, R2, and R3 routers with the IP
addresses from the table.
7. Configure Ethernet interfaces of PC1, PC2, and PC3
8. Configure RIP on each router.

Handout (3)
Homework
Configuration Example: Basic Router Configuration

Task:
-

14 page

Put an IP Addresses.
Configure the routers
Use all the basic configuration command that we had.