You are on page 1of 58
Exercise: Editing Note about licences: These exercises require a licence for Aimsun Small, Aimsun Standard, Aimsun

Exercise: Editing

Note about licences:

These exercises require a licence for Aimsun Small, Aimsun Standard, Aimsun Professional for Microscopic Simulation, Aimsun Advanced or Aimsun Expert. Users with an Aimsun Professional for Travel Demand Modelling edition will be able to do all the exercises except those related to control plans and dynamic simulation. Users with an Aimsun Professional for Mesoscopic Simulation edition will simulate with the mesoscopic simulator instead of the microscopic simulator.

Editing exercises. Introduction.

In these exercises, the final goal is the creation of a complete network from zero with all the necessary data to finish with a microscopic simulation of the network (if the license allows it).

We will define,

step

by step,

and

based on

a

background image, all the

graphical elements that compose a network, including sections, nodes, detectors, VMS, solid lines and bus stops.

We will also define a control plan for traffic lights, bus lines and plans, reserved lanes for buses, a traffic state, centroids, O/D matrices, a traffic demand, and a scenario with an experiment which we will use for the final simulation.

Exercise 1. Template.

The first step after executing Aimsun is to create a new model; this can be done using the menu File / New. Select the default template.

Exercise 1. Template. The first step after executing Aimsun is to create a new model; this

This template places default objects within the project, which are shown in the following image:

Exercise 1. Template. The first step after executing Aimsun is to create a new model; this

The user has the opportunity to create new objects and store them in a template for future projects.

Exercise 2. Background.

Now we are going to import the images that will help us to create the exercise’s

model. We have a .DWG (CAD drawing) file and a JPG image to be imported. We’ll use the menu File / Import:

Exercise 2. Background. Now we are going to import the images that will help us to

We start by importing the DWG File Background_Small.dwg (found in the Exercises folder), accepting the default Geo Units as Meters and System Encoding, and then from the main menu select View / Whole World.

Now we should look at the layers which make up the imported background. For this we

Now we should look at the layers which make up the imported background. For this we should make the layers active, by selecting the menu Window / Windows / Layers.

Now we should look at the layers which make up the imported background. For this we

If we look at the layers, we see that the layer ‘Ejes’ is a layer with a lot of clutter

which would be better hidden by deselecting the corresponding checkbox :

.
.

The second operation we can do is to select the layer subarea by double clicking on the layer with the mouse and assigning the colour red. We should modify the drawing style as in the following figure:

Now we should look at the layers which make up the imported background. For this we

Finally, select the VITORIA layer by double clicking on the layer with the mouse and assign the colour blue. We should modify the drawing style as in the following figure:

The background should now look as in the figure below: Next we import the image image.jpg

The background should now look as in the figure below:

The background should now look as in the figure below: Next we import the image image.jpg

Next we import the image image.jpg by selecting File / Import / Image File and selecting image.jpg from the Exercises directory.

After selecting the image image.jpg a dialog where the Units can be selected shows up. Accept the default settings.

The background should now look as in the figure below: Next we import the image image.jpg

Once the image is open, to place it correctly in the model, we use the option called positioner. Double click on the image, and we are presented with the Positioner window.

First of all, select check the option Show Image When Selected in the Basic tab of the Geo Image dialog.

Once the image is open, to place it correctly in the model, we use the option

After that, open the Positioner tab to select corresponding reference points in the model and in the image.

Once the image is open, to place it correctly in the model, we use the option

Once reference points have been selected, click on Scale and Translate to position the image correctly over the background.

Suitable points could be those shown in the figure below:

Once the image is well located, it is useful to lock the layer so that it
Once the image is well located, it is useful to lock the layer so that it

Once the image is well located, it is useful to lock the layer so that it can’t be accidentally edited or moved. To do this we double click on the layer Images and deselect the option Allow Object Editing.

Once the image is well located, it is useful to lock the layer so that it

Exercise 3. Section creation.

Now we can start creating the geometry of the network inside the red area over the image. In the next picture all the sections are shown:

General view:

Exercise 3. Section creation. Now we can start creating the geometry of the network inside the

Zoom 1

Zoom 1 9

Zoom 2

Zoom 2 Note that some sections are already joined. Adding sections Select the ‘Create Section’ button

Note that some sections are already joined.

Adding sections

Zoom 2 Note that some sections are already joined. Adding sections Select the ‘Create Section’ button

Select the ‘Create Section’ button from the Toolbar. Left click in the view where the section will start, then double click where the section should end.

Zoom 2 Note that some sections are already joined. Adding sections Select the ‘Create Section’ button

The section position may be modified by dragging its centre line update points (circled in red) which are visible when the section is selected.

Create new vertex - using straight or curve segments

Sections can be shaped using the New (Straight

Zoom 2 Note that some sections are already joined. Adding sections Select the ‘Create Section’ button
or Curve ) Vertex tool.
or Curve
) Vertex tool.

The first ones define straight segments, and as many vertexes as desired can be added to a section. Between two of these vertexes, up to two new curve vertexes can be added.

To add a new vertex, first select the section, then click on the ‘New Vertex’ tool

(straight or curve), then by holding down the left mouse button on the view, drag a line that intersects the section at the point where the control point is required. This point may then be dragged to apply a shape to the section.

Adding lanes

To add or remove lanes in each section, select the section and right click to

enter the context menu, then from this select ‘Number of Lanes’ / [number]. The

number of lanes of a section can also be chosen while the section is selected, by clicking CTRL + [number of lanes].

Adding lateral lanes

Use lateral update points (circled in green) to create or remove lateral lanes.

Drag the update point away from the section to create the lateral, then drag the

new point down the section to change the lateral lane’s length.

The first ones define straight segments, and as many vertexes as desired can be added to

Joining sections

The first ones define straight segments, and as many vertexes as desired can be added to

Join sections by selecting all sections to be joined with SHIFT-(left click), then

either right click on any section to reveal the context menu and select ‘Join’, or

use [Ctrl+M].

The first ones define straight segments, and as many vertexes as desired can be added to

Exercise 4. Node creation.

In this exercise, we will create the nodes with missing geometry which are marked in the following picture:

Intersection

Roundabout Intersection Roundabout
Roundabout
Intersection
Roundabout
Exercise 4. Node creation. In this exercise, we will create the nodes with missing geometry which
In order to create an intersection we must click on the node creation icon at which

In order to create an intersection we must click on the node creation icon at which point the node editor is displayed. The turnings must be created one by one, by clicking on New in the ‘Main’ tab in the Node editor, and using the mouse to select lanes on the origin section of the turning (the [SHIFT] key allows selection of multiple lanes), followed by lanes on the destination section.

The fastest way to activate the Give Way on the different turnings is to select the node and afterwards select all the turnings which have the restriction and by pressing the right mouse button to access the context menu, we select the option Give Way as shown in the following image:

In order to create an intersection we must click on the node creation icon at which

We could also have set the priority by opening the node’s dialog window and selecting Give Way in the Warning column for the corresponding turnings.

In order to create an intersection we must click on the node creation icon at which

Roundabouts

Roundabouts Figure 1 First Roundabout 14
Roundabouts Figure 1 First Roundabout 14

Figure 1 First Roundabout

Figure 2 Second Roundabout In order to create a roundabout, we should use the Roundabout Tool
Figure 2 Second Roundabout In order to create a roundabout, we should use the Roundabout Tool

Figure 2 Second Roundabout

Figure 2 Second Roundabout In order to create a roundabout, we should use the Roundabout Tool

In order to create a roundabout, we should use the Roundabout Tool as follows: Select all sections entering and exiting the roundabout, then select the Roundabout tool and click at the centre of the image. After that, move the mouse to define the radius of the roundabout. While keeping pressed the mouse, we should change the number of lanes of the roundabout by pressing

CTRL + [number of lanes] (1, 2, 3, sections representing the roundabout.

...

,

7). Release the mouse button to create all

Then we should modify the sections geometry to Automatically, all turnings entering the roundabout have a Give Way Warning Sign. Note that, in the first roundabout, the highlighted section has 5 lanes instead of 4. We should modify the lanes and turnings as it is shown in Figure 1

Exercise 5. Curved turnings and stop lines.

Now in the intersection we will modify the place where vehicles wait to Give Way to other traffic. In the left turning from the south, the vehicles should not stop at the traffic light, but some metres afterwards as shown in the image below:

Exercise 5. Curved turnings and stop lines. Now in the intersection we will modify the place

To create this point, we should create a waiting line in the corresponding turning. To do this we right click on the appropriate turning and select the option Stop Lines / New.

Exercise 5. Curved turnings and stop lines. Now in the intersection we will modify the place

This creates a waiting line as shown in the image (indicated by the orange arrow), which can be moved by dragging with the mouse.

This creates a waiting line as shown in the image (indicated by the orange arrow), which

Exercise 6. Assigning Road Types to sections.

The road types that we will assign to the sections of our model are shown in this picture:

ARTERIAL

Exercise 6. Assigning Road Types to sections. The road types that we will assign to the

ON/OFF RAMP

ROAD

Exercise 6. Assigning Road Types to sections. The road types that we will assign to the
Exercise 6. Assigning Road Types to sections. The road types that we will assign to the

At present, all sections are of type Arterial. You can check this by double- clicking in the Site window on the Arterial road type. Arterial is found under the folder ‘Road and Lane Types’. To assign type On/Off Ramp to the relevant sections, we select them using the left Mouse button (remembering to hold down [SHIFT] to select multiple sections), then press the right Mouse button on one of the selected, then from the context menu change the Road Type to On/Off Ramp.

We must also change the roundabout sections type so we select all the sections belonging to

We must also change the roundabout sections type so we select all the sections belonging to it, press the right mouse button and change the Road Type to Roundabout.

We must also change the roundabout sections type so we select all the sections belonging to

Exercise 7. Layers.

Layers are used to show objects in the network in different groups and altitudes. Each layer has a subgroup of elements in the network, and they all are on the same level. In our network we have sections which are elevated with respect to the others. Therefore if we want the network to be drawn correctly we have to have them in different layers and their view at different height.

Exercise 7. Layers. Layers are used to show objects in the network in different groups and

The first step is to create the two layers from the previous figure (UPPER and LOWER). To create each new layer, reveal the Network layer context menu by right clicking on it in the Layers window and selecting New Layer.

Exercise 7. Layers. Layers are used to show objects in the network in different groups and

Rename the two layers ([F2] while selected or select Rename from their context menu) with the names from that previous figure, then double click on each to access the layer editor and edit their drawing level. As an example we set the drawing level for the lower drawing Level to 9, and the upper drawing Level a higher value of 12 which means it will be drawn over the lower layer.

Exercise 7. Layers. Layers are used to show objects in the network in different groups and

Finally, we must assign each section to its corresponding layer. We select the two sections which will go in the lower layer, and with the right mouse button we open their context menu. Select Arrange / Move To Layer / Network Layers / Lower to send these sections to the lower layer:

Finally, we must assign each section to its corresponding layer. We select the two sections which

Repeat the same operation with the elevated sections to the upper layer, and now we have the sections correctly located in their layers. Now when we carry out the simulation we will not have vehicles appearing to overlap in the 2D view.

Exercise 8. Solid Lines

We’ll define Solid Lines on two sections, as shown in this picture:

Solid Lines
Solid Lines

The way to create solid lines is to press icon line that we want to make solid.

Exercise 8. Solid Lines We’ll define Solid Lines on two sections, as shown in this picture:

and again on the broken white

Exercise 9. Detectors and VMS creation.

In this exercise we are going to create other elements in the network:

Detectors

Exercise 9. Detectors and VMS creation. In this exercise we are going to create other elements

Within the network we need to place 6 detectors as shown in the picture above. To place a detector, press icon and press again on the desired location on the desired section. Then, double-click on the detector to set its name and features, as shown in the next picture.

Exercise 9. Detectors and VMS creation. In this exercise we are going to create other elements
Exercise 9. Detectors and VMS creation. In this exercise we are going to create other elements

VMS

Now we are going to set two Variable Message Signs (VMS) in the main

street of the model. To set a VMS, press on the icon

VMS Now we are going to set two Variable Message Signs (VMS) in the main street

and press

again on the desired location on the desired section. Double-click on the VMS to set its features and name (South Direction and North Direction).

VMS Now we are going to set two Variable Message Signs (VMS) in the main street

Exercise 10. Traffic State.

We will now define a Traffic State to represent the demand. The following pictures provide all
We will now define a Traffic State to represent the demand. The following
pictures provide all the information necessary to create it:
700
1800
400
20
80
80
30
70
20
80
20
90
700
10
30
70
70
600
10
30
90
200
90
10
2100
70 30 70 30 70 30 40 60 95 5
70
30
70
30
70
30
40
60
95
5
50 50 50 50 30 60 70 40
50
50
50
50
30
60
70
40

To put this data in the model, we need to create a Traffic State with the menu Project / New / Demand Data / Traffic State. In the Project window the folder Traffic State’ inside the folder ‘Demand Data’ will appear with a state inside it. We rename the state to ‘State Car: 08:00’ and double-click on it to change its parameters. Within the Input Flow tabbed form:

70 30 70 30 70 30 40 60 95 5 50 50 50 50 30 60

Select the vehicle type as car.

Set the initial time From to 08:00:00 and the Duration to 01:00:00.

Select the Show only Entrances option.

Fill in the column Flow with data from the previous figure.

After that, click on the tab Turning Info and fill in the turning proportions with the data from the previous figure.

In the following pictures we can see how the dialogs should look after all the information has been filled in.

In the following pictures we can see how the dialogs should look after all the information
In the following pictures we can see how the dialogs should look after all the information

Exercise 11. Centroids.

If the traffic demand is given as an OD Matrix, then the first step will be defining the centroids to which the matrix corresponds. In our example, we will define the centroids and their connections as shown in the next picture:

Exercise 11. Centroids. If the traffic demand is given as an OD Matrix , then the
To place a centroid in the network, press the icon and then click on the position

To place a centroid in the network, press the icon and then click on the position in the network where it should be placed. In this exercise, the blue rectangles are the locations where the centroids should be placed. After defining a centroid, double click on it to display the Centroid editor and under the ‘Main’ tab give the Centroid the name in the picture. And finally, we must create the connections from the centroid to the network and vice versa. This is done by pressing New and selecting the entrance or exit section. When all the connections are ready, press Ok.

For all the centroids except for centroid South, no option should be selected. For the centroid South we select the option Use Origin Percentage, assigning 90% to the section on the main street, and 10% to the secondary street (see previous image).

To place a centroid in the network, press the icon and then click on the position

Exercise 12. O/D Matrices.

We will create the OD Matrices starting from a Total Matrix from which we will extract two matrices, one for cars and another for trucks. We will consider that 95% of the trips of the Total Matrix are car trips and the remaining 5% are truck trips.

Car Matrix 95% Total Matrix 5% Truck Matrix
Car
Matrix
95%
Total
Matrix
5%
Truck
Matrix

The Total Matrix is this:

Exercise 12. O/D Matrices. We will create the OD Matrices starting from a Total Matrix from

We can create the matrix from the ‘Centroids Configuration’ folder, in the

Project window. Click the right mouse button on the configuration, then select

the option New

...

/ O/D Matrix. Rename the matrix to ‘Total Matrix’ and by

double-clicking on it we’ll edit the matrix. Fill in all the data as in the previous image: vehicle type, initial time, duration and all the values in the OD Matrix.

The next operation is to create the two matrices from this one. To move from one matrix to two, we may use the operation built into Aimsun. Double click on the matrix ‘Total Matrix’ to open the dialog windo (Cells Tab), then select the operation split. Then press the button New twice two create two divisions where we should mark the percentages by which we want to divide the original matrix. Edit the percentages as shown to 95% y 5% then select Execute.

Two new matrices appear in the Project window. Open each one to change the type of

Two new matrices appear in the Project window. Open each one to change the type of vehicle, and change the name of each to ‘Car Matrix’ y ‘Truck Matrix’, as

shown in the following image:

Two new matrices appear in the Project window. Open each one to change the type of

Exercise 13. Traffic Demand.

Now that we have prepared the OD Matrices and the Traffic State, we can create two Traffic Demands. Create each one by selecting menu Project / New / Demand Data / Traffic Demand, which will cause a new Traffic Demand to appear in the Project window.

Exercise 13. Traffic Demand. Now that we have prepared the OD Matrices and the Traffic State,

1) With OD Matrices

Rename the first Traffic Demand to ‘Traffic Demand Matrix’, double-click on it and follow these steps:

   Fix the Type: Matrices. Press Add Demand Item and insert the cars and
Fix the Type: Matrices.
Press Add Demand Item and insert the cars and the trucks
matrices we prepared in the previous exercise.
Press Ok to end.

2) With Traffic States

Rename the other Traffic Demand to ‘Traffic Demand State’, double-click on it and follow these steps:

Fix the Type: States.

Press Set Time and fill in the Initial Time 8:00:00 and Duration

1:00:00.

Press Add Demand Item and insert the traffic state we prepared in exercise 12.

Exercise 14. Simulation Preview with Traffic Demand 1 .

To test the geometry created up until now, we may run some initial simulation, even though we have still to specify any control plans or public transport.

To do this we need to create a scenario and an experiment.

First we need to create a Scenario. We create it with menu Project / New / Scenarios / Dynamic Scenario, and it will appear in the Project window inside the ‘Scenariosfolder. Now we should create an experiment associated with this scenario, and to do this we place the mouse over the scenario in the Project window, press the right mouse button to access the scenario context menu, select New Experiment. Select the experiment type to Microscopic Simulator and Stochastic Route Choice. Now we may open the scenario editor and select the demand which should be used for the scenario. Double click on the scenario to open the scenario dialog window, and under the Main tab, we can choose between the two demand items we have already created.

Exercise 14. Simulation Preview with Traffic Demand . To test the geometry created up until now,
Exercise 14. Simulation Preview with Traffic Demand . To test the geometry created up until now,

1 Available for all editions except Aimsun Professional for Travel Demand edition. Users with an Aimsun Professional for Mesoscopic edition should change the microscopic simulator with the mesoscopic simulator.

We won’t review the Experiments feature s in this exercise. If we want to simulate the

We won’t review the Experiments features in this exercise. If we want to simulate the scenario, we must create a Replication. Just click the right mouse button on Experiment and go to New / Replication as shown in the picture:

We won’t review the Experiments feature s in this exercise. If we want to simulate the

When presented with Creating replication editor dialog, deselect Create Average, and click OK. Now, click the right mouse button on the Replication and choose Animated Simulation (Autorun).

We won’t review the Experiments feature s in this exercise. If we want to simulate the

The simulation dialog (see next picture) will appear in the task box, and we’ll be

able to perform the simulation of our exercise by pressing play ( ).
able to perform the simulation of our exercise by pressing play (
).

Exercise 15. Signal group creation 2 .

The first intersection is controlled by a traffic light. Information about phases is usually given as shown in next picture and table:

1 5 4 3 2
1
5
4
3
2
Exercise 15. Signal group creation . The first intersection is controlled by a traffic light. Information

The first step before entering the signal timings is to create the signal groups. To do this we follow the groups as shown in the image above.

2 Available for all editions except Aimsun Professional for Travel Demand Modelling edition.

We must create its signal groups following these steps:

SG 1

SG 2

SG 3

SG 4

SG 5

SG 1 SG 2 SG 3 SG 4 SG 5
SG 1 SG 2 SG 3 SG 4 SG 5
SG 1 SG 2 SG 3 SG 4 SG 5
SG 1 SG 2 SG 3 SG 4 SG 5
SG 1 SG 2 SG 3 SG 4 SG 5

Double-click on the intersection and select the Signal Groups label.

We must create its signal groups following these steps: SG 1 SG 2 SG 3 SG

Click on New and a signal group identifier will appear in the list. Then we must select the set of turnings belonging to that Signal Group. When all the Signal Groups are already defined, press OK.

The

adjacent dialog window looks like

the

window one should get after

assigning all the turnings in the intersection to the four corresponding Signal

Groups.

Exercise 16. Phases creation 3 .

Once we have defined the signal groups, we should create the control plan and apply the signal timings as shown in the following table:

Exercise 16. Phases creation . Once we have defined the signal groups, we should create the

The first thing we need to start defining the phases is a Control Plan. Control Plans are created in menu Project / New / Control / Control Plan. In the Project window a new Control Plan folder will appear and the new created Control Plan will be inside it.

Exercise 16. Phases creation . Once we have defined the signal groups, we should create the

We can rename the Control Plan, pressing the right mouse button on it. Another way to do this is to press F2 when the Control Plan is selected. Let’s name it ‘Control AM’. Now we return to the signalised intersection, and specify the signal phases according to the information above:

Exercise 16. Phases creation . Once we have defined the signal groups, we should create the

Set the Control Type to Fixed

Set the Yellow Time to 3’’.

Switch to ‘Signals group mode’

The five groups defined in the previous exercise must be filled with two parameters:

Start Time

3 Available for all editions except Aimsun Professional for Travel Demand Modelling edition.

Duration

Use values from the figure below:

Signal

Start Time

Duration

Group

 
  • 1 0

52

  • 2 0

 

52

  • 3 0

 

52

 
  • 4 58

26

 
  • 5 58

26

Blank spaces between phases are considered interphase. In this case, they are considered 6’’ long. Yellow time is taken as the first 3 seconds of the interphase.

 Duration  Use values from the figure below: Signal Start Time Duration Group 1 0

Then we switch to Phases Mode. There, the different phases are shown as in the next figure:

This mode also permits traffic control edition. It is also the way of editing actuated or

This mode also permits traffic control edition. It is also the way of editing actuated or external types of control.

And we can finally check all different movements corresponding to each phase:

Phase 1

This mode also permits traffic control edition. It is also the way of editing actuated or

Phase 3

This mode also permits traffic control edition. It is also the way of editing actuated or

Exercise 17. Master Control Plan creation 4 .

A Master Control Plan is a set of Control Plans. Go to menu Project / New / Control / Master Control Plan to create a Master Control Plan that appears in the Site window. Right click on it and rename it to ‘Master Control Plan AM. Double-click on it to define its features.

Exercise 17. Master Control Plan creation . A Master Control Plan is a set of Control

Press the button Set Time and set it to 8:00:00 with duration of 1:00:00, as we had in our only Control Plan. Now, to link them, press Add Control Item and load the Control Plan.

The editor should look like this:

Exercise 17. Master Control Plan creation . A Master Control Plan is a set of Control

4 Available for all editions except Aimsun Professional for Travel Demand Modelling edition.

Exercise 18. Simulation Preview with Control Plan 5 .

At this point it would be interesting to place the Master Control Plan into the scenario and execute a simulation with signal control to observe the signals introduced. To do this simply double click on the scenario and select the created master control plan from the Master Control Plan drop-down.

Exercise 18. Simulation Preview with Control Plan . At this point it would be interesting to

Now we can simulate the replication created in the previous exercises.

5 Available for all editions except Aimsun Professional for Travel Demand Modelling edition.

Exercise 19. Reserved Lanes.

Next we are going to define a Reserved Lane for the compulsory use of the

Public Transport (Bus). The picture to Reserved Lane.

the right shows

the

location of the

We will use the template defined ‘Reserved (Compulsory) for Public’, found in the Lane Types folder in the Project window (Infrastructure), with the icon .

Exercise 19. Reserved Lanes. Next we are going to define a Reserved Lane for the compulsory
Exercise 19. Reserved Lanes. Next we are going to define a Reserved Lane for the compulsory

Reserved Lanes

Should this not be available we can create a new Lane Type in menu Project / New / Infrastructure / Lane Type. By double-clicking on this new Lane Type (in the ‘Road and Lane Types’ folder) we can manipulate the features of the lane. We relate the Lane Type to the Vehicle Class ‘Public’ and set this Lane Type to be reserved for this class:

Should this not be available we can create a new Lane Type in menu Project /

Now we should relate the Lane Type to the desired lane from the section in our exercise. To do that, select the section and press the right mouse button on the lane and select, in the option Lane Type, the reserved lane type.

Should this not be available we can create a new Lane Type in menu Project /

Exercise 20. Bus Stops.

We will add three Bus Stops to the network as shown in the next figure: Stop
We will add three Bus Stops to the network as shown in the next figure:
Stop 1
Stop 2
Stop 3

In order to add a Bus Stop we must click on the icon

Exercise 20. Bus Stops. We will add three Bus Stops to the network as shown in

and then click on

the lane of the section where we want to locate it. Once it’s defined, we can change its length, and if we double-click on it we can set the name and the type.

Stop 1: Length 15m and type Normal. Stop 2: Length 15m and type Normal. Stop 3: Length 20m and type Bay.

Exercise 20. Bus Stops. We will add three Bus Stops to the network as shown in

Exercise 21. Public Transport Line.

We will define three Transport Plan Lines for buses; in the following pictures. The names and the routes for the three lines are specified:

L1

Exercise 21. Public Transport Line. We will define three Transport Plan Lines for buses; in the

L2

Exercise 21. Public Transport Line. We will define three Transport Plan Lines for buses; in the

All the necessary information about the stops in the routes and time tables is listed in the table below:

 

Name

Bus Stops ( Exercise

Departure Interval Time

Stop Time

10)

(mean)

(mean)

L1

Stop 1

 
  • 6 min (dev 1min)

  • 18 sec

L2

Stop 2, Stop 3

 
  • 5 min (dev 1min)

  • 18 sec 20 sec

To create

a

Line,

go

to

menu

Project / New

/ Public Transport / Public

Transport Line, and a new Line will appear in the folder ‘Public Transport /

Public Transport Lines’ in the Project window, with the icon

Exercise 21. Public Transport Line. We will define three Transport Plan Lines for buses; in the

. We rename the

Line (mouse right click and select rename) and by double-clicking on it we open the Public Transport Line editor to change the features.

In the tabbed form Main: Select consecutively the sections of the bus line route (by clicking the left mouse button on the sections in the view), and in the sections where a bus stop of the line is located, we must choose it. The next figure corresponds to Route definition for line L1:

In the tabbed form Main: Select consecutively the sections of the bus line route (by clicking

In the tabbed form Timetables:

Click on the New button to create a new timetable, then change the name to: Work Day.

Click on the New button in the Schedules area, and set the Initial Time to 8:00:00, the Duration to 15:59:00, and the Departure Times to Interval(Punctual).

In the Departure area, select bus as the vehicle type and set the corresponding time from the previous table in the field Mean.

In the Dwell Times area, fix the mean times for each of the stops with the data from the data from the table above by entering values

directly into the form’s table

We must repeat this process for the two lines.

When all the Public Transport Lines are ready, the Public Transport Plan must be generated. We

When all the Public Transport Lines are ready, the Public Transport Plan must

be generated. We create a new plan in menu Project / New / Public Transport

/ Public Transport

Plan; it will appear in the folder ‘Public Transport / Public

When all the Public Transport Lines are ready, the Public Transport Plan must be generated. We

Transport Plans’ in the Project window with the icon . We rename the plan to Plan AM’ and double-click on it and double click on it to enter the Public Transport Plan editor.

Now we assign Lines and corresponding Timetables to the Plan. We can do this either by double clicking on the Timetable of each Line, or by selecting the Timetable and pressing the icon . The next image shows how the editor should look after assigning the three lines to the Plan.

When all the Public Transport Lines are ready, the Public Transport Plan must be generated. We
When all the Public Transport Lines are ready, the Public Transport Plan must be generated. We

Exercise 22. Simulation Preview with Public Transport 6 .

Now we should inform the scenario that we wish to use the created public transport plan, and execute a simulation using it. To do this, double click on the scenario, and select the created public transport plan from the Public Transport Plan drop down menu.

Exercise 22. Simulation Preview with Public Transport . Now we should inform the scenario that we

Now we can simulate the replication created in the previous exercises.

6 Available for all editions except Aimsun Professional for Travel Demand Modelling edition.

Exercise 23. Pre-emption 7 .

In every controlled intersection we can give priority to any kind of vehicles we choose. We will now see an example where we give priority to the buses of the line 2. This Pre-emption requires that we are able to detect the priority request, and detect when to end it, so we will define two more detectors, placed as shown in the figure below:

A B
A
B

These detectors must be able to recognise equipped vehicles using this line. So buses from line 2 must be equipped and the detectors must have the Equipped Vehicle measuring capability (double click on each detector and select Equipped Vehicle under Measuring Capability).

Exercise 23. Pre-emption . In every controlled intersection we can give priority to any kind of

7 Available for all editions except Aimsun Professional for Travel Demand Modelling edition.

The percentage of equipped buses is set in its Vehicle Type editor (in the Project / Demand Data window under Vehicle Types and Classes double click on bus).

The percentage of equipped buses is set in its Vehicle Type editor (in the Project /

Now we are prepared to set all the data in the Pre-emption folder in the Control of the Node Editor. Add a Pre-emption set with the Add button. For this pre- emption set, we must add the line 2, the phase that gives right of way to the buses of this line, phase number 3 and the detector that emits the request for priority (detector A in the picture) and the one ending the request (detector B).

In the parameters section, we will set the Minimum Dwell time to 15 seconds and the Maximum to 20. And finally, between the two types of pre-emption let’s choose the alternative, which will give green to the dwell phase as soon as the minimum green time of the current green phases are over and the interphase is finished.

Now we can run a simulation to observe how the pre-emption works. Open the Simulation Control

Now we can run a simulation to observe how the pre-emption works. Open the Simulation Control folder in the Node Editor during the simulation for information about the active signals and phases.

Now we can run a simulation to observe how the pre-emption works. Open the Simulation Control

Exercise 24. Actuated Control 8

Let’s edit the traffic control at the intersection controlled by traffic lights. We will

change the fixed control and define an actuated control with dual-ring instead. We consider straight turning movements ‘as one’ with their corresponding right turning movement, as when the straight movement is allowed, the turn to the right will not interfere with other turnings.

For straight and to the left turnings, if we want to implement a full dual-ring actuated control, we need to detect individually each call for a turning movement on the junction, therefore we need an individual detector and traffic light for each turning movement. We also require that lanes should not be shared by two or more turning movements.

In our case, the signal groups defined for the fixed control already fulfil these conditions:

SG 1

SG 2

SG 3

SG 4

SG 5

SG 1 SG 2 SG 3 SG 4 SG 5
SG 1 SG 2 SG 3 SG 4 SG 5
SG 1 SG 2 SG 3 SG 4 SG 5
SG 1 SG 2 SG 3 SG 4 SG 5
SG 1 SG 2 SG 3 SG 4 SG 5

Then, we must also add enough detectors to detect calls for any of the movements, so we will add five detectors (covering one or two lanes depending on the movement) as shown in next figure:

1 5 4 3 2 8 Available for all editions except Aimsun Professional for Travel Demand
1
5
4
3
2
8 Available for all editions except
Aimsun Professional for
Travel Demand Modelling edition.

55

As a minimum requirement, detectors must capable of detecting vehicle Presence, although some other examples of actuated control require Count capability. Check that all the detectors we have just defined have the Presence capability enabled.

As a minimum requirement, detectors must capable of detecting vehicle Presence , although some other examples

We create a new control named Actuated Control. In the node we define it as actuated.

As a minimum requirement, detectors must capable of detecting vehicle Presence , although some other examples

We will define a dual-ring with two barriers. Add a ring by pressing the Add Ring button, and create a second barrier by dragging the right line defining the end of Barrier 1 towards the left.

As a minimum requirement, detectors must capable of detecting vehicle Presence , although some other examples

The Yellow Time can be set to 3 seconds, and we deactivate the Single Entry option so that, when a barrier is crossed, a phase in every ring must receive green (marked as Default phase).

As a minimum requirement, detectors must capable of detecting vehicle Presence , although some other examples

Now let’s define the phases: the first barrier will contain the movements coming

from the North and the South, and the other barrier will contain the movements coming from the West.

On the other hand, in the first barrier, the movement up is compatible with the movement up-left and the movement down, so this last two will be together in one ring, and the first in the other.

Next picture shows how this control could be defined (signals for each phase are defined in the Basics tab):

Signal 2 Signal 4 Signal 3 Signal 1 Signal 5,6 The next step is to fill
Signal 2
Signal 4
Signal 3
Signal 1
Signal 5,6
The next step is to fill in the parameters in the Actuated folder.

For Phase 1, we will set the recall to Min so that it gets a green for each cycle:

Next picture shows how this control could be defined (signals for each phase are defined in

In phases 3 and 9 we will implement a Gap Reduction:

Next picture shows how this control could be defined (signals for each phase are defined in

Phase 5:

Phase 5: And finally Phase 7 that we will mark with the Hold feature, so that

And finally Phase 7 that we will mark with the Hold feature, so that it stays green even in the absence of calls, until we cross the barrier.

Phase 5: And finally Phase 7 that we will mark with the Hold feature, so that

The last step is the definition of the detectors that will emit the call for a green phase when they detect the presence of vehicles. Choose the detector by pressing the Add button and then selecting the detector in the view.

Phase 5: And finally Phase 7 that we will mark with the Hold feature, so that

Following the numeration of detectors in next picture and the numeration of phases in the diagram of the Node Editor, the associations will be:

Phase

Detector

  • 1 2

  • 3 4

  • 5 3

  • 7 1

  • 9 5

Now we can run a simulation to observe how the actuated control works. Open the Simulation Control folder in the Node Editor during the simulation for information about the signals and phases.