You are on page 1of 12

P.U.C. Semestrul I, an univ.

2012 – 2013

Şef lucr.dr.ing. Morariu-Gligor Radu Mircea

Laborator nr. 8 + 9. MathCAD® - Prezentare generală

Check Spelling… - utilizarea modulului care controlează sintaxa şi gramatica
documentului.

Meniul View:

New – deschiderea unui document MathCAD nou.
Open – deschiderea unui document MathCAD existent;
Close – închiderea documentului curent;
Save – salvarea documentului curent;
Save as – salvarea cu un alt nume a documentului curent;
Save as Web page – salvarea documentului ca o pagină Web;
Page setup – stabilirea dimensiunilor hârtiei la imprimantă;
Print preview – vizualizarea documentului înainte de a fi imprimat;
Print – imprimarea documentului curent.
Observaţie: Extensia documentelor MathCAD este .mcd

Toolbars – bara de instrumente, conţinând tipurile:
Standard – include butoanele corespunzând celor mai utilizate comenzi ale
sub-meniurilor File, Edit. Ea se plasează sub bara principală de meniuri;
Formating – are butoane pentru stabilirea tipurilor şi dimensiunilor
caracterelor, poziţia şi indentarea textului;
Math – conţine butoane corespunzând barelor cu instrumente pentru: calcule
aritmetice (Calculator), evaluări de expresii aritmetice (Evaluation) şi logice
(Boolean), reprezentări grafice de funcţii (Graph), definirea vectorilor sau matricelor şi
calcul matriceal (Matrix), calcul de sume, integrale, derivate, limite (Calculus),
comenzi pentru scrierea programelor MathCAD (Programming), caractere ale
alfabetului grecesc (Greek), calcul simbolic (Symbolic);
Status bar – bara de stare a documentului curent. Ea se plasează la baza
ecranului;
Header and Footer - permite setarea antetului sau a subsolului unui
document;
Regions – pentru identificarea zonelor documentului (de text şi conţinând
expresii matematice, programe etc);
Zoom – pentru stabilirea dimensiunii caracterelor în vederea afişării pe ecran;
Refresh – pentru refacerea imaginii afişate pe ecran.

Meniul Edit:

Meniul Insert:

Figura 9.1.
Meniul principal al aplicaţiei (figura 9.1) conţine următoarele meniuri:

Meniul File:

Undo – anularea ultimei acţiuni de editare;
Redo – are efect invers comenzii Undo;
Cut – decuparea zonei selectate din document;
Copy – copierea zonei selectate;
Paste – plasarea zonei copiate sau mutate în poziţia curentă a cursorului;
Paste Special – plasarea de obiecte sau imagini, din memoria tampon (Clipboard) în
poziţia curentă a cursorului;
Delete – şterge zona selectată;
Select All – selectează documentul întreg;
Find – găsirea unui cuvânt în document.
Replace – găsirea unui cuvânt şi înlocuirea acestuia cu un altul;
Go to page – plasarea cursorului la începutul paginii indicate;

Graph – permite repezentarea grafică a funcţiilor în două sau trei dimensiuni sub
diferite forme;
Matrix – permite stabilirea dimensiunilor unui tablou (vector sau matrice);
Function – permite inserarea funcţiilor care se găsesc în biblioteca aplicaţiei;
Unit – permite utilizarea unităţilor de măsură în care sunt exprimate datele;
Picture – pemite inserarea unei imagini în documentul MathCAD;
Area – se utilizează pentru separarea documentului în zone distincte;
Math/Text Region – se utilizează pentru delimitarea zonelor documentului în care
sunt formule matematice (sau programe) de zonele de text (comentarii).

1

Tipuri de date MathCAD a) Variabile numerice reale sau complexe.se introduce expresia care defineşte variabila. pentru aranjarea ferestrelor în cascadă şi are o listă a documentelor deschise în sesiunea curentă. b) Operatorul de afişare = Format: variabila = expresie = functie(lista de variabile) = Mod de operare: se afişează valoarea membrului stâng. b) Variabile şir: Format: var_şir := val_iniţială. Paragraph – indentarea textului.C. Meniul Math Calculate – determină execuţia calculelor pentru zona unde se găseşte cursorul. În MathCAD se face distincţie între literele majuscule şi cele minuscule în zonele de calcul. Variable – are la rândul său o listă de opţiuni care devin accesibile dacă se plasează cursorul pe o variabilă.setarea poziţiei tabulatorului. simbolul pentru numărul complex. Meniul Help : permite utilizarea sistemului de informaţii ajutătoare. Options – permite stabilirea valorii iniţiale pentru o serie de parametri. capitole. Matrix – pentru determinarea matricei transpuse (Transpose). 2012 – 2013 Şef lucr. sub-capitole etc .5 ↔ x = {0. 0. 0. Separate Regions – delimitarea (fără linii) a regiunilor documentului .. Transform – pentru determinarea transformatei directe şi a transformatei inverse de tip Fourier. Automatic Calculation – execută automat calculele de fiecare dată când o formulă este scrisă. . val_următoare . val_finală Exemplu: x := 0. Factor – scrierea expresiilor ca un produs de factori ireductibili Polinomial Coefficients – pentru determinarea vectorului coeficienţilor unui polinom . Meniul Windows : are comenzi pentru divizarea ferestrei în două părţi. pentru aflarea rădăcinii (Solve) unei ecuaţii. 0.. Laplace. 0.5} 2 . pentru dezvoltarea în serie Taylor (Expand to Series). Repaginate Now – numerotarea paginilor documentului.4. pentru calcularea derivatei (Differentiate).se tastează numele variabilei.2. Semestrul I. 0.U. Calculate Worksheet – execută calculele cuprinse în documentul curent. Pentru a defini o variabilă: . determinantul unei matrice (Determinant) . Color – stabilirea culorii fondului documentului .dr.3. 0.ing. Tabs . Text – permite stabilirea tipului şi dimensiunilor caracterelor unui text. 2. etc). Morariu-Gligor Radu Mircea Meniul Format: Equation – stabilirea tipurilor de caractere utilizate în scrierea ecuaţiilor.1. a matricei inverse (Inverse). Style – editarea documentului împărţit în secţiuni.1 . Result – precizarea formei rezultatelor (numărul de cifre zecimale. a primitivei (Integrate). 0. Z. Meniul Symbolics: Simplify – simplificarea expresiilor matematice. fie orizontale. Observaţii: 1.se tastează operatorul de definire (:=). . Headers/Footers – inserarea antetului şi subsolului în document . Într-un document MathCAD calculele se fac de la stânga spre dreapta de sus în jos! Operatori MathCAD a) Operatorul de atribuire / definire := Format: variabila := expresie functie(lista de variabile) := expresie Mod de operare: valoarea expresiei este atribuită membrului stâng. fie verticale. an univ.P.

var2.01 Utilizat pentru calculul procentelor. … care satisfac blocul restricţiilor definit de Given returnează valorile variabilelor var1. ceil(x) length(v) max(v). var2. 9. Arccosinus z. MathCAD afişează un vector sau o matrice având dimensiunile specificate.. ln z.U. cos(z). … care minimizează eroarea restricţiilor din blocul definit de Given returnează z1 dacă condiţia este adevărată.z (x) x! xy ‘x x! x^y \x Tabelul nr. 9.var) find(var1. var2. . valoarea următoare.. ln(z). z2) until(x1. . ordonează crescător elementele vectorului v. Tangentă z.71828 % Procent 0. .dr. an univ.valoare finală Paranteză Factorial ridicare la putere radical |x / valoare absolută. altfel se returnează z2 returnează x2 cît timp x1 > 0. acos(z).3: Funcţii MathCAD Apelarea funcţiei: sin(z). z1. …) minerr(var1. Arctangentă z ez . [x]. modul. Daca x1 < 0 atunci calculul se opreşte. Tabelul nr. cel mai mic element al vectorului v numărul liniilor matricei M. 3 . [x]+1 numărul elementelor vectorului v cel mai mare element al vectorului v. j) x Ctrl + ^ i M Ctrl + ! Ctrl + $ v v Ctrl + * w Tabelul nr. min(v) rows(M). Exemplu: 100*30*% = 30 TOL Toleranţa 0.2: Simboluri MathCAD Semnificaţie / Operator atribuire / definire domeniu de variaţie: valoarea iniţială. determinant împărţire x |x| x y Şef lucr.1: Constante şi parametri MathCAD Simbol: Denumire: Valoare: Explicaţie: π 3.y. 2012 – 2013 c) Variabile tablou: vectori şi matrice Pentru a crea un tablou se parcurg următorii paşi: . Semestrul I. var2.ing.z Se tastează: : x. numărul coloanelor matricei M returnează valoarea variabilei var care anulează expresia expr returnează valorile variabilelor var1.se tastează Ctrl + M. 9..14159 e 2.001 Test de precizie utilizat în implementarea metodelor numerice ORIGIN Originea 0 Indicele primului element într-o variabilă de tip tablou Pentru: := x.x2) & integrală d f ( x) dx ? derivată x≥y x Ctrl + ) y mai mare sau egal f ( x)dx mai mic sau egal diferit egal utilizat în definirea restricţiilor în cadrul procedurilor find şi minerr indice indici dubli indice superior transpusa suma vectorială produs vectorial sort(v) Semnificaţia: Sinus z.j x<i> MT ∑v vxw x[i x [ (i . Morariu-Gligor Radu Mircea x≤y x≠y = x Ctrl + ( x#y Ctrl + = xi xi.se completează poziţiile marcate. Arcsinus z. tan(z). floor(x). asin(z). cols(M) root(expr. Cosinus z.y.se stabilesc dimensiunile tabloului.P.C.) if(cond. trecerea de la o poziţie la alta realizânduse acţionând tasta Tab. atan(z) exp(z).

se selectează comanda dorită din meniul Symbolic şi se lansează în execuţie prin clic sau Enter. 4 .P.meniul View → Toolbars → se activează bara cu instrumente Symbolic. Substituie variabila Dezvoltare în serie Dezv. utilizând una dintre metodele: . Pentru acţionarea comenzilor meniului Symbolic se procedează astfel: se tastează expresia / ecuaţia asupra căreia va acţiona comanda. Determinarea elementului maxim dintr-o matrice: c max(C) c 109 4. trebuie să se deschidă bara cu unelte Symbolic. . z inversă 7 Elemente de calcul simbolic în MathCAD Figura 9. an univ.2).ing.dr.4. Exemple: 1. Produsul a două matrice: 4 5 1 2 3 A B 6 7 4 5 6 C A B 1 9 19 46 C 52 109 3.2 Buton → simplify expand factor collect coeffs solve substitute expand parfrac Pentru utilizarea instrumentelor de calcul simbolic în MathCAD. Calculul valorii unei funcţii într-un punct f ( x) 3 x 3 x f 2 1 3. Laplace inversă Transformarea z Transf. 2012 – 2013 Şef lucr. Operaţiile meniului Symbolic sunt prezentate în tabelul alăturat.U. Morariu-Gligor Radu Mircea Tabelul 9. se acţionează asupra butonului Symbolic Keyword Toolbar. Fourier inversă Transformata Laplace Transf. Pe ecran se deschide bara cu unelte Symbolic (figura 9. Semestrul I.bara cu unelte Math. în fracţii simple MT → M-1 → |M| → Transpose Matrix Invert Matrix Determinant of Matrix Matricea transpusă Matricea inversă Determinantul matricei fourier invfourier laplace invlaplace ztrans invztrans Fourier Transform Inverse Fourier Transform Laplace Transform Inverse Laplace Transform z Transform Inverse z Transform Transformata Fourier Transf. Suma elementelor unui şir v ( 1 2 0 3 5) sum v sum Numele comenzii: Evaluate Simplify Expand Expression Factor Expression Collect on subexpression Polynomial Coefficients Solve for variable Substitute for variable Expand in Series Convert to partial fraction Semnificaţia: Evaluare Simplifică o expresie Dezvoltarea unei expresii Descompunere în factori Dezvoltă după o expresie Coeficienţii polinomului Rezolvă ecuaţia în necun.625 2 2. se selectează expresia sau variabila activă (acolo unde comanda cere precizarea variabilei).C.

simplificaţi următoarea expresie: x y 7 x7 y7 lim lim x x2 x 1 x2 x 1 Exemplu: x 1 3 x 2 1 expand Descompunerea în fracţii simple a unei funcţii raţionale: Exemplu: 3 2 2 x 1 2 3 lim lim 3 2 cos ( x) 1 x 0 2 4 4 x lim 1 tan( x) Derivate: d 3 ( x 3 x2 Exemplu: dx cos ( 12 x) 216 2x 2 3 2 arcsin( x) 6 sin ( x) 3 2 3 ln( 2) sin( x) 5 sin ( x) 16 x 4 lim 2 1 2 1 2 ln( 3) 1 4 1 6 1 sin ( 2 x) ( cos ( 2 x) ) 4 sin ( x) x 1 tan ( x) 1 3x 2 x) 4 ( cos ( x) ) x 0 sin( x) ln( 1 x x 5 4 x3 3 x 4 4 x 2 3 x 1 cos ( x) 4 lim Dezvoltarea unui produs: 1 x 0 Descompunere în factori a unui polinom: x2 1. Se utilizează apoi operatorul Symbolic Evaluation ( → sau Ctrl + .C. derivatelor şi integralelor unor funcţii: Simplificarea unor expresii algebrice: Se consideră următoarea expresie: a 2 (a b 2 c b) ( a 2 a c) 2 (b b 2 c a) ( b 2 a c) 2 b (c 2 c a) ( c 2 b) simp lify şi se doreşte simplificarea acesteia. factor x sin( x) 3 Exerciţiu: Exemplu: x4 e x 4 x 4 17 12 2 x 6 5 3 2 4 3 2 2 3 x2 6 x 2 2 x 1) Exerciţii: f1( x) 2 4 f3( x) x asin( x) 2 1 f2( x) 2 1 x ln 3 2 x 2 x 2 x 5 2 x 3 2 x 3 2 x 2 x 1 x asin( x) 1 2 3 ln x 2 2 x atan 2 x 2 x 1 5 . Limite: Exemple: a (a 2 b 2 b) ( a c 2 a c) (b 2 b 2 c a) ( b 2 a c) 2 (c b 2 a) ( c c 2 b) 2 simp lify 2 lim x 0 În mod asemănător. se selectează comanda simplify din meniul Symbolic. Se introduce expresia de mai sus.P. ). Morariu-Gligor Radu Mircea Calculul limitelor. Semestrul I.U.ing.dr. În final se obţine: Pentru fiecare exerciţiu se apelează operatorul de calcul corespunzător şi se completează poziţiile marcate cu datele 2corespunzătoare. 2012 – 2013 Şef lucr. an univ. se tastează Enter.

C. Semestrul I. Pentru rezolvarea ecuaţiei f(x)=0 forma de utilizare a funcţiei root este următoarea: x := a f(x) := expresia de calcul pentru funcţia f y := root(f(x).U. Morariu-Gligor Radu Mircea Exerciţii: Primitive şi integrale: Exemplu: x3 x2 1 4 x 4 x 2 dx 1 3 x 3 1 2 x 2 2 2 x 5 x x (x 0 f2( x) x 1 1 f3( x) 2 x Exerciţii: 4 x x 8 x 2) ( x 8 2) dx 33 25 2 lncos ( x) ( x) ln1( x cos 2) ( x) dlnx( x 22 22 sin ( x) 1 sin ( x) 2 x 2t)an 1 x 2 x f4( x) e x x 2 2 ln( x) e 6 ln( x) 1 12 2x 1 f5( x) 2 e 2 0 t an x 2 Calculul determinanţilor: 2 4 x 2 x 1 (x 1 dx 6 1) 5 cos ( x) t an x1 x atan 2 2x sin ( x) 3 x x 2 22 2 12 2 2 2 1 1 0 3 2 ln ( 3) 44 ln ( 2) 3 tan( x) dx 2 0 1 2 1 2 1 ln( 2) A 2 2 0 1 2 2 B 0 3 0 0 2 12 1 3 9 4 0 C 0 2 3 1 4 1 1 2 1 4 0 5 Rezolvarea unei ecuaţii algebrice: În MathCAD rezolvarea unei ecuaţii algebrice se poate realiza cu ajutorul funcţiei root.x) x sin ( x) 2 2 y = 1.x) y= A 20 B 162 C 175 Observaţie: succesul metodei depinde de alegerea adecvată a aproximaţiei iniţiale. Exemplu: x 0 f1( x) y := root(f1(x). an univ.83 6 2 2 .dr. 2012 – 2013 Şef lucr. La utilizarea acestei funcţii trebuie furnizată în prealabil aproximaţia iniţială.ing.P.

se afişează vectorul soluţie ca rezultat al funcţiei find.366 2 t a Pc 0. fie se apelează comanda Unit din meniul Insert.84 136. 9.6 N 2 Di mm Pc Di 2 6 Pc Di Sn Sn 0 x+y=2 S Figura 9.C. 2012 – 2013 Şef lucr. .634 2. . x y 2 Pentru rezolvarea sistemului de ecuaţii neliniare se scrie următoarea secvenţă MathCAD: x 0 y Given 2 x y 2 find(x y) S 0.6 1000 2 0. coeficientul de rezistenţă al îmbinărilor sudate.se scrie blocul de restricţii (ecuaţii sau inecuaţii).84.84 136. diametrul interior.6 MPa. . Pentru rezolvarea sistemului se construieşte matricea coeficienţilor necunoscutelor şi vectorul coloană a termenilor liberi. tensiunea admisibilă a materialului at = 136. φ = 0.3). în câmpul ataşat variabilei se introduce unitatea de măsură dorită.se iniţiază necunoscutele cu valori din vecinătatea soluţiei. 631 Pentru rezolvarea sistemelor de ecuaţii cu ajutorul MathCAD-ului se utilizează funcţia find. Pentru dimensionarea mantalei se cunosc: presiunea de calcul Pc = 0. Exemplu: Sn 2. Morariu-Gligor Radu Mircea Rezolvarea sistemelor de ecuaţii liniare Utilizarea unităţilor de măsură 3 x1 Exemplu: Să se rezolve sistemul de ecuaţii: x2 1 x1 2 x2 3 x3 3 x2 x3 2 x4 x3 3 x4 2 6 MathCAD permite utilizarea unităţilor de măsură în calcule.P. conversia către aceasta realizându-se automat.U.62 mm Dimensionare utilizând MathCAD-ul: Se vor introduce pe rând fiecare variabilă împreună cu unităţile de măsură: Pc 0.dr. 069 Pentru găsirea soluţiei se aplică relaţia: X = A-1·B şi se obţine: X Rezolvarea sistemelor de ecuaţii neliniare 1. Aplicaţie: Dimensionarea mantalei unui schimbător de căldură 4 Mantaua cilindrică este supusă acţiunii unei presiuni interioare uniforme.3 1000 mm 0. Cunoscând rezistenţele admisibile atât ale materialului de bază cât şi a îmbinărilor sudate. astfel: .62 10 3 m 7 . x2 y 2 6 Exemplu: Să se rezolve sistemul de ecuaţii neliniare: .6 2.66 0. Astfel: 3 1 0 0 1 1 2 3 0 2 A B 0 3 1 2 6 1. 023 0 0 1 3 4 2.66 [N/mm2]. an univ. 054 0. Di = 1000 mm. Pentru aceasta. Semestrul I.ing. pe baza unei teorii de rezistenţă se va determina expresia grosimii de rezistenţă a mantalei recipientului. fie se tastează Ctrl + U (fig.66 N 2 mm Pc Sn 2.se începe cu cuvântul cheie Given.62mm În cazul în care se doreşte modificarea unităţilor de măsură.

dacă expresia a fost definită sub formă de funcţie).4 a) Reprezentarea polară: Pentru reprezentarea grafică a unei funcţii în sistem polar. .C.U.se activează comanda Graph → Polar Plot. (figura 9.se defineşte domeniul de variaţie al variabilei. Semnificaţia fiecărei opţiuni din bara cu instrumente Graph este prezentată în tabelul următor: Operator: Semnificaţie: X-Y plot Zoom Trace Polar Plot Surface Plot Contour Plot 3D Bar Plot 3D Scatter Plot Vector Field Plot Reprezentare grafică într-un sistem de axe cartezian Modificarea scării de vizualizare a graficului Determinarea coordonatelor unui punct de pe grafic Reprezentarea grafică polară.4 b).6 . Se apelează din meniul Graph. Semestrul I. . se parcurg următori paşi: . 2012 – 2013 Şef lucr. . . se utilizează bara cu instrumente Graph. . Pentru deschiderea acesteia fie se acţionează butonul Graph Toolbar din bara cu instrumente Math.5 6 2.dr. . Exemplu: reprezentarea grafică a funcţiilor: Reprezentarea grafică a suprafeţelo sub formă de puncte f ( x) unde: 0 0. Se scrie expresia funcţiei f(x): f ( x) x3 3 x2 4 x 5 3. comanda X-Y Plot. 4. f ( x) 1 27 95 63 31 1 33 65 97 1 29 1 61 1 93 2 25 120 60 10 150 30 5 ( ) ( ) 180 0 0 210 330 240 5 4 3 2 a) 1 0 1 2 3 4 5 x 300 270 6 b) Figura 9. unde 5.se tastează Enter sau se dă click oriunde în afara graficului. trebuie parcurşi următori paşi: . 1.P.se activează comanda Graph → X-Y Plot. Se completează câmpurile corespunzătoare axelor X şi Y (figura 9.se defineşte domeniul de variaţie al variabilei oentru care se doreşte reprezentarea (pentru aceasta se utilizează bara cu instrumente Vector and Matrix Toolbar).5. dacă expresia a fost definită sub formă de funcţie). .pe axa X a graficului se înscrie variabila.pe axa Y a graficului se înscrie expresia pentru care se doreşte reprezentarea grafică (sau numele funcţiei. respectiv .se tastează Enter sau se dă click oriunde în afara graficului.ing.001 2 2 2 .pe axa unghiulară se înscrie numele variabilei. .pe axa polară se înscrie expresia pentru care se doreşte reprezentarea grafică (sau numele funcţiei. an univ. Reprezentarea grafică a suprafeţelor sub formă de pânze Reprezentarea grafică a suprafeţelor sub formă de linii de contur Reprezentarea grafică a suprafeţelor sub formă de bare Comandă tastatură @ Ctrl + 7 Ctrl + 2 Ctrl + 5 x x3 3 x 2 4 x 5 . parcurs cu pasul 0. Reprezentare grafică sub formă de câmp de vectori 90 Reprezentarea carteziană: Pentru reprezentarea grafică a unei funcţii în sistem cartezian. Morariu-Gligor Radu Mircea Realizarea graficelor 2D: Exemplu: Trasarea graficului funcţiei: y Pentru realizarea graficelor cu ajutorul MathCAD-ului. Se stabileşte domeniul de variaţie pentru x: x 5 4.4 8 . fie se selectează Opţiunea View → Toolbars → Graph.

b) cercul cu centrul în punctul de coordonate (a.C. .se scrie expresia funcţiei dependente de cele două variabile.se tastează Enter. y t v b sin(t ) d) cicloida x t . . .5 5 .v) şi semiaxele a şi b: x t u a cos(t ).4 .în coordonate polare: 2 1 cos a) b) f (t ) 2 pentru 3 1 cos(t ) . an univ. v) u sin(v) b) f 2(u . sau se dă click undeva în afara graficului. 2 0.5 5 4 3 1 sin(t ) . Se stabilesc domeniile de variaţie ale celor două variabile: 5 4. . . 2 .dr. y ) cos( y ) f 1(u .b) şi rază r: x t a r cos(t ). 2 cos (t ) sin (t ) şi g (t ) 2 sin(t ) 2 cos(t ) pentru t c) 2 d) 4 sin 3 e) 3 sin 2 f) 4 g) e4 0. y ) sin( x) sin( y ) f 3( x. 2012 – 2013 Şef lucr. t 0. y t .P. respectiv y 5 4. 2 . y t b r sin(t ) c) elipsa cu centrul în punctul de coordonate (u. Semestrul I. y ) sin( y ) cos( x) a) f 2( x.reprezentare 3D: f 1( x.se stabilesc domeniile de variaţie ale variabilelor.ing.în câmpul situat în partea din stânga-jos a graficului se scrie numele funcţiei dependente de cele două variabile.în coordonate carteziene: a) f ( x) cos( x) sin( x) sin( x) pentru x Exemplu: graficul funcţiei f ( x y) x 2 x 2 y 2 Se scrie expresia funcţiei: f ( x y) 2 x 2 y 2 Se apelează comanda Surface Plot şi se scrie numele funcţiei ( f ) în câmpul corespunzător. .se alege comanda Surface Plot din bara cu instrumente Graph. v) u cos(v) f 3(u.U. cos 2 . Morariu-Gligor Radu Mircea Realizarea graficelor 3D: Exerciţii: Să se reprezinte grafic următoarele funcţii: Pentru realizarea unei reprezentări tridimensionale a unei funcţii dependente de două variabile se parcurg următorii paşi: . v) u sin 2 (u ) f 9 .

astfel: sin cos sin cos T1 T2 0 P Pentu rezolvarea sistemului se construieşte matricea A şi vectorul coloană sin sin 0 B. Proiectând ecuaţia de -T2 4 a 3 Soluţia.1) cu ajutorul MathCAD-ului se utilizează forma matriceală a sistemului de ecuaţii. Soluţia obţinută pe această cale este: T 62.xG se determină uşor.945 N Pentru rezolvarea sistemului de ecuaţii (9. obţinem: dl 0 ) pe Rezolvare analitică: Din prima ecuaţie: T1 dx 2 dy 2 T2 sin P a dl Elementul de arc dl se calculează astfel: dl T1 cos P ydl . reprezentată sub forma vectorului coloană T se calculează astfel: T A 1 B . an univ.031 N 10 . 637 N T2 104. Semestrul I.P. B cos( ) A G(xg . 2: y Problemă: Să se afle centrul de greutate al arcului de cicloidă: M (x. între doi pereţi verticali..yG se determină cu ajutorul relaţiei: y G Prin urmare: y G echilibru a celor trei forţe: ( T1 T2 axele de coordonate.1) P sin sin T2 sin sin .629 105. A O T1 a . 4 a 3 0 Rezolvarea cu ajutorul MathCAD-ului: yG a 1 cos( ) 2 a sin 2 2 a sin 0 2 d 2 d simplify T2 cos P 0 (9. în care se înlocuiesc expresiile lui y şi dl. 2012 – 2013 Şef lucr.C.y) O1 ? x a y a (1 cos( )) O lampă de greutate P = 150 N este suspendată de două fire. Să se determine tensiunile T 1 şi T2 din cele două fire (figura). iar cel din dreapta unghiul β = 20°. astfel: A B P cos cos 2 0 0 Rezolvarea cu ajutorul MathCAD-ului: Cu ajutorul MathCAD-ului se va rezolva calculul lui yG. Pe baza relaţiei : ydl . aşezate pe axa Ox (figura).ing. Morariu-Gligor Radu Mircea Aplicaţia nr.. Înlocuind în ecuaţia a doua: T2 P sin sin . T2 P sin sin . fiind la mijlocul distanţei OA: xG OA 2 2 a 2 2 2 a sin 2 d Rezultă: T1 2 1 cos( ) sin 0 2 2 sin 3 d 0 2 a d 2 2 2 sin 0 2 d 2 cos 2 . se obţine: T2 T1 sin Rezolvare analitică: 2 a2 Rezolvare: Vom tăia firele şi le vom înlocui cu tensiunile T1 şi T2 .dr. Soluţia este: T1 62. Firul din stânga formează unghiul α = 35° cu peretele.yg ) a 2 x a ß -T1 cuprinsă între primele două puncte ale cicloidei.U. 1: Aplicaţia nr.

131·10 4 2.562·10 3 2. Rezolvare: luna n 1 an 12 luna SUM A 320000 nr_ani nr_ani an .517·10 3 1.609 4.527·10 4 2. Creditul se rambursează în rate lunare egale.654·10 3 1.921·10 3 2.711·10 3 13 2.503·10 3 1.utilizand regula dobanzii compuse. an univ.089·10 3 48 2.C.194·10 3 -3.136·10 4 2.graficul achitarii creditului: 1 9 SUMA i 1 n balanta0 SUM A balantai balantai dobanda i platai (1 1 balantai rata achitati achit ati 2 105 1 p) rata bal antai p dobanda i SUM A balantai 0 0 0 0 20 40 60 i 80 100 120 n luna j 1 2 1 1 an 2 3 4 n an 1 an an an 1 n 11 .338·10 3 1. se obtine: rat a (1 SUMA p (1 p) p) n n rata p 10 % an balant a achit at lu n aj lu n aj dobanda plata lu n aj lu n aj 1 3.194·10 3 3.U.169·10 5 3. cu o dobândă de p% anual.14·10 3 2.963·10 4 2.004·10 5 1. 2012 – 2013 Şef lucr. Să se determine rata lunară şi să se calculeze balanţa.158·10 5 69.283·10 5 9.667·10 3 1.891·10 3 36 2.173·10 4 1.547·10 5 6.184·10 5 1.726·10 3 24 2. 3: Rambursarea unui împrumut: O bancă acordă un împrumut în valoare de SUMA lei. pe o perioada de nr_ani.ing.159·10 3 3. Morariu-Gligor Radu Mircea Aplicaţia nr.2·10 5 34.949 4.575·10 3 12 3. Semestrul I.986·10 5 2.dr.137·10 3 2.P.562·10 3 2 3.278·10 120 -9 1 Suma totala rambursata: rata n j 3 4.229 10 10 luna j 5 5.307·10 3 119 4.075 10 .787·10 5 4.

Funcţia implementează metoda Runge-Kutta de ordinul patru şi permite atât rezolvarea ecuaţiilor diferenţiale cât şi a sistemelor de ecuaţii diferenţiale. pentru a fi vizibile valorile deplasărilor au fost înmulţite cu 10.  x y1 sin m cu condiţiile iniţiale: x0 x(0). utilizată pentru rezolvarea ecuaţiilor sau a sistemelor de ecuaţii diferenţiale. q m 1 v0 p q p2 2 q sin pt p2 2 - F0 x y0 . x0 v0 x (0) t k y0 m v0 se construieşte vectorul D care conţine derivatele de ordinul întâi ale funcţiilor necunoscute: D(t . x y1 . x1.dr. Se va prezenta în continuare funcţia rkfixed.x1. Sistem mecanic vibrant forţă armonică (figura 9. diferenţiale de ordinul întâi. Ec.prima coloană conţine punctele în care s-a calculat soluţia. . x0. . asupra masei acţionând o Figura 9. astfel: x0 y1 sin t Valorile numerice utilizate în exemplele care urmează sunt: F0 = 200 [N].U.npoints reprezintă numărul de puncte în care se determină soluţia. 12 T . Morariu-Gligor Radu Mircea Pentru implementarea în MathCAD trebuie parcurse următoarele etape: Aplicaţia nr. respectiv v0 reprezentând condiţiile iniţiale. x2 = 2. npoints = 8000.05 0 0.5. an univ. 2012 – 2013 Şef lucr.5): Ecuaţia diferenţială a mişcării este: mx kx F0 sin t a cărei soluţie generală se exprimă astfel: x unde: p x0 cos pt k . x2. diferenţiale. . Dif. se va rescrie ca un sistem de ec. Forma generală a funcţiei este: rkfixed(y.5 2 0 Observaţie: deoarece valorile obţinute pentru deplasări şi viteze sunt reprezentate pe acelaşi grafic.următoarele coloane conţin valorile coresp.000 [N/m]. 4: (vibraţii mecanice) k F sin t 0 m Se consideră un sistem mecanic vibrant format dintr-o masă m şi un element elastic. soluţiilor pentru primele n-1 derivate. .y: este un vector care conţine condiţiile iniţiale. D) Funcţia returnează o matrice în care: . m Argumentele utilizate în cadrul funcţiei au următoarele semnificaţii: . . Astfel: - F0 . cu parametrii stabiliţi în etapele precedente. se construieşte vectorul y care conţine condiţiile iniţiale: y - y 0 y D( t y ) 0 1 F 0 m sin t k m S y rkfixed( y 0 2 8000 D) 0 Reprezentările deplasărilor şi a vitezelor.P.05 S S 1 2 10 0 0. Valorile returnate de funcţie vor fi atribuite unei matrice S. Semestrul I.D este un vector cu n elemente care conţine derivatele de ordinul întâi ale funcţiilor necunoscute. ω = 35 [rad/s]. funcţie de timp sunt ilustrate în figura următoare: 0.C. k = 25. y ) F0 sin m k y0 m t se stabilesc limitele intevalului şi numărul de puncte în care se determină soluţia: x1 = 0. x2 reprezintă limitele intervalului în care se determină soluţia ec.ing.5 1 S 1.se apelează funcţia rkfixed. m = 250 [kg]. npoints.