PetroMod 1D and 1D Express SP3 – Tutorial

1

Introduction

PetroMod 1D is part of the PetroMod software package that fully integrates seismic, seismicstratigraphic and geologic interpretations with multi-dimensional simulations of thermal, 3-phase fluidflow and petroleum migration histories in sedimentary basins. The PetroMod family offers full 3D
hydrocarbon generation and migration modeling capabilities. The full package combines the
technically most advanced 1D, 2D and 3D technologies with a unique degree of usability for the best
results of your petroleum systems analysis.
PetroMod is mostly used in exploration work, but has also proven to be a valuable tool in research
applications. PetroMod is equally valuable in new exploration areas where only a few data are
available, as well as in already explored areas where problems such as source-reservoir correlations,
seal efficiencies, and overpressure systems are investigated - in addition to the fundamental task of
obtaining the most accurate prediction of timing and location of petroleum generation, expulsion, and
migration processes.

PetroMod 1D can be used as a stand alone tool or as a fully integrated component of IES’ modeling
systems, the PetroMod 2D and 3D packages. Single point data (wells and pseudo-wells) can be
constructed from scratch or extracted directly from PetroMod 2D and 3D models. Calibration results
such as heat flow trends can then be used directly by the 2D and 3D simulators. The result is that
calibration work is performed much faster in all packages. An easy-to-use input table enables the user
to create and manage individual wells within one or several projects. Boundary conditions such as
basal heat flow and paleo water depth can be set graphically or through direct tabular input. The
simulation is initiated automatically by opening the Output window. The results can be displayed in
individually customized templates made up of one or more panels.

PetroMod 1D Express is a restricted freeware version and has not the full functionality of PetroMod
1D. However, it has full compatibility with PetroMod's 1D, 2D and 3D packages. Some of the links that
refer to other PetroMod applications may not be active. The freeware version has the same source
code as the fully functional version and is actually the same executable. License control is simple: if a
license key is not found, the software automatically starts in the freeware mode. PetroMod 1D Express
makes it possible for an unlimited number of 1D licenses to be used, for example as a 'reader' for 1D
models or for points extracted from 2D/3D models. Please see the table below for a comparison of the
features of PetroMod 1D and PetroMod 1D Express.

5

Most parts in this tutorial are valid for both PetroMod 1D and for 1D Express. They cover all of the features of the PetroMod module. 2D and 3D packages. only default library None No license controls. The parts that refer exclusively to PetroMod 1D are clearly marked as such. customize your output model and create your own output panel template. 6 . IES' PetroRisk technology can be applied to all PetroMod 1D (complete version only). If you have any suggestions. questions or concerns. The PetroMod 1D and 1D Express Tutorial offers a general overview over the PetroMod 1D software package. optional dongle control Sun. SGI. The lessons have been written in a simple step-by-step format. which should take about 4-6 hours. In this tutorial.de.000 for all platforms Note *PetroRisk is IES' unique risk management system which enables the user to determine and statistically evaluate the effects of uncertainties in specific types of geologic input data on the results. it is suggested that you take the time to go through the tutorial in one sitting. Windows XP/2000. as well as an introduction to individual features and functions. It consists of a series of lessons. you will learn how to build a 1D well model from scratch beginning in PetroWells. fully integrated with all PetroMod 2D/3D packages Direct extraction of well data from OpenWorks and GeoFrame projects Full non-steady state thermal history modeling Full pressure history modeling Complete range of lithology and kinetics editors Fully integrated with IES’ PetroRisk* modeling tool Full FLEXIm multi-platform license controls. We. please feel free to contact us via email at support@ies. Linux < US$10. and finally how to calibrate your 1D model to optimize your output. at Integrated Exploration Systems (IES) constantly strive to improve our products and wish to make the usage of our software as convenient as possible.PetroMod 1D and 1D Express SP3 – Tutorial Product Goal Data Sources Thermal History Modeling Pressure Modeling Property Editors Special Modeling Tools Licensing Platforms Cost PetroMod 1D Express (freeware) 1D data reader/viewer and basic modeling tool No special tools NEW! Full non-steady state thermal history modeling NEW! Full pressure history modeling No lithology or kinetics editors. Since the individual features build on each other. automatically in Express mode if no license found Windows XP/2000 Freeware PetroMod 1D (full version) 1D modeling package. how to set boundary conditions. including information on how to install the program and on how to get started. which leads the firsttime PetroMod user through a typical project using a fairly standard workflow within each module. For further contact options please see chapter 9 “IES Support” at the end of this tutorial.

The InstallShield Wizard will open automatically.) on CD.ies. Figure 2. 2. documentation and tutorials. 7 .ies.de/Support/Support. Hardware requirements: Please visit us at www. SeisStrat 2D/3D. From here you can download IES software.1: The InstallShield Wizard Notes The download is free of charge! To use programs that are not freeware tools you will need to acquire a license. Follow the online instructions. Input 2D/3D. Simulator. While PetroMod 1D Express is freeware.1 Installation via Download or from CD Open the IES costumer support website: http://www. For detailed information on different PetroMod license packages please contact sales@ies.de).de for a list of hardware requirements. etc.PetroMod 1D and 1D Express SP3 – Tutorial 2 Installation PetroMod 1D Express (Windows) can be downloaded by itself directly from the IES website (www. PetroMod 1D requires a license. When installed only the free Express version or the versions for which you have acquired a license will function. IES PetroMod 1D Express is also distributed together with other PetroMod modules (1D.de. PetroMod 1D Express will self-extract. To install PetroMod 1D (Windows) or the versions for Unix and Linux you need to download the full PetroMod package.ies.html. Follow the guide through the installation procedure.

The Select Project Path window will open (see Figure 2. Figure 2. 2.3: The Select Project Path window Note The big panel in the Select Project Path window displays the Project History. you could choose one by double-clicking 8 . Double-click the shortcut. In our case this panel is empty since we have not yet created any PetroMod project directories. Click the Project Dir button to change the project directory.3). The PetroMod Command Menu will open.2: The PetroMod Command Menu The Project Dir: button at the bottom left of the PetroMod Command Menu indicates an automatically created PetroMod directory.PetroMod 1D and 1D Express SP3 – Tutorial 2. Figure 2.2 Opening PetroMod 1D 1. If several project directories would be listed here.

You have now created a new project directory. Figure 2. the name of this directory will be shown in the Project bar (and under Project History) of the Select Project Path window. 9 . 5. The PetroMod 1D window will open (Figure 2. (The bar may be empty as well.4). Enter a name for your new project directory. Click the OK button twice. The new path to the project directory will now be shown in the PetroMod Command Menu. By default the window will open with the Input tab open.) 3. In the Select Project Path window. Building a 1D Model”.4: The PetroMod 1D window The main PetroMod 1D user-interface has three tabs (Input.PetroMod 1D and 1D Express SP3 – Tutorial directly its name in the Project History panel. We will begin here with 1D model building. click the Create New Project Directory button . The bar below indicates the path to the current project directory. 6. Open PetroMod 1D by clicking 1D on the menu bar or simply by clicking the PetroMod 1D button on the PetroMod Command Menu. and Output). for our example enter 1DProject into the Enter Directory Name field. The Enter Directory Name window will open. 4. Boundary Assignment. You can now move on to “Exercise 1.

Figure 3. 4. 10 . PetroWells will open as a separate application. 2.1 The PetroWells window 3.PetroMod 1D and 1D Express SP3 – Tutorial 3 Exercise 1 Building a 1D Model We will begin our exercise in the first section by creating a new well model from scratch using the IES well editing tool PetroWells. A small window at the bottom left will open. Click Wells in the tree in the Objects window.1 Creating a New Well in PetroWells 1. To create a new well type a name into the List box. 3. TestWell_1. age. and click the New Well List button .4). we will load our well into PetroMod 1D and build a 1D model using the PetroMod 1D tabular input. lithologies. Then. Click the Well Editor button (Calibration Data Editor) . Open PetroMod 1D. since no other wells have yet been created. and source rock properties. Nothing will be listed in the project path nor will there be any groups in the WellData tab in the lower right part of the window. By default the Input tab will be open. We can now begin to create our own well from scratch (see Figure 2. There will be only one tab within the Input tab (at the bottom of the page): Well1. The well will be further defined by assigning values for thickness.

Click the Well Data tab in the bottom right window. 12. Figure 3. Click the Apply button to apply and save your settings and close the Wells in List window. Click Save to save the newly created well. Figure 3. The newly created well list will appear in the Objects and in the bottom left windows. 13. Click the Save button or click Save on the File menu to save your newly created group. Click TestWell_1 in the tree in the Objects window.3: The Wells in List window 10. 9.2: Windows in PetroWells 7. 6. Close and reopen PetroMod 1D. Close PetroWells. Extend the well list under TestWell_1. 11. The title in the window at the bottom left will change to TestWell_1.4: The Well Data window 11 . Figure 3. Click Edit in the TestWell_1 window.PetroMod 1D and 1D Express SP3 – Tutorial 5. Fill in manually the name and coordinates for our main well TestWell_1 according to Figure 3. You can now see a graphic representation of the well location in the PetroWells main area. You will find our newly created TestWell_1. The Wells in List window for TestWell_1 will open.3. 8.

click the + symbol to expand the ALL group list. 3. 4..6: The Project Tree TestWell_1 (i. Note The data tree will always be displayed when you access the same project directory in PetroMod 1D. On the left side. click the Well Data tab (per default. The newly saved model will appear in the data tree under the Project tab in the upper right part of the PetroMod 1D window. 12 . Individual wells can be loaded e. 2. 3. layer thickness. 1.g. the Layer Properties tab is active). Notes Well groups can also be created. In the data tree. The Save As window will open. Click the name of the well you wish to delete. by "drag-and-drop" from the Project tab (right) into the Input table (left). lithologies. You do not need to follow this exercise to proceed with Exercise 2.5: The New TestWell_1 tab 15. or deleted in the 1D Base Map using the respective commands from the shortcut menu. Figure 3. Click Delete.PetroMod 1D and 1D Express SP3 – Tutorial 14.g. e. 5. renamed. In the lower right panel of the PetroMod1D window. Save your project in the PetroMod 1D menu.2 How to Delete a Well This part of the tutorial interrupts the flow of the tutorial for information on how to delete a well in case you have created a well by mistake. The ALL group list contains all wells that have been created or imported so far. Click TestWell_1 with the left mouse button and drag and drop the well into the Input table on the left.e. your 1D model) is now ready for geological data assignment. the Well Data tab shows a data tree structure. The functionalities described above are also available in PetroWells. Figure 3. source rock properties. A new tab with the well name TestWell_1 will appear. Click that well with the right mouse button. etc. which causes a submenu to open. Enter as the file name for this exercise TestWell_1 and click the Save button. The well data are automatically stored in the well subdirectory of the project directory.

3. The TestWell_1 tab should appear in white. ready for the input of geological data. 8. 13 . 7. Quit PetroMod and re-open the program. Enter names for the individual layers into the Name column according to Figure 3. 9. If not. use the drag-and-drop function to copy data. it needs to be deleted in the PetroMod 1D Input table as well as in the Well Data box. Begin now with the input of geological data: 2. 6. 1. 3. Save your model. Click Delete.7. Do not change the default setting. Make sure that the Input table is open. This means that the top of the layer directly underneath the sediment surface (here layer_10) is also at 0 m. Click the tab for the well to be deleted at the bottom of the Input table. This corresponds to the default setting.7: Entering data into the Input table. click the Input tab at the top left of the PetroMod 1D window. Note The Input table works to a large degree in the same way as the spread sheets in Microsoft Excel.PetroMod 1D and 1D Express SP3 – Tutorial If the well has already been loaded into the Input table. Click the well with the right mouse button which causes a shortcut menu to open.3 Entering Depositional Thickness and Age We will start model building by entering the necessary data into the table for TestWell_1. The present-day water depth shall be 0 m in this exercise. The default name of the top layer is always Sediment Surface and cannot be changed. Figure 3. Double-click in a cell to edit the cell contents.

If however. depth or thickness. density. SHALE) to open a table of lithologies belonging to that group (e.7. only the default lithologies will be used. When you enter the values into Deposition Age from from top to bottom.7.PetroMod 1D and 1D Express SP3 – Tutorial 4. will automatically be assigned along with it. The erosion columns can be turned off by clicking the Erosion button .g. information about the lithologies of the respective layers.1 Lithologies When a lithology is set for a specific layer. Note No erosion will be entered in this exercise. the values for Deposition age to will be calculated and inserted automatically. you need to fill in both columns manually. double-click in the respective cell in the Lithology column of the Input tab to open the lithology group selection window: Figure 3. Enter the values into the Deposition Age from column according to Figure 3. You only have to enter one item. customized and edited using the PetroMod Lithology Editor ( ).g. and permeability. 3. e. additional lithologies can be created.g. For this tutorial however. various SHALE lithologies). To assign a lithology to a specific layer. In the full version of PetroMod 1D. 3.4 Entering Lithologies and Source Rock Properties For compaction calculations your 1D model needs besides depth and age. PetroMod offers a range of default lithologies with corresponding lithological properties. its lithological properties. Double-click a lithology group (e. for maturity calculations we will determine the petroleum system elements and source rock properties.4. Additionally. 5. 1. you wish to enter a hiatus. 6.8: The lithology group selection window 2. 14 . The other will be calculated and inserted automatically. porosity. Enter the values for the Top and Bottom depths OR the Thickness values into the table columns according to Figure 3. Click Save on the File menu to save the model.

In: MAGOON. if wells are imported from 2D or 3D projects. 15 . When you create a new 1D model a facies number will be entered automatically.g. Per default. Double-click an element to assign it to the cell. . 3. & DOW. In order to assign PSE terms to the individual layers of a well.3 Petroleum System Essential Elements The petroleum system elements are based on the concept introduced and described by MAGOON.24.From Source to Trap. double-click in the respective cell in the PSE column. (1994): “The Petroleum System” . 5.9: The Input table completed with values 3. 4. W. Double-click the desired lithology (e. 1.4.9 when assigning lithologies to the respective layers.B. the PetroSys Essential Elements column is hidden.G. L. Click the Petroleum System Essential Elements (PSE) button to display the PetroSys Essential Elements column (column 12) in the Input table. W. & DOW. facies names and colors will be displayed according to their data assignments in PetroMod 2D/3D.B.PetroMod 1D and 1D Express SP3 – Tutorial 3. SHALEcarb or pure SHALE) to place it into the marked cell. Follow Figure 3. 2.AAPG Memoir 60: 3 .2 Facies The Facies column is hidden by default. Click Save on the File menu.G. L. This number cannot be edited.): The Petroleum System . Figure 3. However. (eds. The essential elements list will appear.10: The PSE list 3. or click the Save button to save your input. Figure 3.4. click the Facies button . To make it available.

2. HI. 2. In PetroMod 1D it makes no sense to simulate migration.9). The right panel of the Layer Properties tab lists the available Layer Based Models (see Figure 3.4. In this tutorial. Click in the cell for the salt layer (layer_2) in the Name column of the Input table. kinetics can be created. In this tutorial. Click Save on the File menu. The chosen layer name will now be displayed in the Selected Layer(s) panel under the Layer Properties tab.4.4. Salt Movement. 1. This exercise refers to the full version of PetroMod 1D only. TOC and Kinetics columns are available for petroleum kinetics. 3. 4. Please refer for more information about the different types of kinetics to the reference literature listed in the detailed bibliography in the PetroMod 1D User Manual. and Thrusting) that allow further geological refinements of the model to adapt it to the situation in the field. For this tutorial however. Input Burial History Diagram”. Hydrogen Index (HI). 16 . Enter 5 wt% for the TOC and 500 mgHC/gTOC for HI petroleum kinetics into the respective cells for the source rock layer_4 (see Figure 3.6. and Kinetics. Save your model. Click the Layer Properties tab in the bottom right section of the screen.5 Salt Movement (PetroMod 1D only) The full version of PetroMod 1D offers a range of special tools (i. Fracturing. and Kinetics columns. 1. In the full version of PetroMod 1D. PetroMod offers a range of default kinetics.11). we will enter petroleum kinetics with the HI. the layer based model "Salt Movement" will be assigned to the salt layer (layer_2). Intrusion.PetroMod 1D and 1D Express SP3 – Tutorial 4.4 Source Rock Properties Source rock properties include Total Organic Carbon (TOC). At the end of this exercise we will remove the data again to proceed to the common sections of PetroMod 1D and 1D Express. Click the Source Rock Properties button to display the TOC. 3. Note HI. The kinetic type can be chosen. only the default kinetics will be used.e.10 when assigning Petroleum System Essential Elements to the layers. Piercing. Users of PetroMod 1D Express should move on directly to Chapter “3. or click the Save button . 3. yet it is possible to calculate the petroleum generation potential for a certain kinetic reaction. Cementation. 5. Double-click in the Kinetics cell of layer 4 to open the selection list and click Tissot_et_al(1988)_T2 for the kinetic reaction. customized and edited using the PetroMod Kinetics Editor ( ). Follow Figure 3.

only the Age and the Thickness columns for that layer contain default data. a node (small black square) will appear. click it with the middle mouse button. Select the Salt Movement check box. There are two ways to set up salt thickness through time: a) by entering numerical values directly into the table or b) by drawing the changes directly into the graph.12: The Salt editor 17 .12 to enter age and thickness data into the columns for layer_2. The Salt editor window will open. Drag the node to any desired place (to drag. The cursor will turn into a cross hair. Therefore.PetroMod 1D and 1D Express SP3 – Tutorial Figure 3. Figure 3. follow Figure 3.12). Click on the trend. i. Click in the graphic panel. hold the left mouse button and move the cursor) and drop it with another click. Note It is not possible to enter any property (such as Thickness) for a layer prior to its deposition. Either way. Since only one layer (layer_2) in the 1D Input has been determined for salt movement. Note To delete a node. in this example. after 40 Ma. 4. It displays Age and Thickness columns for three layers and three graphical input panels. one for each layer (see Figure 3. salt movement can only begin after deposition of layer_2.e.11: Choosing the Layer Based Model 3.

Figure 3. click the Input Burial History tab.13: Changes to the Input panel after entering salt movement 6. Save your model.14: The Input Burial History diagram displaying the salt movement.14). is not yet the result of a simulation. 7. you will see that the small square next to Salt Movement in the lower right window is checked (see Figure 3. Note The salt layer (layer_2) in the Input table will now show a light green background color. When you click in the cell of layer_2 in the table on the left. The color indicates that salt movement has been assigned to that layer. The thickness of the salt layer (layer_2) varies over time.PetroMod 1D and 1D Express SP3 – Tutorial 5. Figure 3.13). The Input Burial History diagram allows you to check the geometry evolution of your model prior to simulation. it may take a few seconds until the calculation has completed and the geometry can be displayed. In the upper right panel of the PetroMod 1D Input window. The graphic for the Input Burial History will be displayed (see Figure 3. This input burial history is a mere graphic representation of the built geometry and does not take compaction into account. Important When you select this tab for the first time. 18 . What you see. Click OK to apply the modifications and close the Salt editor window.

The input burial history will be displayed in a diagram (see Figure 3.6 Input Burial History Diagram The main 1D model input data have been entered. You can now check visually the geometry evolution of your model through the Input Burial History tab. Please proceed to “Exercise 2. To do this. When you click this tab for the first time. we need to take off the data for the salt movement again. 2. 19 . The Input Burial History diagram allows you to check the geometry evolution of your model prior to simulation.15). heat flow) need to be set.PetroMod 1D and 1D Express SP3 – Tutorial 8. This input burial history is a mere graphic representation of the built geometry and does not take compaction into account. In order to proceed with the tutorial version that is valid for PetroMod 1D and 1D Express. Setting Boundary Conditions”.13). 1. Check the geometry evolution of your model prior to simulation. What you see is not yet the result of a simulation. 9.g. boundary conditions (e.15: The Input Burial History tab for verification of your input data Before running the simulation. click in the cell of layer_2 in the Input table on the left and deselect the Salt Movement check box in the lower right window (see Figure 3. In the upper right panel of the PetroMod 1D Input tab. Figure 3. Save your model again. 3.4. it may take a few seconds until the calculation has completed and the geometry can be displayed. click the Input Burial History tab.