You are on page 1of 17

viatechnik.

com

http://www.viatechnik.com/76-autodesk-revit-tips-shortcuts/

76 Autodesk Revit Tips and Shortcuts

76 Autodesk Revit Tips


and Shortcuts
Autodesk Revit is an indispensable tool for architects, engineers, designers and contractors. Its use as a Building
Information Modeling (BIM) software is critical for those involved in Virtual Design and Construction (VDC). But, a
tool is only as good as its user, and the full power of Revit can only be unleashed with a better understanding of its
various functions.
Here are some important tips and shortcuts to help you make the most of Revit that are brought to you by the team
at VIATechnik.
01Pinning
If you are referencing or overlaying an external dwg, rvt, or other types of drawings files, make sure they are pinned
down to ensure that these reference files do not shift and cause inaccuracies in modeling. You can pin objects by
selecting the pin object icon under the Modify Tab, or by typing PN while object is selected. Pinned objects can also
be set to not select or highlight when the cursor highlights over the pinned object. This is helpful when an extremely
large external Revit model is linked to the working Revit model. Revit tries to visually highlight any elements that
your cursor hovers over, and may take up some processing time when highlighting an extremely detailed element.
Simply toggle the Select Pinned Element button at the bottom right corner of your Revit model to disabled, and
your pinned element will no longer be selectable. Toggle it back on when you need to make adjustments to the
pinned element.
Pinned objects will show a thumbtack when selected. Clicking the thumbtack will unpin the object.
02Use Splash Screen

Sometimes when experiencing a hard time opening a project, make it


easier by utilizing a splash screen. Go to Manage tab >> Manage
Project panel >> Starting View Tool. The default view to be opened is
the Last Viewed. You can change this to a set view. To improve the
boot up of Revit, create a new view or choose an existing view that
does not display a lot of detail. This reduces the processing time of the
Revit file and lets you start working on the project much more quickly.
03Using Filters to Find Objects
Often times, you may need to find a specific object in the model, or
select multiple of a similar object in the model. Use the Filter function
to your advantage. Drag Select a region that will select all the
elements you wish to select. Click the Filter button under the Modify
Tab and uncheck all irrelevant objects. Click OK and the objects that were left checked will be selected.
This trick is especially useful in locating imported CAD Drawings that did not import to a correct scale. Simply type
ZE to Frame all objects in the model space within the window and select all objects in the view. Filter and only check
the box for the externally referenced CAD File. Click OK and your imported CAD File will be highlighted. Usually a
line with a Pin will indicate the location of the CAD file. Zoom in closer and youll find an underscaled CAD plan that
you can rescale.
04Understanding Sheets & Views
Sheets are used for printing, while views are actual workspaces that
can be placed onto sheets for printing. A view can only be placed on
one sheet, and cannot be used in multiple sheets at one time. In order
to have a similar view placed in multiple sheets, you must duplicate
the Views as Dependents and place the new view onto the sheet:
Here is a break down of the differences within duplicating a view:
Duplicate View
Duplicates a view, and all objects that are considered part of the
model. Things that are detail items, such as detail lines,
hatches, text annotations, and detail groups will now show up in
the new Duplicated View. Any new changes to the views wont
affect the other.
Duplicate View with Detailing
Duplicates a view with all model items and detail items. Any new
changes to either the old or new view wont affect the other.
Duplicate as Dependent
Duplicates a view exactly as seen. Any changes in one view will
affect the other.
05Snapping
Control where your line ends with greater precision by using the snap function. Often times, there will be lines that
do not meet at corners, or over-extend due to the default auto-snap that Revit uses. When clicking certain points,
input snap shortcuts such as SE (Snap to Endpoint), SI (Snap to Intersection), SP (Snap to Perpendicular), SN
(Snap to Nearest), SM (Snap to Midpoint), before clicking the point to have it snap precisely to the point you need it
to be in. If you are working in an area where a lot of linework is occurring, it is best to use the snapping feature and

the TAB key to cycle through the available snap points in the area that your cursor is hovering over. Revit will
indicate which lines are being used as references to the snap by highlighting the lines.
06Constraining Models
When building models, there are often times that changes to a model require one to shift multiple objects at once.
Constraining certain elements of a model can aid in adjustments quickly. Simply dimension two elements you want
constrained and input the dimension you want to lock in. In the example below, I want the center of the door to
always be 2 feet away from the wall to the right. Lock in the dimension string and the object is now constrained. If
you want the object to remain constrained but to not show any dimension strings, simply delete the dimension string
and click OK on the alert message. Clicking Unconstrain will remove the constraint along with the dimension
string. Now, every time the right wall shifts, the door will shift along with it to maintain the 2 feet distance.

*Note: Over-constraining elements will cause the model to create error messages, which will require you to remove
certain constraints.

07Override Graphics in View


If you want a temporary override of lineweights or surface texture in a view, simply click the element, click Override
Graphics in View, then also click By Element. This is useful when overlaying CAD drawings to a floor plan view to

draft as a reference. When linking CAD files with different colored layers, it may be visually difficult to draft over
these drawings. Override projection lines to a dull gray or even a single easily recognizeable color to differentiate
what a CAD drawing is and what a Revit model is.
*Note: Override Graphics only works on the view in which it was turned on in. If you want to change an element
throughout the Revit model, change the Visibility Settings instead. Additionally, be aware as to what elements are
being overridden. All overrides take precedence over visibility settings, so you will need to turn off the override to
have it take on the Visibility Settings characteristics again.
08Room Areas vs Area
It is important to differentiate between Room Area tags and Area tags. Use Area tags to calculate overall footage of a
building, or areas that are not distinguished as a space. Utilize Room Area tags when defining rooms, such as any
space enclosed by walls. Use the walls to frame the area, and use Room Separation lines to divide spaces with
openings. Do NOT use Area to calculate areas of rooms, as it will not populate in room schedules correctly.

09Understanding Families & Types


Knowing when to create new Families and when to create new Types can make a world of a difference to how long
modeling will take. You can view Families and Types to that of animal kingdoms. Families are similar to a species of
Animal (Dog, Cat, Parrot, etc.) and there are specific Family Types (Mammals, Amphibians, etc.). Types are similar
to the breed of an animal (Golden Retriever, Chihuahua, Bulldog). If you are going to model an object that will
change in dimensions, or have certain elements that are visible and not visible in certain instances, then this should
be differentiated by Type. If the Family is going to be two completely different models (i.e. a model of a table & a
model of a chair), they should be two different Furniture Families.
01.
Families are broken down into certain sub-categories of Families.

02.
Within these sub-categories rests individual Families. I.E. Basic Wall Family.
03.
Within an individual Family rests Types, which are different configurations of a
Family. I.E. Brick on CMU is a Family Type within a basic wall Family.
Example: If I need a box in Revit with the dimensions (2x2, 4x4, and 8x8), simply
make a Family with a rectangular extrusion. Set the Length, Width, and Height as
dimension parameters in the Family. Load the Family into the model and create 3
different Types. Within the Type settings, input the necessary dimensions and click
OK. Create another Family Type by clicking Duplicate and renaming the Type to
something else.
10Pick Lines
If you are converting line work from a CAD file, instead of drawing the lines
individually, you can use Pick Lines to automatically copy the CAD lines onto Revit.
If the line is drawn as a Polyline in CAD, you can press Tab while hovering over the
line to potentially select an entire Polyline versus a single segment. There is the
possibility that you can convert an entire CAD drawing into Revit linework by
exploding the imported CAD file, but this is not recommended for drawings containing
large amounts of linework, 3D elements, hatches, etc.
By choosing Pick Line and hovering over a specific line and tabbing through the
selections, you can draw single Polylines from existing CAD drawings quickly.

11Customize Double Clicking Family Shortcut


If you are modelling a space with alot of families in the model space, often times you may accidentally double click
families and enter the edit family window. This can take up some of your time, especially when this mistake happens
often during modelling. To avoid this issue, customize your double click shortcut key by clicking on the Revit icon on
the top left and clicking on Options. Under the User Interface tab, Click Customize under the Double Click Options
section. You can change the option from Edit Family to Do Nothing. Hit OK and Apply these settings. Now
whenever you double click a Family, it wont automatically open up the Edit Family window. Instead youll have to
click the Edit Family button at the top toolbar ribbon.

12View Ranges
If your views are now displaying parts of a model, or models created are disappearing from the modelling view, it is
most likely because it is outside of your specified View Range. To fix this, simply go to the Project Properties an
adjusting the View Range to a more wider range.

When viewing floor plans, you can change the view range under the Properties window and adjust it accordingly.
Anything outside of this range will be clipped from the plan.
13Detail Levels to Optimize Workability

When building Revit Families, creating different models for different Levels of Details can help in how fast the Revit
Model can function later on. When building a family, build a generic geometry such as a Box, Circle, or Linework to
represent the Object and have it sit on top of the Detailed Model. Select the Detailed Model and Group it as one
object. Under the Properties window, click Edit for Visibility and Graphics Overrides. Uncheck Coarse and
Medium and click OK. Now the Family will only show the detailed model when the Revit View is set to Fine Detail.
Similarly, select the Basic Geometric model mentioned earlier and edit its Visibility so that only Coarse and Medium
are checked. Now a simplified geometric model will be used in place of the detailed model when Revit Views are set
to Coarse or Medium. This can allow users to work on the Model Space quickly without the need for the computer to
process the detailed family model constantly.

14Aligning Plans on Revit Sheets


01.
Adding two reference lines that intersect can act as a point of reference when placing views on sheets.
02.
Draw detail lines on the sheets for the views to snap to when place on the
sheet. In this instance, we are snapping the floor plans reference line
intersection point onto the detail lines intersection. Detail lines can be copied
and pasted between sheets aligned to current view.
15Visibility Settings
You can specify representational colors for your models categorically
through your visibility settings. Under View>Visibility Graphics, you can
specify certain Revit families to be a certain color. Simply select the
necessary category and change the Lines/Patterns to your desired color.
You can be more specific by opening the tree down further and only specifying certain parts of the Family be a
certain color.

In the screenshot above, all ducts are set to show as red. This will only affect the view currently opened. If you
change views, this visibility needs to be set again. *Note: There is a difference between Projection & Cut Lines &
Patterns. Any views that cut through an object such as a wall would show the Cut Lines and Cut Patterns. Any
models that are visibly without being cut (such as in 3D views) will show the Projection/Surface Lines and Patterns.
16Linked Revit Files
Linking Revit Files are essential in using external models as references in order to detect clashes between models.
Make sure these Linked Revit Files are placed in the correct locations and are pinned down to ensure correct
referencing.

The difference between Linking and Importing is the ability to update. Linking a CAD or Revit file will allow the Revit
file to check the file and update if the reference file is changed at all. Imported files will not update and will stay the
same as when it was imported.
17Keyboard Shortcuts
Make an effort to learn the keyboard shortcuts for common commands in Revit. You may customize the shortcuts to
your preference, but it is suggested you learn the existing shortcut layouts so you can work interchangeably with
others easily.

18Working Between Views

Often times, you may not be able to fully comprehend a model in just a single view. You can view the model
sectionally by creating a section cut on the floor plan, or in 3D by going to View> 3D View. Use View>Switch
Windows to swap between views and use View>Close Hidden to close all the views when youre done. Note: Any
section cuts made will create a view under the Project Browser. Keep the Project Browser clean by deleting these
views afterwards if you do not intend to use them in the future.

01.
When you create a section view, you can right click the section line and click Go To View to directly open up the
corresponding section view.
02.
Adjusting the depth of view for the section using the drag-bar can control what is being cropped out of the section.
03.
Adjusting the drag-bar on the left and right will adjust what is being cropped in the section view.

Creating sections (and 3D Views) will create these views under the Project
Browser. If youre only doing this to view parts of the model and navigate
around, please delete these sections or 3D views afterwards to avoid clutter.
If you are going to utilize this view in the future, do not delete it.
19Input Numbers; Do Not Drag & Estimate!
When working with such familys as ducts, it is important to make sure these
dimensions are as precise as possible. If they are estimations, they should
still be set to a whole integer.
In the case seen to the left, the initial duct was set with dimensions that are
not rounded. Change these numbers to whole integets by selection the duct,
then clicking on the dimension number. This will allow you to change the
dimension to a set number. Press enter and this dimension will be adjusted.
20Create a Wall
Creating a wall or beam you can use the pick line if theres a given 2D CAD
dwgs instead of drawing/dragging it up to the length required. Prior to
selecting the line for the wall, set the location line to either exterior or interior
to ensure the walls created line up to the edge of the linework.
Create the wall and trim, align, or extend accordingly.

21Check Your Room Heights


Rooms are essential for scheduling, especially in a multi-discipline team. Unfortunately, rooms created in Revit often
dont go full height. Make sure they are the correct height by turning on a cut section and looking for the room fill.
Otherwise you can click on the room and set its height in the properties. This ensures all fixtures are correctly
assigned to the room and that the room is the right size for MEP calculations.
22Nudging Objects
If you need objects to move in a certain direction ever so slightly, but sacrifice precision, you can nudge them by
using the arrow keys with the object selected. The closer you zoom into the object, the finer the nudge will become.
Vice versa, as you zoom out, the nudge is greater. Holding Shift while nudging will increase the amount of nudge as
well.
23Importing CAD & Revit files to the Right Location
There are a variety of ways to import or link a Revit or CAD Drawing to Revit Model. One purpose for this is to
overlay different models on top of one another as reference. You have to, however, import to the correct location, or
else models wont overlay correctly. When importing a Revit or CAD file, it is best to use the Link Revit/CAD or
Import CAD commands found under the Insert Category of the top ribbon. Avoid Dragging and dropping, as this
will prompt you to manually specify the location where the referenced file will sit.

Once you have clicked one of these commands, you will be asked to select a reference file. Before actually

importing the file into the space, you will notice that there is a choice as to where to place this referenced file.

The selections do the following:


Auto-Center to Center
Based off the average centerpoint of everything in the referenced file, this point will be placed on the average
center point of the revit model space. The center point changes as models are changed, so it is not a reliable
positioning to use for overlaying files.
Auto-Origin to Origin
The referenced file will place its own origin point at the origin point of the revit file. This is useful in overlaying
referenced files if all of the models are located at the same location in relations to the origin point.
Auto-By Shared Coordinates
If you assign a coordinate to each model, the model will be placed exactly within its specified coordinates.
This is useful if the project has been set up initially to utilize a shared coordinate system.
Manual
All manual selection involved you manually specifying a point to place the referenced file. Manual-Origin will
ask you to manually place the referenced files origin point, while manual base point will ask you to manually
place the referenced file based off a selected based point. Manual-Center will ask you to manually place the
referenced file based off its center point.
In the end, it is best to use either Origin to Origin or By Shared Coordinates to overlay referenced files for
collaboration.
Revit Shortcuts
A

AA Align
AL Align
AP Group Objects
AS Align
C
CC Copy
CS Create Similar
D
DD Align Dimension
DE Delete
DI Dimension
DL Detail Line
DM Mirror From Drawn Line
DR Door
E
EL Spot Elevation
G
GP Group
L
LC Link CAD
LI Align
LR Line Model
M
MA Match Type Properties
MI Mirror
MM Mirror From Axis
MN Manage Link
MV Move
O

OF Offset
P
PB Project Browser
PI Align
PN Pin
R
RE Scale
RG Remove Object from Group
RM Room
RO Rotate
RP Reference Plane
S
SA Select All Instances
SC Snap Center
SE Snap End
SI Snap Intersection
SL Splits an Element
SM Snap Middle
SN Snap Nearest
SP Snap Perpendicular
SS Splice
T
TG Tag
TR Trim
TX Text
U
UG Ungroup
UP Unpin
V

VG Adjust Visibility Graphics


VP View Properties
VV View Manager
W
WA Wall
WN Window
Z
ZE Zoom Extents
ZO Zoom Out
ZX Zoom to Fit
ZZ Zoom in Region