You are on page 1of 19

EDEM Tutorial:

Conveyor Simulation

EDEM Tutorial: Conveyor

Copyrights and Trademarks

Copyright 2014 DEM Solutions. All rights reserved.

Information in this document is subject to change without notice. The software described in
this document is furnished under a license agreement or nondisclosure agreement. The
software may be used or copied only in accordance with the terms of those agreements. No
part of this publication may be reproduced, stored in a retrieval system, or transmitted in any
form or any means electronic or mechanical, including photocopying and recording for any
purpose other than the purchasers personal use without written permission.

DEM Solutions
49 Queen Street
Edinburgh
EH2 3NH
UK

www.dem-solutions.com

EDEM incorporates CADfix translation technology. CADfix is owned, supplied by

and Copyright TranscenData Europe Limited, 2007. All Rights Reserved. This software is
based in part on the work of the Independent JPEG Group. EDEM uses the Mersenne Twister

random number generator, Copyright 1997 - 2002, Makoto Matsumoto and Takuji Nishimura,
All rights reserved. EDEM includes CGNS (CFD General Notation System) software. See the
Online Help for full copyright notice.

EDEM EDEM Creator , EDEM Simulator , EDEM Analyst and Particle Factory are
registered trademarks of DEM Solutions. All other brands or product names are the property
of the respective owners.

Page 2 of 19

EDEM Tutorial: Conveyor

Introduction
Through this introductory tutorial we can learn how to set-up and analyze an EDEM
simulation. The exercise is directed at beginners to get a basic understanding of the
software.
The model used here is a conveyor belt that transports material to a hopper.
The main focus in on:

Creation of materials for Particles and Geometry.

Creation of Particles with a User Defined Size distribution

Creation a Particle Prototype from multiple spheres. The multi-sphere particle


shape is defined using particle CAD templates, which can be imported to
EDEM and manually filled with spherical particles.

Use of the Moving Plane contact model, which provides movement for the
conveyor belt.

Creation of bin groups in the Analyst to analyze particles and their properties
in specified regions.

Export of simulation data to a .csv (text) file.

1. Start EDEM.
2. Go to File > Save As
3. Select a location on the local machine (e.g. C:\EDEM_Tutorials).
4. Enter a file name (e.g. Conveyor_Tutorial.dem) and click Save.

Page 3 of 19

EDEM Tutorial: Conveyor

EDEM Creator: Setting up the model


Step 1: Set the Global Model Parameters
Choose the units
The first step in creating the model is to set the units used throughout EDEM.
1. Go to the Tools > Options menu and select the Units tab.
2. Change the following measurement units:

Angle to degrees (deg)

Angular acceleration to deg/s2

Angular velocity to deg/s

Length to mm

Mass to kg

Mass Flow Rate to kg/s

3. Click OK.

Enter the model title and description


The model title and description will appear in the Data Browser window.
1. Click on the Globals tab in the Tabs pane.
2. Enter the title Conveyor Model in the Title field in the Simulation section.
3. Enter the description in the Description field.

Set the contact models


The Physics section lists contact models and forces. A contact model describes how
elements behave when they come into contact with one another.
1. Select Particle to Geometry from the
Interaction drop-down list in the Physics
section.
2. Click the
button then select the Moving
Plane contact model.
3. Select Moving Plane in the list of models
then click the up button
, so that Moving
Plane is calculated before Hertz-Mindlin:

Page 4 of 19

EDEM Tutorial: Conveyor

Install the EDEM materials database


The materials database is supplied with EDEM, but it must be installed first.
1. In Windows go to Start > DEM Solutions > EDEM 2.6 and select Install
external libraries to My Documents.
2. When you navigate My Documents folder you will notice that new folder
EDEM_2.6.0 was created.
To make sure that the materials database is already available in your new simulation:
3. Go back to EDEM and navigate to: Tools > Options > File Locations.
4. In Materials Database section, click Browse button and go to EDEM_2.6.0
folder in My Documents.
5. Select materialsDB.ddb and click OK.
When you use EDEM later, the database would already be imported so you do not
have to install libraries every time you run EDEM.

Set the gravity and define the materials


Every particle or section of geometry used in a model is made of a particular
material. All materials and the interactions between them must be defined in the
Materials section.
1. Check that Gravity is set to -9.81m/s2
in the z-direction.
2. Click the
button in the Materials
section to create a new material.
3. Click the
button and rename the
material to rock. Click OK.
4. Set the Poisson's Ratio, Shear
Modulus and Density as shown below:
Now define the conveyor material. The conveyor is made of steel a material very
similar to the high-stiffness material defined in EDEMs materials database and it can
be transferred from there.
1. Click
the
Transfer
button.
The
Material/Interactions Transfer dialog will
appear
2. Expand the Materials tree in the
Materials Database window and select
high-stiffness.
3. Click the left arrow to copy the material
into your model. Click OK to close the
window.
4. Select the high-stiffness material and
click the
button to rename the
material to steel.

Page 5 of 19

EDEM Tutorial: Conveyor

Define the interactions between the materials


1. Select rock from the drop-down list at the top of the Materials section.
2. Click the
button in the Interaction section. Select rock when prompted.
This will define the interaction between elements both made of the material rock.
3. Set the coefficients as follows:

4. Click the Interaction


button again and select the material steel.
This will define interaction between elements made of rock with elements made
of steel.
5. Set the coefficients as follows:

Page 6 of 19

EDEM Tutorial: Conveyor

Step 2: Define the Base Particles


All types of particles used in a model are defined in the Particles pane. These are the
base or prototype particles.

Create a new particle type


1. Click the Particles tab.
2. Click the
type.

button in Select Particle section in order to create a new particle

3. Click the

button and rename the particle type to rock particle.

Define the surfaces and properties


Particles are made up of one or more spherical surfaces. In this case we import a
CAD template of a rock and fit 4 spheres to the template shape.
1. Select Tools > Options > Particle Display.
2. Click the Import button then import the particle template rock_particle.stl. This is
the mesh file to use as a particle template.
3. When Import Options dialog appears, set the measurement units to Millimeters
(mm) and click OK.
4. When the Geometry Import Parameters dialog appears, leave all the settings at
the default values and click OK.
If Quality was selected instead of Curvature, then a smooth mesh of much
higher resolution would be used, as can be seen below. Curvature is selected
here as the shape will be filled with spheres, therefore it does not need to be
perfectly smooth.

Curvature
5. Click the

Quality
button and rename the template to Rock Template then click OK.

Page 7 of 19

EDEM Tutorial: Conveyor


6. Go back to Particles tab in Creator panel.
Set the Radius of the surface to 18 mm and the Position X, Y, Z to (0, -3, 0) mm.
7. To view the template, go to Viewer Controls on the right of the screen. In
Particles section check the Show Template box:

8. Click the

button in the Surfaces section to create a second surface.

9. Set the Radius of this surface to 18 mm and the Position to be (-13, 0, 0) mm.
The second surface is offset from the first.
10. Check the Highlight Surface box in Viewer Controls section to be able to
distinguish the surfaces:

Page 8 of 19

EDEM Tutorial: Conveyor


11. Create a third surface, setting the Radius to 18 mm, the Position to (0, 4, 0) mm.

12. Create a final surface of Radius 18 mm and the Position (12, 0, 0) mm.

13. In Properties section, set the Material to rock.


14. Click the Calculate Properties button and pick the Imported Template option in
the dialog that appears.
When using the imported template option, mass, volume and inertia are calculated
from the CAD template. Alternatively you could use the Surfaces option to Calculate
Properties from the group of spheres.
15. Click OK.

Page 9 of 19

EDEM Tutorial: Conveyor

Step 3: Define the Geometry


Next step is to define the conveyor geometry used in the model.

Import the conveyor geometry


The conveyor geometry has been created in a CAD package and it is ready to be
imported into EDEM.
1. Click on the Geometry tab.
2. Click the Import button in the Sections part.
3. Navigate to the file conveyor_hopper.stl and import it.
4. When prompted to, set the Units of measurement to Millimeters.
5. When the Geometry Import Parameters dialog appears leave all the settings at
the default values and click OK.
The conveyor will appear in the Viewer. It is made up of five sections, which are
listed in the Sections drop-down list. When any is selected it is highlighted in red.
6. Select and rename each section in the drop-down list. Name them appropriately:
guide_1,
guide_2,
belt_top
lower_hopper,
hopper
7. In Details tab, set Type to Physical and change the Material to steel for all
sections.

Configure the moving plane


The conveyor model uses the Moving Plane contact model. This model simulates a
linear motion of a geometry section, where the whole section moves at the same
velocity. The contact model adds this linear velocity to the velocity of the geometry
section only within the contact model. In other words, the geometry section does not
actually move.
1. Go back the Globals tab.
2. Select the Moving Plane contact model then click the configure button

3. In the dialog that appears, click the


button to add the belt_top as the moving
plane. Set the Linear Velocity as follows and click OK.

Page 10 of 19

EDEM Tutorial: Conveyor

Create the particle factory plate


Particle factories are used to define where, when and how particles appear in a
simulation. All factories must be based on a section of geometry (whether 'real' or
'virtual'). This defines the area or volume in the model that produces the particles.
1. Return to the Geometry tab.
2. Click the

button in the Sections section and select Polygon.

3. Click the

button and rename the section factory_plate.

4. Click on the Details tab and set the type to Virtual, since the plate is not a
physical part of the machinery.
5. Click on the Polygon tab and set the Number of Edges, X/Y/Z Center and
Dimensions of the polygon as follows:

Page 11 of 19

EDEM Tutorial: Conveyor

Step 4: Create the Particle Factory


Particle factories are used to define where, when and how particles appear in a
simulation.

Create the particle factory


1. Click on the Factories tab.
2. Click the

button to create a new factory.

Set the factorys particle creation values


In this model, rock particles are to be created at a rate of 50 kg per second.
1. Set the Factory Type to dynamic.
2. Select Total Mass and set the value to 500 kg.
3. In the Generation Rate section, select Target Mass and set the rate to 50 kg/sec.

Set the factorys initial parameters


1. In the Parameters section, select the factory_plate from the Section pull-down.
2. Set the Size to user defined and click the configure button
Defined Size Distribution box
3. Select the

to open the user

button 4 times and input the following distribution, followed by OK:

4. Set the Position to random to ensure that the particles are randomly created over
the entire plate area.
5. Set the Velocity to fixed and click the configure button
direction to -2 m/s.
6. Select File > Save.

Page 12 of 19

to set the velocity in z-

EDEM Tutorial: Conveyor

EDEM Simulator: Running Simulation


Once the model has been set-up in the Creator we move to the Simulator to run it.
1. Click on the Simulator button

on the toolbar.

Step 1: Set the Time options


Set the time step
The time step is the amount of time between iterations (calculations) in the Simulator.
The particles in this model are loosely packed for the majority of the simulation, so
set a time step of 0.00015 s (~19% of the Rayleigh Time Step). To find out more
about Rayleigh time step, refer to Appendix A: Estimating Simulation Time of the
EDEM Help.
1. Set the Fixed Time Step lower box to 0.00015 s. The percentage of Rayleigh time
step would be calculated automatically.

Set the simulation time and data write-out frequency


The simulation time is the amount of real time your simulation represents.
1. In Simulation Time section, set the Total Time to 10s.
2. Set the Target Save Interval to 0.02s to specify write-out frequency.
It is not usually necessary to write a data point for every iteration in a simulation.
Doing so would result in a slow simulation and a very large amount of data being
collected.

Step 2: Set the Grid options


The grid options are used to optimize the simulation.
1. Set the Cell Size to 3 Rmin. (Rmin = smallest particle radius in simulation)
Note the number of grid cells (Approx. Number of Cells) is stated below. The
simulation results are not affected by the number of grid cells, only the time taken to
reach them. The more grid cells a simulation uses the more system RAM is required.
It is necessary to find a balance between RAM usage and simulation performance.
For simulations with a narrow size distribution the ideal value will be between 2 3
Rmin, but for wider size distributions this will increase.

Step 3: Run the Simulation


You are now ready to start the simulation.
1. Click the start Progress button

at the bottom of the simulation window.

2. In Viewer Controls, click the Refresh Viewer button or enable Auto Update at
any point to update the Viewer and see how the simulation is progressing.

Page 13 of 19

EDEM Tutorial: Conveyor

EDEM Analyst: Analyzing Your Results


The Analyst is used to review, examine and analyze the results of the simulation.
1. Click on the Analyst button

on the toolbar.

2. Use the controls below the main window to rewind the simulation to the first timestep.
3. Click the play button to play through each time step of your simulation.

Step 1: Configuring the Display


The options in the Model pane are used to configure how the different elements in
your model appear.

Configure the geometry


1. Click on the Model tab to open the Model pane.
2. Experiment with altering the geometry display: For example, try making the
hopper transparent, the guides a mesh and the belt fully opaque. To do that in
Geometry section change Type and then modify the Display options. Display
Mode can be chosen to be Filled, Mesh or Points. The Opacity can take values
0-1, with 0 being completely transparent and 1 being solid.
3. Before finishing, make sure the factory_plate Display box is unchecked, so it is
not visible in the Viewer.
4. Other sections should be displayed as Filled with 0.5 opacity.

Configure the particles


The display of the particles can be altered in a similar way to that of the geometry. In
addition, the particles can be represented using a number of different forms. One
such form is the template originally used to create the particle.
1. In the Particles section of the
Model tab, select Template
from the Representation pulldown menu.
2. Click the Options button then
set the Template to Rock
Template.
3. Click OK to close the dialog,
then click Apply.
In large simulations, a template
representation can put a high
demand on system resources.
4. Watch the simulation step by
step, zooming at particles.
5. Set the Representation back to Default before proceeding and click Apply.
6. Watch the simulation.
Page 14 of 19

EDEM Tutorial: Conveyor

Step 2: Coloring Elements


The particles, geometry and contacts within your model can be colored in a variety of
ways. Any section of geometry, particle, contact type or selection group can be
colored independently.

Color the particles according to their mass


1. Click on the Coloring tab to open the Coloring pane.
2. In the Select Element section, set:

Element to Particle

Color by to Type

Type to All

3. In the Attribute Coloring section, set the Attribute to Mass.


4. Set the Min, Mid and Max colors to the Blue, Green and Red respectively.
5. Click the buttons
next to the Min and Max Value fields this reads the
current values from the point in the simulation being displayed in the Viewer at
the moment. Unselect Auto Update and set Min to 0 kg and Max to 0.8 kg.
6. Click the Apply button to color the particles.
7. Check the Show Legend checkbox then click Apply.
8. Click the Play button to view the distribution of mass over time.
Notice that in the picture below, the color of geometry has been changed to Dark
Grey.

Page 15 of 19

EDEM Tutorial: Conveyor

Step 3: Creating Selections


Selections allow data to be extracted from a particular area or element in the domain.
Using selections, you can monitor any element passing through a particular area
(known as a bin) or track particular elements when they move within the domain.
You can then display, color, graph or export data based on the selections.

Create a grid bin group


We can compare the total mass of particles that fall off the end of the conveyor belt
with mass of particles falling out at the bottom of the lower hopper. To do so, create
two grid bin groups each containing one bin.
1. Click on the Selection tab.
2. Click the

button then select Grid Bin Group. Rename it Conveyor_group

3. Set the properties of the bin group as follows then click Apply:

4. Click the
button one more time to create a second Grid Bin Group. Rename
it Hopper_group.
5. Set the properties of the bin group as follows then click Apply:

Page 16 of 19

EDEM Tutorial: Conveyor

Define selection group queries


A query is used to define a single element attribute, for example particle velocity,
total force on a geometry section or number of collisions. To compare the total mass
of particles passing through the first bin group with the number passing through the
second:
1. Set the Current Time (using the control in the top of the Viewer Control pane at
the right of the screen) to about 5s. This is the last time-step before any particles
leave the conveyor belt.
2. Select the Conveyor_group from the drop-down list.
3. In the Options section click the Queries Edit button:

The Selection Query Editor is displayed.


4. Expand the Particle tree then select Mass.
5. Set Type to rock particle and Query Type to Total.
6. Select the Total Over Time option then click the
displayed in the list at the bottom of the dialog:

button. The query is

7. Click OK.
8. Repeat the above steps to define an identical query for the Hopper_group.

Page 17 of 19

EDEM Tutorial: Conveyor

Set selection group display options


1. Select the Conveyor_group from the drop down list then in the Representation
section, click the Display Options Edit button.

The Display Options window is displayed.


2. Tick the On Screen Query checkbox to display the mass in the viewer:

3. Repeat the above steps to for the Hopper_group.


4. Click the play button to view the results in real time. As playback continues
through the time-steps, bin group data is collected and displayed.

Page 18 of 19

EDEM Tutorial: Conveyor

Step 4: Extracting Data


Data collected during your simulation can be exported for analysis. Data can be
exported from a single time step or a range of time steps; from all elements in a
model or just from a selection or bin group.

Create an export configuration


1. Select File > Export > Results Data. The Export Results Data dialog will appear.
2. Click the
button to create a new configuration. A single configuration can
contain multiple queries and can be reused at any point in your model.
3. Set the Export format to Text to extract data to a .csv file.
4. Enter the file name Conveyor then set the save location to the tutorial folder.

Define a query to export bin group data


Export Total Over Time queries for each bin group.
1. In File > Export > Results Data dialog, go to General tab.
2. Tick the Output Averages, Maximums, Minimums and Totals in Columns
checkbox.
3. In Time Steps section, uncheck All then set the range to start at about 5s.
4. Click the Queries tab to open the Queries pane. This is where you define the data
to be exported.
5. Click the

button to create a new query.

6. Click on the Particle element in the list then select Mass.


7. Select Conveyor_group as the Selection.
8. Set the Type to rock particle and Query Type to Total Over Time.
9. Repeat the instructions 5-8 to add a second query for the Hopper_group.

Export the data


1. Click the Export button to export the data to the pre-defined file.
2. Open the file in an external application (such as a spreadsheet) and review the
data.

Page 19 of 19