P. 1
Gambit Lect 01

Gambit Lect 01

|Views: 595|Likes:
Published by Daud Simon A

More info:

Published by: Daud Simon A on May 28, 2010
Copyright:Attribution Non-commercial Share Alike

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

08/12/2013

pdf

text

original

Fluent User Services Center www.fluentusers.

com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Introduction to GAMBIT

1-1

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Agenda Day 1
8:00 Introduction + Demo 9:15 Tutorial 1: Creating and Meshing Basic Geometry 9:45 Creating Geometry in Gambit 10:45 Tutorial 2: Geometry Creation Exercises 12:00 Lunch 1:00 Edge/Face Meshing and Mesh Quality 2:00 Tutorial 3: Edge and Face Meshing Exercises 2:45 Volume Meshing and the Sizing Function

3:45 Tutorial 4: Volume Meshing and Sizing Function Exercises 4:30 5:00 Volume Decomposition Examples Break for the Day

1-2

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Agenda Day 2
8:00 Tutorial 5: Volume Decomposition Exercises 8:45 Mesh Control through Boundary Layers and Face Vertex Types 9:30 Tutorial 6: Vertex Types 1:00 10:30 CAD/CAE Import and Geometry Cleanup + Demo 11:30 Tutorial 7 or 8: Geometry Import Exercise 12:00 Lunch
1-3 © Fluent Inc. 8/9/02

1:00 1:30

Tutorial 7 or 8: Continued Tutorial 9: Hex meshing the Flow Probe Work on your own Project or Tutorial 7 or 8: Continued G/Turbo + Demo

3:00

1:30

3:00 Work on your own Project 5:00 Break for the Day

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

What is GAMBIT?
u

A single, integrated preprocessor for CFD analysis:
l

Geometry construction and import n Using ACIS solid modeling capabilities n Using STEP, Parasolid, IGES, etc. import
s

Cleanup and modification of imported data

l

l l

Mesh generation for all Fluent solvers (including FIDAP and POLYFLOW) n Structured and Unstructured hexahedral, tetrahedral, pyramid, and prisms. Mesh quality examination Boundary zone assignment

1-4

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Operation
u

General sequence of operations
l

l

l

l l

l

Initial setup n Solver selection, Mesh size, Defaults, etc. Geometry Creation (ACIS, STEP, Parasolid, IGES or Mesh import) n Create full geometry n Decompose into mesh-able sections Meshing n Local meshing: Edge and Boundary layers n Global meshing: Face and/or Volume Mesh examination Zone assignment n Continuum and Boundary attachment Mesh export

1-5

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Files (1)
u

GAMBIT directory and files l When GAMBIT starts up, it creates a directory called GAMBIT.# n # = the process number n It also creates a “lock” file, ident.lok, in the working directory n ident.lok prevents any user from starting up another session using the same identifier in the same directory. If the code crashes, this file needs to be manually removed. l Three files are created inside this directory n ident.dbs = the database. All information will be saved in this file. This file is NOT retrievable upon a crash
n

jou trn

= =

the journal file. This file is directly accessible from the Run journal form the transcript file. Output from GAMBIT

n

1-6

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Files (2)
u

GAMBIT directory and files l GAMBIT permanently saves these files to your working directory as ident.dbs, ident.jou and ident.trn anytime you issue a “Save” option (equivalent to any standard word processor) n Upon Save, earlier versions of ident.dbs and ident.trn will be overwritten, while new commands are appended to the file ident.jou
l

Upon successful exit of GAMBIT: n The directory GAMBIT.# is removed n The lock-file ident.lok is deleted

1-7

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Startup: DEMO
u

Start gambit with “gambit filename”
l

NT Users must start Gambit this way from a command prompt.

Before save

u

u

Example: Start Gambit in directory “projects” > gambit airfoil

After save

1-8

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Journal Files
u

Journal File:
l

l

Executable list of Gambit commands n Created automatically by Gambit from GUI and TUI. n Can be edited or created externally with text editor. Journals are small - easy to transfer, e-mail, store Can be parameterized, comments can be added Easy recovery from a crash or power loss edit existing commands to create new ones

u

Uses:
l l l

1-9

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Running Journal Files
u

Journal files can be processed in two ways:
l

l

Batch mode (Run) n All commands processed without interruption. n “read pause” command will force interrupt with resume option appearing. Interactive mode (Edit/Run) n Includes text editor for easy modifications
s

s s

s

Mark lines in process field to activate for processing. Editable text field. Right click text field for more options. Auto or Step through activated process lines.

1-10

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Journal File: Parametric Modeling
u

Parameters (incl. arrays), control-blocks, do-loops, arithmetic functions, etc., can be used in the Journal File for simplifying parametric studies.

Parameter names begin with $

Commands are not case sensitive

Comment lines

1-11

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

GUI
Main Menu bar Operation toolpad

Command line

Description window
1-12

Global Control
© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Operation Tool Pads

Vertex Edge Face Volume Group

Boundary Layer Edge Face Volume Group

Boundary Types Boundary Entity Continuum Types Continuum Entity

Coordinate Systems Sizing Function G/Turbo User-Defined Tools

1-13

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

File Menu (1)
u

New, Open, Save, Save As and Exit
l

Standard form of database operations Prints graphics to printer or to file PostScript, BMP, TIF, etc. Screen editor/command processor for journal files Command processing: n Partial or global selection/de-selection n Automatic or stepwise processing Ability to load the current journal File browser Clean Journal removes unnecessary tags, undo’s, etc.
1-14 © Fluent Inc. 8/9/02

u

Print Graphics
l l

u

Run Journal / Clean Journal
l l

l l l

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

File Menu (2)
u

View File
l

l

View of the current output,ident.trn, the transcript file Ability to view other files as well
ACIS, Parasolid IGES, STEP ICEM Input, Vertex Data CAD - Pro/E, Optegra Visualizer, I-DEAS FTL Mesh - mesh and faceted geometry files. ACIS, Parasolid IGES, STEP Mesh - Export your mesh for your Solver. n 2D option guarantees 2D mesh
1-15 © Fluent Inc. 8/9/02

u

Import
l l l l l

u

Export
l l l

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Edit Menu (1)
u

Edit Title
l

Title will be included on any printed graphics Ability to launch an editor within GAMBIT Ability to define, modify and list parameters n parameters: $numeric = 10, n arrays: $array(3,4) = 5 Parameters and arrays can also be directly defined in the journal file using an editor (preferred option)

u

Edit File
l

u

Edit Parameters
l

l

1-16

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Edit Menu (2)
u

Edit Defaults
l

l

Modify a large range of defaults that effect: n User Environment n Meshing Characteristics n Geometry Ability to load, modify and save a new set of defaults in $HOME/GAMBIT.ini which is loaded automatically at startup. Ten levels of undo/redo (default) Reducing number of levels also reduces memory requirements.

u

Undo/Redo
l l

1-17

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Solver Menu
u

The Solver selection will have an impact on the following input forms:
l l l l l

Available meshing algorithms Available element types Continuum types Boundary types Export mesh file

1-18

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Graphical User Interface
u

Command:
l

Input of (non-GUI) commands, e.g., n reset: deletes all mesh and geometry in the current model n reset mesh: deletes mesh, keeps geometry Gives a short description of all global function buttons and screen areas Output from GAMBIT is printed here as well as in ident.trn Transcript window can be expanded using arrow button in top right corner

u

Description
l

u

Transcript
l l

1-19

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Global Control (1)

Scale-to-Fit

Orient Model Journal View

Pivot anchor for view manipulation Modify (on/off) Label Visibility Rendering Show mesh Silhouette

Four split Four view Wire frame Shade Hidden Line

Light source Undo/Redo Special Labels Annotate Color coding Examine Mesh Entity type Connectivity

1-20

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Global Control (2)
u u

Scale-to-fit resizes the model to fit the screen Orient Model - major axes , isometric and:
Reverse Previous Journal view

u

Select Pivot - around which the model rotates, zooms
Body center Mouse position

u

Model display attributes
l

Turn on/off visibility, label, silhouette, mesh and hidden line on all or selected geometrical entities 4-view and 4-split Options to return to any single view
1-21 © Fluent Inc. 8/9/02

u

Preset configuration of the graphics window

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Global Control (3)
u

The Window Attributes form
l

l

Modify the following attributes (defaults given) n Render Wireframe on ; shaded and hidden off n Mesh Volume - off n Silhouette All on n Label All off n Visibility All on Two ways of picking entities n “All” - All entities are picked (Default) n “Pick” - Individual picking including the use of pick lists

1-22

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Global (4)
u u

Render Model - Wireframe Modify Light/Label type

, Shaded

, Hidden

Change light source orientation and properties Additional information on the entity label Insert arrows and text for graphic presentations
u

Color Mode
Color by entity Color by connectivity

u

Undo/Redo

u

Examine Mesh
l

Display different element types by quality, plane cuts, etc.
1-23 © Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Forms (1)
u

Form - components
l

l

l

l

l

l

List box - (picking) n active (yellow) - ready to pick n inactive (white) - click to activate Radio buttons n mutually exclusive options Option button n Option menu Text box n Click-to-focus Check box n non-mutually exclusive options Command buttons

1-24

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Forms (2)
u

Text box

l l

l

Field for input of data, expressions, parameters The cursor is blinking if active n To activate - left click in the text box (click-to-focus) Forms with several text boxes n The order of input is not important n Use “tab” to go to the next text box n Use left click (click-to-focus) to go to any text box

1-25

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Forms (3)
u

List box
l

l

l l

Highlighted in yellow if active n To activate - left click in the list box Tells you the name of the latest picked item n The item is highlighted in red on the screen n All previously picked items are pink Individual pick lists for each list box Forms with several list boxes: n Depending on the form, the order of picking may be important n Use Shift right-click to go to the next list box n Use left click (in the list box) to go to any list box

1-26

© Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Forms (4)
u

Pick Lists
l

Open the Pick List by clicking on the arrow

l l

The “Available” list is sorted in the order of picking Pick List functionality: n Pick or Un-pick, Selected or All entities by highlight in left column and by clicking on the arrows n Highlighted “picked” entities will appear red on the screen
s n

edge.32, edge.33 edge.26, edge.28

Non-highlighted “picked” entities will appear pink
s

n n

Right-click in lists area provides additional options Filter can be used to control which objects are picked.
1-27 © Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Mouse Operations (1)
Left Drag Shift + Click Double Click Ctrl x-y rotation Pick Middle Translation Next Previous View Drag zoom Stretch zoom Right Zoom/ z-rotation Accept/Next picker Save view to journal Click points to grid

You can toggle between picking with or without “Shift”:
Keep right mouse button down while doing a “left-click” The cursor now changes to another symbol Now, Pick/Next/Accept do not need a “Shift” The Rotation/Translation/Zoom now needs a “Shift”
1-28 © Fluent Inc. 8/9/02

Fluent User Services Center www.fluentusers.com

Introductory GAMBIT Notes GAMBIT v2.0 Jan 2002

Mouse Operations (2)
u

The picking philosophy: Left - Middle - Right
l

l

Shift-Left: initial pick n Alternative: click and hold, drag diagonally to pick several items at the same time - “window picking” n The latest pick is highlighted in red, previously picked items are highlighted in pink Shift-Middle: modify pick n The middle pick will behave differently depending on the mouse location:
s s s

Same: New: Bad:

Cycle to the next available object within picking tolerance Replace last pick with new pick at new location A Shift-Middle pick on “nothing” is equivalent to “Un-select last pick”

l

Shift-Right: Apply or go to the next list box

1-29

© Fluent Inc. 8/9/02

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->