You are on page 1of 11

なでじゃこのアレ

なでじゃこ 0.1
最終更新日  2005 年 3 月 23 日
なでじゃことは

「なでじゃこ」とは、日本語プログラミング言語
「なでしこ (http://nadesi.com/) 」の 言語仕様
をもとに開発されている Java VM 上で動くス
クリプト言語です。
言語仕様
文字列について
文字列と判断されるのは以下の書き方です。

書き方 展開
「なでじゃこ」 展開できる
『なでじゃこ』 展開できない
" なでじゃこ " 展開できる
` なでじゃこ ` 展開できない

括弧の中に数字が記述されていても、それは文字として判断します。
そして、文字列の中に「展開」というものがあります。
例えば以下のような記述ができ、 { ・・・ } で挟まれたものが展開されます。

言語は「なでじゃこ」
「これは { 言語 } でできています」と表示

果は「これはナデジャコでできています」と表示されます。
展開ができるのは「・・・」と " ・・・ " のみです。『・・・』と ` ・・・ ` は展開できませ
文字列中の特殊記号について
特殊記号も { ・・・ } で挟みます。以下のような書き方になります。

「こんにちわ { 改行 } さようなら」と表示

文字列中の連結について
文字列の連結は「+」もしくは「&」で可能です。

挨拶は「こんにちわ」+「さようなら」
挨拶は「こんにちわ」&「さようなら」
数値について
なでじゃこが使うことができるのは、整数と実数です。
例えば、以下の表記は数値として扱います。

書き方 内容 半角全角
100 普通 半角
100 普通 全角
1.01 小数点あり 半角
1.01 小数点あり 全角
0100 先頭「 0 」 半角
0100 先頭「 0 」 全角
単位コメントについて
また、なでじゃこはコメント的に単位を記述することができます。
例えば以下のように書くことができます。

1個+3個を表示
以上の計算の結果は「 4 」と表示されます。以下はコメント的単位です。

トル、ドット、つ目、つめ、個目、個、円、つ、本、冊、 px 、 pt 、 cm 、 mm 、 m 、 kg
単位コメントは、ユーザによって定義が可能です。
そのときは「 nadejako.properties 」の
「 unit.comment.dictionary 」の値を
使用したい設定のファイルに書き換えます。
【 nadejako.properties の例】
unit.comment.dictionary=conf/UserUnitComment.txt

【 UserUnitComment.txt の例】

セット

以下、技術資料
なでじゃこのアレの関係
単語の区切り方
リンゴは10
0。
リンゴを表示。

【構文木】 リンゴ × 2を表
示。 × 表示
は を

リンゴ 100 リンゴ 表示 リンゴ 2


天気は「晴れ」
もし、天気が「晴れ」ならば
   「洗濯物を干す」と表示。
違えば
   「洗濯物は干さない」と表
示。