P. 1
Ta Mpls Finish

Ta Mpls Finish

|Views: 58|Likes:
Mohon cacian makiannya :D
Mohon cacian makiannya :D

More info:

Published by: Harry Chan Putra. SP. MTCNA. MTCTCE. MTCRE on Sep 06, 2010
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

09/06/2010

pdf

text

Dalam pengerjaan tugas akahir ini adalah usaha untuk mengumpulkan informasi optimasilasi network VPN dengan menggunakan

konsep network MPLS / VPLS serta sekayasa network traffic. Untuk menjelaskan bagaimana MPLS bekerja penulis menjelaskan dan mepraktekan logic MPLS/VPLS di network VPN PLN WILAYAH SUMBAR di PT. Telkom Tbk. MPLS/VPLS yang menggunakan cisco router dengan mengimplementasikannya menggunakan mikrotik router board adalah tahapan di mana paket data di label dengan secara unik dan di distribusikan secara labeling. Dalam Tugas akhir ini penulis menggunakan ROUTER BOARD 4 router Mikotik RB 750 G ada yang terkoneksi dengan antarmuka jaringan dan 4 memori 32MB harus mampu melakukan pekerjaan itu. PE-D1-PD ± PE-D-SLK adalah Provider dalam hal ini PT. Telkom. Tbk. (MPLS Backbone) router. PLN_PADANG ± PLN_SOLOK adalah merupakan router costumer. Setiap router setup dengan adaptor lobridge loopback yang memegang alamat loopback. Dari kita bisa melihat ini melayani 2 tujuan: * Karena hanya ada satu sesi LDP antara setiap 2 router, tidak peduli berapa banyak link yang menghubungkan mereka, alamat loopback IP memastikan bahwa sesi LDP tidak terpengaruh oleh negara interface atau perubahan alamat * Penggunaan alamat loopback sebagai alamat transportasi LDP memastikan hop kedua dari belakang muncul perilaku yang tepat ketika beberapa label yang melekat pada paket seperti dalam kasus MPLS. Analisa tugas akhir penulis menerapkan konsep MPLS network yang digunakan PT. PLN WILAYAH SUMBAR menggunakan CISCO router dengan PROVIDER PT. TELKOM. Dengan budget yang besar menggunakan CISCO router di alternatifkan dengan penggunaan router murah dari MIKROTIK.COM yaitu rb 750 g. TOPOLOGI NETWORK

untuk konfiigurasi layanan di gunakan 2 router rb 750 sebagai router pe yaitu pe-d1-pd berada di kantor Telkom padang , pe d1-slk berada kantor telkom solok , dan 2 router sebagai costumer router bearada disisi padang dan solok. Konfigurasi perangkat di sisi pe nya yaitu :

Konfiguasi detail PE-D1-PD Lankah pertama adalah jalan kan program winbox.exe dapat di download di websitenya mikrotik.com atau mikrotik.co.id. Arahkan moouse kea rah browser di tombol konek di winbox akan terbaca mac address dari router, setelah itu klik konek.

10.1.0.1/ 24

10

P LN Wilayah P adang 192.1

1. Konfigurasi Nama Router Setelah masuk kedalam router keluar menu winbox router yang isinya interface, ip, ppp, switch, bridge, mesh, ip, mpls, vpls, routing, system, quee, file, log, radius, tools, newterminal, meta router, metasupport, manual dan menu exit.

Langkah selanjutnya adalah pemberian nama router.

Klik menu system -> identify kana keluar toolbox identify, dalam toolbox aka nada tulisan mikrotik secara default, ganti namanya sesuai dengan nama router yang kita inginkan contoh PE-D1-PD sesuai gambar diatas. Atau secara command line bisa di lakukan dengan command :

/system identify set name=PE-D1-PD dengan awalnya ambil menu new terminal di winbox lalu di ketikan command tersebut.

2. Konfigurasi interface loopback dan ip address. a. Konfigurasi interface loopback ( bridge )

Kliklah menu bridge di router akan keluar diaglog menu bridge . selanjutnya klik tanda (+ ) pada bridge, akan keluar menu dialog interface bridge. Ganti nama bridge1 dengan nama loobridge setelah itu klik ok, sesuai gambar diatas. . Atau secara command line bisa di lakukan dengan command : /interface bridge add name=lobridge interface ini di gunakan untuk

penandaan id di routingan dynamic ( OSPF, BGP, RIP ). dengan awalnya ambil menu new terminal di winbox lalu di ketikan command tersebut.

b. Konfigurasi ip router Klik menu ip pada router dan pilih selanjutnya addresses akan keluar menu dialog addresslist kemudian klik tombol ( + ) ,akan keluar menu dialog new address, setelah itu masukan ip address router PE-D1-PD sesuai dengan gambar berikut.

Ip yang di alokasikan untuk router pln solok adalah 10.1.0.254/24 untuk interface kearah router PLN PADANG ( ether3 ), ip 10.255.255.1/30 untuk interface router PE-D1-SLK ( ether1 ) untuk interface lobridge dengan ip 10.255.255.1/32. Atau sacara command line bisa di ketikan di menu new terimal dengan command berikut ini .

/ip add address=10.0.255.1 netmask=255.255.255.252 interface=ether1 /ip add address=10.0.255.5 netmask=255.255.255.252 interface=ether2 /ip add address=10.1.0.254 netmask=255.255.255.0 interface=ether3 /ip add address=10.255.255.1 netmask=10.255.255.1 interface=loopbridge 3. Setting routing dynamic router PE-D1-PD dengan OSPF Konfigurasi routingan menggunakan dynamic routing ospf dengan area id backbone ( 0.0.0.0.0 ). Langkah awal adalah klik menu routing dan ambil submenu OSPF, akan keluar menu dialog OSPF sesuai dengan gambar berikut ini

Selanjutnya tentukan routing id OSPF dengan area name backbone dan id ( 0.0.0.0.0 ) di menu area di menu dialog OSPF. Klik tanda (+) akan keluar menu dialog OSPF Area < backbone.

Langkah selanjutnya adalah menetapkan router id sebagai penanda router di jaringan. Alokasi id nya adalah alokasi ip yang digunkann untuk lobridge. Dan pilih redistribute default routenya dengan nilai never dan redistribute connected routenya as type1 Seperti gambar berikut ;

Secara command line di new terminal bisa di ketikan command berikut /routing ospf set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.1. selanjutnya menetapkan OSPF network router PE-D1-PD. Network OSPFnya di distribusikan oleh router pe-d1-pd dengan alokasi ip 10.1.0.0/24, 10.0.255.0/30, 10.0.255.4/30, 10.1.0.0/24, 10.3.0.0/24 sedangkan ip dari router PE-D1-PD ke PE-D1-SLK secara direct di alokasikan 10.0.255.1/30 di interface ether1. Pada menu network di menu dialog OSPF di klik tanda ( + ), masukan network area dari OSPF router PE-D1-PD adalah ip 10.1.0.0/24, 10.0.255.0/30, 10.0.255.4/30, 10.1.0.0/24, 10.3.0.0/24. Dapat di dilihat di gambar berikut :

Atau secara command line bisa di ketikan command di new teriminal berikut ini /routing ospf network add area=backbone comment="" disabled=no network=10.0.255.0/30 add area=backbone comment="" disabled=no network=10.0.255.4/30 add area=backbone comment="" disabled=no network=10.1.0.0/24 add area=backbone comment="" disabled=no network=10.3.0.0/24 . Setelah routingan OSPF di create di kedua sisi baik disi PLN PADANG, PE-D1-PD dan PE-D1-SLK akan di infomasikan pada sub menu interface di menu OSPF neighbournya akan terbaca dengan dalam bentuk angka 1 jika nilainya 0 berarti OSPF kita belum jalan

sempurna pastikan konfigurasi network backbone dan area idnya sudah benar. Pada gambar berikut di informasikan OSPF routingan kita sudah ok dan jalan, sesuai dengan gambar berikut ;

Dari gambar diatas digambarkan infomasi OSPF berjalan seacara dynamic ( D ) di interface ether1,2 dan 3 yang direct langsung dengan interface kea rah router PE-D1-PD. Jika koneksi OSPF sudah jalan dengan baik akan di dapatkan di sub menu neighbournya dengan terbacanya router2 lain yang terknoksi ke routingan OSPF. Bisa di lihat pada menu Neigbhors di menu OSPF dialog.

Gambar di atas router PLN PADANG menerima routingan OSPF dari router PLN PADANG dengan router id 10.255.255.4 dengan ip direct dengan PE-D1-PD 10.1.0.1/24. Routingan OSPF broadcast melui PLN SOLOK ( 10.0.255.6 ) dan PE-D1-SLK (10.0.255.2 ). Jika koneksi OSPF sudah jalan dengan baik akan di dapatkan di sub menu neighbournya dengan terbacanya router2 lain yang terknoksi ke routingan OSPF.

Dengan terdistribusinya informas neighbour antar router ini berdasarkan protocol link state advertisement ( LSA ) di OSPF routing router akan didistribusikan semua sehingga routigan berlajan secara dynamic.

Dari gambar diatas di gambar routingan antar router yang menggunakan routingan OSPF. Lebih detail lagi dapat kita lihat pada menu routers di menu dialog OSPF, dapat dilihat dari gambar berikut ini ;

Dengan routingan berjalan baik maka router juga menginformasikan border router yang ada di network.

4. MPLS Setting Langkah pertama adalah dengan klik menu MPLS dan akan keluar menu dialog MPLS seperti gambar berikut ini.

Langkah selanjutnya tetapan interface yang digunakan sebagi media pendistribusian MPLS. Yaitu interface yang direct langsung ke PE-D1-PD ( ether1 ) di router PE-D1SLK dan ether3 ke router PLN PADANG, dengan cara mengklik (+) pada menu LDP Interface di menu dialog MPLS. Sesuai dengan gambar berikut ini :

Secara command line penetapan interface LDP bisa di ketik di new terminal dengan perintah /mpls ldp interface interface=ether1 /mpls ldp interface interface=ether2 /mpls ldp interface interface=ether3 Selanjutnya tetapkan LDP setting agar informasi mpls terdistribusi dengan baik. LDP akan menginfomasikan peering antar router. Hal ini dapat juga menginformasikan forwarding routing mpls dengan terdistribusi label paketnya secara remote dan local, dengan menginformasikan LSR id dan transport ip menggunakan ip lobdrige router PED1-PD . dapat dilihat dari gambar berikut :

Jika semua LDP telah terdistribusi akan di infomasikan LDP router router lain di network juga. Dapat dilihat dimenu LDP neigbour pada gambar berikut ;

Setalah berjalan normal MPLS settingnya akan dapat kita lihat infomasi LDP terdistribusi dengan baik pada menu forward table, local bindings dan remote bindings.

Pengujian Pada forward table di infomasikan label MPLS yang merupakan label paket data di switching dengan sesuai pengalamatan paketnya. Sesaui gambar beikut ini.

Pada gambar diatas paket data telah terlabel di dalam router PLN SOLOK yang di forwadkan ke PE-D1-SLK begitu juga sebaliknya. Label paket yang di fowardkan anataralain 22± 20 dengan next hop router PE-D1-SLK ke PLN SOLOK , 23 ± 21 dengan next hop router PE-D1-SLK ke ip Lan PLN SOLOK, paket yang tidak di label ke luar tidak akan di forwadkan ( distribusikan ) . Pada menu local bindings diinfomasikan paket data yang dilabel terdistribusi dari router sisi lain ( baik itu router CE dan PE ) ke local router ( PE-D1-PD) dan ada juga yang tidak terdistribusi.

Pada gambar di atas di infomasikan bahwa label data 20,21,22,23,24 dan 25 akan di distribusikan ke address tujuannya. Confoh paket label 20 dari 10.3.0.0/24 ( PLN SOLOK ) dengan memalui peer 10.255.255.3 ( PE-D1-SOLOK ), paket label 21 dari PE-D1-SLK ( 10.255.255.3 ) dengan melalui peer 10.255.255.3 ( PE-D1-SLK ). Pada menu remote bindings diinfomasikan paket data yang dilabel terdistribusi dari local router ( PE-D1-PD ) ke menuju router sisi lainnya ( router CE dan PE ) dan ada juga yang tidak terdistribusi.

Paket labeling mpls berada di posisi PE-D1-PD dari router PE label paket yang diproses yaitu 17,20,21,22,24,31. Pada gambar di atas di infomasikan bahwa label data 30 akan di distribusikan ke address broadcast melalui peer 10.255.255.4 (PLN PADANG). paket label 22 dari 10.1.0.0/24 ( PLN PADANG ) dengan memalui peer 10.255.255.3 ( PE-D1-SLK) dengan next hopnya direct PE-D1-PD. Konfigurasi PE-D1-SLK

Konfiguasi detail PE-D1-SLK Lankah pertama adalah jalan kan program winbox.exe dapat di download di websitenya mikrotik.com atau mikrotik.co.id. Arahkan moouse kea rah browser di tombol konek di winbox akan terbaca mac address dari router, setelah itu klik konek.

5. Konfigurasi Nama Router Setelah masuk kedalam router keluar menu winbox router yang isinya interface, ip, ppp, switch, bridge, mesh, ip, mpls, vpls, routing, system, quee, file, log, radius, tools, newterminal, meta router, metasupport, manual dan menu exit.

Langkah selanjutnya adalah pemberian nama router.

Klik menu system -> identify kana keluar toolbox identify, dalam toolbox aka nada tulisan mikrotik secara default, ganti namanya sesuai dengan nama router yang kita inginkan contoh PE-D1-SLK sesuai gambar diatas. Atau secara command line bisa di lakukan dengan command :

/system identify set name=PE-D1-SLK dengan awalnya ambil menu new terminal di winbox lalu di ketikan command tersebut.

6. Konfigurasi interface loopback dan ip address. c. Konfigurasi interface loopback ( bridge )

Kliklah menu bridge di router akan keluar diaglog menu bridge . selanjutnya klik tanda (+ ) pada bridge, akan keluar menu dialog interface bridge. Ganti nama bridge1 dengan nama loobridge setelah itu klik ok, sesuai gambar diatas. . Atau secara command line bisa di lakukan dengan command : /interface bridge add name=lobridge interface ini di gunakan untuk

penandaan id di routingan dynamic ( OSPF, BGP, RIP ).

dengan awalnya ambil menu new terminal di winbox lalu di ketikan command tersebut.

d. Konfigurasi ip router Klik menu ip pada router dan pilih selanjutnya addresses akan keluar menu dialog addresslist kemudian klik tombol ( + ) ,akan keluar menu dialog new address, setelah itu masukan ip address router PE-D1-SLK sesuai dengan gambar berikut.

Ip yang di alokasikan untuk router pln solok adalah 10.3.0.254/24 untuk interface kearah router PLN SOLOK ( ether3 ), ip 10.255.255.2/30 untuk interface router PE-D1-SLK ( ether1 ) untuk interface lobridge dengan ip 10.255.255.3/32. Atau sacara command line bisa di ketikan di menu new terimal dengan command berikut ini .

/ip add address=10.0.255.6 netmask=255.255.255.252 interface=ether1 /ip add address=10.0.255.2 netmask=255.255.255.252 interface=ether2 /ip add address=10.3.0.254 netmask=255.255.255.0 interface=ether3 /ip add address=10.255.255.3 netmask=10.255.255.3 interface=loopbridge 7. Setting routing dynamic router PE-D1-SLK dengan OSPF Konfigurasi routingan menggunakan dynamic routing ospf dengan area id backbone ( 0.0.0.0.0 ). Langkah awal adalah klik menu routing dan ambil submenu OSPF, akan keluar menu dialog OSPF sesuai dengan gambar berikut ini

Selanjutnya tentukan routing id OSPF dengan area name backbone dan id ( 0.0.0.0.0 ) di menu area di menu dialog OSPF. Klik tanda (+) akan keluar menu dialog OSPF Area < backbone.

Langkah selanjutnya adalah menetapkan router id sebagai penanda router di jaringan. Alokasi id nya adalah alokasi ip yang digunkann untuk lobridge. Dan pilih redistribute default routenya dengan nilai never dan redistribute connected routenya as type1 Seperti gambar berikut ;

Secara command line di new terminal bisa di ketikan command berikut /routing ospf set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.3. selanjutnya menetapkan OSPF network router PE-D1-SLK. Network OSPFnya di distribusikan oleh router pe-d1-slk dengan alokasi ip 10.1.0.0/24, 10.0.255.0/30, 10.0.255.4/30, 10.1.0.0/24, 10.3.0.0/24 sedangkan ip dari router PE-D1-SLK ke PE-D1-PD secara direct di alokasikan 10.0.255.2/30 di interface ether2. Pada menu network di menu dialog OSPF di klik tanda ( + ), masukan network area dari OSPF router PE-D1-PD adalah ip 10.1.0.0/24, 10.0.255.0/30, 10.0.255.4/30, 10.1.0.0/24, 10.3.0.0/24. Dapat di dilihat di gambar berikut :

Atau secara command line bisa di ketikan command di new teriminal berikut ini /routing ospf network add area=backbone comment="" disabled=no network=10.0.255.0/30 add area=backbone comment="" disabled=no network=10.0.255.4/30 add area=backbone comment="" disabled=no network=10.1.0.0/24 add area=backbone comment="" disabled=no network=10.3.0.0/24 . Setelah routingan OSPF di create di kedua sisi baik disi PLN SOLOK, PE-D1-PD dan PE-D1-SLK akan di infomasikan pada sub menu interface di menu OSPF neighbournya akan

terbaca dengan dalam bentuk angka 1 jika nilainya 0 berarti OSPF kita belum jalan sempurna pastikan konfigurasi network backbone dan area idnya sudah benar. Pada gambar berikut di informasikan OSPF routingan kita sudah ok dan jalan, sesuai dengan gambar berikut ;

Dari gambar diatas digambarkan infomasi OSPF berjalan seacara dynamic ( D ) di interface ether1,2 dan 3 yang direct langsung dengan interface kea rah router PE-D1-SLK. Jika koneksi OSPF sudah jalan dengan baik akan di dapatkan di sub menu neighbournya dengan terbacanya router2 lain yang terknoksi ke routingan OSPF. Bisa di lihat pada menu Neigbhors di menu OSPF dialog.

Gambar di atas router PE-D1-SLK menerima routingan OSPF dari router PLN SOLOK dengan router id 10.255.255.6 dengan ip direct dengan PLN SOLOK 10.3.0.1/24. Routingan OSPF broadcast melui PE-D1-PD ( 10.0.255.1 ). Jika koneksi OSPF sudah jalan dengan baik akan di dapatkan di sub menu neighbournya dengan terbacanya router2 lain yang terknoksi ke routingan OSPF.

Dengan terdistribusinya informas neighbour antar router ini berdasarkan protocol link state advertisement ( LSA ) di OSPF routing router akan didistribusikan semua sehingga routigan berlajan secara dynamic.

Dari gambar diatas di gambar routingan antar router yang menggunakan routingan OSPF. Lebih detail lagi dapat kita lihat pada menu routers di menu dialog OSPF, dapat dilihat dari gambar berikut ini ;

Dengan routingan berjalan baik maka router juga menginformasikan border router yang ada di network.

8. MPLS Setting Langkah pertama adalah dengan klik menu MPLS dan akan keluar menu dialog MPLS seperti gambar berikut ini.

Langkah selanjutnya tetapan interface yang digunakan sebagi media pendistribusian MPLS. Yaitu interface yang direct langsung ke PE-D1-PD ( ether1 ) di router PE-D1SLK dan ether3 ke router PLN SOLOK, dengan cara mengklik (+) pada menu LDP Interface di menu dialog MPLS. Sesuai dengan gambar berikut ini :

Secara command line penetapan interface LDP bisa di ketik di new terminal dengan perintah /mpls ldp interface interface=ether1 /mpls ldp interface interface=ether2 /mpls ldp interface interface=ether3 Selanjutnya tetapkan LDP setting agar informasi mpls terdistribusi dengan baik. LDP akan menginfomasikan peering antar router. Hal ini dapat juga menginformasikan forwarding routing mpls dengan terdistribusi label paketnya secara remote dan local, dengan menginformasikan LSR id dan transport ip menggunakan ip lobdrige router PED1-SLK . dapat dilihat dari gambar berikut :

Jika semua LDP telah terdistribusi akan di infomasikan LDP router router lain di network juga. Dapat dilihat dimenu LDP neigbour pada gambar berikut ;

Setalah berjalan normal MPLS settingnya akan dapat kita lihat infomasi LDP terdistribusi dengan baik pada menu forward table, local bindings dan remote bindings.

Pengujian Pada forward table di infomasikan label MPLS yang merupakan label paket data di switching dengan sesuai pengalamatan paketnya. Sesaui gambar beikut ini.

Pada gambar diatas paket data telah terlabel di dalam router PE-D1-SLK yang di forwadkan ke PLN SOLOK dan PE-D1-PD begitu juga sebaliknya. Label paket yang di fowardkan anataralain 25± 26 dengan next hop router PE-D1-PD ke PLN PADANG , 26 ± 27

dengan next hop router PE-D1-PD ke ip Lan PLN PADANG, paket yang tidak di label ke luar tidak akan di forwadkan ( distribusikan ) . Pada menu local bindings diinfomasikan paket data yang dilabel terdistribusi dari router sisi lain ( baik itu router CE dan PE ) ke local router ( PE-D1-PD) dan ada juga yang tidak terdistribusi.

Pada gambar di atas di infomasikan bahwa label data 17,20,21,25 dan 26 akan di distribusikan ke address tujuannya. Confoh paket label 22 dari 10.0.255.4/24 ( PLN PADANG ) dengan memalui peer 10.255.255.1 ( PE-D1-PD), paket label 17 dari PE-D1-PD ( 10.255.255.1 ) dengan melalui peer 10.255.255.1 ( PE-D1-PD ). Pada menu remote bindings diinfomasikan paket data yang dilabel terdistribusi dari local router ( PE-D1-PD ) ke menuju router sisi lainnya ( router CE dan PE ) dan ada juga yang tidak terdistribusi.

Paket labeling mpls berada di posisi PE-D1-SLK dari router PE label paket yang diproses yaitu 17,18,1920,21,22,24,26 dan 27. Pada gambar di atas di infomasikan bahwa label data 19 akan di distribusikan ke address broadcast 10.0.255.0/30 melalui peer 10.255.255.1 (PE-D1PD). paket label 26 ke 10.1.0.0/24 ( PLN PADANG ) dengan memalui peer 10.255.255.3 ( PED1-SLK) dengan next hopnya broadcast.

Konfigurasi router costumer ( CE )

Konfiguasi detail PLN PADANG Lankah pertama adalah jalan kan program winbox.exe dapat di download di websitenya mikrotik.com atau mikrotik.co.id. Arahkan moouse kea rah browser di tombol konek di winbox akan terbaca mac address dari router, setelah itu klik konek.

Klik ICON WInbox di Desltop

9. Konfigurasi Nama Router Setelah masuk kedalam router keluar menu winbox router yang isinya interface, ip, ppp, switch, bridge, mesh, ip, mpls, vpls, routing, system, quee, file, log, radius, tools, newterminal, meta router, metasupport, manual dan menu exit.

Langkah selanjutnya adalah pemberian nama router.

Klik menu system -> identify kana keluar toolbox identify, dalam toolbox aka nada tulisan mikrotik secara default, ganti namanya sesuai dengan nama router yang kita inginkan contoh PLN_PADANG sesuai gambar diatas. Atau secara command line bisa di lakukan dengan command :

/system identify set name=PLN_PADANG dengan awalnya ambil menu new terminal di winbox lalu di ketikan command tersebut.

10. Konfigurasi interface loopback dan ip address. e. Konfigurasi interface loopback ( bridge )

Kliklah menu bridge di router akan keluar diaglog menu bridge . selanjutnya klik tanda (+ ) pada bridge, akan keluar menu dialog interface bridge. Ganti nama bridge1 dengan nama loobridge setelah itu klik ok, sesuai gambar diatas. . Atau secara command line bisa di lakukan dengan command : /interface bridge add name=lobridge interface ini di gunakan untuk

penandaan id di routingan dynamic ( OSPF, BGP, RIP ). dengan awalnya ambil menu new terminal di winbox lalu di ketikan command tersebut.

f.

Konfigurasi ip router Klik menu ip pada router dan pilih selanjutnya addresses akan keluar menu dialog addresslist kemudian klik tombol ( + ) ,akan keluar menu dialog new address, setelah itu masukan ip address router PLN PADANG sesuai dengan gambar berikut.

Ip yang di alokasikan untuk router pln solok adalah 10.1.0.1/24 untuk interface kearah router pe-d1-pd ip 10.255.255.4/32 untuk interface lobridge dan ip 192.168.2.1/24 untuk arah computer land i solok. Atau sacara command line bisa di ketikan di menu new terimal dengan command berikut ini .

/ip add address=10.1.0.1 netmask=255.255.255.0 interface=ether1 /ip add address=192.168.2.1 netmask=255.255.255.0 interface=ether2 /ip add address=10.255.255.1 netmask=10.255.255.1 interface=loopbridge 11. Setting routing dynamic router PLN_PADANG dengan OSPF Konfigurasi routingan menggunakan dynamic routing ospf dengan area id backbone ( 0.0.0.0.0 ). Langkah awal adalah klik menu routing dan ambil submenu OSPF, akan keluar menu dialog OSPF sesuai dengan gambar berikut ini

Selanjutnya tentukan routing id OSPF dengan area name backbone dan id ( 0.0.0.0.0 ) di menu area di menu dialog OSPF. Klik tanda (+) akan keluar menu dialog OSPF Area < backbone.

Langkah selanjutnya adalah menetapkan router id sebagai penanda router di jaringan. Alokasi id nya adalah alokasi ip yang digunkann untuk lobridge. Dan pilih redistribute default routenya dengan nilai never dan redistribute connected routenya as type1 Seperti gambar berikut ;

Secara command line di new terminal bisa di ketikan command berikut /routing ospf set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.4. selanjutnya menetapkan OSPF network router PLN_PADANG. Network OSPFnya di distribusikan oleh router pe-d1-slk dengan alokasi ip 10.1.0.0/24, sedangkan ip dari router PLN PADANG secara direct di alokasikan 10.1.0.1/24 di interface ether1. Pada menu network di menu dialog OSPF di klik tanda ( + ), masukan network area dari OSPF router PLN PADANG adalah 10.1.0.0/24. Dapat di dilihat di gambar berikut :

Atau secara command line bisa di ketikan command berikut ini /routing ospf network add area=backbone network=10.1.0.0/24 di new teriminal. Setelah routingan OSPF di create di kedua sisi baik disi PLN PADANG dan PE-D1-PD akan di infomasikan pada sub menu interface di menu OSPF neighbournya akan terbaca dengan dalam bentuk angka 1 jika nilainya 0 berarti OSPF kita belum jalan sempurna pastikan konfigurasi network backbone dan area idnya sudah benar. Pada gambar berikut di informasikan OSPF routingan kita sudah ok dan jalan, sesuai dengan gambar berikut ;

Dari gambar diatas digambarkan infomasi OSPF berjalan seacara dynamic ( D ) di interface ether1 yang direct langsung dengan interface kea rah router PE-D1-PD. Jika koneksi OSPF sudah jalan dengan baik akan di dapatkan di sub menu neighbournya dengan terbacanya router2 lain yang terknoksi ke routingan OSPF. Bisa di lihat pada menu Neigbhors di menu OSPF dialog.

Gambar di atas router PLN PADANG menerima routingan OSPF dari router PE-D1-PD dengan router id 10.255.255.1 dengan ip direct dengan PE-D1-PD 10.1.0.254/24. Jika koneksi OSPF sudah jalan dengan baik akan di dapatkan di sub menu neighbournya dengan terbacanya router2 lain yang terknoksi ke routingan OSPF. Dengan terdistribusinya informas neighbour antar router ini berdasarkan protocol link state advertisement ( LSA ) di OSPF routing router akan didistribusikan semua sehingga routigan berlajan secara dynamic.

Dari gambar diatas di gambar routingan antar router yang menggunakan routingan OSPF. Lebih detail lagi dapat kita lihat pada menu routers di menu dialog OSPF, dapat dilihat dari gambar berikut ini ;

Dengan routingan berjalan baik maka router juga menginformasikan border router yang ada di network.

12. MPLS Setting Langkah pertama adalah dengan klik menu MPLS dan akan keluar menu dialog MPLS seperti gambar berikut ini.

Langkah selanjutnya tetapan interface yang digunakan sebagi media pendistribusian MPLS. Yaitu interface yang direct langsung ke PE-D1-PD ( ether1 ) di router PLN PD, dengan cara mengklik (+) pada menu LDP Interface di menu dialog MPLS. Sesuai dengan gambar berikut ini :

Secara command line penetapan interface LDP bisa di ketik dengan perintah /mpls ldp interface interface=ether1 di new terminal. Selanjutnya tetapkan LDP setting agar informasi mpls terdistribusi dengan baik. LDP akan menginfomasikan peering antar router. Hal ini dapat juga menginformasikan forwarding routing mpls dengan terdistribusi label paketnya secara remote dan local, dengan menginformasikan LSR id dan transport ip menggunakan ip lobdrige router PLN PADANG . dapat dilihat dari gambar berikut :

Jika semua LDP telah terdistribusi akan di infomasikan LDP router router lain di network juga. Dapat dilihat dimenu LDP neigbour pada gambar berikut ;

Setalah berjalan normal MPLS settingnya akan dapat kita lihat infomasi LDP terdistribusi dengan baik pada menu forward table, local bindings dan remote bindings.

Pengujian Pada forward table di infomasikan label MPLS yang merupakan label paket data di switching dengan sesuai pengalamatan paketnya. Sesaui gambar beikut ini.

Pada gambar diatas paket data telah terlabel di dalam router PLN SOLOK yang di forwadkan ke PE-D1-SLK begitu juga sebaliknya. Label paket yang di fowardkan anataralain 16 ± 29 dengan next hop router PLN PADANG ke PE-D1-PD menuju PE-D1-SLK , 20 ± 30 dengan next hop router PLN PADANG ke PE-D1-PD menuju PE-D1-SLK , 21 -31 dengan next hop router PLN PADANG ke PE-D1-PD menuju i plan PLN SOLOK , 22 -32 dengan next hop router PLN PADANG ke PE-D1-PD menuju PE-D1-SLK , paket yang tidak di label ke luar tidak akan di forwadkan ( distribusikan ) . Pada menu local bindings diinfomasikan paket data yang dilabel terdistribusi dari router sisi lain ( baik itu router CE dan PE ) ke local router ( PLN PADANG ) dan ada juga yang tidak terdistribusi.

Pada gambar di atas di infomasikan bahwa label data 16,17,18,19,20,21 dan 22 akan di distribusikan ke address tujuannya. Confoh paket label 16 dari 10.255.255.4 ( PLN PADANG ) dengan memalui peer 10.255.255.1 ( PE-D1-PD ), paket label 21 dari lan PLN PADANG ( 192.168.1.0/24 ) dengan melalui peer 10.255.255.1 ( PE-D1-PD ). Pada menu remote bindings diinfomasikan paket data yang dilabel terdistribusi dari local router ( PLN PADANG ) ke menuju router sisi lainnya ( router CE dan PE ) dan ada juga yang tidak terdistribusi.

Paket labeling mpls berada di posisi PLN PADANG dari router PE label paket yang diproses yaitu 18,19,20,21,23. Pada gambar di atas di infomasikan bahwa label data 23 akan di distribusikan ke address tujuannya yaitu 10.255.255.6 ( PLN SOLOK ) melalui peer 10.255.255.1 (PE-D1-PD). paket label 20 dari 10.3.0.0/24 ( PLN SOLOK ) dengan memalui peer 10.255.255.1 ( PE-D1-PD) dengan next hopnya direct 10.1.0.254 dengan router PLN PADANG.

Dengan melakukan pengujian kita bisa lakukan tracert i p PLN SOLOK yaitu 192.168.1.2 dari router PLN PADANG. Sesuai gambar berikut ; Pengujian pengiriman paket ping ke posisi kantor PLN_SOLOK dengan ip computer di lannya adalah 192.168.1.2 di tracert dari router pe-d1-pd ke pe-d1-slk paket di label dengan mplslabel=22. Berarti MPLS kita sudah berjalan baik. jika di lakukan tracert dengan adanya 4 hop delay time nya masih 1ms . ini menandakan link antar lan PLN PADANG di ping dari lan PLN SOLOK sangat baik.

Konfiguasi detail PLN SOLOK Lankah pertama adalah jalan kan program winbox.exe dapat di download di websitenya mikrotik.com atau mikrotik.co.id. Arahkan moouse kea rah browser di tombol konek di winbox akan terbaca mac address dari router, setelah itu klik konek.

Klik ICON WInbox di Desltop

13. Konfigurasi Nama Router Setelah masuk kedalam router keluar menu winbox router yang isinya interface, ip, ppp, switch, bridge, mesh, ip, mpls, vpls, routing, system, quee, file, log, radius, tools, newterminal, meta router, metasupport, manual dan menu exit.

Langkah selanjutnya adalah pemberian nama router.

Klik menu system -> identify kana keluar toolbox identify, dalam toolbox aka nada tulisan mikrotik secara default, ganti namanya sesuai dengan nama router yang kita inginkan contoh PLN_SOLOK sesuai gambar diatas. Atau secara command line bisa di lakukan dengan command :

/system identify set name=PLN_SOLOK dengan awalnya ambil menu new terminal di winbox lalu di ketikan command tersebut.

14. Konfigurasi interface loopback dan ip address. g. Konfigurasi interface loopback ( bridge )

Kliklah menu bridge di router akan keluar diaglog menu bridge . selanjutnya klik tanda (+ ) pada bridge, akan keluar menu dialog interface bridge. Ganti nama bridge1 dengan nama loobridge setelah itu klik ok, sesuai gambar diatas. . Atau secara command line bisa di lakukan dengan command : /interface bridge add name=lobridge interface ini di gunakan untuk

penandaan id di routingan dynamic ( OSPF, BGP, RIP ).

dengan awalnya ambil menu new terminal di winbox lalu di ketikan command tersebut.

h. Konfigurasi ip router Klik menu ip pada router dan pilih selanjutnya addresses akan keluar menu dialog addresslist kemudian klik tombol ( + ) ,akan keluar menu dialog new address, setelah itu masukan ip address router PLN SOLOK sesuai dengan gambar berikut.

Ip yang di alokasikan untuk router pln solok adalah 10.3.0.1/24 untuk interface kearah router pe-d1-slk, ip 10.255.255.6/32 untuk interface lobridge dan ip 192.168.1.1/24 untuk arah computer land i solok. Atau sacara command line bisa di ketikan di menu new terimal dengan command berikut ini .

/ip add address=10.3.0.1 netmask=255.255.255.0 interface=ether1 /ip add address=192.168.1.1 netmask=255.255.255.0 interface=ether2 /ip add address=10.255.255.6 netmask=10.255.255.6 interface=loopbridge 15. Setting routing dynamic router PLN_SOLOK dengan OSPF Konfigurasi routingan menggunakan dynamic routing ospf dengan area id backbone ( 0.0.0.0.0 ). Langkah awal adalah klik menu routing dan ambil submenu OSPF, akan keluar menu dialog OSPF sesuai dengan gambar berikut ini

Selanjutnya tentukan routing id OSPF dengan area name backbone dan id ( 0.0.0.0.0 ) di menu area di menu dialog OSPF. Klik tanda (+) akan keluar menu dialog OSPF Area < backbone.

Langkah selanjutnya adalah menetapkan router id sebagai penanda router di jaringan. Alokasi id nya adalah alokasi ip yang digunkann untuk lobridge. Dan pilih redistribute default routenya dengan nilai never dan redistribute connected routenya as type1 Seperti gambar berikut ;

Secara command line di new terminal bisa di ketikan command berikut /routing ospf set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.6. selanjutnya menetapkan OSPF network router PLN_SOLOK. Network OSPFnya di distribusikan oleh router pe-d1-slk dengan alokasi ip 10.3.0.0/24, sedangkan ip dari router PLN SOLOK secara direct di alokasikan 10.3.0.1/24 di interface ether1. Pada menu networl di menu dialog OSPF di klik tanda ( + ), masukan network area dari OSPF router PLN SOLOK adalah 10.3.0.0/24. Dapat di dilihat di gambar berikut :

Atau secara command line bisa di ketikan command berikut ini /routing ospf network add area=backbone network=10.3.0.0/24 di new teriminal. Setelah routingan OSPF di create di kedua sisi baik disi PLN SOLOK dan PE-D1-SLK akan di infomasikan pada sub menu interface di menu OSPF neighbournya akan terbaca dengan dalam bentuk angka 1 jika nilainya 0 berarti OSPF kita belum jalan sempurna pastikan

konfigurasi network backbone dan area idnya sudah benar. Pada gambar berikut di informasikan OSPF routingan kita sudah ok dan jalan, sesuai dengan gambar berikut ;

Dari gambar diatas digambarkan infomasi OSPF berjalan seacara dynamic ( D ) di interface ether1 yang direct langsung dengan interface kea rah router PE-D1-SLK. Jika koneksi OSPF sudah jalan dengan baik akan di dapatkan di sub menu neighbournya dengan terbacanya router2 lain yang terknoksi ke routingan OSPF. Bisa di lihat pada menu Neigbhors di menu OSPF dialog.

Gambar di atas router PLN SOLOK menerima routingan OSPF dari router PE-D1-SLK dengan router id 10.255.255.3 dengan ip direct dengan PE-D1-SLK 10.3.0.254/24. Jika koneksi OSPF sudah jalan dengan baik akan di dapatkan di sub menu neighbournya dengan terbacanya router2 lain yang terknoksi ke routingan OSPF. Dengan terdistribusinya informas neighbour antar router ini berdasarkan protocol link state advertisement ( LSA ) di OSPF routing router akan didistribusikan semua sehingga routigan berlajan secara dynamic.

Dari gambar diatas di gambar routingan antar router yang menggunakan routingan OSPF. Lebih detail lagi dapat kita lihat pada menu routers di menu dialog OSPF, dapat dilihat dari gambar berikut ini ;

Dengan routingan berjalan baik maka router juga menginformasikan border router yang ada di network.

16. MPLS Setting Langkah pertama adalah dengan klik menu MPLS dan akan keluar menu dialog MPLS seperti gambar berikut ini.

Langkah selanjutnya tetapan interface yang digunakan sebagi media pendistribusian MPLS. Yaitu interface yang direct langsung ke PE-D1-SLK ( ether1 ) di router PLN SOLOK, dengan cara mengklik (+) pada menu LDP Interface di menu dialog MPLS. Sesuai dengan gambar berikut ini :

Secara command line penetapan interface LDP bisa di ketik dengan perintah /mpls ldp interface interface=ether1 di new terminal. Selanjutnya tetapkan LDP setting agar informasi mpls terdistribusi dengan baik. LDP akan menginfomasikan peering antar router. Hal ini dapat juga menginformasikan forwarding routing mpls dengan terdistribusi label paketnya secara remote dan local, dengan menginformasikan LSR id dan transport ip menggunakan ip lobdrige router PLN SOLOK . dapat dilihat dari gambar berikut :

Jika semua LDP telah terdistribusi akan di infomasikan LDP router router lain di network juga. Dapat dilihat dimenu LDP neigbour pada gambar berikut ;

Setalah berjalan normal MPLS settingnya akan dapat kita lihat infomasi LDP terdistribusi dengan baik pada menu forward table, local bindings dan remote bindings.

Pengujian Pada forward table di infomasikan label MPLS yang merupakan label paket data di switching dengan sesuai pengalamatan paketnya. Sesaui gambar beikut ini.

Pada gambar diatas paket data telah terlabel di dalam router PLN SOLOK yang di forwadkan ke PE-D1-SLK begitu juga sebaliknya. Label paket yang di fowardkan anataralain 16 ± 25 , 18 ± 24 , 21 23 , 22 -26 paket yang tidak di label ke luar tidak akan di forwadkan ( distribusikan ) . Pada menu local bindings diinfomasikan paket data yang dilabel terdistribusi dari router sisi lain ( PLN PADANG ) ke local router ( PLN SOLOK ) dan ada juga yang tidak terdistribusi.

Pada gambar di atas di infomasikan bahwa label data 16,17,18,19,20,21 dan 22 akan di distribusikan ke address tujuannya. Confoh paket label 16 dari 10.255.255.4 ( PLN PADANG ) dengan memalui peer 10.255.255.3 ( PE-D1-SLK ), paket label 22 dari lan PLN PADANG ( 192.168.2.0/24 ) dengan melalui peer 10.255.255.3 ( PE-D1-SLK ). Pada menu remote bindings diinfomasikan paket data yang dilabel terdistribusi dari router sisi lain ( PLN PADANG ) ke local router ( PLN SOLOK ) menuju dan ada juga yang tidak terdistribusi.

Paket labeling mpls berada di posisi PLN SOLOK dari router PE label paket yang diproses yaitu 23,24,25,29.30. Pada gambar di atas di infomasikan bahwa label data 23 dan 22 akan di distribusikan ke address tujuannya. Confoh paket label 25 dari 10.255.255.4 ( PLN PADANG ) dengan memalui peer 10.255.255.3 ( PE-D1-SLK ) dengan next hopnya direct 10.3.254 dengan router PLN SOLOK, paket label 26 dari lan PLN PADANG ( 192.168.2.0/24 ) dengan melalui peer 10.255.255.3 ( PE-D1-SLK ) dengan next hopnya direct 10.3.254 dengan router PLN SOLOK. Dengan melakukan pengujian kita bisa lakukan tracert i p PLN PADANG yaitu 192.168.2.1 dari router PLN SOLOK. Sesuai gambar berikut ;

di tracert dari router pe-d1-slk ke pe-d1-pd paket di label dengan mpls-label=34. Berarti MPLS kita sudah berjalan baik karena data sudah terlabel dan sampai menuju targetnya yaitu

192.168.2.1 jika di lakukan tracert dengan adanya 4 hop delay time nya masih 1ms . ini menandakan link antar lan PLN PADANG di ping dari lan PLN SOLOK sangat baik.

Dari hasil ±pengujian di lakukan di dapatkan hasil 1. Hasil tracert dari kantor lan pln solok ke lan pln padang dengan 4 hop delay time masih di bawah 1 ms begitu juga sebaliknya. Seolah network dari lan pln padang dengan pln solok ( mode bridge/ swicth ). 2. Paket di tracert dari router ce pln solok ke ip lan pln padang paket di label oleh proses MPLSnya dengan label 34. Sedangkan ketika di tracert dari router pln solok paket di label oleh MPLSnya dengan label 22 sehingga pengelompokan paket data teratur ( paket anomali bisa di minimalkan ). Dapat dilihat dari kesimpulan gambar beikut

Di sisi router costumer di dapatkan label 22 dan 34 sedangkan di antara router pe terjadi pertukaran label . antar router label out dan in disi router pe ke pe

3. Dengan konsep mode bridge namun looping data bisa di hindari dapat dilihat dari pada labeling posisi di remote dan local . sehingga data terdistribusi dengan baik 4. Proses label swaping terjadi disaat forwarding label antara label in dan label out dengan membutuhkan waku pendek untuk swaping.

Harapan penulis agar tugas akhir ini dilanjutkan untuk optimalisasi network lainnya seperti tunneling trafik. Karena tugas akhir yang penulis kerjakan masih dalam tahapan awal network mpls belum detail. Namun dengan aawalan ini penulis telah dapat menggambarkan prorese kerja mpls network dengan hasil penulis capai.

Bahan bacaan Wiki.mikrotik.com Mikrotik.co.id Harrychanputra.web.id Primadonal.wordpress.com Mum.mikrotik.com 2009 di bali

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->