P. 1
WF5 Drawing

WF5 Drawing

|Views: 1,175|Likes:
Published by mujahidali500

More info:

Published by: mujahidali500 on Sep 24, 2010
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

06/18/2013

pdf

text

original

PRO/ENGINEER WILDFIRE 5.

0 GETTING STARTED GUIDE

DRAWING

The drawing tree. This information provides manufacturing engineers and other downstream users with data to produce these objects. company name or logo. just the model tree manages model items. This allows for intuitive organization of functions. etc. date of issue. A drawing communicates information such as dimensions. Interface The drawing tool bar is comprised of a menu bar and its associated icons at the top of the Pro/ENGINEER window. revisions. person releasing the drawing. on the left side. the menu bar categorizes using the Microsoft “ribbon” style of organization. providing users only the right tool at the right time. notes. views.Drawing Drawings are used to document parts and assemblies created by the design engineer. allows you to manage drawing items. Unlike the feature toolbar. bill of materials (BOM). Main Toolbar Menu Bar Drawing Ribbon Toolbar Message Window Selection Filter Drawing Tree Model Tree Graphics Window Drawing Sheets Pro/ENGINEER Getting Started Guide – Drawing 1 .

Drawing Labels Drawing labels can include parametric system or user-defined parameters. such as who is creating the drawing. the system displays the date that the model was added to the format. tables. etc. and adds them to the format. Once the parameter has been entered. and add tables. Users are able to add their own defined parameters for which the system prompts the user for values. Parameters &todays_date &drawn_by &checked_by &model_name &dwg_name &scale &type &format &current_sheet &total_sheets Description Adds the date the model is added to the drawing Adds the person’s name that created the drawing Adds the person’s name that checked the drawing Adds the name of the model in the drawing Adds the name of the drawing Adds the scale of the drawing Adds the model type (part or assembly) Adds the format size Adds the current sheet number Adds the total number of sheets in the drawing Pro/ENGINEER Getting Started Guide – Drawing 2 . if the date label is added. Users can then delete entities. on drawings. company logo. or parameter information to get the right look. it is populated to the correct location in the table. draft new entities using 2D drafting tools. They allow companies to standardize the above information. the system evaluates them and updates them when models are added. For example. Formats can be created from scratch or by using legacy data from other packages by importing an IGES or DXF file. title blocks. When these parameters are added in a drawing format. The following table lists commonly used system parameters.Formats Formats show borders. always keeping the drawing accurate with the model. as well as what sheet size will be used. text.

which is retrieved from the model. Tables are commonly used to list the Bill of material (BOM) of an assembly model. the table will populate automatically with the correct information. Adding Information Once tables have been created. Tables are defined by:  Table direction: users can specify a table as ascending or descending. Therefore. tables are stored as *. the user would type “&cost” into the table cell. such as BOM tables. These sizes can be defined by an actual length or number of characters. if a model has a cost parameter and that parameter is added to a drawing.  Angle: users can set the angle of the text.  Location: the system prompts users to locate the first corner of the table. and based on the table direction.  Height: users can define the height of the text to fit the cell.  Wrap text: text may overlap into an adjacent cell. Storing and Retrieving Tables Tables can be standardized if they include parametric notes. and parameter values. Manipulating Drawing Tables Users can change the following:  Font: users are provided with the standard Windows font library. thus users can wrap the text to the next line in the cell. users can define the rows and columns. Once imported. Tables are intelligently populated with parametric text.tbl files that can be imported into a drawing when needed.  Justification: users can justify the text to center. Creating Tables Tables are created with the table tools in the drawing toolbar. Adding dimensions and parameter values requires an ampersand (&) prefix. or right. instances in a family table. which updates automatically with the model’s information.  Row and column size: the size of the row and column can be defined to reflect the actual size the user desires. and as rightward or leftward. users can add plain text. left. etc.Tables Tables enable users to place information in drawings in a tabulated format. dimensions. Pro/ENGINEER Getting Started Guide – Drawing 3 . but can also include variable model information. Tables can also serve as title blocks in a format. For example.

material. CREATING BOM TABLES  Create a table: Accommodate for the growth of the table by choosing the origin and placement of the table carefully.  Report symbols: After the table is set with the repeat region. Display the index number assigned to each record. etc.mbr.mbr. Parameter &asm. as components are added to the assembly. Pro/ENGINEER Getting Started Guide – Drawing 4 . The following table lists common parameters used in repeat regions.qty  Definition Displays the name of an assembly member. Update Table: Updating the table will extract the information from the model and automatically populate the table. For example.name &asm. users can utilize report parameters that will fill the repeat region with the desired information from the model. Displays the quantity of an item.User Defined &rpt. Displays the value of a user defined parameter. the table will automatically update by adding rows to the table. such as cost. These regions automate the creation and maintenance of BOMs by adjusting the table size and display with the assembly. There are two types of repeat region tables:  Simple: the repeat region grows in one direction.level &rpt. These parameters can be manually entered or be selected from a menu.BOM Tables BOMs are often created using what are known as “repeat regions” in Pro/ENGINEER.  Define repeat regions: The system extracts information from the model to automatically fill the cells of the table based on the repeat region requirements.type &asm. Displays the type of an assembly member (part or assembly).  2D: the repeat region grows in two directions.mbr.index &rpt. Displays the recursive depth of an item.

REMOVING LISTED COMPONENTS If there are components in the list that need to be removed.  Recursive – the system is enabled to search through all levels of the assembly.e. if the same bolt exists in multiple sub-assemblies.  No Duplicates – the system will list the component only once even if it exists multiple times in the assembly and display the quantity.  No Dup/Level – the system will list the component once for every sub-assembly. These BOM balloons are parametric to the BOM table and will update as the assembly is changed (i. simply re-order the list by selecting Repeat Region > Fix Index. washers). components are added or removed). it will be listed once in each level of the sub-assembly. This means 100% accurate BOMs! Pro/ENGINEER Getting Started Guide – Drawing 5 . nuts. bolts. For example.e. BOM BALLOONS BOM balloons allow users to display a balloon marker to designate where its corresponding component is located with respect to its listing in the BOM table. users can control the display of these duplicated components by setting repeat region attributes. CONTROLLING LIST ORDER To change the order of how the components are displayed in a BOM.  Duplicates – the system is defaulted to create a row for every single instance of a component.CONTROLLING DUPLICATE COMPONENTS If a component is used multiple times in an assembly (i. users can filter the table so that the system automatically removes those items by:  Item: allows users to remove a component by selecting a record to remove.  Rule: allows users to set up a rule to remove multiple entries. CONTROLLING LEVELS SEARCHED If there is more than one level in an assembly. BOM balloons are displayed by the item number alone or item number and quantity.  Flat – the system is defaulted to only display the top-level components because the system is unable to search through all lower levels of the assembly. users can control the search level through repeat region attributes.

as this file superseded all settings. Users can also create their own configuration files. Pro/ENGINEER Getting Started Guide – Drawing 6 . This can be found by right-clicking on the Pro/ENGINEER desktop icon and clicking properties. which allow them to customize their specific Pro/ENGINEER working environment.pro file (the primary configuration file).Drawing Standards Configuration File Configuration files control settings that enable standardization of a user’s Pro/ENGINEER working environment.pro in the startup directory is the last location to be read and will overwrite any conflicting configuration files options from files in the previous locations. If you don’t want a configuration option to be overridden. can reside in one of three locations:  Loadpoint/text directory: This is the Pro/ENGINEER installation directory. The config.  Startup directory: This is the Start in directory of Pro/ENGINEER. you should placed a config. The config.  Home directory: This is typically c:\document and settings\username\my documents.sup file in the Loadpoint/text directory.

c:\ptc\drawing_setup.dtl Sets the default directory for the drawing format library. Drawing setup files are similar to configuration files. Determines whether the system saves the model after changes are made. No – saves driven dimensions created in drawing mode on solid geometry in the solid. For information on configuration and drawing setup file settings. different. Place full path of directory location.com. Set to “yes” to always invoke the open rep dialog when opening a drawing. Yes – Saves all new driven dimensions created in the drawing as associative draft dimensions. and ANSI. while a configuration file controls the entire session of Pro/ENGINEER. drawing setup files. but control drawing-specific attributes. Sets the directory that contains the symbol instance Palette. One notable difference is that a drawing can have its own drawing setup file. go to Tools > Options. The drawing setup file can be accessed through File > Drawing Options.To set options in the configuration file. Pro/ENGINEER Getting Started Guide – Drawing 7 . Drawing Setup File The drawing setup file allows companies to specify company specific drawing standards and save them in *. Place full path of directory location. This is an independently managed website and is not affiliated with PTC or TriStar.dtl files. Place full path of directory location. Sets the directory that contains start parts and assemblies. users can check out http://www. Displays model in default orientation when placing a general view in the drawing. Pro/ENGINEER provides standard ISO.dtl files. Place full path. Below is a list of commonly used configuration options for drawings: Option drawing_setup_file pro_format_dir start_model_dir symbol_instance_palette_file save_modified_draw_models_only open_draw_simp_rep_by_default rename_drawings_with_object disp_trimetric_dwg_mode_view create_drawing_dims_only Description Points the system to the drawing setup file. JIS. Controls whether the system copies associated drawings automatically with parts and assemblies.dtl.dtl. i.e. Therefore. a single Pro/ENGINEER session can have multiple.proesite.

Pro/ENGINEER Getting Started Guide – Drawing 8 .  Basic view types include:  General  Projection  Detailed  Auxiliary  Special view types include:  Half/Partial/Broken Views  Cross-Section (Planar/Offset)  3D Cross Section General View The general view is the first view to be added to a drawing. This is called associativity and is key to the tremendous productivity gains from Pro/ENGINEER. which convey the model’s geometric configuration in the best possible way. It serves as a parent view to other views. There are a number of views that can be created. This can be done by adding the model through File > Drawing Models > Add Model.Creating Views Design models are represented by views. A general view by itself can also represent an isometric view orientation (to give a nice 3D view of a part in a drawing). meaning that a change in one mode will be reflected in all other modes automatically and vice versa. If a model is changed by dimensions. symbols. which are referenced or projected from the general view. tolerances. The system will allow the user to choose the desired model. If there is more than one model associated to a drawing. Details such as dimensions. or relational formulas. those changes are propagated to any assembly or drawings that reference the model. This associative behavior is bi-directional. and notes are added to these views to provide as much information as possible for manufacturing. The model is required to be in session or in memory and associated to the drawing in order for its views to be placed. the user can toggle the active model by selecting the Set the Active Model/Rep from the Model tree.

Cross Section Views 2D Cross sectional views are beneficial when the model’s internal detail or specific section details must be displayed. Half/Partial/Broken Views These views are used to detail portions of a design model. Auxiliary View An auxiliary view is a view projected at an angle from another datum plane. projected to the top. or left of an existing view. Detailed View A detailed view enlarges the display of a small portion of an existing view. The biggest difference is that the cross section can be viewed in an isometric orientation. Detailed views are often used when a portion of an existing view is crucial to the manufacturing engineer. surface.Projection View A projection view is simply an orthographic projection from another view. bottom. but needs to be blown up for better detail. Detailed View Auxiliary View Projection View General View Projection View Cross Sectional View Pro/ENGINEER Getting Started Guide – Drawing 9 . The selected reference on the parent view must be perpendicular to the plane of the drawing. or axis. right. 3D Cross Section Views 3D cross sections are used for the same purpose of a 2D cross section discussed above. They are useful when a design model is long and needs to be fitted into the size of the drawing sheet.

Exploded View Pro/ENGINEER Getting Started Guide – Drawing 10 .Exploded Views Assemblies can be positioned to show how an assembly fits together. This information can be displayed in drawings through exploded views with dashed offset (or assembly) lines as shown.

a user will usually want to clean up and adjust. half. partial. and HLR edge display quality  Origin: modifies view origin options  Alignment: modifies view alignment options Moving Views Users can move views anywhere on the drawing simply by selecting the view and dragging it to the desired location. hidden line removal for quilts. or broken  Scale: modifies the scale and perspective options  Sections: defines 2D or 3D cross sections  View States: defines combined states. Many of the modifications can take place in the Drawing View Dialog Box. all children views will be deleted with it. exploded views. hidden line removal for cross-hatches. Pro/ENGINEER Getting Started Guide – Drawing 11 . or simplified representations  View Display: modifies the display style. which can be accessed by double-clicking any view. tangent edge display. and parent information if available  Visible Area: modifies the view visibility to full. If a parent view is deleted. Deleting and Erasing Views Unwanted views can be deleted by selecting the view and pressing the Delete key or through the context-sensitive right mouse button menu. These views can also be locked to a specific location by selecting the view and clicking Lock View Movement.Modifying Views Once views have been placed onto a drawing. This box includes:  View Type: modifies the name of the view. type. pulls colors from the drawing or model.

Driving dimensions are extracted from the 3D model and allow users to take full advantage of the bi-directional associativity between the 3D model and the drawing. components. driving dimensions and driven dimensions. driven dimensions have single-directional associativity from the 3D model to the drawing. symbols.Detailing Once the necessary views have been placed on the drawing. and datum features. notes. surface finish. geometric tolerances. and/or features to show the desired dimensions. it is necessary to detail the dimensions and notes. which specify size. Annotation Type Dimension Type Show Annotation Select All Deselect All Pro/ENGINEER Getting Started Guide – Drawing 12 . those changes automatically update the drawing and vice versa. but cannot drive any geometry to the 3D model. and information of every feature in the object. location. Dimensioning Concepts There are two types of dimensions that can be placed onto drawings. Driven dimensions are added to the drawing if there are dimensions that were not part of the 3D model’s design intent. This tool allows users to select views. The tool lists all annotation types available. The dimension automatically updates as the model changes. Thus. Showing and Erasing Dimensions SHOWING DIMENSIONS Driving dimensions can be shown by using the Show Model Annotations dialog box accessible on the Annotate ribbon toolbar. These dimensions already exist within the model and are shown or erased from the drawing as desired. Driven dimensions are beneficial when adding reference dimensions. If a change is made at the 3D model. and the user simply chooses what to show.

surfaces. and intersections to define the driven dimension. driven dimensions are not shown or erased by extracting that information from the 3D model. Pro/ENGINEER Getting Started Guide – Drawing 13 . The user may also right-click on a dimension and select erase. users have the ability to select entities. Cleaning Up Dimensions When showing dimensions for an entire view. centers. That dimension can also be “unerased” with the same method (but only in the drawing tree on the left). Similar to the dimension tool in sketcher. the dimensions do not usually come out exactly as desired. midpoints. The Clean Dimensions tool allows users to easily and quickly space out each dimension at an offset and incremented value. Creating Driven Dimensions Unlike driving dimensions. Erased dimensions can always be retrieved and placed back into the drawing. and users can then manually move the remaining dimensions as needed. This does 75 percent of the cleanup work. Driven dimensions are created on the fly by using the Dimension – New References tool on the Annotate ribbon toolbar.ERASING DIMENSIONS Erasing driving dimensions simply means that the dimension will not be displayed. but simply erases it from the drawing display. usually through the drawing tree on the left. It will not delete the actual dimension. as that is being extracted from the 3D model. and then place them with the middle mouse button.

etc). USING PARAMETERS IN NOTES Notes can include user-defined parameters by preceding the name of the parameter with an ampersand (&). Notes can also have superscript and subscript text by adding the following to the note: Type Superscripted Text Subscripted Text Both Superscripted and Subscripted Text String @+text@# @-text@# @+text@#@-text@# Notes can also be boxed by adding @[ and @] at the beginning and end of the note. Notes can be added to a drawing by:  Showing notes from the 3D model: These can be added by using the Show Model Annotations dialog box. When aligning mixed types of dimensions. ALIGNING DIMENSIONS Both angular and linear dimensions can be aligned at the same time. Dimensions can also be moved to different views as appropriate.  Creating a new note by entering text: Plain text or parametric notes can be created by entering text in the drawing using the Note tool. Ordinate dimensions can be created by converting linear dimensions or by creating the ordinate dimension directly with the Ordinate Dimension tool. Users can manage the font. redefine the attachment of an ordinate dimension. arrow styles. This can be done by selecting the dimension(s). thickness.Manipulating Dimensions MOVING DIMENSIONS Users can move dimensions manually by selecting a single dimension or multiple dimensions and dragging to a different location. or delete dimensions. Users can change the attributes of notes. and angle of the note. right-clicking. and selecting the view to which the dimensions will be moved. selecting “Move Item to View”. Users can add dimensions to existing ordinate dimension groups. For example. For example. or jogged leader lines. all from this one menu. you can create a note and enter the text &Material. ORDINATE DIMENSIONS Ordinate dimensions are useful for parts with many dimensions (holes. slant.  Creating a new note from a saved text file: Notes can be formatted to company standards where users can insert them into a drawing. they align based on selection order (where the first selected dimension sets the location). Pro/ENGINEER Getting Started Guide – Drawing 14 . This will associate the material information from the model’s parameter into the drawing note. Notes Notes contain textual information that conveys process and assembly details that are not easily conveyed through dimensions. such as leader/no-leader.

Tolerances Dimensional Tolerances Dimensional tolerances are specific. orientation. and run-out of features. Geometric Tolerances are classified into the following categories: Category Tolerance of Form Types Straightness Flatness Circularity Cylindricity Tolerance of Profile Line Surface Tolerance of Orientation Angularity Parallelism Perpendicularity Tolerance of Position Position Concentricity Symmetry Tolerance of Run-out Circular Total Yes Yes Yes Sometimes Icon Reference Datum Required No Pro/ENGINEER Getting Started Guide – Drawing 15 . form. allowable variations in size that are designed in a part. and how the part should be inspected. Dimensional tolerances are defined by the following:  General Tolerances: applied to dimensions that appear in a normal format without tolerances and are presented in a tolerance table or note  Individual Tolerances: specified tolerances on individual dimensions Pro/ENGINEER provides users the ability to use ANSI or ISO tolerance standards when adding dimensional tolerances to drawings. how they relate to one another. They also provide a method for controlling the location. profile. They can be displayed in four types of formats:  Plus-Minus  Symmetric  Nominal  Limits Geometric Tolerances Geometric tolerances specify critical surfaces on a part.

configuration file settings can be set to remove unwanted drawing geometry and details from the drawing. and the editing process). the model can be retrieved at any time. such as bolts. converting components to graphical or geometric representations. If the drawing needs to be modified. Merge Drawings Users can create separate drawings files for models and then merge them together after the drawing sheets have been completed. or by using symbolic representations to replace common parts. Then. Managing Large Assembly Drawings When working with very large models in drawings. To control the view display. repaint time. set the following as appropriate:  display_planes = no  display_point = no  display_axis = no  force_wirefram_in_drawings = yes  display_coord_sys = no  disp_trimetric_dwg_mode_view = no Simplified Representations With simplified representations. Below are some of these tools and tips. This is beneficial when browsing or plotting out drawings. This can be done my putting items on layers and hiding or erasing them. set auto_regen_view to no. Drawing Representations Drawing views can be selected and removed so that the drawing only retrieves the information required. These simplified representations can also be added to drawings. performance can degrade (retrieval time. Users can easily manage individual parts and then add multiple parts into a single drawing file.To place geometric tolerances. it will only retrieve geometry necessary for that session. This means that based on the type of simplified representation. To control the update of views. Retrieving Models Users can significantly reduce retrieval time by retrieving a drawing in view-only mode as it will not retrieve any of its associated models. Configuration File Settings To minimize performance degradation. users can create representations of the master model by excluding unneeded components. first set up the reference datums and basic dimensions. Pro/ENGINEER Getting Started Guide – Drawing 16 . There are tools in Pro/ENGINEER that make users more efficient and productive when working with larger assembly drawings. apply geometric tolerances by using the Geometric Tolerance tool (shown below). regeneration speeds.

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->