LINGVISTICA MATEMATICĂ

material didactic Conţinutul cursului: 1. LOGICA AFIRMAŢIILOR COMPUSE............................................2
1.1 Forma logică şi echivalenţa logică ........................................................2 1.2 Implicaţia logică.....................................................................................9 1.3 Argumente valabile şi nevalabile...........................................................13 1.4 Aplicaţie: circuite logice digitale...........................................................21 2. LOGICA AFIRMAŢIILOR CUANTIFICATE.................................32 2.1 Predicate şi afirmaţii cuantificate I........................................................32 2.2 Predicate şi afirmaţii cuantificate II.......................................................35 3. TEORIA MULŢIMILOR .............................................................................41 4. FUNCŢII.............................................................................................47 5. RELAŢII.............................................................................................62 6. GRAFURI ŞI ARBORI.......................................................................72 7. ARBORI..............................................................................................88 8. Literatura...........................................................................................................92

Tradus, prelucrat şi aranjat pentru cititor de M. Perebinos Autorul acestui material aduce sincere mulţumiri, studentei anului V, FCIM, ILMA, Diana Hriplivaia, pentru suport în traducerea şi verificarea materialului.

1

1. 1.1

LOGICA AFIRMAŢIILOR COMPUSE

FORMA LOGICĂ ŞI ECHIVALENŢA LOGICĂ
“Logica este o ştiinţă a legilor necesare ale gândirii, fără de care nu are loc nici o angajare a procesului de înţelegere şi raţiune.” Immanuel Kant (1785)

Afirmaţii
În orice teorie matematică, termenii noi sunt definiţi folosind termenii care au fost definiţi anterior. Câţiva termeni iniţiali rămân indispensabil nedefiniţi. În logică, cuvintele propoziţie, adevărat, fals sunt termenii iniţiali nedefiniţi. Aceşti termeni sunt descrişi cu ajutorul următoarei definiţii.

DEFINIŢIE: O afirmaţie este o propoziţie care este adevărată sau falsă, dar nu ambele. EXEMPLUL 1.1.1. Afirmaţii şi Nonafirmaţii 1. 2. 3. 4. 5. 6. 7. Doi plus doi este egal cu patru. Doi plus doi este egal cu cinci. Nici o femeie nu a fost vreodată preşedinte al S.U.A. Ce zi frumoasă! El este student. x + y > 0. Această propoziţie este falsă.

Afirmaţii Compuse
Acum vom introduce 3 simboluri care sunt utilizate pentru a construi expresii logice mai complicate din cele simple. Simbolul ~ înseamnă “Nu”, ∧ înseamnă “Şi” şi ∨ înseamnă “Sau”. Fiind dată o propoziţie p, propoziţia “~p” se citeşte “nu p” sau “Nu este cazul ca p” şi se numeşte negaţia lui p. În unele limbaje de calculator simbolul Fiind dată o altă propoziţie q, propoziţia “p ∧ q” se citeşte ca “p şi q” şi se numeşte conjuncţia lui p şi q. Propoziţia “p ∨ q” se citeşte ca “p sau q” şi se numeşte disjuncţia lui p şi q. EXEMPLUL 1.1.2. Transformaţi în expresii logice propoziţiile următoare, notând p = ”Este cald” şi q = “Este soare”: a. Nu este cald, dar este soare. [~p ∧ q ] b. Nu este în acelaşi timp nici cald , nici soare. [~(p ∧ q )] c. Nu este nici cald, nici soare. [~p ∧ ~q ]

¬

este folosit în locul simbolului ~.

2

EXEMPLUL 1.1.3. Şi, Sau şi Inegalităţile Fie x un număr real anumit. p, q şi r simbolizează respectiv: “0<x”, “x<3” şi “x=3”. Scrieţi în formă simbolică următoarele inegalităţi: a. x ≤ 3 [a. q ∨ p b. 0 < x < 3 b. p ∧ q c. 0 < x ≤ 3 c. p ∧ ( q ∨ p ) ]

DEFINIŢIE:

Dacă p este afirmaţie, negaţia lui p, ~p, are valoarea opusă lui p. Dacă p este adevărată, atunci falsă, iar dacă p este falsă, atunci ~p este adevărată. Această definiţie este rezumată în tabelul de adevăr, care dă valorile corecte ale lui p: Tabelul de adevăr pentru p p A F

~p este

~p
F A

DEFINIŢIE: Dacă p şi q sunt afirmaţii, conjuncţia lui p şi q, p ∧ q, este adevărată atunci şi numai atunci când ambele afirmaţii p şi q sunt adevărate. p ∧ q este falsă, dacă ambele sau măcar una din afirmaţiile p şi q sunt false. Tabelul de adevăr pentru p ∧ q P A A F F q A F A F p∧ q A F F F

DEFINIŢIE: Dacă p şi q sunt afirmaţii, disjuncţia lui p şi q, p ∨ q, este adevărată dacă cel puţin una din afirmaţiile p şi q este adevărată, şi este falsă numai când ambele afirmaţii sunt false. Tabelul de adevăr pentru p ∨ q P A A F F q A F A F p∨ q A A A F

3

Evaluarea adevărului unor Afirmaţii Generale mai Compuse

DEFINIŢIE: Forma afirmaţiei (sau forma propoziţională) este o expresie formată din variabilele afirmaţiei (aşa ca p, q şi r) şi legături logice (aşa ca ~, ∧ şi ∨ ), care devine afirmaţie când afirmaţia curentă este substituită de variabilele componente ale afirmaţiei. Tabela adevărurilor pentru forma afirmaţiei date expune valorile adevărate ce corespund diferitor combinaţii ale valorilor adevărate ale variabilelor. EXEMPLUL 1.1.4. Tabelul de adevăr pentru ~p ∨ q p A A F F EXEMPLUL 1.1.5. Sau exclusiv. Când “Sau” este folosit în sensul său exclusiv, afirmaţia “p sau q” înseamnă “p sau q, dar nu ambele” sau “p sau q, dar nu împreună p şi q ”. Aceasta s-ar traduce în limbajul simbolurilor astfel: (p ∨ q ) ∧ ~ (p ∧ q ). Construiţi tabela adevărurilor pentru formele afirmaţiei (p ∨ q ) ∧ ~ (p ∧ q ). p A A F F q A F A F p∨ q A A A F p∧ q A F F F q A F A F

~p
F F A A

~p ∨ q
A F A A

~ (p ∧ q )
F A A A

(p ∨ q) ∧ ~(p ∧ q) F A A F

EXEMPLUL 1.1.6. Tabelul de adevăr pentru ( p ∧ q ) p A A A A F F F F q A A F F A A F F r A F A F A F A F

∨ ~r
p∧ q A A F F F F F F

~r
F A F A F A F A

( p∧ q ) ∨ A A F A F A F A

~r

4

Echivalenţa logică
Examinaţi următorul tabel de adevăr: p A A F F q A F A F p∧ q A F F F q∧ p A F F F

Aceleaşi valori de adevăr! Din tabel rezultă că pentru fiecare combinaţie a valorilor adevărate pentru p şi q, p ∧ q este adevărată atunci şi numai atunci când q ∧ p este adevărată. În asemenea caz, formele afirmaţiei sunt numite egalitate logică.

DEFINIŢIE: Două forme ale afirmaţiei sunt numite egalitate logică dacă şi numai dacă ele au valori ale adevărului identice pentru orice substituţie posibilă a afirmaţiilor pentru variabilelor lor de afirmaţie. Echivalenţa logică a formelor afirmaţiilor p şi q se notează prin p ≡ q. Două afirmaţii se numesc echivalente logic dacă şi numai dacă formele lor sunt logic echivalente. EXEMPLUL 1.1.7. Proprietatea Negaţiei Duble: ~(~p) ≡ p Verificaţi dacă negaţia unei negaţii a unei afirmaţii este logic echivalentă cu afirmaţia; aceasta înseamnă că ~(~p) ≡ p. EXEMPLUL 1.1.8. Demonstrarea Non-Echivalenţei Arătaţi că formele afirmaţiilor ~ (p ∧ q) şi ~p ∧ ~q nu sunt logic echivalente. a. O modalitate de a demonstra aceasta este folosirea tabelelor de adevăr. b. O a doua cale de demonstrare este prin exemple. EXEMPLUL 1.1.9. Negarea lui “Şi” şi “Sau”: Legile lui De Morgan Verificaţi dacă afirmaţiile de forma ~ (p ∧ q) şi ~p ∨ ~q sunt logic echivalente.

~(p ∧ q) ≡ ~p ∨ ~q ~(p ∨ q) ≡ ~p ∧ ~q.

Legile lui De Morgan

Negarea unei afirmaţii “şi” este logic echivalentă unei afirmaţii “sau” în care fiecare componentă este negată. Negarea unei afirmaţii “sau” este logic echivalentă unei afirmaţii “şi” în care fiecare componentă este negată. EXEMPLUL 1.1.10. Aplicarea Legilor lui De Morgan Scrieţi negaţii pentru fiecare din afirmaţiile următoare: a. Ion are 1,80 m înălţime şi cântăreşte cel puţin 75 kg. b. Autobusul a întârziat sau ceasul lui Tom a rămas în urmă. Soluţii:
5

a. Ion nu are 1,80 m înălţime sau el cântăreşte mai puţin de 75 kg. b. Autobusul nu a întârziat sau ceasul lui Tom nu a rămas în urmă. EXEMPLUL 1.1.11. Inegalităţile şi Legile lui De Morgan Utilizaţi Legile lui De Morgan pentru a scrie negarea expresiei: –1 < x ≤ y. EXEMPLUL 1.1.12. Un exemplu la care trebuie de atras atenţia După Legile lui De Morgan, negarea lui p: „Jim este înalt şi Jim este slab”. este Jim nu este slab”.

~p: „Jim nu este înalt şi

Observaţi că afirmaţia p poate fi scrisă mai compact ca p’ : „Jim este înalt şi slab”. Scrisă astfel, un alt mod de a nega afirmaţia este ~(p’ ) : „Jim nu este înalt şi slab”. Dar în această formă negarea se aseamănă cu o afirmaţia “şi”. Aceasta nu contrazice Legile lui De Morgan? Motivul constă în faptul că convenţional cuvintele şi şi sau sunt permise numai între fragmente de propoziţie complete.

Tautologii şi Contradicţii

DEFINIŢIE: O tautologie este o formă de afirmaţie care este întotdeauna adevărată, indiferent de valorile adevărului ale afirmaţiilor individuale substituite de variabilele ei de afirmaţie. O afirmaţie a cărei formă este o tautologie se numeşte o afirmaţie tautologică. O contradicţie este o formă de afirmaţie care este întotdeauna falsă, indiferent de valorile adevărului ale afirmaţiilor individuale substituite de variabilele ei de afirmaţie. O afirmaţie a cărei formă este o contradicţie se numeşte afirmaţie contradictorie. EXEMPLUL 1.1.13. Tautologii şi Contradicţii Demonstraţi că forma de afirmaţie p ∨ contradicţie.

~p este o tautologie şi că forma de afirmaţie p ∧ ~ p este o

TEOREMA 1.1.1 Echivalenţe logice Fiind date orice variabile p, q şi r ale afirmaţiei, o tautologie t şi o contradicţie c, au loc următoarele echivalenţe logice: 1. Legile comutative 2. Legea asociativă 3. Legea distributivă 4. Legea de identitate 5. Legea negaţiei 6. Legea dublei negaţii 7. Legea idempotenţei 8. Legile lui De Morgan 9. Legea legăturii universale 10. Legea absorbţiei 11. Negaţia lui t şi c p∧ q ≡ q∧ p (p ∧ q) ∧ r ≡ p ∧ (q ∧ r) p ∧ (q ∨ r) ≡ (p ∧ q) ∨ (p ∧ r) p∧ t ≡ p p∨ ~ p ≡ t p∧ p ≡ p ~ (p ∧ q) ≡ ~p ∨ ~q p∨ t ≡ t p ∨ (p ∧ q) ≡ p ~t ≡ c p∨ q ≡ q∨ p (p ∨ q) ∨ r ≡ p ∨ (q ∨ r) p ∨ (q ∧ r) ≡ (p ∨ q) ∧ (p ∨ r) p∨ c ≡ p p ∧ ~p≡c p∨ p ≡ p ~ (p ∨ q) ≡ ~p ∧ ~q p∧ c ≡ c p ∧ (p ∨ q) ≡ p ~c ≡ t

~ (~p) ≡ p

6

EXEMPLUL 1.1.14. Simplificarea Formei de afirmaţie Folosiţi TEOREMA 1.1.1. pentru a verifica echivalenţa logică ~(~p ∧ q ) ∧ (p ∨ q) ≡ p Soluţie: ~ (~ p ∧ q) ∧ (p ∨ q) ≡ (~(~p) ∨ ~q) ∧ (p ∨ q) după Legea lui De Morgan

~ q) ∧ (p ∨ q) ≡ p ∨ (~q ∧ q)
≡ (p ∨ c ) ≡p

≡ (p ∨

după Legea dublei negaţii după Legea distributivă după Legea negaţiei după Legea identităţii

SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.1.1
7

1. Determinaţi care din perechile de forme de afirmaţii din 1.1-1.10 sunt logic echivalente. Justificaţi răspunsurile Dvs., utilizând tabelele de adevăr. Prin t şi c sunt notate respectiv tautologia şi contradicţia. 1.1 p V (p Λ q) şi p 1.2 ~ (p V q) şi ~p Λ ~q 1.3 p V t şi t 1.4 p V c şi p 1.5 (p Λ q) Λ r şi p Λ (q Λ r) 1.6 p Λ (q V r) şi (p Λ q) V (p Λ r) 1.7 (p Λ q) V r şi p Λ (q V r) 1.8 (p V q) V (p Λ r) şi (p V q) Λ r 1.9 ((~p V q) Λ (p V ~r)) Λ (~p V ~q) şi ~(p V r) 1.10 (r V p) Λ ((~r V (p Λ q)) Λ (r V q)) şi pΛ q 2. Folosind regulile de echivalenţă logică expuse în TEOREMA 1.1.1, verificaţi dacă expresiile ce urmează în 2.1-2.7 sunt logic echivalente. 2.1 (p Λ ~q) V (p Λ q) ≡ p 2.2 (p V ~ q) Λ (~p V ~q) ≡ ~q 2.3 (p Λ ~ q) V p ≡ p 2.4 p Λ (~q V p) ≡ p 2.5 ~ (p V ~q) V (~p Λ ~q) ≡ ~p 2.6 ~((~p Λ q) V (~p Λ ~q)) V (p Λ q) ≡ p 2.7 (p Λ (~(~p V q))) V (p Λ q) ≡ p

1.2

IMPLICAŢIA LOGICĂ
8

“… motivul ipotetic implică subordonarea realului posibilului…” Jean Piaget (1972) Să considerăm exemplul: Presupunem că vă duceţi la un interviu pentru o slujbă la un magazin şi proprietarul vă face următoarea promisiune: “Dacă tu vei veni la lucru Luni dimineaţă, atunci tu vei obţine această slujbă.” Exemplul de mai sus a avut scopul de a vă convinge că unica combinaţie de circumstanţe în care aţi putea numi o propoziţie condiţională falsă apare atunci când ipoteza este adevărată şi concluzia este falsă. În toate celelalte cazuri, nu aţi numi propoziţia falsă. Tabelul de adevăr pentru p → q p A A F F q A F A F p→q A F A A

DEFINIŢIE: Dacă p şi q sunt afirmaţii, condiţia “Dacă p atunci q” notată prin p → q, este falsă când p este adevărată şi q este falsă, altfel este adevărată. Dacă p şi q sunt afirmaţii anumite, notaţia p q (se citeşte “p implică pe q”) înseamnă că afirmaţia p → q este adevărată. EXEMPLUL 1.2.1. Construiţi tabelul de adevăr p ∨ EXEMPLUL 1.2.2. Construiţi tabelul de adevăr ~p ∧ q → r ∨ ~q EXEMPLUL 1.2.3. Demonstraţi că p ∨ q → r ≡ (p → r) ∧ (q → r) EXEMPLUL 1.2.4. Reprezentarea lui Dacă – Atunci ca Sau Demonstraţi că p → q ≡ ~p ∨ q Soluţie: p A A F F q A F A F

~q → ~p

~p
F F A A

p→q A F A A

~p ∨
A F A A

q

Aceleaşi valori ale adevărului EXEMPLUL 1.2.5. Aplicarea Echivalenţei dintre ~p ∨ q şi p → q Rescrieţi afirmaţiile următoare în forma dacă – atunci : “Sau te duci la lucru la timp, sau vei fi concediat”. Soluţii:
9

Fie De asemenea

~p: “Te duci la lucru la timp” ~q: “Vei fi concediat”
p: “Tu nu te duci la lucru la timp” q: “Dacă tu nu te duci la lucru la timp, atunci vei fi concediat”

EXEMPLUL 1.2.6. Tautologiile p ∧ q → p şi p → p ∨ q Demonstraţi că formele de afirmaţii p ∧ q → p şi p → p ∨ q sunt tautologii.

Negarea unei Afirmaţii Condiţionale
 Negarea lui “Dacă p atunci q” este logic echivalentă cu “p şi nu q”: ~p (p → q) ≡ p ∧ ~q  Să facem negaţiile ambelor părţi pentru a obţine: ~ (p → q) ≡ ~( ~p ∨ q) ≡ ~( ~p) ≡ p∧

∧ (~q)

după Legile lui De Morgan

~q

după legea dublei negaţii

EXEMPLUL 1.2.7. Negarea Afirmaţiilor Dacă – Atunci Scrieţi negaţiile pentru fiecare din următoarele afirmaţii: a. Dacă maşina mea este la reparaţie, atunci eu nu pot să mă duc la ore. b. Dacă Simona trăieşte în Atena, atunci ea trăieşte în Grecia.

Contrapozitivul unei Afirmaţii Condiţionale
DEFINIŢIE:

Contrapozitivul unei afirmaţii condiţionale de forma “Dacă p atunci q” este „Dacă ~q atunci ~p”. Simbolic: Contrapozitivul lui p → q este ~q → ~p. Altfel spus: O afirmaţie condiţională este logic echivalentă cu contrapozitivul ei. EXEMPLUL 1.2.8. Demonstraţi echivalenţa logică: p → q ≡ ~q → ~p EXEMPLUL 1.2.9. Scrierea Contrapozitivului Scrieţi fiecare din afirmaţiile următoare în forma lor contrapozitivă echivalentă: a. Dacă Ion poate trece lacul înotând, atunci Ion poate înota până la insulă. b. Dacă astăzi este ziua de Paşti, atunci mâine este luni.

Conversa şi Inversa unei Afirmaţii Condiţionale
10

DEFINIŢIE: Fie dată o afirmaţie condiţională de forma “Dacă p atunci q”. 1. Conversa este: “Dacă q atunci p”. 2. Inversa este: “Dacă ~p atunci ~q”. Simbolic se scrie: Conversa lui p → q este q → p. şi Inversa lui p → q este ~p → ~q. EXEMPLUL 1.2.10. Scrierea Conversei şi Inversei Scrieţi conversa şi inversa pentru fiecare din afirmaţiile următoare: a. Dacă Ion poate trece lacul înotând, atunci Ion poate înota până la insulă. b. Dacă astăzi este ziua de Paşti, atunci mâine este luni. 1. O afirmaţie condiţională şi conversa ei nu sunt logic echivalente. 2. O afirmaţie condiţională şi inversa ei nu sunt logic echivalente. 3. Conversa şi inversa unei afirmaţii condiţionale sunt logic echivalente una cu alta.

Numai Dacă şi Bicondiţionala

DEFINIŢIE: Dacă p şi q sunt afirmaţii, p numai dacă q înseamnă “Dacă nu q, atunci nici p”, sau, altfel spus, “Dacă p atunci q” . EXEMPLUL 1.2.11. Convertirea lui Numai Dacă în Dacă – Atunci Folosiţi contrapozitiva pentru a rescrie următoarele afirmaţii în forma dacă – atunci în două moduri: “Ion va bate recordul mondial la alergarea de o milă, dacă el va alerga în mai puţin de 4 minute.”

DEFINIŢIE:

Fiind date afirmaţiile p şi q, bicondiţionala notată prin p q, care se citeşte “p dacă şi numai dacă q”, este afirmaţia care este adevărată dacă ambele p şi q au aceleaşi valori ale adevărului şi este falsă dacă p şi q au valori ale adevărului opuse. Cuvintele dacă şi numai dacă sunt câteodată abreviate astfel dşnd. Dacă p şi q sunt careva afirmaţii, notaţia p ⇔ q înseamnă că afirmaţia p q este adevărată. Bicondiţionala are următorul tabel de adevăr (p q): Tabelul de adevăr pentru p p A A F F q A F A F q p A F F A q q

EXEMPLUL 1.2.12. Demonstraţi echivalenţa logică: p

(p

→ q)

(q

→ p)
11

EXEMPLUL 1.2.13. Dacă Şi Numai Dacă Rescrieţi următoarea afirmaţie ca unirea a două afirmaţii dacă – atunci: “Acest program de calculator este corect dacă şi numai dacă el dă răspunsul corect pentru orice seturi posibile de date input.” O echivalenţă logică poate fi exprimată ca o tautologie, folosind notaţia bicondiţională. Dacă două forme de afirmaţie p şi q sunt echivalente logic, bicondiţionala P Q este o tautologie. Invers, dacă o bicondiţională este o tautologie, atunci cele două forme componente de afirmaţie sunt logic echivalente. EXEMPLUL 1.2.14. Exprimarea unei Echivalenţe Logice ca o Tautologie Verificaţi dacă forma de afirmaţie ( p → q ) (~q → ~p ) este o tautologie.

Condiţii Necesare şi Suficiente

DEFINIŢIE: Dacă r şi s sunt variabilele afirmaţiei: r este o condiţia suficientă pentru s înseamnă “dacă r atunci s”, r este o condiţie necesară pentru s înseamnă “dacă nu r atunci nici s.”  Observaţi că din cauza echivalenţei dintre o afirmaţie şi o contrapozitivă: r este o condiţie necesară pentru s înseamnă, de asemenea, că “dacă s atunci r”. Consecinţă:  r este o condiţie necesară şi suficientă pentru s înseamnă că „r dacă şi numai dacă s”. EXEMPLUL 1.2.15. Convertirea unei Condiţii Suficiente la o Formă Dacă – Atunci Rescrieţi următoarele afirmaţii “Dacă A atunci B”: „Forma pătrată a acestei figuri geometrice este o condiţie suficientă pentru ca ea să fie dreptunghi”. Soluţie: “Dacă această figură geometrică este pătrat, atunci ea este un dreptunghi.” EXEMPLUL 1.2.16. Convertirea unei Condiţii Necesare la o Formă Dacă – Atunci Folosiţi contrapozitiva pentru a rescrie următoarea afirmaţie în două moduri: “Împlinirea vârstei de 35 de ani pentru Gheorghe este o condiţie necesară pentru a fi preşedintele SUA.” Soluţie: Varianta 1: Dacă Gheorghe nu a împlinit vârsta de 35 de ani, atunci el nu poate fi preşedintele SUA. Varianta 2: Dacă Gheorghe poate fi preşedintele SUA, atunci el a împlinit vârsta de 35 de ani.

SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.1.2
12

1. Construiţi tabelul de adevăr pentru formele de afirmaţii din 1.1-1.7 1.1 ~p V q → ~q 1.2 p Λ ~q → r 1.3 p Λ ~r qVr 1.4 (p → (q → r)) ((p Λ q) → r) 1.5 p V (~p Λ q) → q 1.6 ~p V q → r 1.7 (p → r) (q → r) 2. Utilizând tabelele de adevăr, să se verifice echivalenţa formei de afirmaţie ~(p → q) ≡ p Λ ~q 3. Arătaţi că formele de afirmaţii ce urmează sunt toate logic echivalente p → q V r, p Λ ~q → r, şi p Λ ~ r → q 4. Folosiţi operaţia pentru a transforma orice formă de afirmaţie logic echivalentă din 4.1-4.3 în tautologie. Pentru a verifica orice tautologie obţinută, utilizaţi tabelul de adevăr 4.1 (q → p) ≡ (~p → ~q) 4.2 p Λ (q V r) ≡ (p Λ q) V (p Λ r) 4.3 p → (q → r) ≡ (p Λ q) → r

1.3 ARGUMENTE VALABILE ŞI NEVALABILE
13

“Controversy?”, Continued twaddle? “if it was so it might be: and if were so, it would be, but as it isn’t, it ain’t. That’s logic” Lewis Carroll. Through the looking glass

DEFINIŢIE: Un argument este o succesiune de afirmaţii. Toate afirmaţiile, în afară de ultima, sunt numite premise (sau presupuneri, sau ipoteze). Ultima afirmaţie este numită CONCLUZIA. Simbolul ∴ , care se citeşte „de aceea”, „prin urmare”, este de obicei plasat chiar înainte de concluzie. De exemplu argumentul: Dacă Socrate este o fiinţă umană, atunci Socrate este muritor. Socrate este o fiinţă umană. ∴ Socrate este muritor. are forma abstractă: Dacă p atunci q P ∴ q.

DEFINIŢIE: Pentru a spune că o formă de argumente este valabilă înseamnă că, n-are importanţă ce afirmaţii anumite sunt substituite de variabilele afirmaţiei în premisele ei, dacă premisele rezultante sunt toate adevărate, atunci şi concluzia este, de asemenea, adevărată. Pentru a spune că un argument este valabil, înseamnă că forma lui este valabilă. Practic vorbind, pentru a testa o formă de argument pentru valabilitate este necesar să: 1. Identificaţi premisele şi concluzia unui argument. 2. Construiţi o tabelă a adevărurilor arătând valorile adevărului ale tuturor premiselor şi ale concluziei. 3. Găsiţi rândurile (numite rânduri critice) în care toate premisele sunt adevărate. 4. Î fiecare rând critic, determinaţi dacă concluzia argumentului este, de asemenea, adevărată. a. Dacă în fiecare rând critic concluzia este, de asemenea, adevărată, forma de argument este valabilă. b. Dacă există cel puţin un rând critic în care concluzia este falsă, forma de argument este nevalabilă. EXEMPLUL 1.3.1. O Formă Valabilă de Argument Arătaţi că următoarea formă de argument este valabilă: p∨ ( q∨ r ) ~r ∴ p∨ q

14

Soluţie: … p A A A A F F F F q A A F F A A F F r A F A F A F A F q∨ r A A A F A A A F Premise p∨ ( q∨ r ) A A A A A A A F Rînduri critice

~r
F A F A F A F A

concluzie p∨ q A p → qA A A A A F F

EXEMPLUL 1.3.2. O Formă de Argument Nevalabilă Arătaţi că următoarea formă de argument este nevalabilă: p q p q∨ ~ r p∧ r r.

Soluţie: …

Modus Ponens şi Modus Tollens
Considerăm următoarea formă de argument: ∴ Dacă p atunci q p q

Iată un argument de această formă:

Dacă ultima cifră a acestui număr este un 0, atunci acest număr este divizibil cu 10. Ultima cifră a acestui număr este un 0. Acest număr este divizibil cu 10.

Faptul că această formă de argument este valabilă se numeşte modus ponens. (termenul “modus ponens” provine din latină şi înseamnă “metoda afirmării”, de vreme ce concluzia este o afirmare). EXEMPLUL 1.3.3. Demonstraţi că Următoarea Formă de Argument este Valabilă p p q q

Soluţie:…

 Acum să considerăm următoarea formă de argument: Dacă p atunci q ~q ∴

~q
15

Următorul exemplu reprezintă un argument de această formă: Dacă Zeus este om, atunci Zeus este muritor. Zeus nu este muritor. Zeus nu este om.

Faptul că această formă de argument este valabilă se numeşte modus tollens. (din latină aceasta înseamnă metoda negării, de vreme ce concluzia este o negare).

Forme de Argumente Valabile de Adunare
EXEMPLUL 1.3.4. Adunarea Disjunctivă a. Următoarele forme de argumente sunt valabile: p b. q ∴ p∨ q ∴ p∨ q Aceste forme de argumente sunt folosite pentru a face generalizări. “Anton este junior” ∴ ”Anton se află în liceu” (este junior sau senior) EXEMPLUL 1.3.5. Simplificarea Conjunctivă Următoarele forme de argumente sunt valabile: a. p∧ q b. p∧ q ∴ p ∴ q Aceste forme de argument sunt utilizate pentru particularizare: „Sandra ştie COBOL şi Sandra ştie Pascal-ul.” ∴ ”Sandra ştie Pascal-ul.” EXEMPLUL 1.3.6. Silogismul Disjunctiv Următoarele forme de argumente sunt valabile: a. p∨ q b. p∨ q ~q ~p ∴ p ∴ q Aceste forme de argument spun că atunci când ai numai două posibilităţi şi poţi să o excluzi pe una din ele, atunci corectă este cealaltă. “Cheia de la casa mea este în buzunarul de la jacheta mea sau în portofelul meu.” “Cheia de la casa mea nu este în buzunarul de la jacheta mea.” ∴ Cheia de la casa mea este în portofelul meu. ” EXEMPLUL 1.3.7. Silogism Ipotetic Următoarea formă de argument este valabilă: ∴ p→q q→r p→r

16

Dacă 18486 este divizibil cu 18, atunci este divizibil şi cu 9. Dacă 18486 este divizibil cu 9, atunci suma cifrelor lui 18486 este divizibilă cu 9. Dacă 18486 este divizibil cu 18, atunci suma cifrelor lui 18486 este divizibilă cu 9.

EXEMPLUL 1.3.8. Dilemă: Demonstrare prin Divizarea în Cazuri Următoarea formă de argument este valabilă: p∨ q p→r q→r r x este pozitiv sau x este negativ. Dacă x este pozitiv, atunci x2 >0. Dacă x este negativ, atunci x2>0. x2>0.

or în cazul unui exemplu concret vom avea

EXEMPLUL 1.3.9. Aplicaţie: O Deducţie mai Complexă Ştiţi că următoarele afirmaţii sunt adevărate: a. Dacă ochelarii mei sunt pe masa din bucătărie, atunci eu I-am văzut la dejun. b. Eu citeam ziarul în camera de zi sau eu citeam ziarul în bucătărie. c. Dacă eu citeam ziarul în camera de zi, atunci ochelarii mei sunt pe măsuţa de cafea. d. Eu nu mi-am văzut ochelarii la dejun. e. Dacă eu citeam cartea în pat, atunci ochelarii mei sunt pe masa de lângă pat. f. Dacă eu citeam ziarul în bucătărie, atunci ochelarii mei sunt pe masa din bucătărie. Unde sunt ochelarii? Soluţie: Ochelarii sunt pe măsuţa de cafea. Iată un şir de paşi pe care aţi putea să-i folosiţi pentru a ajunge la acest răspuns, împreună cu regulile deducerii care vă permit să trageţi concluzia fiecărui pas: 1. Ochelarii nu sunt pe masa din bucătărie. (din (a), (d) şi modus tallens) 2. Eu nu am citit ziarul în bucătărie. (din (f), (1) şi modus tollens) 3. Eu am citi ziarul în camera de zi. (din (b), (2) şi silogismul disjunctiv ) 4. Ochelarii mei sunt pe măsuţa de cafea. (din (c), (3) şi modus ponens) EXEMPLUL 1.3.10. Simbolizând o Situaţie pentru a găsi o Soluţie Soluţie: Fie p = “Ochelarii mei sunt pe masa din bucătărie.” q = “Eu mi-am văzut ochelarii la dejun.” r = “Eu citeam ziarul în camera de zi.” t = “Ochelarii mei sunt pe măsuţa de cafea.” u = “Eu citeam cartea în pat.” v = “Ochelarii mei sunt pe masa de lângă pat.” s = “Eu citeam ziarul în bucătărie.” Afirmaţiile logic se rescriu astfel: a). p → q; b). r ∨ s; c). r → t; d). ~ q;

e). u → v;

f). p → q;

17

Poate fi făcută următoarea deducţie: 1. p → q din (a) ~q din (d) ∴~ p 3. r din modus tollens din (b) din concluzia din (2) din silog. disj.

2. s → p ~p ∴~ s 4. r → t r ∴ t

din (f) din concluzia din (1) din modus tollens din (c) din concluzia din (3) din modus ponens.

~s
∴ r

s

Deci t este adevărat şi ochelarii sunt pe măsuţa de cafea. EXEMPLUL 1.3.11. Eroarea Conversă Arătaţi că următorul argument este nevalabil: Dacă Mihai trişează, atunci el stă în ultimul rând. Mihai stă în ultimul rând. ∴ Mihai trişează. Soluţie: Argumentul are următoarea formă: p→q q ∴ p Alternativ, puteţi confirma nevalabilitatea acestui argument folosind tabelul de adevăr. concluzia premiselor p A A F F q A F A F p→q A F A A q A F A F p A A F F rânduri critice EXEMPLUL 1.3.12. Eroarea Inversă Arătaţi că argumentul următor este nevalabil: Dacă rata dobânzii se ridică, preţurile de piaţă vor coborî. Rata dobânzii nu se ridică. ∴ Preţurile de piaţă nu vor coborî. Soluţie: Observaţi că argumentul are următoarea formă: p→q ~p ∴

~q .
18

Tautologii şi Argumente Valabile
Argumentele valabile sunt înrudite îndeaproape cu tautologiile. Mai specific, o formă de argument este valabil dacă şi numai dacă forma de afirmaţie (p1 ∧ p2 ∧ ... ∧ p) → q este o tautologie. p1 p2 . . pn ∴ q Motivul este că uniunea tuturor premiselor este adevărată dacă şi numai dacă fiecare premisă este adevărată. EXEMPLUL 1.3.13. Exprimarea unui Argument Valabil ca o Tautologie Arătaţi că modus tollens este valabil prin demonstrarea că ((p → q)

∧ ~q) → ~p este o tautologie.

Contradicţii şi Argumente Valabile
Conceptul de contradicţie logică poate fi folosit pentru a face deducţie printr-o metodă a raţionamentului numită regula contradicţiei. Presupunem că p este o afirmaţie oarecare al cărei adevăr vreţi să-l deduceţi.

Regula Contradicţiei
Dacă puteţi arăta că presupunerea că afirmaţia p este falsă logic conduce la o contradicţie, apoi puteţi face concluzia că p este adevărată. EXEMPLUL 1.3.14. Regula Contradicţiei Arătaţi că următorul argument este valabil:

~p → c, unde c este o contradicţie
Soluţie: ∴ q

Construiţi tabelul de adevăr pentru premisa şi concluzia acestui argument p T F

~p
F T

c F F

~p → c
T F

p T F Rind critic

Se observă că avem numai un singur rând critic în care premisa este adevărată; şi în acest rând critic concluzia este de asemenea adevărată. Deci argumentul este valabil.

19

Rezumatul Regulilor de Deducţie şi Tautologiilor
Tabelul 1.3.1. Argumente Valabile şi Tautologii Regula Modus Ponens Modus Tollens Forma de argument p→q p ∴q p→q ~q ∴ ~p a. p b. q ∴p ∨ q ∴p ∨ q a. p ∧ q b. p ∧ q ∴p ∴q a. p ∨ q b. p ∨ q ~q ~p ∴p ∴q p→q q→p ∴p→r p∨ q p→r q→r ∴r ~p → c ∴p Tautologia (p → q) ∧ p → q

(p → q)

∧ ~ p →~ q
q q

Adunarea Disjunctivă Simlificarea Conjunctivă Silogismul Disjunctiv

a. p → p b. q → p a. p ∧ q → p b. p ∧ q → q a. (p b.

∨ ∨

∨ (p ∨

q) ∧

~q q) ∧ ~p

→p →q

Silogismul Ipotetic Dilema: Demonstrarea prin divizarea în cazuri Regula Contradicţiei

(p → q) (p

∧ (q → p) → ( p → r)

q) ∧ ( p → r)

(q → r) → r

(~p → c) → p

20

SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.1.3 1. Utilizaţi tabelul de adevăr pentru a determina dacă formele de argument din 1.1-1,6 sunt valabile ori nevalabile: 1.1 .˙.
1.2

p→q q→p pVq p p→q ~q V r r pVq p → ~q p→r r

1.4 .˙. 1.5 .˙. 1.6 .˙.

.˙. 1.3 .˙.

p Λ ~q → r pVq q→p r p p→q ~q V r r p→q p→r p→qΛ r

21

1.4 APLICAŢIE: CIRCUITE LOGICE DIGITALE
Numai conectaţi! E. M. Forster  Desenul din figura 1.4.1. arată două poziţii a unui întrerupător simplu: deschis Figura 1.4.1  Când întrerupătorul este închis, curentul poate trece de la o bornă la alta; când el este deschis, curentul nu poate trece. închis

baterie Bec electric Figura 1.4.2  Acum să ne uităm la un circuit mai complicat:

p

q

Figura 1.4.3 Legarea în serie  Toate stările posobile ale acestui circuit sunt descrise în tabelul care urmează: întrerupătoare p q închis închis închis deshis deschis închis deschis deschis bec stare conectat deconectat deconectat deconectat
22

 Aceasta corespunde expresiei logice p ∧ q p q

Figura 1.4.4 Legarea în paralel  Acum să analizăm circuitul din figura 1.4.4. întrerupătoare p q închis închis închis deshis deschis închis deschis deschis bec stare conectat conectat conectat deconectat

 Aceasta corespunde expresiei logice p V q  Inginerii, în mod general, folosesc mai mult simbolurile 1 şi 0 decât A şi F pentru a arăta aceste valori.

Cutii Negre şi Porţi
Combinaţii de semnale de biţi (1 şi 0) pot fi transformate în alte combinaţii de semnale de biţi (1 şi 0) cu ajutorul unor circuite variate. Interiorul unei cutii negre conţine implicaţia detaliată a circuitului şi este deseori ignorată, în timp ce atenţia este îndreptată spre relaţia dintre semnalele de ieşire şi intrare p Semnale de intrare q r

Cutie neagră

Semnale de ieşire

(Reprezentaţi o corespondenţă posibilă între semnalele de intrare şi ieşire) O metodă eficientă pentru reprezentarea circuitelor mai complicate este de a le construi prin conectarea circuitelor mai puţin complicate de cutii negre. Trei asemenea circuite sunt cunoscute ca porţi de tip NOT, AND şi OR.  poartă de tip NOT (invertor) este un circuit cu un singur semnal de intrare şi unul singur de ieşire. r 1
not

p

0 0
not

not

1

Figura 1.4.5. p reprezintă semnalele de intrare şi r reprezintă semnalele de ieşire
23

poartă de tip AND este un circuit cu două semnale de intrare şi un semnal de ieşire. p q r 1 1 1

and

and

1 0

and

0

0 1

and

0

0 0

and

0

Figura 1.4.6. p şi q reprezintă semnale de intrare şi r reprezintă semnalul de ieşire • poartă de tip OR are, de asemenea, două semnale de intrare şi un semnal de ieşire. p q
or

r

1 1

or

1

1 0

or

0

0 1

or

0

0 0

or

0

Figura 1.4.7. p şi q reprezintă semnale de intrare şi r reprezintă semnal de ieşire Dacă următoarele reguli vor fi respectate, atunci ca rezultat vom avea un circuit combinaţional: (1)Niciodată să nu combinaţi două cabluri de ieşire. (2)Un cablu de intrare poate fi bifurcat în două şi folosit ca intrare pentru două porţi diferite. (3)Un cablu de ieşire poate fi folosit ca intrare. (4) Ieşirea unei porţi nu poate fi folosită ca intrare pentru aceeaşi poartă prin feed-back.

Tabelul de intrare / ieşire pentru un circuit
EXEMPLUL 1.4.1. Determinarea Ieşirii pentru o Intrare dată

24

Indicaţi ieşirile circuitului din figura 1.4.8. pentru semnalele de intrare arătate. Un punct indică un aliaj a două fire: firele care se intersectează fără punct se presupune că nu se ating.

p

not

and

p

q Semnale de intrare: p = 0 şi q = 1 p
and not and

q r Semnale de intrare: p = 1, q = 0, r = 1 Figura 1.4.8. EXEMPLUL 1.4.2. Construirea unui Tabel de intrare / ieşire pentru un Circuit

s

p
or

p

q

not

Expresia Booleană ce Corespunde unui Circuit
Orice variabilă care poate avea numai una din cele două valori se numeşte variabilă Booleană. O expresie compusă din variabile Booleene şi conexiunile ~, ∧ şi ∨ este numită expresie Booleană.

25

EXEMPLUL 1.4.3. Găsirea expresiei Booleene pentru un Circuit a). p q
and

p q
and

~r
not

(p r

q)

∧~ p

b). p
or and

q

and

not

DEFINIŢIE: Un indicator este un circuit care are valoarea 1 pentru exact o combinaţie particulară de semnale de intrare şi are valoarea 0 pentru celelalte combinaţii. EXEMPLUL 1.4.4. Construirea Circuitelor pentru Expresiile Booleene a) p

∧ ~q

b) (~ p ∧ q ) ∨

~q

c) (( p ∧ q )

∧ ( p∧

s ))

t

Rezultă din TEOREMA 1.1.1 care spune că toate modurile de a adăuga paranteze la p ∧ q ∧ r ∧ s ∧ t sunt logic echivalente. Astfel, de exemplu ( ( p ∧ q ) ∧ ( p ∧ s ) ) ∧ t ( p ∧( q ∧r ) ) ∧( s t) ∧ ( s ∧ t ).

Un asemenea circuit se numeşte o poartă AND multiplă şi este reprezentată prin următoarea diagramă: p q and r s t Porţile Or multiple pot fi construite în mod similar.
26

Găsirea unui circuit care corespunde unui tabel dat de intrare / ieşire
EXEMPLUL 1.4.5. Construirea unui Circuit pentru un Tabel dat de Intrare / Ieşire Construiţi un circuit pentru următorul tabel de intrare / ieşire:

Intrare p 1 1 1 1 0 0 0 0 q 1 1 0 0 1 1 0 0 r 1 0 1 0 1 0 1 0

Ieşire s 1 0 0 1 0 1 1 0

Soluţii: • • • • Expresia pentru primul rând este p ∧ q ∧ r Expresia pentru rândul patru este p ∧ ~ q ∧ ~ r

∧ q ∧~r Expresia pentru rândul şapte este ~p ∧ ~ q ∧
Expresia pentru rândul şase este ~p

r

Expresia Booleană pentru tabelul de adevăr dat este:

(p

∧q∧

r)

(p

∧ ~ q ∧ ~ r) ∨ (~p ∧ q ∧ ~ r) ∨ (~p ∧ ~ q ∧

r)

Circuitul ce corespunde acestei expresii are diagrama arătată în figura ce urmează:

27

p q r
and

not

and

not or

not

and

not

not

and

not

28

Simplificarea Circuitelor Combinatorii
Să studiem cele două circuite combinatorii arătate în figura care urmează: p r
and or and

q
not

and

p
and

r

q a. b.

Dacă atrageţi atenţia la circuitul (a) veţi vedea că tabelul său de intrare / ieşire este acelaşi cu tabelul circuitului (b). Intrare p 1 1 0 0 q 1 0 1 0 Ieşire r 1 0 0 0

Expresiile Booleene care corespund circuitelor (a) şi (b) sunt: (( p ∧ ~ q ) ∨ (p ∧ q )) ∧ q şi respectiv p ∧ q. Dacă le priviţi ca forme de afirmaţie şi folosiţi TEOREMA 1.1.1., veţi constata că (( p

∧ ~ q )∨

(p

q )) ∧ q

≡ ≡ ≡ ≡

∧ (~ q ∨ q )) ∧ ( p ∧ ( q∨ ~ q ) )∧ ( p ∧ t )∧ q p∧ q
(p

q q

din Legea distributivă (3 din T.1.1.1) din Legea comutativă (1 din T.1.1.1) din Legea negaţiei (5 din T.1.1.1) din Legea identităţii (4 din T.1.1.1)

Rezultă că tabelele de adevăr pentru (( p

∧ ~ q )∨

(p

q )) ∧ q şi p

q sunt aceleaşi.

EXEMPLUL 1.4.6. Simplificarea unui Circuit Aceasta înseamnă găsirea unui circuit care are mai puţine porţi, dar acelaşi tabel de intrare / ieşire.
29

and not

not

and

not

or

and

not

SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.1.4
30

1. Pentru fiecare tabel din 1.1-1.4 construiţi: a). expresia Booleană care are tabelul dat în calitate de tabel de adevăr b). circuitul respectiv care are tabelul dat în calitate de tabel de Intrare/Ieşire. 1.1 Intrare p 1 1 1 1 0 0 0 0 q 1 1 0 0 1 1 0 0 r 1 0 1 0 1 0 1 0 Ieşire s 0 1 0 0 1 0 0 0 Intrare p 1 1 1 1 0 0 0 0 q 1 1 0 0 1 1 0 0 r 1 0 1 0 1 0 1 0 Ieşire s 0 0 1 1 0 1 0 0 1.2

1.3 Intrare p 1 1 1 1 0 0 0 0 q 1 1 0 0 1 1 0 0 r 1 0 1 0 1 0 1 0 Ieşire s 1 0 1 0 0 0 0 1 p 1 1 1 1 0 0 0 0 Intrare q 1 1 0 0 1 1 0 0

1.4 Ieşire r 1 0 1 0 1 0 1 0 s 0 1 0 0 1 0 1 0

2. Folosind regulile de echivalenţă logică expuse în TEOREMA 1.1.1, demonstraţi că orice pereche de circuite din 2.1 -2.4 au acelaşi tabel de Intrare/Ieşire. (Determinaţi expresiile Booleene pentru fiecare circuit. Demonstraţi că aceste expresii sunt logic echivalente dacă ele sunt precăutate ca forme de afirmaţii).

31

2.1
2.2 p

q 2.3 p pq 2.4 q
p

and
and

32

2. LOGICA AFIRMAŢIILOR CUANTIFICATE
2.1 PREDICATE ŞI AFIRMAŢII CUANTIFICATE I
„Oamenii care numesc acesta „instinct” dau doar un nume fenomenului, dar nu explică nimic.” Douglas Adam În gramatică, cuvântul predicat se referă la partea de vorbire care dă informaţie despre subiect. În propoziţia „James este student la Colegiul Bedford” cuvântul „James” este subiectul propoziţiei şi fraza „este student la Colegiul Bedford” este predicat. Predicatul este partea de propoziţie din care a fost scos subiectul. În logică, predicatele pot fi obţinute prin eliminarea oricăror substantive din afirmaţie. De exemplu, fie p înlocuieşte cuvintele „este student la Colegiul Bedford” şi q înlocuieşte cuvintele „este student la”. Atunci şi p, şi q sunt simboluri predicative. Propoziţia „y este student la Colegiul Bedford” şi „x este student la y” sunt notate ca p(x) şi q(x,y) respectiv, unde x şi y sunt variabile predicative care iau valori în categorii apropiate.

DEFINIŢIE: Predicatul este o propoziţie care conţine una sau mai multe variabile şi devine o afirmaţie atunci când anumite valori sunt substituite în locul variabilelor. Domeniul variabilei predicative constă din toate valorile care pot fi substituite în locul variabilei.

Cuantificatorii ∀ şi ∃
Simbolul ∀ înseamnă „pentru toate” şi se numeşte cuantificatorul universal, de exemplu, un alt mod de a exprima propoziţia „toate fiinţele umane sunt muritoare” este: fiinţele umane x, x este muritor. ∀ O altă expresie care poate fi folosită în loc de „pentru toate” sau „pentru fiecare” poate fi „pentru orice” sau „fiind dată”.

DEFINIŢIE: Fie q(x) predicatul şi D domeniul lui x. O afirmaţie universală este o afirmaţie de forma „ ∀ x din D, q(x)”. Se defineşte ca fiind adevărată dacă şi numai dacă q(x) este adevărată pentru orice x din D. Se defineşte ca fiind falsă dacă şi numai dacă q(x) este falsă pentru cel puţin un x din D. O valoare a lui x 0pentru care q(x) este falsă se numeşte counter exemplu pentru afirmaţia universală. EXEMPLUL 2.1.1. Veridicitatea şi Falsitatea Afirmaţiilor Universale a. Fie D o mulţime alcătuită din numerele 1, 2, 3, 4 şi 5 şi fie afirmaţia ∀x din D, x2 ≥ x. Demonstraţi că această afirmaţie este adevărată. Tehnica folosită pentru a arăta dacă afirmaţia universală din Exemplul 2.1.1(a).este adevărată se numeşte metoda epuizării. Simbolul ∃ înseamnă „există” şi se numeşte cuantificatorul existenţei. De exemplu, propoziţia „În cabinetul de Matematică 140 se află un student” poate fi scrisă ca ∃ o persoană s aşa încât s este student în cabinetul de Matematică 140. Pot fi folosite şi alte expresii în loc de „există” ca „acolo este”, „noi putem găsi”, „există cel puţin o”, „pentru unele” sau „pentru cel puţin una”.
33

DEFINIŢIE: Fie q(x) predicat şi D domeniul lui x. O afirmaţie de existenţă este o afirmaţie de forma „ ∃ în D astfel încât q(x)”. Se defineşte ca fiind adevărată dacă şi numai dacă q(x) este adevărată pentru cel puţin un x din D. Este falsă dacă şi numai dacă q(x) este falsă pentru toţi x din D. EXEMPLUL 2.1.2. Veridicitatea şi Falsitatea Afirmaţiilor de Existenţă a. Fie D mulţimea tuturor numerelor întregi şi fie afirmaţia: ∃ m în D astfel încât m2 = m. Demonstraţi că această afirmaţie este adevărată. EXEMPLUL 2.1.3. Traducerea din Limbajul Formal în cel Neformal

∀numere reale x, x2 ≥ o. Soluţie: • Toate numerele reale au pătratul nenegativ. • Fiecare număr real are pătratul nenegativ. • Orice număr real are pătratul nenegativ. • x are pătratul nenegativ,pentru fiecare număr real x.
Pătratul oricărui număr real este nenegativ. (Observaţi că substantivul la singular este folosit pentru a se referi la domeniul când simbolul ∀ este tradus ca „fiecare”, „orice”). EXEMPLUL 2.1.4. Traducerea din Limbajul Formal în Limbajul Neformal Toate triunghiurile au trei vârfuri. Soluţie: ∀triunghiuri T, T are 3 vârfuri.

Afirmaţii Condiţionale Universale
Un argument rezonabil poate fi făcut cu referire la faptul că cea mai importantă formă de afirmaţie în matematică este afirmaţia condiţională universală. x, ∀ dacă p(x)atunci q(x). EXEMPLUL 2.1.5. Scrierea Neformală a Afirmaţiilor Condiţionale Universale

∀animale x, dacă x este un câine, atunci x este un mamifer. Soluţii: Dacă un animal este un câine, atunci x este un mamifer. Oricând un animal este un câine, atunci el este un mamifer. Orice animal care este câine este un mamifer. Toţi câinii sunt mamifere.
EXEMPLUL 2.1.6. Scrierea Formală a Afirmaţiilor Condiţionale Universale

∀x, dacă p(x) atunci q(x). Dacă un număr este întreg, atunci el este un număr raţional. Soluţie: ∀număr x, dacă x este întreg, atunci x este un număr raţional.
34

Forme Echivalente ale Afirmaţiilor Universală şi de Existenţă
Observaţi că aceste două afirmaţii „ ∀ animale x, dacă x este un câine, atunci x este un mamifer” şi „ ∀ câini x, x este mamifer” ‚înseamnă acelaşi lucru. Ambele se traduc neformal „Toţi câinii sunt mamifere”. De fapt, o afirmaţie de forma ∀x din U, dacă p(x) atunci q(x) poate fi oricând rescrisă sub forma ∀x din D, q(x). Prin mărginirea lui U la domeniul D, conţinând toate valorile variabilei x, va rezulta că p(x) este adevărată. EXEMPLUL 2.1.7. Forme Echivalente pentru Afirmaţiile Universale

∀x din U, dacă P(x) atunci Q(x) ∀ animale x, dacă x este peşte, atunci x are aripioare. ∀numere reale x, dacă x este întreg, atunci x este un număr raţional. ∀ poligoane p, dacă p este pătrat, atunci p este dreptunghi.

∀x din D, Q(x) ∀peşte x, x are aripioare. ∀întreg x, x este un număr raţional. ∀pătrate p, p este dreptunghi.

Negaţii ale Afirmaţiilor Cuantificate
TEOREMA 2.1.1 Negaţia unei afirmaţii de forma ∀x din D, Q(x) este logic echivalentă cu o afirmaţie de forma ∃ x din D astfel ca ~Q(x). Simbolic: ~( ∀x din D, Q(x)) ≡ ∃ x din D astfel ca ~Q(x). Astfel: negaţia unei afirmaţii universale („toate sunt”)este logic echivalentă cu o afirmaţie de existenţă („unele nu sunt”). TEOREMA 2.1.2 Negarea unei afirmaţii de forma ∃ x din D astfel ca Q(x) este logic echivalentă cu o afirmaţie de forma ∀x din D, ~Q(x). Simbolic: ~( ∃ x din D astfel ca Q(x)) ≡ ∀x din D, ~Q(x). Astfel: Negaţia unei afirmaţii de existenţă („unele sunt”) este logic echivalentă cu o afirmaţie universală („nu toate sunt”). EXEMPLUL 2.1.8. Negarea Afirmaţiilor Cuantificate a. ∀numere prime p, p este impar. Soluţie: ∃ un număr prim P astfel ca P să nu fie impar. b. ∃ un triunghi T astfel ca suma unghiurilor lui T să fie egală cu 2000. Soluţie: ∀triunghiuri T, suma unghiurilor lui T nu este egală cu 2000.
35

Negaţii ale Afirmaţiilor Condiţionale Universale
Din definiţia negaţiei unei afirmaţii „pentru toate” rezultă că: ~( ∀x, P(x) → Q(x)) ≡ ∃ x astfel ca ~ P(x) → Q(x) (2.1.1) Dar negaţia unei afirmaţii dacă – atunci este logic echivalentă unei afirmaţii şi. Mai precis: ~ (P(x) → Q(x)) ≡ P(x) ∧ ~ Q(x) (2.1.2) Substituind (2.1.2) în (2.1.1), obţinem: ~( ∀x, P(x) → Q(x)) ≡ ∃ x astfel ca (P(x) ∧ ~ Q(x)). Scrisă mai puţin simbolic, aceasta are forma: ~( ∀x, dacă P(x) atunci Q(x)) ≡ ∃ x astfel ca P(x) şi ~ Q(x). EXEMPLUL 2.1.9. Negaţia Afirmaţiilor Condiţionale Universale a. ∀oamenii P, dacă P este blond, atunci P are ochi albaştri. Soluţie: a. ∃ o persoană P astfel încât P este blondă şi P nu are ochi albaştri.

2.2 PREDICATE ŞI AFIRMAŢII CUANTIFICATE II Afirmaţii ce conţin Cuantificatori Multiplicativi
EXEMPLUL 2.2.1. Scrierea Neformală a Afirmaţiilor Cuantificate Multiplicative Rescrieţi fiecare din afirmaţiile următoare fără să folosiţi variabile sau simbolurile ∀ori ∃. ∀număr pozitiv x, ∃ un număr pozitiv y astfel ca y < x. Soluţie : Fiind dat orice număr pozitiv, există un alt număr pozitiv care este mai mic decât numărul dat. Fiind dat orice număr pozitiv, noi putem găsi un număr pozitiv mai mic. Nu există cel mai mic număr pozitiv. EXEMPLUL 2.2.2. Scrierea Formală a Afirmaţiilor Cuantificate Multiplicative Rescrieţi următoarele afirmaţii formal, folosind cuantificatori şi variabile. Fiecare iubeşte pe cineva. Soluţie: ∀oameni x, ∃ o persoană y astfel ca x îl iubeşte pe y.

Negaţia Afirmaţiilor Cuantificate Multiplicative
Negaţia lui poate fi scrisă astfel: Negaţia lui

∀oameni x, ∃ o persoană y astfel ca x îl iubeşte pe y,

∃ o persoană astfel ca ∀oameni y, x nu îl iubeşte pe y.
∀x, ∃ y astfel ca P(x,y)
36

este logic echivalentă cu

∃ x astfel ca ∀y,
Negaţia lui

~ P(x,y).

∃ o persoană x astfel ca ∀oameni y, x îl iubeşte pe y, poate fi scrisă ∀oameni x, ∃ o persoană y astfel ca x nu îl iubeşte pe y. Negaţia lui ∃ x astfel ca ∀y, P(x,y) este logic echivalentă cu ∀x, ∀y astfel ca ~ P(x,y).

Relaţia dintre ∀ ∃, ,

şi

Dacă Q(x) este predicat şi domeniul D de x conţine elementele x1, x2, …, xn, atunci afirmaţiile ∀x din D, Q(x) şi Q(x1) ∧ Q(x2) ∧ ... ∧ Q(xn) sunt logic echivalente. Similar, dacă Q(x) este predicat şi domeniul D de x constă din elementele x1, x2, …, xn, afirmaţiile ∃ x din D astfel ca Q(x) şi Q(x1) ∨ Q(x2) ∨ … ∨ Q(xn) sunt logic echivalente.

Variante de afirmaţii condiţionale universale

DEFINIŢIE: Fiind dată afirmaţia de forma ∀x din D, dacă P(x) atunci Q(x) 1. Contrapozitiva sa este afirmaţia: ∀x din D, dacă ~Q(x) atunci 2. Conversa sa este afirmaţia: ∀x din D, dacă Q(x) atunci P(x); 3. Inversa sa este afirmaţia: ∀x din D, dacă ~P(x) atunci ~Q(x); •

~P(x);

Afirmaţia condiţională universală este logic echivalentă cu contrapozitiva sa: ∀x din D, dacă P(x) atunci Q(x) ≡ ∀x din D, dacă ~Q(x) atunci ~P(x); • Afirmaţia condiţională universală nu este logic echivalentă cu conversa sa: ∀x din D, dacă P(x) atunci Q(x) ≠ ∀x din D, dacă Q(x) atunci P(x); • Afirmaţia condiţională universală nu este logic echivalentă cu inversa sa: ∀x din D, dacă P(x) atunci Q(x) ≠ ∀x din D, dacă ~P(x) atunci ~Q(x).

Condiţiile necesare şi Suficiente, „Numai Dacă”

37

Definiţia condiţiei necesare, suficiente şi numai dacă poate fi, de asemenea, extinsă pentru a fi aplicată la afirmaţia condiţională universală.

DEFINIŢIE: 1. „ ∀x, r(x) este o condiţie suficientă pentru S(x)” înseamnă „ ∀x, dacă r(x) atunci S(x)”. 2. „ ∀ x, r(x) este o condiţie necesară pentru S(x)” înseamnă „ ∀ x, dacă ~r(x) atunci ~S(x)” sau, echivalent, „ ∀x, dacă S(x) atunci r(x)”. 3. „ ∀ x, r(x) numai dacă S(x)” înseamnă „ ∀ x, dacă ~r(x) atunci ~S(x)” sau, echivalent, „ ∀ x, dacă r(x) atunci S(x)”.

Argument cu Afirmaţii Cuantificate
Regula instanţierii universale spune că: Dacă careva proprietate este adevărată pentru tot într-un domeniu, atunci este adevărat pentru orice lucru particular în acel domeniu.

Modus Ponens universal
Regula instanţierii universale poate fi combinată cu modus ponens pentru a obţine regula numită modus ponens universal. Următoarea formă de argument este valabilă: Versiunea formală Versiunea neformală ∀x, dacă P(x) atunci Q(x) Dacă x face P(x) adevărată, atunci x face Q(x) adevărată P(c) pentru un anumit c c face P(x) adevărată ∴ Q(x) ∴ c face Q(x) adevărată

Modus Tollens universal
Următoarea formă de argument este valabilă: Versiunea formală Versiunea neformală ∀x, dacă P(x) atunci Q(x) Dacă x face P(x) adevărată, atunci x face Q(x) adevărată ∴

~Q(c) pentru un anumit c ~p(c)

c nu face Q(x) adevărată ∴ c nu face P(x) adevărată

Demonstrarea Valabilităţii unui Argument cu Afirmaţie Cuantificată
Un argument este valabil dacă şi numai dacă veridicitatea concluziei lui rezultă în mod necesar din veridicitatea premiselor lui.

DEFINIŢIE: A spune că o formă de argument este valabilă înseamnă următoarele: Indiferent de faptul care predicate anumite sunt substituite de simbolurile predicative în premisele ei, dacă afirmaţiile premiselor rezultante sunt toate adevărate, atunci concluzia este, de asemenea, adevărată. Un argument se numeşte valabil dacă şi numai dacă forma sa este valabilă. EXEMPLUL 2.2.3. Folosirea Diagramei pentru a demonstra Valabilitatea

38

Folosiţi o diagramă pentru a demonstra valabilitatea următorului silogism indirect: Toate fiinţele umane sunt muritoare Zeus nu este muritor ∴ Zeus nu este o fiinţă umană Soluţii: 1) muritorii muritorii Fiinţele umane 2) 3) muritorii

Fiinţele umane Zeus Zeus

EXEMPLUL 2.2.4. Folosirea Diagramei pentru a demonstra nevalabilitatea următorului argument: Toate fiinţele umane sunt muritoare Felix este muritor Felix este o fiinţă umană. 2) 3) muritori Fiinţele umane Felix 4) muritori

∴ 1) muritori

muritorii Felix

Fiinţele umane

Fiinţele umane

Eroarea conversă (forma cuantificată)
Următoarea formă de argument este nevalabilă: Versiunea formală Versiunea neformală ∀x, dacă P(x) atunci Q(x) Dacă x face P(x) adevărată, atunci x face Q(x) adevărată Q(c) pentru un anumit c c face Q(x) adevărată ← concluzie valabilă ← concluzie ∴ P(c) ∴ c face P(x) adevărată nevalabilă

Eroarea inversă (forma cuantificată)
Următoarea formă de argument este nevalabilă: Versiunea formală Versiunea neformală
39

∀x, dacă P(x) atunci Q(x)

Dacă x face P(x) adevărată, atunci x face Q(x) adevărată c nu face P(x) adevărată ∴ c nu face Q(x) adevărată

~P(c) pentru un anumit c ~Q(c) ← concluzie nevalabilă

← oncluzie nevalabilă

SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.2.1
40

1. Găsiţi exemple opuse prin care să demonstraţi că afirmaţiile 1.1-1.4 sunt false:
1.1 1.2 1.3 1.4 2. ∀ număr real x, x > 1/x ∀ număr întreg a, (a – 1)/a nu este un număr întreg ∀ numere întregi pozitive m şi n, m*n ≥ m + n ∀ numere reale x şi y, √(x + y) = √x + √y

Fie D o mulţime alcătuită din următoarele numere {-48, -14, -8, 0, 1, 3, 16, 23, 26, 32, 36}. Determinaţi care din următoarele afirmaţii sunt adevărate şi care sunt false. Aduceţi exemple opuse pentru acele afirmaţii care sunt false. 2.1 2.2 2.3 2.4 2.5 ∀ x din D, dacă x este impar atunci x > 0 ∀ x din D, dacă x este mai mic ca 0 atunci x este par ∀ x din D, dacă x este par atunci x ≤ 0 ∀ x din D, dacă numărul unităţilor lui x este 2, atunci numărul zecilor este 3 sau 4 ∀ x din D, dacă numărul unităţilor lui x este 6, atunci numărul zecilor este 1 sau 2.

3. Găsiţi contrapozitiva, conversa şi inversa pentru fiecare din afirmaţiile din 3.1-3.8: ∀ numere reale x, dacă x>2 atunci x2 > 4 3.2 ∀ programe computaţionale P, dacă P este corect atunci P compilează fără erori mesajele 3.3 Dacă un întreg este divizibil cu 6, atunci el este divizibil cu 3 3.4 Dacă pătratul unui întreg este par, atunci şi întregul este un număr par 3.5 ∀ numere reale x, dacă x(x + 1) > 0 atunci x > 0 sau x < -1 3.6 ∀ numere întregi n, dacă n este un număr prim atunci n este impar sau n=2 3.7 ∀ numere întregi a, b şi c, dacă a-b este par şi b-c este par, atunci a-c este par 3.8 ∀ animale A, dacă A este o pisică atunci A are mustăţi şi A are gheare. 3.1

4.

Careva dintre afirmaţiile din 4.1-4.9 sunt valabile prin modus ponens universal sau prin modus tollens universal; altele sunt nevalabile şi reprezintă erori converse sau inverse. Constataţi care afirmaţii sunt valabile şi care sunt nevalabile. Justificaţi răspunsurile Dv. 4.1 Toţi oamenii sănătoşi mănâncă un măr pe zi Elena mănâncă un măr pe zi .˙. Elena este sănătoasă 4.2 Toţi bobocii trebuie să ia cursul de educaţie fizică Carolina este boboc .˙. Carolina trebuie să ia cursul de educaţie fizică 4.3 Toţi oamenii sănătoşi mănâncă un măr pe zi Ion nu este sănătos .˙. Ion nu mănâncă un măr pe zi 4.4
41

Dacă produsul a două numere este 0, atunci cel puţin unul din numere este 0 Pentru un număr concret x, nici (x-1) nici (x + 1) nu este egal cu 0 .˙. Produsul (x -1) (x + 1) nu este egal cu 0 4.5 Toţi cei care trişează stau în ultimul rând George stă în ultimul rând .˙. George este un trişor 4.6 Toţi oamenii oneşti îşi plătesc taxele Dorin nu este onest .˙. Dorin nu-şi plăteşte taxele 4.7 Pentru toţi studenţii x, dacă x studiază matematica discretă, atunci x are o logică bună Diana studiază matematica discretă .˙. Diana are o logică bună 4.8 Orice sumă a două numere raţionale este şi ea raţională Suma r + s este raţională .˙. Numerele r şi s sunt ambele numere raţionale 4.9 Dacă un număr este par, atunci şi îndoitul produs al acelui număr este par Numărul 2n este par, pentru un anumit număr n .˙. n este par.

42

3. TEORIA MULŢIMILOR
Fie S reprezintă o mulţime şi a este un element din S. Atunci a ∈ S se citeşte „a aparţine lui S”, „a este un element din S”, „a este în S”. Este adevărată A = {x ∈ S | P(x) } Mulţimea tuturor Astfel ca

Submulţime

DEFINIŢIE: Dacă A şi B sunt mulţimi, A se numeşte o submulţime a lui B: se scrie A ⊆ B, dacă şi numai dacă fiecare element din A este, de asemenea, element al mulţimii B. Simbolic: A ⊆ B ⇔ ∀x, dacă x ∈ A, atunci x ∈ B . Frazele A se conţine în B şi B conţine pe A sunt moduri alternative de a spune că A este o submulţime a lui B. A ⊄ B ⇔ ∃ x astfel ca x ∈ A şi x ∉B.

DEFINIŢIE: Fie A şi B sunt două mulţimi, A este un submulţime proprie a lui B dacă şi numai dacă fiecare element din A este în B, dar există cel puţin un element din B care nu se găseşte în A. Diagramele lui Venn: A⊆ B A B A=B

a) A⊄ B

b)

A

B

B

A

a)

b)

c)

☞ ☞

DEFINIŢIE: Fiind date mulţimile A şi B, A este egal cu B, se scrie A = B, dacă şi numai dacă fiecare element din A este în B şi fiecare element din B este în A. Simbolic: A = B ⇔ A ⊆ B şi B ⊆ A. DEFINIŢIE: Fie A şi B submulţimi ale unei mulţimi universale U. 1. Reuniunea lui A şi B, notată cu A ∪ B este mulţimea tuturor elementelor x din U aşa încât x se găseşte în A sau x se găseşte în B.

43

2. Intersecţia lui A şi B, notată cu A ∩ B, este mulţimea tuturor elementelor x din U aşa încât x se găseşte în A şi x se găseşte în B. 3. Diferenţa lui B minus A (sau complementara relativă a lui A în B), notată cu B – A, este mulţimea tuturor elementelor x din U aşa încât x se găseşte în B şi x nu se găseşte în A. 4. Complementara lui A, notată cu Ac, este mulţimea tuturor elementelor x din U, aşa încât x nu se găseşte în A. Simbolic: A ∪ B = { x ∈ U | x ∈ A sau x ∈ B } A ∩ B = { x ∈ U | x ∈ A şi x ∈ B } B – A = { x ∈ U | x ∈ B şi x ∉A } Ac = { x ∈ U | x ∉A }

Regiunea colorată reprezintă A ∪ B, A ∩ B, B – A, Ac Figura 3.1 Reprezentarea reuniunii, intersecţiei, diferenţei şi complementarei prin Diagramele lui Venn

Produsul Cartezian

DEFINIŢIE: Fie n un număr întreg şi x1, x2, … xn nişte elemente (nu neapărat distincte). Şirul ordonat n (x1, x2, … xn), care constă din elementele x1, x2, … xn în ordinea: mai întâi x1, apoi x2 şi aşa mai departe până la xn. Un şir ordonat de 2 elemente se numeşte pereche ordonată şi un şir ordonat din 3 elemente se numeşte triplet ordonat. Două şiruri ordonate de n elemente (x1, x2, … xn) şi (y1, y2, … yn) sunt egale dacă şi numai dacă x1 = y1, x2 = y2, … xn = yn. Simbolic: (x1, x2, … xn) = (y1, y2, … yn) ⇔ x1 = y1, x2 = y2, … xn = yn. În particular: (a, b) = (c, d) ⇔ a = c şi b = d.

DEFINIŢIE: Fiind date două mulţimi A şi B, Produsul Cartezian al lui A şi B, notat cu A × B, este mulţimea tuturor perechilor ordonate (a, b) unde a aparţine lui A şi b aparţine lui B. Fiind date mulţimile A1, A2, … An, Produsul Cartezian al lui A1 × A2 × … × An este mulţimea tuturor n şiruri ordonate (a1, a2, … an) unde a1 ∈ A1, a2 ∈ A2, an ∈ An. Simbolic: A × B = { (a, b) | a ∈ A şi b ∈ B }, A1 × A2 × … × An = { (a1, a2, … an) | a1 ∈ A1, a2 ∈ A2, an ∈ An }.

Limbaje formale
În ştiinţa calculatoarelor orice mulţime finită de simboluri poate fi folosită ca alfabet. (se notează Σ ).

44

Un limbaj formal pe un alfabet este orice mulţime de şiruri de caractere ale alfabetului. Definiţiile de mai sus sunt rezumate mai jos: Alfabetul Σ: o mulţime finită de caractere. Şir de caractere pe Σ: un şir ordonat de n caractere pe Σ, scris fără paranteze sau virgule, sau simbolul nul ε. Limbaj formal pe Σ: un şir de caractere pe Σ. EXEMPLUL 3.1. Exemple de Limbaje Formale Fie alfabetul Σ = { a, b }. Definiţi limbajul L2 peste Σ ca fiind mulţimea tuturor şirurilor de caractere de lungime finită care să arate la fel scrise de la dreapta la stânga sau de la stânga la dreapta. Scrieţi 10 elemente din L2. Soluţie: L2 conţine următoarele 10 şiruri de caractere: L2: ε, a, b, aa, bb, aba, bab, abba, baab, baabbbbaab. Notaţie: Fie Σ un alfabet. Pentru fiecare număr întreg nenegativ n, fie Σn = mulţimea tuturor şirurilor de caractere peste Σ care au lungimea n şi Σ* = mulţimea tuturor şirurilor de caractere de lungime finită peste Σ. EXEMPLUL 3.2. Fie Σ = { a, b } Găsiţi Σ0, Σ1, Σ2 şi Σ3.

Proprietăţile Mulţimilor
TEOREMA 3.1 Unele Relaţii dintre Submulţimi 1 Incluziunea intersecţiei: Pentru toate mulţimile A şi B, (a) A ∩ B ⊆ A şi (b) A ∩ B ⊆ B. 2 Incluziunea reuniunii: Pentru toate mulţimile A şi B, (a) A ⊆ A ∪ B şi (b) B ⊆ A ∪ B. 3 Proprietatea tranzitivă a submulţimilor: Pentru toate mulţimile A, B şi C, Dacă A ⊆ B şi B ⊆ C, atunci A ⊆ C. TEOREMA 3.2. Identificatorii Mulţimilor Fie toate mulţimile la care se va face referinţă mai jos nişte submulţimi ale unei mulţimi universale U. 1. Legea Comutativă: pentru toate mulţimile A şi B, (a) A ∩ B = B ∩ A, şi (b) A ∪ B = B ∪ A. 2. Legea Asociativă: pentru toate mulţimile A, B şi C, (a) (A ∩ B) ∩ C = A ∩ (B ∩ C) (b) (A ∪ B) ∪ C = A ∪ (B ∪ C). 3. Legea Distributivă: pentru toate mulţimile A, B şi C, (a) A ∪ (B ∩ C) = (A ∪ B) ∩ (A ∪ C) şi (b) A ∩ (B ∪ C) = (A ∩ B) ∪ (A ∩ C). 4. Intersecţia cu U (U joacă rol de Identificator pentru ∩ ); pentru toate mulţimile A, A ∩ U = A. 5. Legea dublei complementarităţi: pentru toate mulţimile A,
45

(Ac)c = A. 6. Legea idempotenţei: pentru toate mulţimile A, (a) A ∩ A = A şi (b) A ∪ A = A. 7. Legile lui De Morgan: pentru toate mulţimile A şi B, (a) (A ∪ B)c = Ac ∩ Bc şi (b) (A ∩ B)c = Ac ∪ Bc. 8. Reuniunea cu U (U joacă rol de Legătură Universală pentru U), A ∪ U = U. 9. Legea Absorbţiei: pentru toate mulţimile A şi B, (a) A ∪ (A ∩ B) = A şi (b) A ∩ (B ∪ C) = A. 10. Reprezentarea alternativă pentru diferenţa mulţimilor: pentru toate mulţimile A şi B, A – B = A ∩ Bc.

Mulţimea vidă, Partiţii şi Mulţimile Putere
TEOREMA 3.3. O mulţime care nu are nici un element este o submulţime a oricărei mulţimi. Dacă Ø este o mulţime cu nici un element şi A este oricare mulţime, atunci Ø ⊆ A.

DEFINIŢIE: Mulţimea unică cu nici un element se numeşte mulţimea vidă. Se notează cu simbolul Ø. Fie toate mulţimile la care se face referinţă mai jos submulţimi ale mulţimii universale U. 1. Reuniunea cu Ø (Ø joacă rol de Identificator pentru U): pentru toate mulţimile A, A ∪ Ø = A. 2. Intersecţia şi Reuniunea cu complementara: pentru toate mulţimile A, (a) A ∩ Ac = Ø şi (b) A ∪ Ac = U. 3. Intersecţia cu Ø (Ø joacă rol de legătură universală pentru ∩ ): pentru toate mulţimile A, A ∪ Ø = Ø. 4. Complementarele lui U şi Ø: (a) Uc = Ø şi (b) Øc = U.

Algebra Booleană
Algebra Booleană este o mulţime S cu două operaţii, notate în mod general cu + şi ο . Astfel pentru toate a şi b din S, şi a + b, şi a ο b sunt în S şi au loc următoarele axiome: 1. Pentru toate a şi b din S, a + b = b + a (legea comutativă a +) şi a ο b = b ο a (legea comutativă a ο ) 2. Pentru toate a, b şi c din S, (a + b) + c = a + (b + c) (legea asociativă a +) (a ο b) ο c = a ο (b ο c) (legea asociativă a ο ) 3. Pentru toate a, b şi c din S, a + (b ο c) = (a + b) ο (a +c) (legea distributivă a + peste ο ) şi a ο (b + c) = (a ο b) + (a ο c) (legea distributivă a ο peste + ) 4. Există elementele distincte Ø şi 1 în S aşa încât pentru toate a din S, a + Ø = a (Ø este un identificator pentru +) şi a ο 1 = a (1 este un identificator pentru ο )
46

5. Pentru fiecare a din S, există un element notat cu a şi numit complementul sau negaţia lui a din S astfel încât: a + a = 1 şi a ο a = 0.

DEFINIŢIE: Două mulţimi sunt numite disjuncte dacă şi numai dacă ele nu au nici un element în comun. Simbolic: A şi B sunt disjuncte ⇔ A ∩ B = Ø. TEOREMA 3.4. Fiind date două mulţimi A şi B, (A - B) şi B sunt disjuncte. DEMONSTRARE….

☞ ☞

DEFINIŢIE: Mulţimile A1, A2, … An sunt reciproc disjuncte dacă şi numai dacă orice două mulţimi Ai şi Aj cu indici diferiţi nu au nici un element în comun. Mai precis, pentru orice i, j = 1,2, …, n. A i ∩ Aj = Ø, atâta timp cât i ≠ j. DEFINIŢIE: O uniune de mulţimi nevide {A1 × A2 × … 1. A = A1 ∪ A2 ∪ … ∪ An; 2. A1, A2,…, An sunt reciproc disjuncte.

× An} este o

partiţie a unei mulţimi A dacă şi numai dacă:

EXEMPLUL 3.3. Fie A = {1, 2, 3, 4, 5, 6}; A1 = {1, 2}; A2 = {3, 4} şi A3 = {5, 6}. Este oare {A1, A2, A3} o partiţie a lui A?

DEFINIŢIE: Fiind dată o mulţime A, mulţimea putere a lui A, notată cu P(A), este mulţimea tuturor submulţimilor lui A. EXEMPLUL 3.4. Mulţimile Putere ale unei Mulţimi Găsiţi mulţimea putere a mulţimii {x, y}, adică găsiţi P ({x, y}). Soluţie: P ({x, y}) = { Ø , {x}, {y}, {x, y}}. TEOREMA 3.5 Pentru toate mulţimile A şi B, dacă A ⊆ B, atunci P (A) ⊆ P (B). TEOREMA 3.6 Pentru toate numerele întregi n, dacă o mulţime X are n elemente, atunci P(x) are 2n elemente. Demonstrare (prin inducţie matematică)… SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.3.1

47

1. Fie mulţimea universală mulţimea numerelor reale R şi fie A={x∈R | 0<x<=2} şi B={x∈R |
1<=x<4} Care va fi rezultatul următoarelor operaţii: a. A ∪ B; b. A ∩ B; c. AC; d. BC; e. AC ∩ BC; f. AC ∪ BC;

2. Definim mulţimile R, S şi T după cum urmează:
R = {x∈Z | x este divizibil cu 2}, S = {y∈Z | y este divizibil cu 3}, T = {z∈Z | z este divizibil cu 6}

a) d)

Este adevărat că: R ⊆ T? T ⊆ R? T ⊆ S? Găsiţi rezultatul operaţiei R ∩ S.

3. Fie A = {a, b, c}, B = {b, c, d} şi C = {b, c, e} a)
Găsiţi A ∪ (B ∩ C), (A ∪ B) ∩ C şi (A ∪ B) ∩ (A ∪ C). Care din aceste mulţimi sunt egale? b) Găsiţi A ∩ (B ∪ C), (A ∩ B) ∪ C şi (A ∩ B) ∪ (A ∩ C). Care din aceste mulţimi sunt egale? c) Găsiţi (A – B) – C şi A – (B – C). Sunt oare aceste mulţimi egale?

4. Fie A = {1, 2, 3}, B = {U, V} şi C = {m, n}. Găsiţi elementele următoarelor mulţimi:
a) b) c) A x (B x C) (A x B) x C A x B x C.

5. Fie mulţimea universală mulţimea numerelor reale R şi A = {x∈R | -2 <= x <= 1}, iar B =
{x∈R | -1 < x < 3}. Găsiţi rezultatele următoarelor operaţii: a) A∪B b) A∩B c) AC d) BC e) A C ∩ BC f) AC ∪ BC.

48

4. FUNCŢII
Funcţii definite pe mulţimi generale

DEFINIŢIE:

O funcţie f din mulţimea X cu valori în Y este o regulă de corespondenţă prin care fiecare element din X este asociat cu un element unic din Y. Notaţia f: X → Y înseamnă că f este o funcţie din x spre Y. X se numeşte domeniul lui f şi Y se numeşte co-domeniul lui f. Fiind dat un element x din X, există un element unic din Y care corespunde lui x. Se spune „f trimite x spre y” şi se scrie x → y. Elementul unic y spre care f îl trimite pe x se notează: f(x) şi se numeşte f de x sau valoarea lui f în x, sau imaginea lui x prin f. Mulţimea valorilor lui f luate împreună se numeşte rangul lui f sau imaginea lui x prin f. Simbolic: rangul lui f = { y ∈ Y | y = f(x), pentru careva x din X}. Fiind dat un element y din Y, există un element în X care au ca imagine pe y. Mulţimea tuturor elementelor de aşa fel se numeşte imaginea inversă a lui y. Simbolic: imaginea inversă a lui y = { x ∈ X | f(x) = y}. X f Y X
X1 *

f

Y
Y1 * Y2 * Y3 * Y4 * Y5 *

f(x)

X2 * X3 * X4 *

O funcţie f din X în Y ia elemente x din X şi le trimite la elemente f(x) din Y. Figura 4.1

domeniu

co-domeniu Diagrama cu săgeţi Figura 4.2

EXEMPLUL 4.1. Diagrama Săgeată pentru o Funcţie definită pe o Mulţime Infinită Definiţi o funcţie f pe mulţimea tuturor numerelor întregi Z spre ea însăţi după regula n → 2n; aceasta înseamnă f(n) = 2n pentru toate numerele n ∈ Z. a. Desenaţi o diagramă săgeată pentru f. b. Găsiţi f(f(1)) şi f(f(f(3))). Soluţie:… f(f(1)) = f(2) = 4 (deoarece2 = 2*1 şi 4 = 2*2) f(f(f(3))) = f(f(6)) = f(12) = 24 (deoarece 6 = 2*3

şi 12 = 2*6

şi 24 = 2*12 )
49

Z f

Z *-6 *-5 *-4 *-3 *-2 *-1 *0 *-1 *-2 *-3 *-4 *-5 *-6

3* 2* 1* 0* -1* -2* -3*

Figura 4.3

Maşini funcţionale

Figura 4.4

DEFINIŢIE: Fie f şi g sunt funcţii din X în Y. Atunci f este egal cu g, se scrie f = g dacă şi numai dacă f(x) = g(x) pentru toţi x ∈ X. EXEMPLUL 4.2. Funcţie Definită pe un Limbaj ∑ este un alfabet.
50

∑* este mulţimea tuturor şirurilor de caractere peste ∑. Fie ∑ = {a, b}şi să definim o funcţie g: ∑* → Z după cum urmează: pentru fiecare şir de caractere s ∈ ∑* , g(s) = numărul de litere a din s. Soluţie: g(bb) este 0, g(bbbaa) este 2. EXEMPLUL 4.3 Funcţia Distanţa lui Hamming Funcţia Distanţa lui Hamming dă o valoare a „diferenţei” dintre două şiruri de caractere de 0-uri şi 1-uri care au aceeaşi lungime. Fie ∑ = {0, 1}. Atunci ∑n este mulţimea tuturor şirurilor de caractere de 0 şi 1 de lungimea n. Definiţi o funcţie: H: ∑n x ∑n → Z+ după cum urmează: pentru fiecare pereche de şiruri de caractere (s,t) ∈ ∑n x ∑n, H (s, t) = numărul de poziţii în care s şi t au valori diferite. Găsiţi: a) H (11111, 00000); b) H (11000, 00000); c) H (00101, 01110). Soluţie: a) 5, b) 2, c) 3.

Funcţii Booleene
Două reprezentări ale unei funcţii Booleene a) b) P 1 1 1 1 0 0 0 0 Q 1 1 0 0 1 1 0 0 R 1 0 1 0 1 0 1 0 S 1 1 0 1 0 0 0 1

Figura 4.5

DEFINIŢIE: O funcţie booleană f (locul - n) este o funcţie a cărui domeniu este mulţimea tuturor perechilor n ordonate de o şi 1 şi a cărui domeniu este mulţimea {0,1}. Mai formal, domeniul unei funcţii booleene poate fi descris ca produsul cartezian de n copii ale mulţimii {0,1}, care se notează cu {0,1}n. Astfel f: {0,1}n → {0,1}. EXEMPLUL 4.4. O Funcţie Booleană Considerăm funcţia booleană de 3 locuri definită pe mulţimea tuturor cuplurilor de 3 din 0 şi 1 cu valori în mulţimea {0,1} prin regula: pentru fiecare triplet {x1,x2,x3} de 0 şi de 1 f(x1,x2,x3) = (x1+x2+x3) mod2.
51

Soluţie: f(1,1,1) = (1+1+1) mod2 = 3mod2 = 1 f(1,1,0) = (1+1+0) mod2 = 2mod2 = 0

/*mod – restul de la împărţire */

Aplicaţie: Automate Finite

Figura 4.6 SCHEMA UNUI AUTOMAT SIMPLU DE VÂNZARE A UNUI OBIECT STARE → 0 bani depozitaţi 5 bani depozitaţi 10 bani depozitaţi 15 bani depozitaţi 20 bani depozitaţi 5 bani 5 bani depozitaţi 10 bani depozitaţi 15 bani depozitaţi 20 bani depozitaţi 5 bani depozitaţi INTRARE 10 bani 10 bani depozitaţi 15 bani depozitaţi 20 bani depozitaţi ori mai mulţi 20 bani depozitaţi ori mai mulţi 10 bani depozitaţi

Automate Finite

DEFINIŢIE: Un automat finit constă din 5 componente: 1. o mulţime I, numită alfabetul de intrare, a simbolurilor de intrare; 2. o mulţime S a stărilor în care automatul se poate afla; 3. o stare predefinită S0, numită starea iniţială; 4. o mulţime de stări, numită mulţimea stărilor acceptate; 5. o funcţie starea următoare, notată N : S x I → S care asociază o „stare următoare” fiecărei perechi ordonate formate din „starea curentă” şi „simbolul de intrare”. Pentru fiecare stare s din S şi simbolul de intrare m din I, N(s,m) se numeşte starea în care trece A dacă m este simbolul de intrare pentru A când A se află în starea s.

52

EXEMPLUL 4.5

Figura 4.7 Automatul Finit A

Limbajul Acceptat de un Automat

DEFINIŢIE: Fie A un automat finit cu mulţimea de simboluri de intrare I. Fie I* mulţimea tuturor şirurilor de caractere pe I şi fie w un şir de caractere din I*. Atunci w este acceptat de A dacă şi numai dacă A trece într-o stare acceptată când simbolurile lui w sunt simboluri de intrare pentru A, începând cu starea iniţială a lui A. Limbajul acceptat de A, notat cu L(A), este mulţimea tuturor şirurilor de caractere acceptate de A. EXEMPLUL 4.6. Găsirea Limbajului acceptat de un Automat Vedeţi desenul din Figura 4.7. Care este limbajul acceptat de A? Soluţie:  Mai întâi, observaţi faptul că dacă w este orice şir de caractere care se sfârşeşte cu 01, atunci w este acceptat de A.  Apoi observaţi faptul că unicul şir de caractere acceptat de A este acel care se sfârşeşte cu 01.

Funcţia de Trecere a Automatului din Starea Iniţială într-o altă Stare

DEFINIŢIE: Fie A automatul finit cu mulţimea de stări S, mulţimea simbolurilor de intrare I şi funcţia starea următoare N : S x I → S. Fie I* mulţimea tuturor şirurilor de caractere pe I şi definiţi funcţia de trecere N* : S x I* → S după cum urmează: pentru orice stare s şi pentru orice şir de caractere w, starea în care trece A dacă simbolurile lui w sunt simboluri de N*(s,w) = intrare pentru A începând cu momentul când A se află în starea s EXEMPLUL 4.7. Găsirea Valorilor Funcţiei de Trecere Găsiţi N*(S1, 10110). Soluţie: Din definiţia funcţiei de trecere rezultă:
53

starea în care trece A dacă simbolurile 10110 sunt simboluri de N*(S1, 10110) = intrare pentru A începând cu momentul când A se află în starea S1

Figura 4.8. S1 1 → S2 0 → S1 1 → S2 1 → S0 0 → S1 N*(S1, 10110) = S1

EXEMPLUL 4.8 Automat care Recunoaşte Şirurile de Caractere care se Sfârşesc cu 011. Soluţie:

Figura 4.9.

Algoritmul Automatelor Finite
(intrare:şir de caractere, ieşire:stare) Acest algoritm simulează acţiunea automatului finit din Figura 4.9. Intrare: un şir de caractere [un şir de caractere format din 0 şi 1, plus un marcher de sfârşit e] Algorithm Body: State: = 0 Symbol: = primul simbol din şirul de caractere de intrare While (symbol ≠ e) if state = 0 then if symbol = 0 then state : = 1 else state : = 0 else if state = 1 then if symbol = 0
54

then state : = 1 else state : = 2 else if state = 2 then if symbol = 0 then state : = 1 else state : = 3 else if state = 3 then if then symbol = 0 then state : = 1 else state : = 0 symbol : = următorul simbol din şirul de intrare end while [După executarea ciclului while, valoarea stării este 3 dacă şi numai dacă şirul de intrare se sfârşeşte cu 011e.] end Algorithm. Algoritm Un automat finit (intrare:şir de caractere, ieşire:stare) [Acest algoritm simulează acţiunea automatului finit din EXEMPLUL 7.1.18 prin aplicarea repetată a funcţiei starea următoare. Stările sunt notate cu 0,1,2 şi 3.] Intrare: şir de caractere [şir de caractere format din 0 şi 1, plus un marcher de sfârşit e.] Algorithm Body: N(0,0) : = 1; N(0,1) : = 0; N(1,0) : = 1; N(1,1) : = 2; N(2,0) : = 1; N(2,1) : = 3; N(3,0) : = 1; N(3,1) : = 0. State : = 0 Symbol : = primul symbol din şirul de intrare While (symbol ≠ e) state : = N(state,symbol) symbol : = următorul simbol din şirul de intrare end while end algorithm.

Funcţii one – to – one, onto şi inversă

DEFINIŢIE: Fie F o funcţie din X cu valori în Y. F este one-to-one(sau injectivă) dacă şi numai dacă pentru toate elementele x1 şi x2 din X, dacă F(x1) = F(x2), atunci x1=x2 sau, în mod echivalent, dacă x1≠x2, atunci F(x1) ≠ F(x2) În mod simbolic aceasta se notează astfel: F:X

→ Y este injectivă ⇔ ∀x1, x2 ∈ X, dacă F(x1) = F(x2) atunci x1 = x2. → Y nu este one-to-one ⇔ ∃ aşa elemente x1 şi x2 în X astfel încât F(x1) = F(x2) şi
Y – co-domeniul lui F O funcţie injectivă

O funcţie F : X x1 ≠ x2.

X – domeniul lui F

55

O funcţie care nu este injectivă Figura 4.10.

DEFINIŢIE: Fie F o funcţie din mulţimea X pe mulţimea Y. F este onto (sau surjectivă) dacă şi numai dacă pentru orice element y din Y este posibil de găsit un element x din X astfel încât y = F (x). În mod simbolic: F : X → Y este surjectivă ⇔ ∀y ∈ Y, ∃ x ∈ X astfel încât F(x) = y. F : X → Y nu este surjectivă ⇔ ∃ y ∈ Y astfel încât ∀x ∈ X F(x) ≠ y. EXEMPLUL 4.9 O funcţie surjectivă X – domeniul lui F domeniul lui F Y – co-

Fiecare element y din Y este egal cu F(x) pentru cel puţin un x din X.

Figura 4.11. EXEMPLUL 4.10 O funcţie care nu este surjectivă X – domeniul lui F Y – co-domeniul lui F Cel puţin un element din Y nu este egal cu F(x) pentru orice x din X

Figura 4.12

DEFINIŢIE: O corespondenţă one-to-one (sau bijecţie) de la o mulţime X la o mulţime Y este o funcţie F : X → Y care este şi bijectivă, şi surjectivă.

Funcţie Inversă

56

TEOREMA 4.1 Presupunem că F : X → Y este bijectivă; aceasta înseamnă că F este injectivă şi surjectivă. Atunci este o funcţie F-1 : X → Y care este definită astfel: Fiind dat orice element y din Y, F-1 = acel element unic x din X astfel încât F(x) este egal cu y. Cu alte cuvinte, F-1(y) = x ⇔ y = F(x).

DEFINIŢIE: Funcţia F-1 din teorema precedentă se numeşte funcţie inversă lui F. X domeniul lui F Y co-domeniul lui F

Figura 4.13

Compoziţia Funcţiilor

Figura 4.14 Mai întâi adăugaţi 1, apoi ridicaţi la pătrat funcţia rezultat.

DEFINIŢIE: Fie f : X → Y şi fie q : Y’ → Z funcţia cu proprietatea că co-domeniul lui f este o submulţime a domeniului lui g. Definiţi o funcţie nouă g f după următoarea regulă: Pentru toţi x ∈ X g f (x) = g(f(x)), unde g f se citeşte ca „g cerc f” şi g(f(x)) se citeşte „g de f de x”. Funcţia g f se numeşte compoziţia lui f şi g.

EXEMPLUL 4.11

Figura 4.15
57

EXEMPLUL 4.12 f(x) = n +1. g(n) = n2 Compoziţia: se adaugă 1 şi apoi se ridică la pătrat.

Compunerea lui g f. Soluţie: Fie f şi g ca cele de mai sus, dar găsiţi compunerea f g. Este oare f (f g)(n) = f(g(n)) = f(n2) = n2 + 1 pentru toţi n ∈ Z (g f)(n) = (n + 1)2 şi (f g)(n) = n2 + 1 pentru toţi n ∈ Z

Figura 4.16

 

 g = g  f?

g f≠f g Aduceţi-vă aminte că funcţia de identitate pe o mulţime X – ix – este funcţia definită pe X cu valori în X după regula ix(x) = x pentru toţi x ∈ X EXEMPLUL 4.13 Fie X = {a,b,c,d} şi Y = {x,y,z} şi să presupunem că f : X → Y este dată de diagrama săgeţilor din figură:

Figura 4.17 Găsiţi f Soluţie: a)

 i şi i  f
x y

b)

58

c)

Figura 4.18 (f ix)(a) = f(ix(a)) = f(a) = x (f ix)(b) = f(ix(b)) = f(b) = y (f ix)(c) = f(ix(c)) = f(c) = y (f ix)(d) = f(ix(d)) = f(d) = x Observaţi că: pentru toate elementele x din X (f ix)(x) = f(x) Aceasta înseamnă că f ix = f.

    

TEOREMA 4.2 Dacă f este o funcţie definită pe mulţimea X cu valori în Y şi ix funcţia de identitate pe X, iar iy funcţia de identitate pe Y, atunci f ix = f şi iy f = f.

Compunerea Funcţiei cu Inversa ei
Fie X = {a,b,c} şi Y = {x,y,z}. Definiţi f : X

→ Y prin diagrama săgeţilor arătată în figura de mai jos:
(f -1 f -1 (f -1

 f)(a) = f (f(a)) = f  f)(b) = f (f(b)) = f  f)(c) = f (f(c)) = f
-1 -1 -1

-1 -1

(z) = a (x) = b -1 (y) = c

Astfel prin definiţia funcţiei f -1 f = ix Într-un mod similar se poate observa că f -1 f = iy

Figura 4.19 TEOREMA 4.3 Dacă f : X → Y este o funcţie injectivă cu funcţia inversă f -1 : X f f -1 = iy

→ Y, atunci f -1

 f=i

x

şi

TEOREMA 4.4
59

Dacă f : X

→ Y şi g : Y → Z sunt ambele funcţii injective, atunci şi g

 f este injectivă.

EXEMPLUL 4.14 X = {a,b,c}, Y = {w,x,y,z}şi Z = {1,2,3,4,5}

Figura 4.20 TEOREMA 4.5 Dacă f : X → Y şi g : Y

→ Z sunt ambele funcţii surjective, atunci şi g

 f este şi ea surjectivă.

60

SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.4.1 1. Operaţii cu funcţiile

a) Găsiţi toate funcţiile din X = {a, b} în Y = {U, V} b) Găsiţi toate funcţiile din X = {a, b, c} în Y = {U} c) Găsiţi toate funcţiile din X = {a, b, c} în Y = {U, V} 2. Definiţi o funcţie f : Z → Z după cum urmează: f(n) = n2, pentru toţi n∈Z
a) Desenaţi diagrama săgeţilor pentru funcţia f b) Găsiţi f (f (3)) şi f (f (f (2))) c) Găsiţi f (n) – 1 (presupunând că n este un număr întreg)

3.

Definiţi o funcţie g : Z → Z după cum urmează: g (n) = n + 1, pentru toţi n∈Z.

a) Desenaţi diagrama săgeţilor pentru funcţia g. b) Găsiţi g (g (-2)) şi g (g (g (-2))) c) Găsiţi g (2n), 2g(n), g(n – 1) şi g (n) – 1 (presupunând că n este un număr întreg). 1. Să considerăm funcţia Distanţa lui Hamming: a) Găsiţi H (10101, 00011), b) Găsiţi H (00110, 10111).

61

2. Desenaţi diagrama săgeţilor pentru funcţiile booleene definite prin următoarele tabele de Intrare/Ieşire: a) I I e ş i r e r 0 1 0 1 I s 1 1 0 1 0 0 0 1

p 1 1 0 0 b)

q 1 0 1 0 Intrar e p q r 1 1 1 1 1 0 1 0 1 1 0 0 0 1 1 0 1 0 0 0 1 0 0 0

62

3. În 6.1-6.6 este dat un automat finit prezentat prin diagrama de trecere. Pentru fiecare
automat: a) Găsiţi stările lui; b) Găsiţi simbolul lui de intrare; c) Găsiţi starea lui iniţială; d) Găsiţi stările lui acceptate; e) Prezentaţi tabelul de referinţă al stărilor următoare ale automatului

6.1

6.2 6.4 6.3

S0

U0
S
63

6.5
6.6
4. Un automat finit A, prezentat prin diagrama de trecere de mai jos, are funcţia starea
următoare N şi funcţia starea eventuală N*.

a) b) c) d)

Găsiţi N (S3, 0) şi N (S2, 1). Găsiţi N (S0, 0) şi N (S4, 1). Găsiţi N* (S0, 010011) şi N* (S3, 01101). Găsiţi N* (S0, 1111) şi N* (S2, 00111).

1
64

5. RELAŢII
Relaţii definite pe mulţimi
EXEMPLUL 5.1. Fie A = {0,1,2} şi B = {1,2,3}.Vom spune că un element x din din A este în relaţie cu un element y din B dacă şi numai dacă x este mai mic decât y. Notaţia: xRy → ca o prescurtare pentru propoziţia „x este în relaţie cu y” 0R1, deoarece 0<1; 0R2, deoarece 0<2; 0R3, deoarece 0<3; 1R2, deoarece 1<2; 1R3, deoarece 1<3; 2R3, deoarece 2<3; ¬ xRy → „x nu este în relaţie cu y” ¬ 0R0 deoarece ¬ 0 < 0 ; ¬1 R 1 deoarece ¬ 1<1; ¬2 R 1 deoarece ¬ 2<1; ¬2 R 2 deoarece ¬ 2<2. Sa ne reamintim ca produsul cartezian al mulţimilor A si B, AxB, este o mulţime care consta din toate perechile ordonate cu primul element din mulţimea A si cu al doilea element din multimea B: AxB ={{x,y) | x ∈ A si y ∈ B}. In aces caz: Ax B = {{0,1), {0,2), {0,3), {1,1), {1,2), {1,3), {2,1), {2,2), {2,3)}. B= {1,2,3} *(0,3) *(1,3) *(2,3) *(0,2) *(1,2) *(2,2) *(0,1) (1,1) (2,3)

A= {0,1,2} Sa precautam in multimea AxB urmatoarea relatie xRy ⇔ x<y. Punctele marcate reprezinta perechile ordodonate ale caror primul si al doilea elemnt sunt in relatia R

DEFINIŢIE: Fie A si B doua multimi, o relatie (binara) R din A in B este o submultime a AxB. Fiind data o pereche ordonată (x,y), din AxB, x este in relatie cu y prin R, notat xRy, dacă şi numai dacă (x.y) ∈ R. Simbolic acest lucru poate fi prezentat după cum urmează: xRy ⇔ (x.y) ∈ R ¬ xRy ⇔ (x.y) ∉ R Termenul binar se refera la faptul ca relatia este o submultime a produsului cartezian dintre doua multimi, de exemplu AxB.

65

EXEMPLUL 5.2.Fie A= {1,2} si B={1,2,3} Definiti urmatoarea relatie binara R din A in B dupa cum urmeaza: Fiind data orice pereche (x,y) ∈ (AxB), (x.y) ∈ R ⇔ (x-y) este un numar par a) constatati in mod explicit care perrechi ordonate sunt in AxB si care sun in R b) prezentati graficul AxB unind toate perechile AxB in planul cartezian ;i marcind punctele care sunt in R c) Exista oare relatiile 1R3? 2R3? 2R2? EXEMPLUL 5.3. Relatii pe o Multime de Şiruri de Caractere Fie A o multime alcatuita din siruri de caractere de lungime 6, continind simbolurile x si y. Atunci A, se noteaza Σ6, unde Σ={xy}. Definiti urmatoarea relatie binara R din A in A dupa cum urmeaza: Pentru toate sirurile de caractere S si t in A. S R t ⇔ primele 4 caractere ale lui S sunt egale cu primele 4 caractere ale lui t Sunt oare relatii: xxyxyxRxxxyxy? yxyyyxRyxyyxy? xyxxxxRyxxxxx? Soluţie: Nu, deoarece xxyx ≠ xxxy Da, deoarece yxyy = yxyy Nu, deoarece xyxx ≠ yxxx d) constatati in mod explicit care perechi ordonate sunt in AxB si care sunt in R e) prezentati graficul AxB, unind toate perechile AxB in planul cartezian si marcind punctele care sunt in R f) Exista oare relatiile 1R3? 2R3? 2R2?

Reuniunea si Intersectia Relatiilor
Deoarece relaţiile binare sunt submulţimi ale produsului Cartezian, rezultă că reuniunile si intersectiile lor sunt de asemenea submultimi ale aceluiasi produs Cartezian. Fie 2 relaţii R şi S din A in B, adică R si S sunt sumbmultimi ale produsului Cartezian AxB.

DEFINIŢIE: Numim reuniunea a doua relaţii R si S, o a treia relaţie T, egala cu R ∪ S, si se notează T=R ∪ S. Relaţia T este o relaţie din A in B, astfel incit din faptul ca setul de perechi ordonate (x,y) apartine produsului Cartezian AxB, rezulta ca (x,y) ∈ R or (x,y) ∈ S. In mod neformal aceasta definitie poate fi scrisă dupa cum urmeaza: R ∪ S = {(x,y) ∈ AxB | (x,y) ∈ R or (x,y) ∈ S }.
66

DEFINIŢIE: Numim reuniunea a doua relaţii R si S, o a treia relaţie T, egala cu R ∩ S, si se notează T=R ∩ S. Relaţia T este o relaţie din A in B, astfel incit din faptul ca setul de perechi ordonate (x,y) apartine produsului Cartezian AxB, rezulta ca (x,y) ∈ R si (x,y) ∈ S. In mod neformal aceasta definitie poate fi scrisă dupa cum urmeaza: R ∩ S = {(x,y) ∈ AxB | (x,y) ∈ R si (x,y) ∈ S }. EXEMPLUL 5.4. Fie A = {-1,0,1} şi B = {0,1}. Atunci AxB = {(-1,0), (0,0), (1,0), (-1,1), (0,1), (1,1)} Definiti relatiile R si S din A in B dupa cum urmeaza: R = {(-1,0),(-1,1),(0,1)} S = {(0,0),(1,1),(-1,1)} Determinati R ∩ S si R ∪ S Soluţie: R ∩ S = {(-1,1)} R ∪ S = {(-1,0),(-1,1),(0,1),(0,0),(1,1)}

Inversa unei Relaţii
Fie dată o relaţie R din A in B, adică R este o submulţime a produsului Cartezian AxB. Relaţia R din A in B de fapt este o submulţime de perechi (x,y) din AxB „ordonată/direcţionată după un anumit criteriu”. Este evident că pentru o astfel de relaţie R din A in B, ar putea exista si una inversa ei, s-o notăm prin R1 , care sa fie definita din B in A, adică R-1 este o submulţime a produsului Cartezian BxA. Sensul acestei relaţii de fapt ar fi trebuit sa fie „ordonarea inversă (inversarea ordinii)/redirecţionarea după un anumit criteriu a perechilor ordonate in R”.

DEFINITIE: Fie R o relaţie din A in B, adică R este o submulţime a produsului Cartezian AxB. Vom numi relaţia R 1 din B in A, relaţie inversa relaţiei R, dacă ea este definită după cum urmează: R-1 = {(y,x) ∈ BxA | (x,y) ∈ R}. Consecinţă: Pentru orice x ∈ X si y ∈ Y, (x,y) ∈ R-1 ⇔ (x,y) ∈ R EXEMPLUL 5.5.Fie A={2,3,4} şi B={2,6,8}. Fie R relaţia care „divide” din A in B după cum urmează – pentru orice (x,y) ∈ AxB, xRy ⇔ x | y (x divide y). a. formulaţi explicit care sunt perechile ordonate care aparţin lui R b. determinaţi R-1
67

c. Soluţie: a) b) c)

descrieţi verbal relaţia R-1 R={(2,2), (2,6), (2,8), (3,6), (4,8)} R-1={(2,2), (6,2), (8,2), (6,3), (8,4)} R-1 este o relaţie definită după cum urmează: pentru orice (y,x) multiplu lui x.

BxA, y R-1 x ⇔ y este

EXEMPLUL 5.6. Construirea Diagramei unei Relaţii Fie A={1,2,3} şi B={1,3,5}. Definiţi relaţiile S si T din A in B după cum urmează: S : S = {(x,y) ∈ AxB si x<y}, adică (x,y) ∈ S ⇔ x < y T : T = {(2,1), (2,5)} Desenaţi diagramele pentru S si T. Soluţie: S 1. 2. 3. .1 .3 .5 Figura 5.1 1. 2. 3. T .1 .3 .5

DEFINIŢIE: O functie F de pe multimea A pe multimea B este o relatie R din A in B care satisface urmatoarele 2 proprietati: 1. pentru orice element x din A, exista un elemnt y in B, astfel incit (x,y) ∈ F 2. pentru toate elementele x din A si y si z din B, daca (x,y) ∈ F si (x,z) ∈ F, atunci y=z Proprietatile 1 si 2 pot fi formulate mai putin formal dupa cum urmeaza: 1. orice element din A este primul element dintr-o pereche ordonata a multimii F. 2. 2 perechi ordonate din F nu pot avea primul element acelasi. EXEMPLUL 5.7. Funcţii si Relaţii Fie A={2,4,6} şi B={1,3,5}. Care dintre relatiile R,S si T, definite mai jos, sunt functii din A in B? a. pentru toate perechile (x,y) ∈ AxB, (x,y) ∈ R ⇔ y=x+1 b. pentru toate perechile (x,y) ∈ AxB, x S y ⇔ y=x-1 c. T = {(2,5), (4,1), (4,3), (6,5)} Soluţie: a) R nu este functie, deoarece R nu satisface proprietatea nr. 1 din definitia de mai sus b) S este o functie S = {(2,1), (4,3), (6,5)}. Fiecare element al multimii A este primul element al unei perechii din S si nu sunt 2 perechi ordonate distincte in S cu acelasi element pe primul loc c) T nu este functie, deoarece T nu satisface proprietatea nr. 2 din definitia de mai sus
68

Relaţii n-are şi Baze de Date Relaţionale
Relaţiile N-are stau la temelia teoriei matematice a bazelor relaţionale de date. Relatia binara este, dupa cum s-a mentionat mai sus, o submultime a produsului Cartezian al 2 multimi. Similar, o relatie N-ara este o submultime a produsului Cartezian al N multimi.

DEFINIŢIE: Fie mulţimile A1, A2, ..., An. Relaţia N-ară R este o submulţime din produsul cartezian N-ar, adica din A1xA2x…..xAn care pune în corespondenţă fiecărui element X1 ∈ A1, X2 ∈ A2, …. Xn ∈ An şirul (X1, X2, ..., Xn). In particular pentru cazurile cind N=2,3, si 4, relatiile se mai numesc binare, tertiare si patrunare. In teoria contemporana Bazele de date sunt o reuniune de tabele bidimensionale interdependente de date. Fiecare tabel de date poate fi interpretat printr-o relatie N-ara de exemplu de forma: X1 X2 ... Xn

unde Xi – cîmpuri şi reprezintă elementele unei relaţii N-are definite pe un set de mulţimi A1, ..., An care descrie un obiect dintr-un domeniu de studiu concret. EXEMPLUL 5.8. Sa precautam relatia patrunara R = {(a1,a2,a3,a4)}. Prin ea vom descrie multimea tuturor pacientilor. Sirul (a1,a2,a3,a4) ∈ A1xA2xA3xA4, unde fiecare element Ai reprezinta respectiv: A1 numarul de identificare al pacientului ID A2 numele A3 data internarii A4 diagnoza primara In forma tabelara el poate fi prezentat A1 A2 A3 A4

DEFINIŢIE: Numărul de elemente din sirul (A1, A2, ... An) se numeşte puterea relaţiei.

Proprietatile Relatiilor
(reflexivitatea, simetria, tranzitivitatea) Fie dată mulţimea A = {2, 3, 4, 6, 7, 9}. Vom defini relatia R pe mulţimea A x A. Vom zice ca x R y, dacă orice perechi ordonate de valori (x, y) ∈ AxA, x-y este divizibil la 3. Or formal acest lucru poate fi scris:
69

∀(x,y) ∈ AxA, x R y ⇔ 3 | (x-y)
Este evident ca, R = {(2, 2), (3, 3), (4, 4), (6,6), (7, 7), (9, 9), (6, 3), (3, 6), (3, 9), (9,3), (6, 9), (9, 6), (4, 7), (7, 4)} este o submultime din A x A. Să

prezentăm grafic mulţimea R ⊂ A x A, astfel încît să fie evidenţiate legăturile dintre elementele ei. Figura 5.2 Din acest mod de prezentare a legăturilor elementelor relaţiei am putea desprinde următoarele proprietăţi interesante: 1. există elemente care au legătură cu ele însăşi (2, 4, 6, 3,7, 9); 2. există elemente care au legătură reciprocă inversă şi sînt prezentate prin săgeţi paralele ((3, 6), (9, 3), (6, 9), (4, 7)); 3. există elemente care au legături triple (cel puţin) cînd săgeata plecată dintr-un punct (3) si poate ajunge în (9) trecînd prin punctul intermediar (6). /nu sunt salturi/ Aceste proprietăţi ale relaţiilor binare se numesc reflexivitate, simetrie şi tranzitivitate.

Fie R o relaţie binară pe mulţimea A, adică R ⊂ A x A, adică (x R y), unde x ∈ A şi y ∈ A. 1. Vom zice că relaţia R este reflexivă dacă şi numai dacă pentru toţi x ∈ A urmează ca x R x (reflexivitatea înseamnă ca relaţia lasă elementul x ∈ A pe loc/nemişcat. În cazul exemplului de mai sus relaţia R este reflexivă). 2. Vom zice că relaţia R este simetrică dacă şi numai dacă pentru toate perechile (x, y) ∈ AxA, care se află în relaţia R, adică x R y, urmează că pentru această pereche este valabilă şi relaţia y R x (simetria înseamnă că relaţia R este biunivocă, ea transformă elementul x şi y şi tot ea îl transformă înapoi. În exemplul de mai sus, relaţia R este simetrică. Simetria pentru relaţia de mai sus este parţială fiindcă în conformitate cu definiţia toate (x, y) ∈ A trebuie să se îndeplinească relaţiile: x R y, y R x. În cazul nostru ele se îndeplinesc pentru 3, 6, 9, 7, 4 parţial) 3. Vom zice că relaţia R este tranzitivă dacă şi numai dacă pentru toţi x, y, z ∈ A din faptul că x R y şi y R z, urmează că x R z. EXEMPLUL 5.9. Fie A={0,1,2,3} şi definim relaţiile R,S şi T pe AxA după cum urmează: R={(0,0), (0,1), (0,3),(1,0),(1,1),(2,2),(3,0),(3,3)} S={(0,0), (0,2), (0,3),(2,3)}
70

DEFINIŢIE:

T={(0,1), (2,3)} a). Este relaţia R reflexivă? Simetrică? Tranzitivă? b). Este relaţia S reflexivă? Simetrică? Tranzitivă? c). Este relaţia T reflexivă? Simetrică? Tranzitivă? Soluţie: a). R este reflexivă R este simetrică R nu este tranzitivă

b). S nu este reflexivă S nu este simetrică S este tranzitivă c). 0 1 T nu este reflexivă T nu este simetrică T nu este tranzitivă 2

3 Figura 5.3

Închiderea Tranzitivă a unei Relaţii
Fie dată o mulţime A. Fie R o relaţie binara definita pe AxA.


1. 2. 3.

DEFINIŢIE:

Închiderea tranzitivă a unei relaţii binare R este o relaţie binară Rt definită pe AxA, care satisface următoarele 3 proprietăţi: Rt este tranzitivă; R este submulţimea a Rt, adică R ⊆ Rt; dacă S este o oarecare altă relaţie tranzitivă care conţine în sine R, atunci Rt ⊆ S.

EXEMPLUL 5.10.
71

Fie A = {0, 1, 2, 3} şi să considerăm relaţia R definita pe A x A după cum urmează:. R = {(0, 1), (1, 2), (2, 3)} Determinaţi închiderea tranzitivă a relaţiei R Grafic legătura dintre aceste elemente poate fi prezentată în următorul mod:
0 3 1 2

Relaţia forma,

tranzitivă închisă pentru relaţia dată Rt va fi prezentată în

0

1

3

2

care de fapt conţine inclusiv şi relaţia R (se îndeplineşte condiţia 2 din Definiţie). Astfel spus, Rt va conţine perechile {(0, 1), (0, 2), (0, 3), (1, 2), (1,3) , (2, 3) }, adică relaţia tranzitivă închisă pentru relaţia dată R este relaţia Rt={(0, 1), (0, 2), (0, 3), (1, 2), (2, 3) , (1,3) }. Această relaţie este tranzitivă.

72

SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.5.1 Fie A={2,3,4} si B={6,8,10}. Definim relaţia binara R din A pe B după cum urmează: pentru toate perechile (x.y) ∈ AxB, perechile (x.y) ∈ R ⇔ x | y Sarcină: a). Determinaţi explicit perechile ordonate din R b). Construiţi diagrama AxB şi încercuiţi elementele lui R c). Este oare 4 R 6? Este 4 R 8? Este (3,8) ∈ R? Este (2,10) ∈ R?
1.

Fie C={2,3,4,5} si D={3,4}. Definim relaţia binara S din C pe D după cum urmează: pentru toate perechile (x.y) ∈ CxD, perechile (x.y) ∈ S ⇔ x >= y Sarcină: a). Determinaţi explicit perechile ordonate din S b). Construiţi diagrama CxD şi încercuiţi elementele lui S c). Este 2 S 4? Este 4 S 3? Este (4,4) ∈ S? Este (3,2) ∈ S?
2.

Fie dată o mulţime Z. Definim relaţia binara R din Z pe Z după cum urmează: pentru toate perechile (m,n) ∈ ZxZ, perechile (m,n) ∈ R, sau m R n ⇔ (m-n) | 3 Sarcină: a). Este 7 R 1? Este 1 R 7? Este 2 R 2? Este (8,1) ∈ R? b). Construiţi diagrama pentru R în planul cartezian de coordonate
3.

Fie dată o mulţime R. Definim relaţia binara R din R pe R după cum urmează: pentru toate perechile (x,y) ∈ RxR, perechile (x.y) ∈ R, sau x R y ⇔ y=x2 Sarcină: a). Este (2,4) ∈ R? Este (4,2) ∈ R? Este (-3) R 9? Este 9 R (-3)? b). Construiţi diagrama pentru R în planul Cartezian de coordonate
4.

R={(x,y) ∈ S={(x,y) ∈ Sarcină: Construiţi în planul Cartezian de coordonate R,S, R ∪ S si R ∩ S
6.

Fie dată o mulţime R. Definim relaţiile binare R şi S din R pe R după cum urmează 2 RxR | x +y2=4} si RxR | x=y}
5.

R={(x,y) ∈ S={(x,y) ∈ Sarcină: Construiţi în planul Cartezian de coordonate R,S, R ∪ S si R ∩ S
7.

Fie dată o mulţime R. Definim relaţiile binare R şi S din R pe R după cum urmează: RxR | x2 + y2 = 4} si RxR | x=y}

Fie dată o mulţime R. Definim relaţiile binare R şi S din R pe R după cum urmează:
73

R={(x,y) ∈ RxR | y=|x|} si S={(x,y) ∈ RxR | y=0} Sarcină: Construiţi în planul Cartezian de coordonate R,S, R ∪ S si R ∩ S
8.

Fie A={0,1,2,3}. Fie R,S si T relaţii binare definite pe A, adică pe AxA

8.1 Fie R={(0,1),(0,2),(1,1),(1,3),(2,3),(3,0)} Sarcină: Determinaţi Rt - Închiderea tranzitivă a relaţiei R 8.2 Fie S={(0,0),(0,3),(1,0),(1,2),(2,0),(3,2)} Sarcină: Determinaţi St - Închiderea tranzitivă a relaţiei S 8.3 Fie T={(0,2),(1,0),(2,3),(3,1)} Sarcină: Determinaţi Tt - Închiderea tranzitivă a relaţiei T
9.

In exemplele ce urmează:

Sarcină: determinaţi daca relaţia binara R definita este sau nu una Reflexiva, Simetrica sau Tranzitiva. Argumentaţi răspunsul. 9.1 Relaţia R este o relaţie definita ca fiind „mai mare ca ori egala cu” pe o mulţime de numere reale astfel: pentru toţi x,y ∈ R, x R y ⇔ x>=y 9.2 Relaţia R este o relaţie circulara pe o mulţime de numere reale definita după cum urmează: pentru toţi x,y ∈ R, x R y ⇔ x2+y2=1 9.3 Relaţia R este o relaţie binara pe R, definita după cum urmează: pentru toţi x,y ∈ R, x R y ⇔ xy>=0 9.4 Relaţia R este o relaţie binara pe Z, definita după cum urmează: pentru toţi m,n ∈ Z, m R n ⇔ m-n este impar 9.5 Relaţia R este „Divizorul” o relaţie binara pe Z+, definita după cum urmează pentru toţi m,n ∈ Z+, m R n ⇔ m | n

74

6. GRAFURI ŞI ARBORI

DEFINIŢIE: V (G) – mulţimea de vîrfuri; E (G) – mulţimea de muchii,

Un graf G este o mulţime care reprezinta o reuniune a 2-ă submulţimi:
a) b)

unde orice muchie este asociată cu o mulţime care constă din cel puţin unul sau două vîrfuri numite extremele lor. In exemplul ce urmează
V1 e3 V4 e1 e2 V3 V2

V1, V2, V3, V4 – vîrfuri e1, e2, e3 - muchii

In exemplul de mai jos / A. şi B./ V1, V2, V3, V4, V5, V6 sunt vîrfuri, iar e1, e2, e3, e4, e5, e6 – muchii.

DEFINIŢIE:

Corespondenţa între muchiile unui graf şi extremităţile lor este denumită funcţie muchie-extremitate.

75

☞ ☞ ☞ ☞ ☞ ☞ ☞ ☞ ☞

DEFINIŢIE:

O muchie care constă dintr-o singură extremitate se numeşte buclă. / sau inel sau cerc V4/. DEFINIŢIE:
e1 V2 e2

Două muchii distincte care au acelaşi set de extremităţi se numesc muchii paralele. /e1 şi e2, ori mai sus e2 şi e3 în punctul A. /

V1

DEFINIŢIE:

Două vîrfuri care sunt unite cu o singură muchie se numesc vîrfuri adiacente. DEFINIŢIE:

Un vîrf care este extremă a unei bucle se zice că este adiacent cu sine însăşi. DEFINIŢIE:

O muchie se zice că este incidentă fiecărui punct de extremă a ei. Două muchii incidente în aceleaşi puncte de extremă se numesc adiacente. DEFINIŢIE:

Un vîrf în care nici o muchie nu este incidentă se numeşte vîrf izolat. DEFINIŢIE:

Un graf care nu are nici un vîrf se numeşte graf vid şi unul care are cel puţin un vîrf se numeşte diferit de vid. DEFINIŢIE:

Un graf este orientat sau digraf dacă el constă din două mulţimi V (G) şi E (G) şi pentru acest graf orice muchie este asociată cu o pereche ordonată de vîrfuri care sînt extremităţile ei. DEFINIŢIE: Dacă muchiile unui graf ei sunt asociate unei perechi de vîrfuri (V,W), atunci se zice că muchia ei este orientată din „V” spre „W”.
V1 e1 e3 V3 e2 V2

EXEMPLUL 6.1. În exemplu B de mai sus avem un graf G = {V(G), E(G)}, în care e1, e2, e3, e4, e5 sunt muchii cu extremităţile respective

76

Nr. 1 2 3 4 5

Muchii e1 e2 e3 e4 e5

Punctele de extremă {V1,V2} {V2,V3} {V3,V4} {V4,V5} {V5,V1}

Grafuri Speciale

DEFINIŢIE:

Un graf se numeşte simplu dacă el • nu are nici o buclă şi • nu are muchii paralele. Intr-un graf simplu, muchia cu extremităţile V şi W se notează {V,W} EXEMPLUL 6.2. Desemnaţi toate grafurile simple care au 4 vîrfuri {U,V,W,X}şi 2 muchii, una din care este muchia {U,V}

Figura 6.1 Mai sus este prezentată mulţimea tuturor graf-urilor simple care au 4 vîrfuri: U, V, W, X şi au o muchie, {U,V} predefinită. Aceste graf-uri nu au muchii paralele.

DEFINIŢIE:

Un graf G = {V(G), E(G)}, care are n vîrfuri se numeşte complet, şi se notează Kn, dacă el este • un graf simplu cu n vîrfuri V1,V2, ..., Vn, • mulţimea de muchii e1,e2,...,en are proprietatea: orice muchie ei este definită printr-o pereche de virfuri distincte {Vi, Vi+1} EXEMPLUL 6.3. Graf-uri complete cu n virfuri, K2,K3,K4,K5

Figura 6.2

DEFINIŢIE:
77

Un graf G = {V(G), E(G)}, care are (m,n) vîrfuri se numşte complet bipartid, şi se notează Km,n, dacă el este un graf simplu cu virfurile V1,V2, ..., Vm şi W1,W2, ..., Wn şi pentru orice i,k =1,2,...,m şi j,l = 1,2,...,n, se satisfac următoarelor proprietăţi : • există o muchie din fiecare vîrf Vi către fiecare virf Wj • nu există nici o muchie din fiecare virf Vi către oricare alt virf Vk • nu există nici o muchie din fiecare virf Wj către oricare alt virf Vl EXEMPLUL 6.4. Graf-uri complete bipartite K3,2 şi K3,3

Figura 6.3

DEFINIŢIE:

Fie dat un graf G = {V(G), E(G)}. Vom spune că H este subgraf al grafului G dacă şi numai dacă • orice vîrf din graful H este în acelaşi timp un vîrf şi în graful G • orice muchie din graful H este în acelaşi timp şi o muchie în graful G şi • orice muchie din graful H are aceleaşi extremităţi pe care ea le are în graful G. EXEMPLUL 6.5. Este dat un graf G = {V(G), E(G)}. Listaţi/Prezentaţi toate subgrafurile nevide ale grafului dat

Soluţie:

78

Figura 6.4 Pentru graful dat pot fi prezentate 11 subgraf-uri nevide.

☞ ☞

DEFINITIE:

Fie dat un graf G = {V(G), E(G)} în care V este unul din virfurile lui. Rangul vîrfului V, notat deg (V), este egal cu numărul de muchii care sînt incidente virfului V. Remarcă: Dacă un vîrf are o buclă, muchia dată la calcularea rangului se considereă ca dublă. DEFINIŢIE:

Rangul total al unui graf G = {V(G), E(G)} este egal cu suma rangurilor tuturor vîrfurilor grafului dat. deg(G)= ∑ deg (Vi)
i =1 n

TEOREMA 6.1: Fie dat un graf G, G = {V(G), E(G)}. Rangul total al grafului G este egal cu îndoitul produs al numarului de muchii ale lui. Dacă este definit un G = {V(G), E(G)}, adică are virfurile V1, ..., Vn, şi muchiile e1,e2,...,en, atunci deg(G) =
n


i =1

deg (Vi)= 2 x n

EXEMPLUL 6.6.Rangul unui Vârf şi Rangul Total al unui Graf

Figura 6.5 Soluţie: Pentru graful G1: deg (V1) = 5, Pentru graful G2: deg (V1) = 0, deg(V2)=2, deg(V3)=4,

79

deg(G2) = deg (V1) + deg (V2) + deg(V3)= 0+2 + 4 = 6. Pentru graful G2, care are 3 muchii E(G)={e1,e2,e3}, în conformitate cu teorema de mai sus obţinem
k

deg(G) = 2 x EXEMPLUL 6.7.


f =1

ef = 2 x 3=6

In graf-urile prezentate mai jos a), b) şi c), demonstraţi că perechile de graf-uri sunt aceleaşi prin suprapunerea vârfurilor şi muchiilor desenului din dreapta cu vârfurile şi muchiile desenului din stânga:

Figura 6.6

Căi şi Circuite
80

Traseul într-un graf se efectuează dintr-un vârf a lui în altul de-a lungul şirului de muchii adiacente. În graful ce urmează de exemplu, aţi putea să Vă mişcaţi din virful U1 spre virful U4 parcurgind sirul de muchii {f1,f7}.Mişcarea dată poate fi prezentată în scris prin indicarea următoarei succesivităţi U1 f1 U2 f7 U4. Succesivitatea dată reprezintă de fapt descrierea traseului într-un graf din virful U1 al lui în vîrful U4.

Figura 6.7 Fie dat un graf G, G = {V(G), E(G)} şi 2 vârfuri ale lui V şi W.

DEFINIŢIE: Traseul într-un graf G dintr-un virf al lui V în alt virf W reprezintă succesivitatea alternantă şi finită de vârfuri şi muchii adiacente lor ce aparţin grafului dat. În exemplul de mai sus, traseul din U1 în U4 poate fi prezentat sub forma următoarei succesivităţi U1 f1 U2 f7 U4. Traseul trivial din V în V constă dintr-un singur virf V.

DEFINIŢIE:

Fie dat graful G şi în el 2 vârfuri V, W. Se numeşte cale mişcarea din V în W, care nu conţine vârfuri repetate. Altfel zis, calea din V în W este traseul care se prezintă prin succesivitatea V=V0 e1 V1 e2 … Vn-1 en Vn=W, unde toate ei sunt distincte (adică ei ≠ ek, pentru orice i ≠ k ).

DEFINIŢIE: Calea din V în W se numeşte simplă, dacă ea nu conţine vîrfuri repetate. Altfel zis, calea simplă, este mişcarea din V în W care se prezintă prin succesivitatea/forma V=V0 e1 V1 e2 … Vn-1 en Vn=W, unde toate ei şi Vj sunt distincte (adică ei ≠ ek, pentru orice i ≠ k şi Vj ≠ Vm pentru orice j ≠ m). Remarcă: Calea trivială constă dintr-un singur vârf.

DEFINIŢIE: Circuitul este calea care porneşte şi sfârşeşte în unul şi acelaşi vârf.
81

Altfel zis, circuitul din V în W este traseul din V în W care se prezintă prin succesivitatea V=V0 e1 V1 e2 … Vn-1 en Vn=W, unde toate ei şi Vj sunt distincte (adică ei ≠ ek, pentru orice i ≠ k şi Vj ≠ Vm pentru orice j ≠ m) cu excepţia că V0=Vn.

DEFINIŢIE: Circuitul se numeşte circuit simplu, dacă calea lui este simplă. Altfel zis, circuitul simplu este traseul din V în W care se prezintă prin succesivitatea V=V0 e1 V1 e2 … Vn-1 en Vn=W, unde V0=Vn şi toate ei sunt distincte (adică ei ≠ ek, pentru orice i ≠ k) cu excepţia că V0=Vn.

Grafuri Legate
Fie dat un graf G, G = {V(G), E(G)} şi 2 vârfuri ale lui V şi W.

☞ ☞

DEFINIŢIE: Virfurile V şi W ale grafului G se numesc legate, dacă şi numai dacă există un traseu din V în W. DEFINIŢIE: Graful G se numeşte legat, dacă şi numai dacă pentru oricare 2 vârfuri ale lui există un traseu din V în W ce le uneşte. Simbolic: G este legat ⇔ ∀virfuri V, W ∈ V(G), ∃ un traseu din V în W, adică o succesivitate V=V0 e1 V1 e2 … Vn-1 en Vn=W, unde toate ei sunt distincte (adică ei ≠ ek, pentru orice i ≠ k ). EXEMPLUL 6.8. Care din graf-urile ce urmează sunt legate?

Figura 6.8

☞ ☞

DEFINIŢIE: Fie dat un graf G, G = {V(G), E(G)}. Vom zice că graful H = {V(H), E(H)} este subgraf dacă mulţimea vârfurilor V(H) şi muchiilor E(H) sunt submulţimi în mulţimea de vârfuri şi muchii ale grafului G, adică V(H) ⊂ V(G) şi E(H) ⊂ E(G). DEFINIŢIE: Fie dat un graf G, G = {V(G), E(G)} şi H – un subgraf al lui G. Vom zice că H este componenta legată a grafului G dacă şi numai dacă se îndeplinesc următoarele condiţii: • H este subgraf al lui G. • H este legat.

82

Nu există subgraf legat S al lui G ce are pe H ca subgraf şi care să conţină vărfuri şi muchii care să nu aparţină lui H.

EXEMPLUL 6.9. Găsiţi toate componentele legate ale grafului G ce urmează:

Figura 6.9 Soluţie: Graful G are 3 componente legate. Ele sunt H1, H2 şi H3 cu mulţimile de virfuri V(H1),V(H2) şi V(H3) şi mulţimile de muchii E(H1),E(H2) şi E(H3) respectiv: H1 H2 H3 : : : V(H1) = {V1,V2,V3} V(H2) = {V4} V(H3) = {V5,V6,V7,V8} E(H1) = {e1,e2} E(H2) = ∅ E(H3) = {e3,e4,e5}

Matrici şi Graf-uri Orientate

DEFINIŢIE: Fie dat un graf G, G = {V(G), E(G)}. Graful G se numeşte orientat dacă muchiile ce unesc virfurile grafului sunt segmente orientate, adică vectori care indică virful din care muchiile iesă şi vîrfurile în care ele intră. EXEMPLUL 6.10.

Figura 6.10

DEFINIŢIE: Matricea A V1 V2 V3

83

V1

A=

V2 V3

1 1   1

0 0 2 1  0 0
A=(aij)

se numeşte matricea de adiacenţă a grafului G.

DEFINIŢIE: Fie dat un graf orientat G cu şirul ordonat de vîrfuri V1,V2,...,Vn, G = {V(G), E(G)}. Matricea de adiacenţă a grafului G este matricea elementele căreia sunt definite pe mulţimea numerelor întregi positive Ζ+, astfel încît aij= numărul de ieşiri (săgeţi ce iesă) din Vi şi intră în Vj, pentru orice i,j =1,2,..,n EXEMPLUL 6.11.

Figura 6.11 Determinaţi matricele de adiacenţă ale următoarelor graf-uri orientate: Soluţie: Matricele de adiacenţă pentru graful G din punctele a). şi b). sunt respectiv următoarele: V1 V2 V3

84

V1

A=

V2 V3

0 0   2
V1

0 0 1 1  1 0
V2 V3

V1

B=

V2 V3

1 1   0

1 0 0

0 2  0

Vom menţiona că poate fi soluţionată şi problema inversă, adică fiind dată matricea de adiacenţă A a unui careva graf G, să determinăm graful orientat G pentru care A este matrice de adiacenţă. Această proprietate permite să utilizăm la studiul graf-urilor algebra matricelor. EXEMPLUL 6.12. Determinaţi graful orientat după matricea de adiacenţă A:

V1

V2

V3

V4

A=

V1 V2 V3 V4

Soluţie:

0 1  0  2

1 1 0 1

1 0 1 0

0 2 1  0

85

Figura 6.11

Matricele de Adiacenta pentru Graf-urile Neorientate

DEFINIŢIE: Fie dat un graf G, G = {V(G), E(G)}. Graful G se numeşte neorientat dacă el nu este orientat. EXEMPLUL 6.13.

Figura 6.12

DEFINIŢIE: Matricea V1 V2 V3 V4

A=

V1 V2 V3 V4

0 1  0  1

1 1 2 1

0 2 0 0

1 1 0  1

se numeşte matricea de adiacenţă a grafului neorientat G.

DEFINIŢIE:
86

Fie dat un graf neorientat G cu şirul ordonat de vîrfuri V1,V2,...,Vn, G = {V(G), E(G)}. Matricea de adiacenţă a grafului G este matricea

A=(aij)
elementele căreia sunt definite pe mulţimea numerelor întregi positive Ζ+, astfel încît aij= numărul de muchii care uneşte virful Vi şi virful Vj, pentru orice i,j =1,2,..,n

DEFINIŢIE: Matricea A se numşte simetrică, dacă şi numai dacă

aij = aji
pentru orice i,j = 1,2,…, n

Matricea de Adiacenţă şi Componentele Legate ale unui Graf
Să considerăm graful G care constă din câteva componente legate:

Figura 6.13 Matricea de adiacenţă are o formă specifică. Ea se numeşte matrice diagonală şi are forma: Matricea V1 V2 V3 V4 V5 V6 V7

87

A=

V1 V2 V3 V4 V5 V6 V7

1 0  1  0 0  0 0 

0 1 0 0 0 0 0 2 0 0 0 0 2 0 0 0 0 0  0 0 0 1 0 0 0 0 1 1 0 0  0 0 0 0 0 2 0 0 0 0 2 0
A1

Or matricea A poate fi prezentată în mod general după cum urmează:

A=

A2 .......

O

O

Ak

Figura 6.14 unde Ai, reprezintă matricele de adiacenţă ale grafurilor Gi, pentru orice i=1,2,...,k, care reprezintă componentele legate ale grafului G, iar O reprezinta matricele care au toate valorile de intrare egale cu 0. TEOREMA 6.2: Fie G un graf cu componentele legate G1, G2, …, Gn. Dacă fiecare Gi are ni vîrfuri şi aceste vîrfuri sunt numerotate consecutiv, matricea de adiacenţă a grafului G are structura diagonală prezentată mai sus. În ea orice matrice Ai este matricea adiacentă a grafului legat Gi. Ea are dimensiunea ni x ni.

Determinarea Traseurilor de Lungime n
Să ne reamintim definiţia de traseu într-un graf G.

☞ ☞

DEFINIŢIE: Traseul într-un graf G dintr-un virf al lui V în alt virf W reprezintă succesivitatea alternantă şi finită de vârfuri şi muchii adiacente lor ce aparţin grafului dat. Numărul de muchii în această succesivitate este denumit lungimea traseului.

88

De exemplu, mişcarea V2 e3 V3 e4 V2 e2 V2 e3 V3 are lungimea 4 /e3 se ia in calcul de două ori/

EXEMPLUL 6.14. Determinaţi cîte trasee distincte de lungimea 2 vor lega V2 cu V2?

Figura 6.15 Soluţie: Iată aceste trasee reprezentate prin succesivitatea ce urmează: V2 e1 V1 e1 V2 V2 e2 V2 e2 V2 V2 e3 V3 e4 V2 V2 e4 V3 e3 V2 V2 e3 V3 e3 V2 V2 e4 V3 e4 V2 Astfel, în graful G prezentat mai sus, din virful V2 în vîrful V2 există 6 trasee de lungimea 2. În teoria grafurilor, problema determinării numărului de trasee dintr-un virf al unui graf într-un alt virf al lui, cu lungimea traseului dată, este soluţionată utilizând matricea adiacentă. Matricea de adiacenţă a grafului prezentat mai este: V1 V2 V3

A=

V1 V2 V3

0 1   0

1 1 2

0 2  0
89

Să calculăm cu ce este egal patratul matricei A, adică să determinăm A2

A2 =

0 1   0

1 1

0 2  2 0

X

0 1   0

1 1

0 2  2 0

=

1 1   2

1 6

2 2  2 4

Observăm că elementul din coloana 2 şi rîndul 2 este egal cu numarul de trasee de lungimea 2 din virful V2 în virful V2. El se obţine prin înmulţirea rindului 2 din Matricea de adiacenţă A la elementele coloanei a doua din aceeaşi matrice, adică

[1

1

2] X

1  1     2

= 1*1 + 1*1 + 2*2 = 6

ori, altfel zis, 6, care reprezintă numărul de trasee distincte de lungimea 2 ce vor conecta V2 cu V2, este de fapt numărul care reprezintă valoare elementului a22 al matricei A2. TEOREMA 6.3: Dacă G este un graf cu virfurile V1,V2,....,Vm, şi A este matricea de adiacenţă a lui G, atunci pentru orice număr pozitiv n, elementul aij al matricei An este egal cu numărul de trasee de lungimea n din Vi în Vj, pentru orice i,j=1,2,....,m.

Izomorfismul Graf-urilor
Noţiunea de izomorfism are semnificaţia de asemănător ca formă, sau identitate de structură. În teoria graf-urilor izomorfismul are semnificaţia de aplicaţie sau funcţie, care transformă un graf în altul păstrându-i structura, ori o funcţie care, fiind aplicată asupra unui graf, nu-i schimbă forma.

DEFINIŢIE: Fie dat un graf G, G = {V(G), E(G)} şi G’ = {V(G’), E(G’)}. Vom spune că graful G este izomorf lui G’ dacă şi numai dacă există 2 aplicaţii/funcţii/corespondenţe univoce gşi h, astfel încăt
90

g : V(G) → V(G’) h : E(G) → E(G’) care păstrează funcţia muchie – punct de extremă a lui G si G’, adică în sensul în care pentru orice V ∈ V(G) şi e ∈ E(G), unde V este un punct de extremă a muchiei e, atunci şi numai atunci cind g(V) este punct de extremă a lui h(e). EXEMPLUL 6.15 Demonstraţi că graf-urile ce urmează sunt izomorfe:

Figura 6.16

Soluţie:

Figura 6.17

7. ARBORI

☞ ☞

DEFINIŢIE: Un graf G se numeşte liber-circuit dacă şi numai dacă el nu are circuite netriviale DEFINIŢIE: Un graf se numeşte arbore, dacă şi numai dacă el:  este liber – circuit  este legat
91

Remarcă: Un arbore trivial este un graf care constă dintr-un singur vârf. Un arbore vid este un arbore care nu are nici un vârf şi nici o muchie. Un graf formează o structura de arbori (o pădure) dacă şi numai dacă el este libercircuit. EXEMPLUL 7.1 Următoarele grafuri sunt arbori :

Figura 7.1 EXEMPLUL 7.2

Următoarele grafuri nu sunt arbori: Figura 7.2 EXEMPLUL 7.3 Analiza unei Propoziţii – notaţia Backus-Naur (Varianta Engleză) 1. 2.3 4. 5. <sentence> <noun phrase> <verb phrase> <article>

→ → → →

<noun phrase> <verb phrase> <article> <noun> | <article> <adjective> <noun> <verb> <noun phrase> the
92

6. 7,8 9.

<adjective> <noun> <verb>

→ → →

young man | ball cought

Derivarea propoziţiei “The young man caught the ball” prezentate prin regulile de mai sus este descrisă prin arborele ce urmează:

Figura 7.3

Arbori Rădăcină

☞ ☞

DEFINIŢIE: Arborele rădăcină este un arbore în care un vârf este diferit de celelalte şi este denumit rădăcină. DEFINIŢIE: Nivelul vârfului unui arbore este numărul de muchii de-a lungul unei căi unice între el şi rădăcină. DEFINIŢIE: Înălţimea unui arbore rădăcină este nivelul maximal al oricărui vârf al arborelui.

☞ ☞

DEFINIŢIE: Fie V un vârf intern al unui arbore rădăcină. Urmaşii lui V sunt toate acele vârfuri care sunt adiacente lui V şi care sunt cu un nivel mai îndepărtat de vârful rădăcină decât cel al lui V. Dacă W este urmaşul lui V, atunci vârful V este numit părintele lui W. Două vârfuri care sunt urmaşii unuia şi aceluiaşi părinte se numesc vârfuri înrudite. Fie V şi W două vârfuri ale unui arbore. Dacă vârful V se află pe calea unică între W şi rădăcină, atunci V este un vârf ascendent al lui W, iar W este un vârf descendent al lui V. EXEMPLUL 7.4 În cele ce urmează prezentăm un arbore rădăcină. V este urmaşul vârfului U, U este părintele lui V şi V si W sunt vârfuri înrudite:

93

☞ ☞ ☞

Figura 7.4

DEFINIŢIE: Arborele binar este un arbore rădăcină în care orice vârf intern are cel mult doi urmaşi. Orice urmaş într-un arbore binar este determinat ca fiind un urmaş de stânga sau un urmaş de dreapta (dar nu ambii), iar un vârf interior are cel mult un urmaş de stânga şi unul de dreapta. DEFINIŢIE: Arborele în care orice vârf intern are exact doi urmaşi se numeşte arbore binar complet. DEFINIŢIE: Fie dat un vârf V al unui arbore binar T. Subarborele de stânga al vârfului V este un arbore binar  a cărui rădăcină este urmaşul de stânga al lui V,  ale cărui vârfuri constau din urmaşul de stânga al lui V şi toţi descendenţii acestuia,  şi ale cărui muchii constau din acele muchii ale lui T care leagă împreună vârfurile subarborelui de stânga Remarcă: Subarborele de dreapta se defineşte analogic. EXEMPLUL 7.5 Termenii definiţi mai sus sunt ilustraţi în figura ce urmează:

94

Figura 7.5

SETUL DE EXERCIŢII PENTRU AUTOEVALUARE ŞI EXAMEN NR.6.1 Pentru grafurile ce urmează 1. Determinaţi toate muchiile care sunt incidente vârfului Vi; 2. Determinaţi toate vârfurile ce sunt adiacente vârfului V3; 3. Determinaţi toate muchiile care sunt adiacente muchiei e1; 4. Determinaţi toate buclele; 5. Determinaţi toate muchiile paralele; 6. Determinaţi toate vârfurile izolate; 7. Determinaţi rangul vârfului V3; 8. Determinaţi rangul total al grafului G;

95

1.1

1.2

96

Literatura
1. 2. 3. Popescu А., Moraru V. Computer Mathematics. Material didactic. Chişinău, U.T.M., 1999. Липски, "Комбинаторика для программистов", Мир, 1985. Савельев, "Прикладная теория цифровых автоматов", Машиностроение, 1986

97

Sign up to vote on this title
UsefulNot useful