You are on page 1of 49

c cc

Origem: Wikipédia, a enciclopédia livre.


Ir para: navegação, pesquisa

c cc é um software aplicativo (programa de computador) do tipo científico, acrónimo


de ctatistical ackage for the cocial cciences - pacote estatístico para as ciências
sociais. Pacote este de apoio a tomada de decisão que inclui: aplicação analítica, Data
Mining, Text Mining e estatística que transformam os dados em informações
importantes que proporcionam reduzir custos e aumentar a lucratividade. Um dos usos
importantes deste software é para realizar pesquisa de mercado.


[esconder]

Œ º Histórico
Œ è Versões do SPSS
Œ  Outros programas de Estatística
Œ D Ligações externas

_
  

Teve a sua primeira versão em º  e é um dos programas de análise estatística mais
usados nas ciências sociais; é também usado por pesquisadores de mercado, na pesquisa
relacionada com a saúde, no governo, educação e outros sectores. Foi inventado por
Norman H. Nie, C. Hadlai (Tex) Hull e Dale H. Bent. Entre º  e º  a Universidade
de Chicago por meio do seu National Opinion Research Center esteve a cargo do
desenvolvimento, distribuição e venda do programa. A partir de º  corresponde à
SPSS Inc.

Originalmente o aplicativo foi criado para grandes computadores. Em º  foi


publicado o primeiro manual de usuário/utilizador do SPSS por Nie e Hall. Este manual
populariza o programa entre as instituições de educação superior nos EUA. Em º D
saiu a primeira versão para computadores pessoais.

O aplicativo SPSS é vendido por uma companhia chamada também de SPSS. Isto é algo
confuso, uma vez que a companhia vende uma larga gama de software de análise
estatística que não apenas o programa SPSS. As iniciais da companhia significam hoje
ctatistical roduct and cervice colutions.

O SPSS Data Editor é útil para fazer testes estatísticos, tais como os testes da
correlação, multicolinearidade, e de hipóteses; pode também providenciar ao
pesquisador contagens de freqüência, ordenar dados, reorganizar a informação, e serve
também como um mecanismo de entrada dos dados, com rótulos para pequenas
entradas.
O SPSS Data Editor tem duas "perspectivas" (views), a Data View (onde ocorre a
entrada dos dados) e a perspectiva das variáveis, onde podemos seleccionar o nome,
tipo, número máximo de letras por célula ("width"), número de casas decimais, rótulo,
largura da célula ("columns"), alinhamento dentro da célula ("align"), e caso se quer ou
não que a variável seja nominal, ordinal, ou "scale" ("measure"). Na perspectiva das
variáveis também se podem categorizar as entradas em rótulos (isto é onde o uso de
duas letras pode surgir em vez de palavras inteiras, na coluna "Values") e marca
entradas como inválidas (na coluna "Missing").

Para aplicações especiais, tais como a análise conjunta ou de séries temporais, há


módulos adicionais que se juntam ao programa base. Para além disso, a empresa SPSS
oferece outros produtos como Clementine ou AnswerTree (anteriormente CHAID), que
são programas Stand-alone e funcionam independentemente do SPSS base.

O SPSS é acionado pelo menu, mas também possui uma linguagem de programação
própria.

Como programa estatístico é muito popular também pela capacidade de trabalhar com
bases de dados de grande dimensão. Na versão ºè são possíveis mais de è mil milhões
de regist(r)os e è  variáveis.

_

 c cc
ΠSPSS-X (para grandes servidores tipo UNIX)
Œ SPSS/PC (º D, em DOS. Primeira versão para computador portátil)
Œ SPSS/PC+ (º  (em DOS)
Œ SPSS for Windows  (º è)
ΠSPSS for Windows 
ΠSPSS for Windows 
ΠSPSS for Windows
Œ SPSS for Windows º / for Macintosh º (è)
Œ SPSS for Windows ºº (èº) / for Mac OS X ºº(èè)
Œ SPSS for Windows ºº. (èè)
Œ SPSS for Windows ºè (è)
Œ SPSS for Windows º
Œ SPSS for Windows ºD
Œ SPSS for Windows º
Œ SPSS for Text Analysis for Surveys. (èD)
Œ SPSS for Windows º
Œ SPSS Statistics º (Windows & Mac)
Œ PASW Statistics º
Œ IBM SPSS Statistics º

Desde o SPSS/PC há uma versão adjunta denominada SPSS Student que é um programa
completo da versão correspondente mas limitada na capacidade quanto ao número de
regist(r)os e variáveis que pode processar. Esta versão é para fim educativo.

_

 

     
ΠSISTAT
ΠInsightful (Antigo S-Plus)
ΠIGEst
ΠAxum
ΠProjeto R
ΠSAS
ΠStatistica
ΠMinitab
Πe-Views
ΠShazam
ΠMatlab
ΠSphinx Software

_
  
 
ΠSPSS Inc Homepage
ΠSPSS BR.
ΠSPSS User Group Homepage
Œ Raynald Levesque's SPSS Tools - material de apoio para os usuários do SPSS.
ΠGNU PSPP - um programe livre (free software) que usa a linguagem SPSS.
Œ SPSS Log - Notícias e soluções de problemas relacionados ao SPSS
Œ Forum de SPSS - um forum para usuários de SPSS (desde junho è)
ΠNational Opinion Research Center

Œ ntrodução ao SPSS 
Π
Œ ántrodução
Œ

Œ O SPSS (Statistical Package for Social Sciences  é uma aplicação de


tratamento estatístico de dados. Esta aplicação torna a análise
estatística de dados acessível para o utilizador casual e conveniente
para o utilizador mais experiente.
Œ O objectivo deste capítulo é fornecer bases para a utilização do SPSS
por utilizadores menos experientes.

Œ O SPSS apresenta-se como uma aplicação de fácil manuseamento visto


que a sua apresentação e o modo como funciona é semelhante a
qualquer aplicação desenvolvida para Windows.
Œ

Œ



K 

‘    

ántrodução ao SPSS

Estatística descritiva

Teorema do Limite Central

Distribuição Normal

Distribuição t-student

Teste t para diferenças de médias

Analise de variância

Correlação e regressão

Tabelas de contingência

Testes não paramétricos

Estatística descritiva

ántrodução

ániciando o SPSS

ánterfaces do SPSS

Abrir e gravar uma base de dados

Criar uma base de dados

Recodificação de variáveis
Selecção de subgrupos

Edição de tabelas e gráficos

ántrodução ao SPSS 

ániciando o SPSS 


6uando o SPSS é iniciado, é apresentada no ecrã a janela uma imagem semelhante á figura 1. A
imagem contém a janela SPSS for Windows (figura 2.

Pode efectuar as seguintes tarefas:

ΠIniciar o manual ( Run the tutorial


ΠConstruir uma nova base de dados ( Type in data
Œ Importar dados, através de uma 'query', de uma base de dados já existente (Run an existing Query 
Œ Importar dados, através de uma 'query', de uma base de dados já existente ( Create new Query using
DataBase Capture Wizard 
Œ Abrir uma base de dados já existente ( pen an existing file 

bastando para isso seleccionar a tarefa pretendidaclicando sobre o círculo correspondente e clicar de seguida e
.
*a parte inferior da janela SPSS for Windows, é apresentada uma lista de bases de dados usadas recentemen
no SPSS. 



K 

‘    

ántrodução ao SPSS

Estatística descritiva

Teorema do Limite Central

Distribuição Normal

Distribuição t-student

Teste t para diferenças de médias

Analise de variância

Correlação e regressão

Tabelas de contingência

Testes não paramétricos

Estatística descritiva

ántrodução

ániciando o SPSS

ánterfaces do SPSS

Abrir e gravar uma base de dados

Criar uma base de dados

Recodificação de variáveis

Selecção de subgrupos

Edição de tabelas e gráficos

ántrodução ao SPSS 
ánterfaces do SPSS 


O SPSS para além de permitir o uso do rato, aprese nta outro tipo de interfaces como por exemplo:
janelas, barras de ferramentas, barras de estado e caixas de diálogo, que tornam ainda mais acessíve
sua utilização.

As janelas de uso mais frequente são:

Œ A janela de edição ( SPSS Data Editor, mostra o conteúdo de uma base de dados, e permite criar nova
bases de dados ou modificá -las. A figura 3 mostra a janela de edição juntamente com a base de dados
³Alcohol.sav´. 
Œ A janela de comandos ( SPSS Sintax Editor, mostra os comandos correspondentes às operações
efectuadas entre ficheiros ou dados. Pode gerar comandos a partir das caixas de diálogo e gravá -los nu
ficheiro para uso em sessões subsequentes. A figura 4 mostra a janela de comandos. 
ΠA janela de resultados ( SPSS Viewer ou utput, mostra os resultados automaticamente sempre que
executarmos um procedimento de análise. A figura 5 mostra uma tabela de frequências. 
Œ A janela de Script é uma janela de programação que permite personalizar e automatizar tarefas do SP
*ão é dado ênfase a esta janela no âmbito deste curso. 

Cada janela do SPSS tem a sua barra de menus com as suas próprias opções, disponíveis no cimo de cada
janela do SPSS. Os menus Statistics e Graphs estão disponíveis em todas as janelas, tornando então mais fá
produzir novos resultados sem ter de trocar de janela. A figura 6 mostra a barra de menus da janela de edição.

Cada janela do SPSS tem a sua barra de ferramentas que proporciona rápido acesso às tarefas mai
comuns. A figura 7 mostra os componentes básicos de uma barra de ferramentas . Se colocar o
ponteiro do rato sobre o botão de uma ferramenta, aparece uma breve descrição da ferramenta. Est
barras encontram-se disponíveis sob as barras de menus de cada uma das janelas do SPSS.

A barra de estado situa-se no fundo de cada janela do SPSS, disponibilizando informação sobre o
estado actual das tarefas executadas no momento. A figura 8 mostra a barra de estado da janela de
edição.

A maioria das selecções feitas em menus geram uma caixa de diálogo . Estas caixas de diálogo serv
para seleccionar variáveis e opções de análise. A figura 9 mostra os componentes básicos de uma ca
de diálogo. O exemplo1 mostra como seleccionar uma variável para análise.

*a janela de comandos ( SPSS Sintax Editor , pode observar os comandos gerados por uma caixa d
diálogo, quando se clica no botão Paste da mesma caixa de diálogo. Todos os comandos terminam c
'.', seguindo-se então um novo comando.
Para executar um determinado comando, posiciona -se o cursor no ínicio desse comando, e mantêm -
pressionado o botão esquerdo do rato. De seguida arras ta-se o ponteiro do rato de modo a selecciona
o respectivo comando. O resultado desta operação é apresentado na figura 10.


K 

‘    

ántrodução ao SPSS

Estatística descritiva

Teorema do Limite Central

Distribuição Normal

Distribuição t-student

Teste t para diferenças de médias

Analise de variância

Correlação e regressão

Tabelas de contingência

Testes não paramétricos

Estatística descritiva
ántrodução

ániciando o SPSS

ánterfaces do SPSS

Abrir e gravar uma base de dados

Criar uma base de dados

Recodificação de variáveis

Selecção de subgrupos

Edição de tabelas e gráficos

ántrodução ao SPSS 

Abrir e gravar uma base de dados 




Se estiver a iniciar o SPSS, pode abrir uma base de dados a partir do ecrã de apresentação do SPSS
(figura 2, seleccionando a opção pen an Existing File .
Se a base de dados estiver na lista apresentada basta clicar duas vezes sobre a base de dados
pretendida e de seguida em . Use as teclas de direcção do teclado para procurar a base de dados
pretendida.

Se a base de dados não estiver na lista apresentada clique sobre ðore Files na referida lista.
Aparecerá então a caixa de diálogo pen File (figura 11. Seleccione a base de dados pretendida
clicando-a, e de seguida clique no botão pen.

Se já estiver a usar o SPSS, seleccione o menu File> pen (figura 12 a partir da janela de edição
(SPSS Data Editor. Aparecerá de novo a caixa de diálogo pen File (figura 11. Proceda de modo
semelhante ao descrito anteriormente.

Os dados armazenados num outro formato de dados que não o do SPSS podem ser lidos mudando a
opção Files of Types no fundo da janela pen File (figura 13.

Do mesmo modo, utiliza-se a janela de edição ( SPSS Data Editor , para gravar uma base de dados,
seleccionando as opções correspondentes do menu File.

Podemos gravar uma base de dados, substituindo -a pela anterior existente na mesma localização,
seleccionando o menu File>Save (figura 14. A base de dados é automáticamente gravada.

Se não quisermos perder a base de dados anterior, gravamos a base de dados com um nome e/ou
formato diferente e/ou numa localização diferente. Para tal seleccionamos o menu File>Save As (figu
15. Aparecerá então no ecrâ a caixa de diálogo Save Data As (figura 16. Para gravar uma base de
dados com um nome diferente digite o nome pretendido na caixa File *ame da caixa de diálogo Save
Data As .


K 

‘    

ántrodução ao SPSS

Estatística descritiva

Teorema do Limite Central

Distribuição Normal
Distribuição t-student

Teste t para diferenças de médias

Analise de variância

Correlação e regressão

Tabelas de contingência

Testes não paramétricos

Estatística descritiva

ántrodução

ániciando o SPSS

ánterfaces do SPSS

Abrir e gravar uma base de dados

Criar uma base de dados

Recodificação de variáveis

Selecção de subgrupos

Edição de tabelas e gráficos

ántrodução ao SPSS 

Criar uma base de dados 




Os dados são editados na janela SPSS Data Editor. A figura 17 mostra a base de dados "Alcohol.sav
*ote-se que as linhas da grelha de edição representam casos distinitos, enquanto que as colunas
representam as variáveis que se pretendem estudar a parti r de uma amostra de uma determinada
população. Os nomes das variáveis aparecem no início de cada coluna.

Apresentar-se-á como exemplo a construção de uma base de dados, a partir dos dados apresentados
na figura 18. A primeira variável da base de dados, apresentada na figura anterior, é chamada 'Id'
usada para identificar cada caso introduzido.

O objectivo desta secção é disponibilizar um modo eficiente de criar uma base de dados, de tal manei
que durante o tratamento estatístico dos dados não ocorram dúvidas acerca do que representa cada
uma das variáveis e da forma como deveriam estar definidas.

Antes da introdução dos dados, é necessário criar e definir variáveis. Para criar uma nova variáve l ba
clicar duas vezes seguidas sobre uma das etiquetas ' var', que se encontra no cimo das colunas vazia
da janela de edição. Surge então no ecrã a caixa de diálogo Define Variable . A figura 19 mostra a ca
de diálogo Define Variable com uma breve descrição dos seus componentes. Apenas podemos defin
uma variável de cada vez.

Para definir uma variável deverá seguir os seguintes passos:

º passo: Definir o nome da variável

*a caixa Variable Name da caixa de diálogo Define Variable (figura 20, substitui-se 'VAR00001' por
um nome sugestivo que permita identificar a que se referem os valores que se vai introduzuir nessa
coluna. *a figura 21 apresenta-se a imagem resultante para a variável sexo.

6ualquer nome de uma variável não pode ter mais do que oito caracteres.

è passo: ðodificar as definições da variável

Defenir o tipo de dados 

Para defenir o tipo de dados dos valores a introduzir deverá clicar no botão Type da caixa de diálogo
Define Variable (figura 21, surgirá então a subcaixa de diálogo Define Variable Type (figura 22. Do
lado esquerdo podemos escolher o tipo de dados relativos á variável a defenir seleccionando o círculo
correspondente.

As variáveis podem ser tanto quantitativas, como por exemplo a altura ou a idade, ou ser qualitativas
como o sexo ou nome. *este caso escolhe -se o tipo de dados numérico, embora a variável seja
qualitativa como apresentado na figura 23.
*o caso das variáveis qualitativas é útil usar valores numéricos. Deverá ser usado este procedimento
sempre que possível, excepto por exemplo em variáveis tais como '*ome', na qual não traz vantagem
usar valores numéricos.

Após estar definido o tipo de dados deverá clicar em Continue da subcaixa de diálogo Define Variab
Type (figura 23 para voltar á caixa de diálogo Define Variable figura 24 onde poderá observar
alterações na zona de descrição.

O tipo de dados numérico deve ser preferencialmente usado relativamente aos outros tipos de dados.

Atribuir etiquetas a variáveis e a valores de variáveis 

Para atribuir uma etiqueta ao nome da variável e/ou aos valores da variável deverá clicar no botão
Labels da caixa de diálogo Define Variable (figura 24, aparecerá então a subcaixa de diálogo Defin
Labels (figura 25. A figura 26 apresenta uma sugestão para a etiqueta da variável 'Altura'.

A caixa Value Labels da subcaixa de diálogo Define Labels (figura 27, permite atribuir etiquetas aos
valores de variáveis qualitativas, como por exemplo para a variável sexo. Para tal, atribuímos a cada
valor numérico uma etiqueta. *o caso da variável sexo(variável qualitativa podemos usar o valor 1 e
em vez de masculino e feminino respectivamente, na introdução da variável sexo. Deste modo,
podemos atribuir a etiqueta masculino ao valor 1 e feminino ao valor 2. Para atribuir etiquetas a valore
de variáveis, escreve-se nas caixas ao lado das opções Value e Value Label o valor e a etiqueta
respectivamente, como se pode observar na figura 28. Para introduzir cada uma das etiquetas, clica -s
no botão Add. O resultado deverá ser uma imagem semelhante á figura 29.

6uando tiver introduzido todas as etiquetas deverá clicar em Continue da subcaixa de diálogo Define
Labels (figura 29 para voltar á caixa de diálogo Define Variable (figura 30.



Valores desconhecidos 

Ú muitas vezes útil saber porquê a informação não é conhecida. Por exemplo, num questionário
podemos ter dois tipos de valores desconhecidos, e querer distingui -los. O primeiro devido ao facto de
um indivíduo não ter dado uma resposta, e o segundo devido ao facto de que a variável em questão n
se aplica a esse indivíduo. *este caso atribui-se um valor a cada um dos casos e define-se as etiquet
para esses valores. Por exemplo se desconhecemos o sexo de um indivíduo, clica -se no botão Label
da caixa de diálogo Define Variable (figura 30, fazendo surgir a subcaixa de diálogo Define Labels
(figura 29. O resultado é apresentado na figura 31. De seguida clica-se em Continue (figura 31 para
voltar á caixa de diálogo Define Variable (figura 30. Agora clica-se no botão missing values da caix
de diálogo Define Variable (figura 30. Surgirá então a subcaixa de diálogo Define ðissing Values
(figura 32. *este caso só temos um valor desconhecido para definir (figura 33. Clique em Continue
para voltar á caixa de diálogo Define Variable (figura 34.

Os valores de uma variável especificados como V  


 pelo utilizador são excluídos do
tratamento estatístico dos dados e são tratados como um caso especial.

*ão se pode definir missing values para variáveis alfanuméricas(strings com strings maiores de 8
caracteres.

Todos os valores atribuídos a strings são considerados válidos a menos que sejam especificados com
missing values.

Alterar o formato da coluna

Para alterar o formato da coluna da variável em questão, deverá clicar em Column Format da caixa
diálogo Define Variable (figura 34, e então aparecerá uma nova subcaixa de diálogo chamada Defin
Column Format (figura 35. A figura 36 apresenta uma sugestão para a variável sexo.
Depois de ter terminado clique em Continue (figura 36 para voltar á caixa de diálogo Define Variab
(figura 37.



D passo: Definir o tipo de variável 

A especificação do tipo de variável é apenas relevante para uso em tabelas e gráficos. Como se pode
observar na figura 38 existem três tipos de variáveis admitidas pelo SPSS. As variáveis do tipo Nomin
e rdinal são ambas tratadas como categóricas nos procedimentos de feitura de tabelas e gráficos.
*o caso da variável sexo definimos como sendo uma variável rdinal (figura 39.

6uando a definição estiver completa clique em na caixa de diálogo Define Variable (figura 39 pa
voltar à janela de edição de dados.

Tem de se repetir este processo para todas as variáveis que queiramos criar.

Depois de defenir todas as variáveis podemos então passar á introdução dos dados. Para as variáveis
qualitativas introduzimos os valore s correspondentes ás etiquetas atribuídas a esses valores. *as
variáveis quantitativas basta apenas introduzir os valores observados.
Se numa variável respeitante a uma entidade, se desconhecer o valor dessa variável, deixa -se em
branco esse valor, a menos que tenhamos definido etiquetas para os volores desconhecidos.


K 

‘    

ántrodução ao SPSS

Estatística descritiva

Teorema do Limite Central

Distribuição Normal

Distribuição t-student

Teste t para diferenças de médias

Analise de variância

Correlação e regressão

Tabelas de contingência
Testes não paramétricos

Estatística descritiva

ántrodução

ániciando o SPSS

ánterfaces do SPSS

Abrir e gravar uma base de dados

Criar uma base de dados

Recodificação de variáveis

Selecção de subgrupos

Edição de tabelas e gráficos

ántrodução ao SPSS 

Recodificação de variáveis 


*uma situação ideal, a forma como introduziu os dados é perfeita para o tipo de análise que deseja
efectuar. Infelizmente, isto raramente acontece. Uma análise preli minar pode revelar esquemas de
codificação inconvenientes, ou erros de codificação de variáveis.
Pode então executar transformações dos dados a partir de procedimentos simples, como juntar
categorias para análise, o que é denominado por recodificação de v ariáveis.

Para modificar a forma como os dados estão codificados ou agrupados seleccione o menu
Transform>Recode (figura 40 a partir da janela de edição ( Editor Data . Este procedimento é
particularmente útil para agrupar ou combinar categorias de variáveis.

A base de dados "Employee.sav" é usada dar exemplos.

Pode recodificar variáveis eliminando a variável de origem ( Recode into Same  (figura 41ou então
criando uma nova variável ( Recode into different  (figura 42. Como eliminar uma variável não é mui
aconselhado, a menos que tenhamos a certeza que não vamos precisar da va riável futuramente,
apresentamos apenas o caso de recodificação criando novas variáveis( Recode into different  (figur
42.

Pode recodificar variáveis numéricas e alfanuméricas. Se tiver selec cionado várias variáveis, é
necessário que todas sejam do mesmo tipo, isto é, não pode recodificar variáveis numéricas e
alfanuméricas ao mesmo tempo.
Por exemplo se quisermos agrupar os salários em categorias, na base de dados "Employee.sav",
seleccione então a opção Recode into different (figura 42. Aparece então a caixa de diálogo Recod
into Different Variables (figura 43. Seleccione agora a variável 'salary' da lista de variáveis do lado
esquerdo. Escreva de seguida o nome da variável de destino e a respectiva etiqueta, com um nome e
descrição sugestiva das variáveis. Clique agora em Change , para confirmar a variável de destino. A
figura 44 apresenta a imagem resultante.

Para dividir os salários em categorias, clicamos então em ld and New Values na caixa de diálogo
Recode into Different Variables figura 44. Aparece então a subcaixa de diálogo Recode into
Different Variables: ld and New Values (figura 45.
Do lado esquerdo define -se os limites das classes dos salários, seleccionando as opções Range ,
correspondentes ao tipo de classe que pretendemos, e do lado direito atribuímos a cada classe um
determinado valor, como na figura 46. Clica-se de seguida no botão Add para confirmar a classe que
acabamos de defenir. A imagem resultante para uma recodificação da variável 'salary' é apresentado
figura 47. Depois de terminar clique em Continue (figura 47 para voltar á caixa de diálogo Recode in
Different (figura 44.

Suponhamos agora que queremos apenas agrupar os s lários dos indivíduos do sexo masculino com
nível de instrução maior que 5 anos. Para tal clicamos no botão áf da caixa de diálogo Recode into
Different Variables (figura 44. Aparece então a subcaixa de diálogo Recode ánto Different variable
áf Cases (figura 48. Seleccionamos o círculo correspondente a á 



    e
seleccionamos a variável 'gender' da lista de variáveis do lado esquerdo. Depois de clicar na seta que
aponta para a direita obtemos a seguinte imagem ( figura 49. *a base de dados 'Employee Data' o va
'm' da variável 'gender' corresponde ao sexo masculino, então procedemos como apresentado na figu
50. Utilizamos os operadores lógicos da caixa de diálogo Recode ánto Different variables: áf Cases
(figura 48 para construir a expressão condicional bastando para tal clicar sobre o operador pretendido
A figura 51 apresenta a expressão condicional para o exemplo pretendido. Agora cli que em Continue
da subcaixa de diálogo Recode ánto Different variables: áf Cases (figura 51para voltar á caixa de
diálogo Recode ánto Different Variables (figura 52.
Clique agora em k da caixa de diálogo Recode ánto Different Variables (figura 52 para voltar á
janela de edição ( Editor Data .



K 

‘    

ántrodução ao SPSS

Estatística descritiva

Teorema do Limite Central

Distribuição Normal

Distribuição t-student

Teste t para diferenças de médias

Analise de variância

Correlação e regressão

Tabelas de contingência

Testes não paramétricos

Estatística descritiva

ántrodução

ániciando o SPSS

ánterfaces do SPSS

Abrir e gravar uma base de dados

Criar uma base de dados

Recodificação de variáveis

Selecção de subgrupos

Edição de tabelas e gráficos

ántrodução ao SPSS
Selecção para subgrupos

Em algumas análises pode ser útil executar o mesmo tipo procedimento para diferentes grupos
separadamente. Para tal utiliza -se a função Split File.

Por exemplo, podemos estar interessados em obter um histograma de frequências da categoria de


emprego para cada um dos sexos separadamente, a partir da base de dados "Employee Data".

Para tal selecciona-se o menu Data>Split File (figura 53 a partir da janela de edição (Editor Data .
Aparece então a caixa de diálogo Split File (figura 54. Agora seleccione o círculo correspondente a
rganize utput by groups e de seguida seleccione a variável 'gender' da lista de variáveis do lado
esquerdo e clique na seta que aponta para a direita. O resultado é apresentado na figura 55. Clique
agora em k para voltar á janela de edição ( Editor Data .
Depois de escolher o procedimento pretendido, todos os resultados são apresentados separadamente
para cada grupo na janela de resultados.
A opção Compare groups disponível na caixa de diálogo Split File (figura 54 é particularmente útil e
procedimentos de testes de hipóteses a qual não trataremos no âmbito introdutório desta secção.

Um outro modo de seleccionar casos para análise é utilizando a função Select Cases . Para tal
seleccione, a partir da janela de edição ( Editor Data , o menu Data>Select cases (figura 56. Aparec
então a caixa de diálogo Select Cases (figura 57.

As expressões condicionais são as mais frequentemente usadas, por isso restringimos a exposição a
uma aplicação deste caso.

*a base de dados "Employee Data", podemos estar apenas interessados em indivíduos do sexo
masculino cujo primeiro salário é superior a $20,000. Para excluir os restantes casos da anális e,
seleccione o menu DATA>Select Cases (figura 56 a partir da janela de edição ( Editor Data . Apare
então a caixa de diálogo Select Cases (figura 58. Para introduzir então a expressão condicional que
define os casos que pretendemos, clique sobre o botão áf da referida caixa de diálogo. Aparece então
subcaixa de diálogo Select Cases: áf (figura 59, onde deverá então escrever "gender='m' &
salbegin<=20000" (figura 60, e clique em Continue para voltar á caixa de diálogo Select Cases (figu
61. Para não eliminarmos os restantes casos da base de dados não devemos seleccionar a opção
4
 

  Deleted e clicamos em (figura 61 paras voltar á janela de edição ( Editor
Data .

*a caixa de diálogo Select Cases:áf poderá usar as funções apresentadas na lista do lado direito, bem
como a calculadora ao centro para escrever a expressão condicional pretendida.





K 

‘    

ántrodução ao SPSS

Estatística descritiva

Teorema do Limite Central

Distribuição Normal

Distribuição t-student

Teste t para diferenças de médias

Analise de variância

Correlação e regressão

Tabelas de contingência

Testes não paramétricos

Estatística descritiva

ántrodução

ániciando o SPSS

ánterfaces do SPSS

Abrir e gravar uma base de dados

Criar uma base de dados


Recodificação de variáveis

Selecção de subgrupos

Edição de tabelas e gráficos

ántrodução ao SPSS

Edição de Tabelas e Gráficos



Uma tabela ou gráficos bem elaborados devem permitir uma rápida recolha de informação. Trataremo
no âmbito deste curso apenas da edição de tabelas e gráficos de um modo geral. A edição de tabelas
gráficos faz-se a partir da janela de resultados (SPSS Viewer .

Para seleccionar a tabela que pretende editar, clique uma vez sobre a respectiva tabela ( figura 66.
Deverá agora clicar duas vezes sobre a mesma tabela, para activar o menu de edição ( figura 67.
Poderá agora fazer as alterações que pretender á sua tabela.

Apresentar-se-á apenas como exemplo a edição da tabela representada na figura 68.

Pode utilizar o menu View>Gridlines (figura 69 para visualizar os limites de cada célula que constitu
uma tabela. O resultado é apresentado na figura 70. Para esconder os limites das células seleccione
novo View>Gridlines (figura 69. A tabela terá então o seguinte aspecto ( figura 71.

Para alterar o texto de cada uma das células de uma tabela, basta clicar duas vezes sobre a célula á
qual se pretende alterar o texto ( figura 72. Então podemos agora alterar o texto da célula selecciona

O menu Format (figura 73 permite além de outras tarefas, alterar a aparência de uma tabela, formata
a tabela e/ou cada uma das células individualmente.

Para formatar cada uma das células separadamente, seleccione a célula pretendida clicando -a uma
cujo resultado se pode observar na figura 74, e de seguida seleccione o menu Format>Cell Properti
(figura 75. Aparece então no ecrâ a caixa de diálogo Cell properties (figura 76. Por exemplo, para
centrar o texto de uma célula seleccione Alignment da caixa de diálogo Cell properties e a opção
Center (figura 77. De seguida clique em para voltar á janela de resultados ( SPSS Viewer. A fig
78 apresenta uma sugestão para uma tabela.
Para alterar o formato geral de uma tabela, seleccione o menu Format>Table Properties (figura 79
Aparece então a caixa de diálogo Table Properties (figura 80. Por exemplo para por o texto das
etiquetas das colunas e linhas a carregado, seleccione Cell Formats (figura 81 e na opção Area
seleccione Column Labels e na opção Text clique sobre o botão B, como representado na figura 8
Procede-se de modo semelhante para as linhas. Após ter terminado clique em k ou Aplicar para vo
á tabela (figura 83.
A opção Table Looks do menu Format, permite alterar a aparência de uma tabela. Por exemplo,
seleccione o menu Format>Table Looks (figura 84, aparecerá então a caixa de diálogo Table Look
(figura 85 e clique em "Academic2". Depois de ter clicado em k , a sua tabela terá o seguinte aspec
(figura 86. *a caixa de diálogo Table Looks pode modificar um estilo de aparência de uma tabela e
aplicá-lo directamente á sua tabela, para tal clique no botão Edit Look .

Após criar um gráfico pode editá-lo, para apresentação. Todas as modificações de um gráfico são fei
na janela de edição de gráficos ( SPSS Chart Editor . Para abrir esta janela, clique duas vezes sobre
gráfico que pretende editar para abrir a janela de ediç ão de gráficos ( SPSS Chart Editor representa
na figura 87. Este procedimento activa de imediato o menu de edição de gráficos que se pode observ
na figura 88.

Como exemplo apresentar-se-á com algum detalhe os passos de edição do gráfico representado na
figura 89.
O menu Chart (figura 90 contém as opções necessárias á edição de gráficos.
Para alterar as etiquetas dos eixos seleccionamos o menu Chart>Axis (figura 91. Aparece então a
caixa de diálogo Axis Selection (figura 92 onde seleccionamos a opção Category para o eixo
horizontal, seleccionando o círculo correspondente. Aparece então a subcaixa de diálogo Category
Axis (figura 93. Para alterar o título do eixo horizontal e centrá -lo procedemos do modo representado
na figura 94. Clicando no botão Labels aparecendo então uma nova caixa de diálogo ( figura 95. *a
figura 96 é apresentada uma sugestão para a alteração das categorias do eixo horizontal, e na figura
podemos visualizar as alterações feitas no gráfico. Os procediemntos para as legendas, notas de
rodapé e títulos são semelhantes seleccionando as opções correspondentes do menu Chart.
*a figura 98 podemos visualizar um gráfico completamente editado.


Figura 1: Imagem inicial do SPSS.


Figura 1: Imagem inicial do SPSS.



Figura 3: Componentes básicos da janela de edição (SPSS Data Editor.



Figura 5: Componentes básicos da janela de resultados (SPSS Viewer.

Figura 6: Componentes básicos de tratamento estatístico de dados da barra de menus da


janela de edição.

Figura 7: Componentes mais usados, da barra de tarefas da janela de edição (SPSS Data
Editor.
Figura 8: Componentes da barra de estadoda janela de edição (SPSS Data Editor.

Figura 9: Componentes básicos de uma caixa de diálogo.

Exemplo º:

Consideremos os seguintes dados:

* Manuel Costa João Santos


 èè anos è anos
 !" º. m º. m

*o SPSS Data Editor estes dados deverão aparecer da seguinte forma:


Figura 10: Comando seleccionado na janela decomandos (SPSS Syntax Editor

Figura 2: A janela SPSS for Windows.

Figura 11: A janela pen File.


Figura 13: A caixa de diálogo pen File, mostra como se procede para abrir
uma base de dados com formato diferente do SPSS.
Figura 14: O menu File>Save da janela de edição (SPSS Editor Data 

Figura 15: O menu File>Save As da janela de edição (SPSS Data Editor.


Figura 18: Tabela com alguns valores de uma base de dados e sua apresentação final no
SPSS.
Figura 19: Os componentes da caixa de diálogo Define Variable e
descrição dos seus componentes básicos.

Figura 20: A caixa de diálogo Define Variable

Figura 21: A caixa de diálogo Define Variable.


Figura 22: A caixa de diálogo Define Variable Type com a descrição
dos componentes para o tipo numérico de dados.

Figura 23: A subcaixa de diálogo Define Variable Type com as


definições do tipo de dados para a variável sexo.

Figura 24: A caixa de diálogo Define Variable.


Figura 25: A sub caixa de diálogo Define Labels e descrição dos seus componentes.

Figura 26: Sugestão de uma etiqueta para a variável Altura.

Figura 26: Sugestão de uma etiqueta para a variável Altura.

Figura 28: Atribuição de etiquetas para os valores da variável sexo.


Figura 29: Aspecto da subcaixa de diálogo Define Labels depois de
introduzidas as etiquetas para a variável Sexo.

Figura 30: A caixa de diálogo Define Variable.

Figura 31: Aspecto da subcaixa de diálogo Define Labels para a variavel Sexo
depois de introduzida a etiqueta para o valor desconhecido.

Figura 32: A subcaixa de diálogo Define ðissing Values


e descrição dos seus componentes.
Figura 33: Aspecto da subcaixa de diálogo Define ðissing Values
para a variável Sexo.

Figura 34: A caixa de diálogo Define Variable.

Figura 35: A subcaixa de diálogo Define Column Format e descrição


dos seus componentes básicos.

Figura 36: Sugestão para a variável Sexo.


Figura 37: A caixa de diálogo Define Variable.

Figura 38: A caixa de diálogo Define variable e a descrição do tipo de variáveis.

Figura 39: A caixa de diálogo Define Variable.


Figura 40: O menu Transform>Recode da janela de edição (SPSS Data Editor.

Figura 40: O menu Transform>Recode>ánto Same Variables da


janela de edição (SPSS Data Editor.

Figura 40: O menu Transform>Recode>ánto Different Variables da


janela de edição (SPSS Data Editor.

Figura 43: A caixa de diálogo   

   @
Figura 44: Sugestão para o nome da variável de destino da
recodificação da variável 'salary'@

Figura 45: A caixa de diálogo   

   


    @

Figura 46: Sugestão de duas categorias para a variável 'salary'@


Figura 47: Sugestão para a recodificação da variável 'salary'@

Figura 48: A subcaixa de diálogo   

   

  @

Figura 49: Aspecto da subcaixa de diálogo    


 
   depois de seleccionar a variável 'gender'@
Figura 50: Aspecto da subcaixa de diálogo    


 
   quando queremos seleccionar apenas
os indivíduos do sexo masculino@

Figura 53: O menu      @

Figura 54: A caixa de diálogo    @


Figura 55: Aspecto da caixa de diálogo    quando
selecionamos a variável 'gender'@

Figura 56: O menu        @

Figura 57: A caixa de diálogo      @


Figura 59: A subcaixa de diálogo Select Cases:If @

Figura 60: Exemplo de uma expressão condicional@

Figura 61: Aspecto da caixa de diálogo     


após ter defenido uma expressão condicional@
Figura 66: Aspecto da janela de resultados (    quando se
selecciona uma tabela@

Figura 67: O menu de edição de tabelas da janela de


resultados (   @

Figura 68: Tabela cruzada obtida a partir da base


de dados "Employee data"@

Figura 69: O menu View>Gridlines da janela de resultados ( 


 @
Figura 70: Tabela mostrando as células que a formam@

Figura 71: Tabela original dada pelo SPSS quando se activa o menu de
edição@

Figura 72: Aspecto de uma tabela quando seleccionamos uma célula@

Figura 74: Aspecto de uma tabela quando seleccionamos uma célula para
formatar@
Figura 75: O menu        da janela de
resultados (   @

Figura 77: A caixa de diálogo      quando se


selecciona a opção Alignment@

Figura 78: Sugestão de formatação de células para uma tabela@


Figura 78: O menu Format>Table Properties
da janela de resultados (   @

Figura 80: A caixa de diálogo Table Properties @

Figura 82: Sugestão para a alteração das etiquetas da columna de uma


tabela@
Figura 83: Aspecto de uma tabela após ter modificado o formato
das etiquetas das colunas@

Figura 84: O menu Format>Table Looks da janela de resultados ( SPSS


Viewer@

Figura 85: A caixa de diálogo Table Looks@

Figura 86: Aspecto de uma tabela completamente editada@


Figura 87: A janela de edição de gráficos (    @

Figura 88: O menu   da janela de edição de gráficos (  


  @

Figura 89: Exemplo de um gráfico de barras obtido a partir


da base de dados "Employee Data"@

Figura 90: O menu   da janela de edição de gráficos (  


  @

Figura 91: O menu Chart>Axis da janela deedição de gráficos (   


  @

Figura 92: A caixa de diálogo ´     @

Figura 93: A subcaixa de diálogo    ´  @


Figura 94: Sugestão para a alteração do título do eixo horizontal@

Figura 95: A subcaixa de diálogo    ´ !   @

Figura 96: Sugestão para a alteração das categorias


do eixo horizontal@
Figura 97: Resultado das alterações feitas para o eixo horizontal@

Figura 98: Exemplo de um gráfico de barras editado@