P. 1
Shareguru Help PDF

Shareguru Help PDF

|Views: 312|Likes:
Published by hiru2p

More info:

Published by: hiru2p on Nov 03, 2010
Copyright:Attribution Non-commercial


Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less





Requirements/Supported OS

To run ShareGuru Realtime software, Microsoft .NET Framework 2.0 is required.

Microsoft .NET Framework 2.0 You may download FREE by clicking here http://www.microsoft.com/downloads/details.aspx?FamilyID=0856eacb4362-4b0d-8edd-aab15c5e04f5&displaylang=en

Hardware Requirements
To run AmiBroker/Metastock you need PC-Compatible computer meeting following minimum requirements  Standard Version: o Pentium 1Ghz or higher o 256 MB RAM o 100 MB hard disk space o 256 color graphics card (high color recommended)

Real Time Version: o Pentium 1Ghz or higher o 512 MB RAM (Recommended 1GB DDR2 Ram) o 300 MB hard disk space (Database Size Keeps Increasing Over a period of time) o 256 color graphics card (high color recommended)

Supported Operating Systems
ShareGuru Realtime software works on the following operating systems:     Windows Windows Windows Windows 98SE Millennium XP (any edition) Vista

Installing ShareGuru Realtime Software

Download the latest version of ShareGuru Realtime software from our website http://www.shareguru.in for a 7-Days FREE DEMO. Unzip the downloaded Zip File and double click on the ShareGuruSetup icon. If upon clicking on this icon, a prompt window is opened to download Microsoft .NET Framework 2.0, means your computer is not installed with Microsoft .NET Framework 2.0 as to run ShareGuru Realtime, it is necessary that your computer should be installed with Microsoft .NET Framework 2.0. You may download this from here


It is recommended to install the software on default Directory and Folder i.e.C:\Program Files\ShareGuru Realtime

After the installation is completed, double click on the ShareGuru Realtime icon on your desktop and a registration window will open. You fill this registration form and ShareGuru Realtime software will be opened and you will be prompted to fill Yahoo ID details as below:

Please fill your Yahoo Login ID and Password and press the Save tab. Your Yahoo details will be saved in the software and this is the one time process and it will not prompt you again & again when you close the software and open it again.

To modify the directory path. . click on Settings options.Settings Settings menu option can be used to configure the Directories for converted data.  On the Menu Strip . click the browse button and traverse to the preferred location and press ok.

o Select the Radio Button "Enable" for Local Data storage. C:\Program Files\ShareGuru Realtime\Data\Amibroker\Live Check Mark the check box to make the database load by default on start up of AmiBroker. i.   Press the Create Button. On the Dialogue Box that appears provide path and name for the Database.e. o Write 50000 in Number of Bars column.    Open Amibroker and go to Files Menu -> New -> Database. o Select Base Time Interval as " Tick " from the Drop Down Menu.AmiBroker Database Creation Steps to create AmiBroker Database to be used with ShareGuru Realtime software. . Under the Data Source Section: o Select (local database) from Data Source Drop Down Menu.

Making it the default database would ensure smooth functioning and no errors in data. AmiBroker should be installed on the same drive where you have installed ShareGuru Realtime software for smooth functioning of both softwares. Example Charts: . Once the Database has been created and Data has been fetched into AmiBroker through ShareGuru Realtime software. Press Ok to finish the Database Setup Procedure and your AmiBroker software is setup to be used with ShareGuru Realtime software. NOTE : If you already have a database created. then simply go to File Menu -> Open Database and traverse the path to that database. you can select the script symbol and view its chart.




MetaStock Configuration Viewing Charts in MetaStock® as such requires no additional configurations in MetaStock Software.Note : For further help on AmiBroker please refer the AmiBroker Reference Guide provided with AMIBROKER SOFTWARE. Example : If you have provided the name of MetaStock . Simply Open the MetaStock Charting Software and browse to the folder specified under ShareGuru Realtime Directory Settings and select your favourite script to view in MetaStock.

Example : . Go To File Menu -> Open Charts Browse to C:\Program Files\ShareGuru Realtime\Data\Metastock\Live   Select the script symbol for which you want to plot the chart. Press OPEN and your chart will be displayed.Directory under the” Settings” tab as C:\Program Files\ShareGuru Realtime\Data\Metastock\Live .   then Open MetaStock Software .

At the time of setup please provide valid credentials to login to the Yahoo servers for Real Time updation of data.Yahoo Realtime Introduction ShareGuru Realtime software supports fetching Yahoo Data (Including National and International Indices and Stocks).   You will see “Market Watch” updating with Real Time Quotes for scripts included in the Ticker List.  Open the ShareGuru Realtime Application. To start updating your charting software with Yahoo Data. select your favourite Ticker List Then click on " Load" Button. Click On " Market Watch " option in menu tab   On the box that appears . . select your charting software first and then press the “Update Charts” button to start automatic update procedure. you need to be Logged In to Yahoo.To use Yahoo Data properly.

one list will not hamper working of other list. each Ticker List will run as a separate Market Watch and each can have different settings . like one can be used to update AmiBroker and second to update MetaStock .NOTE:  If you select Multilpe Ticker List to load . Example of Multiple Loaded Lists:  .


Procedure for Backfilling: .Backfill Data Introduction Intraday Data can be Backfilled with certain limitations. 5 minute Intraday Data available for past 5 days from the date of Backfilling.   1 minute Intraday Data available for the same day only.

Either Select "1 Min Data (One day)" or "5 Min Data (5 days)" option and press Download.  Example: . select your favourite Ticker List. Then click " Load " Button. Click on " Market Watch " option in menu tab. On the box that appears.     You will see a Market Watch updating with Real Time Quotes for Scripts included in the Ticker List. go to the “BACKFILL OPTIONS” section in the Market Watch.    Open the ShareGuru Realtime Application. To Backfill the data. After selecting the scripts . select one or more scripts from the Market Watch by pressing Control Key +Mouse or press Shift Key to select multiple scripts.

  The download process will take a while depending upon the number of scripts.THEN DATA OF ALL THE SCRIPTS IN THE OPENED MARKET WATCH WILL BE DOWNLOADED AND BACKILLED IN AMIBROKER/METASTOCK. NOTE : IF YOU DONT SELECT ANY TICKERS AND PRESS THE DOWNLOAD BUTTON . After downloading is complete. PIB Realtime . normal procedure to update charts can be followed.

right click on any symbol in your Market Watch and click on “Intraday Charting” and a chart of that particular symbol will appear and then again right click on this chart and click on “Synch” and keep this chart opened through out the trading hours. otherwise data from PIB will not be fetched.    Open ShareGuru Realtime Application. For smooth running of PIB data in AmiBroker/MetaStock.   Login to Power Indiabulls Terminal (PIB) and open your all Market Watches and keep them open all the time . Click On " PIB Realtime " option in menu tab. Example : C:\Program Files\Indiabulls Securities Limited\Power . you need to have an account with Indiabulls and an active Client Id. For the First time users . You have to select the full path. on the Dialogue Box that appears. click the Browse Button to select the Indiabulls Data Folder.Introduction To fetch data from Power Indiabulls Terminal .

In case of Metastock converted Data.select your charting software as AmiBroker or MetaStock and press the UPDATE CHARTS button to start updating your charting software with PIB Data . It will be placed under the Metastock Directory Specified under the” Settings” tab.  After setting up the Directory . ( See MetaStock Configuration) .Indiabulls\DH26357\Data where“DH26357” is a folder in the name of your PIB login User Id.

In the screen above you will see the scripts of list present in the Market Watch List of PIB and their latest updated prices. . the updation procedure is automatic.

as shown in the picture below: . BSE. Once you have ODIN setup on your computer along with the access rights.ODIN Realtime 1. you will need to open one with a broker who can provide any such service. make your own Market Watch of the tickers you need. MCX & NCDEX). happens automatically.Real Time Intraday Live Data is downloaded by ODIN from the various exchanges country wide (NSE .To start this. we first need to understand how the data will flow from ODIN.CASH & FO. 2. All this once started. so that you can concentrate and work meaningfully & fruitfully on your own charts. This data once downloaded can be sent directly to your Technical Analysis Software (AmiBroker or MetaStock) using ShareGuru Realtime software. If you do not have an ODIN account.

the data starts to flow and the graph can be closed. You can do this process before starts of the Market also. Your ODIN is now set up and we can now progress to move the data onto AmiBroker & MetaStock. You will need to open the graphs for all the tickers you want to import. 4.This will open the chart / graph of that ticker.3.To start continuous data flow. you will need to right click on each ticker which you want to import and select 'Graph It'. . After opening these graphs once.


Once selected. it will always show the same software. . the next time you run it.5.Once the ODIN Data Extractor starts. 6.ODIN Data Extractor can be started by clicking ODIN Realtime tab in ShareGuru Realtime software. please select the Technical Analysis software to which you want to import the data.


where the data from ODIN is landing. you will need to select the Data Source Folder. . The default folder for this is generally C:\ODIN\DIET\Data for ODIN below version 9 and C:\ODIN\DIET\ChartData for ODIN above version 9.To begin with.7.


it will save all changes and it will not again prompt you for the same ticker. 10. you will see the tickers which are there in this folder.8. After you have entered an Alias Name. till your ODIN is kept running in the background. 9. . These are the same tickers for which you selected 'Graph It/Intraday Chart' in your ODIN.Now click on Update Charts and see the data from your folder flow to the charts and continue flowing Live thereon. The Alias Name window will prompt you once only and when you will close this window after filling the Alias Name.You can fill the 'Alias Name' column in prompt window and change the name of the ticker which is finally imported to your Technical Analysis Software.Having selected the data folder. you will be able to see the chart of the Alias Name and not the ticker.

you can only plot charts as Backfill Data is available with this version in real time. NOTE:.You can modify/delete any ticker Alias Name by going to Tools>Alias Names Organizer.You can update Real Time charts in AmiBroker or MetaStock from ODIN below version 9 but there is no option of Backfill Data however with ODIN version above 9. .11.

.  Click On " EOD Download " option in menu tab.  Open ShareGuru Realtime Application.  Provide the Date Range for which you want to download data.EOD Download INTRODUCTION EOD Data for NSE-Scripts. Indices/ Scriptwise Data : Indices/Scriptwise EOD Data (NSE ONLY) can also be downloaded through ShareGuru Realtime software.  One .  Select The Charting Software you are using. NSE-Options. NSE-Futures.  Two Separate Sections are provided.Contains the list of NSE Indices. NSE-Indices & BSEScripts can also be downloaded through ShareGuru Realtime software.

Bhav Copy Data:  Daily Bhav Copy of NSE & BSE can also be downloaded with the help of ShareGuru Realtime software  Click on " Bhav Copy " tab.  Check Mark all the things that you want to download and press the Download Button. Provide the Date Range for which you want to download data. . Check Mark all the things that you want to download and press the Download Button.    Select the Charting Software you are using. the downloaded data will be fetched automatically into the charting softwares.List of all the Scripts on NSE. After Download is complete. Two .

provide a name to the list in the Text Provided and press "Create Ticker List" To add scripts to the newly created list . In the menu options select " Tickers Organizer " On the Dialogue Box that appears select the "Tickers" tab. The Charting Software will be automatically updated and the data will be placed according to the Directory Settings of the user (done in the “Settings” tab). Steps to Create User Defined Yahoo Ticker Lists are :      Log In to the ShareGuru Realtime Application. Tickers Organizer User defined Yahoo Ticker Lists can also be created for use With ShareGuru Realtime Yahoo Import Module. write Yahoo symbol in symbol column at the bottom and its name and press “Save” tab. To Create a new Ticker List. Example: .



yahoo. In the menu options select " Tickers Organizer " On the Dialogue Box that appears. you can add/modify/delete tickers to the list. To add a new symbol to the list write yahoo symbol in the symbol column at bottom and its name and press “Save” tab and the new symbol will be added in the opened ticker list. NOTE : If you have added a Yahoo symbol in the list but no data is coming in the Market Watch. . select the "Global Tickers" tab.com Updating Components for Yahoo Global Tickers List The components of various International Markets can be updated at the click of a button in ShareGuru Realtime software. you can verify your symbol name from finance.   Once the New Ticker List is created or already existing Ticker List is selected . Steps to Update Components:    Log In to the ShareGuru Realtime Application.

Example: Online Support For any type of query or help.in . you may click on Live Help tab on our homepage during 10.00PM on any working day and your problem/query will be solved online or you may send us email at support@shareguru.00AM to 5. Select Country/Market for which you want to update components and press the "DOWNLOAD SELECTED TICKERS" button.

You're Reading a Free Preview

/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->